Subject: [lmap] information-model: ma-task-capability-obj vs. elements in ma-task-obj

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 24 Sep 2014 16:09:57 +0000

I see that information-model has objects of:

   object {
       string              ma-task-name;
       uri                 ma-task-registry;
       string              ma-task-role;
   } ma-task-capability-obj;

object {
    string              ma-task-name;
    uri                 ma-task-registry-entry;
    string              ma-role;
    name-value-pair     ma-task-options<0..*>;
   [boolean             ma-task-suppress-by-default;] // default: TRUE
   [string              ma-task-cycle-id;]
} ma-task-obj;

Where the ma-task-capability-obj items can be reported up to the Controller as capabilities, and the ma-task-obj items are what get configured.
I see no correlation between ma-task-capability-obj nor to any of the elements of ma-task-obj (other than certain elements having similar names), and no ability to create such a correlation. Furthermore, ma-task-obj has 3 elements that appear almost identical to the elements of ma-task-capability-obj.

Why doesn't ma-task-obj just have an element of type ma-task-capability-obj instead of ma-task-name, ma-task-registry-entry, and ma-role?
Wouldn't this provide for precise correlation between the reported capabilities and the specific capability being configured through this ma-task-obj?
Barbara

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 25 Sep 2014 08:40:06 +0200

> Wouldn't this provide for precise correlation between the reported capabilities and the specific capability being configured through this ma-task-obj?

For me, this would not change anything. Note that the 'name'
properties have actually different scopes since I can have multiple
ma-task-obj's configured for a single ma-task-capability-obj.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: <[email-masked]>
Date: Thu, 25 Sep 2014 08:59:09 +0100

The intention was that the capability object would simply say something about the task/role that was installed on the MA. The task configuration object would then have the configuration of various parameters. It would be possible (and perhaps sensible) to link from the task configuration to the task capability (which is what you suggest).

Trevor.

>-----Original Message-----
>From: lmap [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
>Sent: 24 September 2014 17:10
>To: [email-masked]
>Subject: [lmap] information-model: ma-task-capability-obj vs. elements in ma-
>task-obj
>
>Where the ma-task-capability-obj items can be reported up to the Controller as
>capabilities, and the ma-task-obj items are what get configured.
>I see no correlation between ma-task-capability-obj nor to any of the elements of
>ma-task-obj (other than certain elements having similar names), and no ability to
>create such a correlation. Furthermore, ma-task-obj has 3 elements that appear
>almost identical to the elements of ma-task-capability-obj.
>
>Why doesn't ma-task-obj just have an element of type ma-task-capability-obj
>instead of ma-task-name, ma-task-registry-entry, and ma-role?
>Wouldn't this provide for precise correlation between the reported capabilities
>and the specific capability being configured through this ma-task-obj?
>Barbara
>
>_______________________________________________
>lmap mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lmap