Subject: [lmap] protocol selection: Rest Style Large MeAsurement Platform Protocol

From: "Vic Liu(CMCC)" <[email-masked]>
Date: Tue, 24 Mar 2015 17:36:44 +0800

Hi All

We are the author of Draft-liu-lmap-rest-02. Here is our reply to the
Citeria. Any comment and discussion of the draft is big welcome. Thank you!

Control Protocol Criteria
Mandatory Criteria
[CP-MUST-1]--[Draft-liu-lmap-rest-02]--section 4.1
[CP-MUST-2]-- [Draft-liu-lmap-rest-02]--section 5.1
[CP-MUST-3] the credential employed for authentication by HTTPS. 
[CP-MUST-4] we use JSON which can be extended by adding more information
mode. (hoping this can be adding in information mode draft as well)

Comparative Criteria
[CP-DIFF-1] 1 
[CP-DIFF-2] 1 
[CP-DIFF-3] Yes
[CP-DIFF-4] JSON and REST over HTTPs
[CP-DIFF-5] Header contain about 100bytes(host\content type\accept)
[CP-DIFF-6] Header contain about 100bytes(host\content type\accept)
[CP-DIFF-7] Rest widely used. Meantime, Chinacache has been used it as a
trial.
[CP-DIFF-8]Test tools for JSON. More is under developed.
[CP-DIFF-9] yes on Github
[CP-DIFF-10] JSON and HTTPs, also we developed open source program.
[CP-DIFF-11] yes
[CP-DIFF-12] yes
[CP-DIFF-13] JSON

Report Protocol Criteria
Mandatory Criteria
[RP-MUST-1] [Draft-liu-lmap-rest-02]--section 5.1
[RP-MUST-2] the credential employed for authentication by HTTPS.
[RP-MUST-3] we use JSON which can be extended.(hoping this can be adding in
information mode draft as well)

Comparative Criteria
[RP-DIFF-1] TCP
[RP-DIFF-2] Yes
[RP-DIFF-3] 1
[RP-DIFF-4] Yes
[RP-DIFF-5] Yes
[RP-DIFF-6] Yes 
[RP-DIFF-7] about 100 bytes
[RP-DIFF-8] REST is used widely
[RP-DIFF-9] Test tools for JSON, certification program
[RP-DIFF-10] Yes
[RP-DIFF-11] JSON and HTTPs, also we developed open source program.
[RP-DIFF-12] JSON

ALL THE BEST!
----------------------------------------------------------------------------
-----------------
刘志恒 Vic Liu
中国移动通信研究院 网络技术研究所
China Mobile Research Network Dept.
Mobile: +86- 13810761678
Email: [email-masked]
----------------------------------------------------------------------------
-----------------
「梦は逃げない、逃げるのはいつも自分だ」

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 24 Mar 2015 15:53:00 +0000

Thanks. 

Comments? Questions? 

We will discuss these also in the meeting tomorrow. 

Regards,

Dan

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Vic Liu(CMCC)
> Sent: Tuesday, March 24, 2015 11:37 AM
> To: [email-masked]
> Cc: [email-masked]; 'Liu, Shu'; 'duanshihui'
> Subject: [lmap] protocol selection: Rest Style Large MeAsurement Platform
> Protocol
> 
> Hi All
> 
> We are the author of Draft-liu-lmap-rest-02. Here is our reply to the Citeria.
> Any comment and discussion of the draft is big welcome. Thank you!
> 
> [CP-MUST-2]-- [Draft-liu-lmap-rest-02]--section 5.1 [CP-MUST-3] the
> credential employed for authentication by HTTPS.
> [CP-MUST-4] we use JSON which can be extended by adding more
> information mode. (hoping this can be adding in information mode draft as
> well)
> 
> Comparative Criteria
> [CP-DIFF-1] 1
> [CP-DIFF-2] 1
> [CP-DIFF-3] Yes
> [CP-DIFF-5] Header contain about 100bytes(host\content type\accept) [CP-
> DIFF-6] Header contain about 100bytes(host\content type\accept) [CP-DIFF-
> 7] Rest widely used. Meantime, Chinacache has been used it as a trial.
> [RP-MUST-1] [Draft-liu-lmap-rest-02]--section 5.1 [RP-MUST-2] the
> credential employed for authentication by HTTPS.
> [RP-MUST-3] we use JSON which can be extended.(hoping this can be adding
> in information mode draft as well)
> 
> Comparative Criteria
> [RP-DIFF-1] TCP
> [RP-DIFF-2] Yes
> [RP-DIFF-3] 1
> [RP-DIFF-4] Yes
> [RP-DIFF-5] Yes
> [RP-DIFF-6] Yes
> [RP-DIFF-9] Test tools for JSON, certification program [RP-DIFF-10] Yes [RP-
> DIFF-11] JSON and HTTPs, also we developed open source program.
> [RP-DIFF-12] JSON
> 
> 
> ALL THE BEST!
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_lmap&d=AwIGoQ&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=UhxHaj
> 0zZTvqAPO2jkl4QVIE3OjNqRq6kE-
> wPugYxeE&s=5MUAsTIQuuIWSJzy7CbNK3qtIlsisurql7Y8VMHIgLw&e=