Subject: [lmap] using RESTCONF within LMAP

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Mar 2015 16:52:15 +0100

Hi,

I have done my homework to produce an I-D that describes how a YANG
data model maps to bits on the wire using RESTCONF. We tried to keep
things concise - if more explanation is needed, let us know.

http://tools.ietf.org/html/draft-schoenw-lmap-restconf-00

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 26 Mar 2015 15:58:33 +0000

Thanks, Juergen. 

All WG participants - please read, comment, ask questions!

Regards,

Dan

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Thursday, March 26, 2015 5:52 PM
> To: [email-masked]
> Subject: [lmap] using RESTCONF within LMAP
> 
> Hi,
> 
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__tools.ietf.org_html_draft-2Dschoenw-2Dlmap-2Drestconf-
> 2D00&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvls
> iLQfucBXRucPvdrphpBsFA&m=7zMEj7GrJgaN35aPBn5I-
> cjet2iNX8fRN5nE6n3pkaY&s=KNtctWlTMb3XjTvViARZ3g7mWnyT2EKAEtIVo2
> StsHg&e=
> 
> /js
> 
> --
> Fax:   +49 421 200 3103
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-
> 2Duniversity.de_&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31O
> cNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=7zMEj7GrJgaN35aPBn5I-
> cjet2iNX8fRN5nE6n3pkaY&s=O3wA5mLX9LXhLoo0eaHWwiuB2jQ8Gg0nBuC8
> nPKoM6c&e= >
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_lmap&d=AwICAg&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=7zMEj7
> GrJgaN35aPBn5I-
> cjet2iNX8fRN5nE6n3pkaY&s=ophUOCY2Ww4ZwrVKhylfYJ7nPNykVRncQ9tZV
> VGNjbM&e=

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 26 Mar 2015 20:05:11 +0000

Juergen,

I did have a question on the communication of a MA to a Data Collector.

The communication is based on schedules for a particular scheduled task that executed a task. Is all these multiple schedules - each for specific results from a scheduled task work within the call home mechanism. Can a MA call home to multiple servers?

BR,
Tim

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, March 26, 2015 4:59 PM
To: Juergen Schoenwaelder; [email-masked]
Subject: Re: [lmap] using RESTCONF within LMAP

Thanks, Juergen. 

Regards,

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Mar 2015 23:35:28 +0100

On Thu, Mar 26, 2015 at 08:05:11PM +0000, Carey, Timothy (Timothy) wrote:
> The communication is based on schedules for a particular scheduled task that executed a task. Is all these multiple schedules - each for specific results from a scheduled task work within the call home mechanism.
>

For reports, I assume the reporting task calls home whenever needed.

>  Can a MA call home to multiple servers?

Yes. You can have multiple 'servers' and for each one you can have
multiple endpoints (so you can fail over to backup 'servers').

/js