Subject: [lp-wan] draft-toutain-lpwan-coap-traffic-00.txt

From: Ana Minaburo <[email-masked]>
Date: Thu, 12 Jan 2017 14:48:01 +0100

Dear LPWANers,

In order to finish the CoAP compression, we decide to go forward by describing some scenarios which describes the possible traffic in the LPWAN networks, we also give the possible SCHC compression in the different cases, please read the draft and tell us if you are confortable with this solutions, if you find there are some scenarios missing or anything that is not clear, please let us known

Thanks

Ana and Laurent

> On 12 Jan 2017, at 14:43, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-toutain-lpwan-coap-traffic-00.txt
> has been successfully submitted by Ana Minaburo and posted to the
> IETF repository.
> 
> Name:		draft-toutain-lpwan-coap-traffic
> Revision:	00
> Title:		CoAP Traffic
> Document date:	2017-01-12
> Group:		Individual Submission
> Pages:		12
> URL:            https://www.ietf.org/internet-drafts/draft-toutain-lpwan-coap-traffic-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-toutain-lpwan-coap-traffic/
> Htmlized:       https://tools.ietf.org/html/draft-toutain-lpwan-coap-traffic-00
> 
> 
> Abstract:
>   This document describes different CoAP scenarios for the SCHC
>   compression.  It goes from the simplest exchange without
>   acknowledgments to a basic study of the CoMI traffic.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 18 Jan 2017 03:33:35 +0000

Hi Ana, Laurent,

Thanks for starting to put this informative doc together!

It has been mentioned in the past that rules can be combined, allowing for compression of more than one layer with a single rule (e.g. IP/UDP/CoAP/...). 

Would you expect this behaviour to be documented in a separate document like this one, or are you planning to include it as part of the main documents (e.g. draft-ietf-lpwan-coap-static-context-hc)? - I personally would have a tendency to document it in the higher layer to avoid confusion and allow for better interoperability, but I'd like to know your views.

Also, there are a few nits and typos in this document, like the figure legends, etc. but since this is the 00 version I'm sure most will be easily solved in the upcoming versions.

Best,

Juan Carlos 

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Ana Minaburo
> Sent: January 12, 2017 8:48 AM
> To: lp-wan <[email-masked]>
> Subject: [lp-wan] draft-toutain-lpwan-coap-traffic-00.txt
> 
> Dear LPWANers,
> 
> In order to finish the CoAP compression, we decide to go forward by
> describing some scenarios which describes the possible traffic in the LPWAN
> networks, we also give the possible SCHC compression in the different cases,
> please read the draft and tell us if you are confortable with this solutions, if
> you find there are some scenarios missing or anything that is not clear,
> please let us known
> 
> Thanks
> 
> Ana and Laurent
> 
> 
> > has been successfully submitted by Ana Minaburo and posted to the IETF
> > repository.
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Laurent Toutain <[email-masked]>
Date: Thu, 19 Jan 2017 10:20:20 +0100

Hi

Thanks for your comments.

You are right, there will be two documents, the IPv6/UDP compression will
define the basic rules for SCHC and another document will specify CoAP
compression based on architecture proposed on the first one.

For implementation, they can be done independently, but for LPWAN  a single
rule ID can cover both IPv6/UDP and CoAP compressions.

Laurent

On Wed, Jan 18, 2017 at 4:33 AM, Juan Carlos Zuniga <
[email-masked]> wrote:

> It has been mentioned in the past that rules can be combined, allowing for
> compression of more than one layer with a single rule (e.g.
> IP/UDP/CoAP/...).
>
> Would you expect this behaviour to be documented in a separate document
> like this one, or are you planning to include it as part of the main
> documents (e.g. draft-ietf-lpwan-coap-static-context-hc)? - I personally
> would have a tendency to document it in the higher layer to avoid confusion
> and allow for better interoperability, but I'd like to know your views.
>
> Also, there are a few nits and typos in this document, like the figure
> legends, etc. but since this is the 00 version I'm sure most will be easily
> solved in the upcoming versions.
>
> Best,
>
> Juan Carlos
>
> > > URL:            https://www.ietf.org/internet-
> drafts/draft-toutain-lpwan-coap-
> > traffic-00.txt
> > > Status:         https://datatracker.ietf.org/
> doc/draft-toutain-lpwan-coap-
> > traffic/
> > > Htmlized:       https://tools.ietf.org/html/draft-toutain-lpwan-coap-
> traffic-
> > 00
> > >
> > >
> > > Abstract:

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+