Subject: [lp-wan] Reordering?

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 8 Feb 2017 23:31:21 +0100

Dear LPWANners,

In order to design the mechanism for fragmentation (of IPv6 packets) over
LPWAN technologies, we need to know whether reordering of L2 data units
can happen between the entity performing fragmentation and the one
performing reassembly.

Given the star topology that is typical of Sigfox and LoRaWAN (i.e. the
technologies considered in the WG that need fragmentation functionality),
an unconfirmed assumption has often been that reordering will not happen.
However, is this true?

That is: can reordering happen in Sigfox and LoRaWAN? If yes, to what extent?

Thanks in advance,

Carles

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Mon, 20 Feb 2017 01:47:26 +0000

Hello Carles,

You are right: due to the star topology and also to the infrequent number of messages (compared to other Internet technologies), we do not foresee having misordering issues.
However, it would be important to make sure that a single fragment loss would not cause a full packet retransmission.

I hope this helps.

Best,

Juan Carlos

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Carles Gomez
> Montenegro
> Sent: February 8, 2017 5:31 PM
> To: [email-masked]
> Subject: [lp-wan] Reordering?
> 
> Dear LPWANners,
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 20 Feb 2017 07:10:01 +0100

Hello Juan Carlos,

> Hello Carles,
>
> You are right: due to the star topology and also to the infrequent number
> of messages (compared to other Internet technologies), we do not foresee
> having misordering issues.

Thanks a lot for this valuable feedback.

> However, it would be important to make sure that a single fragment loss
> would not cause a full packet retransmission.

We plan to publish the draft containing both the mechanisms for IP/UDP
header compression and also for fragmentation very soon.

For the latter, we currently consider at least two main fragment delivery
options: i) one without LPWAN-level reliability (i.e. no LPWAN-level
acknowledgments and no fragment retransmission) and ii) another one with
reliability.

For reliable fragment delivery, we are defining use of selective
acknowledgments, therefore single-fragment (and most likely combinations
of multiple-fragment) losses will only trigger retransmissions of those
fragments that have been lost.

> I hope this helps.

It does help!

Cheers,

Carles

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 22 Feb 2017 00:14:34 +0000

Hello Carles,

> From: Carles Gomez Montenegro [mailto:[email-masked]]
> Sent: February 20, 2017 7:10 AM
> To: Juan Carlos Zuniga <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [lp-wan] Reordering?
> 
> Hello Juan Carlos,
> 
> > Hello Carles,
> >
> > You are right: due to the star topology and also to the infrequent
> > number of messages (compared to other Internet technologies), we do
> > not foresee having misordering issues.
> 
> > However, it would be important to make sure that a single fragment
> > loss would not cause a full packet retransmission.
> 

Excellent! This all sounds very encouraging. 
I look forward to reading the drafts.

Best,

Juan Carlos