Subject: [lp-wan] Question on LoRaWAN and SCHC decompression architecture (Figure 1)

From: <[email-masked]>
Date: Mon, 15 May 2017 09:13:16 +0000

Hi,

The LoRaWAN protocol is designed to encrypt LoRaWAN MAC payload between the Device and the Application Server (End to End confidentiality).
And the NGW and the Application Server are connected through HTTPS link .

How do you see for LoRaWAN a SCHC Decompression function running in between of NGW and Application Server ?
It should not be possible, except to host this function in the Application Server.

Thanks

Philippe

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 15 May 2017 14:58:32 +0200

Hi Philippe,

The location of the SCHC Compressor/Decompressor is not imposed by the
draft, it can be either in a Network Gateway (if the key is known) or in
the Application Server. IPv6/UDP/CoAP can be compressed within a single
rule or a rule for IPv6/UDP can be set and another one for CoAP. In that
case, IPv6/UDP headers can be compressed between the Device and the Network
Gateway and the CoAP between the Device and the Application.

Laurent

On Mon, May 15, 2017 at 11:13 AM, <[email-masked]> wrote:

> Hi,
>
>
>
> The LoRaWAN protocol is designed to encrypt LoRaWAN MAC payload between
> the Device and the Application Server (End to End confidentiality).
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

---

From: Laurent Toutain <[email-masked]>
Date: Wed, 31 May 2017 09:39:08 +0200

Hi Gengyu,

Compression is an equivalence between 2 formats, one standard and generic
and another one adapted to a specific environment. It is not a protocol. If
you receive something encrypted and you don't know how to decipher it then
you cannot uncompress the header.

The  draft gives the architecture of the compression service.

        DEVICE                                            Appl Servers
   +---------------+                                  +---------------+
   | APP1 APP2 APP3|                                  |APP1  APP2 APP3|
   |               |                                  |               |
   |       UDP     |                                  |      UDP      |
   |      IPv6     |                                  |     IPv6      |
   |               |                                  |               |
   |    SCHC C/D   |                                  |               |
   |    (context)  |                                  |               |
   +--------+------+                                  +-------+-------+
            |   +--+     +----+     +---------+               .
            +~~ |RG| === |NGW | === |SCHC C/D |... Internet ...
                +--+     +----+     |(context)|
                                    +---------+

                          Figure 1: Architecture

SCHC C/D is between the  NGW and the Application. If encryption goes up to
the application then the SCHC C/C must be installed here.

Laurent

On Wed, May 31, 2017 at 4:57 AM, weigengyu <[email-masked]> wrote:

> Hi,
>
> There is not any security considerations in IPv6/UDP/CoAP.
> If as Philippe mentioned “The LoRaWAN protocol is designed to encrypt
> LoRaWAN MAC payload between the Device and the Application Server (End to
> End confidentiality)”
> the SCHC Compressor/Decompressor relys on the MAC layer security, or not?
>
> Regards,
>
> Gengyu WEI
> Network Technology Center
> School of Computer
> Beijing University of Posts and Telecommunications
>
> *From:* Laurent Toutain <[email-masked]>
> *Sent:* Monday, May 15, 2017 8:58 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [lp-wan] Question on LoRaWAN and SCHC decompression
> architecture (Figure 1)
>
> Hi Philippe,
>
> ------------------------------