Subject: [lp-wan] Terminology for LPWAN Networks

From: Ana Minaburo <[email-masked]>
Date: Wed, 3 May 2017 23:29:09 +0200

Hello,

I have started doing a list for the most important terms we use on the SCHC drafts, first I put all the names we have used to define the same concept, second I put the name we have defined in the drafts, and last I put one proposition, please feel free to agree or not about this proposed terms.

Thanks
Ana

   Used on draft                     				        draft-overview or and draft-SCHC		   Proposed		          
 End-System, device, Thing , Host, node                   Host or Thing				         THING (THG) 
LPWAN Application Server,  Application  Server        Application Server                                Application (APP)
Network Gateway                                                       Router or Network Gateway                  LPWAN Gateway  (LGW)                
LPWAN C/D (LC)							    LC (LPWAN Compressor)                    SCHC C/D                                Compression/Decompression Function (CDF)          CDF C/D Function	                        C/D Action (CDA)

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 4 May 2017 00:13:15 +0000

Hi Ana,

>From the review I have started on draft-SCHC, I think the proposed terms would add a lot of clarity to the explanations. Using more intuitive acronyms would be very helpful, especially to external readers.

I support using the Proposed list of terms throughout all drafts.

Best,

Juan Carlos

From: lp-wan [mailto:[email-masked]] On Behalf Of Ana Minaburo
Sent: May 3, 2017 5:29 PM
To: lp-wan <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; Alexander Pelov <[email-masked]>
Subject: [lp-wan] Terminology for LPWAN Networks

Hello,

Thanks
Ana

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 3 May 2017 17:29:59 -0700

Hello Ana,

I am O.K. with all of the terms except "thing".  It seems to me that 
particular term is irretrievably ambiguous, and does not offer any 
helpful intuition about the intended meaning.  The result would be that 
it would be harder to write unambiguous specifications, and suddenly 
other words like "anything" and "something" would become dangerous.  I 
would be happy with any of the other terms.  I have often used "device" 
for this meaning.

Regards,
Charlie P.

On 5/3/2017 2:29 PM, Ana Minaburo wrote:
> Hello,
>
> I have started doing a list for the most important terms we use on the 
> SCHC drafts, first I put all the names we have used to define the same 
> concept, second I put the name we have defined in the drafts, and last 
> I put one proposition, please feel free to agree or not about this 
> proposed terms.
>
> Thanks
> Ana
>
>
>  End-System, device, Thing , Host, node       Host or ThingTHING (THG)
> LPWAN C/D (LC)  LC (LPWAN Compressor)  SCHC C/D   
>  Compression/Decompression Function (CDF)          CDF C/D FunctionC/D 
> Action (CDA)
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Pat Kinney <[email-masked]>
Date: Thu, 4 May 2017 07:43:33 -0500

I agree with Charlie, his rationale is solid.  In addition to the terms written below I have also seen Back-end used.

Best Regards, 
Pat Kinney

On 3, May2017, at 19:29, Charlie Perkins <[email-masked]> wrote:

Hello Ana,

I am O.K. with all of the terms except "thing".  It seems to me that particular term is irretrievably ambiguous, and does not offer any helpful intuition about the intended meaning.  The result would be that it would be harder to write unambiguous specifications, and suddenly other words like "anything" and "something" would become dangerous.  I would be happy with any of the other terms.  I have often used "device" for this meaning.

Regards,
Charlie P.

On 5/3/2017 2:29 PM, Ana Minaburo wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

Pat Kinney
[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 4 May 2017 13:02:28 +0000

Same as Charlie, I agree but for 'thing'. I klike the idea to change it to device, which is how it's called in a number of venues I participate(d) to.

Take care,

Pascal

From: Charlie Perkins [mailto:[email-masked]]
Sent: jeudi 4 mai 2017 02:30
To: Ana Minaburo <[email-masked]>; lp-wan <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; Alexander Pelov <[email-masked]>
Subject: Re: [lp-wan] Terminology for LPWAN Networks

Hello Ana,

Regards,
Charlie P.

Thanks
Ana

lp-wan mailing list

[email-masked]<mailto:[email-masked]>

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 4 May 2017 16:41:39 +0200

+1. 

I still find it difficult to use "Thing" on daily basis, and generally tend to fall back to host, end-device or simply device.

So, I’d go with what Charlie and Pascal said. Device is OK for me.

Alex

> Le 4 mai 2017 à 15:02, Pascal Thubert (pthubert) <[email-masked]> a écrit :
> 
> Same as Charlie, I agree but for ‘thing’. I klike the idea to change it to device, which is how it’s called in a number of venues I participate(d) to.
>  
> Take care,
>  
> Pascal
>  
> From: Charlie Perkins [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Ana Minaburo <[email-masked] <mailto:[email-masked]>>; lp-wan <[email-masked] <mailto:[email-masked]>>
> Cc: Pascal Thubert (pthubert) <[email-masked] <mailto:[email-masked]>>; Alexander Pelov <[email-masked] <mailto:[email-masked]>>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 4 May 2017 11:54:51 -0300

+1 on Device.
Regards,

                     Diego

2017-05-04 11:41 GMT-03:00 Alexander Pelov <[email-masked]>:

> +1.
>
> I still find it difficult to use "Thing" on daily basis, and generally
> tend to fall back to host, end-device or simply device.
>
> Same as Charlie, I agree but for ‘thing’. I klike the idea to change it to
> device, which is how it’s called in a number of venues I participate(d) to.
>
> Take care,
>
> Pascal
>
> *From:* Charlie Perkins [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* jeudi 4 mai 2017 02:30
> *To:* Ana Minaburo <[email-masked]>; lp-wan <[email-masked]>
> *Cc:* Pascal Thubert (pthubert) <[email-masked]>; Alexander Pelov <
> [email-masked]>
> *Subject:* Re: [lp-wan] Terminology for LPWAN Networks
>
>
> Hello Ana,
>
> particular term is irretrievably ambiguous, and does not offer any helpful
> intuition about the intended meaning.  The result would be that it would be
> harder to write unambiguous specifications, and suddenly other words like
> "anything" and "something" would become dangerous.  I would be happy with
> any of the other terms.  I have often used "device" for this meaning.
>
> Regards,
> Charlie P.
>
> concept, second I put the name we have defined in the drafts, and last I
> put one proposition, please feel free to agree or not about this proposed
> terms.
>
> Thanks
> Ana
>
>
>    Used on draft
>                     draft-overview or and draft-SCHC
>  Proposed
> Network Gateway
> Router or Network Gateway                  LPWAN Gateway  (LGW)
>
> LPWAN C/D (LC)
>                                         LC (LPWAN Compressor)
>        SCHC C/D                                Compression/Decompression
> Function (CDF)          CDF C/D Function
>   C/D Action (CDA)
>
>
>
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Ivan Di Giusto <[email-masked]>
Date: Fri, 5 May 2017 20:11:57 +1000

Hi All,

Couple of comments:

   - I support the choice of DEVICE
   - I would recommend using APPLICATION SERVER instead of APPLICATION.
   APPLICATION is what runs on the DEVICE, while APPLICATION SERVER is what
   receives data from the DEVICE through the network.
   - I see discussion of the LPWAN Gateway when talking about the network.
   In most LPWAN implementations, Gateway is a dumb radio and the smarts are
   in the Network Server.  It is really the Network Server that is the
   network.  I am not sure if it helps or hinders to introduce the concept of
   the Network Server in this document.

Regards,
Ivan

On 5 May 2017 at 00:54, Prof. Diego Dujovne <[email-masked]>
wrote:

>> Same as Charlie, I agree but for ‘thing’. I klike the idea to change it
>> to device, which is how it’s called in a number of venues I participate(d)
>> to.
>>
>> Take care,
>>
>> Pascal
>>
>>          SCHC C/D
>>  Compression/Decompression Function (CDF)          CDF C/D Function
>>                                     C/D Action (CDA)
>>
>>
>>
>>

---

From: Julien Catalano <[email-masked]>
Date: Fri, 5 May 2017 18:13:38 +0200

Hello all,

I tend to prefer using "END-DEVICE" or "ENDPOINT" instead of DEVICE,
which looks too generic and ambiguous to me.
A gateway or a router can also be called "devices" (as in "electronic
devices" or "network devices").

My (first!) 2 cents.
Julien

On 04/05/2017 16:41, Alexander Pelov wrote:
>> Le 4 mai 2017 à 15:02, Pascal Thubert (pthubert) <[email-masked]
>> <mailto:[email-masked]>> a écrit :
>>
>> Same as Charlie, I agree but for ‘thing’. I klike the idea to change
>> it to device, which is how it’s called in a number of venues I
>> participate(d) to.
>>  
>> Take care,
>>  
>> Pascal
>>  
>> *From:* Charlie Perkins [mailto:[email-masked]] 
>> *To:* Ana Minaburo <[email-masked] <mailto:[email-masked]>>; lp-wan
>> <[email-masked] <mailto:[email-masked]>>
>> *Cc:* Pascal Thubert (pthubert) <[email-masked]
>> <mailto:[email-masked]>>; Alexander Pelov <[email-masked]
>> <mailto:[email-masked]>>
>> helpful intuition about the intended meaning.  The result would be
>> that it would be harder to write unambiguous specifications, and
>> suddenly other words like "anything" and "something" would become
>> dangerous.  I would be happy with any of the other terms.  I have
>> often used "device" for this meaning.
>>
>> Regards,
>> Charlie P.
>>
>>  
>>     I have started doing a list for the most important terms we use
>>     on the SCHC drafts, first I put all the names we have used to
>>     define the same concept, second I put the name we have defined in
>>     the drafts, and last I put one proposition, please feel free to
>>     agree or not about this proposed terms.
>>      
>>     Thanks
>>     Ana
>>      
>>      
>>        Used on draft                           
>>                                                 draft-overview or and
>>     draft-SCHC                 Proposed                                  
>>      Compression/Decompression Function (CDF)          CDF C/D
>>     Function                                    C/D Action (CDA) 
>>      
>>
>>
>>

---

From: <[email-masked]>
Date: Sat, 6 May 2017 08:42:02 +0000

Hello all,

END-DEVICE sounds good to me.
It also resonates with ES (End System) that is sometime used to designate
the thing/host/device.

Dominique

Le 05/05/17 18:13, « lp-wan on behalf of Julien Catalano »
<[email-masked] on behalf of [email-masked]> a écrit :

>> So, I¹d go with what Charlie and Pascal said. Device is OK for me.
>>
>> Alex
>>
>>
>>
>>> Same as Charlie, I agree but for Œthing¹. I klike the idea to change
>>> it to device, which is how it¹s called in a number of venues I
>>> participate(d) to.
>>>  
>>> Take care,
>>>  
>>> Pascal
>>>  

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sat, 6 May 2017 12:19:28 +0200

+1

'End device' is more specific than 'device'.

Cheers,

Carles