Subject: [lp-wan] ACK in packet mode

From: Ana Minaburo <[email-masked]>
Date: Wed, 17 May 2017 09:59:42 +0200

Hello,

After analysing the discussion during the last meeting, We need to fix the problem regarding acknowledgement on packet mode

When we send ack at the end of all fragments transmission, we got the problem of the bitmap size in the downlink. I will take an average size of 10 bytes (LoraWan, SF0) it is less for some technologies but it could be useful for explanation. We got 128 fragments so we need 128 bits in a packet of 10 bytes, so we need two downlink packets to ack all the fragments. So I think Pascal added, we can only send the number of the corrupted fragments, why not, but until how many corrupted fragments this solution is better than the bitmap? 
Taking 10 bytes less Rule-ID size 3bits,  To represent 128 fragments I need 7 bits per fragment, so I put Rule-ID in 3 bits to get 11 fragment in one ack, if not it is 10 lost  fragments I can have.
So in the best case I can only have 11 lost fragments in this solution, so if there are more than 11 lost fragments then we use bitmap and then we need to 2 ack. Well, We need to define something else that can cover all the fragments in one downlink packet

Ana

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 17 May 2017 10:23:13 +0200

Hi Ana,

I have been preparing some emails I'll sent right now, and one of them is
exactly on this same topic. Thanks for bringing this up, and please see my
comments there.

Cheers,

Carles

> Hello,
>
>
> After analysing the discussion during the last meeting, We need to fix the
> problem regarding acknowledgement on packet mode
>
> When we send ack at the end of all fragments transmission, we got the
> problem of the bitmap size in the downlink. I will take an average size of
> 10 bytes (LoraWan, SF0) it is less for some technologies but it could be
> useful for explanation. We got 128 fragments so we need 128 bits in a
> packet of 10 bytes, so we need two downlink packets to ack all the
> fragments. So I think Pascal added, we can only send the number of the
> corrupted fragments, why not, but until how many corrupted fragments this
> solution is better than the bitmap?
> Taking 10 bytes less Rule-ID size 3bits,  To represent 128 fragments I
> need 7 bits per fragment, so I put Rule-ID in 3 bits to get 11 fragment in
> one ack, if not it is 10 lost  fragments I can have.
> So in the best case I can only have 11 lost fragments in this solution, so
> if there are more than 11 lost fragments then we use bitmap and then we
> need to 2 ack. Well, We need to define something else that can cover all
> the fragments in one downlink packet
>
> Ana
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>