Subject: [lp-wan] Fragmentation: retries after L2 MTU decrease

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 3 May 2017 16:17:25 +0200

Hi everyone,

In some LPWAN technologies, the L2 MTU is variable. This means that the
following issue may arise for the "reliable" fragment delivery options we
are designing.

If a fragment needs to be retransmitted, but the L2 MTU has decreased
since the original transmission of the fragment (so that the original
fragment is larger than the current L2 MTU), how should the situation be
handled?

A few options may be:

1.- Abort the on-going transmission of the carried IPv6 datagram.

2.- Perform some form of re-fragmentation (not currently supported by the
    SCHC&F document, and potentially complex).

3.- Defer the decision on how to proceed to technology-specific profiles.

Would the WG have any preference among these (or other) options?

Thanks,

Carles

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 3 May 2017 16:43:46 +0200

>    SCHC&F document, and potentially complex).

As I said in the call:

— retransmissions are less likely than main line transmissions
— any bit spent in a retransmission format is therefore less expensive than in the main line transmission format
— let’s trade complexity for a few more (not so often exercised) bits here.

With this approach, a retransmission can break out of the mould that the original transmission created.

Grüße, Carsten

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 3 May 2017 15:19:04 +0000

I agree with Carsten. For LPWAN, simplicity is King.

If there is a smarter way to avoid/recuperate from this situation, it could eventually be described in the specific technology profile.

Cheers,

Juan Carlos 

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: May 3, 2017 10:44 AM
> To: Carles Gomez Montenegro <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [lp-wan] Fragmentation: retries after L2 MTU decrease
> 
> — retransmissions are less likely than main line transmissions — any bit spent
> in a retransmission format is therefore less expensive than in the main line
> transmission format — let’s trade complexity for a few more (not so often
> exercised) bits here.
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan