Subject: [lp-wan] overview issue#2: AAA server term...

From: Stephen Farrell <[email-masked]>
Date: Thu, 18 May 2017 08:41:34 +0100

Hiya,

(Crap: I mucked up the subject line by also calling this "issue#1"
when I first sent this, maybe that's why nobody responded - so
trying now with a correct subject line and with a suggested
resolution in case nobody else cares... :-)

In [1] we define the term "AAA server." I don't think that's a good
term to use, as it may be read to assume that we'll end up with a
RADIUS or Diameter based solution and a typical AAA server like that
is just not the same as a LoRaWAN NS/JS. (There might be a RADIUS or
Diameter server behind such a beast, but it's not the same thing.)
I think (less sure though) that the "AAA server" is also not so good
for the other technologies too.

What'd the WG like to do here?

If nobody answers, in the next revision I'll use the term "LPWAN
back-end server" ("LBES") instead of "AAA server." That's also not
great but at least doesn't have the potential to create new confusion.

Cheers,
S.

[1] https://tools.ietf.org/html/draft-ietf-lpwan-overview-02#section-3

---

From: Arun <[email-masked]>
Date: Thu, 18 May 2017 17:23:57 +0200

Hi Stephen,
There is a draft, draft-garcia-radext-radius-lorawan, that explains the
use of AAA server in lpwa technologies like lora.
The idea is to use standardized solutions like AAA for authenticating
end devices in such technologies.
IMHO, AAA term in a way is good to push for the use of standard entities
in the architecture.

regards,
Arun

On 18/05/2017 09:41, Stephen Farrell wrote:
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 18 May 2017 16:01:20 +0000

Hi,

I tend to agree with Stephen in that assuming a RADIUS or Diameter server is not generic enough. Even though a solution like the one proposed in draft-garcia-radext-radius-lorawan might be suitable for certain technologies like LoRaWAN, there are other protocols like Sigfox which don't have a joining procedure or an authentication message exchange (i.e. every message is individually authenticated). Therefore, Stephen's proposal to use LBES instead of AAA sounds like a good generic solution.

Best,

Juan Carlos

From: lp-wan [mailto:[email-masked]] On Behalf Of Arun
Sent: May 18, 2017 11:24 AM
To: [email-masked]
Subject: Re: [lp-wan] overview issue#2: AAA server term...

Hi Stephen,
There is a draft, draft-garcia-radext-radius-lorawan, that explains the use of AAA server in lpwa technologies like lora.
The idea is to use standardized solutions like AAA for authenticating end devices in such technologies.
IMHO, AAA term in a way is good to push for the use of standard entities in the architecture.

regards,
Arun

Hiya,

Cheers,

S.

lp-wan mailing list

[email-masked]<mailto:[email-masked]>

---

From: Dan García Carrillo <[email-masked]>
Date: Thu, 18 May 2017 19:02:31 +0200

Hi,

I agree that the solution presented in draft-garcia-radext-radius-lorawan is specific to LoRaWAN. Not applicable to other radio technologies (i.e. Sigfox as mentioned). 

Although, the idea of having AAA and its advanced characteristics (e.g., Identity federation) is the general idea that can be extrapolated to LPWAN (That was also the idea behind the draft) 

I understand, at the end, that is the goal. Using AAA or LBES from what I understand is only nomenclature. Am I wright, or are there other reasons? If RADIUS or Diameter are not suitable for the task would be an interesting discussion, as well as analyzing the possible gap in case there are reasons to change the name, or the concept, beyond nomenclature. 

What do you think?

Thank you. 
Best Regards,
Dan. 

> El 18 may 2017, a las 18:01, Juan Carlos Zuniga <[email-masked]> escribió:
> 
> Hi,
>  
> I tend to agree with Stephen in that assuming a RADIUS or Diameter server is not generic enough. Even though a solution like the one proposed in draft-garcia-radext-radius-lorawan might be suitable for certain technologies like LoRaWAN, there are other protocols like Sigfox which don’t have a joining procedure or an authentication message exchange (i.e. every message is individually authenticated). Therefore, Stephen’s proposal to use LBES instead of AAA sounds like a good generic solution.
>  
> Best,
>  
> Juan Carlos
>  
>  
> [1] https://tools.ietf.org/html/draft-ietf-lpwan-overview-02#section-3 <https://tools.ietf.org/html/draft-ietf-lpwan-overview-02#section-3>
>  
>  
>  
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 19 May 2017 10:35:14 +0100

Hiya,

On 18/05/17 18:02, Dan García Carrillo wrote:
> Hi,
> 
> I agree that the solution presented in
> draft-garcia-radext-radius-lorawan is specific to LoRaWAN. Not
> applicable to other radio technologies (i.e. Sigfox as mentioned).
> 
> Although, the idea of having AAA and its advanced characteristics
> (e.g., Identity federation) is the general idea that can be
> extrapolated to LPWAN (That was also the idea behind the draft)
> 

Well, in terms of RFC2904 (not that that should be considered that
authoratitive), the thing about which we're talking is just called
the "service equipment."

And that's about right, a LoRaWAN NS/JS is not (architecturally) a
AAA server in my mind, a AAA server is a more generic entity that
is not specific to the radio technology in use.

In saying that it's also true that the LoRaWAN NS/JS interaction is
very similar to one part of what we do with RADIUS/Diameter, so the
ideas in draft-garcia-radext-radius-lorawan are not crazy at all.

> I understand, at the end, that is the goal. Using AAA or LBES from
> what I understand is only nomenclature. 

Yep. This isn't a hill on which anyone ought want to die:-)

> Am I wright, or are there
> other reasons? If RADIUS or Diameter are not suitable for the task
> would be an interesting discussion, as well as analyzing the possible
> gap in case there are reasons to change the name, or the concept,
> beyond nomenclature.

IMO Diameter or RADIUS are fine protocols one might well use talk
to a AAA server from an "LBES" (or whatever we end up calling it).

Cheers,
S.

> 
> What do you think?
> 
> Thank you. Best Regards, Dan.
> 
> 
>> I tend to agree with Stephen in that assuming a RADIUS or Diameter
>> server is not generic enough. Even though a solution like the one
>> proposed in draft-garcia-radext-radius-lorawan might be suitable
>> for certain technologies like LoRaWAN, there are other protocols
>> like Sigfox which don’t have a joining procedure or an
>> authentication message exchange (i.e. every message is individually
>> authenticated). Therefore, Stephen’s proposal to use LBES instead
>> of AAA sounds like a good generic solution.
>> 
>> Best,
>> 
>> Juan Carlos
>> 
>> 
>> Sent: May 18, 2017 11:24 AM To: [email-masked] Subject: Re:
>> [lp-wan] overview issue#2: AAA server term...
>> 
>> Hi Stephen, There is a draft, draft-garcia-radext-radius-lorawan,
>> that explains the use of AAA server in lpwa technologies like lora.
>>  The idea is to use standardized solutions like AAA for
>> authenticating end devices in such technologies. IMHO, AAA term in
>> a way is good to push for the use of standard entities in the
>> architecture.
>> 
>> regards, Arun
>> 
>> In [1] we define the term "AAA server." I don't think that's a
>> good term to use, as it may be read to assume that we'll end up
>> with a RADIUS or Diameter based solution and a typical AAA server
>> like that is just not the same as a LoRaWAN NS/JS. (There might be
>> a RADIUS or Diameter server behind such a beast, but it's not the
>> same thing.) I think (less sure though) that the "AAA server" is
>> also not so good for the other technologies too.
>> 
>> Cheers, S.
>> [1]
>> https://tools.ietf.org/html/draft-ietf-lpwan-overview-02#section-3
>> <https://tools.ietf.org/html/draft-ietf-lpwan-overview-02#section-3>
>>
>> 
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________ lp-wan mailing
>> list [email-masked] <mailto:[email-masked]> 
>> <https://www.ietf.org/mailman/listinfo/lp-wan>
>> 
>> _______________________________________________ lp-wan mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/lp-wan
> 
> 
> 
> 
> _______________________________________________ lp-wan mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/lp-wan
>