Subject: [lp-wan] I-D Action: draft-ietf-lpwan-overview-05.txt

From: [email-masked]
Date: Sat, 01 Jul 2017 11:22:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 over Low Power Wide-Area Networks of the IETF.

        Title           : LPWAN Overview
        Author          : Stephen Farrell
	Filename        : draft-ietf-lpwan-overview-05.txt
	Pages           : 41
	Date            : 2017-07-01

Abstract:
   Low Power Wide Area Networks (LPWAN) are wireless technologies with
   characteristics such as large coverage areas, low bandwidth, possibly
   very small packet and application layer data sizes and long battery
   life operation.  This memo is an informational overview of the set of
   LPWAN technologies being considered in the IETF and of the gaps that
   exist between the needs of those technologies and the goal of running
   IP in LPWANs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lpwan-overview/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lpwan-overview-05
https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-overview-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lpwan-overview-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Tue, 18 Jul 2017 13:37:59 +0000

Hi Stephen,

I have 2 comments regarding the draft.

First one: Paragraph 3. “Generic terminology”. This paragraph should take into account the WI-SUN architecture (as one of the technology in the scope). WI-SUN architecture introduces the notion of border router, routers and leaf nodes. WI-SUN is not talking about gateways, radio gateways etc. One way to solve this is to add another diagram with the WI-SUN approach.

Second: Paragraph 4.6 says that no routing protocol is needed. This is not correct. WI-SUN is using RPL as routing protocol and is based on a mesh topology. This should be reflected in this paragraph not as a gap but as existing technology.

Many thanks,

Patrick

On 01/07/2017, 20:22, "lp-wan on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

            Title           : LPWAN Overview
            Author          : Stephen Farrell
    
    Abstract:

    

    
    _______________________________________________
    lp-wan mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Jul 2017 08:01:40 +0000

Hello Patrick:

There is a match to be found between what Wi-Sun does and what LPWAN is chartered to cover.

1) It is good to mention as an overview that Wi-Sun FAN can do mesh, has routing and 6LoWPAN. It would be good to very briefly position the profiles and which of those qualify as LPWAN.

OTOH, LPWAN is explicitly chartered outside of routing and 6LoWPAN, so there should not be too much emphasis on this since this is not what the LPWAN reader is after. What the LPWAN reader is after is the edge between the low power end objects and the first router, which appears like a LPWAN star. This is where an intersection with LPWAN technology is hopefully to be found. And then we can use the needs expressed in the overview to derive the next charter items. 

2) is very close to 1). After a brief description of the mesh where routing happens, focus should move to access where LPWAN operates by charter.

Take care,

Pascal

-----Original Message-----
From: lp-wan [mailto:[email-masked]] On Behalf Of Patrick Wetterwald (pwetterw)
Sent: mardi 18 juillet 2017 15:38
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [lp-wan] I-D Action: draft-ietf-lpwan-overview-05.txt

Hi Stephen,

Many thanks,

Patrick

    
            Title           : LPWAN Overview
            Author          : Stephen Farrell
    
    Abstract:

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Wed, 19 Jul 2017 11:41:55 +0000

Hi Pascal.

So basically you agree with my comments :=)

Thanks,

Patrick

On 19/07/2017, 10:01, "Pascal Thubert (pthubert)" <[email-masked]> wrote:

    Hello Patrick:

    

    Take care,
    
    Pascal
    
    -----Original Message-----
    From: lp-wan [mailto:[email-masked]] On Behalf Of Patrick Wetterwald (pwetterw)
    Sent: mardi 18 juillet 2017 15:38
    To: [email-masked]; [email-masked]
    Cc: [email-masked]
    Subject: Re: [lp-wan] I-D Action: draft-ietf-lpwan-overview-05.txt
    
    Hi Stephen,

    
    
    Many thanks,
    
    Patrick

        
                Title           : LPWAN Overview
                Author          : Stephen Farrell
        
        Abstract: