Subject: [lp-wan] Comments to the [lpwan] Overview re: Wi-SUN characteristics

From: Charlie Perkins <[email-masked]>
Date: Tue, 18 Jul 2017 21:07:47 -0700

Hello folks,

I'd like to suggest some additional text to be included in the Wi-SUN 
overview section of the document.  I think it is important to emphasize 
the following characteristics.  These comments can be viewed as more or 
less the distillation of information described at longer length in our 
individual Internet Draft contribution submitted earlier about Wi-SUN.  
We have received many comments about that draft, and it needs to be 
significantly revised and resubmitted as soon as possible.  But the 
[lpwan] Overview document is in Last Call, and we don't have time to 
revise our individual draft before the end of Last Call.

Given a little more time after this busy week, I would also like to 
include a fuller description about the Wi-SUN mesh protocol choices.  If 
that is acceptable, I will provide text next week.

Regards,
Charlie P.
-----------------------------------------------------------------------------------------------------------

-Coverage

The range of Wi-SUN FAN is typically 2~3 km in line of sight, matching 
the needs of neighborhood area networks, campus area networks, or 
corporate area networks. The range can also be extended via multi-hop 
networking.

- High bandwidth, low latency

Wi-SUN's relatively high bandwidth, i.e. up to 300 kbps [FANTPS], 
enables remote update and upgrade of devices so that they can handle new 
applications, extending their working life. Some IoT applications may 
require on-demand control, e.g. on-demand metering in AMI, device 
control in distribution automation. Wi-SUN supports these requirements 
by providing high bandwidth, low latency (0.02s) and bi-directional 
communication.

- Low power consumption

FAN devices draw less than 2 uA when resting and only 8 mA when 
listening [COM]. Such devices can maintain a long lifetime even if they 
are frequently listening. For instance, suppose the device transmits 
data for 10 ms once every 10 s; theoretically, a battery of 1000 mAh can 
last more than 10 years.

- Mesh topology

Wi-SUN FAN mesh networks offer self-forming and self-healing 
capabilities. When a new device is powered up, it can automatically 
discover communication peers. If the link is interrupted by obstacles, a 
device can switch to alternative redundant paths. The reliability of 
Wi-SUN has been proven for years in harsh and remote environments.

- Scalability

10s of millions Wi-SUN FAN devices have been deployed all over the 
world, including several deployments with more than 1 million devices 
[COM]. This demonstrates the scalability of Wi-SUN FAN in urban, 
suburban and rural environments.

The following references could be added in the LPWAN overview draft:

[COM] Wi-SUN Alliance, “Comparing IoT Networks at a Glance”, May 2017.

[FANTPS] Wi-SUN Alliance, "Technical Profile Specification Field Area 
Network", May 2016.

Figure.8 needs a column for Wi-SUN:

Another paragraph could be added regarding the Wi-SUN security solution, 
something along the following lines.

    Wi-SUN has made it a design goal to rely on industry standard
    security solutions instead of special-purpose or proprietary
    methods.  In this way, users and equipment vendors can have a high
    degree of confidence that their system will truly be secure. 
    Moreover it will be easier to provide secure interfaces to other
    system modules and components, which are more likely to support
    standard security protocols without special purpose coding.

--------------------------------------------------------------------------------------------------------------------------

Regards,
Charlie P.

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 19 Jul 2017 14:09:41 -0500

You raised some very good points about Wi-SUN, Charlie.  
Perhaps another point could be the ability to change the PHY characteristics such as modulations, packet size, or FEC; or change out the whole PHY for a different band.

Patrick Kinney
Kinney Consulting
+1.847.960.3715
[email-masked]

> On Jul 18, 2017, at 23:07, Charlie Perkins <[email-masked]> wrote:
> 
> 
> Hello folks,
> 
> I'd like to suggest some additional text to be included in the Wi-SUN overview section of the document.  I think it is important to emphasize the following characteristics.  These comments can be viewed as more or less the distillation of information described at longer length in our individual Internet Draft contribution submitted earlier about Wi-SUN.  We have received many comments about that draft, and it needs to be significantly revised and resubmitted as soon as possible.  But the [lpwan] Overview document is in Last Call, and we don't have time to revise our individual draft before the end of Last Call.
> 
> Given a little more time after this busy week, I would also like to include a fuller description about the Wi-SUN mesh protocol choices.  If that is acceptable, I will provide text next week.
> 
> Regards,
> Charlie P.
> The range of Wi-SUN FAN is typically 2~3 km in line of sight, matching the needs of neighborhood area networks, campus area networks, or corporate area networks. The range can also be extended via multi-hop networking.
> 
>  
> 
> Wi-SUN's relatively high bandwidth, i.e. up to 300 kbps [FANTPS], enables remote update and upgrade of devices so that they can handle new applications, extending their working life. Some IoT applications may require on-demand control, e.g. on-demand metering in AMI, device control in distribution automation. Wi-SUN supports these requirements by providing high bandwidth, low latency (0.02s) and bi-directional communication.
> 
>  
> 
> - Low power consumption
> 
> FAN devices draw less than 2 uA when resting and only 8 mA when listening [COM]. Such devices can maintain a long lifetime even if they are frequently listening. For instance, suppose the device transmits data for 10 ms once every 10 s; theoretically, a battery of 1000 mAh can last more than 10 years.
> 
>  
> 
> - Mesh topology
> 
> Wi-SUN FAN mesh networks offer self-forming and self-healing capabilities. When a new device is powered up, it can automatically discover communication peers. If the link is interrupted by obstacles, a device can switch to alternative redundant paths. The reliability of Wi-SUN has been proven for years in harsh and remote environments.
> 
>  
> 
> - Scalability
> 
> 10s of millions Wi-SUN FAN devices have been deployed all over the world, including several deployments with more than 1 million devices [COM]. This demonstrates the scalability of Wi-SUN               FAN in urban, suburban and rural environments.
> 
> 
> 
>  
> 
> [FANTPS] Wi-SUN Alliance, "Technical Profile Specification Field Area Network", May 2016.
> 
>  
> 
> Another paragraph could be added regarding the Wi-SUN security solution, something along the following lines.  
> 
> Wi-SUN has made it a design goal to rely on industry standard security solutions instead of special-purpose or                   proprietary methods.  In this way, users and equipment vendors can have a high degree of confidence that their system will truly be secure.  Moreover it will be easier to provide secure interfaces to other system modules and components, which are more likely to support standard security protocols without special purpose coding.
> 
> <Figure 8 terminology.EFX>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Liubing (Remy)" <[email-masked]>
Date: Thu, 20 Jul 2017 02:08:15 +0000

Hello folks,
I agree with Charlie and Patrick Wetterwald that Wi-SUN FAN uses some different terminologies and should be illustrated as a column in Figure.8 of the LPWAN overview draft.

As mentioned by Patrick Kinney, the packet size of Wi-SUN can also be included.

Best regards,
Remy
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 3:10 AM
To: Charlie Perkins
Cc: lp-wan; Bob Heile; Zhangmingui (Martin); Jonathan Muñoz; Liubing (Remy)
Subject: Re: [lp-wan] Comments to the [lpwan] Overview re: Wi-SUN characteristics

Patrick Kinney
Kinney Consulting
+1.847.960.3715
[email-masked]<mailto:[email-masked]>

On Jul 18, 2017, at 23:07, Charlie Perkins <[email-masked]<mailto:[email-masked]>> wrote:

Hello folks,

Regards,
Charlie P.

-Coverage

- Low power consumption

- Mesh topology

- Scalability

Regards,
Charlie P.

<Figure 8 terminology.EFX>
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 20 Jul 2017 09:29:56 +0200

Dear all,

It seems to me that you have several points that you would wish emphasize, with the majority of them already present in the current LPWAN Overview draft. For example, Section 2.4.2 already mentions the characteristics you wanted to add - mesh network, RPL, MHDS, multi-PHY, multi-throughput. 

I’d like to get back to one of the non-goals of the LPWAN Overview document: provide an extensive description of one of the baseline technologies. Another non-goal - have a document that gets constantly updated to reflect the ongoing developments and publications in these very dynamic technologies. 

We wanted to have a snapshot that allows to grasp the essential approach of each of the technologies. If the need is expressed by the individual technology contributors, then individual, more dynamic, rich, and up-to-date submissions are welcome. Charlie, Bob and Mingui have now submitted a dedicated document and it seems the perfect place to be this venue. The same was done for the other baseline technologies.

I think the document reaches these goals. In addition, get the impression that you are looking to improve the document beyond the point of our stated non-goals. In this sense, I feel that the current document covers most (if not all) of your editorial requests. I think that with the following minor modifications we can strike the right balance between our goals and avoiding the non-goals:
- Check references with updated ones
- Add reference to the draft-heile-lpwan-wisun-overview-00 document
- Add column with WI-SUN terminology

Does that sound reasonable to you?

Alexander

> Le 20 juil. 2017 à 04:08, Liubing (Remy) <[email-masked]> a écrit :
> 
> Hello folks,
> [email-masked] <mailto:[email-masked]>
> 
> On Jul 18, 2017, at 23:07, Charlie Perkins <[email-masked] <mailto:[email-masked]>> wrote:
> 
>  
> Hello folks,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>_______________________________________________
> lp-wan mailing list
> [email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 20 Jul 2017 15:45:10 +0100

Hi all,

Charlie Perkins has kindly offered to send me some text suggestions
for these various comments wrt Wi-SUN. My assumption is that those
will cover the various comments received on the list in the last few
days. Once I have those I'll post a -05 and we can go from there.
AFAIK, those are all editorial changes so hopefully won't affect the
WGLC for this draft. (But will of course need checking.)

As we know, this is a busy week for folks so I'm not sure if
Charlie will get that done today for the usual understandable
reasons.

Cheers,
S.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 20 Jul 2017 14:48:24 +0000

I'm used to get the impossible from Charlie so let's see : ) we have most of the text on the ML already... if Charlie makes it, it would be ideal to be able to announce during the meeting tomorrow that the doc is published and ready for shipping !

Regards,

Pascal

> Le 20 juil. 2017 à 16:45, Stephen Farrell <[email-masked]> a écrit :
> 
> 
> Hi all,
>