Subject: [lp-wan] A New Paper Regarding the SCHC

From: "Khaled Q. Abdelfadeel" <[email-masked]>
Date: Fri, 18 Aug 2017 16:21:49 +0100

Dear All,

We would like to share this work ( https://arxiv.org/abs/1708.05209 ) with
you. It’s a new paper that had been accepted in CHANTS workshop, ACM
MobiCom this October. In this paper, we implemented a preliminary version
of SCHC over Contiki OS (https://gitlab.com/kqorany/SCHC ), compared SCHC
versus IPHC, showed SCHC impact on LoRa network, and proposed some
improvements over the SCHC.

We have some plans to extend this work afterward. We would be happy to get
your feedback and please cite the ACM version of this work.

Best Regards,

Khaled

---

From: Alexander Pelov <[email-masked]>
Date: Fri, 18 Aug 2017 22:30:29 +0200

Dear Khaled,

Thanks for sending this precious resource to the ML! Looks really nice! I’d be happy to see the continuation of your work! 

As you are one of the implementers of the draft, what is your feeling about its clarity? Do you have any points that you would like to see improved for the next version?

Best,
Alexander

> Le 18 août 2017 à 17:21, Khaled Q. Abdelfadeel <[email-masked]> a écrit :
> 
> Dear All,
> 
> We would like to share this work ( https://arxiv.org/abs/1708.05209 <https://arxiv.org/abs/1708.05209> ) with you. It’s a new paper that had been accepted in CHANTS workshop, ACM MobiCom this October. In this paper, we implemented a preliminary version of SCHC over Contiki OS (https://gitlab.com/kqorany/SCHC <https://gitlab.com/kqorany/SCHC> ), compared SCHC versus IPHC, showed SCHC impact on LoRa network, and proposed some improvements over the SCHC.
> 
> 
> 
> We have some plans to extend this work afterward. We would be happy to get your feedback and please cite the ACM version of this work.
> 
> 
> 
> Best Regards,
> 
> Khaled
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Khaled Q. Abdelfadeel" <[email-masked]>
Date: Thu, 31 Aug 2017 12:47:46 +0100

Dear Alexander,

Sorry for being late.

I think the last version of the draft is mature now and clear enough,
however, we presented some issues from our implementation experience in
this work ( https://arxiv.org/abs/1708.05209 )like the Layered SCHC (
https://gitlab.com/kqorany/SCHC ), which we believe could reduce memory
consumption and processing complexity, and add flexibility when compressing
packets.

We would be happy to get your feedback.

Best Regards,
Khaled

On Fri, Aug 18, 2017 at 9:30 PM, Alexander Pelov <[email-masked]> wrote:

> Dear Khaled,
>
> Thanks for sending this precious resource to the ML! Looks really nice!
> I’d be happy to see the continuation of your work!
>
> As you are one of the implementers of the draft, what is your feeling
> about its clarity? Do you have any points that you would like to see
> improved for the next version?
>
> Best,
> Alexander
>
>
>
> We would like to share this work ( https://arxiv.org/abs/1708.05209 )
> with you. It’s a new paper that had been accepted in CHANTS workshop, ACM

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 31 Aug 2017 13:54:02 +0200

Dear Khaled,

Thank you very much for your reply! I am happy to hear that an independent implementation found the draft to be globally clear enough. 

Thank you also for your paper and the proposed implementation approach. From the start of the first meetings there were questions on the way to implement it. The authors of SCHC took good care to enable layered implementation - and I think that your work comes as a great confirmation that this can be achieved. Thanks for sharing your work - which I hope is the first in the line of many on SCHC. 

Best,
Alexander

> Le 31 août 2017 à 13:47, Khaled Q. Abdelfadeel <[email-masked]> a écrit :
> 
> Dear Alexander,
> 
> Sorry for being late.
> 
> I think the last version of the draft is mature now and clear enough, however, we presented some issues from our implementation experience in this work ( https://arxiv.org/abs/1708.05209 <https://arxiv.org/abs/1708.05209> )like the Layered SCHC ( https://gitlab.com/kqorany/SCHC <https://gitlab.com/kqorany/SCHC> ), which we believe could reduce memory consumption and processing complexity, and add flexibility when compressing packets.
> 
> On Fri, Aug 18, 2017 at 9:30 PM, Alexander Pelov <[email-masked] <mailto:[email-masked]>> wrote:
> Dear Khaled,
> 
>> Le 18 août 2017 à 17:21, Khaled Q. Abdelfadeel <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>> Dear All,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
>