Subject: [lp-wan] new FSM

From: Laurent Toutain <[email-masked]>
Date: Mon, 9 Oct 2017 09:14:08 +0200

Hi State Machine lovers,

This is a new version on the FSM for fragmentation. Window 0 and Winfow 1
states are collapsed,
which make it easier to read. The receiver includes the ack always (in
green) and ack on err (in blue).

Laurent

---

From: Ana Minaburo <[email-masked]>
Date: Tue, 10 Oct 2017 09:06:09 +0200

Hello,

I’ve looked to your slides once again, and I was wondering if it is not better to have each fragmentation mode in one state machine? For the moment you have try to put some color in order to make them cleared but when we will need to put this into ASCII, it will be difficult to represent all the things together in one.

I may perhaps suggest to rename the sate because not all modes have a window, and at last perhaps if you agree we can reduce the states, we can discuss if you want.

Ana

Ana Minaburo

Research Division

Phone: +33 (0)2.99.12.24.14
ana at ackl.io

2 bis rue de la Châtaigneraie
35510 Cesson-Sévigné 
France 

www.acklio.com

> On 09 Oct 2017, at 09:14, Laurent Toutain <[email-masked]> wrote:
> 
> Hi State Machine lovers,
> 
> This is a new version on the FSM for fragmentation. Window 0 and Winfow 1 states are collapsed, 
> which make it easier to read. The receiver includes the ack always (in green) and ack on err (in blue).
> 
> Laurent
> <state machine.pdf>_______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan