Subject: Re: [Lsvr] [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

From: [email-masked]
Date: Fri, 20 Jul 2018 12:04:50 +0000 (UTC)

To keep both LSVR and IDR WG in sync , i appreciate to keep LSVR WG in involved. This will allow better understanding of use-case requirement synergies and will aid the framing of most optimal solution space.

G/

Gunter Van de Velde

From: 徐小虎(义先)

Sent: Friday, July 20, 07:51

Subject: Re: [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

To: Susan Hares, Idr, idr

Cc: draft-xu-idr-neighbor-autodiscovery

Hi Sue,

Understood, I will. 

By the way, some authors of this draft are exactly from MSDC operators including Alibaba, Tencent and LinkedIn.

Best regards,

Xiaohu

------------------------------------------------------------------

From:Susan Hares <[email-masked]>

Send Time:2018年7月20日(星期五) 19:18

To:徐小虎(义先) <[email-masked]>; Idr <[email-masked]>; idr <[email-masked]>

Cc:draft-xu-idr-neighbor-autodiscovery <[email-masked]>

Subject:RE: [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

Xiaohu:

Our next step is to gather requirements for the IDR neighbor discovery from the WG.  We would especially be interested in feedback on requirements from operators of data centers.  If you know of an operators of medium data centers who could send requirements to the IDR chairs or the IDR list, it would be helpful.

Cheerily, Susan Hares 

From: Idr [mailto:[email-masked]] On Behalf Of ???(??)

Sent: Friday, July 20, 2018 7:12 AM

To: Idr; idr

Cc: draft-xu-idr-neighbor-autodiscovery

Subject: Re: [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

 

Hi Sue,

Thanks for launching the WG adoption call for draft-xu-idr-neighbor-autodiscovery.

Hi all,

There has been one implementation developed by a switch vendor. Furthermore at least two additional implementations from other vendors are under construction. If any of you have any concrete and technical concerns on this mechanism, please feel free to tell us and we would like to verify your concerns on the implementation and then give you feedbacks.

Best regards,

Xiaohu

------------------------------------------------------------------

From:Susan Hares <[email-masked]>

Send Time:2018年7月19日(星期四) 17:59

To:idr <[email-masked]>

Cc:draft-xu-idr-neighbor-autodiscovery <[email-masked]>

Subject:Re: [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

This closes the 2 week adoption for draft-xu-idr-neighbor-autodiscovery

(July 2 – July 16). 

The WG chairs conclude on my original questions that: 

1)  There is WG interest to have an auto-discovery mechanism 

that will work for BGP peers in Data Centers

2)  There is some WG  interest having this work

in other deployments. 

3)  There is no consensus on the mechanisms 

(BGP hellos or other mechanisms) 

Or requirements for the mechanisms. 

4)  There is WG consensus and AD Consensus that we should 

collaborate with LSVR. One mechanism for both would 

be good, but it needs to fit the requirements set

by the WG.  

There is no consensus on adoption this draft. 

During today’s IDR session (18:10-19:10), we will have a 

discussion on the requirements for the auto-discovery mechanisms. 

We will start by reviewing the LSVR requirement set.

If our discussions today do not come to a clear conclusion, 

the chairs are willing to sponsor an interim on the topic. 

Susan Hares and John Scudder. 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares

Sent: Monday, July 2, 2018 1:09 PM

To: [email-masked]

Cc: [email-masked]

Subject: [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

Greetings: 

This begins a 2 week WG adoption call for draft-xu-idr-neighbor-autodiscovery (July 2 – July 16).  

https://datatracker.ietf.org/doc/draft-xu-idr-neighbor-autodiscovery/

The authors of this draft should send their IPR statements in response to this email.  I hope the authors will ihelp their vacationing co-authors to respond by July 7th.  

The WG should consider the following: 

1)      Does BGP need to have an autodiscovery mechanism for peers within Data Centers? 

2)      Does this mechanism work for other deployments? 

3)      If so, should be passed in BGP Hello message?  

Or should it be a part of another protocol (e.g. LLDP, BFD, etc). 

4)      Does this interact with any of the LSVR work? 

I want to thank the authors for their patience while we sorted through some of the WG LC for other drafts.  We decided to wait until some of those discussion were cleared up prior to starting a new WG Adoption call.

 

Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 20 Jul 2018 08:21:21 -0400

Gunter: 

Thank you for mention that fact.  I had my second cup of tea and noticed I missed requesting it be cross-posted to LSVR WG. 

Sue 

From: Lsvr [mailto:[email-masked]] On Behalf Of guntervandeveldecc=[email-masked]
Sent: Friday, July 20, 2018 8:05 AM
To: Susan Hares; Idr; idr; 徐小虎(义先); [email-masked]
Cc: draft-xu-idr-neighbor-autodiscovery
Subject: Re: [Lsvr] [Idr] WG adoption call for draft-xu-idr-neighbor-autodiscovery

G/

Gunter Van de Velde

From: 徐小虎(义先)

Hi Sue,

Understood, I will. 

Best regards,

Xiaohu

Xiaohu:

Cheerily, Susan Hares 

To: Idr; idr

 

Hi Sue,

Hi all,

Best regards,

Xiaohu

To:idr <[email-masked]>

(July 2 – July 16). 

in other deployments. 

by the WG.  

To: [email-masked]

Greetings: 

 

Susan Hares