Subject: Re: [Ltru] Fwd: draft-davis-t-langtag-ext

From: "Doug Ewell" <[email-masked]>
Date: Sun, 10 Jul 2011 08:54:12 -0600

Mykyta Yevstifeyev proposed to replace

> | lang= | language       | [BCP47  <http://tools.ietf.org/html/draft-davis-t-langtag-ext-01#ref-BCP47>], with restrictions |
> |       | ["-" script]   |                            |
> |       | ["-" region]   |                            |
> |       | *("-" variant) |                            |

in the present draft with:

> lang     = langtag

This won't work, because BCP 47 'langtag' includes tags that contain an extension or private-use component, which are not allowed in the present draft because that would leave no exit from 't' to other extensions or private-use components within the main tag.  So this particular optimization of Mykyta's needs to be rejected.

Along the same lines, Addison replied to Debbie:

>> In other words is the following allowed:  'ja-t-it-m0-xxx-v21a-2007-i-ami'
>
> The -t extension can, itself, be followed by other extensions or by private use. So, yes, that language tag would be allowed.

But only if there is an extension 'i' which defines 'ami' as a subtag within that extension.  It could not have anything to do with the grandfathered tag "i-ami" meaning "Amis," except in the unlikely and inadvisable situation that the extension subtag also has that meaning.

--
Doug Ewell | Thornton, Colorado, USA | RFC 5645, 4645, UTN #14
www.ewellic.org | www.facebook.com/doug.ewell | @DougEwell

---

From: "Phillips, Addison" <[email-masked]>
Date: Sun, 10 Jul 2011 08:36:43 -0700

AP> I agree. Or, to put it another way, that tag is syntactically correct (well-formed according to the ABNF) and contains two extensions. The (non-)definition of the ‘i' extension is something I didn’t address in my response.

Addison

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Sun, 10 Jul 2011 20:46:02 +0300

10.07.2011 17:54, Doug Ewell wrote:
> > | lang= | language       | [BCP47 
> <http://tools.ietf.org/html/draft-davis-t-langtag-ext-01#ref-BCP47>], 
> with restrictions |
> > |       | ["-" script]   |                            |
> > |       | ["-" region]   |                            |
> > |       | *("-" variant) |                            |
> This won't work, because BCP 47 'langtag' includes tags that contain 
> an extension or private-use component, which are not allowed in the 
> present draft because that would leave no exit from 't' to other 
> extensions or private-use components within the main tag.  So this 
> particular optimization of Mykyta's needs to be rejected.
Yes, I agree here.  The only definitions of <language>, <script>, 
<region> and <variant> are to be imported from BCP 47. However, I don't 
withdraw my other ABNF-related comments.

Mykyta

---

From: Mark Davis ☕ <[email-masked]>
Date: Mon, 11 Jul 2011 21:11:27 -0700

We've posted a new version of
http://tools.ietf.org/html/draft-davis-t-langtag-ext

Diffs are here:
http://tools.ietf.org/rfcdiff?url2=draft-davis-t-langtag-ext-02.txt

The changes are:

* Made it clear that application to the case of speech was included, added
Peter C's example.
* Fixed references, adding authors, removing unneeded reference.
* Changed ABNF. Mostly just the table form, but also defined alphanum.
* Made it clear that the CLDR committee must post proposals publicly.
* Added more information on the XML structure, including the description
attribute. (Note that the CLDR committee had decided to add the description
attribute before this process began.)
* Added fixes for typos noted by CEW.

Please let us know of further feedback.

Note to Doug: The CLDR committee had agreed to move the descriptions into
the bcp47 files, such as
http://unicode.org/repos/cldr/trunk/common/bcp47/calendar.xml. Yoshito has
the action to do that, and was able to accelerate it. So please take a look
if you have the time.

Mark

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 12 Jul 2011 07:24:29 +0300

12.07.2011 7:11, Mark Davis ? wrote:
> [ . . .]
The new ABNF starts comments with "//" which should be semicolon ";", 
per RFC 5234.  The "=" characters should be followed by a space or more 
ones.  Wit all other respects, it is obviously better that the previous one.

Mykyta Yevstifeyev
>
> Note to Doug: The CLDR committee had agreed to move the descriptions 
> into the bcp47 files, such as 
> http://unicode.org/repos/cldr/trunk/common/bcp47/calendar.xml. Yoshito 
> has the action to do that, and was able to accelerate it. So please 
> take a look if you have the time.
>
> Mark
>
>
>
>
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis ☕ <[email-masked]>
Date: Tue, 12 Jul 2011 10:43:21 -0700

fixed in the working copy.

Is there an online ABNF checker that I can use?

Mark
*— Il meglio è l’inimico del bene —*

On Mon, Jul 11, 2011 at 21:24, Mykyta Yevstifeyev <[email-masked]>wrote:

>  12.07.2011 7:11, Mark Davis ☕ wrote:
>
> [ . . .]
>
> The new ABNF starts comments with "//" which should be semicolon ";", per
> RFC 5234.  The "=" characters should be followed by a space or more ones.
> Wit all other respects, it is obviously better that the previous one.
>
> Mykyta Yevstifeyev
>
>
> Ltru mailing [email-masked]://www.ietf.org/mailman/listinfo/ltru
>
>
>

---

From: Mark Davis ☕ <[email-masked]>
Date: Tue, 12 Jul 2011 10:45:56 -0700

Any other issues in the document?

Mark

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 12 Jul 2011 12:08:55 -0600

> Is there an online ABNF checker that I can use?

http://tools.ietf.org/tools/bap/abnf.cgi

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Felix Sasaki <[email-masked]>
Date: Tue, 12 Jul 2011 20:53:06 +0200

Yes, see my mail about "Language tags and (localization) processes (Re:
draft-davis-t-langtag-ext)". Please take my comments into account and liaise
with the Unicode localization TC.

Thanks,

Felix

2011/7/12 Mark Davis ☕ <[email-masked]>

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 12 Jul 2011 20:38:43 +0200

>Please let us know of further feedback.

I think "BCP 47 Extension T" is a very bad title...
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 13 Jul 2011 15:48:22 +0900

> I think "BCP 47 Extension T" is a very bad title...

Agreed. Here is something for a start: "A Language Tag Extension for 
Transliterations/Transcriptions"

Regards,   Martin.

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Wed, 13 Jul 2011 10:14:27 +0300

> Transliterations/Transcriptions"
+1.

Mykyta

---

From: "Jukka K. Korpela" <[email-masked]>
Date: Wed, 13 Jul 2011 11:02:29 +0300

> Transliterations/Transcriptions"

But the abstract refers to translations as well. I wonder if
"A Language Tag Extension 'Trans'"
would be acceptable - "Trans" is cryptic, but more suggestive than "T".

Or, as the abstract says "transformed content, including content that 
has been transliterated, transcribed, or translated, or in some other 
way influenced by the source", what about

"A Language Tag Extension for Transformations"

(perhaps with the word "Text" before "Transformations")?

Actually the pages banners now have "BCP 47 Transform Extension"...

-- 
Yucca, http://www.cs.tut.fi/~jkorpela/