Subject: [Ltru] Language tags and (localization) processes (Re: draft-davis-t-langtag-ext)

From: CE Whitehead <[email-masked]>
Date: Tue, 12 Jul 2011 14:35:13 -0400

Hi, once more.Felix Sasaki felix.sasaki at fh-potsdam.de Tue Jul 12 09:23:36 CEST 2011> Language tags so far have described *states*: an object is in a language, a> script etc. The proposed extension extends languages to described *states*: an object is in a language, a script etc.  > The proposed extension extends languages to describe the outcome> of a *process*: objects have been transformed, with a source object as the> basis for this process. According to the paragraph above, this> transformation includes also translation.I do personally agree that it's good to discuss and then document in the draft some of the concerns you have described.  And yes, translation/transliteration is a process.
That said, I personally see the from language as part of the "state" too of the translation --it affects how things end up being translated; sometimes a translation even includes annotation of say a "pun" in the original.
The translator may translate structures, terms, greetings directly from the original language (for example translating from Arabic to English, do you translate "tahaya-t-an wa 'ihtaraama wa ba'ada" -- hope I've got my transliteration from the Arabic right here -- at the beginning of a letter?; if you opt to, you might begin your translation "Greetings and Respect, and now;" some translators may shorten this; in any case, many speakers of one language, when they create texts in another language, well elements of their first language tend to slip into it; also some of the grammar from the original language may be translated into the new language).I think this is even more true for transliteration; knowing the variety transliterated into Latin script is extremely important.So it's useful to know the language of the original that the translation was made from, in my opinion; this gives you more details about the state.
I do think this is briefly mentioned (intro, last paragraph):   "The usage of this extension is not limited to formal transformations,
   and may include other instances where the content is in some other
   way influenced by the source.  For example, this extension could be
   used to designate a request for a speech recognizer that is tailored
   specifically for 2nd-language speakers who are 1st-language speakers
   of a particular language (e.g. a recognizer for "English spoken with
   a Chinese accent")."
Maybe there could be very brief info (in the intro or where the M0 part of the extension is discussed) on the methods/mechanism used in transcription, why they are relevant to indicate, a sentence or something?
Best,--C. E. [email-masked]

---

From: CE Whitehead <[email-masked]>
Date: Tue, 12 Jul 2011 15:18:03 -0400

Hi again.From: [email-masked]: [email-masked]; [email-masked]: Language tags and (localization) processes (Re: [Ltru] draft-davis-t-langtag-ext)Date: Tue, 12 Jul 2011 14:35:13 -0400> Felix Sasaki felix.sasaki at fh-potsdam.de > Tue Jul 12 09:23:36 CEST 2011>> Language tags so far have described *states*: an object is in a language, a>> script etc. The proposed extension extends languages to described *states*: an object is in a language, a script etc.  >> The proposed extension extends languages to describe the outcome>> of a *process*: objects have been transformed, with a source object as the>> basis for this process. According to the paragraph above, this>> transformation includes also translation.> I do personally agree that it's good to discuss and then document in the draft some of the concerns you have described.  > And yes, translation/transliteration is a process.> . . .> I do think this is briefly mentioned (intro, last paragraph):  > "The usage of this extension is not limited to formal transformations,
  > a Chinese accent").">  Maybe there could be very brief info (in the intro or where the M0 part of the extension is discussed) on the methods/mechanism used in transcription, why they are relevant to indicate, a sentence or something?Actually you have brought this up sufficiently for me in section 2.5:       "A language tag with the t extension MAY be used to request a specific   transform of content.  In such a case, the recipient SHOULD return
   content that corresponds as closely as feasible to the requested
   transform, including the specification of the mechanism.  For
   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the
   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007
   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version would be
   preferred.  As is the case for language matching as discussed in
   [BCP47], different implementations MAY have different measures of
   "closeness"."Best,--C. E. [email-masked]

---

From: John Cowan <[email-masked]>
Date: Thu, 14 Jul 2011 00:20:48 -0400

Andrew Glass scripsit:

> pi-Latn-t-pi-Sinh-t-pra

[snip]

> Do I understand the intent of the proposal correctly such that this
> tag would be invalid because a singleton t follows the language tag
> already introduced with t? 

No, it's invalid because it's invalid to have more than one -t-
extension in the same tag.  But the -t- description could be extended to
allow pi-Latn-t-pi-Sinh-t0-pra, or something of the sort.  What's banned
in -t- is language tags containing -i- (all of which are grandfathered),
because that looks like the -t- extension ends and a new -i- extension
(not defined) starts.

-- 
John Cowan                                [email-masked]
I amar prestar aen, han mathon ne nen,    http://www.ccil.org/~cowan
han mathon ne chae, a han noston ne 'wilith.  --Galadriel, LOTR:FOTR

---

From: CE Whitehead <[email-masked]>
Date: Thu, 14 Jul 2011 11:48:46 -0400

Hi, Andres, I think John's solution is the right one and it's worth mentioning both transforms if both affect the content sufficiently.
Take care.
Best,
--C. E. [email-masked] 

> Date: Thu, 14 Jul 2011 00:20:48 -0400
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Language tags and (localization) processes (Re: [Ltru]	draft-davis-t-langtag-ext)
> 
> Andrew Glass scripsit:
> 
> > pi-Latn-t-pi-Sinh-t-pra
> 
> [snip]
>