Subject: Re: [Ltru] draft-davis-t-langtag-ext-03

From: Mark Davis ☕ <[email-masked]>
Date: Wed, 13 Jul 2011 11:51:35 -0700

I just posted an update for items raised on this list.

http://tools.ietf.org/html/draft-davis-t-langtag-ext-03

Diffs: http://tools.ietf.org/rfcdiff?url2=draft-davis-t-langtag-ext-03.txt

   - Fixed title
   - Fixed a few places to make it clearer that it is results-based (Felix)
   - Removed duplicate paragraph
   - Fixed ABNF nits
   - Fixed typo

Please see if that addresses the concerns.

Mark
*— Il meglio è l’inimico del bene —*

On Wed, Jul 13, 2011 at 01:02, Jukka K. Korpela <[email-masked]> wrote:

> 13.07.2011 09:48, "Martin J. Dürst" wrote:
>
>  I think "BCP 47 Extension T" is a very bad title...
>>>
>>
>> Agreed. Here is something for a start: "A Language Tag Extension for
>> Transliterations/**Transcriptions"
>>
>
> But the abstract refers to translations as well. I wonder if
> "A Language Tag Extension 'Trans'"
> would be acceptable - "Trans" is cryptic, but more suggestive than "T".
>
> Or, as the abstract says "transformed content, including content that has
> been transliterated, transcribed, or translated, or in some other way
> influenced by the source", what about
>
> "A Language Tag Extension for Transformations"
>
> (perhaps with the word "Text" before "Transformations")?
>
> Actually the pages banners now have "BCP 47 Transform Extension"...
>
> --
> Yucca, http://www.cs.tut.fi/~**jkorpela/ <http://www.cs.tut.fi/~jkorpela/>
>
> ______________________________**_________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/ltru<https://www.ietf.org/mailman/listinfo/ltru>
>

---

From: Felix Sasaki <[email-masked]>
Date: Thu, 14 Jul 2011 06:54:08 +0200

2011/7/13 Mark Davis ☕ <[email-masked]>

>    - Fixed a few places to make it clearer that it is results-based
Looks good, thanks. One additional suggestion (feel free to change), to
clarify things related to aligned structures of transformed text:

[
The extension defined in this document is not meant to be used for (mostly
localization related) formats that already align source and target text in a
dedicated, often XML based structure. For example, in an XLIFF file aligning
a source like the original writing of Italian cities and a target, i.e. the
Japanese transliteration of the cities, using "ja-kana-t-it" for the target
would be overgenerating. Instead one would use the language tag "ja-kana".
]

Regards,

Felix

> On Wed, Jul 13, 2011 at 01:02, Jukka K. Korpela <[email-masked]>wrote:
>
>> Yucca, http://www.cs.tut.fi/~**jkorpela/<http://www.cs.tut.fi/~jkorpela/>
>>
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru
>
>

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Thu, 14 Jul 2011 08:11:18 +0300

Mark,

Once more to ABNF.

>     t-ext=    "t"                      ; Extension
>               (("-" lang *("-" field)) ; Source + optional field(s)
>               / 1*("-" field))         ; Field(s) only (no source)
The 2nd and 3rd lines need not have the extra parenthesizing, forming 
the production:

>     t-ext=    "t"                      ; Extension
>               ("-" lang *("-" field))  ; Source + optional field(s)
>               / 1*("-" field)          ; Field(s) only (no source)
This may only be useful in complicated productions.  Moreover, the 2nd 
line might also be simplified to:
>               "-" lang *("-" field)    ; Source + optional field(s)
...however, RFC 5234 recommends to do as you've done (but both variants 
are valid), so this is up to you to decide.

Mykyta

13.07.2011 21:51, Mark Davis ? wrote:
>   * Fixed title
>   * Fixed a few places to make it clearer that it is results-based (Felix)
>   * Removed duplicate paragraph
>   * Fixed ABNF nits
>   * Fixed typo
>
> /--- Il meglio è l'inimico del bene ---/
>
>
> On Wed, Jul 13, 2011 at 01:02, Jukka K. Korpela <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>         Transliterations/Transcriptions"
>
>
>     Or, as the abstract says "transformed content, including content
>     that has been transliterated, transcribed, or translated, or in
>     some other way influenced by the source", what about
>
>     Yucca, http://www.cs.tut.fi/~jkorpela/
>     <http://www.cs.tut.fi/%7Ejkorpela/>
>
>     [email-masked] <mailto:[email-masked]>

---

From: Mark Davis ☕ <[email-masked]>
Date: Thu, 14 Jul 2011 08:57:31 -0700

Here's what I have in my working copy:

   <t>The t extension is not intended for use in structured data that
already provides for source and target language identifiers.

For example, this is the case in localization interchange formats such as
XLIFF.

In such cases, it would be inappropriate to use "ja-t-it" for the target
language tag because the source language tag

"it" would already be present in the data. Instead one would use the
language tag "ja".

</t>

Mark

---

From: Mark Davis ☕ <[email-masked]>
Date: Thu, 14 Jul 2011 08:58:16 -0700

Thanks. I figure it is better to be more explicit than less, so given that
they are both valid, it's probably better to leave as is.

Mark

On Wed, Jul 13, 2011 at 22:11, Mykyta Yevstifeyev <[email-masked]>wrote:

>  The 2nd and 3rd lines need not have the extra parenthesizing, forming the
> production:
>
>     t-ext=    "t"                      ; Extension
> 13.07.2011 21:51, Mark Davis ☕ wrote:
>
>  Diffs:
> http://tools.ietf.org/rfcdiff?url2=draft-davis-t-langtag-ext-03.txt
>
>
>    - Fixed title
> Ltru mailing [email-masked]://www.ietf.org/mailman/listinfo/ltru
>
>
>

---

From: Felix Sasaki <[email-masked]>
Date: Thu, 14 Jul 2011 18:55:01 +0200

Looks good to me, many thanks.

Felix

2011/7/14 Mark Davis ☕ <[email-masked]>