Subject: Re: [Ltru] Proposed -t0- subtag

From: "Doug Ewell" <[email-masked]>
Date: Sun, 24 Jul 2011 21:38:51 +0000

'Zxxx' originally did mean "code for unwritten languages," at least in ISO 15924, but there's no way anyone could interpret "en-Zxxx" or "ja-Zxxx" as meaning those languages are unwritten. Thus I'm not sure where the ambiguity lies.

If it really is necessary to use BCP 47 tags to indicate explicitly whether content is written or spoken, then 'Zxxx' is the tool for the job. But I still wonder how slippery this slope might turn out to be--spoken vs. sung, handwritten vs. typed vs. painted on a sign, etc.

--
Doug Ewell • [email-masked]
Sent via BlackBerry by AT&T

---

From: "Phillips, Addison" <[email-masked]>
Date: Sun, 24 Jul 2011 15:23:48 -0700

Mark separately quoted the relevant paragraph from BCP 47. 

Generally I recommend against using the script subtag. I certainly have the problem Karen describes, but usually I find that the audio vs. written distinction is well-communicated by the context.

No language tag is "perfect" for all possible uses. As I tend to prefer succinct tags to verbose ones, I generally recommend against tagging audio content with 'Zxxx'. In chatting with Mark, though, I have seen that it can work well in applications that expect it.

Additional "language modalities" strike me as even less interesting to tag: "Japanese transcribed into sign language by a one-handed person from the original song as hummed in an Italian accent".

Addison

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Doug
> Ewell
> Sent: Sunday, July 24, 2011 2:39 PM
> To: Broome, Karen; Mark Davis ☕
> Cc: [email-masked]
> Subject: Re: [Ltru] Proposed -t0- subtag
> 
> 'Zxxx' originally did mean "code for unwritten languages," at least in ISO 15924,
> but there's no way anyone could interpret "en-Zxxx" or "ja-Zxxx" as meaning
> those languages are unwritten. Thus I'm not sure where the ambiguity lies.
> 
> If it really is necessary to use BCP 47 tags to indicate explicitly whether content
> is written or spoken, then 'Zxxx' is the tool for the job. But I still wonder how
> slippery this slope might turn out to be--spoken vs. sung, handwritten vs. typed
> vs. painted on a sign, etc.
> 
> --
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru