Subject: Re: [Ltru] draft-davis-t-langtag-ext

From: CE Whitehead <[email-masked]>
Date: Tue, 9 Aug 2011 16:38:58 -0400

Hi.From: Mark Davis â <mark at macchiato.com>
Date: Mon, 8 Aug 2011 09:07:12 -0700> Ok, we've rolled up changes based on feedback and posted. (I wasn't able to post earlier; most of these were in the working > document linked to while posting was disallowed.)>  . . .  It looks fine to me; one more minor proofreading nit if you're still looking for those:
2.5 Last P
"A language tag with the t extension MAY be used to request a specific   transform of content.  In such a case, the recipient SHOULD return   content that corresponds as closely as feasible to the requested   transform, including the specification of the mechanism.  For   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version would be   preferred.  As is the case for language matching as discussed in   [BCP47], different implementations MAY have different measures of   "closeness"."
{ COMMENT:  I would prefer "should be returned" or "is normally returned" over "would be preferred;" also I would not use "would;" I would use "should" or else use all present tense forms here . . . }
=>"A language tag with the t extension MAY be used to request a specific   transform of content.  In such a case, the recipient SHOULD return   content that corresponds as closely as feasible to the requested   transform, including the specification of the mechanism.  For   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version is normally returned.  As is the case for language matching as discussed in   [BCP47], different implementations MAY have different measures of   "closeness"."
{ COMMENT2: alternately you could say here,=>"For example, if the request is ja-t-it-m0-xxx-v21a-2007, and the recipient has content corresponding to both. . . , then the 2007 version SHOULD normally be returned." }
Best,
--C. E. [email-masked]

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 9 Aug 2011 14:25:18 -0700

“SHOULD” is a magic word. It’s not appropriate in these cases, IMO.

Addison

From: [email-masked] [mailto:[email-masked]] On Behalf Of CE Whitehead
Sent: Tuesday, August 09, 2011 1:39 PM
To: [email-masked]
Subject: Re: [Ltru] draft-davis-t-langtag-ext

Hi.
From: Mark Davis â <mark at macchiato.com<mailto:[email-masked]>>
Date: Mon, 8 Aug 2011 09:07:12 -0700
> Ok, we've rolled up changes based on feedback and posted. (I wasn't able to post earlier; most of these were in the working
> document linked to while posting was disallowed.)
>  . . .
 It looks fine to me; one more minor proofreading nit if you're still looking for those:

2.5 Last P

"A language tag with the t extension MAY be used to request a specific
   transform of content.  In such a case, the recipient SHOULD return
   content that corresponds as closely as feasible to the requested
   transform, including the specification of the mechanism.  For
   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the
   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007
   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version would be
   preferred.  As is the case for language matching as discussed in
   [BCP47], different implementations MAY have different measures of
   "closeness"."

=>
"A language tag with the t extension MAY be used to request a specific
   transform of content.  In such a case, the recipient SHOULD return
   content that corresponds as closely as feasible to the requested
   transform, including the specification of the mechanism.  For
   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the
   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007
   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version is normally returned.  As is the case for language matching as discussed in
   [BCP47], different implementations MAY have different measures of
   "closeness"."

{ COMMENT2: alternately you could say here,
=>
"For example, if the request is ja-t-it-m0-xxx-v21a-2007, and the recipient has content corresponding to both
. . . ,
then the 2007 version SHOULD normally be returned." }

Best,

--C. E. Whitehead
[email-masked]<mailto:[email-masked]>

---

From: CE Whitehead <[email-masked]>
Date: Wed, 10 Aug 2011 13:26:42 -0400

Damn this indecision;
I don't know;
shall I take an axe to it,
or shall I let it grow.

--from Judith Wright, "That Seed"

From: [email-masked]
To: [email-masked]; [email-masked]
Date: Tue, 9 Aug 2011 14:25:18 -0700
Subject: RE: [Ltru] draft-davis-t-langtag-ext

> “SHOULD” is a magic word. It’s not appropriate in these cases, IMO. > Addison
Thanks  for your feedback Addison; SHOULD is there in the draft -- in the section just above  and that's why I pounced on it (I know it's a magic word); so if it's not the right word just go for the present tense; use "is;" "would" sounds way to "iffy" here  (it would be nice if . . . it ever could happen . . . that the 2007 version could be returned).
(That's just my editorial opinion of course, but I have done a little editing; also have taken courses in line editing and techincal editing; thanks).
Sincerely,
--C. E. [email-masked]  From: [email-masked] [mailto:[email-masked]] On Behalf Of CE Whitehead
Sent: Tuesday, August 09, 2011 1:39 PM
To: [email-masked]
Subject: Re: [Ltru] draft-davis-t-langtag-ext Hi.From: Mark Davis â <mark at macchiato.com>
Date: Mon, 8 Aug 2011 09:07:12 -0700> Ok, we've rolled up changes based on feedback and posted. (I wasn't able to post earlier; most of these were in the working > document linked to while posting was disallowed.)>  . . .  It looks fine to me; one more minor proofreading nit if you're still looking for those: 2.5 Last P "A language tag with the t extension MAY be used to request a specific   transform of content.  In such a case, the recipient SHOULD return   content that corresponds as closely as feasible to the requested   transform, including the specification of the mechanism.  For   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version would be   preferred.  As is the case for language matching as discussed in   [BCP47], different implementations MAY have different measures of   "closeness"." { COMMENT:  I would prefer "should be returned" or "is normally returned" over "would be preferred;" also I would not use "would;" I would use "should" or else use all present tense forms here . . . } =>"A language tag with the t extension MAY be used to request a specific   transform of content.  In such a case, the recipient SHOULD return   content that corresponds as closely as feasible to the requested   transform, including the specification of the mechanism.  For   example, if the request is ja-t-it-m0-xxx-v21a-2007, and the   recipient has content corresponding to both ja-t-it-m0-xxx-v21a-2007   and ja-t-it-m0-xxx-v21a-2009, then the 2007 version is normally returned.  As is the case for language matching as discussed in   [BCP47], different implementations MAY have different measures of   "closeness"." { COMMENT2: alternately you could say here,=>"For example, if the request is ja-t-it-m0-xxx-v21a-2007, and the recipient has content corresponding to both. . . , then the 2007 version SHOULD normally be returned." } Best, --C. E. [email-masked]

---

From: CE Whitehead <[email-masked]>
Date: Wed, 10 Aug 2011 13:39:45 -0400

Forgot to cut the top of this message (the automatic signature that's only for personal emails that I forgot to turn off) last time; my apologies.

Here is the message again (sorry for the double post).
Sincerely,