Subject: [marf] draft-jdfalk-maawg-cfblbcp

From: "J.D. Falk" <[email-masked]>
Date: Tue, 18 Jan 2011 10:53:34 -0800

Last week I finally found time to finish converting the MAAWG Complaint Feedback Loop Best Common Practices document into IETF format, adding references and (I think) all of the required sections.

http://tools.ietf.org/html/draft-jdfalk-maawg-cfblbcp-00

This is intended to fulfill the informational/BCP goal from the MARF charter:

>   2) The group will produce an informational document detailing
>   guidelines for deploying and using ARF, including descriptions
>   of current practices and their rationales.

The MAAWG Board has decided that they'd prefer to retain change control.  That doesn't mean MARF is locked out, though -- if there are enough suggestions to warrant publishing a 2.0 version, I think MAAWG would be open to it.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 18 Jan 2011 11:02:15 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of J.D. Falk
> Sent: Tuesday, January 18, 2011 10:54 AM
> To: Message Abuse Report Format working group
> Subject: [marf] draft-jdfalk-maawg-cfblbcp
> 
> Last week I finally found time to finish converting the MAAWG Complaint
> Feedback Loop Best Common Practices document into IETF format, adding
> references and (I think) all of the required sections.
> 
> The MAAWG Board has decided that they'd prefer to retain change
> control.  That doesn't mean MARF is locked out, though -- if there are
> enough suggestions to warrant publishing a 2.0 version, I think MAAWG
> would be open to it.

This too should probably become a working group document, though I say that having not yet read it.  :-)  I will do so this week as I seem to be neck-deep in document work anyway.

On a procedural point, I think that since MAAWG wishes to retain change control for now, we can only produce an Informational document.  That's fine, I believe, since we won't be held to producing something that holds formal BCP status in IETF terms.  (Barry, do you concur?)

---

From: SM <[email-masked]>
Date: Tue, 18 Jan 2011 13:56:33 -0800

Hi Murray,
At 11:02 18-01-11, Murray S. Kucherawy wrote:
>On a procedural point, I think that since MAAWG wishes to retain 
>change control for now, we can only produce an Informational 
>document.  That's fine, I believe, since we won't be

The IETF has change control over 
draft-jdfalk-maawg-cfblbcp-00.  There isn't any procedural 
restrictions on publishing a revision of that draft as a BCP.

Regards,
-sm

---

From: Barry Leiba <[email-masked]>
Date: Tue, 18 Jan 2011 23:13:13 -0500

>> On a procedural point, I think that since MAAWG wishes to retain change
>> control for now, we can only produce an Informational document.  That's
>> fine, I believe, since we won't be
>
> The IETF has change control over draft-jdfalk-maawg-cfblbcp-00.  There isn't
> any procedural restrictions on publishing a revision of that draft as a BCP.

SM, I have NO idea what you're trying to say here; no interpretations
I can come up with seem to make sense.

Barry

---

From: Barry Leiba <[email-masked]>
Date: Tue, 18 Jan 2011 23:20:40 -0500

> This too should probably become a working group document, though I say that having
> not yet read it.  :-)  I will do so this week as I seem to be neck-deep in document
> work anyway.

No... if MAAWG wants to retain change control, that means I should
help JD send it through the Independent Submission stream.  It can't
be a working-group document if the working group doesn't have change
control.

That said, as JD points out, it's fine for the working group to
discuss it and make comments, which MAAWG might choose to accept.

As to the charter item (which was due in September), the working group
can formally choose to
1. abandon it after the MAAWG document is published, because we decide
that the MAAWG document says what we want to say, or
2. write an informational document that cites the MAAWG document and
says whatever we want to say that's different.

Or, of course, we can completely ignore the MAAWG document and produce
our own.  I don't recommend that, but it is the working group's
decision.

Barry

---

From: SM <[email-masked]>
Date: Tue, 18 Jan 2011 22:25:23 -0800

Hi Barry,
>I can come up with seem to make sense.

I'll ask questions based on the message you posted.

>be a working-group document if the working group doesn't have change

Does the IETF have change control over draft-jdfalk-maawg-cfblbcp?

Can the MARF working group adopt draft-jdfalk-maawg-cfblbcp as a 
working group document?

Regards,
-sm

---

From: Barry Leiba <[email-masked]>
Date: Wed, 19 Jan 2011 09:13:41 -0500

> Can the MARF working group adopt draft-jdfalk-maawg-cfblbcp as a working
> group document?

As long as a draft belongs to an individual, the individual (JD, in
this case) has change control.  If the working group asks him to make
a change to it, and he does, that's his prerogative.  If he does not,
that's also his prerogative.

If he agrees to turn it over to the working group, and the working
group accepts it, then he'd be agreeing to give change control to the
working group.  If he remains the editor, that would mean he'd be
agreeing to make changes that the working group consensus supports.
If he should refuse, the chairs could replace him as editor.

The working group can not adopt a document that it does not have
change control over.  When we give the document to the IESG, community
last call, directorate reviews, and AD DISCUSS positions may require
changes that the author is unwilling to make.

With the Independent Stream, it's just between the author and the ISE.
 The ISE may refuse to publish it, or the author may withdraw it.  In
any case, it does not represent IETF consensus, and the boilerplate
says as much.

Barry

---

From: "J.D. Falk" <[email-masked]>
Date: Mon, 24 Jan 2011 14:36:40 -0800

Sorry to send this out and then immediately drop off the 'net for a week.  (Long story.)

In any case...yes, the Independent Submission stream was what I was thinking of.  Sorry about that.  I knew there was a key phrase I was missing.

I'm hoping, however, that the MARF WG consensus might indicate that this particular document is sufficient to fulfill our goal of writing a BCP.