Subject: [marf] Updated DKIM reporting draft

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 7 Jan 2011 12:07:14 -0800

Hello all, happy new year!

I am about to post a revision to the DKIM reporting draft.  It has undergone some moderate evolution since its original version, partly based on a small amount of real-world testing (it's been implemented in OpenDKIM and its antecedent for some time) but also partly based on some substantial contributions of material from others in another forum that I'm shepherding into this one.

Although the name is draft-ietf-marf-dkim-reporting, it now also contains support for more general authentication failure reporting by enabling the reporting of SPF-specific data in the report.  It also, therefore, changes the feedback report type from "dkim" to "auth-failure".

A group of implementers have proposed, and I have included, a specific set of fields that are mandatory in an "auth-failure" report.  Most of them we know already, but a new one is "Delivery-Status" to give some indication of what happened to the message that's being reported.

There is also a section that discusses a proposed standard way to do data redaction at a report generator.  Simple replacement with a dummy string like "xxxxx" satisfies a report generator's privacy needs but prevents a report consumer from sorting or grouping of reports about a common problem source.  The proposed mechanism covers both things.  This is something I'd like to include in an RFC5965bis effort somewhere down the road.

One party that's already seen the draft, whom I hope will pipe up on the list once it's posted, has some concerns about the size of the document and thus would like us to consider breaking it into a small set of related documents.  I'll let that discussion start separately along with any other points he may have.

We have a chartered deliverable around this work slated for March, so I'd like to see some effort made to bring this to consensus.

Thanks,
-MSK

---

From: Alessandro Vesely <[email-masked]>
Date: Sat, 08 Jan 2011 20:41:21 +0100

On 07/Jan/11 21:07, Murray S. Kucherawy wrote:
> Although the name is draft-ietf-marf-dkim-reporting, it now also
> contains support for more general authentication failure reporting by
> enabling the reporting of SPF-specific data in the report.

I like that.  I'll forward the i-d-announce to spf-discuss.

---

From: "J.D. Falk" <[email-masked]>
Date: Mon, 10 Jan 2011 13:26:06 -0800

On Jan 7, 2011, at 12:07 PM, Murray S. Kucherawy wrote:

> Although the name is draft-ietf-marf-dkim-reporting, it now also contains support for more general authentication failure reporting by enabling the reporting of SPF-specific data in the report.  It also, therefore, changes the feedback report type from “dkim” to “auth-failure”.

I think this makes a lot of sense; the same people tend to be interested in reporting on both, for the same mailstreams.

> There is also a section that discusses a proposed standard way to do data redaction at a report generator.  Simple replacement with a dummy string like “xxxxx” satisfies a report generator’s privacy needs but prevents a report consumer from sorting or grouping of reports about a common problem source.  The proposed mechanism covers both things.  This is something I’d like to include in an RFC5965bis effort somewhere down the road.

This isn't the only draft where there's been a need (or at least a desire) to discuss redaction -- it seems to be an issue that will follow ARF around forever.  It's written really well here, better than most of the previous attempts (IMHO).  I wonder if it'd make sense to split this section out into a stand-alone draft on the BCP track?  That'll make it easier to reference from other applicable documents.

---

From: "McDowell, Brett" <[email-masked]>
Date: Fri, 28 Jan 2011 15:03:05 -0700

I really like the expanded scope of the latest draft.  Bravo Murray and Hilda.

On Jan 10, 2011, at 4:26 PM, J.D. Falk wrote:

> _______________________________________________
> marf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/marf

---

From: "McDowell, Brett" <[email-masked]>
Date: Mon, 31 Jan 2011 09:36:19 -0700

To clarify: if this progresses in the general direction proposed by Murray and Hilda's expanded scope (noting there are still tweaks to be made per Tim's follow-up comments), I would advocate that my employer build out support for consuming such reports, and I would advocate that my employer's partners (many of the big consumer mailbox providers) build out support for the report generation side.  

-- Brett

---

From: "McDowell, Brett" <[email-masked]>
Date: Mon, 31 Jan 2011 09:43:50 -0700

-- Brett