Subject: Re: [marf] I-D Action: draft-ietf-marf-authfailure-report-00.txt

From: Alessandro Vesely <[email-masked]>
Date: Fri, 01 Jul 2011 11:05:53 +0200

On 30/Jun/11 19:35, Hilda Fontana wrote:
> On Wed, Jun 29, 2011 at 7:25 AM, Alessandro Vesely <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     [...]For example, "dkim=none" means the message had no signature.
>
>     IMHO, the simplest specification is that the feedback-report part
>     contains just the triggering A-Rs, whether or not they are also
>     present in the message/rfc822 part of the report.
> 
> for automation it would be useful for the headers to be standard - so
> if dkim was not checked perhaps dkim="" would be preferable to
> dkim=none - to your point above but I think its worth including to try
> to standardize the format 

I don't see how having dkim="" benefits automation.  Its meaning could
be inferred from the absence of any dkim methodspec.

Using empty result values yields Authentication-Results header fields
different from those that verifiers SHOULD produce, see
http://tools.ietf.org/html/rfc5451#section-2.4

---

From: "John Levine" <[email-masked]>
Date: 1 Jul 2011 14:03:10 -0000

Having taken another look at the document, I would restructure it so
that it reports all of the authentication results for the message.  A
single message can easily have an SPF result and two or three DKIM
results, and possibly an ADSP result which is separate from any DKIM
results. In a typical FBL keyed by IP address, the sender would be
interested in all of these.

As far as the delivery status, you can ask, but no sensible person
will tell you since the primary utility for asking whether a message
was delivered is to tune mail to avoid spam filters.

R's,
John

---

From: "Hilda Fontana" <[email-masked]>
Date: Tue, 5 Jul 2011 09:13:18 -0700

It helps automation in that you know to always expect it - rather than the
way the headers come now where the headers that may appear are not standard 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alessandro Vesely
Sent: Friday, July 01, 2011 2:06 AM
To: [email-masked]
Subject: Re: [marf] I-D Action: draft-ietf-marf-authfailure-report-00.txt

> to standardize the format

I don't see how having dkim="" benefits automation.  Its meaning could be
inferred from the absence of any dkim methodspec.

Using empty result values yields Authentication-Results header fields
different from those that verifiers SHOULD produce, see
http://tools.ietf.org/html/rfc5451#section-2.4
_______________________________________________
marf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/marf

---

From: "Hilda Fontana" <[email-masked]>
Date: Tue, 5 Jul 2011 09:14:42 -0700

Apologies for the footers - will not include on the mailing lists 

Thanks
H

-----Original Message-----
From: John Levine [mailto:[email-masked]] 
Sent: Thursday, June 30, 2011 7:48 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [marf] I-D Action: draft-ietf-marf-authfailure-report-00.txt

>This is the first draft of the split out document for the ARF reporting.
>Please review and let me know how best to improve it.

Well, OK.

>CONFIDENTIALITY NOTICE
>
>The information contained in this e-mail and any attachments is 
>CONFIDENTIAL and is intended only for the use of the addressee. Any 
>unauthorized use, disclosure, distribution, dissemination, or copying 
>is strictly prohibited and may be unlawful. If you are not the intended 
>recipient, you are prohibited from any further viewing of the e-mail or 
>any attachments or from making any use of the e-mail or attachments. If 
>you believe you have received this e-mail in error, please notify us 
>immediately and permanently delete the e-mail, any attachments, and all 
>copies from any drives or storage media and destroy any printouts of 
>the e-mail or attachments and any copies of such printouts. Thank you for your cooperation.

Sorry, never mind.

R's,
John

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 5 Jul 2011 10:59:57 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Alessandro Vesely

+1.

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 5 Jul 2011 14:18:59 -0400

On Tuesday, July 05, 2011 01:59:57 PM Murray S. Kucherawy wrote:
> > Alessandro Vesely Sent: Friday, July 01, 2011 2:06 AM
> > To: [email-masked]

+1 from me too.

Scott K