Subject: [marf] I-D Action: draft-ietf-marf-authfailure-report-03.txt

From: [email-masked]
Date: Sat, 08 Oct 2011 23:43:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Messaging Abuse Reporting Format Working Group of the IETF.

	Title           : Authentication Failure Reporting using the Abuse Report Format
	Author(s)       : Hilda L. Fontana
	Filename        : draft-ietf-marf-authfailure-report-03.txt
	Pages           : 20
	Date            : 2011-10-08

   This memo registers an extension report type to ARF for use in
   reporting messages that fail one or more authentication checks
   performed on receipt of a message, with the option to include
   forensic information describing the specifics of the failure.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-marf-authfailure-report-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-marf-authfailure-report-03.txt

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 24 Oct 2011 10:53:14 -0400

> 	Filename        : draft-ietf-marf-authfailure-report-03.txt

...

I think this is much better, but still a few nits:

para 2.2 (I think) also needs to list FWS as an imported definition.  It 
is listed in 3.2 as imported from DKIM.

para 3.2.3: I think for DKIM-Canonicalized-Header and 
DKIM-Canonicalized-Body, instead of saying they can't include redacted 
data, it should to be "SHOULD be included unless inclusion would 
involved redacted data in which case they MUST NOT be included."  I 
don't think these fields make sense under any circumstances once they 
have been redacted.

para 3.2.5: I think this needs rewording.  Current:

>    SPF-DNS MUST appear once for every query to an SPF record that was
>    done, to enable the reporting of included fields and where they came
>    from.  The ABNF in Section 4 changes; see below.

proposed:

>    SPF-DNS MUST appear once for every SPF record used to obtain the SPF result.

I'm not sure that's clear, but I think it a step in the right direction.

para 8.1: The reference to [MAIL] to use RFC 2822 should be updated to 5322.

Scott K

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 25 Oct 2011 03:09:12 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Kitterman
> Sent: Monday, October 24, 2011 7:53 AM
> To: [email-masked]
> Subject: Re: [marf] I-D Action: draft-ietf-marf-authfailure-report-03.txt
> 
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Messaging Abuse Reporting
> Format Working Group of the IETF.
> >

Just for the sake of being pedantic, -04 is current.

> is listed in 3.2 as imported from DKIM.

I agree; moving this to 2.2 is neater.  Good catch.

> don't think these fields make sense under any circumstances once they

That makes sense.  Also, this paragraph is incorrectly indented.  Looks like it needs to be moved outside the <list> element.

> >    SPF-DNS MUST appear once for every SPF record used to obtain the SPF result.

Looks like this one got included in -04.

> para 8.1: The reference to [MAIL] to use RFC 2822 should be updated to

Ditto.