Subject: [MLS] Fwd: XRD: Scalable Messaging System with Cryptographic Privacy

From: =JeffH <[email-masked]>
Date: Fri, 4 Jan 2019 07:37:16 -0800

Of possible interest...

-------- Forwarded Message --------
Subject: 	Tuesday, January 8 -- Albert Kwon: XRD: Scalable Messaging 
System with Cryptographic Privacy
Date: 	Thu, 3 Jan 2019 19:42:20 -0800
From: 	Saba Eskandarian <[email-masked]>
To: 	[email-masked]

   XRD: Scalable Messaging System with Cryptographic Privacy

                          Albert Kwon

                    Tuesday, January 8, 2019
                         Talk at 4:15pm
                           Gates 463A

Abstract:

Even as end-to-end encrypted communication becomes
more popular, private messaging remains a challenging problem
due to metadata leakages, such as who is communicating
with whom. Most existing systems that hide communication
metadata either (1) do not scale easily, (2) incur
significant overheads, or (3) provide weaker guarantees than
cryptographic privacy, such as differential privacy or heuristic
privacy.
In this talk, I will presents XRD, a metadata private messaging system
that provides cryptographic privacy, while scaling easily to support
more users
by adding more servers. At a high level, XRD uses multiple
mix networks in parallel with several techniques, including a
novel technique to efficiently and privately verify the correctness of
mix network operations. As a result, XRD is more than 10x
faster than prior messaging systems that provide cryptographic privacy.

Bio:

Albert Kwon is a sixth year student at MIT working with Srini Devadas.
He is broadly interested in applied cryptography, and likes to design
and implement systems that can enhance users' privacy.
His most recent focus has been on anonymous and private communication
systems.

---

From: Richard Barnes <[email-masked]>
Date: Fri, 4 Jan 2019 13:31:13 -0500

Interesting.  Looks more metadata-focused than MLS; curious to see if it
might dovetail well.

Albert was involved in some pre-BoF MLS discussions.  I think he might even
be on this list?

On Fri, Jan 4, 2019 at 11:04 AM =JeffH <[email-masked]>
wrote:

> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
>