Subject: Re: [MLS] February MLS interop event

From: Richard Barnes <[email-masked]>
Date: Fri, 8 Feb 2019 12:15:06 -0500

Summary of conclusions from this call:

- Folks weren't quite ready to do live interop
- In general, we should do interop async, via test vectors, and use calls
to debrief / discuss issues
- Next interop check-in targeted for Feb 18
  - Still targeting -03 test vectors in mls-implementations repo
  - ... with #115 to fix application key schedule
- A couple of actual test changes would be useful
  - Tests for the resolution algorithm
  - Tests for the key schedule (decoupled from a session)

Please indicate your availability for the next check-in in this Doodle:

https://doodle.com/poll/7b7hurwg268e86a9

On Sat, Jan 26, 2019 at 1:25 PM Richard Barnes <[email-masked]> wrote:

> OK, based on the Doodle results, let's shoot for 16:00-19:00 UTC
>
>
> https://www.timeanddate.com/worldclock/fixedtime.html?msg=MLS+Interop&iso=20190208T16&p1=1440&ah=3
>
> We can use the following Webex bridge:
>
> Join from a video conferencing system or application
> Meeting link: https://cisco.webex.com/meet/richbarn
> Dial: [email-masked]
> Join using Microsoft Skype for Business: [email-masked]
> Toll Free: +1-866-432-9903
> Toll: +1-408-525-6800
> Access Code: 201006237
>
> If you're interested in joining, please make sure you're in the MLS
> Implementors Wire channel, which we'll use for text-based coordination.
>
>
> https://app.wire.com/join/?key=3tL-NJOoCKZlDXNU1H2c&code=kZOc0ujnDQ9Tq98tLfSt
>
>
> On Tue, Jan 15, 2019 at 8:01 PM Richard Barnes <[email-masked]> wrote:
>
>> Hey all,
>>
>> A few of us who are writing code for MLS are thinking of having an
>> informal interop event in early February.  If you'd like to participate,
>> please fill out this Doodle to help pick dates:
>>
>> https://doodle.com/poll/2yd3b2eydchis82b#table
>>
>> The interop target will be draft-ietf-mls-protocol-03.  We will try to
>> get everyone passing a common set of test vectors, covering, e.g.:
>>
>> - Tree math
>> - Derive-Key-Pair
>> - Message parsing and serialization
>> - Fully crypto calculations for a simple scenario
>>
>> This will be a remote meeting / teleconference.  I will send out Webex
>> details once we've picked a date/time.
>>
>> --Richard
>>
>>

---

From: Richard Barnes <[email-masked]>
Date: Sat, 16 Feb 2019 22:35:56 -0500

Update: We'll aim for a check-in next Wednesdsay, Feb 20, at 16:00 UTC

https://www.timeanddate.com/worldclock/fixedtime.html?msg=MLS+Interop&iso=20190220T11&p1=263&ah=1

I'll send out Webex coordinates in the MLS Implementors Wire channel.