Subject: Question: MIME (rfc2048 registry) of ATM SDP parameter values

From: Rajesh Kumar <[email-masked]>
Date: Fri, 27 Oct 2000 21:46:40 -0700

Team,
Since MIME registry applies to IP-based object classes only, there is no 
need to register the ATM formats, encodings, encapsulations, profiles etc. 
referenced in the ATM SDP draft.
This is even though we're using an IP-based control fabric, the bearer 
fabric represented in ATM SDP are not IP-based structures and are therefore 
not amenable to rfc2048 (MIME) registry. 	

The rfc2327 suggestion to MIME-register SDP parameter extensions does not 
apply to ATM SDP.

Please confirm, refute, guide.

Rajesh Kumar
Cisco Systems
Phone 408 527 0811
Fax 408 853-1101

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 29 Oct 2000 10:00:18 -0500

> -----Original Message-----
> From: Rajesh Kumar [mailto:[email-masked]]
> Sent: Saturday, October 28, 2000 12:47 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Question: MIME (rfc2048 registry) of ATM SDP parameter values
> 
> 
> Team,

I disagree.

There are many cases where numbers referring to non-IP based protocols are
carried in IP protocols, and these are still registered with IANA. From the
registry at iana.org, I quickly turned up a bunch:

http://www.isi.edu/in-notes/iana/assignments/address-family-numbers

which includes a variety of ITU numbering plans and other stuff

http://www.isi.edu/in-notes/iana/assignments/novell-sap-numbers

Novell SAP numbers

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 30 Oct 2000 09:09:24 -0500

No, I think if you create a new MIME type, you register it.
We probably don't have to create IANA registries for new items,
because we are likely to have a new SDP RFC before we have
any updates to this document, but we should do the MIME registrations.

Brian

> To: Rosen, Brian; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]