Subject: Re : RTP/RTCP and Q.931 implementation

From: Cesar Augusto Cavalheiro Marcondes <[email-masked]>
Date: Wed, 01 Mar 2000 11:16:44 -0300

Hi,

    I can add URL open source RTP, H.323, SIP from VOVIDA Networks
    http://www.vovida.com   -> Link Open Source

    Java Media Framework has RTP support too.
    http://java.sun.com/products/java-media/jmf/index.html

> > Hello,
> > I am an university student and I am doing a
> > project on VoIP.
> > If you have 'C' codes on RTP/RTCP, Q.931
> > signalling, please provide me the same.
> > Please give me some web site addresses where I
> > can find those codes.
>
> Of Q931 stacks I know nothing...of RTP implementations a little...
>
> The Lucent Elemedia H.323 stack contains a C RTP/RTCP implementation
> and looks to be v. close to functionally complete and is very well
> documented.  It was developed by Jonathon Lennox, Jonathon Rosenburg,
> and Dan Rubenstein.  You can find documentation at:
>
>         http://www.cs.columbia.edu/~jdrosen/rtp_api.html
>
> and download it from:
>
>         http://www.elemedia.com/Main/download.htm
>
> You will have to apply for an id and passwd and agree to licensing
> conditions (that you can't read without an id ;-).
>
> There is also RTP/RTCP C code in the UCL Multimedia Common library
> (open source):
>
>         http://www-mice.cs.ucl.ac.uk/multimedia/software/common/
>
> It's not particulatly well documented and there are some parts of the
> spec not yet implemented, but it is fairly easy to use and supports
> IPv4/v6 (plug plug).  It was developed by Colin Perkins with
> contributions from Bill Fenner, Timur Friedman, Markus Germeier, and
> myself.  If you are interested we have demo code that's not yet
> included in the package that should show you everything you need.
>
> You should also check out Henning's excellent RTP resources:
>
>         http://www.cs.columbia.edu/~hgs/rtp/
>
> as there are implementations in Java and C++ that may also be of interest
> also.
>
> You might also checked out openh323 (http://www.openh323.org), and
> their site is down at the moment, but they too presumeably have an
> implementation.
>
> If there are other publicly available implementations I'd be
> interested in hearing about them.
>
> - Orion
>
> BTW, rem-conf is the AVT groups mailing list and where this request
> should have gone to.
>

---

From: singh pramod <[email-masked]>
Date: Mon, 6 Mar 2000 23:42:02 -0800 (PST)

Hi,
   I got the codes from the given site. I already
compiled other codes for H.323 stack. The RTP/RTCP
module is giving some problems. The files getting
compiled individually. But, while linking I am getting
following errors. 
Linking...
rtp.obj : error LNK2001: unresolved external symbol
__imp__ntohl@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__ntohl@4
rtp.obj : error LNK2001: unresolved external symbol
__imp__ntohs@4
rtp.obj : error LNK2001: unresolved external symbol
__imp__htonl@4
qfDES.obj : error LNK2001: unresolved external symbol
__imp__htonl@4
rtp.obj : error LNK2001: unresolved external symbol
__imp__htons@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__htons@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__inet_addr@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__gethostbyname@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__bind@12
net_udp.obj : error LNK2001: unresolved external
symbol __imp__socket@12
net_udp.obj : error LNK2001: unresolved external
symbol __imp__WSAGetLastError@0
net_udp.obj : error LNK2001: unresolved external
symbol __imp__setsockopt@20
net_udp.obj : error LNK2001: unresolved external
symbol __imp__sendto@24
net_udp.obj : error LNK2001: unresolved external
symbol __imp__recvfrom@24
net_udp.obj : error LNK2001: unresolved external
symbol ___WSAFDIsSet@8
net_udp.obj : error LNK2001: unresolved external
symbol __imp__select@20
net_udp.obj : error LNK2001: unresolved external
symbol __imp__inet_ntoa@4
net_udp.obj : error LNK2001: unresolved external
symbol __imp__gethostname@8
test.obj : error LNK2001: unresolved external symbol
__imp__WSACleanup@0
test.obj : error LNK2001: unresolved external symbol
__imp__WSAStartup@8
Debug/rtp.exe : fatal error LNK1120: 18 unresolved
externals
Error executing link.exe.

rtp.exe - 22 error(s), 0 warning(s)

    I am using microsoft's visual studio VC98
compiler. 
   Could you please, spare some time and let me know
what these errors? Are these from the system included
files or Is there any other files to be included?

   It would be helpful for me if you give some ideas.

Thanks.

regards

pramod Singh

--- Orion Hodson <[email-masked]> wrote:
<[email-masked]>singh
> pramod writes:
> BTW, rem-conf is the AVT groups mailing list and
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com