Subject: A query regarding RTSP and netscape!!!

From: A Saha <[email-masked]>
Date: Tue, 17 Feb 1998 22:04:10 +0800

Hi all

I am Amlan from the NationalUniversity of Singapore. I am working
on a project which partially involves working with RTSP.  I would like
to ask you if it is possible to do the following with NETSCAPE and
if so where should I be looking for documents.

Say I type "rtsp://my.domain.net:554/some_directory/coolsong.wav"
in exactly the place where one would typically type
"http://something.com/something" in netscape.  Now is there a
such that I can spawn or activate my own application from netscape
with the entire string as the argument ? Something similar to when
one types "telnet://something", netscape starts the telnet application.

Has it got anything to do with "rundll32.exe" and my application
being a DLL to be loaded by rundll32.exe ?

Any comments would be highly appreciated.

regards
yours truly
-amlan.

-- 
-------------------------------------------------------------
Amlan Saha			   Voice:  (Work) +65-8709289 
Dept. of Electrical Engineering		   (Res)  +65-2562157
National University of Singapore   Fax:		  +65-7751910
10 Kent Ridge Crescent		   SMTP:  [email-masked]
Singapore 119260		   HTTP: mip.ee.nus.sg/~amlan
-------------------------------------------------------------

---

From: "B�rge Haga" <[email-masked]>
Date: Wed, 18 Feb 1998 11:31:49 +0100

> one types "telnet://something", netscape starts the telnet application.

I don't know if I understand your question correctly, but if I do you
can solve it like this:

1) JUST START OTHER PROGRAM, NO PARAMETERS PASSING
If you want clicking on an URL in netscape to launch a local application
you
can do so by using MSDOS BATCH files. You create a MIME type under
Edit-Preferences-Navigator-Applications for BAT files. Application entry
should be --"%1" %*-- (everything between --'s) when specifying the BAT
mime-type.

2) START OTHER PROGRAM, WITH PARAMETERS PASSING
With this you can start another program and send parameters to it as well.
The way to do this is to intercept the tn3270:// terminal handler in
Netscape.
This and the above is described at a web-site I found:

 Web Browser Techniques

http://gearbox.maem.umr.edu/~html-stuff/

Again, if I misunderstood your question I apologize.

--
Børge Haga
Telenor Nextel AS
Tel + 47 22770378
Fax + 47 22771910
Internet: [email-masked]
P.O.Box 393, Skøyen, 0212 Oslo, Norway
Office:Drammensveien 167, Skøyen