Subject: RE: draft-olson-sdp-ipv6-02.txt

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Oct 2001 09:22:12 -0400

> -----Original Message-----
> From: Pekka Pessi [mailto:[email-masked]]
> Sent: Thursday, October 11, 2001 8:50 AM
> To: Sean Olson
> Cc: [email-masked]
> Subject: Re: draft-olson-sdp-ipv6-02.txt
> 
> 
> >Attached is an updated version of the draft describing how to encode
> >IPv6 addresses in SDP. There are very minor edits, but 
> mostly this is a
> >re-submission because the draft has expired.
> 
> >Any comments or questions are welcome. 
> 
> 	I'd like to include both IPv6 and IPv4 addresses for a
> 	dual-stack host in the SDP.  While SDP syntax supports including
> 	multiple addresses in the media description, that syntax is
> 	intended for layered session with multiple groups.  
> 
> 	An attribute containing the IPv6 address would be best for
> 	indicating the alternative addresses of a dual stack host.  the
> 	attribute could have syntax like connection line:
> 
> a=dual-c:IN IP6 3ffe:1200:3012:c006:290:27ff:fe7d:d024
> 
> 	What do you think?

You could alternatively have multiple m lines, and use the fid specification
to indicate that the other side should "pick one". It would be even handier
to be able to indicate a preference amongst addresses - "pick this m line
first since it uses v6".

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 11 Oct 2001 17:50:38 +0300

Hi,

> to be able to indicate a preference amongst addresses - "pick this m line

The offer would look like:

         a=group:FID 1 2
         m=audio 30000 RTP/AVP 0
         c=IN IP4 131.160.1.112
         a=mid:1
         m=audio 20000 RTP/AVP 0
         a=IN IP6 3ffe:1200:3012:c006:290:27ff:fe7d:d024
         a=mid:2

The answerer would set the port of one of the m lines to zero to
indicate what he wants to receive (assuming that he does not want to
receive media simultaneously in both addresses).

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]