Subject: Re: How does a Registrar inform UA about deregistration?

From: [email-masked]
Date: Fri, 13 Aug 1999 09:48:30 +0200

Anoop wrote:

> Also , does that mean since I don't have a de-registration message , I am forced
> to implement using clustering. Now that I am clustering , it is almost
> impossible for me to implement a stateful proxy.
>
> Hence I think it would be nice to have this de-registration message.
>
> Anoop

On page 33 of RFC2543 you can find the following:

> A client cancels an existing registration by sending a REGISTER
> request with an expiration time (Expires) of zero seconds for a
> particular Contact or the wildcard Contact designated by a "*" for
> all registrations. Registrations are matched based on the user, host,
> port and maddr parameters.

I think this solves your problem.

Regards,

Angelo

========================================================================
A house is a machine built for living in.
                                     (Read on a t-shirt)
========================================================================
Ing. A.E.M. Hulshout                         [email-masked]
Philips Research Laboratories          Information & Software Technology
Prof. Holstlaan 4 (Building WL11)                         Room WL p 1.20
5656 AA Eindhoven, The Netherlands                Tel. (+31 40 27) 43704
========================================================================

---

From: [email-masked]
Date: Fri, 13 Aug 1999 12:55:33 +0200

The message below I sent to confcntrl but it didn't show up. Therefor
a retry

Angelo
-----------

---

From: "Anoop Tripathi" <[email-masked]>
Date: Fri, 13 Aug 1999 09:19:42 -0500

We are talking about the Registrar sending a De-registration message.

Anoop

[email-masked] on 08/13/99 05:55:33 AM

Sent by:  [email-masked]

To:   Anoop Tripathi/MW/US/3Com, [email-masked], [email-masked]
cc:
Subject:  Re: How does a Registrar inform UA about deregistration?

Angelo
-----------