Subject: SDP: grammar for "multicast-address"

From: [email-masked]
Date: Fri, 18 Aug 2000 19:00:09 +0530 (IST)

I have a query on the BNF for "multicast-address" in rfc 2327.

---------------------------------------------------------------------
multicast-address = 3*(decimal-uchar ".") decimal-uchar "/" ttl
                    [ "/" integer ]
                         ;multicast addresses may be in the range
                         ;224.0.0.0 to 239.255.255.255
---------------------------------------------------------------------

Isn't a multicast address supposed to be somewhat similar in form 
to the unicast IP4-address?
	1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT ....

That is, shouldn't it be of the form
    3*3(decimal-uchar ".") decimal-uchar "/" ttl ["/" integer]
      ^^

Although the accompanying text states the valid range for a
multicast address, the BNF seems misleading.

Or have I missed something? Can someone please clarify?
Thanks.

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Fri, 18 Aug 2000 15:53:46 +0200

decimal-uchar =       DIGIT
                         | POS-DIGIT DIGIT
                         | ("1" 2*(DIGIT))
                         | ("2" ("0"|"1"|"2"|"3"|"4") DIGIT)
                         | ("2" "5" ("0"|"1"|"2"|"3"|"4"|"5"))

Gruesse, Carsten

---

From: [email-masked]
Date: Fri, 18 Aug 2000 19:35:04 +0530 (IST)

>                         | ("2" ("0"|"1"|"2"|"3"|"4") DIGIT)

Thank you for your response.

Although decimal-uchar is supposed to be restricted to 3 digits (is
it?), my doubt is because the pattern
    (decimal-uchar ".") 
itself is not restricted.

The BNF only says that it has to appear _atleast_ thrice.
It doesn't say that it should _not_ appear _more_ than thrice.
(Yes, the accompanying text suggests that, but the BNF doesn't seem to.)

So according to the multicast-address BNF, won't the
following address also be considered valid?
    224.10.11.12.13

I hope I made my query clear.
Thanks again.

---

From: James Undery <[email-masked]>
Date: Fri, 18 Aug 2000 16:01:20 +0100

>                          | ("1" 2*(DIGIT))

The previous rule should be ("1" 2*2(DIGIT))