Subject: SIP Conference Control for peer conference calls

From: "Fleischman, Eric W" <[email-masked]>
Date: Tue, 6 Mar 2001 17:46:31 -0800

I request assistance from these lists to better understand the conference control options available to support SIP-oriented conference calls. My current experience with conference control alternatives resemble the all-or-nothing alternatives described in Section 6 of M. Handley/J. Crowcroft/C. Bormann/J. Ott's internet draft document "The Internet Multimedia Conferencing Architecture" (see http://search.ietf.org/internet-drafts/draft-ietf-mmusic-confarch-03.txt). These alternatives (simplistically speaking) are the tightly coupled control of the H.320 series (e.g., H.323) versus the lightly coupled control of traditional MBONE applications. However, what I seek is something in the middle, since I would prefer to avoid the overheads associated with tightly coupled approaches as well as the inefficiencies of loosely coupled.

More specifically, I am seeking a SIP-based solution to the "phone bridge" scenario in which different callers -- all of whom are peers and all of whom are equally likely to speak -- form a conference together from N different locations (N > 2). Current phone bridges permit people to "talk over" each other. Such a possibility would be fine for what I'm after. However, an alternative which would also meet our needs is a "token-based" approach whereby each site requests the token in order to speak and, if it is granted, then that site could speak, thus avoiding contention.

In any case, I am told that certain current Internet2 applications approach this need by having each participant establish bi-directional multicast relationships with each other. While this may work in the unique Internet2 environment, where bandwidth and local CPU resources are plentiful, this approach is unappealing in a commercial environment with our more humble resources. Hence my question to you all: how can the requirements of the previous paragraph be met in a commercial environment using SIP-based conference control? Are there any existing products or implementations doing this?

An approach which makes sense to me is to duplicate the "phone bridge" in the SIP world in the sense that each participant establishes a bi-directional session to a central bridge, and the bridge distributes the call. Are there any such implementations of this using Internet technologies? If so, how well did it work?

Thank you for your attention to this question. I would appreciate any information which you could provide concerning how to achieve peer conference calls using SIP.

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 06 Mar 2001 21:06:34 -0500

One solution that we're implementing in our SIP conference bridge is to
use a web interface, where the chair can enable and disable speaking (or
video sending) from different participants. The web interface has a
connection to the conference server, which in turn mutes the sources,
both locally and via SIP-based muting. This has the advantage that it
doesn't require any special user interface or protocol for the chair
(and the chair could also be on a regular phone through a gateway), but
obviously doesn't support things like queueing up for questions,
although I don't think adding this functionality via a web page would be
particularly hard. (We would probably use SIP NOTIFY to tell the speaker
that it's his or her turn or that the time is up.) This simplistic
approach dodges many of the tough problems, such as maintaining a
consistent membership list of the conference and the need to support
non-IP devices such as phones connected through a gateway.

"Fleischman, Eric W" wrote:
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs