Subject: Key Management for Multimedia Sessions

From: "Fredrik Lindholm (ERA)" <[email-masked]>
Date: Mon, 19 Nov 2001 10:38:26 +0100

FYI

The following drafts are the continuation of the work on the "Key Management for Multimedia Sessions" draft presented in London (at the MSEC and MMUSIC sessions). The original draft has now been split between the MMUSIC WG (where key management extensions to SDP and RTSP are handled) and the MSEC WG (where the protocol itself is handled). 

The MSEC draft ("MIKEY: Multimedia Internet KEYing") can be found at:
http://www.ietf.org/internet-drafts/draft-ietf-msec-mikey-00.txt

and the MMUSIC draft ("Key Management Extensions for SDP and RTSP") can be found at:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-kmgmt-ext-00.txt

We would appreciate any comments. 

Fredrik & Elisabetta

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 20 Dec 2001 15:16:07 -0500

One comment:

For the SDP extension, both keymgmt-data and key-extra-auth are simply using the "byte-string" construct to provide the actual values. It would seem preferable to adopt the existing SDP mechanism (for keys) and specify the encoding method used, e.g. "clear" or "base64", as I imagine it's possible for some protocols to want to use the values
excluded in byte-string.

A similar comment applies to the RTSP header which just recommends using base64 encoding, implying that other encoding methods could be used, however there's no way of specifying these.

Regards

            Flemming

--
Flemming Andreasen
Cisco Systems