Subject: does RTSP support http-like content negotiation ?

From: [email-masked]
Date: Sun, 5 Jul 1998 06:06:45 EDT

i don´t have the document handy, so: does RTSP support http-like content
 negotiation ? i.e. can you you use URLs like the following:

rtsp://www.mumble.org/audio

and store at the server
audio.rm (RealNetworks streaming format)
audio.pcm (standard MIME audio format)

and the server figures out which file to send, depending on the capabilities
communicated by the client ?

The same goes for language, i.e. an english and a french version of the same
 audio file could be stored, and depending on client preferences, either one
 could be sent.

Is this doable in RTSP ?

---

From: Alagu Periyannan <[email-masked]>
Date: Mon, 6 Jul 1998 11:12:25 -0700

RTSP does content format negotiation for the
description format, i.e. in response to a DESCRIBE
you can get SDP, SMIL, etc.

One of the ways to currently do what you want is
to make the SDP description contain multiple
streams and make the client do a SETUP on
only one of them.

> audio file could be stored, and depending on client preferences, either one

---------------------------------------------------
Alagu Periyannan                   [email-masked]

Interactive Multimedia Group
Apple Computer, Inc.