Subject: RE: [SIP] RE: [Sip-implementors] Meaning of SDP 'm' line in INVIT E transact ion

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 17 Mar 2001 01:19:23 -0500

> -----Original Message-----
> From: Culpepper, Bert [mailto:[email-masked]]
> Sent: Thursday, March 15, 2001 11:00 AM
> To: Jonathan Rosenberg; 'Piotr S. Kossowski'; 
> [email-masked]'; [email-masked]'
> Subject: RE: [SIP] RE: [Sip-implementors] Meaning of SDP 'm' 
> line in INVIT E transact ion
> 
> > An alternative is to define an attribute that allows codecs 
> > within a stream
> > to be unidirectional:
> > 
> > INVITE
> > m=audio 5004 RTP/AVP 0 77
> > a=rtpmap:77 telephone-event
> > a=direction:77 sendonly
> > 
> > 200 OK
> > m=audio 5004 RTP/AVP 0 77
> > a=rtpmap:77 telephone-event
> > a=direction:77 recvonly
> > 
> > This is yet another SDP extension. There are many recognized 
> > limitations of
> > SDP, and thus the reasoning behind SDP-ng, which will address 
> > this case.
> > 
> > So, what should we do here?
> 
> I believe the above can be achieved without any SDP extension. 
> For the case a UA supports multiple codecs differently, it can 
> use multiple media descriptions.  For example, the case above 
> can be signaled as:
> 
> INVITE
> m=audio 5004 RTP/AVP 0
> m=audio 5004 RTP/AVP 77
> a=rtpmap:77 telephone-event
> a=sendonly
>  
> 200 OK
> m=audio 5004 RTP/AVP 0
> m=audio 5004 RTP/AVP 77
> a=rtpmap:77 telephone-event
> a=recvonly

No, this has a different meaning. Multiple m lines in SDP imply "parallel"
streams. What we want here are alternatives.

> > I'm inclined, in the interests of KISS, to:
> > 
> > 1. stick with the subset mechanism and correct the 
> > inconsistencies in the
> > flows
> 
> I don't see any harm in allowing a response to contain a superset 
> of the codecs offered in a request.  A requestor can simply not 
> send any media it doesn't support.

WHich they don't, since it wasn't in the request, unless the codec was
send-only at the caller. 

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 17 Mar 2001 22:58:18 +0200

Hello,

Jonathan Rosenberg wrote:

> streams. What we want here are alternatives.

This is addressed by:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-fid-00.txt

If you guys want me to add an example about this before going to final
call let me know.

Regards,

Gonzalo
-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]