Subject: [lists.ietf.announce] I-D ACTION:draft-kutscher-mmusic-sdpng-req-00.txt,.ps

From: Dirk Kutscher <[email-masked]>
Date: 20 Jul 2000 10:41:17 +0200

Hi,

this is an updated version of the SDP-ng requirements document that
Joerg posted a few days ago.

We have added a description of the system model and the terminology
that is used in the text.

There is an html version at:

http://www.dmn.tzi.org/ietf/mmusic/sdp-ng/draft-kutscher-mmusic-sdpng-req-00.html

-- 
	Dirk

------- Start of forwarded message -------
From: [email-masked]
Newsgroups: lists.ietf.announce
Subject: I-D ACTION:draft-kutscher-mmusic-sdpng-req-00.txt,.ps
Date: 19 Jul 2000 17:13:48 +0200
Organization: mail2news gateway
Message-ID: <[email-masked]>

--NextPart

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Requirements for Session Description and Capability 
                          Negotiation
	Author(s)	: D. Kutscher, J. Ott, C. Bormann
	Filename	: draft-kutscher-mmusic-sdpng-req-00.txt,.ps
	Pages		: 16
	Date		: 18-Jul-00
	
This document defines some terminology and lists a set of
requirements that are relevant for a framework for session
description and endpoint capability negotiation in multiparty
multimedia conferencing scenarios. 
This document is intended for discussion in the Multiparty
Multimedia Session Control (MMUSIC) working group of the Internet
Engineering Task Force.  Comments are solicited and should be
addressed to the working group's mailing list at [email-masked]
and/or the authors.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kutscher-mmusic-sdpng-req-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-kutscher-mmusic-sdpng-req-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-kutscher-mmusic-sdpng-req-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

--NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

--OtherAccess
Content-Type: Message/External-body;
	access-type="mail-server";
	server="[email-masked]"

Content-Type: text/plain
Content-ID:	<[email-masked]>

ENCODING mime
FILE /internet-drafts/draft-kutscher-mmusic-sdpng-req-00.txt

--OtherAccess
Content-Type: Message/External-body;
	name="draft-kutscher-mmusic-sdpng-req-00.txt";
	site="ftp.ietf.org";
	access-type="anon-ftp";
	directory="internet-drafts"

Content-Type: text/plain
Content-ID:	<[email-masked]>

--OtherAccess--

--NextPart--

------- End of forwarded message -------

---

From: Thomas LEVY <[email-masked]>
Date: Thu, 17 Aug 2000 18:39:29 +0200

Hi,

First, I must confess that I am not very confident with SDP.
So perhaps, my question will seem rather evident or confused.

In the current version of the draft SDPng, it is mentioned:
"In case of video transmission, a JPEG-based still image protocol may be used, H.261
encoded CIF images could be sent as could H.261 encoded QCIF images. All three cases
constitute
different configurations. Of course there are many more detailed protocol parameters.
.."

It points out that the format of the image (such as CIF, QCIF..) is a determining
parameter for some video codecs (such as H.261).
But as I look to RFC 2327 (SDP) and RFC 2038 (RTP Profile for Audio and Video ...) ,
I can't imagine how such a parameter is currently negotiated in SDP.
If we suppose user A and user B aiming at videoconferencing.
What happen if A wants CIF and B wants QCIF :
    -Will A sends RTP packets with CIF and B sends RTP packets with QCIF (thus,
having non symetrical transmission) ?
    -Is there some kind of negotiation mechanism in RTP/RTCP (just an eventuality)?
- May we correlate bandwidth information in SDP to determine the format?

Or last proposition:
Is it a known identified lack in SDP, that you intend to solve with SDPng?

Comments welcome,

Thomas LEVY,