Subject: RE: ATM SDP draft 0.03

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Jun 2000 17:52:39 -0400

I'll look closely at the draft over the next several days.
 
In Megaco, we use SDP much more intensively for configuration negotiation.
To support this,
the MGC (call agent) can send a partially specified SDP to the MG (gateway).
When it encounters this, the MG can select any value it can
support.  The fully specified SDP is then returned to the MGC.
 
There are two ways to "underspecify".  One is CHOOSE ($).  This
is the same as MGCP - it means you may pick any value you can support.
The other is "alternatives", which are coded like {1,2,3}.  This means
choose any of the listed alternatives you can support.
 
The dB range is due to the equivalent in "native" annex C, which supports
a 16 bit value.   Overkill, most definitely.
 
Brian

-----Original Message-----
From: Rajesh Kumar [mailto:[email-masked]]
Sent: Monday, June 12, 2000 5:43 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: ATM SDP draft 0.03

Team,
Attached is an updated version (0.03) of the ATM SDP draft. It has all your
comments
factored in (and I mean all of them :-)

The document is missing page numbers, which will not be added until the IETF
submission
draft (0.04). Since I do not know of a good way to convert word processor
files into
plain text, I am editing a plain text document and I need to insert Page #s,
formatting
etc. manually.

I plan to issue another draft following your next round of comments. This
next
draft (0.04) will be presented to the IETF with (possible) final call at the
Pittsburgh meeting. Since I need to generate and submit the next draft
(0.04) by
the IETF cut-off date of July 10, I would appreciate your prompt review of
the
attached document.

I have not been able to comprehend the following statement in the Megaco
draft about
SDP. Could some one explain to me what it means in the context of the
attached SDP 
document? My view is that the "$" wildcard in SDP is equivalent to the
"choose" wildcard
in Megaco. Also, there is no need for the violate SDP syntax in my opinion
(contrary to
what Megaco says):

   "In session descriptions sent from the MGC to the MG, the following
exceptions to the     
    syntax of RFC 2327 are allowed:

   . the use of CHOOSE is allowed in place of a single parameter value,and
   . the use of alternatives is allowed in place of a single parameter
value."

Also, I feel that the decibel range allowed for inserted loss in the Megaco
draft is absurdly large (who needs to insert a loss of 65,535 dB? !!)

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 13 Jun 2000 20:32:08 -0400

For your information, Rajesh, the IETF supplies a Word template at
 http://www.ietf.org/internet-drafts/Internet_Draft_Template.doc

You print the resulting document to file using the "generic text printer"
driver, then run it through the supplied DOS executable crlf.exe to make
sure every CR is paired with a LF.

Brian explained most of what Megaco offers in the MGC->MG direction.  We can
also use inequality constraints on numerical values.  This should probably
save a lot of repeated session descriptions when we want to have MGC-MG
negotiation at the detailed parameter level.

> From:	Rajesh Kumar [SMTP:[email-masked]]
> To:	[email-masked]; [email-masked]
> Attached is an updated version (0.03) of the ATM SDP draft. It has all
> your comments
> The document is missing page numbers, which will not be added until the
> IETF submission
> plain text, I am editing a plain text document and I need to insert Page
> #s, formatting
> etc. manually.
> 
> Also, I feel that the decibel range allowed for inserted loss in the
> Megaco draft is absurdly large (who needs to insert a loss of 65,535 dB?
> !!)
>  << File: ATMsdpWorkingDraft03.txt >>  << File: atmsdpWorkDraft0.03.pdf >>
> << Message:  >>

---

From: Helpdesk MIS <[email-masked]>
Date: Wed, 14 Jun 2000 12:10:04 -0400

>From ; Tom-PT Taylor 

 For your information, Rajesh, the IETF supplies a Word template at 
  http://www.ietf.org/internet-drafts/Internet_Draft_Template.doc
<http://www.ietf.org/internet-drafts/Internet_Draft_Template.doc>  

	-----Original Message----- 
From:   Rajesh Kumar [SMTP:[email-masked]] 
Sent:   Monday, June 12, 2000 5:43 PM 
To:     [email-masked]; [email-masked] 
Cc:     [email-masked]; [email-masked]; [email-masked];

	Team,

---

From: "Mackey, Michael" <[email-masked]>
Date: Wed, 14 Jun 2000 12:21:39 -0400

I'm new to this list so the usual disclaimer but am I right in thinking that
this document is purely for using sdp to control an ATM gateway in a VTOA
case. Has anyone thought about VoIP e.g Annex C ?
 
  "Although   RTP encapsulation defined in rfc1889 is not used, the
   payload type variables are used exactly as defined in rfc1890.
   Hence, the protocols used for VoAAL1 and VoAAL5 are identified as
   AAL1/AVP and AAL5/AVP in the media information line."

Michael Mackey,
Marconi Communications,
Tel: +353 1 2804533
- www.marconi.com <http://www.marconi.com/>  -

-----Original Message-----
From: Rosen, Brian 
Sent: Monday, June 12, 2000 10:53 PM
To: 'Rajesh Kumar'; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: ATM SDP draft 0.03

 

Brian

-----Original Message-----
From: Rajesh Kumar [mailto:[email-masked]]
Sent: Monday, June 12, 2000 5:43 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];

Team,

---

From: Rajesh Kumar <[email-masked]>
Date: Wed, 14 Jun 2000 16:49:53 -0700

>    AAL1/AVP and AAL5/AVP in the media information line."

Michael, VoIP is addressed by rfc2327 (SDP), h.248/megaco, MGCP etc. Everything
is first done for VoIP and then adapted to VoATM. It is VoATM, not VoIP, that
is the step-child of packet telephony.

Having said that, Annex C of H.323 is not VoIP. It is RTP on raw AAL5 with no
intervening IP layer. It does include interoperability with VoIP.

Yes, we have addressed Annex C of H.323 in the SDP extensions document (0.03
revision) that I sent out last week. Please review the parameters therein
against Annex C of H.323 and let me know if I have missed something. The intent
is go attempt to go to standards track in the July Pittsbutgh IETF.

Rajesh

>
>  
>  
> Michael Mackey,
> Marconi Communications,
> Tel: +353 1 2804533
> - <http://www.marconi.com/>www.marconi.com -
>>

+++++++++++++++++++++++++++++
Rajesh Kumar         
 [email-masked]                 
408 527 0811                
Carrier Packet Voice
Cisco Systems, 
San Jose, California
+++++++++++++++++++++++++++++

---

From: "Mackey, Michael" <[email-masked]>
Date: Thu, 15 Jun 2000 05:55:38 -0400

I suppose its my own fault for not being more specific. The problem I've
noticed is I don't see where you specifiy the RTP port(s) in your SDP
description if you want to do RTP/AAL5. The normal place for it is the m=
line with the <port>/<no. of ports> but in your document you specify the m=
line to have the format

"m=audio <virtualConnectionId> AALn/AVP <payloadType#1>
<payloadType#2>...<payloadType #n><portId>/<vpi>/<vci>" 

with <virtualConnectionId> specified as 

        * VCCI-<vcci>
        * <ATMaddressType>-<ATMaddress>/VCCI-<vcci>
        * BCG-<bcg>/VCCI-<vcci>
        * PORT-<portId>/VPI-<vpi>/VCI-<vci>
        * BCG-<bcg>/VPI-<vpi>/VCI-<vci>
        * VPCI-<vpci>/VCI-<vci>

Have I missed something ?

Michael Mackey,
Marconi Communications,
Tel: +353 1 2804533
- www.marconi.com -
-----Original Message-----
From: Rajesh Kumar [mailto:[email-masked]]
Sent: Thursday, June 15, 2000 12:50 AM
To: Mackey, Michael; Rosen, Brian; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]; [email-masked];
Shanahan,Tim; flynn, martin
Subject: RE: ATM SDP draft 0.03

 

Michael, VoIP is addressed by rfc2327 (SDP), h.248/megaco, MGCP etc.
Everything is first done for VoIP and then adapted to VoATM. It is VoATM,
not VoIP, that is the step-child of packet telephony.

Having said that, Annex C of H.323 is not VoIP. It is RTP on raw AAL5 with
no intervening IP layer. It does include interoperability with VoIP.

Yes, we have addressed Annex C of H.323 in the SDP extensions document (0.03
revision) that I sent out last week. Please review the parameters therein
against Annex C of H.323 and let me know if I have missed something. The
intent is go attempt to go to standards track in the July Pittsbutgh IETF.

Rajesh

Michael Mackey,
Marconi Communications,
Tel: +353 1 2804533
- www.marconi.com -

-----Original Message-----
From: Rosen, Brian 
Sent: Monday, June 12, 2000 10:53 PM
To: 'Rajesh Kumar'; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];

 

Brian

-----Original Message-----
From: Rajesh Kumar [mailto:[email-masked]]
Sent: Monday, June 12, 2000 5:43 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];

Team,