Subject: Re: [SIP] ipv4 addresses in SDP

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Aug 2000 10:58:58 -0400

[email-masked] wrote:
> 
> On Thu, 17 Aug 2000, Jonathan Rosenberg wrote:
> 
> >SDP queries belong on [email-masked].
> 
> Thanks, I'll post it there.
> 
> >The BNF is correct. You need to examine complete production for
> >decimal-uchar:
> >
> >>  decimal-uchar =       DIGIT
> >>                          | POS-DIGIT DIGIT
> >>                          | ("1" 2*(DIGIT))
> >>                          | ("2" ("0"|"1"|"2"|"3"|"4") DIGIT)
> >>                          | ("2" "5" ("0"|"1"|"2"|"3"|"4"|"5"))
> >
> >The production defines one of five rules; the first covers the numbers
> >0-9. The second covers 10 through 99.
> 
> >The thrid 100 through 199 (thus a 1 followed by two digits),
> 
> Right, but the third production also allows
> 1000 through 1999, 10000 through 19999 ...
> 
> That is, it doesn't restrict the length of decimal-uchar to three
> digits like the fourth & fifth productions do, does it?

Oops, you're right. This BNF is wrong; it should be:

...
| ("1" 2DIGIT)
...

This should be corrected in the draft version.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: James Undery <[email-masked]>
Date: Fri, 18 Aug 2000 16:02:50 +0100

> Oops, you're right. This BNF is wrong; it should be:

Shouldn't this be | ("1" 2*2(DIGIT))

James Undery

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Aug 2000 11:21:53 -0400

According to rfc2234:

> Specific Repetition                                  nRule
> 
>    A rule of the form:
> 
>         <n>element
> 
>    is equivalent to
> 
>         <n>*<n>element
> 
>    That is, exactly  <N>  occurrences  of <element>. Thus 2DIGIT is a
>    2-digit number, and 3ALPHA is a string of three alphabetic
>    characters.

Thus, Nelement and N*Nelement are the same.

-Jonathan R.