Subject: Re: Regarding SDP Media level description

From: "Kartick" <[email-masked]>
Date: Thu, 15 Apr 1999 09:53:49 +0530

hi! Mark

Some lines in each description are required and some
   are optional but all must appear in exactly the order given here (the
   fixed order greatly enhances error detection and allows for a simple
   parser). Optional items are marked with a `*'.

Media description

m= (media name and transport address)

i=* (media title)

c=* (connection information - optional if 

here "m" does not have a star before it hence it 

is mandatory or that is what I feel

regards 

kartick

-----Original Message-----
From: Mark Handley <[email-masked]>
To: Kartick <[email-masked]>
Cc: confctrl <[email-masked]>
Date: Thursday, April 15, 1999 2:27 AM
Subject: Re: Regarding SDP Media level description 

>
>>hi! I have a doubt regarding Media Level description
>>
>>The RFC 2327 states that
>>   "An announcement consists of a session-level section followed by zero
>>   or more media-level sections. " [page no:7]
>>
>>If so then how is it possible to declare "m=" as a mandatory
>>parameter when there is a possibility of the field "m="
>>not being there.
>
>Where does it say "m=" is mandatory?  Both page 8 that you quoted and
>the ABNF state zero or more media descriptions.
>
>Cheers, 
> Mark
>

---

From: Mark Handley <[email-masked]>
Date: Thu, 15 Apr 1999 00:36:09 -0700

>m=3D (media name and transport address)
>
>i=3D* (media title)
>
>c=3D* (connection information - optional if=20
>
>here "m" does not have a star before it hence it=20
>

Well, yes and no.  Within a media description it's mandatory, but
media descriptions themselves are optional within a session
description.  Thus a session description does not have to contain any
"m=" fields.

Hope this clears things up!

Cheers,
	Mark