Subject: Re: confctrl BOF template

From: schooler
Date: Tue, 23 Mar 1993 00:24:23 -0800

----- Begin Included Message -----

---

From: schooler
Date: Tue, 23 Mar 1993 00:27:32 -0800

----- Begin Included Message -----

---

From: Thierry TURLETTI <[email-masked]>
Date: Mon, 29 Mar 93 17:23:25 +0200

Conference Control BOF Template
    		    -------------------------------

    1. Program name: "IVS" (Inria Videoconferencing System)

    2. Contact person, affiliation and e-mail address.

	Thierry Turletti  
	INRIA Sophia Antipolis
	RODEO Project
        [email-masked]

    3. Target operating environment and key design considerations:

	* Both LAN and WAN
	* digital audio and video media
	* packet technology
	  IP multicast extensions used on top of UDP
	* H.261 software video codec.

   4.a Type of conference styles supported by your system/protocol.

	* Point to point. A daemon is running at each side to
	   simulate a phone call.

	* small size conference (less than 10 participants)
	   --> feedback from decoders allowed. (NACK, Full Intra Request)

	* large size conference 
	   --> no feedback from decoders

    4.b Profile of user community: 

	No expertise level required.
	Freely available in the public domain. 

    5. Architecture assumptions: 

	* Distributed model. A single session manager resides at each 
	  participant side. It is responsible for a particular user of 
	  audio/video encoding/decoding options.

	* The session manager must choose the correct options
          according to the type of conference and the network conditions.
	  For example, it has to decide if feedback from decoders
	  is allowed, if knowledge of the whole participants is possible.
	  The bandwidth used is tunable during ongoing sessions. 

    6.a How do you define conference control?

        Managing sessions, users in a session and media used. (Some
        media have more priority than others)

    6.b Conference control functionality supported.

	The following packets are currently used:

	- Description (name, audio/video encoding, feedback allowed/avoided)
	- Bye : The participant is leaving
	- Hello : A new participant requires a rapid description of
	          the other parts. Ignored if feedback is avoided.

	Feedback from decoders: avoided or allowed according to
	the number of participants in the conference. This option
	can be changed during ongoing sessions.

    6.c Other control functions you would like to support.

	- merging conferences.
	- QOS control to find the maximal bandwidth allowed.
	- interaction between media to privilege for example audio
	  quality rather than video.

    7. Conference control protocol details: 

	Implicit setup.
	  For a small conference, an "HELLO" packet can be sent to 
	  force each participant to describe itself quickly.

	Each participant send periodically to the group its state
	and keep up to date each member's current state list. A member
	is considered as having left the conference if he stops sending 
	its state.

	Robustness: When feedback information is allowed, video decoders 
	could send to their video sources NACK information and Full
	image encoding request (a kind of all refresh). In this mode,
	the first image received will be full encoded, and effects of
	packet loss reduced. 
          Else, when no feedback, the video coding will force
	encoding of all blocks more often and will limit the
	number of successive "inter" encoding blocks. ("inter"
	means that only the difference between two successive images
	is encoded. Use of the "inter" mode increases the compression rate
	but also increases sensibility to packet lost).

    8. Hardware/software platforms.

	X11 - Athena toolkit. IP multicast extensions required.

	Current experiments are done on Sparc, HP, SGI and DEC stations.

	Video framegrabbers used are: VideoPix, Parallax, Indigo board,
				      Raster Rops and VIDEOTX.

    9.a What specifically has or has not been implemented?

	All conference control functions mentioned are implemented. The
        "Avoid feedback" mode hasn't been well tested yet over WAN
 	with a lot of participants.

	The bandwidth tuning should be automatically adapted to
	the network conditions.

    10. If available, suggested readings about your work on confctrl.

	The following report describing the previous IVS version is
	available by anonymous ftp from avahi.inria.fr in directory
	/pub/videoconference:

	"H.261 software codec for videoconferencing over the Internet'',
	INRIA Research Report no 1834, Sophia Antipolis, January 1993.