Subject: Re:

From: [email-masked]
Date: Fri, 14 May 1999 00:41:12 -0400 (EDT)

Cc:  
           [email-masked]

Bcc: 
Subject: Basic Questions in SIP

Hi all,

Iam a beginner to SIP.I was going through the RFC2543,
I have some basic doubts:

1) Is it mandatory for all UAC to REGISTER or be 
registered to any SERVER (proxy,redirect) so that
it can be contacted.

2) How does a SERVER send 1xx,2xx responses.

3) Does any UAC receive INVITE or other requests
if so how does it reply.

please bear with me if u find the questions very
silly?

thanks in advance

Ram

---------------------------------------------------
Get free personalized email at http://www.iname.com

---

From: Christian Gosselin <[email-masked]>
Date: Fri, 14 May 1999 11:08:26 -0400

>registered to any SERVER (proxy,redirect) so that

The UA is responsible for the registration and the request is sent by the
UAC. If your last registration is not expired then it's not necessary to
register again. If your not registered anywhere I don't see how you could
receive invitation, as mention in the rfc2543 p.34 "the support for the
REGISTER is RECOMMENDED".

>2) How does a SERVER send 1xx,2xx responses.

not sure I understand the question.

>3) Does any UAC receive INVITE or other requests

UAC don't receive request they send them. All received request (INVITE,
ACK, BYE, OPTIONS and REGISTER) are handle by servers (redirect, proxy or
UAS). Read: Requirements for SIP Servers and User Agents. If the call is
successful the recipient (UAS) of an INVITE responds by a 200 OK.

>please bear with me if u find the questions very

=======================================
Christian Gosselin
Laboratoire téléinformatique de l'UQAM
[email-masked]
http://www.info.uqam.ca/~gosselin
987-3000 #6189