Subject: Re: confused about identifying RTSP ses

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 15:18:35 -0400

> using it ?
> 
> The current spec mentions three different identifiers
> 
> 1) the "session" header
> 2) HTTP state management
> 3) unique URLs generated dynamically (in Appendix A: "A server may choose to
>   generate dynamic presentation descriptions where the URL is unique for a
>   particular RTSP session and thus may not need an explicit RTSP session
>   identifier in the request header")

Thanks for pointing this out. Points 1), 2) are easy to clear up. 2) was
mentioned as an alternative to 1) and the choice between them was an
open issue at Memphis. This was decided in favour of 1). Hence the
Session: header will be sole identifier of a RTSP session across
transport connections. The references to HTTP state maintenance will go
away in the next draft.

At the time of the March 29th draft, we were debating on the means of
identifying sessions accross connections and client endpoints. As such,
3) (which might still work) seems to be an  overloading of URLs without
apparent gain. In the next draft, we should have a *clear and concise*
definition for session identification and that will be 1)(The Session:
header).

> On the other hand, most of the example requests in the document
> do not contain any way to identify a session, which seems to
> imply that identifying the session is something which is optional.
> 

The first example is pretty detailed, and has the Session: headers. The
others do not, (but I do believe that they mention that some of the
responses/headers are excluded for simplicity). We will take care of of
this in the next draft.

Regards,
-- 
-----------------------------------------------------------------
  Anup Rao                                                      
  Netscape Communications Corp.                   
  email : [email-masked]         Phone : (415) 937 3129       
-----------------------------------------------------------------

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],
        [email-masked], [email-masked]
Subject: Re: confused about identifying RTSP sessions
References: <[email-masked]>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk

---

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 17:15:37 -0400

Regards,

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked], [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 15:18:35 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

---

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 19:01:56 -0400

Regards,

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked], [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 15:18:35 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 17:15:37 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

---

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 20:16:41 -0400

Regards,

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked], [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 15:18:35 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 17:15:37 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 19:01:56 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

---

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 21:39:08 -0400

Regards,

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked], [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 15:18:35 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 17:15:37 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 19:01:56 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 20:16:41 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

---

From: [email-masked] (Anup Rao)
Date: Fri, 23 May 1997 23:44:13 -0400

Regards,

------ Message Header Follows ------
Date: Fri, 23 May 1997 10:07:38 -0700
From: Anup Rao <[email-masked]>
Organization: Netscape Communications Corp.
To: Philipp Hoschka <[email-masked]>
Cc: [email-masked], [email-masked], [email-masked],
[email-masked],

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked], [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 15:18:35 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 17:15:37 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 19:01:56 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 20:16:41 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]

------ Message Header Follows ------
From: [email-masked] (Anup Rao)
To: [email-masked] (goncalves),
        [email-masked] (Philipp Hoschka)
Cc: [email-masked] (confctrl), [email-masked] (osofia),
        [email-masked] (abaird), [email-masked] (robla),
        [email-masked] (hgs), [email-masked] (anup)
Organization: Process Software Corporation
Date: Fri, 23 May 1997 21:39:08 -0400
Subject: Re: confused about identifying RTSP ses
Sender: [email-masked]