Subject: RE: SIP Provisional Responses

From: Eric Tremblay <[email-masked]>
Date: Wed, 20 May 1998 10:22:40 -0400

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: 19 mai, 1998 20:20
> To: Eric Tremblay
> Cc: 'Jonathan Rosenberg'; [email-masked]'
> Subject: Re: SIP Provisional Responses
> 

[ - deleted - ]

> Unfortunately, the alternative of acknowledging 1xx responses would
> greatly complicate the state machinery.
>
> Currently, either client or server can, if they so desire and are
> willing to suffer the network traffic and server load 
> consequences, get
> semi-reliable status updates:
> 
> 1) The client can retransmit INVITE more frequently. This is 
> against the
> rules, but otherwise causes no interoperability problems.
>
> 2) The server can retransmit 1xx responses periodically.

I'm sure that one of these solution will do just fine, as long as it
causes no interoperability problems and as long as the network
ressources are not overloaded.

> For non-technical users, the difference between Trying and 
> Ringing isn't
> all that great - certainly not something that the standard telephone
> tones (ring-back in either case) could express.

I don't think we'd want to use ringback for both 100 and 180 responses.
I'd use ringback only when I receive a 180 response, not before.  This
is to avoid having a scenario where a client gets a ring back (100) and
then a busy or fast busy signal...  ( response > 200 )  This doesn't do
a good emulation of the PSTN and I'm always thinking that the transition
from PSTN to IP should be as smooth as possible for the current PSTN
users. 

EricT

Eric Tremblay       | Mediatrix Telecom
Ingénieur Stagiaire | -----------------
email: [email-masked]
Tel: +1(819)829-8749 ext. 238
Web: www.mediatrix.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 May 1998 13:38:19 -0400

Eric Tremblay wrote:

> from PSTN to IP should be as smooth as possible for the current PSTN

You may get a fast-busy or busy after a 180 anyway. Consider a UAC which
sends an INVITE, and gets back a 100, then a 180, and then begins
ringback. The UAS alerts the user, and then the user rejects the call
(600). The UAC will then need to play the busy or fast-busy anyway. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       Lucent Technologies
Member of Technical Staff                   101 Crawfords Corner Rd.
High Speed Networks Research                Holmdel, NJ 07733
FAX:   (732) 834-5379                       Rm. 4C-526
EMAIL: [email-masked]
URL: http://www.cs.columbia.edu/~jdrosen