Subject: Re: draft-olson-sdp-ipv6-02.txt

From: [email-masked]
Date: Thu, 25 Oct 2001 13:45:32 +0200

Let me check I understand this "alternate" syntax.

Would it be possible to describe a given content (say a movie)
as being available in several "flavors", any or all of
the following examples:

* italian versus french sound track
* different bit rate
* different codec

?

Regards,

Philippe Gentric
Software architect
Philips Digital Networks - MP4Net
51 rue Carnot B.P. 301
92156 Suresnes FRANCE
tel: +33(0)147283740
fax: +33(0)147283725
[email-masked]
http://www.mpeg-4.philips.com

Sent by:        [email-masked]
To:     <[email-masked]>
cc:      (bcc: Philippe Gentric/LIM/CE/PHILIPS)
Subject:        Re: draft-olson-sdp-ipv6-02.txt
Classification: 

In message <[email-masked]> Christer Holmberg 
<[email-masked]> writes:
>First, it's not only about the address. We may also have separate
>attributes, which may have different values depending on if they are for
>IP4 or IP6. In that case we would have to use "a=altC:a=<whatever>" for
>those.

                 I agree on these, so a group attribute seems to be a 
superior
                 solution for the dual-stack problem.  However, the 
current FID
                 semantics are not exactly what we want.  Should we define 
a new
                 group semantics like "ALT" (see below)? 

  Pekka

v=0
o=- 38973621 6 IN IP6 3ffe:1200:3012:c006:290:27ff:fe7d:d024
s= 
a=group:ALT ip4 ip6
m=audio 6000 RTP/AVP 96 97 99
c=IN IP6 3ffe:1200:3012:c006:290:27ff:fe7d:d024
a=mid:ip6
a=rtpmap:97 AMR/8000
a=fmtp:97 mode-set=4,5,6 interleaving crc vad=on use-redundancy=1
a=rtpmap:99 AMR/8000
a=fmtp:99 mode-set=8
a=rtpmap:96 AMR-WB/16000
m=audio 6000 RTP/AVP 96 97 99
c=IN IP4 172.21.40.44
a=mid:ip4
a=rtpmap:97 AMR/8000
a=fmtp:97 mode-set=4,5,6 interleaving crc vad=on use-redundancy=1
a=rtpmap:99 AMR/8000
a=fmtp:99 mode-set=8
a=rtpmap:96 AMR-WB/16000

---

From: Pekka Pessi <[email-masked]>
Date: 25 Oct 2001 16:01:53 +0300

>as being available in several "flavors", any or all of

	My idea of ALT group was to provide the same media stream using
	alternative transports, like IP, IPv4, ATM or 767 loaded with
	CDs.

>* italian versus french sound track

	What about using i= line and/or a=lang:IT v. a=lang:FR?

>* different bit rate

	Streams using different bitrates should be sent to different
	multicast groups.  There can be multiple c= lines in media
	description, one for each group.

>* different codec

	FID semantics allow that.

	Best regards,
					Pekka Pessi