Subject: RE: [sdp-ng] Re: Encoding SDPng messages using UMF

From: "Mark Watson" <[email-masked]>
Date: Wed, 6 Jun 2001 18:16:55 +0100

> 
> 
> Jeff,
> 
> I'm afraid I don't really buy the compression argument.  If size is
> important to you than you are prepared to use compression, 
> then you can
> compress any protocol, including UMF.  I would rather start off with a
> smaller encoding and avoid the extra step.  Indeed, 
> compression seems to
> defeat one of the advantages of text encoding, and that's 
> easy sniffing and
> viewing of messages on the wire.  After all, a compressed encoding is
> effectively a binary encoding.
> 

Depends if your compression is content aware. If you have a hand-crafted
compression scheme for a particular protocol, then it's just a binary
encoding. But if you have a generic compression algorithm which does not
vary with different versions of the protocol, then you just need to put the
decompression algorithm in your sniffers.

> As for XSL, I think we should try and get some practical 
> experience with it
> as a sort of feasibility study ASAP.  I don't think it is 
> going to be as
> easy to use as it might first appear.  If Dirk has then, it 
> would be good to
> see them so that I can attempt to do a UMF equivalent.  It 
> would be good to
> know what the tools status is for it also.
> 
> Also, an XSL parser is likely to be something in addition to 
> an XML parser.
> Therefore having an XSL parser extension plus an XML parser 
> is likely to be
> no better than having an XML parser plus a UMF parser.  After 
> all, XSL =
> YAPS also.
> 
> Pete.
> 
> =============================================
> Pete Cordell
> Tech-Know-Ware
> [email-masked]
> +44 1473 635863
> =============================================
> 
> ----- Original Message -----
> From: Jeff Ayars <[email-masked]>
> To: Pete Cordell <[email-masked]>; Dr. Carsten Bormann
> <[email-masked]>; Dirk Kutscher <[email-masked]>;
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: 05 June 2001 20:47
> Subject: Re: Encoding SDPng messages using UMF
> 
> 
> > XML may not be the most efficient syntax from a bytes used 
> perspective but
> > it is regular and WIDELY understood.  Compression a-la zlib 
> in RFC 2974
> for
> > SDP compression in SAP or WAP Binary XML representation should be
> > considered for byte efficiency.
> >
> > XSL solves the data type problem in another existing standard way.
> >
> > I already have an XML parser in my product.  YAPS (Yet 
> Another Protocol
> > Syntax) == YAPP (Yet another protocol parser).  I don't 
> want to bloat my
> 
> > product with YAPP.
> >
> > JEff
> >
> >
> 
> 
> To unsubscribe from this group, send an email to:
> [email-masked]
> 
>  
> 
> Your use of Yahoo! Groups is subject to 
> http://docs.yahoo.com/info/terms/ 
> 
> 
>

---

From: John Lazzaro <[email-masked]>
Date: Fri, 8 Jun 2001 11:00:49 -0700

> "Christian Huitema" <[email-masked]> writes
>
> The main inconvenient of XML is that it can be bulky. I am not convinced
> that this is an actual problem: SDP is used for describing multimedia
> sessions, that normally last a few minutes and carry at a minimum
> several tens of kilobytes of media; the media stream dwarfs the
> signaling stream by orders of magnitude.

If the size of the SIP header + the size of the XML-encoded 
SDPng message is greater than the MTU, then using UDP for SIP 
transactions means fragmentation of SIP UDP packets becomes
commonplace. I'm not familiar with just how inefficient XML 
really is, but if XML-encoded SDPngs are approaching the 
1500 byte Ethernet MTU, I believe there is cause for concern ...

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------