Subject: Compact names

From: Vincent Mouilleron <[email-masked]>
Date: Thu, 03 Jun 1999 23:03:46 -0500

I am maybe not enough familiar with the protocol, so let me know if I am
defenetaly wrong, but I would like to make a comment :

SIP only initiates the session. That means that a flow of data is going
to follow the SIP message.
What I do not understand is that if you can not afford spending a few
microseconds to perform a strcmp, how can you expect to manage the data
flow ?
I mean, the time required in executing a strcmp is unrelevant compare to
the time the session is going to last. And it seems that the more
important the traffic will be, the more unsignificant the SIP message
treatment time will be.

Am I right ?

-- 
Vincent Mouilleron

Corporate Research Center
Alcatel U.S.A. 
1201 East Campbell Road         | Tel : (1) 972-996-7439
M/S 446-310                     | Fax : (1) 972-996-5902
75081-1936 Richardson, TX. USA. | E-mail : [email-masked]

---

From: Mark Grosen <[email-masked]>
Date: Fri, 04 Jun 1999 11:16:08 -0700

I think that some people are making an incorrect assumption
about control and media being tied together. If I am building
a "switch" (ala PBX) or in SIP terms, a proxy or redirect
server, my device never sees the data following the session
initiation. Devices like this are rated in terms of the
number of calls they can handle per unit time. So, if I can
parse the headers faster, I can handle more calls. How
much faster is in my mind an open question. The old "90-10"
rule still holds in terms of optimization: optimizing the
10% part does not yield much benefit.

However, Scott's application may be special and all he needs
to do is look at the fields like CSeq: and ignores what follows
which is why he wants the x: short-form. I don't know
what that application might be, so I am still in favor of
quantifying the potential improvements (and hence justifying) 
before modifying the spec.

Mark Grosen
Dialogic Corporation
[email-masked]
V: 805 964-5083 F: 805 967-1395
http://www.dialogic.com

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Vincent Mouilleron
> Sent: Thursday, June 03, 1999 9:04 PM
> To: [email-masked]
> Subject: Compact names
> 
>

---

From: Emmanuel Bertrand <[email-masked]>
Date: Mon, 07 Jun 1999 10:15:13 +0200

Vincent,

The path followed by SIP messages has nothing to do with the path followed
by voice (media) packets.  Across the network, SIP messages are processed by
SIP servers (at application level) while voice packets are processed by
routers (i.e. at network level).  This is an illustration (among others) of
the orthogonality between signaling and media transport in IP telephony.  In
the discussions of  Henning, Jonathan and Scott, the concern is to make the
signaling process as fast and effective as possible, regardless of the
transport and routing of voice packets that may come after.

Hope this helps,

Manu

--
---------------------------------------------------------------
Emmanuel Bertrand
Alcatel - Corporate Research Center
Network Architecture Department
F. Wellesplein 1   B-2018 Antwerp - Belgium
Phone : +32 3 240 97 35 - Fax : +32 3 240 99 32
Alcanet : (+60) 59735 - Email : [email-masked]
http://www.rc.bel.alcatel.be/projects/Internet/VoIP/
---------------------------------------------------------------