Subject: RE: Comments on <draft-rosenberg-mmusic-sdp-offer-answer-00.txt>

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 5 Dec 2001 01:59:01 -0500

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: Wednesday, December 05, 2001 1:36 AM
> To: Jonathan Rosenberg
> Cc: 'Flemming Andreasen'; Henning Schulzrinne; MMUSIC
> Subject: Re: Comments on
> <draft-rosenberg-mmusic-sdp-offer-answer-00.txt> 
> 
> 
> --> Jonathan Rosenberg writes:
> ...
> >> - Section 2 mentions that SDP allows for concatenation of multiple
> >> session descriptions. I can't seem to find this in the SDP 
> >> spec - where
> >> does it say that ?
> >
> >Page 7:
> >
> >   When SDP is conveyed by SAP, only one session description 
> is allowed
> >   per packet.  When SDP is conveyed by other means, many SDP session
> >   descriptions may be concatenated together (the `v=' line 
> indicating
> >   the start of a session description terminates the previous
> >   description). 
> 
> This was one of the changes in sdp-new: SDP is now silent on 
> the issue of
> concatenation, since that seemed more appropriately specified 
> as part of
> the transport of SDP.
> 
> Are people happy with this change? I can revert it if not...

I think thats good. This fits well with offer-answer, which basically says
that for O/A transport, its not used.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 06 Dec 2001 04:32:43 -0500

> that for O/A transport, its not used.

I agree, not least considering that the meaning of concatening multiple
session description is not specified in SDP itself and hence will be
application specific anyway.

-- Flemming

--
Flemming Andreasen
Cisco Systems