Subject: RE: RTSP session model

From: Eric Fleischman <[email-masked]>
Date: Thu, 10 Jul 1997 09:44:43 -0700

I'm sorry, Henning, but I believe that you made a mistake in your
posting for the 2+1 example.

Since audio and video are in the same transport stream in this example,
they are a "presentation". This means that RTSP must treat them as a
"unit". Thus, one can not pause audio (in this example) without also
pausing video. Of course, since audio/video are a separate transport
connection than animation, one can naturally control the audio/video
stream independently from the animation stream by the same RTSP control
session, which is what (I trust) you had meant to show.

In any case, I am pleased that the community seems to be forming a
consensus that 1-1-1 and 1-1-N are worthy targets for RTSP.

> -----Original Message-----
> From:	Henning Schulzrinne [SMTP:[email-masked]]
> Sent:	Wednesday, July 09, 1997 12:41 AM
> To:	Alagu Periyannan
> Cc:	[email-masked]; Rob Lanphier; Anup Rao
> Subject:	Re: RTSP session model
> 
> 
> (2+1) audio and video are together (maybe MPEG or some container
> format), animation is separate:
> 
>   SETUP movie
>   Session: 123
>   Streamid: audio, video
>   Transport: rtp/udp
> 
>   SETUP movie
>   Session: 123
>   Stremaid: anim
>   Transport: tcp
> 
>   PLAY movie
>   Session: 123
>   Streamid: audio, video, anim
> 
>   # pauses delivery of the animation and audio
>   PAUSE movie
>   Session: 123
>   Streamid: anim, audio
> 
>   # pauses delivery of the video
>   PAUSE movie
>   Session: 123
>   Streamid: video
> 
>   # resume delivery of audio, video, animation; we don't need
>   # the streamid here since it's the whole session
>   PLAY movie
>   Session: 123
> 
>   # tear down video (don't ask me why the client does this...):
>   TEARDOWN movie
>   Session: 123
>   Streamid: video
> 
>   # tear down the remaining streams:
>   TEARDOWN movie
>   Session: 123
> 
>

---

From: Stephen Casner <[email-masked]>
Date: Fri, 11 Jul 1997 14:35:12 -0700 ()

Eric,

> posting for the 2+1 example.

I agree that some details of Alagu's and Henning's messages were not
right.  But:

> pausing video.

I agree with the last sentence, but I don't think having the audio and
video in the same transport stream makes them a "presentation".  From
RTSP's point of view, the multiplexed transport stream is just the
same as a monomedia transport stream.  In this example, I would say
the presentation is the combination of the multiplexed A/V stream plus
the animation stream.  Those two streams should be separately
controllable, but as I mentioned in a previous message, I don't see
how the presentation control is supposed to work.
							-- Steve