Subject: RE: A few questions on REGISTER

From: Anurag Vohra <[email-masked]>
Date: Wed, 29 Sep 1999 21:12:24 +0530

Hi, 

> Anoop Tripathi wrote:
> >
> > If the protocol had an UNREGISTER message , this problem could be bypassed by
> > implementing
> >
> > " UNREGISTER to all registered clients on a shutdown."
> >
> > Now all the unregistered clients keep trying to register and when the server
> > comes up , the system is up and running.
> >
> > However, the problem still remains for systems which do not use the UNREGISTER
> > message. ( Well what do you get when you implement
> > something partially ?).
> >
> > Also, the problem still remains in case a Registrar/Proxy server crashes (
> > without sending  UNREGISTER messages ) and then comes up to
> > find the Registration DB corrupt?
> 
> This is the part I find confusing. Why is your old registration database
> corrupt? If you have a flakey drive, you shouldn't depend on the
> protocol to get around your hardware problems.
> 
> In any case:
> 
> 1. sending UNREGISTER to each registered user individually doesn't work.
> You'll miss people who register during the transition period, or that
> are temporarily disconnected. It also doesn't scale well, as you'll get
> tons of responses.
> 
> 2. sending a multicast type of UNREGISTER also doesn't work, since you
> can't get responses (implosion problem), and then you won't know if it
> worked or not.
> 
> The best way to handle this is to use SRV records to point to your
> backup server, wait for DNS ttls to expire, and then take down the
> primary. By then, everyone is using the backup. Also, multicast
> registrations are a huge benefit here also. Don't try to handle backups
> by telling ALL your clients about it, and hope they pick up the new
> backup.

Can we do the following as an alternative - 

  The registrar server apart from storing in its local memory store the information in a directory server using LDAP. All new registrations are also updated there. One can restart any time for maintenace without losing any info. Or use a another back up server which can always read the current information from the directory server. Keeping it in one place will also help in sharing registration information between proxy server. I don't know whether this is a requirement, but feel this also can have a use.  
  
Regards,
Anurag Vohra

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 29 Sep 1999 13:32:36 -0400

>   The registrar server apart from storing in its local memory store the information in a directory server using LDAP. All new registrations are also updated there. One can restart any time for main…

How you implement your system is your choice. Handling directories and
data storage has nothing to do with SIP. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       Lucent Technologies
Member of Technical Staff                   101 Crawfords Corner Rd.
High Speed Networks Research                Holmdel, NJ 07733
FAX:   (732) 834-5379                       Rm. 4C-526
EMAIL: [email-masked]
URL: http://www.cs.columbia.edu/~jdrosen