Subject: RE: G.729a packet size

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 18 Jan 2001 15:24:47 -0500

Actually, its 20 for IP, 12 for RTP, 8 for UDP, for a total of 40 above L2.

-Jonathan R.
  
-----Original Message-----
From: James M. Polk [mailto:[email-masked]]
Sent: Wednesday, January 17, 2001 12:53 PM
To: [email-masked]; [email-masked]
Subject: Re: G.729a packet size

Aparna

I think its 40 bytes for UDP/RTP, plus 20 bytes for the IP header and
whatever L2 you have (~ 20 more bytes for Ethernet).... this is all without
header compression of any kind

At 09:57 AM 1/17/2001 -0700, [email-masked] wrote:
>Does anyone know what the default and/ or most commonly used packet size
for
>G.729a is? I know that the ITU-T spec specifies a frame size of 10 ms; but
>the number of frames that normally make a packet (1 or 2?) is not clear to
>me. 
>Thanks,
>Aparna
>
>Aparna V.
>Level (3) Communications.

----
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "David Oran" <[email-masked]>
Date: Thu, 18 Jan 2001 15:46:40 -0500

G.729 frame size is 10 bytes. Each frame is 10ms of packetization period. Few people put less than 2 frames/packet, that's why the number 20 keeps popping up.

Dave.

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Jonathan Rosenberg
> Sent: Thursday, January 18, 2001 3:25 PM
> To: 'James M. Polk'; [email-masked]; [email-masked]
> Subject: RE: G.729a packet size
> 
> 
> I think its 40 bytes for UDP/RTP, plus 20 bytes for the IP 
> header and whatever L2 you have (~ 20 more bytes for 
> Ethernet).... this is all without header compression of any kind
> 
> 
> >G.729a is? I know that the ITU-T spec specifies a frame size 
> of 10 ms; 
> >but the number of frames that normally make a packet (1 or 
> 2?) is not 
> >clear to me. Thanks, Aparna
> >
> >Aparna V.