Subject: PLAY with range header

From: Alagu Periyannan <[email-masked]>
Date: Fri, 18 Jul 1997 14:55:47 -0700

Hi all,

A PLAY method with a range header causes the server to
start playing at the beginning of that range. While the server
is playing, if it receives another PLAY method with a range
header, then the server queues this up to play after the
first range is done. This scheme is unambiguous for
single stream sessions.

When we have multi-stream sessions, there are two
ways of playing the presentation - using a single PLAY
or with one PLAY per stream. If we use one PLAY per
stream and include the range header in each PLAY
then it is unclear what the server must do. The RTSP
spec. must clarify this. The following are the 2 choices,

1. The server starts playing each stream at the beginning
of the range specified in the range header in each of the
PLAY methods.

2. The server queues each of the subsequent PLAYs so that
they are played after the previous PLAY is completed.

I prefer solution 2 since it is more in line with the
rules for single stream sessions.

By going with solution 2, a client that wants to use
multiple PLAYs for a multi-stream session
will need to send the 2nd, 3rd ... PLAYs without
range headers. This would cause the server to
add them on and start playing them along with
the other streams that are already playing.

---------------------------------------------------
Alagu Periyannan                   [email-masked]

Interactive Multimedia Group
Apple Computer, Inc.

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 19 Jul 1997 10:35:54 +0200

Alagu Periyannan wrote:
> then it is unclear what the server must do. 

A session defines a common, "synchronized" time axis for all streams
within that session. If you play a single media, this would indicate
that time progresses for all at the same rate, just that media isn't
delivered to the client. Otherwise, you lose sync. 

The RTSP
> rules for single stream sessions.

Agreed.