Subject: sdr: relaying between sessions

From: Jon Crowcroft <[email-masked]>
Date: Thu, 17 Apr 1997 12:19:59 +0100

Mark

anyone thought of writing a plugin to allow creation of sessions that
are multicast relays between other sessions (i.e. click on sessoon a,
b and get a c, that is the sum....union......maybe even intersection
would be a useful session mux type as well...)

 jon

---

From: Mark Handley <[email-masked]>
Date: Thu, 17 Apr 1997 11:20:12 -0400

>would be a useful session mux type as well...)

Doing the relay is not too hard, but adding it to sdr would mean
working around sdr's model of what a session is.  You'd have to start
up different parts of a mixer separately, and then externally plumb
them together.  Such as architecture seems a little odd as a way of
doing relays and not too efficient either.

However, if you're just relaying and not transcoding, there seems
limited reason to do such a thing.  If you want to transcode, then
perhaps modifying sdr to perform this would be a better path than
working around sdr's current limitations.

Mark

---

From: George Michaelson <[email-masked]>
Date: Fri, 18 Apr 1997 08:52:31 +1000

I'd expect a majority usage to be people using sdr one side of a slow PPP
to get the sdr up on the main node to create a short horizion redistribution
of the main feed. In that case, transcoding would be vital, and scoped
address usage would also play a role in limiting dispersion of the re-feed.

Nightmare scenario is some dude cross-linking the Jerry Falwell hour of glower
with a satanic rock festival... Does the owner of a session get to control
cross linking of prior-declared sessions? I think this gets into twisty areas.

Adding a new re-broadcast is not the same as AND-ing together two distinct
clouds always...

-George

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 18 Apr 1997 09:27:28 +0100

>doing relays and not too efficient either.

you're not stretching the session model _far enough_ :-)

um, why not have a session that we realy multicast session realy confiogurations on

that way you have a set of filters already running (some may be fast
enough to support multiple sessions relays, plural, and may live
inside routers....) - then yo ucreate a meta session tgat mcasts out
config to say, plug these two sessions togerther wherever you filter
guys see them.....

 >working around sdr's current limitations.
 
see above

multicast EVERYTHING including info about what to do with
multicast....

 jon

---

From: David Oran <[email-masked]>
Date: Fri, 18 Apr 1997 10:44:33 -0400

>cross linking of prior-declared sessions? I think this gets into twisty
areas.
I think this already happened. Didn't you see the pictures of Pat Boone in
his heavy-metal outfit?
	:-)
-----------------
David R. Oran
Cisco Systems		Direct: 408-527-0567
7 Ladyslipper Lane	Home Office: 508-264-2048,  Home: 508-263-2705
Acton, MA 01720	EMail: [email-masked]