Subject: RE: Comments on <draft-rosenberg-mmusic-sdp-offer-answer-00.txt>

From: [email-masked]
Date: Wed, 5 Dec 2001 11:27:55 +0200

Hi,

> -----Original Message-----
> From: ext Colin Perkins [mailto:[email-masked]]
> Sent: 05. December 2001 8:36
> To: Jonathan Rosenberg
> Cc: 'Flemming Andreasen'; Henning Schulzrinne; MMUSIC
> Subject: Re: Comments on
> <draft-rosenberg-mmusic-sdp-offer-answer-00.txt> 
> 
> 
> --> Jonathan Rosenberg writes:
> ...
> >> - Section 2 mentions that SDP allows for concatenation of multiple
> >> session descriptions. I can't seem to find this in the SDP 
> >> spec - where
> >> does it say that ?
> >
> >Page 7:
> >
> >   When SDP is conveyed by SAP, only one session description 
> is allowed
> >   per packet.  When SDP is conveyed by other means, many SDP session
> >   descriptions may be concatenated together (the `v=' line 
> indicating
> >   the start of a session description terminates the previous
> >   description). 
> 
> This was one of the changes in sdp-new: SDP is now silent on 
> the issue of
> concatenation,

Does this mean that multiple SDP session description concatenation is NOT
allowed anymore, or is the decision totally left to the upper level control
protocol which uses SDP, e.g. RTSP, SIP, SAP?

> since that seemed more appropriately specified 
> as part of
> the transport of SDP.
>

At least in 3GPP, multiple SDP decriptions in RTSP DESCRIBE response is one
of the concerns, but RTSP does not define anything related to multiple SDP
descriptions. The usage is totally inherited from the SDP. If this sentence
is taken out in SDP-new, then RTSP spec or the 3GPP-related spec has to be
changed for the transport of SDP. Am I correct?

-Emre

---

From: Colin Perkins <[email-masked]>
Date: Wed, 05 Dec 2001 09:37:40 -0500

>protocol which uses SDP, e.g. RTSP, SIP, SAP?

The SDPnew draft says nothing about concatenation, so it would be up to the
upper layer to specify. 

>changed for the transport of SDP. Am I correct?

Yes. We have to decide if the change to the protocols which use SDP is
worthwhile, or if we should just revert the change in SDP.

Since it seems that different users of SDP do different things here, I
think it should be specified by the user; but there may be other
considerations.

Colin