Subject: RE: more sip phone feature emulations...

From: Eric Tremblay <[email-masked]>
Date: Thu, 22 Apr 1999 11:44:00 -0400

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Thursday, April 22, 1999 2:26 AM
> To: [email-masked]
> Subject: more sip phone feature emulations...
> 

...
[deleted]
...

> 
> 
> From: "asd098yasdnasbyuy8" <sip:ojasd08yasdb>;enc=pgp;present=no
> 
> would be an encrypted version of the From field. Since its still a
> completely valid From field, intermediate proxies don't know 
> the better

Jonathan,

Maybe I'm mistaken, but the From header does not contain an
"extension-attribute" construct, thus, From only supports the parameter
"tag".  RFC2543 would have to be modified to make this a valid From header.
We might also consider doing the same for the To header as we might
eventually come up with a reason to have extra parameters there too.  

This is all true of course if it is not implicit that headers can have any
kind of extra parameters.

> even if they don't understand this encryption tag. Only the 
> terminating
> gateway would be able to decode it, and then it would also know not to
> present it based on the tag. This would also work for calls to IP
> endpoints. An endpoint receiving this, but not knowing about this
> extension (and if there is no Require header), would still do an OK
> thing, which is to present a name which makes no sense (i.e., 
> looks like
> anonymous anyway). This is reasonable behavior.
> 
> Thoughts on this? Does this fall into the "only useful for PSTN
> interworking, so do it with the rest of the ISUP parameters" model?
> 
> Thanks,
> Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg                       Lucent Technologies
> Member of Technical Staff                   101 Crawfords Corner Rd.
> High Speed Networks Research                Holmdel, NJ 07733
> FAX: (732) 834-5379                         Rm. 4C-526
> EMAIL: [email-masked]
> URL: http://www.cs.columbia.edu/~jdrosen
> 

Eric Tremblay, ing. stag.
------------------------------
Mediatrix Telecom
email: [email-masked]
Tel: +1(819)829-8749 ext. 238
Web: www.mediatrix.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 22 Apr 1999 23:44:20 -0400

You are right. I think this should be fixed for draft.

-Jonathan R.

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 23 Apr 1999 10:52:58 -0400

Change made:

% Reported: 1999-04-23; Eric Tremblay, Mediatrix
\item Bug:  The \header{From}, \header{To}, and \header{Via} headers
were missing extension parameters. The \header{Encryption} and
\header{Response-Key} header fields now ``officially'' allow parameters
consisting only of a token, rather than just ``token = value''.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs