Subject: Re: New SAP draft draft-01.1

From: Valerie Lasker <[email-masked]>
Date: Fri, 22 Nov 1996 18:45:33 -0800

At 08:16 PM 11/19/96 -0500, Mark Handley wrote:
>- The SAP P bit is now replaced by a C (compression) bit to allow SDP
>  payloads to be compressed.  I'm not completely convinced by this, but
>  when we have authentication headers we get somewhat cramped for space
>  in a 1K packet, so it seems like a reasonable idea.
>

I'm concerned about the requirement for gzip compression on my Windows 95 &
NT SDR products.

The most common compression programs used in the PC world are pkzip and
WinZip. These programs use a different algorithm than that used by gzip. The
latest Winzip code can uncompress gzip files, but it is a Windows app. and
therefore not callable from SDR/SAP packet parsing software.

Is there readily-available gzip source code for the PC?

-- Valerie

---

From: [email-masked]
Date: Sun, 24 Nov 1996 00:55:28 +0100

There's a readily available C library for compression and
decompression according to the RFCs that describe "gzip"
compression.

You'll find the references in RFC 1950, 1951 or 1952.

                 Harald A