Subject: RTSP: 7. Undiscussed issues

From: Rob Lanphier <[email-masked]>
Date: Thu, 17 Apr 1997 15:10:32 -0700

There was a list of issues that weren't discussed,
but it was generally agreed need work. Those issues
include the following:
   o The MUTE method was mentioned on the list, but
     discussion died out before a resolution was
     stated. It is unclear exactly how this would be
     implemented, and so in order to promote a useful
     discussion on this front, any advocates should
     provide a strawman proposal with an example laid
     out.
   o Queued PLAY ranges. The authors recommend that
     PLAY messages can be queued, but that a PAUSE
     message clears the queue entirely.
   o From Joerg Ott: More clarity as to maintenance
     of session at server end. (What happens if
     client dies etc.)
   o From Mark Handley: list requirements imposed on
     underlying transport (keep-alive feedback, etc.)

---
Rob Lanphier               Voice: (206)674-2322         Fax: (206)674-2699
Program Manager-Protocols                         Email: [email-masked]
Progressive Networks-Home of RealAudio            Web: http://www.real.com
For more information on firewalls:       http://www.real.com/firewall.html
For more information on RTSP:               http://www.real.com/prognet/rt

---

From: David Oran <[email-masked]>
Date: Fri, 18 Apr 1997 10:43:02 -0400

>     message clears the queue entirely.
Just an observation: queueing PLAYs is relatively easy as long as RTSP
itself runs over a reliable transport, but can get tricky fast if you want
to make the protocol inherently sequential and allow it to run on UDP.

>     underlying transport (keep-alive feedback, etc.)
Yes. This will avoid confusion later if people try to port RTSP to another
environment.

-----------------
David R. Oran
Cisco Systems		Direct: 408-527-0567
7 Ladyslipper Lane	Home Office: 508-264-2048,  Home: 508-263-2705
Acton, MA 01720	EMail: [email-masked]

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 19 Apr 1997 11:03:12 -0400

> to make the protocol inherently sequential and allow it to run on UDP.

I suppose that depends on the implementation. If you have a 'reliability
module' that doesn't pass on any out-of-order PLAY packets to the RTSP
state machine, this would seem to be no different than using TCP.

Actually, PAUSE with timestamp does not clear the queue - it clears
whatever comes after it in NPT. PAUSE without timestamp clears the
queue.