Subject: RE: TTL of zero in WinNT?

From: Amritansh Raghav <[email-masked]>
Date: Tue, 10 Nov 1998 11:56:35 -0800

> -----Original Message-----
> From: Jon Crowcroft [mailto:[email-masked]]
> 
> In message <[email-masked]>, Colin Perkins typed:
> 
>  >>--> Jonathan Rosenberg writes:
>  >>>Has anyone had any experience with sending multicast 
> packets with a TTL
>  >>>of 0 under WinNT? We are getting the bizarre result that 
> Windows sets
>  >>>the TTL to zero, but sends the packets anyway.. We kind 
> of need this for
>  >>>all of these conference bus schemes.
> 
>  >>I'm seeing the same problem -- WinNT 4.0 with service pack 
> 4 installed. 
> 
> Colin
> 
> hypothesis - some smart NT soft-person uses loopback in a 
> link level driver to
> loop multicast packets, instead of havign a general abstraction of
> loopback drivers, then forgets that by the time they get to the
> link/mac level they cannot check the TTL, so they see a multicast
> packet, loop it back, but send it on the wire with TTL=0
> 
> oops

and, as usual, you would be wrong.

anyways - i just tried this and NT defaults to a ttl of 1 if you dont
setsockopt IP_MULTICAST_TTL, otherwise sets the ttl to the value passed for
the socket option (and will accept 0).

i used a small test program (attached, quick cut and paste from someone
elses test)which sends UDP packets. seems to work as expected on NT4 SP4.
If you can send me more info as to what exactly the program is doing, i
would be glad to look at it.

> 
> j.
> this wouldn't hapen in a millenium of halloweens with linux:-)
> 

once it runs a fully multithreaded kernel with fine grain locking on an mp
alpha...

---

From: Jon Crowcroft <[email-masked]>
Date: Wed, 11 Nov 1998 07:27:11 +0100

>>and, as usual, you would be wrong.

makes a  change from microsoft then  :-)
 
 >>the socket option (and will accept 0).

its not what it accepts, itwhat it DOES wth TTL00...

 >>would be glad to look at it.

yes but no thanks.
 >>once it runs a fully multithreaded kernel with fine grain locking on an mp

how about settling for  runnig reliably and correcly on 
a single processora first as the baseline comparison - 
that is the _point_ of the time based
joke? :-)
 >>begin 600 test.c

ta very much for yourcommercial strength insight and comment on my
exrtise - next time check wth your employer before making
legally actionable (and provably incorrect) asertions
 about someone elses techical ability in a
public forum.
j.