Subject: RE: Mute vs. PAUSE in RTSP

From: Eric Fleischman <[email-masked]>
Date: Wed, 26 Mar 1997 14:49:08 -0800

Hence the need to "do away with" mute since there doesn't appear to be
any way to implement it which isn't A Bad Thing.

	-----Original Message-----
	From:	Karl Auerbach [SMTP:[email-masked]]
	Sent:	Wednesday, March 26, 1997 12:15 PM
	To:	[email-masked]
	Subject:	RE: Mute vs. PAUSE in RTSP 

	> .... The third possibility, to have
	> the server "extract" the sound channel(s) and not send them,
adds extra
	> state and overhead to the server - particularly with
interleaved data
	> types - and this overhead will detrimentally harm the
performance of the
	> server. (This is "A Bad Thing".)

	Ummmm... it seems to me that sending a stream when nobody is
listening is
	rather a much, much worse thing.  Indeed, even stronger
condemnitory terms
	would apply.

	I'd rather lose performance on some server somewhere than place
the burden
	on the network and make everyone suffer, even those not
concerned with
	multimedia networking.

			--karl--

---

From: Karl Auerbach <[email-masked]>
Date: Wed, 26 Mar 1997 15:16:25 -0800 (PST)

> any way to implement it which isn't A Bad Thing.

I don't agree.  The notion of having a state in which media time keeps
advancing on the media stream, but nothing is being sent onto the network,
is a useful thing to have.

What's bad are techniques that cause congestion or route thrashing; the
former occurring if the notion of "mute" is "it's still sent, just plug
your ears", the latter occurring if "mute" is "unjoin the multicast group
and then join again".

		--karl--