Subject: SIP multicast

From: Vipul Patel <[email-masked]>
Date: Fri, 10 Sep 1999 20:37:28 -0400

Let's say my Registration server is expecting authorization. And it
listens for request to All SIP  servers multicast address 224.0.1.75.

Now if the server receives a request through the multicast address, and
since it cannot send any response other than 2xx or 6xx, what should it
do...

Same with Invitations. For a client registered to listen at a multicast
address (239.1.1.1) and is accepting invitations from only authorized
clients. What should it do when it receives invitation with no
Authorization header?    Send a 603 Decline response?

Thank you,
Vipul.

--

Vipul J. Patel
dynamicsoft
200 Executive Drive
West Orange, NJ 07052
mailto:[email-masked]

Office:         + 1 732.741.7244
FAX:            + 1 732.741.4778
www:            http://www.dynamicsoft.com

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 11 Sep 1999 09:07:50 -0400

Not sure who first brought this up, but in the revised version of the
spec, 401 will also be allowed, for the reasons you mention.

See www.cs.columbia.edu/~hgs/sip/drafts/draft-ietf-mmusic-sip-new-00.pdf
for a snapshot.

Vipul Patel wrote:
> Now if the server receives a request through the multicast address,
> and since it cannot send any response other than 2xx or 6xx, what
> should it do...
> 
> Same with Invitations. For a client registered to listen at a
> multicast address (239.1.1.1) and is accepting invitations from only
> authorized clients. What should it do when it receives invitation with
> no Authorization header?    Send a 603 Decline response?
> 
> Thank you,
> Vipul.
> 
> --
> 
> Vipul J. Patel
> dynamicsoft
> 200 Executive Drive
> West Orange, NJ 07052