Subject: I-D ACTION:draft-ietf-mmusic-rtsp-06.txt,.ps

From: [email-masked]
Date: Thu, 04 Dec 1997 09:09:42 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group 
of the IETF.

	Title		: Real Time Streaming Protocol (RTSP)
	Author(s)	: H. Schulzrinne, A. Rao, R. Lanphier
	Filename	: draft-ietf-mmusic-rtsp-06.txt,.ps
	Pages		: 99
	Date		: 03-Dec-97
	
   The Real Time Streaming Protocol, or RTSP, is an application-level
   protocol for control over the delivery of data with real-time
   properties. RTSP provides an extensible framework to enable
   controlled, on-demand delivery of real-time data, such as audio and
   video. Sources of data can include both live data feeds and stored
   clips. This protocol is intended to control multiple data delivery
   sessions, provide a means for choosing delivery channels such as UDP,
   multicast UDP and TCP, and provide a means for choosing delivery
   mechanisms based upon RTP (RFC 1889).
 
   This is a snapshot of the current draft which will become the next
   version of the ``official'' Internet Draft.

Internet-Drafts are available by anonymous FTP.  Login with the username
"anonymous" and a password of your e-mail address.  After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-mmusic-rtsp-06.txt".
A URL for the Internet-Draft is:
ftp://ds.internic.net/internet-drafts/draft-ietf-mmusic-rtsp-06.txt

Internet-Drafts directories are located at:

	Africa:	ftp.is.co.za
	
	Europe: ftp.nordu.net
		ftp.nis.garr.it
			
	Pacific Rim: munnari.oz.au
	
	US East Coast: ds.internic.net
	
	US West Coast: ftp.isi.edu

Internet-Drafts are also available by mail.

Send a message to:	[email-masked].  In the body type:
	"FILE /internet-drafts/draft-ietf-mmusic-rtsp-06.txt".
	
NOTE:	The mail server at ds.internic.net can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Rob Lanphier <[email-masked]>
Date: Thu, 04 Dec 1997 09:48:49 -0800

>	Filename	: draft-ietf-mmusic-rtsp-06.txt,.ps
...
Official drafts:
ftp://ds.internic.net/internet-drafts/draft-ietf-mmusic-rtsp-06.txt
ftp://ds.internic.net/internet-drafts/draft-ietf-mmusic-rtsp-06.ps

The official draft contains a number of fixes from the unofficial draft
that was distributed on November 21.  The changelist is included below.  

The easiest way to distinguish the unofficial draft06 postscript and the
official draft06 postscript is to look at the expiration date (April 28 is
unofficial, May 21 is official).  The text version is much more difficult,
though a typo in the unofficial version that you can search for:  "mechanims".

Sorry for any confusion this may cause.  The good news is that I think we
can move this to IETF last call now.

Rob
-----

General:
  Removed references to Internet drafts for PEP, SIP.
  Fixed undefined \cite{} references.
  Missed TLS references.  For TLS and SDP (the two unknown RFCs), removed
  citation and replaced with simple RFC reference to avoid having to
  back-fill bibliography later.

Page 11, S2, para 3.
  Removed statement about differences between authors

Page 12.  top of page
  Fixed text wrapping problem

Page 13, S3.3, S3.4, Page 15 S3.8, Page 58 S15.1
  Changed BNF for conference-id, session-id, and option-tag to be more
  restrictive, and added the additional BNF to the spec:

  S3.3:
  conference-id  = 1*xchar
  
    Conference ids are externally generated, and often times expressable as
    URLs.  Though not specified to be a URL, recipients should be able to
    handle unmodified URLs.
  
  S3.4:
  session-id = 1*(ALPHA|DIGIT|safe)
  
    Session id's we want to be more restrictive with, since they are
    generated by RTSP implementations.  This ensures that they can be passed
    to other systems with minimal escaping necessary.
  
  S3.8:
    option-tag = 1*xchar
  
    Since many option tag proposals are URI-based, the complete set of URI
    characters is necessary to ensure that implementations can handle URIs if
    the standard evolves this way.
  
  S15.1:
  safe           = "$" | "-" | "_" | "." | "+"
  extra          = "!" | "*" | "'" | "(" | ")" | ","
  
  hex            = DIGIT | "A" | "B" | "C" | "D" | "E" | "F" |
		   "a" | "b" | "c" | "d" | "e" | "f"
  escape         = "%" hex hex
  
  reserved       = ";" | "/" | "?" | ":" | "@" | "&" | "="
  unreserved     = ALPHA | DIGIT | safe | extra
   
  xchar          = unreserved | reserved | escape

Page 7, S1.3
  Entity definition inserted from HTTP spec:

    Entity: The information transferred as the payload of a request or
    response. An entity consists of metainformation in the form of
    entity-header fields and content in the form of an entity-body, as
    described in Section 8.

  Also removed a couple uses of the word "entity" where it was inconsistant
  with the definition above.

Page 13, S3.5
  "---" in smpte-type BNF changed to "|" (.ps only)

Page 14, S3.6
  "---" in npt-time BNF changed to "|" (.ps only)

  npt-range added.

Page 15, S3.8.1, bullet 1
  "The name >>should<< not contain any spaces, ..."
  "should" changed to "MUST"

Page 18, S7.1.1, last para on page
  Fixed grammar on sentence starting "Note that RTSP adopts..." 

Page 23, para 4 "Each request..."
  The spec formerly said the sequence number is "not incremented".  The
  more specific wording now says that resent request must have the same
  sequence number as the original.

  Also see Page 39, S12.17

Page 28, S10.6

  Added to the end of first paragraph: 
    "Any server resources are kept, though servers MAY close the session
    and free resources after being paused for the duration specified with
    the {\sf timeout} parameter of the {\sf Session} header in the {\sf
    SETUP} message.  

  Example moved to after first paragraph to make things slightly clearer.

Page 30, S10.9
  Last paragraph of text moved to after the example to avoid confusion.

  Added Content-Type field to the response, and added Content-Length field
  to the request.

Page 33, S11.3.6

  Added the following sentence: "The response SHOULD contain an Allow
  header to make error recovery easier."

Page 34, S11.3.14
  State that an "Unsupported" field is returned.

Page 34, S12
  Third paragraph removed:

  "If the field content does not apply to the particular resource, the
  server MUST return status 456 (Header Field Not Valid for Resource)."

Page 34 S12 para 2
  "Note that not all fields marked "r" ..."  
   .. here and in the next sentence "r" changed to "req".

Page 37  BNF
   In "cache-extension", "---" changed to "|" (.ps only)

Page 41, S12.29
  "This specification defines..." now includes NPT

  Added "If the Range header is given in a time format that is not
  understood, the recipient should return ``501 Not Implemented''."

Page 42, S12.32
  Added note explaining why "funky-feature" and "funky-parameter" are
  not the same.

Page 43, S12.33
  Added rtptime to the BNF

Page 46, S12.39 "interleaved"
  "eg."->"e.g.", other grammatical tweaks.

Page 47, S12.39
  The BNF should allow multiple comma separated transport specs but doesn't.

Page 49, S14.1
  in the SDP, the video URL changed to video.example.com not audio.example.com

Page 50
  "CSeq: 4" in the last request and response changed to "CSeq: 3"

Page 53, S14.3
  "CSeq: 2" in the first request and response changed to "CSeq: 1"

Page 54, example at top of page
   Fixed indenting

Page 55, setup response
   The port for RTP/RTCP changed to range 3456-3457

Page 56, S14.6
   The conference participant is recording both audio and video, not just
   "the audio portion".

Page 57, video setup request and reply
   The multicast address for video changed to 224.0.1.12 from .11

Page 57, RECORD request
   The Range field now has an "=" after the word "clock".

Page 58, S15.1
   Fixed messed up formatting in "OCTET", "quoted-string", "qdtext", and
   "quoted-pair"

---
Rob Lanphier ([email-masked])    Voice: (206)674-2322   Fax: (206)674-2699
RealNetworks:  http://www.real.com
RTSP Info:     http://www.real.com/rtsp
Firewall Info: http://www.real.com/help/firewall