Subject: TCP Connections

From: Vincenzo Crupi <[email-masked]>
Date: Tue, 14 Sep 1999 10:55:56 +0200

Hello,

according to SIP rfc sec. 1.5.2
..."User agents SHOULD implement both UDP and TCP transport." and
"Proxy, registrar, and redirect servers MUST implement both UDP and TCP
transport"
and in case of a Proxy server, it must be stateful  (sec. 12.3) to
accept TCP requests.

The question regards a stateless proxy server: should it rejects TCP
requests or MUST anyway accept it?

Thanks
Kind regards

---

From: "Shary" <[email-masked]>
Date: Wed, 15 Sep 1999 18:31:20 +0200

----- Original Message -----

From: Vincenzo Crupi <[email-masked]>
To: SIPML <[email-masked]>
Sent: Tuesday, September 14, 1999 10:55 AM
Subject: TCP Connectionsboundary="------------133429A09EC83405FB4687D6"

> requests or MUST anyway accept it?

A proxy server MUST accept both UDP and TCP transport!!!
I think, if  it is initially stateless, and arrives a TCP request  it has to
switch to a stateful proxy.
Shary.