Subject: Re: [MOBILE-IP] RFC2002bis

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Tue, 11 Jan 2000 17:18:56 +0100

Hi

>  > >> Q: new FA forwarding text; sometimes two MNs on the
>  same FA sometimes get
>  > >>    traffic forwarded directly rather than via HA.
>  >
>  > The host specific route to MN shouldn't be available to any packets
>  > other than the ones arriving to FA on the tunnel
>  configured for this MN.
>  > This requires forwarding based on not only destination
>  address but also
>  > incoming interface. Without this, there's the problem of
>  getting HA out
>  > of the loop, and in the case of MN moving another site,
>  host specific
>  > route will not go away until previous FA expires the registration,
>  > and until then any communication going through this FA will be
>  > interrupted.
>
>  I'll try to find a place to put this.  Do you have a suggestion?

Could you please clarify why it is not possible to optimise the forwarding
when two communicating MNs are connected to the same FA (or GFA)? If you
use smooth handoffs (or fast handoffs in the case of HFAs) then if the MN
moves to another site there should be no problem. Also, what is the
problem of getting the HA out of the loop?

Regards,
Karim

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 11 Jan 2000 12:58:01 -0800

Hello Karim,

Suppose two nodes are in the same area, so that they could
do as you suggest.  The problem comes when one of them moves,
there is no way for all the other nodes to find out that
their ARP caches are now stale.  Since the ARP request was
(presumably) broadcast, all the other nodes that were in
communication with the node in question would have acquired
a new (and eventually incorrect) layer-2 address for the
mobile node.

Regards,
Charlie P.