Subject: Re: [MOBILE-IP] 3G Mobile Architectures

From: "BINAR, Simon" <[email-masked]>
Date: Fri, 7 Jan 2000 16:16:50 -0000

Hi, See below my answer...

Simon Binar

> -----Original Message-----
> From: Claude Castelluccia [mailto:[email-masked]]
> Sent: 07 January 2000 15:55
> To: BINAR, Simon
> Cc: [email-masked]
> Subject: Re: [MOBILE-IP] 3G Mobile Architectures
>
>
> Hello,
>
> BINAR, Simon wrote:
> >
> > Some further comments and thoughts on this issue:
> >
> > - If I connect base stations directly to an IP network (a bunch of
> > routers, presumably), where will the Radio Resources
> Management (RRM)
> > function reside? In GSM, this was  typically in the BSC,
> and in UMTS,
> > this is in the RNC. If I put RRM functionality into every
> single base
> > station, I will end-up with extremely expensive (and
> un-sellable) base
> > stations. Thus, the RRM function would need to be located
> somewhere in
> > the IP network, maybe in a server? If I do this, what
> impact will this
> > have on system performance (I am especially thinking about handover
> > latency). Should I have local servers to handle local areas
> (in order to
> > improve system performance), or one single super-server to
> deal with the
> > entire network? Obviously, if I use local servers, this
> will look much
> > more like the "old" access networks of GSM and UMTS. This will also
> > reduce the flexibility of the network that you mentioned.
>
> The RRM functions of GSM networks are complex because GSM is
> "connection-oriented".
> RRM would be much simpler if packet-based wireless access
> networks would
> be used and could easily be implemented in the BS without support from
> the
> network (IEEE802.11 BS are quite cheap, aren't they?).
>
> The main issue that I see with IP-based Cellular networks is the QoS
> issue.
> How do you guarante an acceptable QoS to the users without
> establishing
> a connection...? I believe that DiffSer/IntServ amd adaptive
> radios/applications might be very useful here...

[SB] One can argue about what "cheap" means, but IEEE802.11 is
presumably cheap because it works like a shared-media LAN (e.g.,
Ethernet). QoS makes the thing much more complex. You can use network
layer QoS like DiffServ/IntServ for the core network, but you need also
a dedicated QoS scheme at the radio layer as well. What's the point of
agreeing a certain bandwidth via RSVP if it cannot be guaranteed by the
radio layer (read: 802.11)? Introducing QoS at the radio layer
essentially makes it connection-oriented, and thus makes it a complex
system. Connectionless QoS may be possible in IP networks where
bandwidth is supposedly abundant, but I believe radio spectrum will
always be a scarce resource, even in times of UMTS and IMT-2000, and
thus, efficient resource management will be required.

>
> > - The argument about re-using existing infrastructure needs to be
> > considered with care. I think your scenario would apply to a very
> > specific case, say, an ISP that wishes to get into the
> mobile networking
> > business. In this case, having the ability to connect base stations
> > directly to the existing IP infrastructure would be really great (of
> > course, additional functions would also be required for billing,
> > authorisation and accounting, etc...). But most mobile
> network operators
> > already have infrastructure in place. If we look at a
> scenario in 3-5
> > years time where most mobile operators have either GPRS or
> a variant of
> > an IMT-2000 network, then the infrastructure is already in
> place, and
> > expanding that infrastructure shouldn't really be an issue.
>
> that's exactly why it is important to design IP-based
> cellular networks:
> to allow new ISP to provide mobile networking services and
> also to allow
> a company or a university to set up its own wireless IP network (or
> intranet)
> without having to pay expensive fees to its GPRS operator....
>
> Claude.
>
> ----------------------------------------
> Claude CASTELLUCCIA, INRIA Rhone-Alpes
> ph:  +33 4.76.61.52.15 (fax: 52.52)
> http://www.inrialpes.fr/planete/
>

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 7 Jan 2000 18:07:25 +0100

thanks for your comments,

BINAR, Simon wrote:
> system.

I do not fully agree. I believe that by using smart radio and
applications
 that adapt to the environments and give higher priorities to sensitive
flows you can do a lot without having to open connections....

For campus or company networks (i.e controled environments), adaptive
radio/applications + well dimensioning should make it...when the
user switches to a public network then that an other story but
in this case it is probably OK to have more complex base stations
(eventhough some coarse grain reservation + access control mechanisms
might be enough)...

I agree that more research/experimentations are needed though...

regards,

Claude.

-------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/