Subject: [MOBILE-IP] Mobile Router hints

From: Rob Goode <[email-masked]>
Date: Tue, 18 Jan 2000 15:21:13 +0100

Dear gentle folk,

as part of our studies into how to apply Internet technology
we put together a prototype Mobile Router system for a
demonstration. A Mobile Router is a system with more
than one interface which does IP forwarding between its
interfaces and runs Mobile Node software. A Mobile Router
is a useful device if you want a mobile network on, for
instance, a ship or a train. The Mobile Router is entirely
consistent with RFC2002, where a Mobile Node is defined
as a "host or a router". There is nothing about a Mobile
Router which deviates from the IETF standards.

The Mobile Router prototype was made by modifying the
Mobile IP implementation which Sun make publicly available
in source code form for compiling under Solaris and Linux.

We have compiled a list of detailed hints showing most
of the changes that were necessary to get the Mobile Router
working. The hints are for the Solaris base but are largely
applicable to the Linux base. These hints are available from
myself on request.

Please send an email to me if you want them. You should be
aware that they come with no warranty (express or implied)
and no support. We are not liable in any way for any
consequences of the use or non use of the hints. You are
on your own. Have a nice day!

Cheers,

Rob Goode
Principal Scientist CSD/T
NATO C3 Agency
The Hague, The Netherlands
Tel: +31-(0)70-3142442
Fax: +31-(0)703142176
Email: [email-masked]

---

From: Eric Brunner <[email-masked]>
Date: Tue, 18 Jan 2000 11:07:15 -0500

Rob,

I'd like to try this as well. Please send me a hint.

TiA,
Eric