Subject: Re: [MOBILE-IP] WG Opinion on MIER course?

From: Raja Narayanan <[email-masked]>
Date: Mon, 10 Jan 2000 15:17:12 -0600

Hello Charlie,

Although the MIER draft does not specify a protocol, it does specify a
template that is MANDATED for all future Mobile IP extensions. This is a
strong binding to the base Mobile IP protocol and therefore the draft needs
to be a 'proposed standard'.

The authors of MIER are in favor of the option where we pursue MIER
standardization independent of RFC2002bis. Work on MIER has come to a close
and we should complete the standardization and move on.

The guidelines in the appendix are meant to be just that ...guidelines! They
are not intended to be binding on future design [beyond the first 32 bytes
which, as mentioned above, MUST be in the MIER format].

--Raja

-----Original Message-----
From: C. Perkins/D. Reese [mailto:[email-masked]]
Sent: Saturday, January 08, 2000 1:10 PM
To: [email-masked]
Subject: Re: [MOBILE-IP] WG Opinion on MIER course?

I think there are other alternatives.

I agree that MIER would fit well in RFC2002-bis.  Failing that,
I would like to strongly suggest that MIER become an informational
draft, not a Proposed Standard.  My reasoning for this is simple.
MIER does not specify any protocol.

Second, the draft that I read had some _guidelines_ in the
Appendix.  I do not think that those guidelines should be
considered binding on the design for whatever generalized
extensions would be eventually be specified.

For instance, the Challenge draft has a fully specified
Generalized Authentication Extension, along with the
definition for a particular subtype of that generalized
extension.  I expect that a revised Route Optimization
draft will specify another subtype for that extension, and
that the Regional Registration draft will specify yet another
subtype.  These definitions do conform to the guideline in
MIER, the last time I looked.

However, I do not expect that an NAI generalized extension,
should one ever be defined, would need to conform to the
guideline in the MIER appendix.

I'll hold off on sending out the revised RFC2002-bis until I
hear whether working group members wish to include MIER
in that draft.

I'd also like to suggest that the NAI draft be allowed to go
forward before the MIER questions are resolved.  Some
people have been waiting a long time for that draft.

Regards,
Charlie P.

Basavaraj Patil wrote:

>
>
> Hello,
>
> After having had a discussion with our AD (Dave Oran) we have
> the following options for moving ahead with the MIER draft
> (draft-ietf-mobileip-mier-00.txt):
>
> 1. Do a WG last call for this draft requesting a Proposed standard
>    status and have RFC2002-bis reference it for the definition of
>    extensions.
> 2. Roll MIER into RFC2002-bis, which will be going to a WG last call
>    soon.
>
> In view of the two drafts that are currently on the IESG plate, the
> MN-NAI draft and the Vendor specific extensions draft, the extensions
> defined in these drafts would have to be modified to the new mobile IP
>
> extension format.
>
> I would like to hear your views on the above two options.
>
> -Basavaraj

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 10 Jan 2000 20:17:17 -0800

Hello Raja,

> template that is MANDATED for all future Mobile IP extensions.

I do not support the mandatory conformance of all future Mobile IP
extensions to the format illustrated in MIER.  There may other
requirements that we don't know about yet.  Furthermore, there
might be extensions that don't need subtypes.

> standardization independent of RFC2002bis. Work on MIER has come to a
> close and we should complete the standardization and move on.

My comments should be counted as Last Call comments, requesting
additional clarification and possibly respecification of MIER.
I have not talked to _anyone_, outside the authors of the MIER
draft, who supports the mandatory conformance of all future
extensions to the MIER format, and I have talked to more than
ne person who agrees with me that such conformance should not
be mandated.

I reiterate my request that MIER be considered purely informational,
and not binding on future extension specifications.

> The guidelines in the appendix are meant to be just that
> ...guidelines! They are not intended to be binding on future design
> [beyond the first 32 bytes which, as mentioned above, MUST be in the
> MIER format].

Can you say a few words about why the appendices are there?  I think
the draft does not benefit from their presence, and that it would
be very easy for the guidelines to be miscontrued in future Mobile IP
discussions.  It would be better for them to removed, in my opinion,
and I have thought about it a lot of times.

Regards,
Charlie P.