Subject: Re: [MOBILE-IP] 3G Mobile Architectures

From: "BINAR, Simon" <[email-masked]>
Date: Fri, 7 Jan 2000 15:04:18 -0000

Some further comments and thoughts on this issue:

- If I connect base stations directly to an IP network (a bunch of
routers, presumably), where will the Radio Resources Management (RRM)
function reside? In GSM, this was  typically in the BSC, and in UMTS,
this is in the RNC. If I put RRM functionality into every single base
station, I will end-up with extremely expensive (and un-sellable) base
stations. Thus, the RRM function would need to be located somewhere in
the IP network, maybe in a server? If I do this, what impact will this
have on system performance (I am especially thinking about handover
latency). Should I have local servers to handle local areas (in order to
improve system performance), or one single super-server to deal with the
entire network? Obviously, if I use local servers, this will look much
more like the "old" access networks of GSM and UMTS. This will also
reduce the flexibility of the network that you mentioned.

- The argument about re-using existing infrastructure needs to be
considered with care. I think your scenario would apply to a very
specific case, say, an ISP that wishes to get into the mobile networking
business. In this case, having the ability to connect base stations
directly to the existing IP infrastructure would be really great (of
course, additional functions would also be required for billing,
authorisation and accounting, etc...). But most mobile network operators
already have infrastructure in place. If we look at a scenario in 3-5
years time where most mobile operators have either GPRS or a variant of
an IMT-2000 network, then the infrastructure is already in place, and
expanding that infrastructure shouldn't really be an issue.

Simon Binar

> -----Original Message-----
> From: Rami Gabriel Mukhtar [mailto:[email-masked]]
> Sent: 07 January 2000 14:05
> To: [email-masked]
> Subject: Re: [MOBILE-IP] 3G Mobile Architectures
>
>
> Hi Simon,
>
>     Thanks for the response, some valid points, but here
> are
>     a few comments in reply...
>
>     Quoting "BINAR, Simon" <[email-masked]>:
>
>     > [SB] I don't quite understand the relation to
> leased
>     lines. In OSI
>     > parlance, leased lines are layer 1, whereas IP is
>     layer 3. Even if base
>     > stations are directly connected to the Internet,
> IP
>     packets needs to be
>     > carried over some form of physical media. Leased
> lines
>     (e.g., microwave
>     > links) could be one such form of transport.
>
>     I guess I was a little vague, I need to clarify my
> point
>     further...  You are right leased lines are
> definately
>     layer 1 as opposed to IP (layer 3).  Also, yes! you
>     still need a physical media ...
>
>     My point was that if IP networks are common, then it
> may
>     be a lot cheaper to connect to a LOCAL IP network as
>     opposed to building an entire core network from
>     scratch.
>
>     For example consider if a Telco wished to introduce
> a
>     CDMA network into an area that is currently well
> covered
>     by another type of cellular network.
>
>     If the other network is, say a GSM network, then a
> great
>     deal of infrastructure needs to be built.  BUT if
> the
>     network was simply a whole lot of base stations
> hanging
>     of an IP network, then the entire core network could
> be
>     re-used, assuming the capacity was there.
>
>     Using a standard network like IP as close to the
> edge as
>     possible enables the flexibility to re-use existing
>     infrastructure.
>     >
>     > I have also heard the argument of easier
>     configurability. Would this
>     > mean that base stations would implement a routing
>     protocol such as OSPF,
>     > which would allow the service provider's IP
> network to
>     automatically
>     > detect the new base station? I would also assume
> that
>     the new base
>     > station would acquire its own address via some
> dynamic
>     mechanism, such
>     > as DHCP? This could make sense...
>
>     Yes, I guess a some sort of routing table update
>     algorithm will need to be employed...
>
>     >
>     > > From another perspective, operators may wish to
>     connect small
>     > > clusters of base stations directly
>     > > to the internet.  For example a company may wish
> to
>     connect a single
>     > > private cell to the internet to enable network
>     access within
>     > > a building
>     > > without incurring expensive Telco charges.  If
> the
>     base station is IP
>     > > addressable this can be done without having to
>     construct a core
>     > > network.
>     >
>     > This addresses the particular scenario of a
> private
>     access. My question
>     > was more focused on the public network
> environment.
>     Even when the
>     > Internet is all-pervasive, a lot of the Internet
>     infrastructure will be
>     > privately owned (by telcos). I don't see what
> benefit
>     there would be for
>     > a telco to connect base stations directly to the
>     Internet (which is
>     > assumed not be "owned" by the telco), since the
> telco
>     wouldn't be making
>     > any money from the user's traffic...
>     >
>
>     For small future mobile service providers, it may be
>     more cost effective to buy into the banwidth of a
> larger
>     Telco's land line IP network then build and maintain
> its
>     own core network.  By doing so a small mobile
> provider
>     could spend more money base stations, and get better
>     coverage.  I guess this may be a political thing ...
>     depending on deregulation etc.?
>
>     Even today competing telco's lease long haul
> bandwidth
>     from competing telco's in preference to laying their
> own
>     cables ... it can be very cost effective.
>
>     Anyway, thanks for your comments, let me know what
> you
>     think.
>
>     Kind Regards,
>
>     --
>     Rami Mukhtar
>     ___________________________________________
>     Post Graduate Student
>     Telecommunications Group
>     The University of Melbourne
>     Ph: (03) 9344-9207
>     WWW:  http://www.ee.mu.oz.au/pgrad/rgmukht
>     ___________________________________________
>

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 7 Jan 2000 16:55:27 +0100

Hello,

> reduce the flexibility of the network that you mentioned.

The RRM functions of GSM networks are complex because GSM is
"connection-oriented".
RRM would be much simpler if packet-based wireless access networks would
be used and could easily be implemented in the BS without support from
the
network (IEEE802.11 BS are quite cheap, aren't they?).

The main issue that I see with IP-based Cellular networks is the QoS
issue.
How do you guarante an acceptable QoS to the users without establishing
a connection...? I believe that DiffSer/IntServ amd adaptive
radios/applications might be very useful here...

> expanding that infrastructure shouldn't really be an issue.

that's exactly why it is important to design IP-based cellular networks:
to allow new ISP to provide mobile networking services and also to allow
a company or a university to set up its own wireless IP network (or
intranet)
without having to pay expensive fees to its GPRS operator....

Claude.

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Rami Gabriel Mukhtar <[email-masked]>
Date: Mon, 10 Jan 2000 10:07:05 +1100

Simon,
        I understand some of your concerns, here are some comments:

> latency).

Your concern is valid!  I have heard a lot of talk about how handoffs
will be handled and the latency an IP network will introduce if it is
used for signaling purposes.

But why should an IP network be any slower then any other wire line
network such as a GSM core network????

I think the trap is that people get confused between an IP network that
will have a SLA to support the real time traffic, and the current PUBLIC
Internet in its current state.

They are two very different things!  The current internet has grown to
support explosive mostly elastic type traffic.  Telco's in the future
will build packet networks (IP) specifically to support real time
traffic, there is no reason why they will be any worse in supporting
signaling traffic then a dedicated network.

> Should I have local servers to handle local areas (in order to

I don't think RRM is such a difficult task to manage.  In my opinion the
IP address will terminate at the base station and then you will have a
point to point link to the mobile.  Applications that have strict
bandwidth requirements will be able to request a particular bandwidth
from lower layers, for the last leg of the link.  I don't think this is
too much to ask from a base station, ie: who to give bandwidth to (yes,
specific protocols will need to be established).

In GSM you have a connection orientated system with a whole lot of its
own protocols.  When you make a connection the HLR (maybe VLR) needs to
be accessed, in IP this access is done by the home agent, connections
need to be maintained BY THE NETWORK, in IP the connection is maintained
by higher layers (transmission, application).  This would make resource
management a lot simpler in an IP network.

Functions that have dedicated hardware in a GSM network can be
implemented on a server or in an application on an IP network, thus
demanding less of the network itself.  Also some of these functions can
be shared across networks, ie a home agent will be used regardless of
using GPRS, IMT-2000 or IEEE802.11, this saves on a lot of
infrastructure!

> expanding that infrastructure shouldn't really be an issue.

What about expanding to another network type.  How compatible are GSM
PLMN components with an IMT-2000 PLMS network???  I think it would be
better to have a common end to end core network like IP then building
customized high level gateways to bridge different RAN PLMN technologies
together.

Kind Regards,

---

From: Andrew Worsley <[email-masked]>
Date: Mon, 10 Jan 2000 14:43:38 +1100

I am not sure if this thread or my question belongs on this list but...
...
> Internet in its current state.
.....

  I understand that people worry that TCP (implementations) are not very good
  at handling data loss due to data corruption as most (BSD derived)
  implementations are optimised for data loss due to congestion and basically
  back off sending packets, instead of re-transmitting immeadiately.

  As radio networks are prone to great amounts of data corruption (as
  exemplified by the extensive work GSM does to correct errors by duplicating
  data, spreading voice data across succesive packets and so forth) the TCP
  and lossy radio networks probably don't mix very well.

  I presume that link level protocols will try to hide this a great deal -
  but is there any understanding at what level of error (due to data
  corruption) is acceptable for TCP?

  I guess voice can handle this loss as latency is more important but most of
  the Internet protocols we love want TCP.

        Andrew Worsley