Subject: Re: [MOBILE-IP] WG Opinion on MIER course?

From: Mohamed Khalil <[email-masked]>
Date: Sun, 9 Jan 2000 20:48:43 -0600

I think considering MIER draft as a Proposed standard is  a better
option of the WG for the following two reasons:
        1- It will guarantee consistency of using the new extension among
all  future drafts and it will be much less confusing  for people.
        2- If the material is folded in other drafts,  the authors of MIER
should join the list of authors for those drafts. I don't think that the
other drafts' authors would like this to happen, but I might be mistaken.

        Also, I agree with Charlie that the NAI draft should go forward.
        .

> -----Original Message-----
> From: C. Perkins/D. Reese [SMTP:[email-masked]]
> Sent: Saturday, January 08, 2000 1:10 PM
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] WG Opinion on MIER course?
>
> I think there are other alternatives.
>
> I agree that MIER would fit well in RFC2002-bis.  Failing that,
> I would like to strongly suggest that MIER become an informational
> draft, not a Proposed Standard.  My reasoning for this is simple.
> MIER does not specify any protocol.
>
> Second, the draft that I read had some _guidelines_ in the
> Appendix.  I do not think that those guidelines should be
> considered binding on the design for whatever generalized
> extensions would be eventually be specified.
>
> For instance, the Challenge draft has a fully specified
> Generalized Authentication Extension, along with the
> definition for a particular subtype of that generalized
> extension.  I expect that a revised Route Optimization
> draft will specify another subtype for that extension, and
> that the Regional Registration draft will specify yet another
> subtype.  These definitions do conform to the guideline in
> MIER, the last time I looked.
>
> However, I do not expect that an NAI generalized extension,
> should one ever be defined, would need to conform to the
> guideline in the MIER appendix.
>
> I'll hold off on sending out the revised RFC2002-bis until I
> hear whether working group members wish to include MIER
> in that draft.
>
> I'd also like to suggest that the NAI draft be allowed to go
> forward before the MIER questions are resolved.  Some
> people have been waiting a long time for that draft.
>
> Regards,
> Charlie P.
>
> Basavaraj Patil wrote:
>
> >
> >
> > Hello,
> >
> > After having had a discussion with our AD (Dave Oran) we have
> > the following options for moving ahead with the MIER draft
> > (draft-ietf-mobileip-mier-00.txt):
> >
> > 1. Do a WG last call for this draft requesting a Proposed standard
> >    status and have RFC2002-bis reference it for the definition of
> >    extensions.
> > 2. Roll MIER into RFC2002-bis, which will be going to a WG last call
> >    soon.
> >
> > In view of the two drafts that are currently on the IESG plate, the
> > MN-NAI draft and the Vendor specific extensions draft, the extensions
> > defined in these drafts would have to be modified to the new mobile IP
> >
> > extension format.
> >
> > I would like to hear your views on the above two options.
> >
> > -Basavaraj

---

From: Raja Narayanan <[email-masked]>
Date: Tue, 11 Jan 2000 07:58:10 -0800

Hello,

Charlie's opinions prefixed CharlieP>

My response prefixed RN>

CharlieP> I do not support the mandatory conformance
of all future Mobile IP extensions to the format
illustrated in MIER.  There may other requirements
that we don't know about yet.

RN>We do not find technical rationale in the argument
above. A simple way to ensure that future requirements
are taken care of is to have reserved bits which you
did not support. We have asked this several times
before ...can you illustrate any future requirements
that MIER format would preclude ? How much more
simple can an inclusion of subtypes get.

CharlieP> Furthermore, there might be extensions that
don't need subtypes.

RN>well!... Perhaps this was the thought when the
extensions were originally designed...
There might well be extensions that just need no
subtypes _for now_...but MIER gives you the
flexibility to add subtypes.

CharlieP> I have not talked to _anyone_, outside the
authors of the MIER draft, who supports the mandatory
conformance of all future extensions to the MIER
format, and I have talked to more than ne person who
agrees with me that such conformance should not be
mandated.

RN> The WG mailing is established for the _very_
purpose of articulating positions. We need to
encourage all who have an opinion to share with the
mailing group _directly_.

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com