Subject: Re: [MOBILE-IP] Cellular IP for Private Network Access

From: Thomas Eklund <[email-masked]>
Date: Fri, 7 Jan 2000 11:24:43 +0100

> -----Original Message-----
> From: Zoltan Richard Turanyi [mailto:[email-masked]]
> Sent: Thursday, January 06, 2000 6:14 PM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] Cellular IP for Private Network Access
>
>
> Yingchun Xu wrote:
> > Encapsulation may not be a disadvantage  if it does not
> across air link.
>
> It may not. But, the fact that something is not disadvantageous is no
> reason to use it.
>
> > I meant tunneling based approaches in general.
> > Can you point out how this is done and where it is
> described in "Cellular IP
> > draft"?
>
> It is not included in this version of Cellular IP.
>
> > It seems to me that a unified approach for handling both
> public and private
> > network access is prefered.
>
> I do not think that the tunneling of packets containing private
> addresses breaks the "uniform approach" of Cellular IP.
> Besides, public
> and private addresses are handled differently in fixed
> networks as well.
>
Yes it does because you snoop on the addresses.... And it is very hard if
you tunnel packets, because the inner packet is encrypted, how do you get
that info?
It will be very hard for Cellular IP to obtain security...I have also
pointed out that several times before and I agree with Yingchun Xu that this
is a problem...

/Thomas

---

From: Zoltan Richard Turanyi <[email-masked]>
Date: Fri, 7 Jan 2000 15:41:16 +0100

> you tunnel packets, because the inner packet is encrypted, how do you get

Thomas,

In case of private home addrersses the whole purpose of tunneling is to
hide the inner (private) address. Naturally Cellular IP nodes snoop the
outer address. They are not even aware of the tunnel.

> pointed out that several times before and I agree with Yingchun Xu that this

Tunneling of private addresses have little security consequencies here.
I do not really see what one has to do with the other. Private addresses
require only easy to add extensions to Cellular IP and do not break the
basic mechanisms of location management and routing. It also seems that
you are a bit unfamiliar with the new Cellular IP draft which contains
security extensions (draft-valko-cellularip-01.txt). Feel free to raise
specific security concerns relating to Cellular IP.

/Zoltan
--
Zoltan Richard Turanyi
Research Fellow, Ericsson Hungary
Traffic Analysis and Network Performance Lab