Subject: Re: [MOBILE-IP] Darwinian evolution of proxy tunnelling...

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 4 Feb 2000 16:52:01 -0800

> Hi, Guilhem,
>
> "G. Ensuque" <[email-masked]> (GE) writes:
>
> GE> Hi all
>
> GE> This is just to test my understanding: could the insiders correct
i was finally reading some *very* old messages before the weekend.

just wanted to add something here...

> GE> Am I right to assume the following Darwinian evolution path for the idea
> of GE> having 'daisy-chained' tunnels through proxies?
>
> GE> Hierarchical FA --> TEP --> regionalized tunnel mgt --> THEMA
>
> I'm not sure I would draw the picture quite that way.  THEMA definitely
> derives from TEP and is a form of hierarchical FAs, but I would say
> that the recent "Regionalized Tunnel" draft is on a separate branch.
> The key distinguishing feature is that of transparency.

yes, i agree that thema-style tunnels are more transparent.

even before TEP, they appear in TSP (now expired,
fetch it from):

  http://playground.sun.com/~gab/papers/tsp-draft.txt

there these were called compound tunnels. notice that TSP
and TEP (rev0) merged into what was also called TEP (rev1):

  http://playground.sun.com/~gab/papers/draft-ietf-mobileip-calhoun-tep-01.txt

so i'd draw the diagram like this:

  Hierarchical FA     regionalized tunnel mgt
                 \   /
                  TEP
                 /  \
      ??? --> TSP    THEMA

>
> THEMA was originally conceived to solve a techno-political problem of
> separation of the cellular link-layer termination point from foreign
> agent functionality.  It provides a nice interface to FAs that is
> independent of the link layer used to access the network. ...

in tsp it was also seen as a way to do remote access
and (optionally, by chaining another tunnel) mobility

-gabriel

---

From: Pete McCann <[email-masked]>
Date: Mon, 7 Feb 2000 10:04:06 -0600

>> independent of the link layer used to access the network. ...

GM> in tsp it was also seen as a way to do remote access
GM> and (optionally, by chaining another tunnel) mobility

I should point out that THEMA should be considered superseded by
draft-ietf-mobileip-3gwireless-ext-02.txt.  The protocol described
there also tunnels link-layer data (such as octets intended for PPP)
which THEMA was not designed to do.  We do not plan any further
updates to THEMA at this time.

-Pete