Subject: Re: [MOBILE-IP] Mobile Wireless Internet Forum

From: Thomas Eklund <[email-masked]>
Date: Fri, 4 Feb 2000 12:05:49 +0100

If we stick in the private address lane that some people support then we
will NEVER see the wireless Internet boom that everyone is waiting for -
IPv6 is a natural catalyst for making evrything always connected - not
semi-connected as in these private address/NAT based solutions.

IPv6 will give you end-to-end semantic which a ipv4 based solution will not
give you.
IPv6 is far superior when it comes to scaling because of its hierarchal
address-architecture.
And in huge cellular backbone it makes a real difference.

And if you have private addresses how will you be able to roam?
It is not possible to roam with your private ipaddress.
Having a proxy implies that you must tunnel out from the proxy to the
mobile... in other word to the mobile's private address - it does not matter
if you have a l2 or l3 tunnel you still must tunnel out to the mobile.
Why should the mobile trust the proxy? Which it must when you have private
addresses....
This definatly breakes the e-2-e security.

The most natural scenario would be to use ipv6 internal in your cellular
networks and translate to v4 in the edges and give every cellular phone an
ipv6 address.

/Thomas

> -----Original Message-----
> From: Casati, Alessio (Alessio) [mailto:[email-masked]]
> Sent: Friday, February 04, 2000 11:40 AM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] Mobile Wireless Internet Forum
>
>
> > i agree, wireless is a natural for v6 cuz most of the time
> deployment
> > is already planning on having some sort of proxy or
> intermediate system
> > between the wireless cloud and the general internet. i'm
> not talking about
> > laptops that happen to connect wirelessly, i'm talking
> about the much
> > more numerous phone-like devices. imposing a proxy may
> > have other architectural consequences, but it does provide a natural
> > location for the v6/v4 interface function. certainly worth
> exploring.
> >
> >
> Well, if we use proxy, then why not using private addresses.
> If so we don't need IPv6. Thinking Loudly.
>
> alessio
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 4 Feb 2000 10:18:19 -0800

Thomas:

> semi-connected as in these private address/NAT based solutions.

I predict that IPv6 will never (read for the next 20 years if ever)
be deployed making MIP v6 a dead duck?