Subject: Re: [MOBILE-IP] Issues with draft-ietf-mobileip-3gwireless-ext-02.txt (fwd)

From: Gopal Dommety <[email-masked]>
Date: Wed, 2 Feb 2000 17:23:20 -0800

Hello David et al:

        This is regarding the new  GRE draft.  We are currently  using
the Key field (RFC1701) in an Interface referred to as RP that is used
in 3rd generation  wireless networks.  This  interface enables a large
part of the wireless network to  be IP based. This interface currently
uses the Key field of GRE.

        The new GRE draft talks about deprecating the Key field. Would
like  to know your thoughts  on having the key  field  in the new GRE
draft. This change will make the RP interface complient with the new
GRE draft/RFC.

Thanks
Gopal

>
> Hi David.  I'm trying to understand the implications of
> draft-meyer-gre-update-03.txt for our GRE tunnels.  Since
> we have multipoint GRE tunnel using NHRP (based on the key
> field), will this draft make mGRE unsupportable.  I know
> of other vendors as well as Cisco's RP interface (based
> on draft-ietf-mobileip-3gwireless-ext-02.txt) for Mobile IP
> that relies on the Key field.
>
> I guess why are certain fields deprecated?  The draft did
> not seem to provide reasons.  Can you explain?
>
> -- Kent --
>
> Forwarded message:
> > From [email-masked] Wed Feb  2 16:22:35 2000
> > X-Mailer: Sun NetMail 2.3
> > MIME-Version: 1.0
> > Content-Type: text/plain; charset="US-ASCII"
> > Content-Transfer-Encoding: 7bit
> > Message-ID:  <[email-masked]>
> > Date:         Wed, 2 Feb 2000 16:13:43 -0800
> > Reply-To: [email-masked]
> > Sender: "IP Routing for Wireless/Mobile Hosts (mobile-ip)"
> >               <[email-masked]>
> > From: Patrice Calhoun <[email-masked]>
> > Subject:      [MOBILE-IP] Issues with draft-ietf-mobileip-3gwireless-ext-02.txt
> > To: [email-masked]
> > X-SMTP-HELO: standards.nortelnetworks.com
> > X-SMTP-MAIL-FROM: [email-masked]
> > X-SMAP-Received-From: outside
> > X-SMTP-PEER-INFO: standards.nortelnetworks.com [137.118.21.16]
> > Content-Length: 552
> >
> > All,
> >
> > I was looking at this draft today and noticed that it makes use of the
> > Key field in the GRE header. I was recently informed that the new GRE
> > I-D targetted to replace the Informational RFC, is in last call, and
> > no longer contains the Key field. The Key field is required for the
> > Mobile-IP draft, and therefore will not be able to support the
> > standards track version of the GRE protocol (draft-meyer-gre-update-03.txt).
> >
> > I would urge anyone that cares about this draft to make your issues
> > known to the IESG before the GRE last call expires.
> >
> > PatC
> >
> >
>
>

---

From: Tony Li <[email-masked]>
Date: Wed, 2 Feb 2000 22:10:46 -0800

Gopal,

> draft. This change will make the RP interface complient with the new

You should notice that while this field is deprecated, there is nothing that says that
you can't continue to use it.  Your usage would simply be compliant with the existing
RFCs, not with the proposed standard.

Regards,
Tony

---

From: Gopal Dommety <[email-masked]>
Date: Thu, 3 Feb 2000 08:45:51 -0800

Tony,

> RFCs, not with the proposed standard.

I relized that we can use the key  field and be complient with RFC1701
but not with the  new proposed  standard.  The main motivation  behind
this  email is to  see how we  can be complient  with the new standard
(Since RFC1701 is an informational RFC, some of the wireless standards
bodies would not like to reference it).

Would appreciate if you give some insight into why the Key field was
deprecated and what is needed to de-deprecate:) it?

Regards,
Gopal

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 3 Feb 2000 14:57:27 -0800

Hello Tony,

Unfortunately, it isn't sufficient for Mobile IP to cite a
standard that is only Informational.  We have to have something
better in order to go to Draft Standard -- later this year if
possible.

Or, should the working group define its own encapsulation that
already includes a session identifier?  That is the main thing
that people want from GRE, it seems, aside from compliance with
existing equipment.  I wonder how the latter will interact with
changing GRE itself...

Regards,
Charlie P.

Tony Li wrote:

> You should notice that while this field is deprecated, there is nothing
> that says that you can't continue to use it.  Your usage would simply be
> compliant with the existing RFCs, not with the proposed standard.

---

From: Tony Li <[email-masked]>
Date: Fri, 4 Feb 2000 00:27:46 -0800

Gopal, MOBILE-IP folks, et. al.,

> deprecated and what is needed to de-deprecate:) it?

The Key field was deprecated mostly becuase there is no good semantics for it within GRE
itself.

As to what's necessary to have it included in the Proposed Standard version, I would say
that you would need to:

- Contact Dave Meyer as he's the one driving this advancement, not me.

- Deliver to him a clear semantics for the Key field that is completely independent of
MOBILE-IP and is somehow essential for GRE.

- Get buy-in from all of the authors of this draft and then get it pushed through the IESG
again.

Good luck.  Yer gonna need it.

Tony

---

From: Gopal Dommety <[email-masked]>
Date: Fri, 11 Feb 2000 00:14:51 -0800

Hello:

I received an email from Fred Baker regarding IESGs decision on GRE options. I have attached below part of his email.
I replied to him (and the IESG) that I will submit the draft for being kicked around soon.

I apologize for the delay in sending this email, too many things happening :(
-Gopal

> Gopal:
>
> The IESG discussed your concern this morning, and came up with this
> approach.
>
> We suggest that you write up an addendum/extension to GRE - another
> internet draft that specifies how the fields should be used. This can be
> kicked around in whatever forum is best, and any users of GRE with Key and
> Sequence can then basically implement to the combined specification.
>
> Are you willing to do that?
>

Thank You.
Regards,
Gopal
-------------------------------------------------------------------------------------------------------------

Gopal Dommety
408 525 1404
[email-masked]
Cisco Systems, San Jose, CA, 95051