Subject: Re: [MOBILE-IP] Mobile Wireless Internet Forum

From: Patrice Calhoun <[email-masked]>
Date: Thu, 3 Feb 2000 07:25:38 -0800

well, given that you aren't providing me with any context, I will simply
assume that you are asking me whether I meant Mobile IP and not Cellular IP
being driven in MWIF, and the answer is yes (Mobile IP, not Cellular IP).

PatC
>You mean Mobile IP but not Cellular IP?
>
>Behcet
>
>--
>Behcet Sarikaya
>Computer Communications Lab.
>The University of Aizu
>Tsuruga, Ikki-machi, Aizu-wakamatsu City
>Fukushima, 965-8580 Japan
>Tel. +81-242-37-2559 Fax. +81-242-37-2742
>Home page:  http://www.u-aizu.ac.jp/~sarikaya/
>email: [email-masked]
>
>

---

From: Charles Lo <[email-masked]>
Date: Thu, 3 Feb 2000 10:52:02 -0800

We need to be careful to distinguish between mobility protocols favored by
specific companies for MWIF adoption, vs. actual agreed-to position or direction
in MWIF.  For the former, I agree with Pat that a number of companies prefer
Mobile IP, especially given fairly broad global wireless industry support.
Mobile IP is specified in the 3GPP2 packet data standard (3GPP2 represents
industry players behind the cdma2000 radio technology of 3G), as well as will be
supported by 3GPP (the W-CDMA 3G industry) in their R'00 standard.  Re. the
latter, in future work the MWIF technical committee will consider different IP
mobility protocols in a contribution-driven manner, and then make decisions on
which protocol(s) to adopt.  No such decision has been made to-date.

Charles

Patrice Calhoun <[email-masked]> on 02/03/2000 07:25:38 AM

Please respond to [email-masked]

To:   [email-masked]
cc:    (bcc: Charles Lo/Corporate/AirTouch)
Subject:  Re: [MOBILE-IP] Mobile Wireless Internet Forum

PatC

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 3 Feb 2000 11:09:10 -0800

If you had read my note, that unfortunately wasn't included in the
response that caused this whole thread, I stated that *I* was trying
to make sure that Mobile-IP was being adopted. I never stated that I
was speaking for MWIF, or any other standards body.

PatC

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Fri, 4 Feb 2000 11:44:20 -0000

Thomas,

We all concur on the good things IPv6 provides. We all have to
check reality as well.

The thing is 3G deployment is to start 2002, with some folks starting
earlier,some later. 2G1/2 is supposed to have commercial start
in early 2001 (somebody shoots earlier than that). Can anybody predict
widespread use of IPV6 in corporations or internet websites by that time?

If no corporation is after IPv6, I want to be able to offer
corporate net access. We need IPv4 support in 21/2 and 3G.

> And if you have private addresses how will you be able to roam?
> It is not possible to roam with your private ipaddress.
>
Well, GPRS and Mobile IP allow for roaming with private addresses.
I don't see how to provide access to corporate nets, otherwise.

> Having a proxy implies that you must tunnel out from the proxy to the
> mobile... in other word to the mobile's private address - it does not
> matter
> if you have a l2 or l3 tunnel you still must tunnel out to the mobile.
>
Well, I've never seen an IP packet over the air,
without at least radio physical and link layers.
There are ways not to use a L3 tunnel to the mobile,
as per MIPv4 and GPRS/UMTS PS domain.

> Why should the mobile trust the proxy? Which it must when you have private
> addresses....
>
well, this would have to happen for the worth
exploring solution for 4 to 6 transition Gabriel mentions.

> The most natural scenario would be to use ipv6 internal in your cellular
> networks and translate to v4 in the edges and give every cellular phone an
> ipv6 address.
>
How does that translation impact IPSEC? Which is the trust model
you have in mind?

alessio

> /Thomas
>
> > -----Original Message-----
> > From: Casati, Alessio (Alessio) [mailto:[email-masked]]
> > Sent: Friday, February 04, 2000 11:40 AM
> > > i agree, wireless is a natural for v6 cuz most of the time
> > deployment
> > > is already planning on having some sort of proxy or
> > intermediate system
> > > between the wireless cloud and the general internet. i'm
> > not talking about
> > > laptops that happen to connect wirelessly, i'm talking
> > about the much
> > > more numerous phone-like devices. imposing a proxy may
> > > have other architectural consequences, but it does provide a natural
> > > location for the v6/v4 interface function. certainly worth
> > exploring.
> > >
> > >
> > Well, if we use proxy, then why not using private addresses.
> > If so we don't need IPv6. Thinking Loudly.
> >
> > alessio
> >
>

---

From: Guilhem Ensuque <[email-masked]>
Date: Fri, 4 Feb 2000 12:38:07 +0100

Hi Hannes,
Hi all,

The result of the study was an incremental deployment scenario for Mobile IP
in UMTS involving ultimately a new node, the IGSN, that collapses the
functions of GGSN, SGSN and FA if I understand everything correctly.

All 3GPP documents are free and public and can be found at www.3gpp.org

The document in questions are:
23.922 Architecture for an all-IP network (v3.0.0 - dec 99)
23.923 Combined GSM and Mobile IP mobility handling in UMTS IP CN
(v3.0.0 - dec 99 as well)

To find the documents, follow the links to 'Technical Specification Group'
from the main page. Then for the MIP ad-hoc documents follow:
ftp://ftp.3gpp.org/TSG_SA/WG2_Arch/S2MobileIp/

The authors of these document are on this list so I am sure you can ask more
info.

Regards

Guilhem

-----Original Message-----
From:   IP Routing for Wireless/Mobile Hosts (mobile-ip)
[mailto:[email-masked]] On Behalf Of Hannes
Hartenstein
Sent:   Friday, February 04, 2000 10:05 AM
To:     [email-masked]
Subject:        Re: [MOBILE-IP] Mobile Wireless Internet Forum

Hi Guilhem,

Guilhem Ensuque wrote:

> A feasibility study has indeed been carried out by the 3GPP MIP adhoc
> group -in which a number of participants of this list have been involved-
to
> investigate the possibility of introduction of MIP to the 3G core network.
> However, I do not think it is an agreed part of the standard yet.

what are the results of the study? And where do we find documents of this
study and  of the 3GPP MIP ad hoc group in general?

Thanks, Hannes

--
Dr Hannes Hartenstein           [email-masked]
Research Staff Member           Tel.: +49 6221 905 11 15
C&C Research Laboratories       Fax.: +49 6221 905 11 55
NEC Europe Ltd.
Adenauerplatz 6
69115 Heidelberg, Germany
http://www.ccrle.nec.de/heidelberg/index.html

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 4 Feb 2000 11:36:46 -0800

>If so we don't need IPv6. Thinking Loudly.

others have responded, but here's a short theme to think about:
talking about semi-isolated wireless clouds going through a
gateway/proxy. yes, the cloud can run v4 private addresses,
or v6. the former gets you locked into an isolation you won't
be able to move out of. ever. v6 at least gives you a future in which
you *could* go e2e as v6 starts appearing in the internet.
you have a future. even the present has something which is
very valuable: a universally significant identifier (unlike
v4+private).

-gabriel

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Sat, 5 Feb 2000 13:17:28 -0000

> ----------
> From:         Gabriel Montenegro[SMTP:[email-masked]]
> Reply To:     [email-masked]
> Sent:         04 February 2000 19:36
> To:   Casati, Alessio (Alessio); [email-masked]
My considerations apply to proxy based wireless services,
which was the topic of dicussion. It's not the case of
services requiring e2e seamless connectivity.

On the universally significant ID, I'm not sure that
this should be defined at the network layer. Anyway
there are different options.

alessio

---

From: Charles Lo <[email-masked]>
Date: Sat, 5 Feb 2000 14:55:13 -0800

> > in future work the MWIF technical committee will consider different IP
> > mobility protocols in a contribution-driven manner, and then make
> > decisions on which protocol(s) to adopt.  No such decision has been
> > made to-date.
>
> However, I had not heard of the MWIF before, and Charles Lo seems to know
> quite well what's going on there... what 'different IP mobility protocols'
> are you thinking of? There are not so many around, are there?

Briefly MWIF, as an operator-driven industry forum is intended to influence and
align worldwide 3G standardization and commercial development of the
next-generation wireless network.  Its scope covers both the radio access and
the core networks - everything in the wireless network beyond the radio
interface.  It promotes ubiquitous adoption of IP technologies and leveraging as
much as possible IETF standards.  It will also drive and  facilitate product
interoperability as the traditional, monolithic and closed wireless
infrastructure evolves to becoming open and multi-vendor sourced.  It will NOT
be a standards development organization such as 3GPP  or 3GPP2.

What I mean by different IP mobility protocols include those at IP layer -
Mobile IP (both v4 and v6) and DHCP-based methods.  Also, some people are
touting SIP based terminal mobility, at the application level.  I think all
these will be considered by MWIF.

Charles
+++++++
Charles Lo
Vodafone AirTouch
925-210-3460
[email-masked]