Subject: Re: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter update?)

From: Thomas Eklund <[email-masked]>
Date: Fri, 3 Mar 2000 11:10:34 +0100

> -----Original Message-----
> From: Casati, Alessio (Alessio) [mailto:[email-masked]]
> Sent: Friday, March 03, 2000 1:12 AM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] Terminology (was: [MOBILE-IP]
> charter update?)
>
>
> BP,
>
> > Mobile IP's access independence characteristic makes it so viable.
> > So there's not much to be said for IP mobility support over specific
> > access technologies as you propose.
> >
> I'm not so sure about this as you are. I just say
> IP itself is technology indep., but if you
> want to support intserv there is for instance an ISSLOW spec,
> an ISATM spec, and a spec on how to support
> Qos on 802.x stuff. Just imagine if we want to solve
Since I work with this as well I could not agree more...
It is very important to map the link characteristics to the mobility
management (which in our case is IP based) in order to make it efficient...

> the problem of supporting IP QoS in mobile environment over
> a certain access technology: it is at least as specific to the
> technology as it may be for a fixed technology I guess.

People that dont agree with you here have not worked with layer 2 stuff..:-)

> > >There may be another approach (AKA "the tail that
> > >wags the dog") that is defining a new access network
> > >based on newly IETF specified access protocols, but this
> > >probably would not be useful for some technologies
> > >currently (or about to be) on the
> > >marketplace (cellular and non cellular). It looks
> > >like a long term work.
> > >
> >
> > Seriously???
> >
> I can answer "YES!" since I'm sure I'm serious ;)
> But I'm also interested in knowing what this question is about
> (what in the quoted text looks likely not to be serious?)
>
>
> alessio

At least I agree with you...

/Thomas

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 3 Mar 2000 16:08:03 -0800

Hello Thomas and Alessio and Basavaraj,

>> Qos on 802.x stuff.

> management (which in our case is IP based) in order to make it efficient...

But whether it is important depends on the link.  For some or maybe
most links, Mobile IP works great without any changes.  And a lot
of the recent discussion about changes to Mobile IP doesn't have
anything to do with link characteristics, but more how the link is
to be operated because of very high-level policy decisions.

I'd rather consider Mobile IP as link-independent, and then engineer
specific extensions for particular links when and if they are needed.

For the specific case of QoS, I reckon that a layer-2 mechanism is
required to implement whatever layer-3 allocations have been made
(on the basis of whatever application-layer requests have been
 fulfilled).  But that is a QoS problem, not a Mobile IP problem.

Regards,
Charlie P.

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 3 Mar 2000 19:41:50 -0800

I agree with Charlie on decoupling for QOS.

IP is link independent as Mobile IP is.

When a QOS model is developed out for Mobile IP (e.g.,
wireless DiffServ) on could imagine mapping to the radio link
via issll type techniques via some open API that
provides quality indicators for handoff (SNR, etc.)
and for resource allocation.

But to make Mobile IP dependent on that API is
a NOP.

Andrew

--
Andrew
http://comet.columbia.edu/~campbell