Subject: Re: [MOBILE-IP] Charter Update

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 2 Mar 2000 13:51:43 +0100

>  One more thing:
>  Handoff solutions that the WG needs to work on need to be
>  applicable to both IPv4/6.
>
>  -Basavaraj

I agree.
For this same reason in Adelaide we will be presenting a
draft describing a Hierarchical extension to MIPv6 and
Fast Handoffs for both Hierarchical MIPv4 (Regional Tunnel Mgt.)
and Hierarchical MIPv6. Fast Handoffs for Hierarchical MIPv4
was already described in a previous draft presented in Oslo
(draft-elmalki-mobileip-fast-handoffs..).
The new draft will be out soon.

Rgds,
Karim

---

From: Thomas Eklund <[email-masked]>
Date: Thu, 2 Mar 2000 16:55:07 +0100

I could not resist since I work in a silicon company...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, March 02, 2000 3:20 PM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] Charter Update
>
>
> Not sure this thread really belongs here, but...
>
>
> > Hi, Basavaraj,
> >
> > I agree with your message below - I think we need to be
> very cautious
> > about expanding the charter of the WG to be too cellular-specific.
> > This is the Mobile IP working group, which means that we should be
> > defining IP-layer protocols.
>
> agreed, and specifying a better (or faster) hand-off mechanism isn't
> cellular-specific, but as you and Raj state, it can be used
> by these people.
> What we need to do is make Mobile IP provide the
> functionality that they need,
> not try to design their networks/systems.
>
> >
> > There are some link-layer specific questions that need to be
> > addressed, in terms of how a Mobile IP Foreign Agent should
> be "glued"
> > onto the cellular wireless link layer.
> > draft-ietf-mobileip-3gwireless-ext-02.txt does this pretty well.
> > However, I do not think we should try to start standardizing other
> > aspects of a 3rd generation cellular network.  I think some
> people are
> > trying to plan a BOF in Adelaide called "IP to the Base
> Station" that
> > could address some of these questions, but I am concerned that the
> > IETF has a fairly limited understanding of the cellular link layer,
> > especially as it pertains to CDMA - I've read and heard statements
> > that reveal a certain lack of knowledge of how a CDMA Selection and
> > Distribution Unit really work, when people try to get IP
> packets sent
> > by a MN directly out of a BTS.  Of course, I've also seen
> people here
> > who *do* understand the technology quite well - I don't
> mean to start
> > a flame war, but I think this kind of work logically belongs in the
> > respective 3GPPs for each technology.
>
> Well, I for one will be at this BOF, and I agree that many
> people don't fully
> understand how the macro diversity combiner works. However, I
> think that it is
> a reasonable goal to allow the *control* protocol between the
> BSC and the BTS
> to run over an IP network. Furthermore, once IP is in the BTS, one can
> centrally manage it using off the shelf tools, etc.
>
> As for data, is switching or routing better, I'm not conviced
> the latter is
> the right design choice. A layer 2 approach, such as MPLS,
> may be appropriate.

My opinion is that it is the same thing today - technically ... You do l2
switching or ip switching in integrated L2 switch and L3 router in HW
today... In other words L3 switching :-)

And as a sidenote MPLS is seen from the layer two protocol as a layer three
protocol but I would say that it is a useless L2,5 protocol...

/Thomas

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Sat, 4 Mar 2000 11:06:00 -0000

> Pat:
>
> "[email-masked]" wrote:
>
> > not really. AAA is one way to facilitate deployment of Mobile IP, but
> not fast
> > hand-off, IMHO. This is really new work, and although we could conceal
> it
> > under a variety of existing work items in the charter, I think that we
> should
> > specifically spell out that we will develop a scheme to provide fast
> hand-off
> > at the IP layer. Please note, however, that we *may* find that there are
> > optimizations that can be done for specific link layers, and if we
> decide that
> > hand-offs is a work item that we want to take on, we will get into link
> layer
> > issues. A one-size fits all may not apply here.
> >
> > PatC
>
> I think there has been a wide range of proposals on micro-mobility.
>
> If the working group thinks it worthwhile (or even needed, above and
> beyond
> making Mobile IP go faster and, be more scalable in the signaling
> load it generates under wide scale deployment) then some
> consensus could be reached by considering the
> existing proposals.
>
Andrew, would a FA at a GGSN require a micromobility support?
Would a FA at a PDSN require anything more than what the
R-P interface provides?

If not, then Pat is right (and you are wrong)

> My feeling is that the solution space for
> micro-mobiliy is well covered. That is not to
> say that better solutions could not be proposed.
>
>
Current micromobility solution do actually cover a solution
space. I would like to know which problem space this solution
space is mapped to.

Micromobility is by definition provided
by access nets, so the only way the IETF could
claim to provide micromobility protocols
is to enter in the access nets business (which are
layer 2).

There are two ways the IETF can enter the access net business:
either by defining a protocol that fits in an access net
designed by other bodies (and the R-P is the first instance
I've seen along these lines) or by defining it's own
router based access network. The second goal is far more ambitious
that the first and I sort of condider this a long term
work (if the IETF will ever like to enter this business).

cheers

alessio

> Of course I would be in favor for the charter to
> explicitly call out a specific work item on
> "micro-mobility. People actively pushing micro-mobility
> could come to a consensus with a join ID for the
> working group to consider. I think this could
> be done quite quickly once we understand the
> trade off of the current proposals.
>
> --
> Andrew
> http://comet.columbia.edu/~campbell
>

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 6 Mar 2000 10:34:49 +0100

> > Seem okay?
>
> not really. AAA is one way to facilitate deployment of Mobile
> IP, but not fast
> hand-off, IMHO. This is really new work, and although we
> could conceal it
> under a variety of existing work items in the charter, I
> think that we should
> specifically spell out that we will develop a scheme to
> provide fast hand-off
> optimizations that can be done for specific link layers, and
> if we decide that
> hand-offs is a work item that we want to take on, we will get
> into link layer
This is EXACTLY my point here as well...

I agree with you, on this....

/Thomas

---

From: Yingchun Xu <[email-masked]>
Date: Wed, 8 Mar 2000 11:43:07 -0600

Jim,
Give you another update. As I know upto today, there are three groups (MWIF, 3G
IP, TSG-ALL IP) working on "all IP" solution and every one of them has different
vision (or purpose). I heard another  one is coming in pipe (scary).  Sooner, we
need another one to unify all of them.

--Yingchun.

Jim Willkie <[email-masked]> on 03/08/2000 11:01:39 AM

Please respond to Jim Willkie <[email-masked]>

Sent by:  Jim Willkie <[email-masked]>

To:   [email-masked]
cc:    (Yingchun Xu/MW/US/3Com)
Subject:  Re: [MOBILE-IP] charter update

At 10:33 AM 3/8/00 -0600, Yingchun Xu wrote:
>Jim,
>Depending on which all IP you are talking about, it is not true that all
all IP
>schemes will introduce the hassles.

Good. Thanks for the clarification, because the concept of 'all IP' is
good. Perhaps the ''all IP' schemes that introduce hassle are deficient?

Jim W

>Jim Willkie <[email-masked]> on 03/08/2000 09:59:51 AM
>
>Please respond to Jim Willkie <[email-masked]>
>
>Sent by:  Jim Willkie <[email-masked]>
>
>
>cc:    (Yingchun Xu/MW/US/3Com)
>Subject:  Re: [MOBILE-IP] charter update
>
>
>
>At 02:40 PM 3/7/00 -0800, James Kempf wrote:
>>I agree if you consider the PDSN (or SGSN and GGSN in GPRS) and
>>connectivity to the Internet. But if you look at the RAN as a self contained
>>network, and consider soft handoff for mobility, then I would maintain
>that it
>>does introduce more complexity, due to the multiple incoming and
>>outgoing streams (macrodiversity in the cellular jargon).
>
>James:
>
>A CDMA network handles soft handoff within the RAN, so network components
>outside the RAN should not be involved in soft handoff issues. Now an all
>IP network in the RAN would introduce some hassles. I would think that this
>is a shortcoming of 'all IP' within a RAN and not a complexity of CDMA.
>Perhaps people that are on the 'all IP' bandwagon should consider that and
>weigh the benefits versus the hassles of 'all IP'.
>
>Jim Willkie

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Wed, 8 Mar 2000 20:15:31 -0000

> need another one to unify all of them.
Yeah, and probably this is not the place where to update Jim
on this, I guess.

Alessio

---

From: James Kempf <[email-masked]>
Date: Thu, 9 Mar 2000 08:59:15 -0800

>need another one to unify all of them.

Actually, the goal of MWIF is to have 3GPP and 3GPP2 have the same "all IP"
solution for both the core network and the RAN.

                jak

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 9 Mar 2000 11:21:27 -0600

>>Give you another update. As I know upto today, there are three groups
>>(MWIF, 3G IP, TSG-ALL IP) working on "all IP" solution and every one
>>of them has different vision (or purpose). I heard another  one is
>>coming in pipe (scary).  Sooner, we need another one to unify all of
>>them.
>

Looks like the discussion on this list is degenerating into what MWIF
or 3G.IP are doing and their objectives. Let's try to keep it focused
on Mobile IP. I do not intend to discourage discussion on topics that
are closely intertwined between Mobile IP and the work being done in
these forums, but we need to keep it relevant to the charter of this
WG. If the outcome of the work in these forums has a positive impact
on Mobile IP (getting it deployed) then we MUST look at how we can
assist in that effort.

-Basavaraj