Subject: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter update?)

From: Sirish K Challagulla <[email-masked]>
Date: Wed, 1 Mar 2000 21:32:45 +0530

All,
      Let us give a new terminology 3GMobile-IP, Is more generic, 3G stands  for
3rd Generation Mobile Networks. Support for 3G Networks  will be a grand Success
for us.

Best Regards
Sirish

---

From: Emad Qaddoura <[email-masked]>
Date: Wed, 1 Mar 2000 10:33:09 -0600

....

> -----Original Message-----
> From: Basavaraj Patil [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2000 9:45 AM
> To: [email-masked]
> Subject: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter update?)
>

....

>
> Does the WG need to develop a terminology document that can be
> referenced by all WG and Mobile IP related docs? It may be a
> worthwhile exercise and help us all to be on the same page.

I agree.

> -Basavaraj
> >PatC

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Wed, 1 Mar 2000 23:12:38 -0000

Any new rechartering should also consider
whether the goal is completing the MIP work
or opening an entire new activity.

If the goal is to solve "mobility in the small", or in access
nets, as I understand some folks are aiming at when they talk
about Fast Handovers, then probably an entire new WG is likely
to be needed.

A spinoff of the MIP WG, say  MIPSAT WG
(IP mobility support over Specific Access Technologies)
would probably be a good thing, accommodating
any need to address specific problems that
MIP is considered not sufficient to address over
specific access Technologies. Also this would
come with the benefit of providing a well defined
scope for each new proposal coming in.

There may be another approach (AKA "the tail that
wags the dog") that is defining a new access network
based on newly IETF specified access protocols, but this
probably would not be useful for some technologies
currently (or about to be) on the
marketplace (cellular and non cellular). It looks
like a long term work.

Which of the two? Both? or none?

alessio

> ----------
> From:         Fred Baker[SMTP:[email-masked]]
> Reply To:     Fred Baker
> Sent:         01 March 2000 17:40
> Subject:      Re: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter
> update?)
>
> At 09:45 AM 3/1/00 -0600, Basavaraj Patil wrote:
> >>that we have: - Link Layer Mobility (Inter-BTS hand-off)
> >>- pick a name Mobility (inter-BSC hand-off)
> >>- Intra-Domain Mobility (Inter-MSC hand-off)
> >>- Inter-Domain Mobility (when the hand-off crosses a domain boundary)
>
> another stab:
>
> keying off the issues that "domain" in IETF circles generally refers to an
> administrative domain, often one that is reflected in DNS and/or corporate
> ownership, and that at the BTS/BSC level what we're really talking about
> is
> wandering around within a particular cellular-etc technology...
>
>         technology-specific mobility
>         inter-technology mobility
>         intra-domain mobility
>         inter-domain mobility
>

---

From: Emad Qaddoura <[email-masked]>
Date: Wed, 1 Mar 2000 17:25:04 -0600

> From: Casati, Alessio (Alessio) [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2000 5:13 PM
> Subject: Re: [MOBILE-IP] Terminology (was: [MOBILE-IP]
> charter update?)
>
>

An interesting thought.

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 2 Mar 2000 16:57:11 -0600

>Fred Wrote:
>ownership, and that at the BTS/BSC level what we're really talking about is

Handoffs within the same technology or access types can vary depending
on the granularity of the handoff (Sector/Cell/MSC...) and then there
is the problem of handoffs between different technologies. Somehow the
first two suggestions are not very intuitive for the specific problem
on hand. Granularity of handoffs may be more descriptive (Just
thinking aloud)....
Can't come up with anything better at the moment though..

-Basavaraj

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 2 Mar 2000 17:28:51 -0600

>or opening an entire new activity.

If the WG feels that there are gaps in the current charter that need
to be closed then we should enhance the scope. Of course completing
the work items that are on our plate at the present time is of utmost
importance and not to be discounted at all.

>scope for each new proposal coming in.

Mobile IP's access independence characteristic makes it so viable.
So there's not much to be said for IP mobility support over specific
access technologies as you propose.

>marketplace (cellular and non cellular). It looks

Seriously???

>Which of the two? Both? or none?

None, in my opinion.

-Basavaraj

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Fri, 3 Mar 2000 00:11:31 -0000

BP,

> access technologies as you propose.
I'm not so sure about this as you are. I just say
IP itself is technology indep., but if you
want to support intserv there is for instance an ISSLOW spec,
an ISATM spec, and a spec on how to support
Qos on 802.x stuff. Just imagine if we want to solve
the problem of supporting IP QoS in mobile environment over
a certain access technology: it is at least as specific to the
technology as it may be for a fixed technology I guess.

I'm not advocating we set up any WG, I'm only examining
the situation and possible scenarios (which may include setting
up a WG)

> >marketplace (cellular and non cellular). It looks
I can answer "YES!" since I'm sure I'm serious ;)
But I'm also interested in knowing what this question is about
(what in the quoted text looks likely not to be serious?)

alessio

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 3 Mar 2000 10:02:50 -0600

>I definitatly not agree here.. It is very important to optimize the IP
>transport (doen in Robust Header Compression WG), mobility management over
>specific link layers, especially over different radio link layers because
>they have very special charateristics that needs to be adapted to in order
>to make it efficient...
>

The ROHC BOF/WG aims to optimize IP transport via compression or
stripping of headers over the air interface. And because of the
limited spectrum it needs to be efficient. But what does mobility and
handoffs have to do with that? How you handle IP transport over
specific access types and link layers is independent of mobility
management (well at least to some extent).

-Basavaraj

>/Thomas

---

From: Emad Qaddoura <[email-masked]>
Date: Fri, 3 Mar 2000 10:38:31 -0600

Hi,

        Has anyone done some analysis on the different mirco mobility
solutions presented in the MIP WG?
        This would be a good mechanism to understand how well Hierarchical
MIP, cellular IP, HAWAII or others would fit the real time need of
technologies like cellular.

thx.

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, March 03, 2000 9:15 AM
> Hans,
> I *was* pretty sure that I made myself clear, and based on
> your response I
> apparently didn't.
>
> I don't care much for cellular terminology, but I used it
> because it was
> convenient. Someone else sent an e-mail to this thread with
> the equivalent in
> the 802.11 world. From your e-mail below, you are *already*
> associating
> certain mobility levels to specific techonologies, when you state:
>
> > Why not referring to both with "Micro Mobility"? The
> definition might be,
> > this is IP-layer mobility with specialized means others
> than Mobile IP (e.g.
> > Cellular IP HAWAII).
>
> Why is Hierarchical Mobile IP not included here? Mobile IP
> can be used to
> provide micro mobility. The reason is because some people's
> definition of
> micro mobility is vastly different from others. Hence the
> reason why I want to
> move *away* from these terms, and create something new that
> is very well
> defined.
>
> PatC
>
> > "[email-masked]" wrote:
> > >
> > > All,
> > >
> > > I had a conversation yesterday with Charlie and we both
> agreed that we need to
> > > define the different layers of mobility. Today we use
> micro and macro
> > > mobility, and these terms mean completely different
> things, depending upon the
> > > proposal that you happen to be backing. Therefore, having
> agreement on the
> > > list as to what micro vs. macro means will be a long,
> drawn out battle, and I
> > > think that we have better things to do with out time
> (well, at least I do).
> > >
> >
> > Maybe we see it this way: different scenarios may need
> different mechanisms.
> > One size fits all is not the approach we want.
> >
> > > btw, in case you still aren't convinced, it isn't clear
> to me that what we
> > > today call micro-mobility cannot be achieved via
> hierarchical Mobile IP, while
> > > others believe that Hawaii or Cellular IP provides micro-mobility.
> > >
> > > So, I would like to propose that we agree on some new
> terminology. I believe
> > agreed here. LL-Mobility is Mobility on lower layers
> without involving IP.
> >
> > I'm not sure what You mean here.
> >
> > Why not referring to both with "Micro Mobility"? The
> definition might be,
> > this is IP-layer mobility with specialized means others
> than Mobile IP (e.g.
> > Cellular IP HAWAII).
> >
> > >
> > > I still don't have a preference for the second name, and
> I am not married to
> > > ANY of the names above. These are merely suggestions. The
> goal here is to ALL
> > > agree on basic terminology so that when we compare
> protocols, we can match the
> > > protocol against a set of common terminology.
> > >
> >
> > I think, the challenge is to allow for very different
> Mobility algorithms
> > suitable for very different areas. The crucial point for me is the
> > interface to the terminals and the access routers of the
> next Mobility
> > stage (e.g. a FA). We need standardized interfaces here. I
> definitely
> > do not want multiple Mobility driver software in an terminal. For
> > example binding updates, paging and AAA should use the same
> interface
> > no matter what technology actually is used to provide Mobility.
> >
> > I personally don't think we should adopt the cellular
> terminology. In
> > the names You propose are some assumptions on the functionality of
> > BTS and BSC which may not be valid for all wireless
> networks although
> > the mechanisms of the Mobile IP WG should be applicable.
> >
> > However it perfectly does make sense to me to construct a flexible
> > Mobility framework which can handle the needs of a cellular network.
> >
> > Regards,
> >         Hans-Peter Huth
> >
> > --
> >  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > |  Hans-Peter Huth                         Phone: +49 89
> 636 430 71 |
> > |  Siemens AG, Dept. ZT IK 2               FAX:   +49 89
> 636 51115  |
> > |  Otto-Hahn-Ring 6          E-mail:
> [email-masked]|
> > |D-81730  Munich
>         |
> >  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>

---

From: James Kempf <[email-masked]>
Date: Fri, 3 Mar 2000 13:31:44 -0800

>Jim, my intention was not to get boggled down in cellular terminology, and
>especially not in any particular vendor's implementation. If one
>implementation doesn't respect the different levels below, then so be it. I am
>trying to describe the various levels, assuming someone has created a truly
>modular network.
>

Sorry, Pat, you asked for comment so I commented. :-)

>That said, let's forget the cellular terminology, and rather concentrate on
>the new terminology that we need to create.
>
>

Yes, I agree.

I also agree with the goal of trying to come up with a flexible framework
that will accommodate the maximum possible radio technologies.

                jak

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Sat, 4 Mar 2000 10:47:11 -0000

Charlie,

Mobile IP [RFC2002 and its bis] is link independent.
No discussion.
Nobody argues.

But, since we have recorded many messages on updating
charter, we have to carefully understand what can fit
in this group activity and what not.

What's wrong with this? (which is what I meant in my msg)

> I'd rather consider Mobile IP as link-independent, and then engineer
> specific extensions for particular links when and if they are needed.
>
...And this may be work to be handled by another WG. Much in the
same way as the INTSERV WG and an ISSLL WG.

> For the specific case of QoS, I reckon that a layer-2 mechanism is
> required to implement whatever layer-3 allocations have been made
> (on the basis of whatever application-layer requests have been
>  fulfilled).  But that is a QoS problem, not a Mobile IP problem.
>
Which may require a new WG.

Regards

alessio

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Sun, 5 Mar 2000 20:37:02 +1100

Hi Pat

> Why is Hierarchical Mobile IP not included here? Mobile IP can be used to
> provide micro mobility. The reason is because some people's definition of
> micro mobility is vastly different from others. Hence the reason why I
> want to
> move *away* from these terms, and create something new that is very well
> defined.
>
> PatC
>
        Absolutely, we have a draft adressing exactly that (HMIP) for both
V4 and V6.

        Hesham

---

From: [email-masked]
Date: Mon, 6 Mar 2000 10:32:30 +0200

Hello, Andrew, and others,

Keeping Mobile IP decoupled from link-specific issues is possibly
needed e.g. to have the flexibility for now unkonwn technologies.

However, since micro-mobility solutions for different scenarios appear
anyway,
mechanisms to provide interoperability, or at least a graceful fallback to
macro-mobility in some cases might be needed. I would also much like to see
a
one-fits-all micromobility/QoS extension set but since this might be
non-trivial to
achieve, the next best thing would be to be able to negotiate what kind of
micro-mobility
extensions are in use. This might or might not need some API definitions,
depending on the extensions/technology used (key operations, network-layer
entity
calibration to some link-information, etc.). Rather, I would imagine a
Mobile IP
protocol handshake (flags?) identifying the micro-mobility extension(s)
supported.
These extensions should be kept as simple as possible.

OTOH, if a one-fits-all solution is searched, there might be a need for
careful
identification of both the terms and goals of micro-mobility, as well as the
least
common denominators among used technologies and how these provide or assist
in
reaching the goals sought for.

regards,

Jari Malinen,
Nokia Research Center, Finland.

> From: EXT Andrew T. Campbell [mailto:[email-masked]]
> Sent: 04. March 2000 5:42
> I agree with Charlie on decoupling for QOS.
>
> IP is link independent as Mobile IP is.
>
> When a QOS model is developed out for Mobile IP (e.g.,
> wireless DiffServ) on could imagine mapping to the radio link
> via issll type techniques via some open API that
> provides quality indicators for handoff (SNR, etc.)
> and for resource allocation.
>
> But to make Mobile IP dependent on that API is
> a NOP.
>
> Andrew
>
>
>
> "Charles E. Perkins" wrote:
> >
> > Hello Thomas and Alessio and Basavaraj,
> >
> > >> Qos on 802.x stuff.
> > > Since I work with this as well I could not agree more...
> > > It is very important to map the link characteristics to
> the mobility
> > > management (which in our case is IP based) in order to
> make it efficient...
> >
> > But whether it is important depends on the link.  For some or maybe
> > most links, Mobile IP works great without any changes.  And a lot
> > of the recent discussion about changes to Mobile IP doesn't have
> > anything to do with link characteristics, but more how the link is
> > to be operated because of very high-level policy decisions.
> >
> > Charlie P.
> Andrew
> http://comet.columbia.edu/~campbell
>

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 6 Mar 2000 10:08:10 +0100

But the mobility management is NOT independent of the access network if you
want it optimized...
/Thomas

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, March 03, 2000 5:03 PM
> To: [email-masked];
> [email-masked]
> Subject: RE: [MOBILE-IP] Terminology (was: [MOBILE-IP]
> charter update?)
>
>
>

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 6 Mar 2000 10:33:14 +0100

Well I speak about IP based mobility not mobileIP... We all know what mobile
ip is best for and what is not...

We where originally speaking about that mobile IP is not enough to solve the
mobility management...

We need clearer interfaces and I  posted a network arhitechure, which Pat
also agreed on, what we name it is irrellevant...

But what we need is clear interfaces so we can extend the mobility
management in the future....
The 4 levels that we discussed is tighhtly closed to how it looks in the
network today...

If we have clear interfaces and several layers of course it has also to be
some kind of hierarhical mobility management, but what is more important is
a defined framework for these different levels....

> I agree with Charlie on decoupling for QOS.
Well so do I, I was just speaking about that different links have different
characteristics....

And at the lowest level of a mobility arhictecture framework it should take
the link layer features into characteristics, or at least have the
possibility to do so... The fallback could of course be mobile IP for
operators that is satisfied with that, but my guess is that mobile ip is not
enough over many access networks...
... at least thats my opinion...

> and for resource allocation.
Agree with you here..:-)

> But to make Mobile IP dependent on that API is
Well if you dont want any advanced policy in your move detection policy it
is up to you....

Best Regards Thomas

---

From: Thomas Eklund <[email-masked]>
Date: Mon, 6 Mar 2000 10:44:54 +0100

Hi Hesham,
it is not a discusion about hierarchical mobile IP..
It is a discussion about defining clearer interfaces than today, and to
achieve this of course you need a hierarchical mobility management...
But the issues is that we need a good ip based mobility frameworks with
clear interfaces so new technologies, access network etc.. could be easy
integrated..

Cheers Thomas

-----Original Message-----
From: Hesham Soliman (EPA) [mailto:[email-masked]]
Sent: Sunday, March 05, 2000 10:37 AM
To: [email-masked]
Subject: Re: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter update?)

Hi Pat

        Why is Hierarchical Mobile IP not included here? Mobile IP can be
used to
provide micro mobility. The reason is because some people's definition of
micro mobility is vastly different from others. Hence the reason why I want
to
move *away* from these terms, and create something new that is very well
defined.

        PatC

        Hesham

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Mon, 6 Mar 2000 23:25:00 +1100

Hi Thomas,

I was just agreeing specifically with the statement that Pat made about
considering HMIP as a possible candidate for the "micro-mobility" management
amongst other proposals.

I used "micro-mobility" until the WG defines a more accurate term ;)

Cheers,
Hesham

> From: Thomas Eklund [SMTP:[email-masked]]
> Sent: Monday, 6 March 2000 8:45
> To:   'Hesham Soliman (EPA)'; [email-masked]
> Subject:      RE: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter
> update?)
>
> Hi Hesham,
>       micro mobility is vastly different from others. Hence the reason why
> I want to
>               Absolutely, we have a draft adressing exactly that (HMIP)
> for both V4 and V6.
>
>               Hesham
>