Subject: Re: [MOBILE-IP] Terminology (was: [MOBILE-IP] charter update?)

From: Thomas Eklund <[email-masked]>
Date: Wed, 1 Mar 2000 15:28:43 +0100

I glad we speak the same languague...
I totally agree with you.

I have tried to raise this question 1,5 year ago but with very little
reponse...

But I dont like you grouping with names very specific to cellular sytems
like BTS BSC and MSC
But I agree on the "levels"
But I would also like the level of personal network or pico mobility where
the typical scenario is the wireless router with a lot of bluetooth links...

> Link Layer Mobility (Inter-BTS hand-off)
> - pick a name Mobility (inter-BSC hand-off)
These two I would grouped together like micro mobility because they have the
same access network!!

In other word the could have the same L2 segment...

And the BTS is just a "wireless bridge" and could be an access point for a
wireless LAN for instance...

And in cellular sytems for instance it is very difficult to break up this
that why I think it should go under a common micro-mobility
And if it is a wirelles LAN access ponit you probably have a ethernet switch
connecting all your access points and 802.1Q ethernet gives you local
mobility...

But clear interfaces is a must.

/Thomas

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2000 3:07 PM
> To: Thomas Eklund
> Cc: [email-masked]
> Subject: Terminology (was: [MOBILE-IP] charter update?)
>
>
> All,
>
> I had a conversation yesterday with Charlie and we both
> agreed that we need to
> define the different layers of mobility. Today we use micro and macro
> mobility, and these terms mean completely different things,
> depending upon the
> proposal that you happen to be backing. Therefore, having
> agreement on the
> list as to what micro vs. macro means will be a long, drawn
> out battle, and I
> think that we have better things to do with out time (well,
> at least I do).
>
> btw, in case you still aren't convinced, it isn't clear to me
> that what we
> today call micro-mobility cannot be achieved via hierarchical
> Mobile IP, while
> others believe that Hawaii or Cellular IP provides micro-mobility.
>
> So, I would like to propose that we agree on some new
> terminology. I believe
> that we have: - Link Layer Mobility (Inter-BTS hand-off)
> - pick a name Mobility (inter-BSC hand-off)
> - Intra-Domain Mobility (Inter-MSC hand-off)
> - Inter-Domain Mobility (when the hand-off crosses a domain boundary)
>
> I still don't have a preference for the second name, and I am
> not married to
> ANY of the names above. These are merely suggestions. The
> goal here is to ALL
> agree on basic terminology so that when we compare protocols,
> we can match the
> protocol against a set of common terminology.
>
> Comments? Is this a worthwhile exercise?
>
> PatC
>

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 1 Mar 2000 06:43:34 -0800

> I totally agree with you.

good.
> I have tried to raise this question 1,5 year ago but with very little

Perhaps you were just a little ahead of your time :)

> the typical scenario is the wireless router with a lot of bluetooth links...

Agreed. I used the cellular names in hopes that most readers would have a
basic understanding of cellular systems, and to provide some context.

> These two I would grouped together like micro mobility because they have the

Here we disagree. Certainly, today's BSCs operate this way, but the work being
done in the All-IP standards will radically change the BSC. I see no reason
why an IP-level mobility cannot be used at the BSC (well, for CDMA anyways).

> wireless LAN for instance...

hence link-layer Mobility. Yes, I thought of using 802.11 as one example, but
it became harder to provider the other levels using 802.11 :(

> connecting all your access points and 802.1Q ethernet gives you local

Again, I respectfully disagree. We only think this way because of the current
systems, but some engineering effort is under way to change these systems, so
I would still prefer to see it the way I proposed. Otherwise, we will end up
with terminology problems when/if they do change.

> But clear interfaces is a must.
Well, I would agree on terminology. Proposals are plentiful, and picking one
from the list will be a rather difficult task. It must/will occur, but my
proposal is to simply come up with some common terminology.

PatC

PatC