Subject: [MOBILE-IP] Sequence Numbers in Binding Updates

From: Govind Krishnamurthi <[email-masked]>
Date: Tue, 28 Mar 2000 16:03:27 -0500

Hello:
There is some confusion in the terminology in  the definition of sequence numbers in  binding updates in the Mobility Support for
IPv6 draft.
According to the definition, "Each Binding Update sent by a mobile node MUST use a sequence number greater than the
sequence number value sent in the previous binding update (if any) to  the same destination address ( modulo 2 **16)".
For the sake of clarity, rather than "destination address" a more appropriate phrase might be "Home Address" (a permanent
address). Destination addresses might be understood as the present care-of address of the mobile node, in which case scenarios
can be constructed wherein the wrong address is chosen  as the address of the correspondent node.

Thanks,
Govind Krishnamurthi
Nokia Reseach Center,
Boston,

---

From: Linfeng Yang <[email-masked]>
Date: Wed, 29 Mar 2000 09:22:56 +0300

Hello Govind,

I think the definition in MobileIPv6 draft is right, since mobile node can
also send Binding Update to a correspondent node. In this case the
destination address will be the correspondent node's address, either its
Home Address or its care-of address if the correspondent node is a mobile
node too.

The present care-of address of a mobile node can be used as source
address in order to pass the ingress filtering. In this case, the home
address of the mobile node will be indicated in a destination option.

I hope you were not confused destination option with destination address
:)

Yours,

Lin

> can be constructed wherein the wrong address is chosen  as the address of the correspondent node.

Linfeng Yang
                Helsinki University of Technology
                Telecommunications Software and Multimedia Laboratory
                P.O.Box 9700, 02015 HUT, Finland
                Phone: +358-(0)9-451 5250     Fax: +358-(0)9-451 5351