Subject: Re: [MOBILE-IP] Home agent considerations for RFC 2794?

From: Tomas Goldbeck-Löwe (ERA)<[email-masked]>
Date: Wed, 19 Apr 2000 10:14:42 +0200

I think this error case should be covered in the next update of the rfc. It makes it easier to acually build a system based on this rfc.
But rfc2002 and draft-ietf-mobileip-rfc2002-bis-00.txt, (sec 3.4) says:
Registration denied by the home agent:
130 insufficient resources
134 poorly formed Request

Is it error code 130 we should go for?
Or do you get 134 "insufficient resource", from another rfc/draft?

        --> Tomas

> -----Original Message-----
> From: [email-masked] [SMTP:[email-masked]]
> Sent: Wednesday, April 19, 2000 5:54 AM
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] Home agent considerations for RFC 2794?
>
> hmmm... somehow I missed this one in my inbox.
>
> You bring up an interesting point. The draft doesn't quite specify how an
> address should/could be allocated, but does allow provisions for it. Perhaps
> in the next update (as it moves towards Draft Standard) we could cover this
> case. I think that Kent's suggestion is a fine idea. Error 134 sounds
> appropriate to me.
>
> PatC
>
> > >
> > > Hi all,
> > >
> > > RFC 2794 doesn't specify what the home agent should do if it fails
> > > to assign a home address for a mobile node that has sent a Registration
> > > Request with the Home Address field set to zero. This may occur for example
> > > if the home agent obtains the home addresses with DHCP and the DHCP server
> > > is down.
> > >
> > > The home agent should probably reply with an error code, but which
> > > code? Should we add this kind of home agent considerations to RFC 2794?
> > >
> >
> > Maybe code 134 'insufficient resource'?
> >
> > -- Kent --
> >
> > > I apologize if this has already been discussed.
> > >
> > > Regards,
> > > Henry
> > >
> > >

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 19 Apr 2000 06:09:02 -0700

No, I was simply agreeing with Kent. I didn't check the RFC. Whatever the
code, "Insufficient resources" seems like the right error code to return when
such an error occurs.

PatC
>
> I think this error case should be covered in the next update of the rfc. It
> makes it easier to acually build a system based on this rfc. But rfc2002 and
> draft-ietf-mobileip-rfc2002-bis-00.txt, (sec 3.4) says: Registration denied
> by the home agent: 130 insufficient resources

---

From: "Kent K. Leung" <[email-masked]>
Date: Wed, 19 Apr 2000 09:37:21 -0700

Yes, it is 130 "Insufficient resource".  My memory mistake.

-- Kent --