Subject: Re: [MOBILE-IP] RFC2002bis

From: Alper Yegin <[email-masked]>
Date: Tue, 11 Apr 2000 17:55:13 -0700

> Hi Alper
>
> >  Hi Charlie,
> >
> >  Sorry for this late reply, somehow I missed your e-mail.
> >
> >  > Regarding the following text:
> >  >
> >  > > The host specific route to MN shouldn't be available to
> >  any packets
> >  > > other than the ones arriving to FA on the tunnel
> >  configured for this MN.
> >  > > This requires forwarding based on not only destination
> >  address but also
> >  > > incoming interface.
>
> I know we have been through this already but I'd like to
> reiterate my objection to this. I don't see why two nodes
> (MN and fixed CN, or two MNs) attached to the same FA should
> not be able to communicate through this common FA rather than
> having to go through the HA. It would surely improve the
> performance of the communication by eliminating triangle routing
> and it is an implementation issue. We also have this as an option
> in the HMIPv4/v6 draft (draft-elmalki-soliman-hmipv4v6-00) where
> such an optimisation of routing may occur through the shortest FA
> path, thus eliminating triangle routing within the hierarchical
> domain.
>
> >Without this, there's the problem of
> >  getting HA out
> >  > > of the loop, and in the case of MN moving another site,
> >  host specific
> >  > > route will not go away until previous FA expires the
> >  registration,
> >  > > and until then any communication going through this FA will be
> >  > > interrupted.
> >  >
>
> This is solved if the MN, upon moving FA, sends a previous
> FA notification extension in its RegReq such that the previous FA
> receives a binding update with zero lifetime from the new FA
> (route optimisation). This is specified for hierarchical MIPv4 in
> Regional Tunnel Mgt. and in the above HMIPv4/v6 draft for
> Fast Handoffs.

Karim,

I understand this is less of a problem if [RFC2002 + route_optimization] is
used, but it's a problem if [RFC2002] is used.

alper

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 12 Apr 2000 09:47:46 -0700

Hello Alper,

I agree that the problem exists in RFC2002bis without
route optimization.  Therefore, I suggest that we make
a concerted effort to move the route optimization draft
along to Proposed Standard.

Furthermore, I think it would be a mistake to create
any special-purpose solution for intra-FA communication,
especially insofar as any such solution would duplicate
functionality from the Previous FA notification extension.

Having said all that, if the general consensus is to put
language into RFC2002bis allowing a FA to make use of
its existing visitor-list entries as host routes, I would
not make an objection.  I would like for someone else to
compose the text and champion its inclusion, however.

Regards,
Charlie P.