Subject: Re: [MOBILE-IP] handover: proactive versus reactive

From: Woo-June Kim <[email-masked]>
Date: Sun, 30 Apr 2000 14:21:55 +0900

All,

Could anyone point to a web page or ftp site where I can get some info on this L2CAP link adaptation protocol ? 

I've been using/developing PPP for while in wireless systems and it always seems so wasteful.

thanks

Woojune Kim

>>
>> Network access such as 802.11 is a good model, and that should be our
>ultimate
>> target.
>
>No Pat, I am (sort of, albeit a malcontent), a cellular insider, having
>worked in that
>industry for over 12 years.  My feeling is that PPP must be disposed of
>ASAP.
>This is not a very popular opinion among those that do set the standards for
>cellular
>in those groups like 3G.IP, 3GPP, 3GPP2, etc.  I believe we can still rescue
>Bluetooth
>from this "circuit" mind set, by recommending an L2CAP link adaptation for
>IPv4 and
>IPv6 that works precisely like that of 802.11 in the Pittsburgh BOF.
>
>-Phil
>

---

From: Wolfgang Hansmann <[email-masked]>
Date: Sun, 30 Apr 2000 14:28:41 +0200

Woo-June Kim wrote:
> Could anyone point to a web page or ftp site where I can get some
> info on this L2CAP link adaptation protocol ?

L2CAP is the segmentation / protocol multiplexing part of the Bluetooth
link-layer. The specification is available at

   http://www.bluetooth.com/link/spec/bluetooth_d.pdf

> it always seems so wasteful.

From that point, you shouldn't expect too much from L2CAP -- it's rather
Bluetooth specific. Hopes to "rescue Bluetooth" refer more to the
Bluetooth LAN access profile proposing "IP over PPP over L2CAP"
for LAN access. This link-layer nightmare should be prevented.

Wolfgang Hansmann