Subject: Re: [MOBILE-IP] question about FAC...

From: "[email-masked]" <[email-masked]>
Date: Fri, 28 Apr 2000 13:34:56 -0700

> Hi!!
> I have one question about FAC in mobile ip..
> (draft-ietf-mobileip-challenge-09.txt)
>
> At Chapter 8. which is SPI for RADIUS AAAA Servers,
> To compute the authenticator, we use
> "High order byte from challenge" || "key" ||
> MD5(Preceding Mobile IP data || type, subtype, length, spi || Least-order
> 237bytes from challenge)..
>
> However, I couldn't understand the meaning of "least-order 237 bytes from
> challenge"..
> if we don't have enough data from challenge (shorter than 237 bytes), which
> value must be concatenated??

If the challenge is greater than 237, take the last 237 bytes of the challenge.
 PatC

---

From: mlj shin <[email-masked]>
Date: Fri, 28 Apr 2000 20:32:29 GMT

Hi!!

Please, let me know about this question.
I'm so sorry that if I bother you.. , anyway, Thank you in advance..
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

---

From: Pete McCann <[email-masked]>
Date: Fri, 28 Apr 2000 18:11:59 -0500

>> value must be concatenated??

psc> If the challenge is greater than 237, take the last 237 bytes of
psc> the challenge.  PatC

Meaning, if the challenge is shorter than 237, then just use all the
bytes, including the first byte if necessary.

Also, I think there is a typo in the text above (there is a typo in
the current version of the draft).  The correct algorithm *should* be:

      High-order byte from Challenge || Key ||
      MD5(Preceding Mobile IP data ||
          Type, Subtype (if present), Length, SPI) ||
                                               ^^^^ missing paren
      Least-order 237 bytes from Challenge

-Pete