Subject: Re: [MOBILE-IP] WLAN vs. CellularIP

From: "Fabio Moioli (ERA)" <[email-masked]>
Date: Wed, 5 Apr 2000 16:28:36 +0200

Hi Werner,

I'm not really sure to understand your question...

- cellular IP works at the IP layer (using Cellular IP Routing, it can be utilized on networks ranging in size from LANs to metropolitan area networks).

- WLAN Mobility works at the link-layer and is applicable only within a single IP subnet (i.e. within a Virtual LAN)

Regards,
Fabio

-----Original Message-----
From: Pomwenger Werner [mailto:[email-masked]]
Sent: den 5 april 2000 15:18
To: [email-masked]
Subject: [MOBILE-IP] WLAN vs. CellularIP

Hi everybody !

I'm just a newcomer in the subject area of mobility and I've a problem
understanding why using cellular ip for micro-mobility and not only a
WLAN.
When I'm going to use MobileIP for macro-mobility and my foreign
network consists of one subnet with several WLAN access points,
isn't it possible to roam between the access points seamlessly, without
a new registration at the home agent ? What is the disadvantage
of using WLAN for micro-mobility (roaming within one subnet) ?

Maybe anyone has a paper with a comparison of cellular ip and wireless
LAN.
I didn't find anything. It would be of great help to me.

regards,

Werner

---

From: campbell <[email-masked]>
Date: Wed, 5 Apr 2000 23:24:58 -0400

Hello Werner:

I think this is a very good question that has been raised
by others, e.g., Prof. Haas asked me this when I presented and
demoed the CIP kit at Polytechnic University
to Prof. Goodman's team recently.

It is natural to think about 'WLAN vs. Cellular IP'
if you consider that Cellular IP is solely operating at the
data link in a wireless LAN subnet setting
or in larger bridged WLANs. Some very large scale
networks have been build (at CMU) using Lucent's WaveLAN in this
context but I not sure bridging is an infinitely
scalable solution. Others may be more informed.

Since we don't have the protocol spec for
WLANs or any source code it is difficult to compare them
with CIP but the question you ask in this context is
interesting.

(As an aside: The Lucent WaveLAN folks were very nice to
give us some low level APIs for grabbing and
programming beacon info (i.e.,
quality, SNR, etc.) for their 2 Mbps system - and
I am familiar with that version of the WaveLAN
to some degree - but I'm not sure if that is
public information so I can't disclose that. Those
API's are bundled with the Mobiware source code:
http://comet.columbia.edu/mobiware/. We developed
Mobiware a few years back and it represents an
open programmable mobile network. It uses
CORBA for service creation and Java for
demand loading active mobile filters in
support of QOS controlled handoff.
You can dig out the Lucent WaveLAN APIs there if
interested).

Back to your good question:

Cellular IP is a L3 technology as pointed out
by Fabio (that could operate at L2 as you indicate)
that supports the following features
not supported by WLANs as far as I know but, I
will stand corrected if need be:

1) L3 solution (but CIP could be implement in
   cheap L2 devices too)

2) Passive connectivity and paging (we feel passionately about
   this and believe that any future IP-based wireless technology should
   support this for salability reasons. Mobile IP and all the wireless
LANs
   do not support this important requirement);

3) Seamless handoff performance (near stationary throughput performance
   to a CIP clients at handoff rates of 1 handoff per second for TCP on
the downlink -
   this is great performance that we are proud of);

4) Security support that does not degrade CIP handoff performance;

5) Scalability far above a typical WLAN range. CIP is
   designed to scale from pico to man environments. It scales
   really nicely and our simulations back this claim up; and

6) An open solutions (most WLAN vendors do not, of course,
   release their specs or code  to the public domain - some do however)
   The CIP testbed code is publuc domain
   and the ns suite will be available soon.

I'm sure there are other issues that I may have overlooked but
you get the drift.

Best,
Andrew