Subject: Re: [MOBILE-IP] IPv6 Mobility Last Call Question

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Sat, 6 May 2000 15:10:35 +0100

> >       Well that is of course a reasonable example.
> > If I understand you correctly you're basically talking about being able
> to
> > do reverse tunnelling. I don't see why an FA is required for that
> purpose.
> > MIPv6 doesn't stop a MN from reverse tunnelling through the home
> network.
> > So given that the right policies are configured in the MN, nothing I
> know
> > of in the specs would stop that from happening. If I missed something
> > please let me know
> >
> >
> This may be a solution, but is that part of the MIPv6 spec?
>
>
> Sure, nothing in the spec stops that scenario as far as I know.
>
I would add to that, that according to MIPv6 the
correspondent node would not send traffic to
the corporation after it has received the binding
update, but to the visited network, and
as such we have problems. We need to add to the
spec the option to have CN's always
send traffic to the HA, I would
think.

>  I'm not an advocate for configuration but I think some sort of a "user
> profile" is essential.
>
Yes, but maybe not stored on the mobile node :).

           I also agree with you that an interaction with AAA is an absolute
necessity (also mentioned in our draft) but I wouldn't like to see the two
functions getting mixed so that you would end up needing MIP to exercise
access control. An interaction is great but let's keep them as separate
functions.

AAA does provide useful services and MIP had already
happened to benefit from them in V4, why not in V6?

>       Also by keeping "some" policies in the MN we can relief the network
> node from the extra processing load => more scalability.  Again I'm not
> suggesting letting the MN do everything but some policy enforcement in the
> MN might be a good thing.
>
Well, what you may keep in the mobile are a NAI and
credentials/authentication material.

Policies are enforced by the network.

alessio

---

From: "C. Perkins/D. Reese" <[email-masked]>
Date: Sat, 6 May 2000 10:34:48 -0700

Hello Alessio,

> send traffic to the HA, I would

The mobile node is not required to send Binding Updates
to any correspondent node.  If it does not, the mobile node
will get all its traffic from the HA.  The existing text
doesn't need to be changed in the regard.

> happened to benefit from them in V4, why not in V6?

What do you think about the AAAv6 draft?

Regards,
Charlie P.