Subject: Re: [MOBILE-IP] IPv6 Mobility Last Call Question

From: Thomas Eklund <[email-masked]>
Date: Mon, 8 May 2000 10:46:35 +0200

Hi Allessio,

>
> >
> >       >The mobile node is not required to send Binding Updates
> >       >to any correspondent node.  If it does not, the mobile node
> >       >will get all its traffic from the HA.  The existing text
> >       >doesn't need to be changed in the regard.
> >
> >  I think Charlie's answered this above. Just remember that
> the MIPv6 SW
> > _will_need_ to be configured. There is no way around that.
> So this is just
> > another configuration parameter. This is basically the option you're
> > referring to. It's a configuration option not a protocol option.
> >
> I would prefer avoiding host configuration if we could have some
> flag set in a message back from the HA telling the MIPv6 SW to
Why?
The only thing that happens if the host dont support local bindings of the
CN is that the traffic will go trough the HA...
In other words it works but the traffic will not take the optimal way , e.g
no route optimazation...

> -Turn off sending BUs
This option is like saying turn off toute optimazation, but why do you want
to do that when you have support for it?
Even a tiny thin client have enough memory for its CN's....

> -Reverse tunnel to the corporate HA
Why is that needed???
In ipv6 all the ip addresses are always topologically correct and there is
no need to do reverse tunneling to the corporate HA...

>
> It would avoid much pain with misconfigured hosts
> in the future.

dont see the need for it...

But that my opinion...

Regards Thomas

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 8 May 2000 05:18:33 -0700

> Even a tiny thin client have enough memory for its CN's....
Security and Privacy.

First off, I may know want everyone that I communicate with what my current
geographic position is, and chances are they can get a pretty good idea given
my IP address. So, BU MUST be able to be turned off.

Second, Short of having all of the v6 nodes in the network share some secret,
or having the promised great unified PKI in the sky, route optimization will
not be used by most clients due to lack of secure communication. So, until we
can all trust each other, BU MUST be able to be turned off.

My 2 cents,

PatC

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 8 May 2000 09:18:11 -0700

Hello Pat,

> can all trust each other, BU MUST be able to be turned off.

This does not require turning off Binding Updates.  It only
requires that binding updates should not be sent if they cannot
be accompanied by unforgeable credentials.

Furthermore, I strongly suggest that privacy decisions should
be made depending on the correspondent node.  Some communications
partners are people we are willing to trust with our location
information, and some are not.  And, finally, some mobile users
may be instructed not to trust anyone.

Regards,
Charlie P.