Subject: Re: [MOBILE-IP] Private addresses

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 23 Jun 2000 15:05:25 -0700

----------
X-Sun-Data-Type: text
X-Sun-Data-Description: text
X-Sun-Data-Name: text
X-Sun-Charset: us-ascii
X-Sun-Content-Lines: 76

Hello:
Please see the attached proposed text for addition in the
appendix in the rfc2344-bis draft. Please note that this
is a rough update and it is under editor's review.

Regards,
Samita

----- Begin Included Message -----

---

From: Tom Hiller <[email-masked]>
Date: Fri, 23 Jun 2000 08:47:45 -0500

Hi

The approach taken in 3GPP2 was to require the FA and HA to have public
addresses, and then we keep track of link addresses, home address, and HA
address in the FA. By maintaining this triplet of information, the FA can
resolve overlapping addresses. We also authenticate the link itself (outside the
scope of IETF protocols using a separate key and mobile identifier called and
IMSI) -- it is important to authenticate the link with this approach.

This discussion occured on the Mobile IP mailing list one year ago.

Charles Perkins and Pat Calhoun also have a draft on private addresses that
encompasses private HA and FA as well as MN home addresses.

Thanks,
Tom

We did not tackle private HA or FA addresss

Thanks
Tom Hiller

> Raffaele Pellicciotta wrote:
>
> Hi, I desire to have information about use of private addresses on Mobile
> IP!!!
>     What is its state of art?
>     Thanks a lot,
>         Raffaele

----- End Included Message -----

----- Begin Included Message -----