Subject: [MOBILE-IP] Private addresses

From: Raffaele Pellicciotta <[email-masked]>
Date: Thu, 22 Jun 2000 18:08:47 +0200

Hi, I desire to have information about use of private addresses on Mobile IP!!!
    What is its state of art?
    Thanks a lot,
        Raffaele

---

From: "Lee, Jiwoong" <[email-masked]>
Date: Fri, 23 Jun 2000 13:45:52 +0900

Dear Raffaele,
You may have a look:

    draft-ietf-mobileip-rfc2344-bis-01.txt
    Reverse Tunneling for Mobile IP, revised

in mobileip working group home page of IETF.

Or you can find another approach for use of private ip addresses
in this mailing list archives, they were not adapted as standards though.

Regards,

Jiwoong Lee
M.com

----- Original Message -----
From: Raffaele Pellicciotta
To: [email-masked]
Sent: Friday, June 23, 2000 1:08 AM
Subject: [MOBILE-IP] Private addresses

Hi, I desire to have information about use of private addresses on Mobile
IP!!!
    What is its state of art?
    Thanks a lot,
        Raffaele

---

From: Tom Hiller <[email-masked]>
Date: Fri, 23 Jun 2000 08:47:45 -0500

Hi

The approach taken in 3GPP2 was to require the FA and HA to have public
addresses, and then we keep track of link addresses, home address, and HA
address in the FA. By maintaining this triplet of information, the FA can
resolve overlapping addresses. We also authenticate the link itself (outside the
scope of IETF protocols using a separate key and mobile identifier called and
IMSI) -- it is important to authenticate the link with this approach.

This discussion occured on the Mobile IP mailing list one year ago.

Charles Perkins and Pat Calhoun also have a draft on private addresses that
encompasses private HA and FA as well as MN home addresses.

Thanks,
Tom

We did not tackle private HA or FA addresss

Thanks
Tom Hiller

> Raffaele Pellicciotta wrote:
>

---

From: Tom Weckström <[email-masked]>
Date: Mon, 26 Jun 2000 15:12:05 +0300

Hello!

Private address issue is discussed in Jouni Malinen's thesis and a
solution is implemented in Dynamics - HUT Mobile IP. The solution allows
private addresses for all other interfaces except the ones from a FA to
the Internet and a HA to the Internet. More information from
http://www.cs.hut.fi/Research/Dynamics/

Regards
        Tom

On Thu, 22 Jun 2000, Raffaele Pellicciotta wrote:

pellic >Hi, I desire to have information about use of private
pellic >addresses on Mobile IP!!!
pellic >    What is its state of art?
pellic >    Thanks a lot,
pellic >        Raffaele
pellic >

--
        Tom Weckström           Dynamics group
                                Helsinki University of Technology
                                [email-masked]
                                http://www.cs.hut.fi/Research/Dynamics/

---

From: Tom Hiller <[email-masked]>
Date: Mon, 26 Jun 2000 13:05:25 -0500

Hi,

I'll check out your URL. The solution I discussed in my previous email is
incorporated into 3GPP2's cdma2000 packet data standard IS-835. 

Thanks,
Tom