Subject: Re: [MOBILE-IP] RFC2344bis Reverse Tunneling

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 2 Jun 2000 09:42:23 -0700

Hi Jiwoong:

Section A1 in the current draft puts Mc into address space A to
provide an example of a visiting mobile node ( which has home
address in address space C) in the foregin network.

BTW, I am working with Gabriel to provide a section for the simplest
case of private address support through reverse tunneling draft.
Hopefully that will clarify the issues vs. possible implementation
requirement for private address.

Thanks,
-Samita

----- Begin Included Message -----

---

From: "Lee, Jiwoong" <[email-masked]>
Date: Sat, 3 Jun 2000 10:46:56 +0900

Dear Samita,

Please notice the statement in pp.20, RFC2344bis-01

   Figure A1: NON-ROUTABLE PACKETS IN DISPARATE ADDRESS SPACES

      Mc               Fa  Fb              Hb  Hc             Yc
   [MN]-----------------[FA]----------------[HA]---------------[Y]
        Addr space A          Addr space B       Addr space C

   In this diagram, there are three disparate address spaces:  A, B
   and C. The home agent (HA) has one address each on address
   spaces B and C, and the foreign agent (FA), on address spaces A
   and B.  The mobile node's (MN) has a permanent address, Mc,
   within address space C.

Mc belongs to Addr Space C, but not A.

If Mc belongs to Addr Space A, Mc is a local address and cannot send
[Mc->Yc] IP diagram since they are disparate.

Besides, if Mc belongs to Addr Space A, is it possible a MN aquires
a co-located COA and find an FA again to use it as a local mobile
agent ? ==> For this, I've not precisely verified yet.

Regards,

Jiwoong Lee

----- Original Message -----
From: Samita Chakrabarti <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, June 03, 2000 1:42 AM
Subject: Re: [MOBILE-IP] RFC2344bis Reverse Tunneling

> From [email-masked] Fri Jun  2 01:26:18 2000
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> X-Priority: 3
> X-MSMail-Priority: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
> Date:         Fri, 2 Jun 2000 17:22:46 +0900
> From: "Lee, Jiwoong" <[email-masked]>
> Subject:      [MOBILE-IP] RFC2344bis Reverse Tunneling
> To: [email-masked]
>
> Hi
>
> There is a part which describes the usage of reverse tunneling for
> private ip network.
>
> In Figure A1 of A.1, MN has its IP address, Mc.
>
> I recommend the fact that IP address Mc belongs to address space C,
> in lieu of address space A.
>
> Figure A1 itself can lead readers to confusion from the viewpoint that
each
> of Fa, Fb, Hb, Hc, and Yc follows the corresponding address space.
>
>
> Jiwoong Lee
>
>
> ----- End Included Message -----
>
>
>

---

From: "Lee, Jiwoong" <[email-masked]>
Date: Mon, 5 Jun 2000 10:57:15 +0900

Hi,

In order to support communications between Mobile node( who has a private
home address and is located at a private IP network) and a correspondent
host (who has a public ip address and is located in a public ip network),

how's designing of HA-NAT combination topology ? With this, HA MAY discern
home ip address and private ip address.

Hope to listen to your comments

Regards,
Jiwoong Lee

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 5 Jun 2000 15:40:48 -0700

For all of you that care about fast hand-off, our latest Internet Draft was
sent to the secretariat and will be shortly available. The name of the draft
is draft-calhoun-mobileip-proactive-fa-01.txt, and this version is drastically
different from the previous (-00) version.

We believe that this contribution contains the required extensions necessary
for Mobile IP to provide fast hand-off. Note that this draft does rely on
portions of the Route Optimization and the Regional Registration drafts, in
addition to RFC 2002.

This draft *could* be adapted to IPv6 in the event that the Mobile Attendant
(as proposed in Charlie's draft) is present.

PatC