Subject: [MOBILE-IP] Handoff Discussions

From: Basavaraj Patil <[email-masked]>
Date: Fri, 14 Jul 2000 14:28:12 -0500

Hi folks,

        I see that you're all interested in handoff!  That's good.  The
request for timeslots for handoff related topics would consume most of
our time at this IETF so we're going to propose the following:

Our goal at the end of this IETF meeting is to have a single draft for
a working group item for handoff. (Two may be needed, perhaps a
separate item for v4 and for v6).  To that end we would like the
authors of the various handoff proposals and other interested WG
members to work together and come up with a merger of some of the
existing proposals, or a small set of proposals (such as two) from
which the working group could pick one.

Here's how we would like to structure the time for this.  Before the
meeting we'd like the authors of the handoff drafts and other
concerned parties to reach an agreement on some criteria that such a
draft must meet and to compare your drafts to find common features and
differences between the proposals (such as the dialogue that has been
going on between Karim, Pat, James and others).  We'd like to allocate
20 minutes in the first session to discuss handoff in the context of
progress that has been made on this activity.  Between the two
sessions we'd like a small group to go work offline to merge some
proposals or pick one, or one or two for the group to decide upon.  In
the second session we'd like to allocate 30 minutes to talk about the
outcome of this activity, and a very short presentation of the one or
two proposals that have been agreed upon.

Also remember that we would like as much as possible to be
accomplished on the mailing list between now and July 31st.

Comments?

Cheers,
the chairs.

---

From: Steven Glass - Solaris Software <[email-masked]>
Date: Fri, 14 Jul 2000 15:42:25 -0400

> separate item for v4 and for v6).

    Why can't there be multiple hand-off technologies?

> Between the two sessions we'd like a small group to go work offline to merge
> some proposals or pick one, or one or two for the group to decide upon.  In

    This is a lot to accomplish in 2 weeks, since in order for a group (of
unbiased individuals) to merge proposals, or select 2 for the WG to then
select during the second session, they're going to have to be in a very
finished state.

    I would rather the WG discuss the merits of each proposal in Pittsburg,
perhaps what is required of a WG sanctioned proposal, then this smaller group
meet after the meeting to discuss recommendations to the group within 2 weeks.

                              Cheers,
                                  Steve

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 14 Jul 2000 12:56:54 -0700

> which the working group could pick one.

I think that melding our ideas is a fine idea, and I firmly support this.

> going on between Karim, Pat, James and others).
Again, I think that this a great idea, but I suspect that the authors in
question will require some assistance from the rest of the WG. Just among
ourselves, we probably will have a hard time agreeing on the correct model,
hence our disagreements on the list.

> We'd like to allocate
> proposals or pick one, or one or two for the group to decide upon.
I presume that the authors are part of the small group.

> In

Great idea!

PatC

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 14 Jul 2000 21:27:38 -0700

Folks:

I think there are a number of important extensions
required to make Mobile IP the 4G technology of choice.

Two issues that we have looked at in the COMET Group
are fast handoff and paging. I would argue that it
is important to consider both registration and paging to fully
optimize Mobile IP networks.

Looking at one optimization (i.e., registration)
for fast handoff without
considering paging (which can reduce signaling
on the core IP network and power consumption of
the mobiles) may be too near-term?
Looks like what  Basavaraj is proposing is
solely fast handoff. I'm questioning that here.

Some micro-mobility protocols have 'integrated'
support for fast handoff and
paging (Cellular IP and Hawaii) others only support
fast handoff (hierarchical Mobile IP). Still others
provide a minimal set of paging extensions
the base Mobile IP protocol (P-MIP).

I think IP paging should be a priority too
among other issues (AAA, etc.). But especially when we
are considering optimizing registration - which
is on the agenda.

On another related note. We have recently
completed an extensive evaluation
of a number of micro-mobility protocols (viz. Cellular IP,
Hawaii, Ethernet Switch, Hierarchical Mobile IP).

We observe that theses protocols can be considered as
realization of a generic micro-mobility model.
We implemented Cellular IP, Hawaii, Hierarchical Mobile IP
in ns using Dave Johnson's extensions
and studied handoff performance. We can make
two observations. First, we found that in typical
scenarios the difference interms of handoff
quality is small. Second, we identified the
reasons for these differences and related
them to the generic model. Other issues
outside the scope of the protocols can
impact the handoff performance far more
than the differences observed e.g., movement
detection.

We hope to provide an ID, presentation
and release the source code for all the models
soon.

Apologies for the verbose message - its the
water in these parts :-)

Andrew

---

From: Behcet Sarikaya <[email-masked]>
Date: Sat, 15 Jul 2000 13:58:05 +0900

Andrew said:
...
>First, we found that in typical
>quality is small.

I don't quite agree with this. We compared Mobile IPv4
handoff performance with the results reported in
Communication Availability (CA) technique of the Dynamics Group at
Helsinki
Univ. of Technology (HUT) as reported in IPCN 2000 proceedings
and we found that the differences are not so small, i.e. CA is really
performing
well.
Our Mobile IP v4 performance results were based on ns simulations
(ns using Dave Johnson's extensions).
  Of course, expect to see more to come on this.

--behcet

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Sat, 15 Jul 2000 01:47:06 -0700

Hello Behcet:

Thanks for your note.

I think you may have misunderstood my e-mail. (Apologies for not making
it
clearer). We do not compare micro-mobility protocols to
the base Mobile IP protocol (that would be unfair).
We only evaluated the micro-mobility protocols against
each other - that is fair.

We implemented Cellular IP, Hawaii and Hierarchical Mobile IP
in ns. In the case of handoff performance they were very close -
'small beer' as we say in England.

This is encouraging for consensus which the chairs are
looking for. What this mean is that
if handoff performance is the sole criteria to select one
of the above micro-mobility protocols as say
'the working group protocol' (I'm
not suggesting this - even if CIP is a mighty fine
protocol ;-) then you could just as well
toss a coin and any of these micro-mobility
protocols would do the job. Really there is
nothing in it.

However, the micro-mobility protocols implemented
show significant differences in
processing requirement, routing efficiency, manageability
and other parameters related to implementation and deployment.

Therefore you have to understand the requirements.
What features make one better than the other.
E.g., Hierarchical Mobile IP is more synergistic
to the root protocol. CIP and Hawaii have
built in paging. CIP is a L2 and L3 technology,
etc., the list goes on and on - just for this small
sample of m-m protocols.

There are lots of factors to consider.

Andrew

---

From: "Jari T. Malinen" <[email-masked]>
Date: Sat, 15 Jul 2000 01:01:25 -0700

Hello, Bechet,

>   Of course, expect to see more to come on this.

The experiments we took at HUT had the MCHO case for which there were
many scenarios where signal quality policies did have a difference.
First of all,
having no signal-based control vs. signal-based handoff scenarios made a
big
difference. Then issues like weak vs. strong fields, few vs. many access
points
within range (sparse vs. over-dense network) etc for different scenarios

favored different policies. But these did not affect the signalling as
within our
constraints there was no need for protocol extensions.

However, to find a protocol that would provide a synthesis of the
handoff work
different scenarios like MCHO and NCHO adaptable to different L2
technologies should be addressed by the end result.

I hope the suggested work should address separate (minimal, IPR-free,
core
design) components. The concept handoff is getting a bit fuzzy, e.g. the
following
solve a bit different problems and on some level each affect handoff
efficiency.
Proposals solving core handoff issues tend to have sketchy solutions for
many
of the issues below.

- "basic" handoff state management between current and previous router
- "micro" or regional mobility, security
- extensions for special-purpose optimizations (QoS, buffer mgmt, header

    compression, paging, traffic control, you name it..)

And, the constraints for IPv4 and IPv6 are quite different, solutions
for IPv4
and IPv6 should be separated.

Maybe a distribution of work could be attempted so that interested
parties
would co-author new documents on relevant handoff-related subproblems?
(the aim is interoperable standards, right?).

To have a more concrete baseline suggestion for an IPv6-based framework,

we recently issued (see Charlie's recent mail) a set of drafts, in
addition
to some new or complementary design ideas brought up by each component.

Regards,

--jari

Jari T. Malinen,
Nokia Research Center.

---

From: Gopal Dommety <[email-masked]>
Date: Wed, 26 Jul 2000 01:13:58 -0700

>two proposals that have been agreed upon.

It is a good idea. Since the first session is on Tue. How about interested
people
meet on Monday?

Thanks
Gopal

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Jul 2000 06:47:37 -0700

>It is a good idea. Since the first session is on Tue. How about interested

How about dinner on Monday? We could all meet at the IETF registration...

PatC

---

From: Gopal Dommety <[email-masked]>
Date: Wed, 26 Jul 2000 10:35:48 -0700

>How about dinner on Monday? We could all meet at the IETF registration...

That sounds good.

-Gopal