Subject: Re: [MOBILE-IP] Comparison of Fast Handoff and Proactive Handoff

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 13 Jul 2000 18:56:51 +0200

Hello Pat

>  I don't think it's too late. I believe that exchanging ideas
>  in this fairly
>  complicated, and possibly controversial space, can only
>  benefit the WG. We
>  need different mechanisms so that we can explore the
>  alternatives, and agree
>  on the best solution. It could very well be that the best
>  solution is a
>  combination of two or more.

Of course, I fully agree and we need this discussion to take
a step ahead in Pittsburgh.

>
>  The draft makes it clear that the Mobile Node MAY ignore
>  packets from a
>  Foreign Agent, and it certainly does not have to register
>  with it either. Yes,
>  it is different from RFC 2002 and the Regional Registration
>  draft, but keep in
>  mind that we are trying to solve a problem that I believe
>  wasn't fully covered
>  in those specs. btw, the FA is NOT registering on behalf of
>  the Mobile Node,
>  it is simply informing its GFA that a Mobile Node is
>  entering its cell. The
>  Mobile Node STILL needs to register.

OK, so my understanding was correct.
However, you state in your draft that proactive FA plus Regional
Registrations provide a complete fast-handoff solution for Mobile IP.
I think proactive FA is not compatible with Regional Registrations.

Also, as I already mentioned in previous emails, I don't like the word
"cell" above since it implies L2 scenarios. As you say below, we don't
want to get into L2 issues.

Let me put what I wrote previously in another way. The GFA/FA establish
some form of a binding with a small lifetime for the MN without
involving the MN. Maybe this is a better description.

>  >
>  > Network control of L3 handoff is possible in both our
>  approaches, but
>  > MN control of L3 handoff is not possible in your approach.
>
>  Incorrect. The Mobile Node has full control over who it is
>  willing to register
>  with. If two FAs share a common GFA, then the draft does
>  allow new FAs to
>  receive traffic for the Mobile Node entering its cell before
>  the registration
>  occurs. However, this assumes that the GFA and FAs are under the same
>  administrative control, so I see no harm since your traffic
>  is already
>  traversing that net.

How is it possible for a MN to have control over L3 handoff if it
isn't aware that a L3 handoff is occurring? I think the MN has no
real control over the L3 handoff process since it doesn't perform
movement detection and doesn't originate the (Regional) Registration
Request message. When the MN stays within the same domain, the MN
may not want to move to a certain RFA for a number of reasons
(preference? cost?). You seem to assume that a MN will have no
preference between FAs within a domain. IMO this is a limitation.

>  We do not get into L2 advertisement issues in our draft, as
>  the Mobile IP WG
>  tries to stay away from L2 issues. Certainly, an air
>  interface is more than
>  welcome to add advertisements to their protocol.

What is a L2 advertisement? I don't know what you mean but
this was never suggested.

>
>  I agree that advertisements must be issued sparingly, but
>  when should the FA
>  issue them? That is the issue at hand.

We cover this in our draft.

>  >
>  > According to my understanding, in terms of spectrum there
>  is no difference
>  > between our approaches. We have the MN register before the
>  handoff while
>  > you have the MN register after the handoff. Therefore the
>  same amount of
>  > messages (advertisements and registrations) are sent over
>  the air, just the
>  > timing is different.
>
>  But how long does it take for the MN to detect that it needs
>  to perform the
>  handoff?

With appropriate movement detection (which is probably the most
important factor) this can be very fast. That's why we discuss
this in our draft.

> The timing is what fast hand-off is all about.

Agreed. What you want to minimise is the disruption interval
due to a handoff. That depends a lot on L2 and coordination between
L2 and L3 handoffs. IMO we won't be able to answer this question
(involving L2) and it shouldn't be our aim. We need to concentrate
on minimizing L3 handoff delays without posing limitations on
Mobile IP.

>  > >  3) As mentioned in my previous email, with our draft,
>  it is possible
>  > >  to perform handoff between two RANs that are not directly
>  > >  connected at L2,
>  > >  although it would require some L2 support and some exchange
>  > >  of L2 information
>  > >  between the two disconnected RANs through L3. This is
>  important for
>  > >  3G systems, but probably not something the mobile IP
>  group wants to
>  > >  dwell on, since it does involve L2 details.
>  >
>  > I agree with you that we should not dwell on L2 details.
>  However I don't
>  > agree that what you are saying above is necessarily an
>  important thing
>  > for 3G systems. Radio networks don't always need to be
>  directly connected,
>  > but they exchange messages which we consider as
>  radio-specific L2 messages.
>  > That is our assumption which is applicable IMO and allows
>  us to hide most
>  > L2 details and concentrate on generic L3 handoffs.
>
>  This is also NOT covered by the pro-active FA draft, and the
>  draft works quite
>  well without the propagation of L2 data, so let's not worry
>  about this in this
>  WG.

I'm a bit confused. You seem to have different views than
James regarding this particular point, so I can't understand what
the assumptions behind your draft are. As I said previously
propagation of L2 data should not be an item here.

Regards,
/Karim

---

From: Chandana Pairla <[email-masked]>
Date: Thu, 13 Jul 2000 17:12:12 -0500

>How is it possible for a MN to have control over L3
>handoff if it isn't aware that a L3 handoff is occurring?
>I think the MN has no real control over the L3 handoff
>process since it doesn't perform movement detection and
>doesn't originate the (Regional) Registration Request
>message. When the MN stays within the same domain, the MN
>may not want to move to a certain RFA for a number of
>reasons (preference? cost?). You seem to assume that a MN
>will have no preference between FAs within a domain. IMO
>this is a limitation.

The handoff isnt completed until the MN registers with the
"new" FA. Hence the MN has complete control over it. The
draft only talks about preparing the "new" FA in
anticipation of the arrival of the MN. After the MN arrives
in the service area of the "new" FA it is upto it to accept
or reject the FA. The MN is free to exercise its preference.

>>  > messages (advertisements and registrations) are sent over

Actually, your draft requires that a total of 5 messages
need to be sent before the MN "can" recieve service from
the new FA. On the other hand we require only 2 messages
sent before the MN "can" recieve service. It is upto the MN
to decide whether it want to accept the service or not.

>important factor) this can be very fast. That's why we discuss

While your draft proposes the mobile handle this, we
propose the network handle it.

>due to a handoff.

The issue is to minimize the interval of service disruption
irrespective of whether it is due to a handoff or not.

Regards,
Chandana