Subject: Re: [MOBILE-IP] Handoff (and Paging?) Discussions

From: James Kempf <[email-masked]>
Date: Sat, 15 Jul 2000 18:32:46 -0700

Andrew,

Another point I think you are missing is the effect of a particular
fast handoff technique on factors other than handoff performance itself.
For example, buffering techniques have the effect of introducing
state into the network, whereas techniques that don't do buffering don't.
Depending on the requirements for a solution, this may or may not
be acceptable.

This is why I think it is important to have a list of requirements that
state what the desirable characteristics of a solution are, beyond simply
"it makes real time stream handoff faster."

                jak

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Sat, 15 Jul 2000 22:13:57 -0700

Hi James:

I wasn't missing the buffer/state thing but I agree with
your general point.

But there is no free lunch here, right?

If you want zero loss and fast handoff then
the are state, synchronization and complexity
penalties at play here - if you want
to do things in the access network that is.

Alternatively, you can have
smart TCPs which are more robust against
the typical loss patterns caused by handoff, in which case,
you may not need the heavy duty buffering/sync
techniques you point too to minimize loss. That's clean, fast
and e2e friendly - hey I like that!

Just a flip side to your point. But I see both side to
this argument and as you point out there are multiple
prespectives based on your requirement.

The question is what is the minimum control
that needs to be added (to the net) with the
least complexity for the max
performance (e.g., fast handoff with min loss is a
simple metric, there are others clearly).

Andrew