Subject: [MOBILE-IP] Questions about Route Optimization in Mobile IPv4

From: "Park, Hyun Seo" <[email-masked]>
Date: Wed, 19 Jul 2000 22:40:00 +0900

I have some questions as follows ....
Any comments are appreciated ....

1) How much 'cost' does "Triangle Routing" impose on packets from 
    CH to MN in basic Mobile IPv4 ?
    Is there any Modeling, Demonstration or Simulation about it ?

2) In Route Optimization draft, CH maintains Binding Cache.
    How much 'overhead' on it ?
    And, How about 'tradeoff' btw. this 'overhead' and above 'cost' ?

3) In Route Optimization draft, 
    If above 'cost' imposed by "Triangle Routing" is very high and
    CH can't understand Route Optimization protocol,
    CH doesn't acknowledge "Binding Update" .....
    How about my humble opinion ?
    My thoughts .....
    If HA doesn't "Binding Acknowledge" from CH for some time, 
    it deduces the CH can't understand Route Optimization protocol ...
    Then, it tries to send "Binding Update" to Routers 1~3 hops apart from 
    the CH .... 
    So this activity will be able to solve "Triangle Routing" problem indirectly ...

            HA +++++++++++ FA ---- MN
            |                    + +
            |                +   +
            |            +    +
            |        +     +
            |    +      +  
            R2      +
            |    +
            R1                                    +  tunneling
            |                                      -  link
            CH                                   
   
    It's too difficult to figure it ...... *^^*
       
Thanks for your time to read this mail ....
And any comments will be good enough to me .... 
Thanks in advance for any comments ....

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 19 Jul 2000 14:56:35 -0700

Hello,

I'll try to make some answers, but of course the questions that
you ask do not have any absolute answers.

>     CH to MN in basic Mobile IPv4 ?

This depends on the placement of the network entities, and the traffic
models employed.  There is no one answer.

>     Is there any Modeling, Demonstration or Simulation about it ?

There have been quite a few attempts to analyze parts of the situation.
Off the top of my head, I can remember work by Stuart Jacobs for
authentication, and by Ruixi Yuan for an idea about "friends" of a
mobile node.  There are quite a few other works.

>     How much 'overhead' on it ?

Memory is the main overhead, along with additional search time.
These costs are typically considered to be insignificant compared
to the network messaging costs.

>     And, How about 'tradeoff' btw. this 'overhead' and above 'cost' ?

Thus, the tradeoff would usually be for more processing complexity
and less messaging complexity (i.e., maintaining more "state").

>     If above 'cost' imposed by "Triangle Routing" is very high and

O.K.

>     CH doesn't acknowledge "Binding Update" .....

O.K.  We agree so far...

>     So this activity will be able to solve "Triangle Routing" problem indirectly ...

Take a look at VIP, from Teraoka/Sony, which does things this way.
The problem seems to be that it's hard to establish security associations
with random infrastructure routers.

Regards,
Charlie P.