Subject: Re: [MOBILE-IP] Questions about Route Optimization in Mobile IPv4

From: Muhammad Jaseemuddin <[email-masked]>
Date: Wed, 19 Jul 2000 19:12:42 -0400

> -----Original Message-----
> From: Charlie Perkins [SMTP:[email-masked]]
> Sent: Wednesday, July 19, 2000 5:57 PM
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] Questions about Route Optimization in Mobile
> IPv4
>
> Hello,
>
> I'll try to make some answers, but of course the questions that
> you ask do not have any absolute answers.
>
>
> > 1) How much 'cost' does "Triangle Routing" impose on packets from
> >     CH to MN in basic Mobile IPv4 ?
>
> This depends on the placement of the network entities, and the traffic
> models employed.  There is no one answer.
>
> >     Is there any Modeling, Demonstration or Simulation about it ?
>
> There have been quite a few attempts to analyze parts of the situation.
> Off the top of my head, I can remember work by Stuart Jacobs for
> authentication, and by Ruixi Yuan for an idea about "friends" of a
> mobile node.  There are quite a few other works.
>
> > 2) In Route Optimization draft, CH maintains Binding Cache.
> >     How much 'overhead' on it ?
>
> Memory is the main overhead, along with additional search time.
> These costs are typically considered to be insignificant compared
> to the network messaging costs.
>
        [MJ]  It may not be in the overhead category, but it requires
changes
        in host's IP stack implementation.

> >     And, How about 'tradeoff' btw. this 'overhead' and above 'cost' ?
>
> Thus, the tradeoff would usually be for more processing complexity
> and less messaging complexity (i.e., maintaining more "state").
>
> > 3) In Route Optimization draft,
> >     If above 'cost' imposed by "Triangle Routing" is very high and
>
> O.K.
>
> >     CH can't understand Route Optimization protocol,
> >     CH doesn't acknowledge "Binding Update" .....
>
> O.K.  We agree so far...
>
> >     How about my humble opinion ?
> >     My thoughts .....
> >     If HA doesn't "Binding Acknowledge" from CH for some time,
> >     it deduces the CH can't understand Route Optimization protocol ...
> >     Then, it tries to send "Binding Update" to Routers 1~3 hops apart
> from
> >     the CH ....
> >     So this activity will be able to solve "Triangle Routing" problem
> indirectly ...
>
> Take a look at VIP, from Teraoka/Sony, which does things this way.
> The problem seems to be that it's hard to establish security associations
> with random infrastructure routers.
>
> Regards,
> Charlie P.

---

From: "Park, Hyun Seo" <[email-masked]>
Date: Thu, 20 Jul 2000 10:19:43 +0900

RE: [MOBILE-IP] Questions about Route Optimization in Mobile IPv4
  Thanks for your comments, Charlie and Muhammad .... 
  My comments are included .....
            Hello, 

    [Park] How can I find it ? If you know, please let me know . 

    Or you can send e-mail addresses to contact them, if you know.

    [MJ]  It may not be in the overhead category, but it requires changes 
    in host's IP stack implementation. 

    [Park] I agree with you. Thanks

    O.K. 

    O.K.  We agree so far... 

    >     Then, it tries to send "Binding Update" to Routers 1~3 hops apart from 
    >     the CH .... 
    >     So this activity will be able to solve "Triangle Routing" problem indirectly ... 

    [Park] I will look into VIP .... Thanks a lot ....

    But, There is the same problem that it's hard to establish security associations with random 

    CHs, isn't it ? And I think the problem with CHs is more serious than with random Routers ... 

    Am I right ?

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 20 Jul 2000 10:50:53 +0900

Hi Hyun Seo,
  Can I recommend you to try to work out a simple exercise to evaluate
what is gained with route optimization?
I sometimes give in my graduate course on Wireless Networks simple
exercises of this nature. You can use this simple formula:
T=propagation time + transmission time + queueing time
and take a simple case of three nodes (CN, MN and HA) and calculate T
once without route optimization and once with route
optimization and see the difference your self especially on links with
high propagation time.
  Regarding VIP solution, there are newer solutions of more or less the
same nature (if I can mandate things on my routers type of thinking)
i.e., CIP and HAWAII and they do give much better performance.
  Lastly, if you look into mipv6 which is based on ipv6 which mandates
binding caches on all hosts, so your concerns are naturally resolved.

Regards,

--
Behcet

---

From: Cheng-Yin Lee <[email-masked]>
Date: Mon, 24 Jul 2000 19:10:42 -0400

"Park, Hyun Seo" wrote:

>      Thanks for your comments, Charlie and Muhammad ....My
>      comments are included .....          Hello,
>

Another way is to perhaps have the Binding messages
processed/intercepted by access routers or firewalls instead, making the
route optim transparent to CN/CHs.

If the Registration Request message is also intercepted, within a
foreign network domain, then there is opportunity to reduce handoff
latency as well.  What do you think?

cheers,
cyl