Subject: [MOBILE-IP] Short description and Two question

From: "Taeyong,Kim" <[email-masked]>
Date: Wed, 9 Aug 2000 10:21:29 +0900

Hi. recently, I schemed out a new idea about HA.
Then I want to know my idea is worth.

please, read the following short description and answer  the
question.^^;

I think subject of my idea is "distributed HA".

short description :

 _______           _____                    ______
 | RA  | ------ |FA | ----------- | MN |
 |_____|        )  |___|      ))))))))))) |____|
    |              )
    |             )
 _______    )          ______
 | TA    |  )            | CN |
 |_____|  )))))))))) |____|

TA : tunneling Agent
RA : Registration Agent
HA : Home Agent
CN : Correspondent Node
) : tunneling procedure from CN to MN
- : registration procedure between RA and MN via FA
| : synchronization procedure between RA and TA

TA : tunneling Agent
RA : Registration Agent
HA : Home Agent
CN : Correspondent Node

My Idea is that separates the HA to two functional unit (TA, RA).
TA is Tunneling Agent tunnels the packet to MN from CN.
RA is Registration Agent that keeps binding entries for each MN and
Process the Registration messages.
Note: TA must communicate with RA to know where MN is.

Scenario:
Registration:
1) MN sends the Registration Request to RA(initially, network prefix  of RA
and HA are same, that means HA is belong to RA)
2) RA sends the Registration Reply with the address of proper TA
3) FA receives the packet and relaying the packet to the MN
Note: almost procedures are same with original Mobile IP
but RA sends modified Registration Reply  to MN that contains
the additional information, address of TA.
Also RA does not advertise the address of registered MN but TA does.

Sending packet to MN:
1) CN sends the packet to MN
2) TA intercepts the packet
3) TA sends the Synchronization Request message to RA to know where MN is.
4) TA receives the Synchronization Reply from RA.
5) TA tunnels it to FA
6) FA relays it to MN
Node: step 3), 4) is always performed periodically.

Majority:
1) This idea can reduce the network traffics.
2) This idea can reduce the load of HA to separate it (RA, TA)
3) This idea can introduce the new routing algorithm (ex: dynamic HA)
4) etc
My question is:
1) Does same or similar idea exist?
2) Is this idea is sufficient for writing the RFC or contribution?

---

From: "Lee, Jiwoong" <[email-masked]>
Date: Wed, 16 Aug 2000 22:32:38 +0900

Dear Taeyong,

I had a look on your new idea and it seems nascent.
Rather I don't see the better qualification than the current version of IETF
Mobile IP.

Based on my understanding, your idea obtains performance elevation only in
the
case that TA is located closely to CN.  My notes are following.

1) How can TA intercept the packet of CN heading for MN ?
 - The only possibly reliable case is when TA is the edge router of CN.
    This is the deployment problem. All edge routers including CNs who want
    to talk to MN SHOULD be implemented with your idea.  The current Moblie
IP
    does not have to.

2) Security Association
 - RA and TA should have security association. Many TAs belong to one RA.
    One TA supports many RAs. Therefore, a new security problem should be
    solved out and network operators will have tough time to manage it.

I hope my remark might help you to build a new good scheme.

Jiwoong Lee

  ----- Original Message ----- 
  From: Taeyong,Kim 
  To: [email-masked] 
  Sent: Wednesday, August 09, 2000 10:21 AM
  Subject: [MOBILE-IP] Short description and Two question

  short description :

   _______           _____                    ______

  TA : tunneling Agent
  RA : Registration Agent
  HA : Home Agent
  CN : Correspondent Node

  TA : tunneling Agent
  RA : Registration Agent
  HA : Home Agent
  CN : Correspondent Node

  Scenario:
  Registration:

  Sending packet to MN:

  Majority: