Subject: Re: [MOBILE-IP] charter review

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Wed, 30 Aug 2000 15:48:44 +0100

I believe the WG want to get focused on the revised charter
to finalize outstanding urgent matters.
If the need for further work in the area you are
describing is felt necessary then a BOF and a new WG
should be the way to go at this stage.
I believe there's no
value judgement on the "demoted" drafts in the WG decision
to get more focused. In the end, the mobile IP WG
deserves to retire, as any other WG.

alessio

> ----------
> From:         Luca Salgarelli[SMTP:[email-masked]]
> Reply To:     Luca Salgarelli
> Sent:         30 August 2000 14:05
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] charter review
>
> Hi Phil.
>
> I apologize if this will be a naive question, but I guess I am not an
> expert on IETF procedures.
>
> I think it is now clear what were the technological criteria for deciding
> the new charter (no host-based routing or non-tunneling-based approaches
> will be handled by the Mobile-IP WG), but I do not understand how the WG
> arrived to the selection of such criteria. I do not remember any major
> discussion on these criteria being held on the mailing list.
>
> I think there are some undeniable technological benefits in avoiding
> tunnels
> in some parts of a wireless network (I am thinking at access-networks in
> particular), such as better efficiency in the usage of the air interface.
> In my opinion, ruling out such approaches without having a proper
> technical
> discussion within the WG could hurt the WG output in the long run.
>
> Just my 2 cents about re-chartering.
>
> Thanks
> Luca
>
> On Tue, Aug 29, 2000 at 09:31:28AM -0500, Roberts Phil-QA3445 wrote:
> > Hi Sandy,
> >
> >         I'm sorry it has taken so long to respond to this email.
> >
> >         What we have in mind I believe are protocol extensions to
> mobile-ip
> > that are based on existing mobile-ip entities such as foreign agents and
> > home agents, extend messages that are already used, and rely on some
> kind of
> > encapsulation or tunneling in a way that is similar to what is being
> done
> > today.  Developing protocols that rely on some form of host routing or
> > application level address management for example would be beyond the
> scope
> > of the group.  That's not to say some might find such an approach useful
> in
> > certain settings but that the mobile ip working group has its hands full
> and
> > won't be considering these kinds of approaches.  Is that clear enough?
> >
> > Phil
> >
> >
> > > -----Original Message-----
> > > From: Sandy Thuel [mailto:[email-masked]]
> > > Sent: Wednesday, August 23, 2000 11:23 AM
> > > To: [email-masked]
> > > Subject: Re: [MOBILE-IP] charter review
> > >
> > >
> > > >
> > > > The chairs would like to refocus the Mobile IP WG objectives to
> > > > protocols and solutions that are based on Mobile IP v4 and v6.
> > >
> > >  Can someone please explain CLEARLY how you determine whether or not
> > > "protocols and solutions" are based on
> > > Mobile IP and are therefore, within the scope of the
> > > mobileip WG charter? (e.g. do they have to be rfc2002
> > > compliant?)
> > >
> > > Thanks,
> > > Sandy
> > >
>

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 30 Aug 2000 07:52:58 -0700

Some of us are working on such a BOF.

PatC

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 30 Aug 2000 07:56:30 -0700

Hello Alessio,

Judging from the distance between need and deployment for
Mobile IP, it seems we have a very long way to go before
retirement.

I'm also not very comfortable about disallowing host-route
based approaches for Mobile IP.  I am comfortable with
focussing the effort on specifications that use Mobile IP
messages possibly with new extensions.  However, it seems
to me that some new extension might specify some behavior
related to host routing.

Regards,
Charlie P.

---

From: Sandy Thuel <[email-masked]>
Date: Wed, 30 Aug 2000 13:54:14 -0400

Hi Charlie,

> to me that some new extension might specify some behavior

This is precisely the issue that is unclear.
It makes absolute sense to focus the WG efforts on
specifications that solely use Mobile IP messages
(whether extended or not).  But outruling the use of
host routing methods may be a costly and unnecessary restriction.

Sandy