Subject: Re: [MOBILE-IP] Handoff framework [Was Re: [MOBILE-IP] Anothernovicequestions!]

From: Michael Kounavis <[email-masked]>
Date: Tue, 15 Aug 2000 03:13:57 -0400

Dear colleagues:

As a side note, modern software engineering can be
used for implementing extensible and modular
access network architectures, that incorporate many
different levels of abstractions, including those that
have been mentioned:

For example, one can completely separate the handoff detection
process  -which implementation can be specific to the link layer used-
from the handoff execution process which can be generic,
independent of the layer two, and implement them as
collection of software components that create bindings at run-time.

We have done some work on these concepts at CoIlumbia as
part of our reserach on programmable mobile networks.

--Michael

>I agreed with Jim. In fact, the approach has been used to some extent in 3G
>cdma2000 wireless network.
>
>In general, there are two approachs to abstract an Access Network:
>1. Abstract Link Layer Protocol: Defining an common link layer protocol to
>extend various Access Network to FA.
> By doing this, an FA will only need to understand the Abstract link layer
>protocol (or Abstract Access Network).
>Each Access Network will be
>responsible for translating (or mapping) its specific link layer to the
Abstract
>link layer.
>
>In 3G cdma2000, the RP interface protocol (to some extent) is an extension
of
>cdma2000 link layer.
>
>2. Link Layer Specific FA: This will make every Access Network has its own
>specific FA. The FA will be fully
>knowledgable of a specific link layer (or Access Network).  This method
tries to
>abstract Access Network
>at network layer so that from HA point of view, all Access Network are
same.
>Unfortunately, it makes Mobile IP
>depending on specific link layer.
>
>Method 1 is prefered since it makes Mobile IP independent of any specific
link
>layer protocol (but still dependent of
>the common Abstract link layer).
>
>---Yingchun.
>
>
>
>
>
>
>Arthur Ross <[email-masked]> on 08/13/2000 01:52:05 PM
>
>Please respond to Arthur Ross <[email-masked]>
>
>Sent by:  Arthur Ross <[email-masked]>
>
>
>To:   [email-masked]
>cc:    (Yingchun Xu/MW/US/3Com)
>Subject:  Re: [MOBILE-IP] Handoff framework [Was Re: [MOBILE-IP]
>      Anothernovicequestions!]
>
>
>
>At 11:09 -0700 08/13/2000, Sebastian Thalanany wrote:
>>The use of  an abstraction of link layer characteristics(ie. optional
>>triggers etc.) to assist L3 is fundamental to the realization
>>of efficient wireless mobile handoffs. I agree with Jim.
>>
>I support this as well. The trick, of course, is going to be coming up with
>that OOP- or WIN-like abstraction. And, like Jim said, in the attempt may
>lie a VERY USEFUL large-scale gedanken experiment in helping to clarify
>what the physical layer designers' problem(s) is(are), and how the legacy
>stuff either a) fits in, or b) can be patched up. This is, IMHO, precisely
>the sort of enlightened collective discussion of this problem that has been
>needed for a long time.
>
>   -- Arthur
>
>   Dr. Arthur H. M. Ross
>   2325 East Orangewood Avenue
>   Phoenix, AZ 85020-4730
>

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 15 Aug 2000 07:19:35 -0700

> collection of software components that create bindings at run-time.

This appears to be what we had been proposing the WG should do. The basic idea
is to come up with some basic capabilities that link layers have, which could
be used to perform the handoff execution process. Since some link layers are
more complex than others, some may provide better handoff performance.

PatC