Subject: Re: [MOBILE-IP] IPv6 handover document

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 15 Sep 2000 12:51:22 -0700

Hello Francis,

I'm catching up on old mail -- your original note in its entirety
follows these little snippets...

>    I guess some L2 help is always needed to make a realistic handoff.
>    (ie. avoid these RA beacons).
>
> => I agree!

But what does "realistic" mean?  What if the medium was a bit faster,
and handover had to happen within 50 ms, and if beacons came out
"fast enough" but did not consume more than 1% of the bandwidth?

>    => What you say above is very interesting and we've been looking into
>    similar algorithms that reuse L2 knowledge. One general comment though,
>    Sending a Neighbour solicitation (or even worse router solicitation) only
>
> => I agree about a NS is better than a RS.

What would the target address be?

Regards,
Charlie P.

Francis Dupont wrote:
>
>  In your previous mail you wrote:
>
>    I guess some L2 help is always needed to make a realistic handoff.
>    (ie. avoid these RA beacons).
>
> => I agree!
>
>    => What you say above is very interesting and we've been looking into
>    similar algorithms that reuse L2 knowledge. One general comment though,
>    Sending a Neighbour solicitation (or even worse router solicitation) only
>
> => I agree about a NS is better than a RS.
>
>    due to signal measurements makes the assummption that whenever you change
>    Base station, you also change subnets.
>
> => we need to know the layer 2 property before in order to say if
> this assumption was made. In a IEEE 802.11 network in an ad-hoc mode
> ("an" because a well-known vendor has its own ad-hoc mode :-) you
> can do real good things with signal strength (no base station => no
> assumption). Same if base stations and routers are always in the same box.
>
>    That coupling is not required by
>    MIP and hence may also be inefficient in terms of radio resource usage.
>
>    Also are you making the assumption that you can talk to two routers
>    in two subnets at the same time ?
>
> => obviously there is something like overlapping cells here.
>
>    Do you have a specific Layer 2 in mind ?
>
> => ah! This should be the next point after "Link Layer Assisted ...".
> I am afraid it is a bit hard to rely efficiently on a generic layer 2.
> Unfortunately not a scoop!
>
> Thanks
>
> [email-masked]
>
> PS: is there a specialized mailing list for this topic?

---

From: Francis Dupont <[email-masked]>
Date: Sat, 16 Sep 2000 15:25:42 +0200

=> my point is the idea to use RAs as a beacon is very bad idea.
The RFC 2461 timings for RAs are:
 - MaxRtrAdvInterval (min 4, max 1800, default 600)
 - MinRtrAdvInterval (min 3, max 3/4MaxRtrAdvInterval, default 1/3MaxRtr.)
 - AdvDefaultLifetime (min MaxRtrAdvInterval, max 9000, default 3MaxRtr.)
 - AdvValidLifetime (default 2592000s/30days)
 - AdvPreferredLifetime (default 604800s/7days)
any proposal with a different scale for one of these values is *broken*.
For instance if you'd like to reduce AdvDefaultLifetime to a small value
(some seconds) then you should do this indirectly (IMHO it is exactly
what Advertisement Interval Option does).
If I come back to your text, you seem to ask for RA rates between 20 to
100 per second, then this is IMHO broken, ie. something else should be
used (note this doesn't work with I-D 12, rate is limited to 2 RA/s).

=> the link-local router address. If the purpose is to know if the router
is alive, a NS is simply enough...

Regards

PS: if you'd like to use an IPv6 packet for a beacon then something
like an empty no-next-header to a (new) multicast link-local "all-MN"
address is enough and the cheaper. Please keep RAs for more useful things...

---

From: Chern Nam Yap <[email-masked]>
Date: Sat, 16 Sep 2000 15:34:24 +0100

Hi

Agree on that point of using RA as beacon is very bad idea.
If the key issue here is to allow mobile node to determine change in Network
Prefix.

The simpliest, fastest, most feasible way currently
that IETF can "talk about" is using IIP method of doing handoff.

That is:
by looking at the co-located IP address (Network Prefix)
that PPP server issue during PPP setup session.

Hence no matter how fast, or how quick any IP handoff is,
the ultimate limit lies with link layer handover.

PS: I presume that the "smart handoff" Francis is looking for... ;)
----------------------------------------------------------------------------
---
Chern Nam Yap
Research Associate
Center for Mobile Communication Research
Department of Electronic and Electrical Engineering
University of Sheffield
Regent Court
211 Portobello Street
Sheffield S1 4DP
United Kingdom
Tel:+44 (0) 114-222-3308
Fax:+44 (0) 114-222-8299
Web: www.mobile1.net
E-mail: [email-masked]
E-mail: [email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Sat, 16 Sep 2000 17:25:01 +0200

=> RA = IPv6 router advertisements.

   That is:

=> this is not for IPv6 (no PPP, no prefix, ...). But if you mean a PPP
shutdown-setup helps movement detection it is true (basic interface change
with no interface in the middle of the operation) but new radio links
no more use PPP (or do you suggest PPPoE?) even if UTMS will have some
kind of point-to-point communication at the layer 2 between BSS and phone *.

=> but this is out of the scope of the WG.

Regards

PS *: don't ask why we won't be able to do direct phone to phone
communication (:-).

---

From: Chern Nam Yap <[email-masked]>
Date: Sat, 16 Sep 2000 17:12:11 +0100

Hi

----- Original Message -----
From: "Francis Dupont" <[email-masked]>
To: "Chern Nam Yap" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, September 16, 2000 4:25 PM
Subject: Re: [MOBILE-IP] IPv6 handover document

> => RA = IPv6 router advertisements.

yup!

> with no interface in the middle of the operation) but new radio links

1) IPv6 have PPP RFC 2472
2) IPv6 support IPv6CP

> no more use PPP (or do you suggest PPPoE?)

Forget about using 802.11, that is old technology with lots of holes.
There are many new technology out there now like Bluetooth, HiperLan, LMDS,
CDMA, GPRS.....

> even if UTMS will have some

1) GPRS uses PPP to connect to Mobile station (101 348 version 7.2)
2) CDMA2000 uses PPP. (July 2000 version) TSG-P version 1-A

I am sorry that I am not getting the latest version, and I am will grateful
if you can provide me with the information that you have.
Moreover, it will be even better if you can provide me with
realistic equipment to try with, especially W-CDMA/CDMA 2000.

> => but this is out of the scope of the WG.

I suppose it is true that anything about link layer is out of the scope of
this WG

But, what i am trying to say is that PPP is a link layer protocol,
The speed of handoffs lies with link layer connection.

---

From: Francis Dupont <[email-masked]>
Date: Sat, 16 Sep 2000 18:59:39 +0200

yup!

=> it was just in order to fix the context (before someone begins to
talk about the FA :-).

   > => this is not for IPv6 (no PPP, no prefix, ...).

=> which is described in RFC 2472 and has nothing like subnet prefix
negociation. IPv6CP has two functions (no more): negociate a different
interface ID at the two ends, negociate compression protocol (we moved from
zero possibilities to one, not too hard to do :-).
Prefix acquisition is done by the RA from the other end (which should be
a router) and is part of the standard "new link" sequence. This is more
general than PPP.

=> not yet convinced... 802.11 had large successes at last IETF meetings
and I know many places where 802.11b equipment is bought these days
(I agree this doesn't make 802.11 a good techno, but this makes Lucent
shares attractive :-).

   There are many new technology out there now like Bluetooth,

=> a security hole announced?

   HiperLan,

=> I can sell to you some photos of HiperLAN 1 devices. It should be very
expensive in some years (:-).

   LMDS,

=> not yet

   CDMA,

=> not living in USA

   GPRS

=> not this year (last news from France Telecom)

   > kind of point-to-point communication at the layer 2 between BSS and phone

=> I have heard 3GPP*&co people want to replace PPP by something else.
It is too late for GPRS/GSM but not for GPRS/UTMS or CDMA2k.
Of course, I have no accurate document about the new choice but
even PPP has many advantages it seems everybody gives up PPP...

=> I am sorry but I have not last documents (help) nor CDMA devices
(I'm in Europe too and you need the whole thing, not only a handset,
and this is *more* than expensive today).

=> of course it is...

=> If I understand your idea is to mandate PPP because it is a simple
and very well known link layer with a clear up/down state. You'd like
to use it in order to control handoff by the network, this idea works
and can be sold to mobile phone people but it will be hard with
wireless LAN people... If you succeed it will simplify my code.

Regards

[email-masked]
(ENST= Telecom Engineer School, Bretagne= Brittany, FR= France (ISO IS 3166))

---

From: Chern Nam Yap <[email-masked]>
Date: Sat, 16 Sep 2000 20:22:35 +0100

Hi

> a router) and is part of the standard "new link" sequence. This is more

Essentially, with mobile node detecting the end process of IPv6CP,
and trigger the process to send RS for the required prefix will
still better than waiting for the router to send one RA.
In current state, this will be easier than strong cell switching
for link layer.

> (I agree this doesn't make 802.11 a good techno, but this makes Lucent

In the research point of view, 802.11 has more issue to get QoS in place.
Moreover, it will take some effort to get strong cell switching technology
into it. Due to the fact that many people having 802.11, it is even tougher
get it done.

> => a security hole announced?

At this moment when fire is small.
There is still time for the fireman.

> expensive in some years (:-).

Pentium IV 2Ghz cost a lot too........

> => not yet

Singapore has announce licensing for LMDS.............

> => not living in USA

I suppose you don't go IETF meeting then............

> => not this year (last news from France Telecom)

Obviously, they have spent about 25.1 billion pounds acquiring Orange ;)
Trial running at Hong Kong, Singapore, London ........
Only few months more to 2001......

> even PPP has many advantages it seems everybody gives up PPP...

I believe that, Bluetooth is part of 3G
If you have when to the IP over Bluetooth BOF,
those guys has still give up Ethernet
and ends up with PPP.
May be you can ask them why.

> and this is *more* than expensive today).

That is why I hope someone in this mailing list will kindly provide
me with some "input" ;-)

> wireless LAN people... If you succeed it will simplify my code.

Does WAP phone consider as "mobile phone people" or "wireless lan people".