Subject: Re: [MOBILE-IP] Vendor/Organization-Specific Extensions

From: Rambabu Tummala <[email-masked]>
Date: Wed, 27 Sep 2000 15:59:06 -0400

Let me understand this case,

An FA is allowed to send and Agent Advertisement with "NVSE", correct?.

This is very important in the case of a Foreign agent of a specific vendor
sending agent advertisement with NVSE extension, where the Mobile Nodes of
that vendor understand this extension and process the message, where as
other MN's still use the message, but ignore the extension.

Is this correct?

Gopal, do you know when the official values be assigned?

-Regards,

Rambabu Tummala
Nortel Networks
ESN 444-8970
External (972)684-8970

On Tue, 26 Sep 2000 10:42:50 -0700, Gopal Dommety <[email-masked]>
wrote:

>At 03:29 PM 25/09/00 +0300, Henry Haverinen wrote:
>>Hi all,
>>
>>I have some questions concerning draft-ietf-mobileip-vendor-ext-11.txt.
>>
>>Section 2.3 doesn't cover the case of an Agent Advertisement
>>containing a CVSE. Is this because the operation is obvious (MN
>>must silently discard the Advertisement)?
>
>That is correct.
>
>>Such an extension is useful if a FA doesn't want to receive
>>Registration Requests from MNs that don't support a certain vendor/
>>organization-specific feature.
>
>Yes, if you want the entire advertisement to be ignored.
>
>
>>I wonder why the current version of the vendor-ext draft doesn't suggest
>>any type values for the extensions but just says "to be assigned by IANA".
>>Did the type values used in previous versions (38 and 134) overlap
>>with some other draft? It might be a good idea to give some initial
>>guesses for the types so that people can be implement the draft and test
>>the interoperability of their implementations. I guess even the vendor-
>>specific extensions should be tested for interoperability, as the draft
>>specifies processing considerations for unrecognized vendor types.
>
>We did specify the type values and IESG instructed  that we remove the
>any recommended assignments by us. The values we picked were not
>conflicting with any assigned value. I think this is an IESG policy.
>
>
>>Regards,
>>Henry

---

From: Henry Haverinen <[email-masked]>
Date: Thu, 28 Sep 2000 12:51:57 +0300

Raj and Gopal,

I hope you don't mind that I'm posting this to the
mailing list, because I think others may be interested
in this as well.

> Seriously, I think the reason why IANA wants to do the
> assignment is because once a registry for a protocol has
> been setup they become the authority in administering
> the type values w.r.t that protocol.

It's a very good idea to have a central authority that
assigns the protocol numbers. But we should get
the type values for the drafts early so that we can implement
them and test them for interoperability.

Do you think we could get type values for the vender-ext
draft and other Mobile IP drafts from IANA soon, even before the
protocols get the Proposed Standard status?

Regards,
Henry

---

From: Gopal Dommety <[email-masked]>
Date: Thu, 28 Sep 2000 10:29:32 -0700

At 01:30 PM 26/09/00 -0500, Rambabu Tummala wrote:

>This is very important in the case of a Foreign agent of a specific vendor sending agent advertisement with NVSE extension, where the Mobile Nodes of that vendor understand this extension and process the message, where as other MN's still use the message, but ignore the extension.
>
>Is this correct?

Your understanding is correct.

>Gopal, do you know when the official values be assigned?

Waiting for IANA to assign.

Thanks
gopal