Subject: Re: [MOBILE-IP] Comments on draft-calhoun-mobileip-proactive-fa-02.txt

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 4 Oct 2000 17:23:18 +0200

On Wednesday, October 04, 2000 15:59, [email-masked] [SMTP:[email-masked]] wrote:
> >
> > I agree.  I'm concerned, however, that the octet sub-type may be
> > insufficient. It may need to distinguish between not only different wireless
> > transmission technologies, but also between the same technology applied in
> > different frequency bands. -- An alternative is of course to express
> > link-layer address formats in such a manner that it comprises both band and
> > address information, when the technology itself doesn't have an address
> > scheme that lets you derive the frequency band from the link layer address.
> > Then the LLA field in 9.0 would actually be something more than a simple
> > link layer address.
> >
> OK, but would be, I assume, for a very specific technology, right? So, when
> that technology's LLA is defined, it would include the band. In the CDMA2000
> part, we also encode the RLP identifier, which is not part of the MAC address
> itself. However, other technologies don't have such extensibility.
>
> So, do you have specific text to propose?
>
> PatC

Yes, right.

I'd propose:'
      LLA

         Contains the Link Layer Address, or a composite of a Link
         Layer Address field and a radio band designation field for
         technologies where the same Link Layer Address may occur on
         multiple radio bands.
'

        Regards,
                Henrik

---

From: Ajoy Singh <[email-masked]>
Date: Wed, 4 Oct 2000 13:03:58 -0500

Hello Pat/All,
How about the idea of documenting the details of LLA encoding in some
informational draft ? If you like the
idea, we can come up with such a document and keep on adding new stuff based
on others' comments. This
will avoid frequent changes in proactive draft.
regards,
ajoy

I was just thinking of having an informational draft that can talk about the
details of LLA encoding for
different technologies. If everybody like the idea, we can start working on
this. This way we do not have
to provide these details in proactive draft.
regards,
ajoy

-----Original Message-----
From: IP Routing for Wireless/Mobile Hosts (mobile-ip)
[mailto:[email-masked]]On Behalf Of Henrik
Levkowetz
Sent: Wednesday, October 04, 2000 10:23 AM
To: [email-masked]
Subject: Re: [MOBILE-IP] Comments on
draft-calhoun-mobileip-proactive-fa-02.txt

Yes, right.

I'd propose:'
      LLA

        Regards,
                Henrik