Subject: Re: [MOBILE-IP] MIPv6 node location detection

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 19 Oct 2000 09:51:05 +1100

> On Wed, 18 Oct 2000, Jarno Rajahalme wrote:
>
> > John F. Leser wrote:
> > > - Then, whenever a MN receives an RA with the H bit set, it will know
> > > with certainty whether that RA came from the current home or foreign
> > > network, or from some new network, based on whether the prefix of the
> > > MN's home or current CO address is advertised in the RA. This way,
> > > movement onto a new link is detected as soon as any home agent on that
> > > link sends an advertisement.
> > >
> >
> > What if the MN never receives a RA with the H bit set?
>
> Then the mobile node falls back on some slower mode of movement
> detection.
>
        => I'm not sure why you're emphasising the 'H' bit.
        The H bit is only a flag that means "I'm a HA".
        It does NOT mean "I'm YOUR HA". So having said that,
        I would say you don't have to worry about having the HA
        tell if you're at home or not. You know that from the RA,
        whether it comes from your HA or another router.

> > I hope you do not assume all links have home agents.
> >
> Routers could be configured to fill this role while not accepting home
> registrations by setting the H bit and inclunding a home agent information
> option with 0 home agent lifetime (This is currently against spec, but
> could be defined to mean 'I have complete prefix information but will not
> serve as a home agent')  Or, perhapse it would be better/cleaner to define
> another bit the RA to indicate that this router has the complete prefix
> list.
>
        => Why not just advertise the RA ? What is the point
        of the H bit ?

        I'd like to repeat a comment that was said before.
        A MN does not have to move when it has a new
        prefix. It has to move when it hears a new prefix
        and the old default router disappears.

        If you think that it is too slow to probe the old router
        then you can move as soon as you hear a new prefix.
        This is ok as long as you don't oscillate.

        Hesham

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 18 Oct 2000 19:12:57 -0700

Hello,

I thought that the idea was to have the home agent advertise all
of the "available" prefixes.  If the mobile node is on a link that
doesn't have a home agent, then it should still be able to listen
for regular advertisements, but then it doesn't have to worry about
renumbering its home address.  Whatever strategy is realistic for
renumbering non-mobile nodes, will also work for mobile nodes
and their care-of addresses.

I don't think there is any problem here.  I thought that the only
problem was when the mobile node might have been away from
home for long enough to miss out on some transitional advertisements
from its home agent.  Is there something else?

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Fri, 20 Oct 2000 14:14:59 +0200

In your previous mail you wrote:

=> I'll agree if you change "the old default router" by "old default routers".

=> I think it is important to be protected against rogue router
advertisements... The only scenario discussed here is the cellular one
and usually it is not the kind of media with the lowest error rate.
And of course there is the case of overlapping cells.

Regards

[email-masked]

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 20 Oct 2000 08:26:28 -0700

Hello Francis,

> And of course there is the case of overlapping cells.

My radar is tuned to finding things that need to be changed
in the specification for the next revision.  I don't think
this represents a "Mobile IPv6" problem.  I think it is a more
basic problem with Neighbor Advertisements, and as such we should
not try to fix it in the Mobile IPv6 specification.

Does this sound reasonable?  I hope so, because I am very
much hoping to avoid the big delay that fixing this problem
would represent.

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Fri, 20 Oct 2000 18:27:57 +0200

My radar is tuned to finding things that need to be changed
   in the specification for the next revision.  I don't think
   this represents a "Mobile IPv6" problem.

=> I agree. In fact I think all the movement detection stuff should
not slow down the Mobile IPv6 draft because they are out of the scope
(ie. if there are too many things to say about this, another document
should be produced).
As soon as neighbor discovery is correctly used in the mobility draft
no change are needed (then only MUST in 10.19 should be changed,
to do a DAD for the home agent address is an extreme solution then
should be used only when nothing else can work: IMHO the MUST is too strong).

Regards