Subject: Re: [MOBILE-IP] FW: I-D ACTION:draft-jaseem-rap-cops-mip-00.txt

From: Roberts Philip-qa3445 <[email-masked]>
Date: Wed, 4 Oct 2000 09:48:47 -0500

I thought the AAA working group had already eliminated COPS as a AAA
protocol.  If so, please explain why we should be considering COPS in MIP?

> ----------
> From:         Muhammad Jaseemuddin
> Reply To:     Muhammad Jaseemuddin
> Sent:         Wednesday, October 4, 2000 9:10 PM
> To:   [email-masked]
> Subject:      [MOBILE-IP] FW: I-D ACTION:draft-jaseem-rap-cops-mip-00.txt
>
> We have submitted a draft defining COPS usage for Mobile IP. The
> announcement is attached below. We will appreciate any comments.
>
> - Muhammad Jaseemuddin
>
> -----Original Message-----
> From:   [email-masked] [SMTP:[email-masked]]
> Sent:   Wednesday, October 04, 2000 7:19 AM
> To:     [email-masked]
> Subject:        I-D ACTION:draft-jaseem-rap-cops-mip-00.txt
>
> To: IETF-Announce: ;
> CC: [email-masked]
> From: [email-masked]
> Reply-to: [email-masked]
> Subject: I-D ACTION:draft-jaseem-rap-cops-mip-00.txt
> Date: Wed, 04 Oct 2000 06:54:46 -0400
> Sender: [email-masked]
>
> --NextPart
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
>         Title           : COPS usage for Mobile IP (MIP)
>         Author(s)       : M. Jaseemuddin, A. Lakas
>         Filename        : draft-jaseem-rap-cops-mip-00.txt
>         Pages           : 14
>         Date            : 03-Oct-00
>
> Mobile IP is a protocol that is used to achieve transparent routing
> of IP packets to a mobile node. A mobile node obtains a care-of-
> address in the foreign network and registers that address with the
> home agent. The home agent as well as the foreign agent can apply
> policies to the mobile node registration. This draft defines COPS
> [1] usage for Mobile IPv4 [2]. It describes how COPS is used to
> control Mobile IP registration based on policies. It defines the
> interactions between the PEP and the PDP to handle Mobile IP
> registration messages. It also provides a guideline for mobility
> agents on how to use this COPS client with regards to the
> registration messages.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-jaseem-rap-cops-mip-00.txt
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-jaseem-rap-cops-mip-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-jaseem-rap-cops-mip-00.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
> --NextPart
> Content-Type: Multipart/Alternative; Boundary="OtherAccess"
>
> --OtherAccess
> Content-Type: Message/External-body;
>         access-type="mail-server";
>         server="[email-masked]"
>
> Content-Type: text/plain
> Content-ID:     <[email-masked]>
>
> ENCODING mime
> FILE /internet-drafts/draft-jaseem-rap-cops-mip-00.txt
>
> --OtherAccess
> Content-Type: Message/External-body;
>         name="draft-jaseem-rap-cops-mip-00.txt";
>         site="ftp.ietf.org";
>         access-type="anon-ftp";
>         directory="internet-drafts"
>
>
> --OtherAccess--
>
> --NextPart--
>
>

---

From: Steven Glass - Solaris Software <[email-masked]>
Date: Wed, 4 Oct 2000 14:03:50 -0400

> protocol.  If so, please explain why we should be considering COPS in MIP?

    I know this is going to get dinged by many of the people I work with (on
this list, and in the office), but is there some reason the authors can't have
an individual submission for an informational RFC?  RFC2356 comes to mind (use
of SKIP FW traversal in Mobile IP), published by the mobile ip working group
in June 1998, after the decision of the IPSec WG (and Jeff Schiller) for
ISAKMP/Oakley as the IPSec protocol of choice.  If the authors want to work on
this, it doesn't have to be an official working group document (hence the name
d-jaseem-..., not d-i-mip-...) to get some review from mobile ip WG members
willing to read it (if any, and presuming it works).  If the authors want to
move it to anything more than informational, however, it seems likely to be
blocked by the IESG...

                              Cheers,
                                  Steve