Subject: Re: [MOBILE-IP] Are requirements required?

From: Roberts Philip-qa3445 <[email-masked]>
Date: Fri, 6 Oct 2000 08:26:06 -0500

Hi Charlie,

> ----------
> From:         Charles E. Perkins
> Reply To:     [email-masked]
> Sent:         Thursday, October 5, 2000 5:54 AM
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] Are requirements required?
>
> Hello Sandy,
>
> > There is no question about the following statement
> > you make regarding Mobile IP:
> > > "as it's currently
> > > defined will have trouble completing a "handoff" in
> > > time to keep from noticing a glitch in service if
> > > it's being used to support a realtime service."
>
> I would like to raise a lot of doubt about this statement.
>
> There is nothing in Mobile IP that prevents the mobile
> node from knowing _EXACTLY_ when to register a new
> care-of address.
>
> There is nothing in Mobile IP that _ASSURES_ that the
> mobile node discovers exactly when to register a new
> care-of address.
>
> Mobile IP does NOT OFFER A SOLUTION for notifying
> the mobile node about the completely optimal time
> when to register a new care-of address.  The solutions
> provided are not meant to stand in the way of any other
> better solution that might be available.
>
> A mobile node IS ALLOWED, by any means deemed expedient,
> to discover when to register a care-of address.
>
> This has a much different truth value than the quoted
> statement above.
>
> For example, suppose a mobile node hears an advertisement
> (from another protocol) 1000 times a second, that contains
> a care-of address, it will be able to execute perfectly
> smooth handovers.  Just as an example.  No one says you
> have to do it this way, and no one says you cannot do
> it this way.  The protocol says you cannot issue RFC 1256
> Router Advertisements this often, but nobody says you
> cannot do it another way.
>
> Bottom line is that a mobile node, using Mobile IP,
> _possibly_ but _not necessarily_ in conjunction with
> other protocols, _MAY_ be able to execute a perfectly
> smooth handover without any glitches.
>
> Maybe I didn't say this the right way or the politically
> correct way, but I hope it is clear.  It's a little
> frustrating over the years to hear Mobile IP be so often
> dinged for not doing a thing it was explicitly designed
> to avoid doing. The whole point was to enable the
> development of link-specific or system-specific solutions
> since no general methods seem to be widely agreed upon
> as applicable.  Link-specific and system-specific solutions
> have more limited interoperability, but that is just the
> way it is.
>
I think I've digested all the wording here and I think I agree.  Perhaps if
I'd said "Mobile IP as it's currently defined wil have trouble ... on a lot
of systems in which people seem to be interested in using it" you would have
been more sympathetic?   No doubt one could send 1000 advertisements a
second in some systems, but probably not in most cellular systems.  And no
doubt one might be able to implement a link layer that could be engineered
to automatically generate an advertisement at a mobile without sending it
over the air.   Might we also agree that the number of proposals being
generated in the working group to improve handoff performance gives the
impression that maybe some things could be done to modify MIP to make it a
little better for this in the context of some real systems?
> Regards,
> Charlie P.
Phil

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 6 Oct 2000 11:11:41 -0700

Hello Phil,

I agree with what I think you are trying to say.

And I don't have a problem with modifying Mobile IP to
fit the needs, say, for seamless handover.  I wanted to
make it clear that (as best I understand it) Mobile IP
was designed to allow interworking with other ways to
get timely information about moving to a new point of
attachment.  I agree with you that the number of current
proposals points out the need to do so.

Regards,
Charlie P.