Subject: Re: [MOBILE-IP] Fast Handoff v4 archives available

From: Luca Salgarelli <[email-masked]>
Date: Mon, 2 Oct 2000 16:46:45 -0400

Basavaraj, Andrew,

I would like to add some comments to what Andrew wrote.

> Regards the process: I thought the idea was to come up with a set of
> requirements, then a strawman proposal that sort consensus and met the
> requirements?
>
> It looks like the starting point was too narrow?
>
> It looks like the output from the design team resulted in deltas to
> existing IDs? (Why are these two IDs technically superior to others?).
>
> In addition, weeding out some IDs because they didn't support tunneling
> (e.g., Hawaii) or MIP messaging (e.g., CIP), etc.  was a bad call in a
> process that should have been open and inclusive and now looks like on
> the surface to have preselected two IDs (i.e., fast handoff/ proactive
> IDs) that have not been proven "better" than others.

I completely agree with Andrew. Several weeks ago I wrote a message to the
WG asking clarifications about this process, but those questions were left
unanswered. I too thought that the goal of this sub-WG (?) was to come up
with a set of requirements. While I do not question the technical soundness
of the proposals (not requirements) that this sub-WG has defined, I still
do not understand the process through which the goals for the sub-WG were
set, and how the sub-WG was formed.

I also do not understand how the WG can benefit in the long run from this
seemingly closed process where no real discussion has taken place on the
technical merits (or lack of thereof, for what matters) of the IDs that
were left out.

Would someone please comment on this?

Thanks
Luca

---

From: Mohamed Khalil <[email-masked]>
Date: Mon, 2 Oct 2000 17:30:23 -0500

Hello folks,

I agree with all completely. As a participant of the handoff meetings at the
last IETF I was expecting to follow the engineering approach (Since we are
all belong to the Internet Engineering Task Force) of coming up with a set
of requirements for IPv4   then we propose different solutions which satisfy
those requirements. Unfortunately, this never happened.

MK

-----Original Message-----
From: Akhtar, Haseeb [RICH1:IP30-M:EXCH]
Sent: Monday, October 02, 2000 4:06 PM
To: [email-masked]
Subject: Re: [MOBILE-IP] Fast Handoff v4 archives available

Hello folks,

Ditto. The requirements should have come first before the solution!

Regards,

Haseeb

        -----Original Message-----
From:   Luca Salgarelli [SMTP:[email-masked]]
Sent:   Monday, October 02, 2000 3:47 PM
To:     [email-masked]
Subject:        Re: [MOBILE-IP] Fast Handoff v4 archives available

        Basavaraj, Andrew,

> IDs) that have not been proven "better" than others.

        I completely agree with Andrew. Several weeks ago I wrote a message
to the

        I also do not understand how the WG can benefit in the long run from
this
seemingly closed process where no real discussion has taken place on the
technical merits (or lack of thereof, for what matters) of the IDs that
were left out.

        Thanks
Luca

---

From: Roberts Philip-qa3445 <[email-masked]>
Date: Tue, 3 Oct 2000 09:55:28 -0500

Hi Luca,

> ----------
> From:         Luca Salgarelli
> Sent:         Tuesday, October 3, 2000 10:37 PM
> To:   Roberts Philip-qa3445
> Cc:   [email-masked]
> Hi Phil.
> I was not in Pittsburgh, so your explanation is most welcome.
>
Sorry you missed it and we're glad to be able to help.

>  Still, I
> don't see why the sub-WG, as a basis for its work, completely ignored
> other
> possible starting points for fast-handoffs, namely the ones based on host
> based routing. In particular, I don't think there has been any technical
> discussion on the WG mailing-list to justify such weeding.
>
> Again, I asked questions about this lack of technical discussion when the
> re-chartering was being discussed a few weeks ago. Apart from a message
> from Charlie who said that he was not very comfortable "about disallowing
> host-route based approaches for Mobile IP", there was no other reply.
>
> And now we see that even lacking such technical discussion, we already
> have
> selected some solutions. I would be happy to see a sub-WG working to
> specify requirements, or to evaluate proposals about fast-handoffs (along
> the lines of what has been done in the AAA WG). But in this case the
> sub-WG
> was from the start ignoring solutions based on host-based routing, without
> any evaluation on the technical merits of such approach.
>
> I don't think that such a seemingly closed approach is what I would expect
> from the IETF.
>
There seem to be two issues here.  First the trimming of the charter and
second the consideration of proposals for fast handoffs.   They could be
related in that the two proposals that were removed as working group items
are interested in handling handoffs faster.

On trimming the charter, neither of the chairs heard a lot of objections
from the working group to consolidating the charter.  We try to work on a
rough consensus and would expect more people in the working group than just
the authors of one approach objecting before we could begin to believe the
working group as a whole might be concerned about the decision.   Let me say
it again if I haven't made it clear in the past.  We believe this
consolidation will allow the working group to focus better on making
solutions based on Mobile IP better prepared for deployment.   If there is a
lot of interest in proposals based on alternate approaches to Mobile IP
there may be room somewhere in the IETF for consideration of such proposals.

On the issue of fast handoff.  You seem mainly to object to the seemingly
closed process but again neither chair finds this an easy objection to
understand.  Anyone who had an I-D on fast handoff was allowed to
participate in the meeting in Pittsburgh, the results of that meeting were
discussed in the working group meeting itself, it was announced that there
were design teams forming and the leaders of the design teams were
designated, and the minutes were posted on the list.  I'm not sure what else
could've been done.

Phil

> Thanks
> Luca
>
> On Tue, Oct 03, 2000 at 08:42:29AM -0500, Roberts Philip-qa3445 wrote:
> > Hi Luca,
> >
> >
> > > ----------
> > > From:     Luca Salgarelli
> > > Reply To:         Luca Salgarelli
> > > Sent:     Tuesday, October 3, 2000 4:46 AM
> > Of course!
> > There were enough drafts dealing with the problem presented at the last
> > IETF.   The authors of all of those drafts got together and came up with
> > some agreements about what we wanted to do about fast handoff in a
> meeting
> > outside the MIP working group meeting.  The outcome of those authors
> > discussions were presented to the working group and the entire working
> group
> > was asked for comment.   This is recorded in the minutes of the working
> > group meeting.  You can review those if you weren't at the meeting in
> > Pittsburgh.
> >
> > Among the conclusions reached were that the WG would like to see two
> drafts
> > for fast handover - one for IPv4 and one for IPv6 - and that a design
> team
> > was being formed to look at each.
> >
> > The IPv4 design team has pretty much concluded its work and is coming
> back
> > to the working group with two drafts.  (A previous post pointed to the
> > archive of the minutes for you to review the discussions that went on in
> > these meetings.)   In brief the outcome was that 3 drafts were merged
> into a
> > single draft (Calhoun, et. al.) and another draft was revised (Soliman
> and
> > El Malki).  The design team could not reach consensus on selecting just
> one
> > of these.  So it is now up to the working group to pick a single draft.
> If
> > there are aspects of the problem that are not covered by either of the
> > existing drafts it is time for members of the working group to speak up.
> > The latest versions of both drafts have been posted.
> >
> > The IPv6 design team is just about to begin its work.
> >
> > It seems to me that the problem is fairly well understood, but if it
> becomes
> > apparent from the WG discussion that there is something that is being
> missed
> > it will be taken into consideration.
> >
> > Hope this helps,
> > Phil
> >
> >
> > > Thanks
> > > Luca
> > >
> > >
>
>

---

From: Basavaraj Patil <[email-masked]>
Date: Tue, 3 Oct 2000 14:59:20 -0500

Hi Andrew,

Now that I understand your concerns, let me see
if I can address them.

>
>Pat and Basavaraj:
>
>First, my observations may be completely
>unfounded since I have not the experience
>of the design team.
>

The archives provide a good insight into the
discussions of the design team. So go ahead
and delve into the archives.

>While I am not party to the process (and as Pat
>points out its easy to say "free beer") I had
>greater expectations given the flurry of
>activity, ideas and IDs in this space, and the number
>of real systems that have been built
>and experience gained with.
>

I am not sure what your expectations were, but
you still have the opportunity to express your
opinions and problems with the proposals of the
design team.

>Let me briefly explain my knee jerk
>reaction.
>
>I think there are a number of conclusions one can
>draw from reading the archive and the ID on a
>technical level and from a process point of
>view.
>
>Regards the process: I thought the idea was to
>come up with a set of requirements, then a strawman proposal
>that sort consensus and met the requirements?
>

The idea to create a design team was to speed up
the process of getting an I-D with input from most
of the people who had an opinion or an idea about
handoffs.
The design team creation was well advertised at the
last IETF and anyone who wanted to contribute to the
effort was welcome to participate in the design team.

>(Reading between the lines from the archive)
>

The scope of the effort was discussed at IETF48
and presented to the WG. I do not know if the
scope was completely understood by all, but I
do not think of it as being narrow. Based on the
milestone (Dec 00) we had to have focus.

>It looks like the output from the design team
>resulted in deltas to existing IDs? (Why are these
>two IDs technically superior to others?).
>

The output of the design team is essentially a consensus
document(s).
No claims of technical superiority to other I-Ds
are claimed for the design team outputs. Please
feel free to comment and disagree with the results.
The intent of publishing the docs to the WG is to
initiate a discussion on the solution being presented.

>It looks like the process and results are
>narrow? Both IDs are complex and coupled far too closely to
>the 3G mindset/RANview: 3GPP2 air interface
>is only one type of cellular technology and
>cellular is only one type of wireless network, etc.
>

I think the process was quite open and focused. It's
now upto the WG members to raise concerns and issues.
The issue that you raise here is I guess your opinion
and hence should be addressed to the design team.

>In addition, weeding out some IDs because
>they didn't support tunneling (e.g., Hawaii)
>or MIP messaging (e.g., CIP), etc.
>was a bad call in a process that should
>have been open and inclusive and now looks
>like on the surface to have preselected two IDs
>(i.e., fast handoff/ proactive IDs)
>that have not been proven "better" than others.
>

The design team had a set of guidelines that they
worked under. Ultimately the "better" solution will
prevail. The reasons for not considering Hawaii and
CIP are based on changes to the charter.

>Again, I could be way off here on my reading
>of events.
>
>Finally, I still firmly believe that Mobile IP
>will not be widely deployed until
>efficient handoff and paging are incorporated.
>I just don't think we have moved very far
>forward on this.
>

You believe the solution proposed by the design team
is not efficient?

>So I'm very supportive of the work but
>surprised at the output.
>

Thank you. Hope to see you provide comments and input
to the design team output.

>Best,
>Andrew

-Basavaraj