Subject: Re: [MOBILE-IP] MIP implementation !!!

From: Vipul Gupta <[email-masked]>
Date: Wed, 4 Oct 2000 14:50:31 -0700

The folks behind the SUNY Binghamton implementation have moved
  on and that implementation is no longer maintained actively.
  If you are interested in something that works on Linux 2.2, you can try
  the distribution from Sun Labs at:

  http://playground.sun.com/~vgupta/sunlabs-mobileip-new.tar.gz

  regards,

  vipul

  p.s. If you are specifically looking for the Binghamton implementation,
       a copy can be found at

 http://playground.sun.com/pub/mobile-ip/Linux/Linux-MobileIPv101.tar.gz

       be warned, though, the last Linux kernel it was tested on is
       1.3.58 (or thereabouts) and will not work on 2.2.

       Other Linux implementations are available from:

         o National University of Singapore (http://mip.ee.nus.sg/)

         o Stanford University as part of the Mosquitonet project
           (http://mosquitonet.stanford.edu/)

> Good morning folks !
> Can someone please tell me whats going on with
> the Binghamton UNIs URL for the Linux implementation
> on Mobile IP? Its been for ages that Im trying to download
> the files but it seems that the URL doesn't work anymore.
> Does anyone know if they have any updated versions of the
> implementation which runs on 2.2.x Kernells?
>
> Regards,
>             Christos
>
> --
> Christos Chrisanthakopoulos
>
> INTRACOM S.A.
> Development Programmes Department
> Panepistimiou 254
> 26443  Patras
> GREECE
>
> Tel:  (+30 61) 465153 (direct)
> E-mail: [email-masked]
> URL: www.intracom.gr

---

From: Gaetan Feige <[email-masked]>
Date: Fri, 6 Oct 2000 17:41:31 +0100

Hello all,

Following the question on Mobile-IP implementations on Linux I would like to know if there are some starts of implementation for Windows 2000 ?

I heard the Singapore stack works on windows 98.

Thank you very much

Gaétan

>> implementation which runs on 2.2.x Kernells?

*************************************************************
Gaetan Feige
Technical Consultant                                 
11, rue Camille Desmoulins             TEL:  +33 (0)1 58 04 68 36
92782 Issy Les Moulineaux             FAX: +33 (0)1 58 04 61 00
CEDEX 9 - France                          GSM: +33 (0)6 89 10 82 89

*************************************************************

---

From: "Tom K. Weckström" <[email-masked]>
Date: Wed, 11 Oct 2000 00:36:16 +0300

Hello.

>            (http://mosquitonet.stanford.edu/)

I would add Dynamics -- HUT Mobile IP from Helsinki University of
Technology, Finland. Dynamics works on Linux 2.2 (And has been
compiled on a Linux in iPAQ even ;). There is pretty much
doucmentation available from two master's theses to couple of
conference papers and the current results of Dynamics code
documentation project.

The URL is below in the signature.

Regards,
        Tom

--
        Tom Weckström           Dynamics group
                                Helsinki University of Technology
                                [email-masked]

http://www.cs.hut.fi/Research/Dynamics/

---

From: Alex Petrescu <[email-masked]>
Date: Wed, 11 Oct 2000 12:56:05 +0200

Mee too, I've compiled and I'm maintaining a sort of list of mobile
ipv6 implementations.  Here it is.

Mobile IPv6 implementations
---------------------------
KAME
-bsd-ish.
-Mobile-IPv6 code from Ericsson.
-draft 09.

INRIA HMIP
-Hierarchical Mobile IPv6.
-FreeBSD and Francis Dupont's IPv6 stack.
-draft 09.

MONARCH
-bsd-ish.
-1997.
-draft 03.

MICROSOFT RESEARCH
-Windows.
-partial IPv6 mobility support.

NUS (National Univ of Singapore)
-linux.

LANCASTER UNIVERSITY
-linux
-draft-ietf-mobileip-ipv6-05
-Stefan Schmid, [email-masked].

MIPL at hut.fi
-linux 2.4.0
-Sami Kivisaari, Niklas Kämpe, Juha Mynttinen, Toni Nykänen, Henrik
 Petander and Antti Tuominen
-draft-12.

FRANCIS DUPONT
-has a mipv6 implementation based on his ipv6 stack.