Subject: Re: [MOBILE-IP] Are requirements required?

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Tue, 3 Oct 2000 16:43:34 +0100

> You still haven't explained your position.
>
> I know per-host routes do not scale in the core
> network. We al agree on that. And I'm not proposing that.
>
> We are discussing edge networks - e.g., wireless access
> networks.
>
In which case, I think host routing is not technically sound
for it is conflicting with the requirement to support Private addresses. And
it makes the AN inherenly non multiprotocol.
We want to support PPP.

> We use per-host routing in Cellular IP access networks
> for handoff control its very scalable.
>
>
I should have used "not Technically sound", instead...

Andrew, I'm not pointing at any scalability issues,
I just wanted to explain the meanung of a word. Is it clear now?

I'm sure it is.

alessio

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Tue, 3 Oct 2000 19:39:50 +0100

> Now how
> can we initiate some healthy, open and technically
> sound discussions aimed at getting to the heart of
> these charter-setting problems?
>
>
>
It is my understanding that we have no such issue,
since everything is clear in the mobile IP WG at
this stage.

If it is not clear what is going to happen in
other yet to be chartered WGs or whether they'll overlap
with MIP WG, probably that would be better discussed on other
mailing lists, outside this WG.

What we need to do here is to solve technical
issues in front of the house based on the work
of 2 distinct task forces that have been openly
managed by the WG chairs.

alessio

---

From: Roberts Philip-qa3445 <[email-masked]>
Date: Wed, 4 Oct 2000 10:05:03 -0500

> ----------
> From:         Erik Anderlind
> Reply To:     Erik Anderlind
> Sent:         Wednesday, October 4, 2000 6:33 AM
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] Are requirements required?
>
> Hi Phil and Basavaray,
>
Hi Erik,

> I have been a (passive) member of the MIP list for many years and was
> also surprised by the lack of discussions preceding the charter
> reorientation.
> With a list as large as the MIP list, I saw no need to add "I agree too"
> comments
> to messages that disagreed with the narrow rescoping of the wg without
> clear
> discussions of the decision criteria. The comments went unanswered or
> there
> was little attempt to answer them.
>
The working group, like all IETF working group, works on rough consensus.
If we only hear one objection to stop something or one proposal to start
something, it's kinda up to the chairs to make a judgement.   (This is kind
of a recurring issue for us).  So please speak up if you've got an opinion.

> If the objective is to finish off the base work on the MIPv4 and v6
> protocols as they stand today, close the wg and deal with other
> mobility issues in new wgs, that is OK. Is there a desire/policy to not
> have wg:s active for too long? If the wg is still open to dealing with
> extensions to MIP, then criteria have to be a lot more specific.
>
> On the MIP charter posted at IETF I didn't see anything that mentions
> handoff
> at all, except the last milestone which talks about both intra and
> inter-domain
> handoff.
>
Yes, that's where it is.

>  How some low latency handoff solutions are OK to work on while
> others are not
> is a mystery to me. Cutting out certain IDs just before soliciting input
> for problems
> they address, was not very elegant.
>
What exactly are you talking about?  Which IDs were cut out?

> Let's continue the work on making the MIP based mobility solution better
> so that it will become widely deployed and not just be a solution of
> last resort.
>
> ...Erik
>
Phil

> Ps. I am not one among those people that have previously expressed
> concerns to Sandy.
>
>

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 5 Oct 2000 10:18:21 +1100

> I do not think that approaches based on tunneling are
> excluded, but I don't know what the IPv6 team thinks.
> I also do not know whether the IPv4 drafts are reasonable
> for IPv6.
>
        This is not so much in response to Charlie's statement but
        to other earlier ones.
        What I don't understand is why people keep relating MIP to
        tunnelling. Sorry if that sounds naive, but the association should
        be between MIP4 and tunnelling. Realistically speaking RO will
        probably not be used much in MIPv4 hence my statement.
        But for V6 why not ? Hopefully tunnelling will be minimised in V6.
        So if the assumption is that "MIP" = "MIPv4" then the association
        is correct but I wouldn't use that terminology anyway. There are 2
        protocols here under the MIP umbrella.

        Regarding whether the V4 drafts are reasonabe for V6, I'll speak
        about Fast Handoffs. One of our main goals with Fast Handoffs was
        to find a solution that will work for both. Since the basic models
of
        RFC 2002 and MIPv6 are similar, this shouldn't be too hard.
        So our approach was based on the model in RFC 2002 and you can see
        by reading both drafts (V4 and V6 Fast Handoffs) that they are very
similar.
        So to answer the question, yes, I believe it's possible, and I'd
like to maintain
        the model of RFC 2002 and MIPv6 as much as possible.

---

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Thu, 5 Oct 2000 16:52:05 +0100

> It's comforting to hear that these questions will be
> addressed in more depth.  Do you know what is the
> IPv6 design team's target timeframe in making this
> document available? Is there any place where people
> external to the design team can keep tabs on the
> team's progress?
>
> Regards,
> Sandy
>
>
> > A discussion list has been setup for this and the address
> of this list
> > is: [email-masked]
> >
> > The list is open to anyone who wishes to contribute to this
> effort and
> > anyone can be a part of the design team.

---

From: Glenn Morrow <[email-masked]>
Date: Thu, 5 Oct 2000 11:20:00 -0500

I believe December is the timeframe.

Here is how to subscribe:

TO:
[email-masked]'

BODY:
subscribe [email-masked] "address"

> -----Original Message-----
> From: Casati, Alessio (Alessio) [SMTP:[email-masked]]
> Sent: Thursday, October 05, 2000 10:52 AM

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 6 Oct 2000 15:18:53 -0500

Hesham, Andrew,

Could you please let me know where the paper co-authored by Andrew on the mobility management approaches can be found?

Thank you,

Madjid Nakhjiri

-----Original Message-----
From: Hesham Soliman (EPA) [mailto:[email-masked]]
Sent: Tuesday, October 03, 2000 5:20 PM
To: [email-masked]
Subject: Re: [MOBILE-IP] Are requirements required?

Hi Sandy,

        > The mobile IP working group is not taking fast handoff from its charter.
> We've consolidated the charter to consider mobile IP based approaches only
> and we hope to end up with two approaches to doing fast handoff based on
> mobile IP - one for v4 and one for v6.  The other working group that is
> being proposed may investigate alternate approaches that are not based on
> mobile IP.

        In my mind, fast-handoff = micro-mobility.  In your
definition,  fast handoff = (some mechanism based on
Mobile IP) whereas micro-mobility = (some mechanism
not based in Mobile IP).  Is this correct? If so,
can you explain what are the necessary conditions for
a mechanism to be classified as being "based on
Mobile IP"?  This is too vague.

        => I was guessing that's what was on your mind, may I ask why
fast handoff = micromobility ?
If we can achieve the performance targets that we're aiming for
using MIP and some extensions wouldn't that be better and much less
complex than inventing new protocols ? Let alon saving years of IETF work ?

        In the second session for MIP WG in Pittsburgh, Andrew Campbell mentioned
that he was a co-author on a paper that did an evaluation / comparison of the various
mobility management schemes. I've read that paper, and on the handoff issue, it was
concluded that there were no significant differences between HMIP, CIP and HAWAII.
Andrew also mentioned that in is presentation.
I may also add that the simulations in that paper did not consider the Fast Handoffs
draft (draft-elmalki- ...) which adds improvements to standard HMIP.
So when I hear this direct association between micro mobility and fast handoffs, I get
a bit confused.

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Sat, 7 Oct 2000 13:12:27 +1100

Hi Sandy,

>
> Sorry I didn't get to your email sooner.
>
>       I think we have a terminology problem that is causing all this
> confusion so let me take a stab at defining these terms based on your
> comments and please correct me if I have misunderstood you:
>
>       fast handoff support: approaches to enhance the handover performance
> of Mobile IP by using existing Mobile IP mechanisms possibly with some
> extensions.
>
>       micro-mobility support: approaches to enhance handover performance
> of Mobile IP by defining new protocols that work in conjunction with
> Mobile IP while not adhering to conventional Mobile IP mechanisms.
>
> Is this a reasonable definition for starters?  If so, we can then discuss
> the relative merits and disadvantages of each.
>
        => I'm not sure if managing micro mobility necessarily means that
new protocols
        are needed. Perhaps MIP with some optimisation can do the job, or
perhaps L2
        can. I just wanted to emphasise two points:

        - The definition of micromobility should be generic and independant
of what protocol
        will be used to solve it, MIP or not. We need to know the problem
first before we can
        say protocol X will fix it.

        - I was questioning the statement you made earlier about
        fast handoffs = micromobility (new protocols). I'm not sure whether
that is necessarily
        true always.

        Cheers,
        Hesham