Subject: Re: [MOBILE-IP] Are requirements required?

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Tue, 3 Oct 2000 16:17:36 +0100

> > 1) the solution MUST NOT suck (for a definition of "suck",
> >    consider the scalability of host based routing)
>
> Per-host routes in the "wireless access network" (not the Internet) are
> required (in my estimation) for a number of reasons: basis
> for fast handoff control, aggregated micro-QOS to the host, etc.
>
> CIP is a proponent of this approach and its highly scalable.
>
> Can you shine some light on your view? Its easy to say
> 'not scalable' but please back that claim up?
>
>
I can shed some light on the requirement:

I don't want the solution to suck. One good example
to give a gist of what I mean by "Suck" is observing
the scalability of host routing. I generally come to the
conclusion "It SUCKS!"

> > 2) the solution MUST be based on tunnels, since this is the way mobile
> IPv4
> > works
>
> Why?
>
Please have a look at RFC2002. Mobile IP is indeed based on tunnels.
Departing from this model is not within the scope of this WG.

> On a related note. If the working group will only entertain work items
> that include tunneling, MIP messaging, etc., then that will limit
> any innovation of this group in the long term. Its a hard line (MIPv4/
> MIPv6 and
> nothing else). What happens if the carriers decide that MIP
> will never work and seek alternatives?
>
this is not a problem for us (hic et nunc).

> Should we simply keep working on
> say (lateral
> point) "ATM" in the hope that ATM one day get deployed to
> the desk top once the carriers 'get it'. (BTW, I don't
> mean to slur MIP by attaching its name to ATM - just
> to illustrate my point).
>
It is a very lateral point...

> > 3) the solution MUST NOT be based on host routing (missing this,
> requirement
>
> Your repeating yourself old chap.
>
>
No, unless you think
there's a one to one correspondence between 1 and 3.

> > 1) would be       violated)
> ?
Andrew, You must glue this to the end of the line above this
line in my original message, for your understanding.
Hope this satisfies your "?".

> > 6) During handoff it MUST be possible to transfer some info to the new
> FA.
>
> Only in the case of buffering and forwarding between FAs during handoff
> - does
> that motivate your comment? I must say  that all the explicit signaled
> seamless
> handoff proposals seem very complex - the exchange of "state" between
> FAs may not
> scale?
>
??? If the state scales, its transfer does too.

By the way, I was not talking about buffering.

Yours,

Alessio

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Tue, 3 Oct 2000 11:50:04 -0700

> the scalability of host routing. I generally come to the

You still haven't explained your position.

I know per-host routes do not scale in the core
network. We al agree on that. And I'm not proposing that.

We are discussing edge networks - e.g., wireless access
networks.

We use per-host routing in Cellular IP access networks
for handoff control its very scalable.

Now why is the use of per-host routes in
such a setting unscalable?

Can you provide some insight.