Subject: [MOBILE-IP] Are requirements required?

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Tue, 3 Oct 2000 12:09:12 +0100

I think I could start writing the requirements right now:

1) the solution MUST NOT suck (for a definition of "suck",
   consider the scalability of host based routing)
2) the solution MUST be based on tunnels, since this is the way mobile IPv4
works
3) the solution MUST NOT be based on host routing (missing this, requirement
1) would be       violated)
4) the solution MUST include security mechanisms that work fine and fast.
5) the solution MUST be fast/low interruption.
6) During handoff it MUST be possible to transfer some info to the new FA.
7) queries to AAA servers MUST be minimized
...

do we have to read this from an ID?

Or, wouldn't it be faster to build on what some colleagues have written
in some documents, and try to improve them if possible?
That is send comments to the list/authors???

$ 2/100

alessio

> ----------
> From:         Mohamed Khalil[SMTP:[email-masked]]
> Reply To:     Mohamed Khalil
> Sent:         02 October 2000 23:30
> To:   [email-masked]
> Subject:      Re: [MOBILE-IP] Fast Handoff v4 archives available
>
> Hello folks,
>
> I agree with all completely. As a participant of the handoff meetings at
> the last IETF I was expecting to follow the engineering approach (Since we
> are all belong to the Internet Engineering Task Force) of coming up with a
> set of requirements for IPv4   then we propose different solutions which
> satisfy those requirements. Unfortunately, this never happened.
>
> MK
>
>       -----Original Message-----
>       From: Akhtar, Haseeb [RICH1:IP30-M:EXCH]
>       Sent: Monday, October 02, 2000 4:06 PM
>       To: [email-masked]
>       Subject: Re: [MOBILE-IP] Fast Handoff v4 archives available
>
>
>
>       Hello folks,
>
>       Ditto. The requirements should have come first before the solution!
>
>       Regards,
>
>       Haseeb
>
>               -----Original Message-----
>       From:   Luca Salgarelli [SMTP:[email-masked]]
>       Sent:   Monday, October 02, 2000 3:47 PM
>       To:     [email-masked]
>       Subject:        Re: [MOBILE-IP] Fast Handoff v4 archives available
>
>               Basavaraj, Andrew,
>
>               I would like to add some comments to what Andrew wrote.
>
>               > Regards the process: I thought the idea was to come up
> with a set of
>       > requirements, then a strawman proposal that sort consensus and met
> the
>       > requirements?
>       >
>       > It looks like the starting point was too narrow?
>       >
>       > It looks like the output from the design team resulted in deltas
> to
>       > existing IDs? (Why are these two IDs technically superior to
> others?).
>       >
>       > In addition, weeding out some IDs because they didn't support
> tunneling
>       > (e.g., Hawaii) or MIP messaging (e.g., CIP), etc.  was a bad call
> in a
>       > process that should have been open and inclusive and now looks
> like on
>       > the surface to have preselected two IDs (i.e., fast handoff/
> proactive
>       > IDs) that have not been proven "better" than others.
>
>               I completely agree with Andrew. Several weeks ago I wrote a
> message to the
>       WG asking clarifications about this process, but those questions
> were left
>       unanswered. I too thought that the goal of this sub-WG (?) was to
> come up
>       with a set of requirements. While I do not question the technical
> soundness
>       of the proposals (not requirements) that this sub-WG has defined, I
> still
>       do not understand the process through which the goals for the sub-WG
> were
>       set, and how the sub-WG was formed.
>
>               I also do not understand how the WG can benefit in the long
> run from this
>       seemingly closed process where no real discussion has taken place on
> the
>       technical merits (or lack of thereof, for what matters) of the IDs
> that
>       were left out.
>
>               Would someone please comment on this?
>
>               Thanks
>       Luca
>
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Tue, 3 Oct 2000 10:36:52 -0700

Hi Alessio:

> I think I could start writing the requirements right now:

From the right ;-)

>    consider the scalability of host based routing)

And on the left ...

Per-host routes in the "wireless access network" (not the Internet) are
required (in my estimation) for a number of reasons: basis
for fast handoff control, aggregated micro-QOS to the host, etc.

CIP is a proponent of this approach and its highly scalable.

Can you shine some light on your view? Its easy to say
'not scalable' but please back that claim up?

> 2) the solution MUST be based on tunnels, since this is the way mobile IPv4

Why?

Hawaii and CIP don't carry the overhead of tunneling or address
translation to deliver data in the access network, nor need
to be aware of a tree structure of FAs. What is the basis for
such religion?

On a related note. If the working group will only entertain work items
that include tunneling, MIP messaging, etc., then that will limit
any innovation of this group in the long term. Its a hard line (MIPv4/
MIPv6 and
nothing else). What happens if the carriers decide that MIP
will never work and seek alternatives? Should we simply keep working on
say (lateral
point) "ATM" in the hope that ATM one day get deployed to
the desk top once the carriers 'get it'. (BTW, I don't
mean to slur MIP by attaching its name to ATM - just
to illustrate my point).

How else should be scope our work for acceptability by the
polit bureau ;-) May be the chairs can tell us what
assumptions to base our research on.

> 3) the solution MUST NOT be based on host routing (missing this, requirement

Your repeating yourself old chap.

> 1) would be       violated)
?
> 4) the solution MUST include security mechanisms that work fine and fast.

This is an important one. I'd add:

The solution should have a security model that operates on the
timescales
of fast handoff (extreme case - that can be very fast in pico-nets). AAA
may not work at
such speeds?

CIP has a light weight/ fast and secure model that is tailored to
delivering
performance securrity at fast handoff speeds.

> 5) the solution MUST be fast/low interruption.

Agree.

> 6) During handoff it MUST be possible to transfer some info to the new FA.

Only in the case of buffering and forwarding between FAs during handoff
- does
that motivate your comment? I must say  that all the explicit signaled
seamless
handoff proposals seem very complex - the exchange of "state" between
FAs may not
scale?

My feeling is that fast handoff with low loss should be the first
order goal. Zero loss requires lots of additional buffering,
synchronization
and signaling: it will not fly and may be unscalable.

> 7) queries to AAA servers MUST be minimized

Faster is the issue. If AAA (control) is slow then we are not going to
deliver
better performance on the data path

> That is send comments to the list/authors???

Thanks for your mail. While we agree/disagree on some points, its
healthy and open to discuss the pros/cons.

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 3 Oct 2000 07:45:07 -0700

> assumptions to base our research on.

This has nothing to do with religion, IMHO, and it also has nothing to do with
whether CIP, HAWAII or any other Micro-Mobility protocol is better than Mobile
IP. It simply has to do with setting the WG focus. At every IETF, the MIP WG
meetings are diluted by contributions that have nothing to do with the Mobile
IP protocol. Don't get me wrong, I do believe that CIP et al. are important,
but they do not belong in the Mobile IP WG. The chairs have stated this, so it
shouldn't be a surprise that the work in the Mobile IP WG is limited to the
Mobile IP protocol.

Now, what is needed is a new WG where new ideas can be exchanged, and a
Micro-Mobility protocol can be created without having to compete with the
Mobile IP protocol. I have previously stated that such a new WG is in the
process of being created, and the final touches are being done to satisfy IESG
comments. So, all I would ask is that you consider bringing your
Micro-Mobility work, which hopefully supports fast hand-offs, to this new WG
which plans to meet at the December IETF.

PatC

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 3 Oct 2000 08:02:20 -0700

Hello Pat,

> which plans to meet at the December IETF.

Is there a mailing list for this proposed new working group?

Your wording about "non-competition" makes me quite nervous.
I would infer that some micro-mobility approaches have been
somehow disenfranchised because of the action of the mobile-ip
working group.  However, I don't believe that has occurred.

I'm very curious about the proposed charter for this new working
group.  I also wonder whether considerations about Mobile IP would
be excluded from consideration within the new working group, in
order to "avoid competition".  If so, I think that would be a
terrific botch.

Is this a minefield?

I notice your use of the term "micro-mobility".  Do you mean to
say mobility between multiple, homogenous network links?  Are
heterogeneous links excluded?  Is handover of interest?  Smooth
handover?  Fast handover?

Regards,
Charlie P.

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 3 Oct 2000 08:08:49 -0700

Sigh, I knew I should have spent hours crafting that e-mail to ensure that it
would be completely P/C. However, given the amount of work load I had, I could
only afford a short response. Of course, now I will have to spend those hours
to do damage control :( :(

See my responses below.

PatC

> Is there a mailing list for this proposed new working group?

This is the result of the CRAPS BOF, but with a much more limited scope. The
CRAPS mailing list will evolve to the new WG mailing list.

> working group.  However, I don't believe that has occurred.

hmmm..... obviously we haven't been reading the same e-mails. The WG chairs
have stated that the Mobile IP WG will, from now on, concentrate on Mobile IP
protocols, and related enhancements. I used the term "compete" quite loosely,
so nothing malicious was intended, and I meant compete for time. The issue, as
I stated, is the somewhat limited amount of time and resources in the Mobile
IP WG. The new WG is intended to take the work that the Mobile IP WG cannot
handle.

> order to "avoid competition".  If so, I think that would be a

Why would you want two WGs to work on Mobile IP? I believe that the Mobile IP
WG chairs want to keep all Mobile IP related protocol development, and other
non-tunneling mobility protocols would be in the new WG.

This is not intended to limit the scope of the Mobile IP protocol in any way,
shape, or form, but rather to allow the Mobile IP WG to concentrate on its
milestones.

> Is this a minefield?

Perhaps it is, and my head blew off....

> heterogeneous links excluded?  Is handover of interest?  Smooth

Sigh. Charlie, how about I make use of the term non-tunneling approaches
instead?

PatC

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 3 Oct 2000 08:27:52 -0700

Hello Pat,

Sorry if I pushed the wrong buttons.  I'm not trying to
be discouraging or aggravating, just really wanting to
understand what the issues are.

> CRAPS mailing list will evolve to the new WG mailing list.

Could you post a pointer to the CRAPS mailing list for those
archive-averse among us?  (o.k.  I'm being lazy.)

> non-tunneling mobility protocols would be in the new WG.

This is the heart of the matter.  Of course you are right that there
should not be two working groups standardizing the same protocols.
However, depending upon its charter, the new working group may end up
designing protocols that should be made to work well with Mobile IP.
That seems to me to indicate that some consideration should be given
to Mobile IP within the new working group, even if the new working
group does not work on Mobile IP.

There also might be some overlap with recent "seamless handover"
efforts from the IPv4 and IPv6 design teams.  Would the new working
group spend any focus on feature-specific context handover?

> Sigh. Charlie, how about I make use of the term non-tunneling approaches

It seems to me that both tunneling and non-tunneling approaches are
fair game in Mobile IP and in the new working group, so that does
not seem to be the dividing line.  Is source routing considered to
be tunneling?

Regards,
Charlie P.

---

From: Luca Salgarelli <[email-masked]>
Date: Tue, 3 Oct 2000 11:47:14 -0400

Hi Pat and Charlie.

In my understanding, the whole discussion is starting to appear as a debate
about what can be considered "related to Mobile IP". I think that during
the re-chartering of the MIP WG, and seemingly the chartering of the new
WG, not enough attention has been paid to the specification of what this
means.

What is "related to Mobile IP"? A protocol that uses the same message
format? A protocol that uses some form of IP tunneling?

I would be very happy to see a new WG working on fast-handoffs exclusively.
However, I too have some doubts about being able to avoid duplication of
work between this new WG and the Mobile IP WG.

Luca

---

From: Sandy Thuel <[email-masked]>
Date: Tue, 3 Oct 2000 14:09:19 -0400

Hi all,

I am happy to see that we are finally starting to
identify the key concerns about the mobile IP WG
and the fast-handoff spinoff-WG (for lack of a better
name).  All boils down to defining clear charters
for the mobile IP WG and for the fast handoff
spinoff-WG.  There is clearly much confusion still
to be cleared before we get to that point.

I absolutely agree that the mobile IP WG needs to
focus its charter to make progress.  The WG chairs
needed to do something to make this happen and
they should be applauded for recognizing this
need and taking some action. Taking fast-handoff
work off the WG charter is a very sensible solution
but it raised the following questions:
  a) what is and what isn't fast-handoff work?
  b) what is a reasonable home for the fast-handoff
    work within the IETF?
  c) how do we manage the dependencies of fast handoff
    work on the evolving Mobile IP work? (i.e., how
    do we handle the coupling between these two WG's
    avoiding redundancy and other potential problems?)

Many of us that have been following the mobileip WG
are puzzled by all these questions.  Thanks to Pat
Calhoun for pointing us to the CRAPS mailing list and
for informing us of the plans to get a micro-mobility
WG started. This helps answer question (b). Now how
can we initiate some healthy, open and technically
sound discussions aimed at getting to the heart of
these charter-setting problems?

Sandy