Subject: Re: [MOBILE-IP] Are requirements required?

From: Roberts Philip-qa3445 <[email-masked]>
Date: Tue, 3 Oct 2000 14:17:19 -0500

> Hi Phil,
Hi Sandy,

> > The mobile IP working group is not taking fast handoff from its charter.
> > We've consolidated the charter to consider mobile IP based approaches
> only
> > and we hope to end up with two approaches to doing fast handoff based on
> > mobile IP - one for v4 and one for v6.  The other working group that is
> > being proposed may investigate alternate approaches that are not based
> on
> > mobile IP.
>
> In my mind, fast-handoff = micro-mobility.  In your
> definition,  fast handoff = (some mechanism based on
> Mobile IP) whereas micro-mobility = (some mechanism
> not based in Mobile IP).  Is this correct? If so,
> can you explain what are the necessary conditions for
> a mechanism to be classified as being "based on
> Mobile IP"?  This is too vague.
>
No this isn't correct.  Well, the part about what's in your mind is correct
I guess.  Fast handoff can be done a number of ways.  The mobile IP working
group is working on it in the context of Mobile IP.  If someone somewhere
has another way they want to do it that's fine and I think Pat has said the
working group he's working on will be welcoming proposals.  The problem as I
see it is that Mobile IP as it's currently defined will have trouble
completing a "handoff" in time to keep from noticing a glitch in service if
it's being used to support a realtime service.  The efforts underway here
are an attempt to improve that situation.   I'm sorry if you think saying
something is "based on Mobile IP" is too vague.  In the past on this list I
tried to say we wanted to use existing mechanisms defined for Mobile IP to
solve this problem.   Other people working on it don't seem to have a
problem understanding it so I'm not sure exactly what I need to explain.

> > I'm pretty happy with the charter that mobile IP has and I haven't heard
> a
> > lot of complaints about our charter that make me think that "many" are
> > puzzled.
>
> In making this statement, I took the liberty of
> speaking for a number of people that have verbally
> expressed their confusion to us.
>
OK, that's fine.  Maybe if they'd express their confusion to the list it
would be more productive?

> > Pat's working hard to get a charter that the IESG is
> > happy with.
>
> I'm fully behind this.  Is there somewhere where we
> can keep informed of the status of this effort without
> bugging Pat with email probes?
>
Don't know.  Pat?

> Sandy
Phil

---

From: Erik Anderlind <[email-masked]>
Date: Tue, 3 Oct 2000 18:33:23 -0400

Hi Phil and Basavaray,

I have been a (passive) member of the MIP list for many years and was
also surprised by the lack of discussions preceding the charter
reorientation.
With a list as large as the MIP list, I saw no need to add "I agree too"
comments
to messages that disagreed with the narrow rescoping of the wg without
clear
discussions of the decision criteria. The comments went unanswered or
there
was little attempt to answer them.

If the objective is to finish off the base work on the MIPv4 and v6
protocols as they stand today, close the wg and deal with other
mobility issues in new wgs, that is OK. Is there a desire/policy to not
have wg:s active for too long? If the wg is still open to dealing with
extensions to MIP, then criteria have to be a lot more specific.

On the MIP charter posted at IETF I didn't see anything that mentions
handoff
at all, except the last milestone which talks about both intra and
inter-domain
handoff. How some low latency handoff solutions are OK to work on while
others are not
is a mystery to me. Cutting out certain IDs just before soliciting input
for problems
they address, was not very elegant.

Let's continue the work on making the MIP based mobility solution better
so that it will become widely deployed and not just be a solution of
last resort.

...Erik

Ps. I am not one among those people that have previously expressed
concerns to Sandy.

---

From: Sandy Thuel <[email-masked]>
Date: Wed, 4 Oct 2000 17:05:57 -0400

Hi Phil,

> are an attempt to improve that situation.

There is no question about the following statement
you make regarding Mobile IP:
> "as it's currently
> defined will have trouble completing a "handoff" in
> time to keep from noticing a glitch in service if
> it's being used to support a realtime service."

Some support for fast handoff (or however one wants
to call it) is needed.  The issue is: what qualifies
a fast handoff solution to be considered to be
"based on Mobile IP"?  If it's clear to everyone in
the world except for me, pardon me for my ignorance
but I'd certainly appreciate if someone would take
the time to spell this out for me. For example:
  Does "based on Mobile IP" mean "based on rfc 2002
   (or its extensions)"?
  Does it mean "based exclusively on tunneling"?

Sandy

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 4 Oct 2000 14:54:29 -0700

Hello Sandy,

> > it's being used to support a realtime service."

I would like to raise a lot of doubt about this statement.

There is nothing in Mobile IP that prevents the mobile
node from knowing _EXACTLY_ when to register a new
care-of address.

There is nothing in Mobile IP that _ASSURES_ that the
mobile node discovers exactly when to register a new
care-of address.

Mobile IP does NOT OFFER A SOLUTION for notifying
the mobile node about the completely optimal time
when to register a new care-of address.  The solutions
provided are not meant to stand in the way of any other
better solution that might be available.

A mobile node IS ALLOWED, by any means deemed expedient,
to discover when to register a care-of address.

This has a much different truth value than the quoted
statement above.

For example, suppose a mobile node hears an advertisement
(from another protocol) 1000 times a second, that contains
a care-of address, it will be able to execute perfectly
smooth handovers.  Just as an example.  No one says you
have to do it this way, and no one says you cannot do
it this way.  The protocol says you cannot issue RFC 1256
Router Advertisements this often, but nobody says you
cannot do it another way.

Bottom line is that a mobile node, using Mobile IP,
_possibly_ but _not necessarily_ in conjunction with
other protocols, _MAY_ be able to execute a perfectly
smooth handover without any glitches.

Maybe I didn't say this the right way or the politically
correct way, but I hope it is clear.  It's a little
frustrating over the years to hear Mobile IP be so often
dinged for not doing a thing it was explicitly designed
to avoid doing. The whole point was to enable the
development of link-specific or system-specific solutions
since no general methods seem to be widely agreed upon
as applicable.  Link-specific and system-specific solutions
have more limited interoperability, but that is just the
way it is.

>   Does it mean "based exclusively on tunneling"?

These are questions that are very likely to receive
intense scrutiny in the weeks to come.  I don't mean
to say whether the issues are clear, or not, but I would
hope that the document resulting from the IPv6 design
team's efforts will spell them out clearly for
everyone's further comment.  Clearly our outcomes
will not necessarily be based on RFC 2002++.

I do not think that approaches based on tunneling are
excluded, but I don't know what the IPv6 team thinks.
I also do not know whether the IPv4 drafts are reasonable
for IPv6.

Regards,
Charlie P.

---

From: Sandy Thuel <[email-masked]>
Date: Thu, 5 Oct 2000 11:30:22 -0400

Hi Charlie,

> have more limited interoperability, but that is just the

Thanks for your clarifications regarding Mobile IP's
ability to support fast handoffs and sorry for having
quoted such a mis-leading statement.

  I absolutely  agree that there is nothing inherent
in Mobile IP that prevents or precludes fast handoff
support.  It is also clear that Mobile IP was designed
with no assumptions nor requirements about
specific link-layer mechanisms for fast handoffs (e.g.,
informing the mobile exactly when to register a
new care-of-address).  On the other hand, the
judicious exploitation of link-layer support for
fast handoffs, when such support exists, has the
potential to significantly enhance the handover
performance of Mobile IP.  The challenge is in
findings ways to exploit these mechanisms without
violating the link-layer transparency of Mobile IP's
design.  By the same token, the fine-tuning of
performance parameters for mechanisms defined by
Mobile IP (e.g., frequency of router advertisements)
can also help in enhancing handover performance
(without exploiting any link-layer support).  There
are, however, cost/performance tradeoffs for these
different approaches that aren't obvious (to me, at
least).  I would expect that the WG work on fast
handoff support would shed some light on these
tradeoffs.

> will not necessarily be based on RFC 2002++.

It's comforting to hear that these questions will be
addressed in more depth.  Do you know what is the
IPv6 design team's target timeframe in making this
document available? Is there any place where people
external to the design team can keep tabs on the
team's progress?

Regards,
Sandy