Subject: Re: [MOBILE-IP] Binding Cache entries per IPv6 address at Corresp ondent Node

From: "Powell, Ken" <[email-masked]>
Date: Fri, 10 Nov 2000 08:35:39 -0500

> -----Original Message-----
> From: Mattias Pettersson [mailto:[email-masked]]
> Sent: Friday, November 10, 2000 4:32 AM
> To: Powell, Ken
> Cc: [email-masked]
> Subject: Re: [MOBILE-IP] Binding Cache entries per IPv6 address at
> Correspondent Node
>
>
> "Powell, Ken" wrote:
> >
> > I'm not sure how the clause "for each of its IPv6 addresses"
> > applies when the prefix length is non-zero. In this case, a
> > single binding covers multiple addresses.
>
> It's the CN/HA that keeps a BC for each of its _own_
> addresses. Not one
> for every address the MN has. Or do I misunderstand you?
>

You understood me correctly, and this is exactly what I
was confused about yesterday. Thanks for clarifying it.

Ken

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Sat, 11 Nov 2000 01:34:50 +1100

> Richard Draves wrote:
> >
> > >  Binding Cache
> > >
> > >          A cache, maintained by each IPv6 node, of bindings for other
> > >          nodes.  A separate Binding Cache SHOULD be maintained by each
> > >          IPv6 node for each of its IPv6 addresses.
> >
> > This is an interesting problem! First let me confirm: my understanding
> is
> > that a MN can only have a single mapping from HA to CoA, because it can
> send
> > its home agent a single such binding. In particular, a MN can not
> reasonably
> > use one CoA when talking to one correspondent and a different CoA when
> > talking to a different correspondent.
>
> Indeed it can. I think that it is a likely case, although very advanced.
> There would be a point in registering different CoAs with different CNs,
> depending on e.g. where you'd want your traffic to flow. In the
> extension, there could be a need to not only register a binding for a
> home address, but also for a port number.
>
        => Yes I agree, draft-ietf-mobileip-hmipv6-  is a good
        example for the case Mattias mentions where the MN registers
        different COA's with different CNs

---

From: Richard Draves <[email-masked]>
Date: Fri, 10 Nov 2000 12:17:27 -0800

>         different COA's with different CNs

So the mobile node can register a single "primary" HA -> CoA mapping with
its home agent, but then after that it can give different correspondents
different mappings?
OK.

Rich

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Sat, 11 Nov 2000 12:28:55 +1100

> its home agent, but then after that it can give different correspondents
        => Yep. I see your concern but nothing in the specs stops
        that and I think that's a strength. A feature ;)

---

From: "Powell, Ken" <[email-masked]>
Date: Mon, 13 Nov 2000 10:08:22 -0500

Mattias,

> One BU is, according to the draft, enough to register all
> home addresses formed by prefixes on the home link, plus
> site- and link-local. However, I feel there is a slight
> gap in the protocol on what home addresses that's actually
> been registered. Is it pointed out somewhere else in the
> spec where the HA explicitly tells the MN about the addresses
> registered, so that the MN can prepare to receive packets to these
> addresses?

I don't remember anything in the spec to do this.

> Or, as I guess is assumed, the HA should already have
> informed the MN in an RA about what prefixes are valid.

I think this is how it works.

Ken