Subject: [MOBILE-IP] Question about "Route Optimization in Mobile IP"

From: "Park, Hyun Seo" <[email-masked]>
Date: Thu, 2 Nov 2000 08:45:28 +0900

Hello, All ....
I have a question about "Route Optimization in Mobile IP" ...

When MN comes back Home Network, it does "Deregistration" with its HA ...
MN sends "Registration Request" with <COA = MN's Home Address> to HA ...

MN can include "Previous FA Notification Extension", if possible,
    Then, HA sends "Binding Update" to MN's previous FA .. 
    Binding Update : <COA = MN's Home Address,  Lifetime = 0>

    The old FA receives that "Binding Update", 
    then it deletes visitor list entry for that MN ....
    And it does not make "Binding Cache" for that MN 
    because <COA = MN's Home Address, Lifetime = 0>...

Now, Suppose a CN that has "Binding Cache" <COA = MN's old FA> ...
When it sends datagrams to MN, it tunnels them to MN's old FA ...
Then MN's old FA decapsulates them 
    and re-routes (not tunnels) them to MN's Home Network ...
MN's old FA does not send "Binding Warning" to HA because it has no "Binding Cache"...
And CN can not receive "Binding Update" from HA ... 
So, CN will countinuously tunnel datagrams until it expires "Binding Cache" for MN ..

Am I right ? 
Any comments will be appreciated ... 
Thanks in advance ...          

--------------------------------------
Park, Hyun Seo 
Graduate Student
Department of Computer Engineering, Chungnam National University
220 Gung-dong,YuSeong-Gu, Taejon, 305764, Korea
E-mail: [email-masked]
ICQ # : 28055093   
Phone : +82-42-823-6049

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 1 Nov 2000 21:56:21 -0800

Hello,

Yes, I think you are correct.  In the past, the foreign agent had
been allowed to send a Binding Warning to the correspondent
node.  I thought that it still could do so, but upon re-reading the
specification I see that it isn't in there now.  We could say that
the foreign agent SHOULD send a Binding Warning to the
correspondent node, if the foreign agent does not have any
record of the home agent for the mobile node.  The correspondent
node presumably will understand the message, since it's stale
binding for the mobile node was produced by processing a
previous  Binding Update in the first place.

Does this solve the problem?

Regards,
Charlie P.

---

From: "Park, Hyun Seo" <[email-masked]>
Date: Thu, 2 Nov 2000 15:33:52 +0900

Thanks, Charlie ... 
My comments are below ....

> record of the home agent for the mobile node.  

[Park] I think FA sends a "Binding Warning" to not CN but HA ...
    Am I correct ?  

> The correspondent node presumably will understand the message, 
> since it's stale binding for the mobile node was produced by processing a

[Park] How about "Binding Cache for Deregistered MN" ?
    When any node receives "Binding Update" with <COA = MN's Home Address, Lifetime = 0>,
    it creates no "Binding Cache" and deletes existing "Binding Cache" or "Visitor List" for that MN ....
    
    But, when FA receives "Binding Update" for deregistered MN from HA,
    it makes a "Binding Cache" for MN with <COA = NULL or MN's Home Address> ..     
    Then, when FA receives tunneled datagrams to MN from any node, 
    it re-routes them to MN's Home Network and sends "Binding Warning" to MN's HA ...
    How about it ?

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 2 Nov 2000 12:46:43 -0800

Hello again,

>>                                       We could say that

That's the way the specification reads now.  I am proposing that
a new revision of the Route Optimization draft be promulgated
that incorporates a new requirement, as outlined in my text
above your response.

>> since its stale binding for the mobile node was produced by processing
>> a previous Binding Update in the first place.
>>
>     When any node receives "Binding Update" with <COA = MN's Home Address,
>     Lifetime = 0>, it creates no "Binding Cache" and deletes existing
>     "Binding Cache" or "Visitor List" for that MN ....
>
>     it makes a "Binding Cache" for MN with <COA = NULL or MN's Home Address
>     it re-routes them to MN's Home Network and sends "Binding Warning"
>      to MN's HA ...     How about it ?

Then you would have to worry about how long that "deregistered"
visitor list entry would be maintained.  That seems like an
unnecessary complication for this hopefully rare case.

Besides, the Previous Foreign Agent Notification (PFAN) is supposed
to supply a binding with a nonzero lifetime to the previous foreign
agent.  If the home agent is the agent that issues the PFAN message,
then it should still not have a nonzero lifetime.  It is good that
you pointed this out, and we should make it explicit in the text.
I would rather set things up in this way, to be consistent with
roaming between foreign agents, than to introduce yet another timing
dependency with static timing parameters.

Regards,
Charlie P.

PS. I edited your response, purely for the purpose of making the lines
    fit better into my message reply window.  I hope you do not mind.

---

From: "Park, Hyun Seo" <[email-masked]>
Date: Fri, 3 Nov 2000 12:45:23 +0900

Hello, again, too .... :-)

> that incorporates a new requirement, as outlined in my text

[Park] Then, when CN receives "Binding Warning", what can CN do ?
    In present Route Optimization draft, when a Node, that is, HA receives "Binding Warning",
    it sends "Binding Update" to the target node in "Binding Warning" message ... 
    Please explain to me in detail ...  
 
> unnecessary complication for this hopefully rare case.

[Park] FA does not maintain "deregistered" visitor list ... 
    It maintains "deregistered" Binding Cache(?) ..
    
> then it should still not have a nonzero lifetime.  

[Park] In My Opinion, I do not think PFAN can not be used with nonzero lifetime ....
    HA can send "Binding Update" with a zero lifetime ... 
    Similarly, when HA receives PFAN with zero lifetime,
    it can send "Binding Update" with a zero lifetime to Old FA ...

> It is good that you pointed this out, and we should make it explicit in the text.

[Park] What is "timing dependency with static timing parameters" ?
    Perhaps I am missing something .. Please let me know ... 
    Thanks a lot, Charlie ...     

>     fit better into my message reply window.  I hope you do not mind.

[Park] Never mind .... ;-)

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 3 Nov 2000 08:44:05 -0800

Hello Park,

>     In present Route Optimization draft, when a Node, that is, HA receives
>     "Binding Warning", it sends "Binding Update" to the target node in
>     "Binding Warning" message ... Please explain to me in detail ...

The Correspondent Node should delete its binding for the mobile
node.  Then packets will go to the home network.  Then the home
agent will send a Binding Update, or else the mobile node will.

>     It maintains "deregistered" Binding Cache(?) ..

O.K.  I am not picky about this point :-)

> [Park] In My Opinion, I do not think PFAN can not be used with nonzero
>     lifetime ....  HA can send "Binding Update" with a zero lifetime ...

O.K. with me.  Why would the home agent get a PFAN with zero lifetime?

>> It is good that you pointed this out, and we should make it explicit in
>> the text. I would rather set things up in this way, to be consistent with

I was trying to imagine how a mobile agent would know when to delete

>      to MN's HA ...     How about it ?

What would you suggest other than some preconfigured static timing
parameter, indicated either by the home agent or the foreign agent?

Regards,
Charlie P.

---

From: "Park, Hyun Seo" <[email-masked]>
Date: Sat, 4 Nov 2000 20:07:40 +0900

Hello Charlie,

> agent will send a Binding Update, or else the mobile node will.

Do you mean another use of "Binding Warning" ?
When a HA receives "Binding Warning", 
    it should send "Binding Update" to the target node in "Binding Warning" ...
When a CN receives "Binding Warning",
    it should delete "Binding Cache" ...
I think it is a little unreasonable .... 
How about my approach that is, "Binding Cache" for "Deregistered MN" ?
I think it is more logical ... 

> O.K. with me.  Why would the home agent get a PFAN with zero lifetime?

For "Smooth Handoff" ...
When MN returns Home Network from Foreign Network,
    it can send "Registration Request" (Deregistration) with attached PFAN Ext. with zero lifetime ....

> I was trying to imagine how a mobile agent would know when to delete

I think There is no serious problem even if a mobile agent does not delete "Binding Cache"
for "Deregistered MN" ...
If "Deregistered MN" moves another Foreign Network again,
    that mobile agent can get "Binding Update" from HA after one or some packets ...  
Then that mobile agent can update its "Binding Cache" ...
An alternative is a use of "Default Lifetime" for "Deregistered MN" ...

---

From: Charlie Perkins <[email-masked]>
Date: Sun, 12 Nov 2000 09:06:22 -0800

Hello Park,

The Binding Warning has had a long history.  The currentformulation
uses the design assumption that it's faster to ask the home agent to
send the information, than to ask the correspondent node to ask the
home agent to send it.  The original formulation had the information
going to the correspondent node.  In the situation where the home
agent is not known, then we could send the Binding Warning to the
mobile node, or to the correspondent node.

> I think it is more logical ...

I think it is also logical for the Binding Warning to be used for the
purpose of warning nodes about stale binding cache entries.
This could be done by specifying that the correspondent node look
for itself in the list of target addresses, or that it implicitly assumes
that it is present in the list if the list is null.

>     it can send "Registration Request" (Deregistration) with attached PFAN Ext. with zero lifetime

Why wouldn't the PFAN have nonzero lifetime?  If the lifetime were nonzero,
then that would say how long the previous foreign agent should perform packet
forwarding services.

> An alternative is a use of "Default Lifetime" for "Deregistered MN" ...

That is a static timing parameter.  And, nowhere else is there any mention
about keeping bindings around after they have been invalidated/deregistered.
So that also counts as a new feature, thus not a minimal solution to the
problem you raised.  However, if consensus emerges that this is a better
solution, I'll be happy to go along.

Regards,
Charlie P.