Subject: Re: [MOBILE-IP] IPv6 mobile routers vs. regional mobility agents

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Wed, 29 Nov 2000 05:24:10 +1100

Hello Charlie,

        I hope you can help me follow this interesting analysis.

> I think there's another way to look at this problem of
> mobile routers that offers a "better" solution.  It isn't
> the same problem as has been discussed in connection with
> hiearchical mobility agents.  It should not be solved by
> techniques associated with hierarchical mobility agents.
> Nor anchor points, if I may use that terminology.  A mobile
> router should not necessarily be considered an anchor point
> or a regional mobility agent.
>
        => First I'd like to clarify the situation where an anchor
        point is needed. Consider a Personal Area Network
        (PAN). When that network attaches via one or more
        routers on that PAN to a foreign network, it may not be
        possible to obtain a topologically correct preftx to allow
        this PAN to use topologically correct addresses.
        So this is the problem I assumed we were looking at
        in the previous thread. So the case is : the MN has
        physically moved but not topologically. It needs to map
        the physical movement into a topological one.
        No hierarchy is needed here. Just a topologically correct
        COA. It just happens that we can use an anchor point's
        address for that purpose. No hierarchy of anchor points
        is required. It is important to separate the two issues.

> The reason it is not the same is as follows:
>
> - With hierarchical mobility agents, the mobile node's home
>   agent can be shielded from having to know about local
>   care-of addresses, as long as it can supply a regional
>   care-of address to the home agent and supply local care-of
>   addresses to the regional mobility agent.
>
        => Agree.

> - With mobile routers, the mobile node "should" be using
>   the prefix of a home address of the mobile router as the
>   prefix by which it forms its own care-of address.  This
>   could be done independently of any sort of hierarchical
>   mobility agent architecture.  In other words, there doesn't
>   have to be any regional mobility agent at all to make
>   a mobile router work.
>
        => But as you say this would work while the MN is located
        at the home network.

> To see this in another way, suppose that the mobile router
> has a fixed Ethernet attached to it.  The nodes on the
> "mobile network" do not run Mobile IPv6.  Why should they
> deal with any advertised care-of addresses from the mobile
> router?
>
        => The mobile router does not need to advertise a COA
        if it is located in the Home network. But when located in
        a foreign network it needs to advertise a COA.
        The reason for advertising a COA is to allow for route
        optimisation. Ie packets sent from the CN directly
        to the MR, and from there to the MN.

> However, this business about mobile routers does bring up
> interesting points.  Suppose the mobile node hooks up to
> a mobile router, and gets a prefix from the advertisement,
> and forms its care-of address.  Packets routed towards that
> care-of address are likely to go through the home agent
> for the mobile router.  The router's home agent will
> encapsulate them.  The mobile router will decapsulate them.
> At this point, the packet should be as issued originally
> by the correspondent node (with a routing header) or
> by the mobile node's home agent (i.e., encapsulated).
>
>
> Now suppose some corrspondent node is sending megabytes of
> data, with each packet having a routing header containing
> the mobile node's care-of address.
>
> We would like for that data not to have to go through the
> home agent for the mobile router.  That means that the
> correspondent node should get information about the care-of
> address for the _mobile router_.  Then, the correspondent node
> could put in a routing header with _two_ care-of addresses.
> The first one would be the care-of address for the mobile
> router, and the second one would be the care-of address
> for the mobile node.
>
        => That's the situation we tried to avoid. In this case the MR
        and the CN have no knowledge of each other.
        In addition for them to know about each other additional
        security requirements are added. It would be simpler
        IMO if the end to end model of MIPv6 is maintained
        by using the MR's COA as an alt-COA for the MN.
        No additions to MIPv6 are required.

> In order to do this directly, the mobile router would need
> some security association with the correspondent node.
> This is one area where this problem shows itself to be much
> different than the hierarchical mobility agent problem.
> For hierarchical mobility agents, there is a natural way
> to set up the security associations.  For the mobile router,
> the same security setup seems unlikely to work.  I didn't
> "map" it out yet, but I reckon some sort of redirect is
> the most likely candidate.  The mobile node can authentically
> "relay" a redirect from the mobile router to the correspondent
> node.  We would have to make some rules about this, but I
> think that what the correspondent node would see would be
> a Binding Update for the care-of address.  This has already
> been specified in another context for smooth handovers.
>
>
> I sure hope we don't have to do this before Mobile IPv6
> completes its Last Call.
>
        => By using the anchor point, there is no need to update
        MIPv6 and the problem becomes independant of MIPv6.
        Isn't that a good thing ?

        Regards,
        Hesham

> "Hesham Soliman (EPA)" wrote:
> >
> > > > > The question is:
> > > > > Is that a problem, if I receive already decapsulated datagrams,
> even
> > > > > if usually I decapsulate them by myself?!
> > > > >
> > > > > Clarifications are welcome.
> > > > >
> > > >         => Your scenario is supported in
> draft-ietf-mobileip-hmipv6-02
> > > >         which will be on the web very soon. I think you'll get the
> > > answer
> > > >         you're looking for there.
> > > >         But as a short answer, no there is no problem because the MN
> > > >         doesn't think that it moved since it is still sending and
> > > receiving
> > > >         packets using its Home address.
> > >
> > > The problem is just this:
> > > I would like the MN to know it moved, so it can update its CNs and its
> > > Home
> > > Agent by itself.
> > >
> >         => I realise that. That's exactly what the draft allows you to
> do.
> >         The MAP option is sent by the Mobile Router (MR), so the MN
> >         knows that it moved and that the MAP acts as a COA for it.
> >         The MN will update the HA and the CNs accordingly with an
> >         alternate-COA as specified in MIPv6. So route optimised
> >         packets will be received by the MAP (MR) and forwarded
> >         to the MN. Every thing happens end to end.
> >         Does that solve your problem ?
> >         Please see the draft for more info.
> >
> >         Regards,
> >         Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 28 Nov 2000 11:10:12 -0800

Hello Hesham,

Thanks for taking the time to read through these long e-mails.

>         this PAN to use topologically correct addresses.

Maybe you're defining something other than a router.
If the PAN router is a router, it should make router
advertisements.  The router advertisements should allow
nodes to attach to its network(s).  These advertisements
could be used by mobile nodes that want to attach to the
network over which the PAN router's advertisements are
being transmitted.  I don't see that this should be
different than normal.

>         is required. It is important to separate the two issues.

Granted that it's important to separate the issues.  But your
claim that the mobile nodes have to detect the movements of
the mobile router that is serving them is, I think, suspect.
It amounts to a transfer of responsibility from the mobile
router to the nodes it is serving.  The disharmony of this
approach is particularly evident when the nodes attached to
the mobile router are NOT themselves mobile nodes.

>         => But as you say this would work while the MN is located

I thought it would work no matter where the MN was located.
In this discussion, we have to be careful to distinguish between
the MN's home network, and the mobile router's home network.
It is likely that there are two home agents involved.

>         to the MR, and from there to the MN.

This is what I am trying to say is wrong.  I also claim that
it's a good illustration about how one might fashion a new
sort of "redirect" message to allow such fixed nodes to do the
right sort of "route optimization" that you allude to.

            .........

>         No additions to MIPv6 are required.

I think that your approach is simpler in some cases if you
disregard the security implications and the general routing
model of Mobile IPv6.  I also point out again that it's not
the endpoint that's moving, and in fact it's not the endpoint
that should be considered to even have a care-of address.
Things that live on their home network and don't move don't
have care-of addresses.  Yet, with your scheme, they would.

>         Isn't that a good thing ?

Paraphrasing, we should make things as simple as possible,
but not any simpler.

Regards,
Charlie P.

---

From: Hrishi Talwar <[email-masked]>
Date: Tue, 28 Nov 2000 14:27:38 -0500

unsubscribe

On Tue, 28 Nov 2000, Charles E. Perkins wrote:

> Date: Tue, 28 Nov 2000 11:10:12 -0800
> From: "Charles E. Perkins" <[email-masked]>
> To: [email-masked]
> Subject: Re: [MOBILE-IP] IPv6 mobile routers vs. regional mobility agents
>
> Hello Hesham,
>

*********************************************************
Computers aren't intelligent, they only think they are. *
*********************************************************
***************************
Hrishi S Talwar           *
2220B Lindmont Circle NE  *
Atlanta, GA 30324         *
Ph. 404-949-9706          *
***************************