Subject: [MOBILE-IP] draft agenda

From: Roberts Philip-qa3445 <[email-masked]>
Date: Tue, 28 Nov 2000 10:38:31 -0600

Here it is, folks.  We have some specific goals we'd like to accomplish at this meeting and the time will be made available to get those done.  We'd like to get the v6 draft wrapped up.  It's in last call now and we'd like to reconcile all remaining issues by the end of the San Diego meeting.  We'd like to reach agreement on a single draft to be working group document for MIP v4 fast handoff.  We'd like to reach agreement on a single draft to be working group document for MIP v6 fast handoff.

Thursday 9-11:30 (150 minutes)
Raj             10      Agenda bashing and wg document status
Charlie Perkins 15      MIPv6 Update                            draft-ietf-mobileip-ipv6-13.txt
Vijay Devarapali        5       MIPv6 ETSI Bake-off Report

Mobile IP V4 fast handoff:
Pat Calhoun     5       Proactive handoff                               draft-calhoun-mobileip-proactive-fa-02.txt
Hesham Soliman  5       Fast handoff                            draft-elmalki-mobileip-fast-handoffs-03.txt
McCann/Soliman  5       Summary  of differences in v4 handoff
WG              15      Discussion of fast handoff in v4

Mobile IP V6 fast handoff:
Charlie Perkins 15      v6 fast handoff design team

Hesham Soliman  10      Hierarchical MIP v6                     draft-ietf-mobileip-hmipv6-01.txt
Pat Calhoun     5       Mobile IP and GRE enhancements          draft-calhoun-mobileip-gre-ext-00.txt
Charlie Perkins 10      DIAMETER extensions for MIP             draft-calhoun-diameter-mobileip-11.txt
Charlie Perkins 10      AAAv6 for MIP
Steve Glass     15      Registration Revocation for Mobile IP   draft-glass-mobileip-reg-revok-00.txt
Samita Chakrabarti 10   Private addressing                              draft-ietf-mobileip-rfc2344-bis-03.txt

Friday 9-11:30 (150 minutes)
Hemant Chaskar  10      A Framework for QoS Support in MIP v6   draft-chaskar-mobileip-qos-00.txt
Glenn Morrow    15      Intercepting Location Updates           draft-lmk-mobileip-intercepting-update-00.txt
Hesham Soliman  10      Security association establishment for route optimization in v6 draft-soliman-mobileip-routeopt-mipv6-00.txt
Charlie Pekins  10      IP v6 Regional Registration             draft-malinen-mobileip-regreg6-00.txt
SL Tsao         15      Introducing Mobile IP in IPv4/IPv6 Interconnected networks                                      draft-tsao-mobileip-duelstack-model-00.txt
Steve Glass     10      Use of DHCP in Mobile IP                draft-glass-mobileip-agent-dhcp-proxy-00.txt
Ernst Thierry   10      Mobile Network Support                  draft-ernst-mobileip-v6-network-00.txt
Jari Malinen    5       GSM SIM authentication                  draft-haverinen-mobileip-gsmsim-00.txt
Jiwoong Lee     6       SGM support in MIP                      draft-lee-sgm-support-mobileip-00.txt

Pekka Nikander  10      Mobile IP v6 for the Homeless           draft-nikander-mobileip-homelessv6-00.txt
Behcet Sarikaya 5       Mobile IP v6 Regional Paging            draft-sarikaya-mobileip-hmipv6rp-00

---

From: Shiao-Li Charles Tsao <[email-masked]>
Date: Thu, 30 Nov 2000 09:12:34 +0800

Dear All, 

My presentation on "Introducing Mobile IP in IPv4/IPv6 Interconnected networks" will based on two I-Ds. 
1. Mobility Support for IPv4 and IPv6 Interconnected Networks based on Dual-Stack Model
draft-tsao-mobileip-duelstack-model-01.txt
http://www.geocities.com/mobileip_interworking/draft-tsao-mobileip-dualstack-model-01.txt

2. Mobile IP Application Level Gateway
draft-tsao-mobileip-alg-00.txt
http://www.geocities.com/mobileip_interworking/draft-tsao-mobileip-alg-00.txt

I do appreciate for any comment and suggestion, Thanks !!!

Shiao-Li Tsao

---

From: cnyap <[email-masked]>
Date: Thu, 30 Nov 2000 19:31:30 -0000

Hi

I wonder is "Mobile IP v6 for the Homeless" in charter of working group.

Chern Nam Yap
MIEEE, MSc(Res), BSc(Hons)
Research Associate
Center for Mobile Communication Research
Department of Electronic and Electrical Engineering
University of Sheffield
F132 Mappin Building
Mappin Street
Sheffield S1 3JD
United Kingdom
Tel:+44 (0) 114-222-5182
Mobile:+ 44(0) 7712804892
Web: www.mobile1.net
E-mail: [email-masked]

----- Original Message -----
From: "Roberts Philip-qa3445" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, November 28, 2000 4:38 PM
Subject: [MOBILE-IP] draft agenda

> Here it is, folks.  We have some specific goals we'd like to accomplish at
this meeting and the time will be made available to get those done.  We'd
like to get the v6 draft wrapped up.  It's in last call now and we'd like to
reconcile all remaining issues by the end of the San Diego meeting.  We'd
like to reach agreement on a single draft to be working group document for
MIP v4 fast handoff.  We'd like to reach agreement on a single draft to be
working group document for MIP v6 fast handoff.
> Pat Calhoun     5       Proactive handoff
draft-calhoun-mobileip-proactive-fa-02.txt
> Hesham Soliman  5       Fast handoff
draft-elmalki-mobileip-fast-handoffs-03.txt
> Glenn Morrow    15      Intercepting Location Updates
draft-lmk-mobileip-intercepting-update-00.txt
> Hesham Soliman  10      Security association establishment for route
optimization in v6 draft-soliman-mobileip-routeopt-mipv6-00.txt
> SL Tsao         15      Introducing Mobile IP in IPv4/IPv6 Interconnected
networks
draft-tsao-mobileip-duelstack-model-00.txt
> Steve Glass     10      Use of DHCP in Mobile IP
draft-glass-mobileip-agent-dhcp-proxy-00.txt
> Pekka Nikander  10      Mobile IP v6 for the Homeless
draft-nikander-mobileip-homelessv6-00.txt

---

From: Pekka Nikander <[email-masked]>
Date: Fri, 1 Dec 2000 21:59:32 +0200

> I wonder is "Mobile IP v6 for the Homeless" in charter of working group.

Well, I assume I am biased to answer (since I am the main author of the
draft), but the charter says:

  "The Mobile IP method supports transparency above the IP layer,
   including the maintenance of active TCP connections and UDP port bindings"

The Homeless Mobile IPv6 draft addresses exactly this point, and in a way
  a) that is backward compatible with the current Mobile IPv6 draft,
  b) that is more efficient in what comes to the average IPv6 header size,
  c) that provides better support for multi-homed mobile hosts (aka
     multi-access), host renumbering, and load balancing over several
     parallel links, and
  d) does not _require_ any changes to the wire protocol, even though
     we do propose some small extensions.
Furthermore, it MAY work without explicit home agents (hence the name),
using something like Dynamic DNS to get the initial address of a host.
Once the address is got, it keeps track of movement using Binding Updates,
more or less just like the current Mobile IPv6 draft.  Even though we
do not mention it in the current draft, I don't see any
techical reason why it could not work with home agents as well.
On the other hand, since our primary goal was to device a protocol
that would be more or less "Mobile IPv6 for ad hoc networks", we
wanted to make a solution that can work without home agents.

Now, the draft proposes a small (but significant) change to the
IP semantics.  Based on our analysis and experimentation, most (but
not all) applications will not notice this change at all.  However,
one of the reasons for publishing the draft is that maybe someone
would come along a method that would allow full backward compatibility
for all applications. We have some ideas, but we haven't tested the yet.

Thus, we'd like to raise some discussion about whether it would be
beneficial to possibly make a small change to the Mobile IPv6
semantics, at some later point, in order to gain the benefits mentioned
above.  At least we think that the issue is worth experimenting, and
we are releasing our prototype implementation as soon as it is stable
enough to be used by others.  On the other hand, if any of you have
already considered the method we describe, and found out why it would
not work, we'd be more than happy to know.  So far, we haven't found
anyting that would be exactly the same approach in any proposals.

--Pekka Nikander