Subject: [MOBILE-IP] Registration Reply in Mobile IP

From: Matteo Berioli <[email-masked]>
Date: Wed, 29 Nov 2000 14:12:37 +0100

I'm looking for the complete list of all the possible values of CODE
field in the Registration Reply message of Mobile IP.
In RFC 2002 of Mobile IP, page 32, it is said:

Up-to-date values of the Code field are specified in the most recent
   "Assigned Numbers" [20].

But I cannot find it!
Anybody can help me?!

Thanks,
Matteo

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 Nov 2000 07:31:54 -0800

Hello Matteo,

Try http://www.iana.org/numbers.html, and work down from there.

Regards,
Charlie P.

Matteo Berioli wrote:
>
> I'm looking for the complete list of all the possible values of CODE field in
> the Registration Reply message of Mobile IP.

---

From: Matteo Berioli <[email-masked]>
Date: Wed, 29 Nov 2000 17:21:21 +0100

OK, I don't find the answer I'm looking for.
Let us assume that two different mobile nodes ask the Foreign Agent to register the
same Co-located CoA simultaneously.
For example the FA could forward only one of the 2 requests, and send to the other
MN a Registration Reply with a particular value in the CODE field.
That value could just mean that the registration would be successful simply
changing the Co-located CoA requested.
As a matter of fact that address, that was free only a minute before, has just been
taken by another MN.
Cannot the FA communicate what happened through a Registration Reply with a
particular CODE field?! Doesn't such a  message exist?

Thanks,
Matteo