Subject: [MOBILE-IP] Sending changed prefixes to the mobile node.

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 8 Nov 2000 11:32:56 -0800

Hello Ken,

In your suggested modifications for section 9.7 of the
Mobile IPv6 draft, about "Renumbering the Home Subnet",
you suggested that notification should occur after the
prefix lifetime is reduced.  This is also specified in
draft revision 12.

It seems to me that the mobile node should also be
notified if the prefix lifetime increases.  The notification
does not have to be done urgently, of course.

Is there any reason why the notification should be done
only after reduction?

Regards,
Charlie P.

---

From: "Powell, Ken" <[email-masked]>
Date: Wed, 8 Nov 2000 17:55:40 -0500

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Wednesday, November 08, 2000 2:33 PM
> To: [email-masked]
> Subject: [MOBILE-IP] Sending changed prefixes to the mobile node.
>
>
> Hello Ken,
>

I agree.

> Is there any reason why the notification should be done

I was thinking that if the home agent periodically sent a
router advertisement with all prefixes every hour, then it
didn't really matter if the a special advertisement goes
out immediately just to tell a mobile node that a lifetime
changed from say 5 days to 2 weeks. Thinking about it again,
it would make a big difference if the lifetime changes from
5 minutes to 2 weeks, so better send the advertisement.
This probably won't happen very frequently, so it makes
sense to keep the logic simple. I wouldn't recommend adding
a special check for the initial lifetime being greater
than the max advertisement interval.