Subject: Re: [MOBILE-IP] v4 fast handoff lack of interest?

From: Roberts Philip-qa3445 <[email-masked]>
Date: Wed, 8 Nov 2000 10:57:16 -0600

Thanks for the comments.  The one point I want to make at this time in
response to what you've written and what Haseeb asked before is that by
choosing a draft from among these two presently does *NOT* imply that draft
is set in stone.  It would become the working group item which is of course
open to improvements.

> ----------
> From:         M. Scott Corson
> Sent:         Thursday, November 9, 2000 12:47 AM
> To:   Roberts Philip-qa3445; [email-masked]
> Subject:      Re: [MOBILE-IP] v4 fast handoff lack of interest?
>
> >        Raj and I are trying to discern whether the working group is a)
> >uninterested in making a decision about the proposals (either one is
> fine)
> >or b) uninterested in having a v4 fast handoff work item because it's not
> >perceived as something that's going to be used.  It's hard for us to draw
> >any conclusions on this without some comments.  Care to give us a sense
> >about it?
> >
> >Thanks,
> >Phil
> >
>
> Phil,
>
> Just on time we have some comments.....and you thought that no one cared
> :-)
>
> We feel that the FA assisted approach has a number of advantages over the
> fast handoff approach. Most of the arguments, however, have been made
> already in this list (see McCann's "[MOBILE-IP] Differences between the
> two
> MIPv4 handoff approaches" for an example). The most important arguments
> against Fast Handoff from our point of view is:
> 1. Increased signaling on the old link; which might be degrading.
> 2. Ability of the FA assisted approach to support vanilla RFC2002 MIP
> clients.
>
> We do, however, feel that the FA assisted proposal can be improved.
>
> Please consider the following modifications:
> Lets use the basic idea of Source and Destination Trigger but also support
> the following:
> 1. A temporary tunnel between old FA and new FA (whether GFA/AFA is used
> or
> not)
> 2. The creation of this temporary tunnel to be based on BR/BU/BUAck
> messages (see below)
> 3. Regional/Hierarchical mobile IP signaling to be optionally used in
> parallel to the 1,2
>
> In more particular:
>
>
>
>                                                  +-----+
>                                                  | GFA |
>                                                  +-----+
>                                                   ^  |
>                                  2b. Regional Reg |  | 3b. Regional Reply
>                                                   |  |
>                                                   |  v
>                       +-----+ 1. Binding Update  +-----+
>                       |     | -----------------> |     |
>                       | oFA | 2. Binding Ack     | nFA |
>                       |     | <----------------- |     |
>                       +-----+                    +-----+
>
>
>                       +-----+    Movement        +-----+
>                       | MN  | - - - - - - - - -> | MN  |
>                       +-----+                    +-----+
>        Figure 4 - "source trigger" hand-off optionally using either AFA or
> GFA
>
> - 1 & 2 are mandatory messages that set a temporary (optionally
> bi-directional) tunnel between oFA and nFA
> - 2b & 3b are optional messages used if the BU includes a GFA or AFA
> address
>
>                                                  +-----+
>                                                  | GFA |
>                                                  +-----+
>                                                   ^  |
>                                  3b. Regional Reg |  | 4b. Regional Reply
>                                                   |  |
>                               1. Binding Request  |  v
>                       +-----+ <----------------  +-----+
>                       |     | 2. Binding Update  |     |
>                       | oFA | -----------------> | nFA |
>                       |     | 3.  Binding Ack    |     |
>                       +-----+ <----------------- +-----+
>
>
>                       +-----+    Movement        +-----+
>                       | MN  | - - - - - - - - -> | MN  |
>                       +-----+                    +-----+
>        Figure 5 - "target trigger" hand-off using either AFA or GFA
>
> - 3b & 4b are optional messages used if the BU includes a GFA or AFA
> address
> - 1 & 2 & 3 are mandatory messages that set a temporary tunnel between oFA
> and nFA
>
> The above modified version of the FA assisted has the following
> advantages:
> 1. Fast Handoff is isolated from Regional Registration or other
> hierarchical signaling.
> 2. The proactive establishment of the temporary tunnel between oFA and nFA
> provides Fast Handoff and helps to ensure zero packet loss during handoff
> 3. Retains the main advantages of the original FA assisted proposal:
>    - support for vanilla RFC2002 MIP clients,
>    - no additional signaling over the radio link.
>    - optional support for Regional Registration (or other hierarchical
> solutions)
>
> -Scott C. (and George T.)
>
>
>

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 8 Nov 2000 09:07:29 -0800

> > We do, however, feel that the FA assisted proposal can be improved.
Speaking as one of the co-authors of the draft (but I presume that all authors
would agree with me), providing some command and/or improvements to the I-D
would be most appreciated. I will read your comments a little later and
provide my input.

Thanks,

PatC