Subject: [MOBILE-IP] Placement for Binding Update and Home Address options

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 9 Nov 2000 10:14:35 -0800

Hello again,

Here's another puzzler -- actually, two.

Most discussions have the Binding Update appearing after
the IPsec headers.  This is presumably to offer some
protection against monitoring how often the mobile node
has to send Binding Updates to its correspondent nodes
and home agent(s), without having to incur the expense
of wrapping the whole packet in tunnel mode encryption.

However, the current specification allows for the Binding
Update to be inserted in the same Option header as the
Home Address destination option.  The advantage in doing
that is to save space.  The disadvantage is that then there
are always two legally specified places for the Binding
Update to appear, making processing more complicated.

The second question involves where the first Destination
Options header should be placed.  After quite a bit of
discussion and thought, I have come to the conclusion
that it should be located _after_ the Routing Header
but _before_ the Fragment Header.  The reasons are that
intermediate routers SHOULD NOT process the Home Address
destination option, but firewall SHOULD see the same
home address for all fragments.

I think I have that right, but I'm mainly offering it for
discussion.

Bottom line _proposal_:

Mandatory placements:
        - Home Address option between Routing and Fragment Headers
        - Binding Update after ESP.

Comments?

Regards,
Charlie P.

---

From: Francis Dupont <[email-masked]>
Date: Fri, 10 Nov 2000 18:27:30 +0100

In your previous mail you wrote:

   Bottom line _proposal_:

   Mandatory placements:

=> I agree, home address and tunnel encapsulation limit between routing
and fragment, all other destination options (binding XXX) after ESP.

   Comments?

=> this makes three placements for a destination option header, two
were already too many. The whole destination option header concept
should be redone, for instance my proposal is:
 - kill the placement between hop-by-hop and routing headers
   (not used, just make implementations more complex)
 - keep the placement between routing and fragment headers for type 60
 - get a new type from IANA for placement after ESP (IPCOMP in fact)
This will give in the future simplest/cleanest implementations, the price
is incompatibility for mobile IPv6 implementations (which should be
incompatible in some cases with any proposal :-).

Thanks

[email-masked]

PS: I have added the IPng WG mailing list because this is in its scope.