Subject: Re: [MOBILE-IP] DAD

From: "Powell, Ken" <[email-masked]>
Date: Thu, 9 Nov 2000 13:54:51 -0500

Charlie,

I think the problem is that the home agent will only
defend against a duplicate address when there is a binding
with the mobile node. This is something that the base specs
are not concerned with. Therefore, it might make sense
to add a statement like:

  The home agent will only defend against a duplicate
  address when there is a binding with the mobile node.
  Therefore, the mobile node MUST treat creation of a
  new binding with the home agent using an existing home
  address the same as creation of a new home address.

Ken

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Thursday, November 09, 2000 10:19 AM
> To: [email-masked]
> Subject: Re: [MOBILE-IP] DAD
>
>
> Hello Matthias,
>
> On page 22, the current specification says:
>
>          ...      The mobile node SHOULD set the Duplicate Address
>          Detection (D) bit based on any requirements for Duplicate
>          Address Detection that would apply to the mobile node if it
>          were at home [17, 27].
>
> Why isn't this sufficient?
>
> Regards,
> Charlie P.
>
>
>
> Mattias Pettersson wrote:
> >
> > Hi all,
> >
> > I pointed this out in a separate mail, but inlined with a
> lot of other
> > text. Here is the separate comment on today's DAD:
> >
> > /Mattias
> >
> > -----
> >
> > Charlie and others: I can't find anywhere in the I-D that the MN is
> > required to check its Home Address for DAD, other that during
> > renumbering. If the MN is given an address from start (hard coded or
> > statelessly created by combining home prefix and interface
> token), it
> > must set the D-flag in the initial BU to the HA. It must do
> this every
> > time the HA doesn't guard the address.
> >
> > The current spec will only work if the MN at day 1 starts
> on the home
> > subnet.
>

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 10 Nov 2000 11:02:40 +0100

>   address the same as creation of a new home address.

Thanks, Ken.

/Mattias

---

From: Francis Dupont <[email-masked]>
Date: Tue, 14 Nov 2000 14:01:48 +0100

In your previous mail you wrote:

=> I can't see the difference between this and the current spec.

   >          Address Detection that would apply to the mobile node if it

=> when a node is attached again to a link with an existing address
(this can imply static configuration which is used for routers for instance)
then it should perform a DAD. For a mobile node this gives the "new binding
using an existing home address", doesn't this?

Regards

[email-masked]