Subject: Re: [MOBILE-IP] v4 fast handoff lack of interest?

From: George Tsirtsis <[email-masked]>
Date: Wed, 15 Nov 2000 08:33:35 -0500

All,

I am a bit surprised that none of the 7 authors of the FA assisted proposal
has reacted to this e-mail. Raj was worried that the WG did not care but
maybe not even the authors of this proposal care.
...just joking ;-)

Seriously, unless we have some debate on this, how do we expect to resolve
this issue in the meeting?

Regards
George
-----Original Message-----
From: Patrice Calhoun
To: [email-masked]
Sent: 11/8/00 12:07 PM
Subject: Re: [MOBILE-IP] v4 fast handoff lack of interest?

> > We do, however, feel that the FA assisted proposal can be improved.
> >
Speaking as one of the co-authors of the draft (but I presume that all
authors
would agree with me), providing some command and/or improvements to the
I-D
would be most appreciated. I will read your comments a little later and
provide my input.

Thanks,

PatC

-----Original Message-----
From: M. Scott Corson
To: [email-masked]
Sent: 11/8/00 11:47 AM
Subject: Re: [MOBILE-IP] v4 fast handoff lack of interest?

..
Phil,

Just on time we have some comments.....and you thought that no one cared
:-)

We feel that the FA assisted approach has a number of advantages over
the
fast handoff approach. Most of the arguments, however, have been made
already in this list (see McCann's "[MOBILE-IP] Differences between the
two
MIPv4 handoff approaches" for an example). The most important arguments
against Fast Handoff from our point of view is:
1. Increased signaling on the old link; which might be degrading.
2. Ability of the FA assisted approach to support vanilla RFC2002 MIP
clients.

We do, however, feel that the FA assisted proposal can be improved.

Please consider the following modifications:
Lets use the basic idea of Source and Destination Trigger but also
support
the following:
1. A temporary tunnel between old FA and new FA (whether GFA/AFA is used
or
not)
2. The creation of this temporary tunnel to be based on BR/BU/BUAck
messages (see below)
3. Regional/Hierarchical mobile IP signaling to be optionally used in
parallel to the 1,2

In more particular:

                                                 +-----+
                                                 | GFA |
                                                 +-----+
                                                  ^  |
                                 2b. Regional Reg |  | 3b. Regional
Reply
                                                  |  |
                                                  |  v
                      +-----+ 1. Binding Update  +-----+
                      |     | -----------------> |     |
                      | oFA | 2. Binding Ack     | nFA |
                      |     | <----------------- |     |
                      +-----+                    +-----+

                      +-----+    Movement        +-----+
                      | MN  | - - - - - - - - -> | MN  |
                      +-----+                    +-----+
       Figure 4 - "source trigger" hand-off optionally using either AFA
or GFA

- 1 & 2 are mandatory messages that set a temporary (optionally
bi-directional) tunnel between oFA and nFA
- 2b & 3b are optional messages used if the BU includes a GFA or AFA
address

                                                 +-----+
                                                 | GFA |
                                                 +-----+
                                                  ^  |
                                 3b. Regional Reg |  | 4b. Regional
Reply
                                                  |  |
                              1. Binding Request  |  v
                      +-----+ <----------------  +-----+
                      |     | 2. Binding Update  |     |
                      | oFA | -----------------> | nFA |
                      |     | 3.  Binding Ack    |     |
                      +-----+ <----------------- +-----+

                      +-----+    Movement        +-----+
                      | MN  | - - - - - - - - -> | MN  |
                      +-----+                    +-----+
       Figure 5 - "target trigger" hand-off using either AFA or GFA

- 3b & 4b are optional messages used if the BU includes a GFA or AFA
address
- 1 & 2 & 3 are mandatory messages that set a temporary tunnel between
oFA
and nFA

The above modified version of the FA assisted has the following
advantages:
1. Fast Handoff is isolated from Regional Registration or other
hierarchical signaling.
2. The proactive establishment of the temporary tunnel between oFA and
nFA
provides Fast Handoff and helps to ensure zero packet loss during
handoff
3. Retains the main advantages of the original FA assisted proposal:
   - support for vanilla RFC2002 MIP clients,
   - no additional signaling over the radio link.
   - optional support for Regional Registration (or other hierarchical
solutions)

-Scott C. (and George T.)

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 15 Nov 2000 09:18:14 -0800

I do appologize for the delay (and I must admit that this fell off my plate :(.
 below are my comments.

PatC
>                       +-----+ 1. Binding Update  +-----+

I believe that I can buy this argument... I have some small issues with
overloading a message type, but I cannot seem to justify them in the fact of
protocol simplicity.

> provides Fast Handoff and helps to ensure zero packet loss during

I agree.

>    - optional support for Regional Registration (or other hierarchical

Correct.

Overall, I believe that I am in agreement with the proposed. I will discuss
this with the co-authors to ensure that they are also in agreement, and will
then submit a revised version before the deadline.

Thanks for the valuable input.

PatC