Subject: Re: [MOBILE-IP] Mobile IPv4/6 interworking draft

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Fri, 8 Dec 2000 01:02:20 +1100

> Hello,
>
> I don't believe there is a need for translators in either scenario
below.
> Comments inline
>
>
>
>
> > In the draft-tsao-mobileip-dualstack-model-01.txt Tsao et al.
suggests to
> > use dual stack mobile nodes to allow it to roam in both IPv4 and
IPv6
> > environment. There are two cases presented:
> > 1. MN is visiting IPv6 network and wants to register to IPv4 HA
> > 2. MN is visiting IPv4 network and wants to register to IPv6 HA
> >
> > In first case the MN sends MIPv4 messages in the payload of IPv6
datagrams
> > and the border router of the IPv6 network translates the messages
into
> > IPv4.
> >
>         => There is no need for translators in either case. For case
(1)
>         IPv4 can be tunnelled into IPv6 up to a Tunnell End Point
(TEP)
>         and then forwarded to the IPv4 network. Please refer to DSTM.
>
>         In the second case 6 over 4 can be used to get connectivity
>         to the V6 network.
>
>         Translators are ONLY needed if single stacked MNs are used,
therefore
>         I don't see the need for translators in either case

Yes, I agree.
However, I think the above two solutions have certain assumptions on the
network infrastructure. For example, in the first case, DSTM and SIIT
should be implemented in the visited networks.

=> No only DSTM is required. You only need translators if
you have 2 incompatible stacks in the end hosts.

 As for the second case,
6over4 mechanism assumes at least one IPv6 router implementing 6over4
method must be connected to the IPv4 domain. How about a MN moves to an
IPv4 domain without IPv6 router connectivity ?

=> If the visited domain doesn't support any
migration mechanism at all, then yes communication
is impossible.

The proposed dual stack mobile IP interworking draft is basically a
MN-based approach regardless of the underlaying infrastructure. That is
why we suggest to send MIPv4 messages in the payload of IPv6 datagrams
or vice versa. Then, these messages are translated by translators such
as SIIT or NAT-PT and forwarded to the destinations.

=> I'll have to read your draft again because I
seem to see a different approach in this statement
above.
SIIT and NAT-PT translate headers, not payloads.
MIPv4 messages can not be seen by SIIT because
they run on the application layer. Again, the
terminology is unclear to me, translators => incompatible
stacks in the end hosts. Are you assuming that
the MN is for example V4 and the HA is V6 only ??
If you just want to encapsulate then you don't need
translators.

Hesham

---

From: Shiao-Li Charles Tsao <[email-masked]>
Date: Fri, 8 Dec 2000 19:45:08 +0800

>you have 2 incompatible stacks in the end hosts.

You are right. Translators are required if CN and MN have incompatible stacks. In the dual stack interworking draft, I assume CN and MN might have incompatible stacks.

>If you just want to encapsulate then you don't need

Yes, SIIT and NAT-PT only translate headers. So, we suggest MNv4 to send MIPv4 messages with an IPv6 header to HAv4 while it is in IPv6-only network or vice versa. SIIT and NAT-PT can translate header (IPv6 header to IPv4 header or vice versa) for us. Then, MIP messages can be recognized by HAv4.

In the draft, we assume MN and HA is in the same IP stack. But the CN can be IPv6 or IPv4 and MN can migrate to IPv4 or IPv6 networks. If CN is IPv4 and MNv4 wants to send MIPv4 messages such as Binding Update to CNv4, the scenario is similar to HAv4 case. If CN is IPv6, CNv6 has to communicate MNv4 using IPv4-mapped address or something like that.

By the way, MIP messages such as Binding Update are incompatible in MIPv4 and MIPv6. There is another problem if MNv4 wants to update binding information in CNv6 or vice versa. We submitted another draft about application level gateway which translates MIPv4 and MIPv6 messages.
http://search.ietf.org/internet-drafts/draft-tsao-mobileip-00.txt

I will also present the draft in the Mobile IP WG and NGTRANS WG at San Diego meeting. I do appreciate for your comments and suggestions.

Shiao-Li Tsao