Subject: Re: [MOBILE-IP] Mobile IPv4/6 interworking draft

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Thu, 7 Dec 2000 11:30:02 +1100

Hello,

I don't believe there is a need for translators in either scenario below.
Comments inline

> In the draft-tsao-mobileip-dualstack-model-01.txt Tsao et al. suggests to
> use dual stack mobile nodes to allow it to roam in both IPv4 and IPv6
> environment. There are two cases presented:
> 1. MN is visiting IPv6 network and wants to register to IPv4 HA
> 2. MN is visiting IPv4 network and wants to register to IPv6 HA
>
> In first case the MN sends MIPv4 messages in the payload of IPv6 datagrams
> and the border router of the IPv6 network translates the messages into
> IPv4.
>
        => There is no need for translators in either case. For case (1)
        IPv4 can be tunnelled into IPv6 up to a Tunnell End Point (TEP)
        and then forwarded to the IPv4 network. Please refer to DSTM.

        In the second case 6 over 4 can be used to get connectivity
        to the V6 network.

        Translators are ONLY needed if single stacked MNs are used,
therefore
        I don't see the need for translators in either case

        Regards,
        Hesham

---

From: Shiao-Li Charles Tsao <[email-masked]>
Date: Fri, 8 Dec 2000 19:42:18 +0800

Dear all,

----- Original Message -----
From: "Hesham Soliman (EPA)" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, December 07, 2000 8:30 AM
Subject: Re: [MOBILE-IP] Mobile IPv4/6 interworking draft

therefore
>         I don't see the need for translators in either case

Yes, I agree.
However, I think the above two solutions have certain assumptions on the
network infrastructure. For example, in the first case, DSTM and SIIT should
be implemented in the visited networks. As for the second case, 6over4
mechanism assumes at least one IPv6 router implementing 6over4 method must
be connected to the IPv4 domain. How about a MN moves to an IPv4 domain
without IPv6 router connectivity ?
The proposed dual stack mobile IP interworking draft is basically a MN-based
approach regardless of the underlaying infrastructure. That is why we
suggest to send MIPv4 messages in the payload of IPv6 datagrams or vice
versa. Then, these messages are translated by translators such as SIIT or
NAT-PT and forwarded to the destinations.
We haven't taken AAA issues into consideration in the current draft. But I
think the proposed draft does not introduce new security issues beyond the
security issues presented in mobile IP and translator mechanisms such as
SIIT and NAT-PT.

Comments are welcome !!!

Shiao-Li Tsao

---

From: Nam Hoang Nguyen <[email-masked]>
Date: Thu, 14 Dec 2000 14:28:44 +0100

Dear all !

I plan to build an experiment/prototype for Mobile IPv4/ or IPv6 and I am not
sure about which equipments (hardware, software) are needed and how to start.
Has anyone done such a similar thing ??
Where (website) should I look for ??

Please give me suggestions, any is highly appreciated.

Many thanks in advance !

Regards

Nam

---

From: cnyap <[email-masked]>
Date: Thu, 14 Dec 2000 15:58:36 -0000

Hi

----- Original Message -----
From: "Nam Hoang Nguyen" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, December 14, 2000 1:28 PM
Subject: [MOBILE-IP] About Mobile IP experiment/prototype !

> Where (website) should I look for ??

It really depend on what you wanted to do.
You would need probably at least 5 (PC)
machines for MIPv4

There are several implementations
I have some links to these implementations
http://myhome.zaobao.com/home/m/mobione/mobile_links.htm

One Router,
One Home Agent
One Foreign Agent
One Mobile Node
One Correspondent Node.

Hence
                 Router --------- Correspondent Node
                      |
--------------------------------
|                                           |
Home Agent                        Foreign Agent
|                                           |
Mobile Node ------------->>

Cheers
Chern Nam Yap
MIEEE, MSc(Res), BSc(Hons)
Research Associate
Center for Mobile Communication Research
Department of Electronic and Electrical Engineering
University of Sheffield
F132 Mappin Building
Mappin Street
Sheffield S1 3JD
United Kingdom
Tel:+44 (0) 114-222-5182
Mobile:+ 44(0) 7712804892
Web: www.mobile1.net
E-mail: [email-masked]