Subject: RE: [mobile-ip] Resolution for issue #198

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 Jan 2003 16:24:41 -0000

Hi Ville,

Note that the MN DAD'ing its own home address as opposed to the HA's
also gets him the LLA of the HA, with no change in ND, and with the
additional value of checking the home address for a real duplication.
There must be a reason why we did not do that way, but I cannot see
which one ???

Pascal

> -----Original Message-----
> From: Ville Nuorvala [mailto:[email-masked]] 
> Sent: mardi 21 janvier 2003 16:20
> To: Francis Dupont
> Cc: Mobile IP Working Group
> Subject: Re: [mobile-ip] Resolution for issue #198 
> 
> 
> Hi Francis!
> 
> The issue is that the MN might need to do ND to get the LLA 
> of its HA if there are multiple advertising HA:s on the home 
> link, as Pascal pointed out, but the (mis)use of DAD probes 
> beyond their scope leads to complications. (MN returning home 
> unwittingly DoS:ing rebooting HA)
> 
> This was the problem we were trying to solve.
> 
> As to the mobile-ip/IPv6 WG issue relating to my proposition, 
> you are probably right. As a relative newcomer to the IETF 
> forums, I wasn't aware of all the bureaucracy and red-tape 
> involved in the decision making process. Is the interaction 
> (not to mention cooperation) between the different IETF WG:s 
> really as problematic as you would imply?
> 
> As to my actual solution, it doesn't break anything, as 
> normal RFC 2461 compliant nodes (all nodes except HA:s) just 
> silently discard the packet, while the old hack actually 
> broke the DAD protocol. The only problem with my solution is 
> that one ICMP code (out of AFAIK 255 free ones) needs to be 
> allocated for this purpose. Which one is worse?
> 
> If the IPv6 WG was about to permit a hack that breaks DAD, I 
> honestly don't understand why it wouldn't permit a solution 
> that doesn't.
> 
> Regards,
> Ville
> --
> Ville Nuorvala
> Research Assistant, Institute of Digital Communications, 
> Helsinki University of Technology
> email: [email-masked], phone: +358 (0)9 451 5257
> 
> 
> 
> 
>

---

From: Ville Nuorvala <[email-masked]>
Date: Tue, 21 Jan 2003 19:35:22 +0200 (EET)

> additional value of checking the home address for a real duplication.

Hey really, couldn't you come up with this yesterday? ;)

> There must be a reason why we did not do that way, but I cannot see

I haven't at least been able to find any problems in your solution with
my somewhat limited knowledge.

The simplest and most elegant solutions are often right before our eyes.
All it takes is someone to notice them, I guess. :)

Ville

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 22 Jan 2003 01:55:36 +0100

Sure sounds like it'll work much better than previous
alternatives. The good news is that we now have 2 weeks
or so in which to really think it over and make sure
this does work (as it seems at first sight).

-gabriel