Subject: Re: [mobile-ip] question on prefixes to be included in MPA

From: [email-masked]
Date: Fri, 24 Jan 2003 09:59:00 +0530

I think we should send all the prefixes advertised by routers with 'H' bit
set (HA)  as well as 'H' bit not set on the home link.
MN in foreign n/w should know all the prefixes as if it is present in home
n/w.

Refer sec 10.6.1 Aggregate List of Home Network Prefixes --

  "Mobile IPv6 arranges to propagate relevant prefix information to the
   mobile node when it is away from home, so that it may be used in
   mobile node home address configuration, and in network renumbering.
   In this mechanism, mobile nodes away from home receive Mobile Prefix
   Advertisements messages with Prefix Information Options, which give
   the valid lifetime and preferred lifetime for available prefixes on
   the home link."

----------------------------------------------------------------
Sourajeet Mohanty
Software Engineer
Communications and Embedded Systems
L&T Infotech Ltd., Bangalore
-----------------------------------------------------------------

                      Vijay Devarapalli                                                                           
                      <[email-masked]>         To:       Shinta Sugimoto <[email-masked]>           
                      Sent by:                        cc:       [email-masked]                     
                      owner-mobile-ip@sunroof.        Subject:  Re: [mobile-ip] question on prefixes to be        
                      eng.sun.com                      included in MPA                                            

                      23/01/2003 12:22 AM                                                                         

Shinta Sugimoto wrote:
>
> Hello,
>
> I need a clarification regarding MPA.
>
> In section 10.6.1 "Aggregate List of Home Network Prefixes"
> of MIP6 base spec, it says that HA collects available prefixes
> on home network and send them with MPA.
> I wonder if it means that HA should only handle prefix that
> have been carried by RA with (H) bit set, or should it also
> handle prefix that have been carried by RA without (H) bit set?

isnt section 10.6.1 clear about this?

>
>    o  For Router Advertisements which have the Home Agent (H) bit set,
>       check valid prefixes that are not yet in the aggregate list.

you should include only those prefixes which has the H bit set.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 24 Jan 2003 09:47:08 -0800

hi Sourajeet,

>    the valid lifetime and preferred lifetime for available prefixes on

heres the deal. if the H bit is not set for a particular prefix,
that means there is no Home Agent on the home link which will 
defend addresses derived from that prefix. so there is no point 
in the MN configuring the home addresses for those prefixes. 
therefore the MN does not have to hear about those prefixes.

do you agree with me here?

Vijay

---

From: Vladislav Yasevich <[email-masked]>
Date: Fri, 24 Jan 2003 13:07:05 -0500

Vijay

> do you agree with me here?

Yes, this is now correct since the "multiple address registration"
('S' bit) has been removed.

If we procede with this, "multiple prefix registration" will have be
redesigned (compared with 'S' bit).  Just something to keep in mind.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tru64 UNIX - IPv6 Project Lead
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07