Subject: Re: [mobile-ip] Proxying for MN's link local address

From: [email-masked]
Date: Thu, 23 Jan 2003 09:58:06 +0530

hi vijay,
   Consider the scenario: -
MN is in foreign network has has registered itself with a HA.  If a CN on
MN's home link tries to send a packet to MN's link local address or  tries
to do NUD for MN's link local address then the packet will be lost if HA
has not sent a gratuitous NA for MN's link local address as CN's neighbor
table won't be updated.

                      Vijay Devarapalli                                                                      
                      <[email-masked].        To:       [email-masked]                       
                      com>                       cc:       [email-masked]                     
                      Sent by:                   Subject:  Re: [mobile-ip] Proxying for MN's link local      
                      [email-masked]         address                                                    
                      g.nokia.com                                                                            

                      22/01/2003 11:51 PM                                                                    

[email-masked] wrote:
>
> hi,
>    if the 'L' bit is set in the BU, HA has to do proxy for MN's link
local
> address also.
> So, HA should send gratuitous NA for MN's link local address also.
> This is missing in section " 10.4.1 Intercepting Packets for a Mobile
> Node". This section only talks about MN's
> home address which is present in the BU.

the HA sends a gratuitous NA to override neighbor cache entries
for the MN's home address on other nodes in the home link

a gratuitous NA is not necessary for the link local. this is
because the HA does not tunnel packets meant for the MN's link
local. so there is not need to override anybody's neighbor cache
entry on the home link.

Vijay

---

From: Vladislav Yasevich <[email-masked]>
Date: Thu, 23 Jan 2003 10:08:28 -0500

Which is correct, since the HA-MN virtual tunnel is a different link.
We don't want that communication to succeed.

Lost data packets will trigger NUD which will fall back to a multicast
NS, which will be answered by the HA.  Subsequent packets to HA will be
dropped by the HA along with a "Beyond Scope" ICMP message to the source
of offending packets.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tru64 UNIX - IPv6 Project Lead
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07