Subject: RE: [mobile-ip] Mipv6 issue #194: More details on how movements are handling wrt IKE

From: "Mohan Parthasarathy" <[email-masked]>
Date: Mon, 6 Jan 2003 14:11:05 -0800

> 
> Francis Dupont wrote:
> 
> >    - Require an API between MIPv6 and IKE so that the IKE SAs can
> >       also change their endpoints
> > 
> > => not require... but such an API will make things easy.
> 
> We have already concluded that we will have to accept a reneg
> request at any time, potentially with INITIAL_CONTACT notif
> which would delete all previous connections.
> 
> We have also concluded that new IKE implementations will be
> able to move to different addresses due to NAT traversal.
> 
> I think most people dislike the idea of rerunning IKE
> on movements, except in special cases perhaps.
> 
> I agree that not all implementations have an IKE API available
> at the moment.
> 
> What alternatives do we have then?
> 
> 1) Use the reneg approach only. This is very undesireable.
> 2) Allow an optional API approach, fallback to reneg.
> 3) Require an API approach always.
> 4) Allow NAT-traversal style non-signaled endpoint changes.
> 5) Require NAT-traversal style end-point changes.
> 
> Between the API vs. NAT-traversal style, I'd prefer the former,
> since we have the information available.
> 
> Francis, what is your preferred approach from above?
> 
> I'd be willing to go for approach #2, but I'm not sure how
> interoperability is achieved. How does my MN know that your
> HA supports or does not support the API? Or will I change my
> endpoint through the API, and if you dont' support this you
> will send me a reneg?
> 
I would also go for (2). As HOTI is sent only after the binding ack is received,
i still think it is a possibility for the HA to tell MN whether it updated
the IPsec SA for the RR SA or not.

-mohan

> Jari

---

From: Jari Arkko <[email-masked]>
Date: Wed, 08 Jan 2003 00:37:27 +0200

> the IPsec SA for the RR SA or not.

Yes, though we'd also need the MN to tell the HA if it can update the SAs.
You could do this through one bit flag in the BU and another in the BA.

Jari