Subject: Re: [mobile-ip] MIPv6 IPSEc and s=0

From: Marc Hasson <[email-masked]>
Date: Mon, 13 Jan 2003 19:27:00 -0800 (PST)

Brian wrote in response to Ed:

 > > I agree that only MNs that care about optimizing to reduce the number of BUs
 > > sent (and thus minimize handover latency) should use the S=0 BU. Otherwise,
 > > multiple S=1 BUs works perfectly fine.
 > 
 > Right, the S-bit isn't required in the protocol, it's an optimization,
 > which is why I asked a year ago to remove it :)  With all the IPsec
 > discussions going on recently, isn't it possible we still missed some
 > other problem?  Putting it in a separate draft gives people time to
 > investigate things further.

Agreed!  And I've yet to hear a clear explanation/scenario where S=0 is
expected to be important in actual production networks.  Not all
optimizations are worth the complexity and I'd appreciate being counted
in the "no on S=0" camp.

   -- Marc --

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 13 Jan 2003 23:55:18 -0800

Hello Marc,

Having multiple subnets is part of the IPv6 architecture, and
the means to support them effectively has been part of the
Mobile IPv6 specification for a long time.  The work has already
been done, in _preparation_ for deployment in production
networks.  If you don't think that having multiple subnets is
very important, then that seems to be something to be worked
out in the IPv6 working group.  Until then, and considering
that we've got a workable answer for now, I hope we can
use what we already have and close this issue.  And get the
specification published!

Regards,
Charlie P.