Subject: Re: [mobile-ip] MIPv6 Clarification to Type 0 & 2 Routing Headerinterop

From: Ville Nuorvala <[email-masked]>
Date: Thu, 16 Jan 2003 14:05:23 +0200 (EET)

Oops, my reply only went to Gabriel...

On Thu, 16 Jan 2003, Ville Nuorvala wrote:

> On Thu, 16 Jan 2003, gabriel montenegro wrote:
>
> > Ville, I see that the clarification could be useful.
> > Would you be ok with this slightly more explicit wording of
> > your clarification?
> >
> > "If both a type 0 and a type 2 routing header are present,
> > the type 2 routing header should follow the other routing header.
> > In such a nested encapsulation the inner (type 2) routing header
> > is constructed first and then treated as an original packet by
> > the outer (type 0) routing header construction process."
> >
> > If so, please feel free to respond on the mailing list citing the above
> > so we can close this issue.
>
> Looks ok to me!
>
> Ville

---

From: [email-masked]
Date: Mon, 20 Jan 2003 09:45:32 +0530

yes, its much clearer now.
thanks a lot.

regards
suvidh

Saturday, 18 January, 2003 7:30 PM
To: Jari Arkko <[email-masked]>
cc: Mobile IPv6 mailling list <[email-masked]>
From: gabriel montenegro <[email-masked]>
Subject: Re: [mobile-ip] MIPv6 Clarification to Type 0 & 2 Routing
Headerinterop

Jari Arkko wrote:
>   "... A packet containing such nested encapsulation should
>    be created as if the inner (type 2) routing header was
>    constructed first and then treated as an original packet
>    by the outer (type 2) routing header construction process."

Right. The old "as if" trick. One would think it's implied
but no harm in making it explicit.

-gabriel