Subject: [mobile-ip] MIPv6 and multiple interfaces

From: "Mauro Cerboni" <[email-masked]>
Date: Wed, 22 Jan 2003 18:34:18 +0100

I'm trying to figure out how to use MIPv6 on a Mobile Node with multiple interfaces (if possible).
At the beginning I have eth1 in Home Network, eth2 down and I open a connection to a Correspondent Node. Then I put eth2 up (associated in the Visited Network) and eth1 down. Eth2 correctly forms its stateless CoA, but it doesn't seem to send any BU.
Anyone knows why this is not currently happening?
I suppose this is because MIPv6 doesn't support multiple interfaces; in this case does anyone knows if there is a kind of patch supporting this?
 
Thanks in advance for your support,
 
Mauro Cerboni

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 22 Jan 2003 10:42:50 -0800

> Anyone knows why this is not currently happening?

it depends on which interface you assign your home address
to. if the home address is assigned to eth1, and you bring
eth1 down, you wont see any binding updates. OTOH, if you 
assign the home address to a virtual interface (as some 
implementations do), then binding updates should go out
using the CoA on eth2.

> I suppose this is because MIPv6 doesn't support multiple interfaces; in this case does anyone knows if there is a kind of patch supporting this?

whose implementation are you using? ask them.

Vijay

---

From: Miguel Angel Díaz <[email-masked]>
Date: Thu, 23 Jan 2003 10:49:46 +0100

Hi Mauro,

if you are using the "Dynamic Home Agent Address Discovery Mechanism"
described in the draft, you should not have problem to contact with the HA,
even if you have your first interface (eth1) down. MN will try to reach HA
sending first DHAAD packets using eth2 and then when it knows the HA's
address it will send the BU to the HA.

Why don't you try this?

Miguel A. Díaz

----- Original Message -----
From: "Mauro Cerboni" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, January 22, 2003 6:34 PM
Subject: [mobile-ip] MIPv6 and multiple interfaces

> At the beginning I have eth1 in Home Network, eth2 down and I open a
connection to a Correspondent Node. Then I put eth2 up (associated in the
Visited Network) and eth1 down. Eth2 correctly forms its stateless CoA, but
it doesn't seem to send any BU.
> I suppose this is because MIPv6 doesn't support multiple interfaces; in
this case does anyone knows if there is a kind of patch supporting this?
> Thanks in advance for your support,

*********************************
Madrid 2003 Global IPv6 Summit
12-14 May 2003 - Pre-register at:
http://www.ipv6-es.com
Interested in participating or sponsoring ?
Contact us at [email-masked]