Subject: Re: [mobile-ip] "running MLD"

From: Marc Hasson <[email-masked]>
Date: Mon, 13 Jan 2003 19:09:43 -0800 (PST)

I'm fine with all the comments quoted above from Francis and Henrik.  I
assume that at some point it would be nice to enhance the ha-ipsec spec
to show how the DHCPv6 or MLD traffic is properly secured.  It seems to
me that requires an IPsec tunnel to carry the link-local/multicast
HA<->MN DHCP or MLD traffic.  Currently, all HA<->MN MH packets are
carried in IPsec transport mode.

   -- Marc --

---

From: Jari Arkko <[email-masked]>
Date: Wed, 15 Jan 2003 01:47:48 +0200

> I'm fine with all the comments quoted above from Francis and Henrik.  I

I agree with the proposed solution. Exactly what do we need
in terms of text to put it in the specification? I guess
the main thing is to state the requirement for the home
agent to be a multicast router and DHCP relay. But surely
this is not sufficient? Don't we need need also text how
the packets related to these are treated in the MN-HA
tunnel?

Marc, can you suggest some text for this?

> carried in IPsec transport mode.

All MH packets, but we do show how to protect payload traffic.
This may not suffice, if the addressing is too different for DHCPv6
and MLD.

Jari