Subject: Re: [mobile-ip] question on prefixes to be included in MPA

From: [email-masked]
Date: Sat, 25 Jan 2003 14:12:45 +0530

that means when MN is in the Home n/w, it should configure the home address
based on the prefixes advertised by the home agents.

----------------------------------------------------------------
Sourajeet Mohanty
Software Engineer
Communications and Embedded Systems
L&T Infotech Ltd., Bangalore
-----------------------------------------------------------------

                      Vijay Devarapalli                                                                      
                      <[email-masked].        To:       [email-masked]                 
                      com>                       cc:       [email-masked], Shinta Sugimoto    
                      Sent by:                    <[email-masked]>                                    
                      [email-masked]        Subject:  Re: [mobile-ip] question on prefixes to be        
                      g.nokia.com                 included in MPA                                            

                      24/01/2003 11:17 PM                                                                    

hi Sourajeet,

[email-masked] wrote:
>
> I think we should send all the prefixes advertised by routers with 'H'
bit
> set (HA)  as well as 'H' bit not set on the home link.
> MN in foreign n/w should know all the prefixes as if it is present in
home
> n/w.
>
> Refer sec 10.6.1 Aggregate List of Home Network Prefixes --
>
>   "Mobile IPv6 arranges to propagate relevant prefix information to the
>    mobile node when it is away from home, so that it may be used in
>    mobile node home address configuration, and in network renumbering.
>    In this mechanism, mobile nodes away from home receive Mobile Prefix
>    Advertisements messages with Prefix Information Options, which give
>    the valid lifetime and preferred lifetime for available prefixes on
>    the home link."

heres the deal. if the H bit is not set for a particular prefix,
that means there is no Home Agent on the home link which will
defend addresses derived from that prefix. so there is no point
in the MN configuring the home addresses for those prefixes.
therefore the MN does not have to hear about those prefixes.

do you agree with me here?

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 26 Jan 2003 21:11:06 -0800

> based on the prefixes advertised by the home agents.

ofcourse not. when the MN is at home it can configure home addresses
based on all the prefixes advertised on the home link. it can defend
its own addresses. it doesnt need the HA defending its addresses.

but when off link, it doesnt make sense for it configure a home
address based on prefix for which the H bit is not set because nobody
is going to defend that address on the MN's behalf.

there is nothing that can be done about this without the S bit.

Vijay

---

From: Joe Lau <[email-masked]>
Date: Mon, 27 Jan 2003 12:05:10 -0800 (PST)

> [email-masked] wrote:

Then we should make this clear on draft.

10.3.1 Primary Care-of Address Registration
   o  ...

   o  Else, if the home address for the binding (the Home Address field
      in the packet's Home Address option) is not an on-link IPv6
      address with respect to the home agent's current Prefix List, ...

Currently, the word "on-link" does not suggest anything about the H-bit
of the prefix.  I checked the MIPL implementation.  It also does not seems
to check the H-bit either...

	void mipv6_bu_add_home(....)
		ifp = is_on_ink_ipv6_address(haddr, daddr);

		if (ifp == NULL) {
			ba_status = NOT_HOME_SUBNET;
			...
		}

The draft really needs to clarify this issue better.

Joe