Subject: RE: [mobile-ip] Comment on ha-ipsec-02.txt

From: "Greg O'Shea" <[email-masked]>
Date: Thu, 30 Jan 2003 08:32:25 -0000

I would like to agree but colleagues keep pointing out that the words
say:
"...the BUs sent by it to the home agent MUST have at least the
following headers in the following order:" [2.1]

The order is wrong for tunnel mode, so some additional text is needed in
order to permit tunnel mode e.g. using the packet format already
described in 2.2.

The essential part of the spec is in sections 1 and 2, which are quite
short. The bulk is in sections 4 and 5: these are "informative" and
could be deleted if document size is a concern.

>-----Original Message-----
>From: Vijay Devarapalli [mailto:[email-masked]] 
>Sent: 23 January 2003 19:07
>To: Greg O'Shea
>Cc: [email-masked]
>Subject: Re: [mobile-ip] Comment on ha-ipsec-02.txt
>
>
>Greg O'Shea wrote:
>> 
>> >
>> >I note that sections 2.1 and 5.1 still do not allow tunnel 
>mode IPSec 
>> >between MN and HA. I thought we had agreed that tunnel mode 
>was okay, 
>> >given that you need it elsewhere anyway.
>
>this was dicussed between some of us. it was felt that 
>specifying too many different options is very confusing. even 
>now the ha-mn-ipsec draft is already 45 pages.
>
>but there is nothing in the spec which prohibits tunnel
>mode IPsec between MN and HA. it is still possible to
>use tunnel mode IPsec. the spec only says that packet 
>formats in section 2 MUST be supported.
>
>Vijay
>

---

From: Francis Dupont <[email-masked]>
Date: Thu, 30 Jan 2003 10:32:07 +0100

=> the tunnel mode has not to be permitted because it is not forbidden...
I interpret your concern as the context where the MUST applies should
be clearer (i.e., as usual the wording is not clear enough)?

Regards

[email-masked]

PS: there is an explicit agrement between the authors to restrict
the main text to the options which "MUST be supported".