Subject: RE: [mobile-ip] MIPv6 and multiple interfaces

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 23 Jan 2003 14:54:58 +0100

A draft mentionned those multi-interfaces issues.

http://www.ietf.org/internet-drafts/draft-montavont-mobileip-mmi-00.txt

It may help you.

Luc

> -----Message d'origine-----
> De : Miguel Angel Díaz [mailto:[email-masked]]
> Envoyé : jeudi 23 janvier 2003 10:50
> À : [email-masked]; [email-masked]
> Objet : Re: [mobile-ip] MIPv6 and multiple interfaces
> 
> 
> Hi Mauro,
> 
> if you are using the "Dynamic Home Agent Address Discovery Mechanism"
> described in the draft, you should not have problem to 
> contact with the HA,
> even if you have your first interface (eth1) down. MN will 
> try to reach HA
> sending first DHAAD packets using eth2 and then when it knows the HA's
> address it will send the BU to the HA.
> 
> Why don't you try this?
> 
> Miguel A. Díaz
> 
> 
> ----- Original Message -----
> From: "Mauro Cerboni" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, January 22, 2003 6:34 PM
> Subject: [mobile-ip] MIPv6 and multiple interfaces
> 
> 
> > I'm trying to figure out how to use MIPv6 on a Mobile Node 
> with multiple
> interfaces (if possible).
> > At the beginning I have eth1 in Home Network, eth2 down and I open a
> connection to a Correspondent Node. Then I put eth2 up 
> (associated in the
> Visited Network) and eth1 down. Eth2 correctly forms its 
> stateless CoA, but
> it doesn't seem to send any BU.
> > Anyone knows why this is not currently happening?
> > I suppose this is because MIPv6 doesn't support multiple 
> interfaces; in
> this case does anyone knows if there is a kind of patch 
> supporting this?
> >
> > Thanks in advance for your support,
> >
> > Mauro Cerboni
> >
> >
> 
> *********************************
> Madrid 2003 Global IPv6 Summit
> 12-14 May 2003 - Pre-register at:
> http://www.ipv6-es.com
> Interested in participating or sponsoring ?
> Contact us at [email-masked]
> 
> 
>

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Thu, 23 Jan 2003 16:25:34 +0100

Hello Luc,

Yes, this draft explians redirecting flows between different interfaces simultaneously.
But, I would like to know how it can support following scenario.

Assume, MN is having two interfaces & two different home IP addresses(hoa1 & hoa2). MN starts communication
with CN-X & CN-Y when only interface 1 is active and having a CoA1. (i.e HA1 keeps a BU for hoa1 & CoA1). No route 
optinmisation with both CN-X & Y

 	 CN-Y
	 CN-X -----  hoa1--MN--hoa2
	 		 CoA1)     (CoA2)

Let's take following example.

Once MN's interface 2 is also active and HA2 keeps a BU for hoa2 & CoA2.
Now, MN decides to forward only CN-X traffic to interface 2, while receiving CN-Y traffic over interface1. 

As I understood from the above draft, MN should send BU to HA1 with CoA2 to redirect flows to interface 2.
But, this causes to redirect all flows to interface 2 as MIPv6 draft says only one BU can keep for one home address (i.e at HA1, 'hoa1& CoA1' binding
is replaced by 'hoa1 & CoA2' - no simulataneous binding is possible)

Thanks in advance

Regards
Koojana

-----Ursprüngliche Nachricht-----
Von: [email-masked]
[mailto:[email-masked]]Im Auftrag von BELOEIL Luc
FTRD/DMI/CAE
Gesendet: Donnerstag, 23. Januar 2003 14:55
An: Miguel Angel Díaz; [email-masked]
Cc: [email-masked]
Betreff: RE: [mobile-ip] MIPv6 and multiple interfaces

It may help you.

Luc
 
> Miguel A. D az

---

From: montavont <[email-masked]>
Date: Thu, 23 Jan 2003 18:00:53 +0100

Hi Koojana,

MMI draft aims to bring basic solution to manage multiple interfaces 
inside a MN.
In the scenario you describe,  once the MN has registered the CoA2 with 
HA1, all packets intended to hoa1 will be forwarded to CoA2 (on 
interface 2). Therefore if CNy sends packets to hoa1, the packets will 
be redirected to CoA2 on if2.

Currently, we are writing a new version to add new functionnalities such 
as the HA filtering to differentiate CNs and to distonguish flows. These 
extensions will allow the HA to register a binding per CN or per flow.

Regards,
Nicolas Montavont