Subject: Re: [mobile-ip] Mipv6 issue #179: Prefix distribution and DHAAD problems

From: Erik Nordmark <[email-masked]>
Date: Wed, 22 Jan 2003 22:10:30 +0100 (CET)

> I see your problem, but do you have a suggestion on what to do? As I
> see it, we have the following options:
> 
> - Do nothing. There will about one additional BU per mobile node per
>    expiring prefix so its not too much. The trouble is, from the HA's
>    point of view they all arrive at the same time.
> 
> - If the prefix expiration is imminent, go to S=1 to avoid trouble
>    for the more stable prefixes.
> 
> - Do not reduce binding lifetimes based on very short prefix lifetimes.
> 
> - Something else, what?

[Perhaps this has already been settled - I'm behind on mail]

I think the important thing is that the MN is aware of the prefix
lifetimes - not necessarily that the binding lifetime is limited to not
exceed the prefix lifetime(s). Limiting the binding lifetime might be viewed as
an efficient way to communicate a tiny bit of information about the prefix
lifetime(s). But if this is causing problems, perhaps it is better to
explicitly carry the valid and preferred lifetimes of the prefix in the BA.
(Could be done with an option, so that they only need to be carried when
the prefix is deprecated or the preferred lifetime is less than the binding
lifetime.)
In this case there is no communication necessary when a prefix becomes
deprecated - the MNs using the HA already know the time the prefix will
become deprecated.

This is easy when each BU/BA is for a single address, and I'm not up to speed
on what the WG decided regarding the S-bit.
(The only way I see that the S=0 can provide sufficient information
to the MN is if the BA contains all the HOAs that were registered on the HA.
If that is done one could also include the lifetime option per such address.)

I think the MN needs to know which of its multiple HOAs are preferred vs. 
deprecated so that it can avoid choosing the deprecated ones as source
addresses for new communication (while continuing to accept packets for the
deprecated HOA). I'm not certain the MN can tell this from the existing
scheme, unless MPS/MPA are mandatory to do "all the time".

  Erik

---

From: Jari Arkko <[email-masked]>
Date: Sat, 25 Jan 2003 01:15:49 +0200

> [Perhaps this has already been settled - I'm behind on mail]

I think the original problem disappeared since we decided
to remove the S=0 registrations.

Jari

---

From: Erik Nordmark <[email-masked]>
Date: Sat, 25 Jan 2003 07:31:16 +0100 (CET)

> to remove the S=0 registrations.

I haven't parsed all of -20 yet so there is one part I'm not sure about.
But most of the issue has gone away by remove s=20 registrations.

It is mandatory for the MN to use MPS/MPA to discover the preferred and
valid lifetime for its home addresses?

If not the MN will have no idea why the BA's have such a short lifetime
and the MN will continue to sending BUs to the HA to try to extend
the binding lifetime as the prefix lifetime drops to zero.
(when the valid lifetime goes towards zero)

And without the MN knowing the preferred lifetime it can't do the
right source address selection while away from home.

   Erik

---

From: Jari Arkko <[email-masked]>
Date: Sun, 26 Jan 2003 08:51:29 +0200

> (when the valid lifetime goes towards zero)

Yes. I think I understand the issue now.

The crucial question is if the mobile node knows what's going
on, or if it stubbornly tries to extend the binding "well before
the binding expires" as required in Section 11.7.1.

Currently, Section 10.3.1 allows the home agent to shrink the
lifetime per local policy, without restrictions. So a mobile
node who sends in a lifetime=3600s registration has no way
of knowing if the returned lifetime=10s is due to the prefix
lifetime or due to local policy. Unless it does prefix discovery,
of course.

I think there is an issue. How should we solve it? I'd like
to avoid mandatory prefix discovery, if at all possible.

(1) We could add a requirement for the home agent to not shrink
the lifetime beyond certain limits just based on policy, and
then require mobile nodes not try to renew registrations
if the home agent set the lifetime very small. If this rule
is "never renew again", then I fear we might get into a
problem if for some reason the prefix lifetimes drop very
short in the home network for a while and then return; the
mobile node's use of the home address is effectively disabled
as a result. If the rules "don't renew until expired" then
we still have many mobile nodes contacting the home agent
at the same time, even if we avoid the ever shortening
lifetimes and attempts to reregister just before the
expiration.

(2) We could have the home agent provide an indication
in the BA that the prefix is gone after the lifetime
is over. Trouble is, how does the home agent know this?

(3) Ignore the issue. So, if prefix distribution is not
used then mobile nodes will be causing unnecessary traffic
for expiring prefixes. But how important is this compared
to an other effect of the prefix change: mobile nodes that don't
use prefix distribution will be unable to take in use the
new prefixes, and will likely be unable to communicate at all.
It seems that the possibility of changing prefixes in the
home network leads to the necessity to use prefix distribution
in any case.

(4) Something else, what?

Jari

---

From: Jari Arkko <[email-masked]>
Date: Sun, 26 Jan 2003 08:51:29 +0200

Jari