Subject: RE: [mobile-ip] Mipv6 issue #241: Editorial issue 10)

From: Pekka Savola <[email-masked]>
Date: Wed, 19 Feb 2003 19:11:38 +0200 (EET)

On Wed, 19 Feb 2003, Hesham Soliman (EAB) wrote:
>  > > > ==> one thing that may have to be considered is, when MN 
>  > moves on to a new
>  > > > link, or detects it's also on range of a different link, 
>  > should it 
>  > > > re-perform
>  > > > DAD for _already existing_ addresses?  If so, on which 
>  > addresses (probably
>  > > > link link-locals/site-locals would be enough).
>  > > > This is a new situation brought by movement.
>  > > 
>  > > Since it is assumed that the mobile node is running IPv6, 
>  > it is also
>  > > assumed that it follows the rules for address 
>  > configuration that are
>  > > part of the IPv6 specification.  That already includes link-local
>  > > address configuration and so on.  It would be unwise to repeat
>  > > those parts of the IPv6 specification again within the Mobile IPv6
>  > > specification.
>  > 
>  > I'm not sure if I didn't elaborate the point enough.
>  > 
>  > The _problem_ (which is IMO more than just an editorial 
>  > issue), is the 
>  > fundamental change of stationary/mobile nodes.
>  > 
>  > Stationary node makes DAD once, when it is booted up in a 
>  > network.  No 
>  > duplicates there.
>  > 
>  > Mobile node could visit 1000 networks in a day using the 
>  > same link-local
>  > address.  There might be a clash in even one of them.  Does 
>  > this change in
>  > model have to be taken into consideration?  IMO, it needs to 
>  > be at least
>  > described somewhere (security considerations, if there is no better
>  > location -- easy way to DoS MN's in local networks!), if not 
>  > "solved" by
>  > specifying that DAD must be run every time a node detects 
>  > it's on a new
>  > link.
> 
> => Makes sense to say that the MN will need to do DAD
> on its link-local address every time it moves 
> somewhere in the spec. The security considerations section
> is the wrong place to say it IMO. There are no security
> issues here specific to MIPv6 as far as I can see. 

I don't think SecCons is best place either, but better than none.

Availability is part of security, and if your DAD clashes (intentionally 
or due to someone figuring out your link-local address from e.g. global 
address's last 64 bits, and anticipates the link where you're moving next) 
it's not nice..
 
> The issues you mention above are relevant to stationary 
> nodes as well.

Totally agree, but stationary nodes do not by definition move that often 
from network to another -- and even, typically when they do, they're 
phyically moved, which implies a new DAD.

On the other hand, MN's (in about all cases I can think of) _do_ move, and
particularly without being shut down -- otherwise regular mobility with
new stateless config'd addresses without MIPv6 would be sufficient.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 19 Feb 2003 18:05:39 +0100

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Thu, 20 Feb 2003 00:33:29 +0200

>>issues here specific to MIPv6 as far as I can see. 

Remember that not all things that may happen to mobile
nodes need to be described in our specification -- some
could be discussed in ND specifications, for instance.
And as you know, DAD failures are being addressed in SEND.

Anyways, we have recently added Section B.6 that mentions
some of these things. I think it says what we need to say:

http://www.piuha.net/~jarkko/publications/mipv6/drafts/mobilev6.html#future:nd

Jari

---

From: Pekka Savola <[email-masked]>
Date: Thu, 20 Feb 2003 00:54:45 +0200 (EET)

> http://www.piuha.net/~jarkko/publications/mipv6/drafts/mobilev6.html#future:nd

I think this is missing one particularly important issue, which IMO must 
be explicitly maintained.

That is, the possible clash of the link-local address (probably 
EUI64-based) on links where the mobile node is moving.

Clashes with Care-of and home addresses are a different thing (and in some
cases, derive from the same problem: if a node has done DAD for it's LL
address, and global address is derived from that, no redoing DAD is
necessary for the rest)