Subject: Re: Which Router Address to use for FMIP signaling (was:Re: [mobile-ip] Fast Handover document revision)

From: "James Kempf" <[email-masked]>
Date: Wed, 19 Feb 2003 09:26:12 -0800

> => possible. On a more philosophical note though, I'd really
> like to see FMIPv6 being self contained as much as possible.
> Relying on other standards that may or may not exist or get
> deployed in some scenarios (e.g. AAA or CT) can impede the
> adoption of this work by operators/vendors.
>

I would phrase the issue somewhat differently. I think the IETF needs to make
sure that the protocols required for implementing the local link handover are
designed so that they provide complementary functions and interoperate properly.
Protocol reusability is considered an important point, and is listed in RFC 1958
as an important architectural consideration. Consider if people had to reinvent
TCP all the time. I think trying to enforce arbitrary design distinctions based
on where particular design activity is currently ongoing is liable to lead to a
system that is not well designed, with duplication of function. I would rather
recommend that the design activity be moved than that the protocols be designed
to fit where the activity is taking place.

            jak

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 19 Feb 2003 18:11:42 +0100

> > => Hmm. We would need to make sure this is secure right?
 > > I haven't seen yet (apart from using RR) a mechanism
 > > that can secure communication between a host and an anycast
 > > group.
 > >
 > 
 > Yes, the security problem doesn't go away. But moving it 
 > away from handover
 > decreases the time constraint. 

=> Well, this security problem is quite unique though (anycast).
It adds an additional burden. 

One can either use SEND 
 > mechanisms (to be
 > published shortly) to do preauthentication or AAA/CT to push 
 > the security
 > context to the new router. 

I'm not sure, however, whether 
 > IPsec applies to
 > anycast addresses. Any IPsec experts know?

=> IPsec works fine for unicast addresses. The use 
of IPsec and anycast is not defined anywhere.

Hesham

 > 
 > Of course, there is the same issue here as with reserving a 
 > new care of address
 > in the new subnet in advance of handover: how to control 
 > reserving resources on
 > the new router and when to drop them.
 > 
 >             jak
 > 
 > 
 >