Subject: [mobile-ip] Sending HOT without route optimization: note or requirement?

From: "Bryan Wang" <[email-masked]>
Date: Thu, 27 Feb 2003 14:21:54 -0800

Hi,

"9.4.3 Sending Home Test Messages
.... Note that the Home Test message is always sent to the home address of
the mobile node , even when there is an existing binding for the mobile
node. "

Shouldn't this be a hard requirement? instead of a "note" ;-)

Thanks,
Bryan

---

From: Jari Arkko <[email-masked]>
Date: Fri, 28 Feb 2003 08:47:56 +0200

> Shouldn't this be a hard requirement? instead of a "note" ;-)

Well, Section 5 talks about sending this message via the home agent
so that might be sufficient. But I can change the above to a "MUST be
sent" so its 100% clear.

Jari

---

From: "Ed Remmell" <[email-masked]>
Date: Fri, 28 Feb 2003 07:53:52 -0800

Jari -

Yes, I agree with Bryan, we need a hard requirement for this somewhere
(otherwise, a future implementor who isn't as familiar with the design might
get it wrong). Please word it such that it makes it clear that route
optimization MUST NOT be used in this case. For example:

"The CN MUST NOT use route optimization when sending a Home Test message."

Thanks.
- Ed Remmell
Elmic Systems, USA

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jari Arkko
> Sent: Thursday, February 27, 2003 10:48 PM
> To: Bryan Wang
> Cc: Mobile IP Working Group
> Subject: Re: [mobile-ip] Sending HOT without route optimization: note or
> requirement?
>
>
> Bryan Wang wrote:
> > Hi,
> >