Subject: [mobile-ip] MIPv6 v20 question re L bit

From: "Greg O'Shea" <[email-masked]>
Date: Fri, 31 Jan 2003 20:37:42 -0000

I can't see any way of automating selection of L bit or writing
reasonable instructions for users who want to set HoA manually. Aside
from the multi-homed issue a user might swap PCMCIA or CF adapters,
yielding different IFIDs, and yet wish to keep the same HoA e.g. because
IPSec is keyed on on HoA. (Maybe that's a good reason for *not* choosing
a stateless config addr as your HoA.)
 
But I can't see that v20 says anything about *not* setting L apart from
the RFC3041 provision (whose "MUST" strikes me as unecessarily harsh).
Therefore one possible tactic might be to set L bit on *all* home
bindings. 
 
Is that legit, or a swamp?
 
Greg
-----Original Message-----
From: Greg O'Shea [mailto:[email-masked]] 
Sent: 11 December 2002 17:08
To: Mobile IPv6 mailling list
Subject: [mobile-ip] MIPv6 question re L bit

         The Link-Local Address Compatibility (L) bit is set when the 
         home address reported by the mobile node has the same interface

         identifier (IID) as the mobile node's link-local address. 

What I fail to follow is that a multi-homed mobile node may have
*several* interfaces, as in more than one, each capable of connecting to
the home net with a different EUI64 LL addr on each.

Presumably then the MN could need to register one HoA for each interface
whose LLA it wants protecting; but then when Ifa is attached to the home
net and Ifb isn't then the HoA for Ifb would nevertheless be "at home"
and so the MN would deregister the Ifb HoA and the HA would stop
defending the LLA for Ifb and someone else could grab the LLA for Ifb
before Ifb attaches to the home net. Or did I miss something?

Apparently L=1 is **mandatory** if S=0, so presumably someone must care
deeply about this [11.7.1]

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 31 Jan 2003 14:32:04 -0800

Ed Remmell wrote:
> 
> Of course, there is the other alternative that Pascal Thubert suggested,
> specifically doing DAD on the MN's home address to resolve the link-layer
> address of the HA defending the home address. That appears increasingly more
> attractive ;-)
> 

I agree with the last part. this is what I has suggested 
to a bunch of folks off the list.

> 
> I had this long discussion with Nicolas Delest. I think we
> like Pascal's suggestion of the MN doing DAD for its own
> address.
> 
> 1. MN realizes it is home (by receiving a router advert
>    with the home prefix)
> 2. it sends a DAD probe with source set to unspecified
>    address and the target set to HoA. Note: this is the
>    natural behaviour. whenever the MN receives a router 
>    advertisement advertising a new prefix, it configures 
>    an address and does DAD for that address.
> 3. the HA responds with a neighbor advertisement.
> 4. the MN gets hold of HA's MAC address
> 5. the MN sends a deregistration BU.
> 
> ofcourse there is one small hack in the above. the MN
> instead of considering the neighbor advertisement from
> the HA as a DAD failure, it considers it a DAD success
> and proceeds to send a deregistration BU. but IMO, this
> is not a big deal. it is a DAD success because, the HA
> was defending it so far and now the MN can take over.
> (Nicolas convinced me on this).

Note: steps 2, 3 and 4 are skipped if the router 
advertisement was sent by the HA which currently has 
binding cache entries for the MN.

> 
> if the HA were not defending MN's home address (because
> the MN was shut off before coming home), then
> 
> 1. MN realizes it is home
> 2. MN looks at its binding update list and knows that
>    the binding at the HA has expired.
> 3. does DAD for the home address.
> 4. if DAD succeeds everything is fine. if it fails, 
>    then someone on the home link has configured its 
>    address.
> 
> we concluded that there is no need for BED (and therefore
> no need for a new ICMP code).
> 

I think the above is sufficient. This also solves the 
issue raised by Greg in another email with subject 
"MIPv6 v20 Question re returning home NA hack".

Vijay