Subject: RE: [mobile-ip] Fast Handover document revision

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 19 Feb 2003 01:40:37 +0100

> >  > Two comments are here:
 > >  > 1) There is no statement in ND that prohibit expose the
 > >  > global IP address of
 > >  > routers.
 > >  > 2) Alper's reference is only appliable for home agents, not
 > >  > for all access
 > >  > routers.
 > >
 > > => Claim 2) is incorrect. Any AR can include its global
 > > address in the prefix option. See section 7.2 in the MIPv6
 > > spec.
 > >
 > 
 > In Mobile IPv6 draft, section 7.2
 > "In a Router Advertisement, a home agent MUST, and all other routers
 >  MAY, include at least one Prefix Information option with the Router
 >  Address (R) bit set"
 > Any AR MAY  include its global address in the prefix option, 
 > but not MUST.
 > For FMIPv6, MAY is not enough, and stronger requirement is 
 > necessary (SHOULD
 > or MUST).

=> MAY does not mean they can't do it! 
I think that there is a merit is asking for a stronger word
but I certainly don't think your conclusion in 2) above 
is correct. 

Hesham

---

From: "Xiaoming Wang" <[email-masked]>
Date: Wed, 19 Feb 2003 09:58:59 +0900

> -----Original Message-----
> From: Hesham Soliman (EAB) [mailto:[email-masked]]
> Sent: Wednesday, February 19, 2003 09:41
> To: 'Xiaoming Wang'; Alper Yegin; James Kempf; Woojune Kim;
> Rajeev Koodli; [email-masked]
> Subject: RE: [mobile-ip] Fast Handover document revision
>
>
>
>  > >  > Two comments are here:

Maybe my comment is not so clear. I'm sorry for that.

Actually in alper's email it was said that:
"how the global IPv6 address of the home agent
can be conveyed using router advertisements.
So, the required feature is already there."

From my point of view, the required feature is not already for all access
routers since this is not a MUST or SHOULD requirement. For FMIP, it's not
enough and cannot be depend on.
That's why I made the conclusion in 2).

xiaoming