Subject: [mobile-ip] Mipv6 issue #248: The L bit

From: Jari Arkko <[email-masked]>
Date: Fri, 14 Feb 2003 16:35:10 +0200

It seems that most people wanted to at least make sure that
the semantics of L=0 are clear in that the home agent will
not be able to defend the link-local version. If it did,
a mobile node that used L=0 could still get a DAD failure
when using its link-local address on the home link.

I think we can make this clear by having the following
item in 10.3.1 (home agent's procedures for processing binding
updates):

"     o  L=0:  Defend only the given address. Do not derive
          a link-local address.
"

We also discussed whether keeping the L bit makes sense after
the other modifications to the specification. I still think it
makes sense, because of the possibility of nodes who optimize
DAD by checking just the link-local address. The L bit allows us
to avoid this case.

As for the potential DAD misses with RFC 3041 -- I agree, that
RFC also appears to optimize DAD by skipping some of the tests.
But I fear there's little we can do about this in Mobile IPv6.
Let's leave that for IPv6.

Jari

---

From: "Ed Remmell" <[email-masked]>
Date: Fri, 14 Feb 2003 08:51:16 -0800

Jari -

Yes, I'm in complete agreement with all of this, thank you for paying
attention to my concerns w/ regards to the L bit.

Thanks.
- Ed Remmell
Elmic Systems, USA
http://www.elmic.com

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jari Arkko
> Sent: Friday, February 14, 2003 6:35 AM
> To: Ed Remmell; Vijay Devarapalli; Greg O'Shea
> Cc: [email-masked]'
> Subject: [mobile-ip] Mipv6 issue #248: The L bit
>
>