Subject: Re: [mobile-ip] MIPv6 v20 rate limit severe for multiple bindings

From: Jari Arkko <[email-masked]>
Date: Tue, 04 Feb 2003 16:49:47 +0200

Greg O'Shea wrote:
> The mobile node MUST NOT send Mobility Header messages of a particular 
> type to a particular correspondent node more than MAX_UPDATE_RATE times 
> within a second.
> 
> So a MN with #n > 3 bindings at CN (e.g. using multiple HoA) must 
> prolong handoff over n/3 seconds just to transmit its BUs. Not great.

I agree that this is a problem. However, we have previously
decided to move functionality related to efficient handling of
multiple home addresses out of the draft. So I wonder if it
would be better to leave the rate limitation as is, and deal
with a more efficient treatment of multiple home addresses
in another document when we get to that point.

We could also try to either remove the rate limitation, or
fix it so that it behaves better. However, I fear that
the first option could create unexpected congestion when
someone happens to configure a large number of home addresses.
As engineers, the second option may sound attractive to us, but
maybe we should resist the temptation -- I'm pretty sure
we can't make the *whole* problem go away by just improving
the rate at which BUs can be sent. We still have to send
multiple packets, for instance. I'd rather not have the
publication of the document be pending on the optimizations
for mobile nodes that have a large number of home addresses.

One thing we could do perhaps is to change the value
of MAX_UPDATE_RATE to a slightly higher value if this
presents a practical problem for planned deployments.

What do you think?

Jari

---

From: "Greg O'Shea" <[email-masked]>
Date: Tue, 4 Feb 2003 18:39:18 -0000

I'm not too worried by this one - it's just a bit clumsy. I keep finding
these things while working on an implementation so I figure I might as
well notify them to the list.

>-----Original Message-----
>From: Jari Arkko [mailto:[email-masked]] 
>Sent: 04 February 2003 14:50
>To: Greg O'Shea
>Cc: [email-masked]
>Subject: Re: [mobile-ip] MIPv6 v20 rate limit severe for 
>multiple bindings
>
>
>Greg O'Shea wrote:
>with a more efficient treatment of multiple home addresses in 
>another document when we get to that point.
>
>As engineers, the second option may sound attractive to us, 
>but maybe we should resist the temptation -- I'm pretty sure