Subject: Re: [mobile-ip] Mipv6 issue #245: prefix fetching intervals

From: "Sourajeet Mohanty" <[email-masked]>
Date: Mon, 24 Feb 2003 12:27:45 +0530

Do we need to retransmit those periodic MPAs to MN untill it acknowledged
by MN with MPS ?
And does it follow the same retransmission rules as other unsolicited MPAs
?

Sourajeet

----------------------------------------------------------------
Sourajeet Mohanty
Software Engineer
Communications and Embedded Systems
L&T Infotech Ltd., Bangalore
-----------------------------------------------------------------

                      Jari Arkko                                                                           
                      <jari.arkko@kolum        To:       Sourajeet Mohanty                                 
                      bus.fi>                   <[email-masked]>                        
                                               cc:       "[email-masked]'"                 
                      19/02/2003 06:06          <[email-masked]>,                           
                      PM                        [email-masked], "T.J. Kniveton"       
                                                <[email-masked]>, Ville Nuorvala               
                                                <[email-masked]>                             
                                               Subject:  Re: [mobile-ip] Mipv6 issue #245: prefix fetching 
                                                intervals                                                  

Sourajeet Mohanty wrote:
>
>     o  If the mobile node has not received the prefix information within
>        the last MaxMobPfxAdvInterval (see Section 13) seconds, then
>        ensure that a transmission is scheduled. The actual transmission
>        time is randomized as described below.
>
> Does this mean that Home Agent has to start sending unsolicited MPAs
> periodically at every MaxMobPfxAdvInterval to the Mobile Node after
> successful registration with Home Agent ?

We changed the formulation of this bullet item a bit. But essentially
the answer is yes -- thought there's some randomness involved in the
time period. Note that MaxMobPfxAdvInterval is a variable i.e. it
can be set by system management to another value.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Mon, 24 Feb 2003 10:20:40 +0200

> Do we need to retransmit those periodic MPAs to MN untill it acknowledged

I think so, the BA status code does not guarantee delivery
of e.g. new prefix information.

> And does it follow the same retransmission rules as other unsolicited MPAs

Not sure I understand the question. There's just one type of unsolicited
MPAs, and their retransmission rules are outlined in Section 10.6.2.
Solicited MPAs are not retransmitted by the home agent, there the
mobile node is responsible for retransmitting the MPS if it doesn
get an answer.

Jari