Subject: RE: [mobile-ip] Mipv6 issue #241: Editorial issue 10)

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 20 Feb 2003 00:12:12 +0100

> >>=> Makes sense to say that the MN will need to do DAD
 > >>on its link-local address every time it moves 
 > >>somewhere in the spec. The security considerations section
 > >>is the wrong place to say it IMO. There are no security
 > >>issues here specific to MIPv6 as far as I can see. 
 > 
 > Remember that not all things that may happen to mobile
 > nodes need to be described in our specification -- some
 > could be discussed in ND specifications, for instance.
 > And as you know, DAD failures are being addressed in SEND.

=> But these are not send issues, it's just a good ol' 
address collision (rare) of link local addresses.
The CoA collisions are taken care-of with DAD. The HoA
collision should not happen (or persist anyway) unless
there is some sort of DoS attacks. So these are different
problems.

 > 
 > Anyways, we have recently added Section B.6 that mentions
 > some of these things. I think it says what we need to say:
 > 
 > http://www.piuha.net/~jarkko/publications/mipv6/drafts/mobile
v6.html#future:nd

=> Yep. That's fine, but it does not address the issue
above. I think all it needs is a couple of lines in the 
spec (i.e. we do not need to talk about ND attacks).

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Thu, 20 Feb 2003 01:26:44 +0200

Pekka, Hesham -- I added the link-local part in B.6. Let
me know if this is OK or if something more is needed. Or
better yet, please send text ;-)

New B.6:

Future specifications may improve the efficiency of Neighbor Discovery
tasks, which could be helpful for fast movements. One factor which is
currently being looked at is the delays caused by the Duplicate
Address Detection mechanism. Currently, Duplicate Address Detection
needs to be performed for every new care-of address as the mobile node
moves, and for the mobile node's link-local address on every new
link. Improvements in this area are, however, generally applicable and
progressed independently from Mobile IPv6 specification.

Future functional improvements may also be relevant for Mobile IPv6
and other applications. For instance, mechanisms that would allow
recovery from a Duplicate Address Detection collision would be useful
for link-local, care-of, and home addresses.

---

From: Pekka Savola <[email-masked]>
Date: Thu, 20 Feb 2003 09:06:34 +0200 (EET)

> for link-local, care-of, and home addresses.

I can live with this, but I suggest adding a last paragraph, like:

In particular, the need and the tradeoffs of re-performing Duplicate
Address Detection for the link-local address every time when the mobile
node moves on to new links will need to be examined.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings