Subject: Re: [mobile-ip] need of clarification in draft 20 concerning Neighbor discovery Proxying ?

From: Jari Arkko <[email-masked]>
Date: Mon, 03 Feb 2003 21:42:59 +0200

Frederic Roudaut writes:

> Does it mean that in the Neighbor advertisement you have to use the
> Mobile Node's address as source address ?

Francis Dupont writes:

> no, it must be a home agent address.

Frederic Roudaut writes:

> I agree with you but consider the following extract of draft 20 (10.4.1): 
> 
> "All fields in each such Neighbor Advertisement message SHOULD be set
> in the same way they would be set by the mobile node itself if
> sending this Neighbor Advertisement [12] while at home, with the
> following exceptions: ... "
> 
> The source address doesn't appear in the exception list.
> So if the source address should be set AS IF it was the mobile node itself who
> sends the Neighbor advertisement (and according to the RFC 2461 4.4) the source
> address should be the MN's address. As a consequent I think that it MUST appear
> in the exceptions list or otherwise a few people will still be confused.

Yes. A new bullet:

   o  The Source Address in the IPv6 header MUST be set
      to an IP address belonging to the home agent.

Jari

---

From: Francis Dupont <[email-masked]>
Date: Tue, 04 Feb 2003 10:35:07 +0100

> no, it must be a home agent address.
   
   ...

   Yes. A new bullet:

=> in fact, the requirement is a bit stronger: the IP address must
belong to the interface of the home agent which is used to sent
the neighbor advertisement.

Thanks

[email-masked]

---

From: Jari Arkko <[email-masked]>
Date: Tue, 04 Feb 2003 12:44:36 +0200

> the neighbor advertisement.

Yes. Add "This address MUST also be assigned to the interface from which
the advertisement is sent."

Jari