Subject: RE: [mobile-ip] Fast Handover document revision

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 18 Feb 2003 09:46:12 +0100

> Two comments are here:
 > 1) There is no statement in ND that prohibit expose the 
 > global IP address of
 > routers.
 > 2) Alper's reference is only appliable for home agents, not 
 > for all access
 > routers.

=> Claim 2) is incorrect. Any AR can include its global
address in the prefix option. See section 7.2 in the MIPv6
spec.

Hesham

---

From: "Xiaoming Wang" <[email-masked]>
Date: Wed, 19 Feb 2003 09:10:33 +0900

> address in the prefix option. See section 7.2 in the MIPv6

In Mobile IPv6 draft, section 7.2
"In a Router Advertisement, a home agent MUST, and all other routers
 MAY, include at least one Prefix Information option with the Router
 Address (R) bit set"
Any AR MAY  include its global address in the prefix option, but not MUST.
For FMIPv6, MAY is not enough, and stronger requirement is necessary (SHOULD
or MUST).