Subject: RE: [mobile-ip] Text for #236: Appliances that don't have config knobs

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 13 Feb 2003 21:54:32 +0100

>  > 5) something about upper-case keywords..
 >  >
 >  >    o  The node MUST allow route optimization to be 
 > administratively
 >  >       enabled or disabled.  The default SHOULD be enabled.
 >  >
 >  > is MUST a bit strong (e.g. consider appliances that may 
 > not have any
 >  > config knobs).  Perhaps a reword: "If node defaults to 
 > enabling route
 >  > optimization, there MUST be a way to administratively 
 > disable it", though
 >  > I'm not sure if that's optimal either.
 > 
 > I agree that we should not force configuration interfaces for all
 > nodes. We can fulfil your request for some of the other cases
 > in the document, but I think this one is kind of special.
 > 
 > This requirement comes from a section which is for nodes that wish to
 > support RO. Assuming we do not want to have nodes that support RO and
 > who are unable to turn it off, this is about the best we can 
 > do at the
 > moment. For instance, in your suggestion, if the node 
 > defaults to RO being
 > disabled, it must have a configuration interface or otherwise RO is
 > just dead code.
 > 
 > (Nodes that don't want a configuration interface should not do RO.)

=> It is tricky to mandate either way. Why do we need 
to mandate anything about RO? I think it is enough to mention
the pros and cons and leave the decision to implementors. 
The only cons I can think of is that RO might be too much 
trouble for short connections, e.g. web browsing. 

 > 
 >  >    o  Every IPv6 router SHOULD be able to send an 
 > Advertisement Interval
 >  >       option (Section 7.3) in each of its Router 
 > Advertisements [12], to
 >  >       aid movement detection by mobile nodes (as in 
 > Section 11.5.1).
 >  >       The use of this option in Router Advertisements MUST be
 >  >       configurable.
 >  >
 >  > as above, I personally like a MUST but it seems a bit 
 > strong, for _all_
 >  > routers..?
 > 
 > I agree, particularly when the requirement to send these options is
 > only a SHOULD. Let's change it to a SHOULD.

=> I'm neutral. Routers are configured anyway, I don't
see a problem.

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Fri, 14 Feb 2003 14:17:07 +0200

> trouble for short connections, e.g. web browsing. 

Hesham, this isn't about mandating RO itself. That decision
has already been made earlier, based on the pros and cons.
But if RO *is* implemented, then the particular requirement
that we are discussing talks about capability to *configure*
the feature so that its disabled... such as in the case that
RO is constantly being attacked by DoS and its causing more
trouble than its worth, a serious security problem is
found in RR and we wish to disable RO until a new version
arrives, or the user is just sending DNS queries from this
node, etc. We only require a configuration knob for this,
not mandate what the user or implementor must do with it.

> => I'm neutral. Routers are configured anyway, I don't

Yes, routers are configured anyway. This is not a burden
in that sense.

The funny thing was that while the capability to send fast
advertisements was only a SHOULD (i.e. not necessarily in
all IPv6 routers), the capability to configure this feature
was a MUST and in all IPv6 routers. This seems inconsistent.

Jari