Subject: RE: [mobile-ip] more IESG review comments available

From: [email-masked]
Date: Fri, 4 Apr 2003 09:42:52 -0600

> 
> Both for base and ha-ipsec:
> 
> http://www.piuha.net/~jarkko/publications/mipv6/issues/issue288.txt
> http://www.piuha.net/~jarkko/publications/mipv6/issues/issue287.txt
> 
> The first one includes e.g. site-local issue (should we now take
> away even the SHOULD NOT, given the IPv6 WG discussion/decision?).

Based on the consensus for site-local in the IPv6 WG I
think the site-local aspects in the base spec should be
deleted.

> Jari

Basavaraj

---

From: Pekka Savola <[email-masked]>
Date: Fri, 4 Apr 2003 20:13:57 +0300 (EEST)

> think the site-local aspects in the base spec should be

Note: the consensus is yet to be seen (and might lead to follow-ups, etc).

We should avoid a lot of text on site-locals, but ripping it out 
completely might be premature: assuming things go well, we might end up 
revising the spec in a year or two anyway.

But either way is ok with me.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 04 Apr 2003 09:20:39 -0800

Hello Basavaraj,

I also agree that site-locals should be deleted from
the base specification, if it is procedurally reasonable
to do so.

We did, after all, already complete working group Last
Call for the recent document.  Would such a change be
major enough to require another working group last call?

If yet another Last Call is required, then I would be
more comfortable with the base specification as is.

We really have to try avoid the requirement to hit every
moving target in sight.  I think that operationally there
is almost no danger that someone reading the specification
as it is would do the "wrong thing" on site-locals.

Regards,
Charlie P.

---

From: "Ed Remmell" <[email-masked]>
Date: Fri, 4 Apr 2003 10:14:53 -0800

IMHO, support for site locals has already been effectively removed, see:
http://www.piuha.net./~jarkko/publications/mipv6/issues/issue258.txt

It is in there currently as a HA requirement: site-local traffic "SHOULD NOT
be tunneled to the mobile node"
also as a MN requirement: "Therefore, site-local addresses SHOULD NOT be
used as home or care-of addresses."

The main change implemented in issue report #258 was to permanently close
the door on requiring any support in the HA for site-local tunneling - there
used to be a MUST in the spec that the HA MUST be configurable to enable
support for site-local tunneling, but this was removed from the spec.

So, just going through the spec and deleting all existing references to
site-local support does not change the intent of the current spec, IMHO
there is no need for another last call if these modifications are made.

Thanks.
- Ed Remmell
Elmic Systems, USA

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Charles E.
> Perkins
> Sent: Friday, April 04, 2003 9:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [mobile-ip] more IESG review comments available
>
>
> Hello Basavaraj,
>

---

From: Jari Arkko <[email-masked]>
Date: Sat, 05 Apr 2003 10:53:28 +0300

Re: site-locals. If the consensus hasn't been reached at IPv6 yet, perhaps
we should just keep the current text. It deals well with the either outcome
at the IPv6 side, and we can't keep the specification consistent with a
moving target. And the text devoted to this is already prety minimized
and has a big warning sign in it (SHOULD NOT).

Jari