Subject: [mobile-ip] Re: closing mipv6 issue #273 (cn becomes ha; ha becomes cn)

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 11 Apr 2003 16:53:11 -0700 (PDT)

> 
> Here's a proposal to close issue #273, what to do
> if CN becomes a HA or the other way around.

The following change looks good to me for CN->HA for the already
existing BCE. 

Should not we make similar restriction for HA->CN for the already
existing BCE ? 

-Samita

> The proposed text changes are:
> 
> Add a new status code in Section 6.1.8 (BA):
> 
>      139  Registration type change disallowed
> 
> Add the following to Section 9.5.1 (BU processing):
> 
>     If a binding already exists for the given home address, and the its
>     home registration flag has a different value than the Home
>     Registration (H) bit in the Binding Update, then the receiving node
>     MUST send back a Binding Acknowledgement with status code 139 
(registration
>     type change disallowed).
> 
> Also change the paragraph about the silent discard as follows:
> 
>     For packets carrying Binding Updates that fail to satisfy all of
>     these tests for any reason other than insufficiency of the Sequence
>     Number, registration type change, or expired nonce index values
>     MUST be silently discarded.
> 
> My understanding is that we don't need to change the mobile node
> section due to this. Mobile nodes have BULs and should not change the
> type of registration just like that.
>

---

From: Jari Arkko <[email-masked]>
Date: Sat, 12 Apr 2003 07:36:28 +0300

> Should not we make similar restriction for HA->CN for the already

Section 9.5.1 is referenced from the HA processing, so I think
that the text I sent out applies also for HAs.

Jari