Subject: [mobile-ip] Issue #283

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 21 Apr 2003 14:04:11 -0700

Hello Ed,

If a mobile node tries and retries but fails to get a
Binding Acknowledgement,  I think it has to assume that
the correspondent node does NOT have a binding.

If the correspondent node DOES have a binding anyway,
then the mobile node would get a RH type 2 packet from
the correspondent node instead of a tunneled packet,
so it could eventually tell the difference.

If the correspondent node has a binding, but never
sends any packets, then the mobile node cannot be
certain.  But these two unusual circumstances, taken 
in conjunction, seem to represent a very small proportion
of the cases, and the downside isn't so bad
after all.

I agree with you that the sentence could be omitted,
but I wish I could remember why it was put there.
It seems to me that the MAX_BINDACK_TIMEOUT parameter
ought to just mean what it says -- that after a while,
the procedure for trying to get an acknowledgement can
only be retried at a very slow rate.  Isn't this what's
covered in section 11.8?

Regards,
Charlie P.

---

From: "Ed Remmell" <[email-masked]>
Date: Mon, 21 Apr 2003 14:20:45 -0700

Charlie -

Well, if you don't know why that requirement is there, I certainly don't
;-)

Perhaps there was concern that the CN might have a good reason to ignore the
MN's BUs, even though the MN has set the (A) bit in the BU requesting an
acknowledgement; then, this requiremeent would be a way for the CN to
disable the MN's attempts to use RO with that specific CN, to shut up the MN
w/ regards to sending BUs? But, they are sent so infrequently at the slower
rate, I fail to see what the cause for concern is. Since wireless links are
lossy, I'd rather see the MN continue to try to retransmit BUs at the slower
rate. Also, I'm mainly concerned about avoiding extra and potentially
unnecessary complexity in my MN implementation.

Thanks.
- Ed

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Charles E.
> Perkins
> Sent: Monday, April 21, 2003 2:04 PM
> To: Ed Remmell
> Cc: Mobile IP Working Group
> Subject: [mobile-ip] Issue #283
>
>
> Hello Ed,
>

---

From: Jari Arkko <[email-masked]>
Date: Tue, 22 Apr 2003 13:35:03 +0300

I think the 11.8 text is sufficient. Let's remove the 11.7.2
SHOULD NOT requirement, particularly when it is at odds with 11.8.

Jari

---

From: "Ed Remmell" <[email-masked]>
Date: Tue, 22 Apr 2003 08:23:36 -0700

Jari -

Awesome. Thanks, that's exactly the change I wanted.

Thanks.
- Ed

> [mailto:[email-masked]]On Behalf Of Jari Arkko
> Sent: Tuesday, April 22, 2003 3:35 AM
> To: Ed Remmell
> Cc: Charles E. Perkins; Mobile IP Working Group
> Subject: Re: [mobile-ip] Issue #283
> 
>