Subject: [mobile-ip] question on authenticator

From: "Bryan Wang" <[email-masked]>
Date: Thu, 10 Apr 2003 16:58:49 -0700

Hi Folks,

In ID 21 and ID 20. There are three places talking about the data to be included in the authenticator computation, and one of them has to be corrected. 

Binding Update
      *  Parameters:
         +  HMAC_SHA1 (Kbm, (care-of address | CN address | BU))

Binding Acknowledgement
      *  Parameters:
         +  HMAC_SHA1 (Kbm, (care-of address | CN address | BA))

6.2.7 Binding Authorization Data
     Mobility Data = care-of address | final dest | Mobility Header Data
     Authenticator = First (96, HMAC_SHA1 (Kbm, Mobility Data))

Which one?

Thanks,
Bryan

---

From: Jari Arkko <[email-masked]>
Date: Fri, 11 Apr 2003 08:40:16 +0300

Bryan Wang wrote:

> In ID 21 and ID 20. There are three places talking about the data to be 
> included in the authenticator computation, and one of them has to be 
> corrected.
>  
> Binding Update
>       *  Parameters:

I have now aligned the formulas, as well as clarified that "final dest" is
the CN address, not the MN address (was unclear for BAs).

See http://www.piuha.net/~jarkko/publications/mipv6/drafts/mobilev6.html#rr-cnbind
     http://www.piuha.net/~jarkko/publications/mipv6/drafts/mobilev6.html#auth-option

Jari