Subject: [mobile-ip] draft-park-fasthandover-agent-fmipv6-00.txt

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 22 Apr 2003 10:14:44 +0900

Hi folks

We've submitted a draft as "Fast Handover Agent (FHA) for Fast Router
Discovery in FMIPv6". This approach does not require any modification of
existing FMIPv6 procedures and systems. 
Accordingly, the network operators might deploy the FHAs by their own
policies and associated environments.

I welcome your comments on this draft.
I'd like to know this draft is valuable enough to discuss as working
group draft. 

http://www.ietf.org/internet-drafts/draft-park-fasthandover-agent-fmipv6
-00.txt

Daniel (Soohong Daniel Park)
Mobile Platform Lab,SAMSUNG Electronics
Tel:+82-31-200-6347 Fax:+82-31-200-3147
mailto:[email-masked]

---

From: "Byung-Jin Lee" <[email-masked]>
Date: Thu, 24 Apr 2003 20:26:17 +0900

draft-park-fasthandover-agent-fmipv6-00.txtHi Diniel.

Your proposal reduces the time required for conf. of the new CoA and it gets the total handover time to reduce, doesn't it?
In Fig3. who sends the "unsolicited RA" message. It doesn't discribed clearly. The AP or FHA?
And, what is the differences between "unsolicited RA" and "Normal RA message"?
If an MN want to get the nCoA, only unsolicited RA message must be sent. (Normal RA message doesn't necessary.)

It can get the nCoA faster, but it doesn't makes the total handover time to short.
Fianlly, I don't know what are the functions of the FHA. What is the differences between FHA and wireless Gateway that is developed immedeately? Is the FHA L3 or L2 agent? 
 
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Soohong Daniel Park
  Sent: Tuesday, April 22, 2003 10:15 AM
  To: [email-masked]
  Subject: [mobile-ip] draft-park-fasthandover-agent-fmipv6-00.txt

  Hi folks 

  We've submitted a draft as "Fast Handover Agent (FHA) for Fast Router Discovery in FMIPv6". This approach does not require any modification of existing FMIPv6 procedures and systems. 

  Accordingly, the network operators might deploy the FHAs by their own policies and associated environments. 

  I welcome your comments on this draft. 
  I'd like to know this draft is valuable enough to discuss as working group draft. 

  http://www.ietf.org/internet-drafts/draft-park-fasthandover-agent-fmipv6-00.txt

---

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 25 Apr 2003 10:08:53 +0900

Hi Byung-jin
 
Please look into my inline response.
 
    Daniel

-----Original Message-----
From: Byung-Jin Lee [mailto:[email-masked]] 
Sent: Thursday, April 24, 2003 8:26 PM
To: Soohong Daniel Park
Cc: [email-masked]
Subject: RE: [mobile-ip] draft-park-fasthandover-agent-fmipv6-00.txt

Hi Diniel.
 
Your proposal reduces the time required for conf. of the new CoA and it
gets the total handover time to reduce, doesn't it? 
 
==>exactly.
 
In Fig3. who sends the "unsolicited RA" message. It doesn't discribed
clearly. The AP or FHA? 
 
==>FHA sends unsolicited RA periodically. AP can't send this message
without extra function into AP.
      
And, what is the differences between "unsolicited RA" and "Normal RA
message"?
If an MN want to get the nCoA, only unsolicited RA message must be sent.
(Normal RA message doesn't necessary.) 
 
==>FHA sends unsolicited RA periodically, however when MN is being
attached to another link,
   MN can recognize its moving and send RS messgae to access router and
wait normal RA.
   After receiving RA, MN should update its field such as address
lifetime, prefix lifetime and so on...
 
It can get the nCoA faster, but it doesn't makes the total handover time
to short. 
 
==> It is a kind of fasthandover that MN makes its own CoA faster.
 
Fianlly, I don't know what are the functions of the FHA. What is the
differences between FHA and wireless Gateway that is developed
immedeately? Is the FHA L3 or L2 agent?  
 
==>All of them.
   FHA can have all functions to provide fasthandover. Specific function
will be addressed.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Soohong Daniel
Park
Sent: Tuesday, April 22, 2003 10:15 AM
To: [email-masked]
Subject: [mobile-ip] draft-park-fasthandover-agent-fmipv6-00.txt

Hi folks 

<http://www.ietf.org/internet-drafts/draft-park-fasthandover-agent-fmipv
6-00.txt>
http://www.ietf.org/internet-drafts/draft-park-fasthandover-agent-fmipv6
-00.txt 

Daniel (Soohong Daniel Park) 
Mobile Platform Lab,SAMSUNG Electronics 
Tel:+82-31-200-6347 Fax:+82-31-200-3147 
 <mailto:[email-masked]> mailto:[email-masked]