Subject: [mobile-ip] Re: Mobile IPv4: MR/NAT, Proxy Mobile IP

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 2 Apr 2003 23:24:35 +0200

On Wed, 2 Apr 2003 12:30:43 -0800 (PST), Sami Vaarala <[email-masked]> wrote:
> Amin,
> 
> --- Amin Abdul <[email-masked]> wrote:
> > Hi,
> > 
> > I scan through the "draft-ietf-mobileip-nat-traversal-07.txt". My
> > feeling are this draft solve the MN (Host) problem not MR 
> > (Mobile Router) problem under NAT environment. Is it true or 
> > I am missing some thing.
> 
> You're right, the draft describes a solution for host mobility.
> Depending on the kind of mobile router scenario you are considering,
> this draft may or may not be helpful.

As Sami says, this draft is not aiming at solving the NAT problem for a
mobile router, only for mobile nodes and foreign agents. 

You might want to have a look at the draft
http://www.ietf.org/internet-drafts/draft-thubert-nemo-ipv4-traversal-00.txt
for an approach for mobile networks (i.e. mobile routers as discussed
within the nemo -- network mobility -- workgroup).

	With regards to proxy mobile IP, I'm not aware of any draft
covering this.

	Regards,
		Henrik

---

From: "Amin Abdul" <[email-masked]>
Date: Wed, 02 Apr 2003 14:02:17 -0500

Hi,

I have another question regarding Proxy Mobile IP. Is there any
Internet-ID for it or is Cisco specific.

thanks,
Amin