Subject: [mobile-ip] Re: new MIPv6 requirements

From: "Bryan Wang" <[email-masked]>
Date: Thu, 1 May 2003 14:00:39 -0700

Hi,

The new requirement in section 6.1 is inconsistent with the existing
description for BRR in

9.5.5.
...
The Binding Refresh Request message is sent in the same way
 as any packet addressed to the mobile node ...

Should we treat this as another exception, or should we require that BRR
always be sent to the home address, and have HA tunnel it to the MN if MN is
traveled out side?

Thanks,
Bryan

----- Original Message -----
From: "Ed Remmell" <[email-masked]>
To: "Bryan Xiangqian Wang" <[email-masked]>
Sent: Thursday, May 01, 2003 11:42 AM
Subject: new MIPv6 requirements

> section 6.1 "Mobility Header":
> "  Mobility Header messages MUST NOT be sent with a type 2 routing
>    header, except as described in Section 9.5.4 for Binding
>    Acknowledgement.  Mobility Header messages also MUST NOT be used with
>    a Home Address destination option, except as described in Section
>    11.7.1 and Section 11.7.2 for Binding Update.  Binding Cache
>    information (when present) for the destination MUST NOT be used in
>    sending Mobility Header messages.  That is, Mobility Header messages
>    bypass the Binding Cache check described in Section 9.3.2 which is
>    normally performed for all packets.  This applies even for message
>    sent to or from a correspondent node which is itself a mobile node."
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 07 May 2003 23:49:44 +0300

> always be sent to the home address, and have HA tunnel it to the MN if MN is

I think the latter is the right thing to do.

--Jari