Subject: RE: Current Movement Detection Process and Time (Re: [mobile-ip] Re: closing issue #297 (erik's and steven's technical comments on base))

From: Hesham Soliman <[email-masked]>
Date: Thu, 1 May 2003 16:44:51 -0400

> OK, I think I agree with you now that handover latency of 
 > 4-5 seconds is
 > generally unacceptable. 

=> Thank you! I've been frustrated by opinions that associate
what is being done in FMIP and HMIP as "stuff for VoIP" which
is not correct. 

   So then optimized NUD probing isn't 
 > really a good
 > solution. But, in some cases NUD may be the only mechanism 
 > available, 

=> Well, I must admit I haven't read all emails on the topic 
but I want to stress one important point: This section is _educational_.
I.e. it does not and could not mandate anything. 
Having said that, you don't need to use the "NUD procedure"
with all its timeouts ...etc. You can simply use an NS/NA
exchange. These messages are always available. In the 
presence of fasr RA, I would prefer that to NS/NA, but 
for now, why not use NS/NA without having to follow NUD. 
And BTW, we don't have to call this use of NS/NA, NUD. 

   in
 > addition to listening for RAs. Note that w/ regards to the 
 > RA Advertisement
 > Interval and RA beacons, if I fail to receive the expected N 
 > (i.e. 3) number
 > of beacons in the expected period, I treat this as a L3 move 
 > indication, in
 > which case I'll solicit w/ RS and skip the NUD probes.

=> Agreed.

Hesham

---

From: "Ed Remmell" <[email-masked]>
Date: Thu, 1 May 2003 14:09:29 -0700

Hesham -

> what is being done in FMIP and HMIP as "stuff for VoIP" which

Yes, TCP entering "slow start" is generally not a good thing to have happen.

> And BTW, we don't have to call this use of NS/NA, NUD.

Agreed. But, be careful. Wireless is a lossy technology, in general. It is
likely that a single NS probe is lost, and/or that the answering solicited
NA is lost. So, just sending a single NS probe to verify reachability
probably won't work too reliably over wireless.

- Ed