Subject: Re: [mobile-ip] I-D ACTION:draft-bagnulo-mobileip-unreachable-hoa-00.txt

From: Greg Daley <[email-masked]>
Date: Fri, 06 Jun 2003 13:08:38 +1000

Hi George,

George Gross wrote:
> Hi Greg,
> 
> in your recent e-mail on the MIP list, you said:
> 
> 
>>the first I can think of would be use of CGA:
>>draft-aura-cga-00.txt describes this topic generally,
>>and has a reference to a MIPv6 application of this.
>>
>>It would be easy to relate an identity which had been established
>>on a previous subnet's CoA or home address to one related to the
>>new CoA.     Unfortunately, CGA is encumbered technology.
> 
> 
> while it is true that Microsoft/Aura have IPR on the ID you mentioned, I
> was not aware that CGA in general is an encumbered technology. For
> example, HIP uses a cryptographic identity to do mobility management, but
> AFAIK there are no IPR liens on HIP (though I have never asked Moskowitz
> to confirm that).
> 
> do you have any insight (e.g. patent numbers) that would offer background
> on CGA intellectual property?

I'm actually about as unclear as anyone as to what the IPR
status of CGA is.

If CGA itself is unencumbered, I'm sorry for misleading people.

Certainly in this case there seems to be some IPR interest.

Greg

---

From: Jari Arkko <[email-masked]>
Date: Fri, 06 Jun 2003 08:03:13 +0300

> Certainly in this case there seems to be some IPR interest.

First, cryptographic identity != CGA. The idea in CGA is that
an address has a specific relationship to a cryptographic
identity. As far as I understand, in HIP the cryptographic
identities are independent of the addresses.

Secondly, at least we at Ericsson have stated publicly that
we may have some IPR that relates to CGAs. If you search
for the old Mobile IPv6 CGA drafts, you'll see some statements
to this effect. For Secure Neighbor Discovery, we succeeded
in getting an open license for the use of CGAs (for details:
http://www.ietf.org/ietf/IPR/ericsson-send-ipsec.txt). But
Ericsson may not be the only company with IPRs in this space,
so the total situation is still unclear, even for SEND.

--Jari