Subject: RE: [mobile-ip] Security question for HMIPv6

From: Soliman Hesham <[email-masked]>
Date: Wed, 18 Jun 2003 23:50:40 -0400

I must be still jetlagged, sorry I have to clarify
one thing in my email 

 >  > > => Correct. But there is a difference between the HoA and
 >  > > the RCoA in this context. The HoA is assumed to be fixed
 >  > > for reachability. Therefore you want to make sure that
 >  > > certain addresses are reserved for certain MNs. In the RCoA
 >  > > case, the address is merely a CoA, it does not need to be
 >  > > fixed. So there is no need to associate certain MNs to
 >  > > certain addresses. There is no reachability requirement
 >  > > here, any address will do for the MN.
 >  > >
 >  > 
 >  > I think as long as there is some verifiable identity that could be
 >  > used to anchor the SA, this would work.
 > 
 > => Agreed.

=> This needs further clarification.
Business Model a: Mobility is part of the access. Gaining access
means you gain mobility. This is basically the case
today in any wireless network except for WLLs (last
mile to the home stuff in which you don't need IP mobility)

Business Model b: The operator thinks that mobility is a service
on top of access. This does not exist today AFAIK.

In Model a, any form of opportunistic IPsec even will
do. The only requirement here is to make sure that 
the MN does the right thing. I.e. it does not steal
addresses or bomb other devices on other links. So
the verfiable identity here is the PK and that's all
you need for the SA. 

In Model b, (which does not exist) the operator needs
additional AUTH. At a minimum, this can be:
- Anyone outside my CA cannot get this service
But this might not be enough. So you might need further
granularity like:
- Only this list of FQDNs can get this service

AFAIK Model b, is also achievable with the current
spec (do you agree?), I just don't think this will
be used because no one wants to provide worse serivce
than they do today. Therefore, there is no reason for
taking out mobility from the basic access package offered
today.

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Thu, 19 Jun 2003 08:14:08 -0700

> taking out mobility from the basic access package offered

I'm still a little concerned about authorization. I would rather not have
the protocol make assumptions about what business models will be common down
the road (see draft-iab-e2e-futures-03.txt for a discussion of making
choices in standards when competing nontechnical interests are involved).

I think an EAP transaction inside a Phase 1 IKEv2 exchange should probably
do the trick, but it would be helpful to walk through the details at some
point (maybe not just now) if for no other reason that it would provide
another data point on what IKEv2 can and cannot do for mobility. In any
case, I don't think anything needs to be in the protocol document about it
for this round.

            jak