Subject: [mobile-ip] Announce: BoF Proposal: Detecting Network Attachment

From: Greg Daley <[email-masked]>
Date: Wed, 11 Jun 2003 16:52:38 +1000

Hi,

There has been some interest in various IETF WGs
regarding what to do when attaching to a network,
and how to distinguish if a host has attached to
a currently configured network or a new one.

In mobile-ip WG this is largely tackled because of
the need to detect movement quickly.

There is currently a BoF proposed for IETF57 which
aims to discuss issues uncovered in DHC, Mobile-IP
and Zeroconf WGs.  The hope is that getting together
people from these (and other) groups who are interested
in the problems may lead to a unified approach
to these problems (or at least only one approach each
for IPv4 and IPv6).

Here is the proposed BoF's description:

Detecting Network Attachment (DNA) Proposed BoF Description:

Network Attachment occurs when a host arrives on a new
IP subnet.  When attaching to a network, a host either
already has a valid configuration for this subnet or
must configure addresses.  A host determines whether
it requires additional configuration by Detecting Network
Attachment.

When a host has existing upper layer protocols sessions,
it is important to receive a timely indication that
attachment has occurred.  This may be the case if a host
is connected intermittently, is moving or has urgent data
to transmit upon attachment to a link.

For these nodes, it is also important detect if an acquired
link is new, or has already been visited. This information
may be used to distinguish between events where
configuration must be initiated, or a host already has
valid configuration.

This meeting hopes to providing a forum for those
interested in developing generic attachment detection
technologies for IPv4 and IPv6.

The BOF aims to:

* Describe existing issues encountered in DHC, ZEROCONF
   and Mobileip WGs, which could benefit from work on
   detecting network attachment.

* Define the problem scope, and environments where network
   attachment detection is desirable.

* Determine if sufficient interest exists to form a
   Working Group on this topic.

* Reach consensus on the area of work for a potential WG,
   including which problems are outside scope.
---

If you are interested in this topic, and contributing to
an agenda for the proposed BoF, please subscribe to
the mailing list:  [email-masked]

You may subscribe by sending an email to:

[email-masked]

with the words:

subscribe dna

in the body of the email.

More information is available at the website:

http://www.ctie.monash.edu.au/dna/

Greg Daley

---

From: "James Kempf" <[email-masked]>
Date: Wed, 11 Jun 2003 08:08:39 -0700

> it requires additional configuration by Detecting Network

This is worded so that it sounds like it excludes discussing opti-DAD
and other accelerated address configuration mechanisms. Is that the
intent (if so, I think it should be explicitly stated)?

            jak

---

From: Greg Daley <[email-masked]>
Date: Thu, 12 Jun 2003 09:34:31 +1000

Hi James,

> intent (if so, I think it should be explicitly stated)?

This is an important point.  At this stage, I was trying to
be inclusive to ensure DHC & other working groups would be
able to participate (so wording may be looser than it needs be).

I would guess that the main aim is the detection of attachment
or movement with address configuration only being concerned
because a node realises that it has arrived on a new network.
At this stage, we'll leave the actual operation of address
configuration out.

We can get a consensus on that answer later (or direction from ADs),
but that's probably the state of play.

Thanks again for your feedback.   Certainly there seems
to be already a few things to be tightened up :)

Greg