Subject: RE: Address config for FMIPv6 (was Re: [mobile-ip] FMIPv6: FBUtransmission text)

From: <[email-masked]>
Date: Fri, 20 Jun 2003 16:46:40 -0500

Optimized DAD and its variants for speeding up address
configuration are interesting solutions. However the
ability to configure a nCOA (with minimal latency) is only
part of the overall problem being addressed. Hence I
do not believe we can go off and keep evaluating the
many different proposals for speeding up address config.

Optimizing DAD will be taken up in the DNA BoF/WG and
when this work is done, I guess it will basically update
the procedure in RFC2462. But there is no reason to create
this dependency now. Lets acknowledge that there is a possibility
that Optimized DAD will be available at some time and FMIPv6
can consider its use in the nCOA configuration part. We
can include it in an appendix for now and move on. The
mechanism proposed by Rajeev which is basically an enhancement
to FNA does not have dependencies on other work being done
elsewhere. Since the draft is intended for Experimental status,
it would be fine to go ahead and build the solution on the
enhanced FNA scheme and allow for people to also experiment 
with other methods for configuring the MNs nCOA as well.

After 3 years, lets get the spec out and begin to do some
real testing of the protocol.

-Basavaraj

> 
> Greg Daley wrote:
> 
> > Hello Seok,
> >
> >
> > Certainly allowing FMIPv6 to work in conjunction
> > with these technologies is worthwhile, though.
> >
> 
> This should be emphasized here. FMIPv6 is not
> trying to incorporate all the alternatives to improving
> DAD.
> 
> Please move stateful versus stateless DAD discussion
> to another place and time. It is interesting, but not
> the focus here.
> 
> The text I sent is a summary of FMIPv6 as it has
> progressed over the last three years. It is not
> proposing anything new per se, except for allowing
> carrying FBU within 'M'. It is trying to
> clarify the protocol operation.
> So, before commenting that protocol is _more_
> complicated now, I suggest you please read the text
> and the draft again.
> 
> Thanks,
> 
> -Rajeev
> 
> 
> 
> 
> >
> > Greg
> 
>

---

From: Greg Daley <[email-masked]>
Date: Mon, 23 Jun 2003 09:43:49 +1000

Hi Basavaraj,

> many different proposals for speeding up address config.

I agree with this for Mobileip related groups,
although some solution has to be found which may be
relied upon for quick handovers.

> with other methods for configuring the MNs nCOA as well.

I also think that the proposal has merit since FMIPv6 is
going to experimental.   Once FMIPv6 is more widely deployed,
we will see if this system has benefits over other proposed
DAD optimizations.

The DNA BoF will be discussing the issue of Address
Configuration Optimizaton, although it is worth noting
that the issue is not yet determined to be 'core work'
of a potential WG.   That's not to say that DAD optimization
is not important, but whether or not it belongs with the
Movement Detection (and attachment detection) work which DNA
will probably be looking at.

If people feel that these issues should be dealt with in DNA
then they are invited to participate in this discussion
at the BoF.

> real testing of the protocol.

Indeed.

For those interested in this issue, the Detecting
Network Attachment (DNA) BoF will be discussing a
potential WG scope and issues on Friday morning at
IETF57, just after breakfast.

Greg