Subject: Re: [mobile-ip] RE: Address config for FMIPv6

From: "Seok Joo Koh" <[email-masked]>
Date: Thu, 26 Jun 2003 09:56:04 +0900

Hello Basavaraj,

> You can deploy base MIPv6 without any optimization.
> You can deploy base MIPv6 and HMIPv6.
> You can deploy base MIPv6 and FMIPv6.
> You can deploy base MIPv6, HMIPv6 and FMIPv6.
>
>
> -Basavaraj

Regarding the 4th scenario of "MIPv6+HMIPv6+FMIPv6",
the fast handover scheme on HMIPv6 networks needs to be applied in a different flavor
due to the HMIPv6 features, as discussed by
http://ectp.etri.re.kr/~sjkoh/mobileip/draft-jung-mobileip-fastho-hmipv6-01.txt

The I-D tries to identify a couple of possible and promising approaches for Fast handover in HMIPv6
(named F-HMIPv6)
A simple and straightforward integration of the FMIPv6 scheme into HMIPv6 will not be preferred for
several reasons.

So, as per your comments on the future work plan (of MIPSHOP WG),
do we need to progress the F-HMIPv6 work on another track (different from FMIPv6) ?

Seok J. Koh

---

From: Greg Daley <[email-masked]>
Date: Thu, 26 Jun 2003 13:37:27 +1000

Hi,

I'm not sure about what will happen to F-HMIPv6
in MIPSHOP or another WG, but that shouldn't
stop you from working on the concept (which
I think is good).

Personally, just from my initial reading, I think
section 5.2 (No Anticipation) is too defensive.

There's likely to be limited benefit to doing
F-HMIPv6 with the old AR in the reactive case
(if the MAP is close) anyway, so I don't see an
issue here.

This is the likely topology for F-HMIPv6 so
I think it is worth saying this, rather than
indicating that reactive tunnel establishment
is unable to be achieved.

What is worth indicating is that the De-encapsulation
provided by the BU with F-bit on the new access
network is valuable even in the reactive case.
This is certainly possible, if the MN can prove
that it is actually on that network.

It may be necessary in this case though to
ensure that an MN when it inspects the RA
checks that both the MAP and nAR support
F-HMIPv6.

This could also be used to initiate the tunnel
before a prediction is required (so one is always
using F-HMIPv6).

Greg

---

From: "Seok Joo Koh" <[email-masked]>
Date: Fri, 27 Jun 2003 15:20:44 +0900

From: "Greg Daley" <[email-masked]>
> stop you from working on the concept (which

Hi Greg,

Thanks for your useful comments

Actually, it seems that many of the WG peoples have a consensus about the need of F-HMIPv6 (or other
naming),
because the fast handover in HMIPv6 may be applied more effectively, only if we exploit the HMIPv6
features,
rather than simply applying the FMIPv6 to HMIPv6 networks.

But, we may still have a lot of things to do for further enhancement and engineering of F-HMIPv6.
That work may be impacted by the future progresses on base FMIPv6 and HMIPv6 specifications.
As your comment, one clear thing is that the F-HMIPv6 is worthwhile enough to discuss in the MIPSHOP
WG (or MIP6).
I believe that the document will be a triggering point to foster and facilitate the discussion.
I also believe the F-HMIPv6 will be more enhanced by the WG comments and contributions.

You can now see the I-D at:
http://www.ietf.org/internet-drafts/draft-jung-mobileip-fastho-hmipv6-01.txt

Seok