Subject: RE: [mobile-ip] FMIPv6: FBU transmission text

From: Soliman Hesham <[email-masked]>
Date: Thu, 19 Jun 2003 00:00:01 -0400

I read the whole message. Comments below.

 > In b), if there is no entry for NCoA in NAR's forwarding tables, but
 > there is already a host on the link with NCoA, NAR will incorrectly
 > create an entry. However, such an entry would be over-written when an
 > advertisement for the DAD probe is received. When this happens, NAR
 > could forward packets to an unintended host. This is the penalty for
 > using NCoA while DAD is in progress and is not unique to the 
 > mechanism
 > described here. Indeed, a simple scan for an existing entry 
 > improves the
 > 
 > chances of expeditiously detecting duplicates. In any case, 
 > it is useful
 > 
 > to bear in mind that the likelihood of a collision actually 
 > taking place
 > is
 > insignificant in the first place.

=> Yet, the draft is _designed_ around this insignificant
problem. If we treat this problem as insignificant (and
we agree that it is), then we should not devote several
messages and make them mandatory to fix it. 
So, why don't we put this problem in context and not 
mandate signalling that is only useful when address 
duplication is detected?

Hesham

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 19 Jun 2003 09:30:14 -0700

Hi Hesham,

> I read the whole message. Comments below.

Thanks :-)

> messages and make them mandatory to fix it.

Sorry.. Which several messages are you referring to ? In order
for both the scenarios (in the text I sent) to work together,
a message from the MN to the AR is necessary. For the
predictive scenario, the message is the only way to announce
to the AR to move the proxy ND cache entry to ND cache and
start forwarding. For the reactive case, the NAR establishes
an entry first; the address verification is trivial: don't over-write
an existing entry.

Are you referring to the router responding in case there is
a conflict ? Since the likelihood of conflict is very small,
this message itself should not be seen on the wire much.
When there is a conflict however, a message would help
since the encapsulated FBU is dropped by NAR.

> mandate signalling that is only useful when address

So, I would assume this is the RA from the router to
MN with an option ? This message is only sent (perhaps
a SHOULD) when there is conflict to let the MN know
of a conflict. Of course NA for DAD probe will let the
MN know, but a message from the router could reach the
MN faster.

-Rajeev