Subject: RE: Address config for FMIPv6 (was Re: [mobile-ip] FMIPv6: F BUtransmission text)

From: Soliman Hesham <[email-masked]>
Date: Tue, 24 Jun 2003 22:25:04 -0400

=> This is a pure implementation issue. For instance, 
how large is the buffer required in NAR for FMIPv6?
RFC 2461 leaves it up to implementers to decide
how long the queue is. If we are going to change
the NAR anyway, it's a hell of a lot easier to
change the queue size than to have all this complexity
in the draft. 

Hesham

---

From: Soliman Hesham <[email-masked]>
Date: Wed, 25 Jun 2003 18:54:41 -0400

Basavaraj, 

I just saw this email after I'd sent mine
that explains exactly where I'm coming from.
So please have a look at that and let me know.
quick comments:

 > 
 > I believe FMIPv6 should be designed to work independent
 > of whether there exists a MAP or hierarchical solution
 > available. Lets not mix up the two optimization schemes
 > and create dependencies between the two.

=> I think it should work independently too. I never
said it should be dependent on HMIP or vice versa. 
I said that in some cases it is not useful and HMIP
is just as useful. This is a system design issue and
does not suggest changes in the draft.

 > I do not think the current proposal is an overkill because:
 > a. FMIPv6 is an optimization solution. Hence reducing the
 >    number of messages, RTT and faster address config are 
 >    all in the game plan.

=> Sure, the cost of doing so should also be considered.
Please see details in the "address confusion email".

 > b. This is experimental. Lets see how well it works or does
 >    not work. I think the results will indicate complexity 
 >    vs gain.
 > c. The message being introduced here is FNA which avoids the
 >    NS/NA exchange. So I am not sure what 3 new messages are
 >    being introduced. If you are refering to HI/HACK, those
 >    I believe have been a part of the fast-HO proposal from 
 >    rev 1 of the document.

=> Yes I was suggesting all 3. But I didn't ask for 
them to be removed from the draft. 

The problem is, I didn't say anything that disagrees
with the above. I said, make them optional... I'm starting
to regret saying it ;)

Hesham