Subject: RE: [mobile-ip] FMIPv6 Address confusion

From: Soliman Hesham <[email-masked]>
Date: Fri, 27 Jun 2003 00:57:57 -0400

> In the Section 3.2, optiDAD says that...
 > 
 >   "Of course, in the meantime the ON may have sent packets which
 >    identify it as the owner of its new Tentative address 
 > (for example,
 >    Binding Updates in [MIPV6]).  This may incur some penalty 
 > to the ON,
 >    in the form of broken connections, and some penalty to 
 > the rightful
 >    owner of the address, since it will receive (and potentially reply
 >    to) the misdirected packets.  It is for this reason that 
 > Optimisitc
 >    DAD should only be used where the probability of collision is
 >    exceedingly low."
 > 
 > Your current proposal cannot avoid the above problem 
 > without any modifiction.
 > 
 > As I mentioned in previous mail, I don't like to tell...
 > 
 >   "FMIPv6 should only be used where the probability of collision is
 >    exceedingly low."

=> Who said anything about FMIPv6 working only in
a scenario where address collision is extremely
low? Only you said that, I didn't. 

For the final time, I'm not proposing a _scheme_.
I was asking for these messages to be made optional
because under several circumstances address duplication
is either not going to happen or extremely unlikely
and there is a cure for that. The reason I showed
one example of this working without the messages in
question is to illustrate that they need not be mandatory.

But people seem to be getting dragged into one example
and forgetting the original message...Sigh

I'll send text to the list.

Hesham

---

From: "Youn-Hee Han" <[email-masked]>
Date: Fri, 27 Jun 2003 14:48:09 +0900

> I'll send text to the list.

What I am trying to say is that we need some means against 
the address collision. In the Koodli's new text, the scan of ND 
cache improves the chances of expeditiously detecting duplicates.
I think that it is one possible solution although it does not solve 
the problem completely.

In your mail, you obviously mentioned that optiDAD can solve 
the address collision gracefully. Is it possible without some message
(e.g., Hi/HAck and FNA/NAAck)? Don't you mind the misdirected 
packets in case address collision?

Youn-Hee