Subject: RE: [mobile-ip] what optimistic DAD?

From: Soliman Hesham <[email-masked]>
Date: Mon, 30 Jun 2003 23:12:38 -0400

> Nick 'Sharkey' Moore wrote:
 > 
 > >
 > > Yeah, and I think that's the difference.  Optimistic DAD is an
 > > attempt to make all this work ON AN UNMODIFIED NAR at the expense
 > > of a couple of extra round-trips.  I think it's important that
 > > we get a practical handover protocol which will work in 
 > Starbucks :-)
 > >
 > 
 > Good applicability statement. If you don't wish to change the
 > router, run reactive with BU to the old router.

=> There is no reason to do that, you can use it
with predictive handovers as well as I showed
several times. In the current draft you assume
that the NAR will check if the address is valid
and there is no concrete and timely way of doing that 
either. So I don't understand why OptDAD would not
be acceptable for predictive handovers, especially
when compared to the vague mechanism in the draft
today.

Hesham

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Tue, 1 Jul 2003 13:37:24 +1000

G'day Hesham!

On 2003-06-30, Soliman Hesham wrote:
> several times.

Yeah, that's what I meant too, which is why I emphasized
"ON AN UNMODIFIED NAR".  Eg: even if the prediction signalling
comes from the MN, the AP, the pixies &c Optimistic DAD
will be a useful technique for predictive fast handovers.

-----Nick
-- 
"Premature optimization is the root of all evil (or at least most of it)
in programming." -- Donald Knuth