Subject: RE: Address config for FMIPv6 (was Re: [mobile-ip] FMIPv6: FB Utransmission text)

From: Soliman Hesham <[email-masked]>
Date: Tue, 24 Jun 2003 05:15:38 -0400

> >  > It is hard to assume that handover delay will always be
 > >  > smaller than the inter-packet separation..
 > > 
 > > => Agreed, that's why you need a reasonable size
 > > queue.
 > 
 > 
 > AFAIK, FMIPv6 is supporting three buffers(or queues):
 > 
 >  Buffer 1 (at PAR):
 >           for packets of which destination address is PCoA. 
 >           (They are sent from other CNs)
 >           Start buffering - when PAR sends HI
 >           Ending buffering - when PAR receives HAck
 > 
 >  Buffer 2 (at NAR):
 >           for packets of which destination address is PCoA.
 >           (They are sent from PAR through the tunnel)
 >           Start buffering - when NAR receives HI
 >           Ending buffering - when NAR receives FNA
 > 
 >  Buffer 3 (at NAR):
 >           for packets of which source address is PCoA.
 >           (They are sent from MN at new link)
 >           Start buffering - when NAR receives FNA
 >           Ending buffering - when NAR receives HI
 > 
 > 
 > Maybe, Buffer 3 does not receive any packets if predictive scenario
 > is performed and HI message is well sent before MN moves to 
 > new link. 
 > However, we cannot ignore the case that the HI message is delayed 
 > (e.g., network congestion, multihop between PAR and NAR, etc.)
 > Can we create Buffer 3 using normal ND without proxy neighbor cache?

=> I was only referring to the ND queue. I was arguing
that no other queueing is necessary if the ND queue
is large enough. 

Hesham

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 24 Jun 2003 19:20:02 -0700

> that no other queueing is necessary if the ND queue

typically the Neighbor Discovery queue is very small. it
is just long enough till the node can determine that the
destination is unreachable. determining that a node is
unreachable takes (typically again) two RTTs on a link.
after that packets are dropped and the node starts sending
ICMP unreachable messages for the destination address.

Vijay