Subject: RE: [mobile-ip] FMIPv6 protocol changes

From: Soliman Hesham <[email-masked]>
Date: Tue, 17 Jun 2003 08:16:36 -0400

> > => Agreed. Optimistic DAD is our friend!
 > 
 > Current FMIPv6 description devotes most parts to the NCoA 
 > confirmation.
 > AFAIK, the confirmation includes normal DAD process. If optiDAD were
 > a friend of FMIPv6, MN itself could create and use its 
 > address without the 
 > complex confirmation protocol, whenever it attaches new 
 > link, cann't it?

=> It sure can. That's been my point for about 3 years 
now and work by Nick et al shows data that confirms that 
it works. But the problem with OpDAD is that it's too
simple ;)

Hesham

---

From: "Mohamed Khalil" <[email-masked]>
Date: Tue, 17 Jun 2003 08:55:53 -0500

- clarify FBU transmission from the new link.
Specifically, it would be useful to have FBU
sent with NCoA as source IP address so that
issues surrounding ingress filtering etc could
be avoided to begin with. And, packet
forwarding could ensue for topologically
consistent address for packets tunneled from
the previous router.

MK>>Agreed, optimistic dad could be used.

- role of Three Party Handover. It would be
better to keep the scope of the draft to simple
scenarios and fall back to base Mobile IP during
error cases. I am proposing that Section 4.6, which
specifies TPH using L2 signaling, be deprecated.
This text might be useful in a separate document
that _could_ specify further optimizations to
FMIPv6, if such thing is seen as useful in the future.

MK>> agreed

- role of L2-optimized handover, i.e., Section 4.5.
It has always been an issue to address L2-L3 interaction
to improve performance. What if we focus (back!) merely on
IP protocol specification and leave the "vertical integration" out, perhaps
to some other time and place ? I think this would impart substantial
simplification to the protocol behavior. At the same time, some illustrative
text on L2 triggers causing protocol invocation would be needed. Any takers
?

MK>> agreed

Mohamed Khalil

Nortel Networks

---

From: <[email-masked]>
Date: Tue, 17 Jun 2003 14:27:02 -0500

> >
> > => What was the conclusion? I don't recall any. I only
> > recall suggestions.
> >
> 
> During SF IETF meeting, we had a discussion. The
> conclusion of that was to move the draft assuming
> some mechanism is available, instead of having to
> devise our own. In the same context, Anonymous
> DH was mentioned as well as a possible candidate.

Right, this was the recommendation from Erik.

> 
> So, I am proposing we specify text on how FMIPv6
> could use the mechanism(s), and/or specify ADH
> as a default.
> 
> -Rajeev
> 

-Basavaraj