Subject: RE: [nemo] WG: [mobile-ip] new I-D on HA filtering

From: Soliman Hesham <[email-masked]>
Date: Thu, 24 Jul 2003 04:07:00 -0400

> > => Definitely not the right WG for this. The right WG
 > > is MIP6 or if MIPSHOP had a more flexible name/charter
 > > it could go there as well. There is nothing NEMO specific
 > > for this problem.
 > 
 > Sorry, I tend to disagree. Ideally, the solution should work for both
 > Mobile IPv6 and NEMO Basic Support. So, if design team there is, we
 > should have people from both working groups, making sure it work for
 > both protocol. This said, whether the report is actually done, during
 > the IETF meeting, in the NEMO WG or another WG may not be important.

=> Well, the problem is how to allow flow-based mobility,
where the flow is a connection or more. To do this, 
there are 2 aspects to consider:
- How to decide which flow goes where (policy)
- How to manipulate a binding cache in the HA/CN to achieve
  this. 

Since we're talking about multiple CoAs, this does not
apply to an MNN (node behind the MR) until an RO
solution for NEMO comes up. It could certainly apply to an
MR with more than one interface, but I fail to see
why anything designed for a MN would not work
for the MR. 

Having said all that, there is no WG membership in IETF :)
So if the chairs decide to have a DT, which is not at all
clear, then it is likely that people with interest in
NEMO and MIP will be in it. ButI don't know if
a DT is needed anyway.

Hesham

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 24 Jul 2003 17:13:03 +0900

> why anything designed for a MN would not work

Hi Hesham,

In NEMO Basic Support, one issue we already have is how to select the
interface/CoA at the MR. It would probably be useful that the MNN kind
of interact with the MR (to exchange policies, for instance), and this
doesn't break the NEMO "Mobility Transparency to MNNs". 

Besides this, since NEMO Basic Support is clearly based on MIP, having
the relevant extensions explicitly stating how it works at CN/HA/MR/MH
is important. 

Let's have another BoF for interface switching and CoA selection ! :-) 
Just kidding - there are already so many WGs to follow :-(
 
> NEMO and MIP will be in it. ButI don't know if

Right.

Thierry.

---

From: Nicolas Montavont <[email-masked]>
Date: Thu, 24 Jul 2003 10:20:50 +0200

>- How to manipulate a binding cache in the HA/CN to achieve
We think that how to decide which flow goes where is out of scope of any 
specification.
In the contrary, we clearly need to standardize how to manipulate 
binding cache and enventually signaling to perform flows spreading

>why anything designed for a MN would not work
Yes, but we have to check if the solution we will propose work in NEMO 
environment.

>NEMO and MIP will be in it. ButI don't know if
But now we have several drafts on this topic. It would be interesting to 
merge them in order to have a unique solution

Nicolas
Thomas