Subject: RE: [mobile-ip] what optimistic DAD?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 2 Jul 2003 08:02:46 +0100

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: mardi 1 juillet 2003 18:35
> To: Pascal Thubert (pthubert); Nick 'Sharkey' Moore;
[email-masked]
> Subject: Re: [mobile-ip] what optimistic DAD?
> 
> > The second thing is, that IMHO, the proxy should be shut off by the
> > simple presence of the real owner of the address on link, and that
we
> > should define the mechanism to ensure so. Also, I still believe that
the
> > owner MN binding to a different HA should cause the sticky binding
in
> > the old HA to go silently. Seems to me that your mechanisms could be
> > used to do all that.
> >
> > What do you think?
> >
> 
> Any suggestions about how to determine who the "real owner" is?
> 
>

I think of the home address as an address statically configured on the
'home' interface, rightfully owned by the MN. In other words, the MN
should be allowed to NA (override=1). As opposed to a HA that is only a
proxy.

Pascal

---

From: "James Kempf" <[email-masked]>
Date: Wed, 2 Jul 2003 08:36:16 -0700

> should be allowed to NA (override=1). As opposed to a HA that is only a

One nice DoS attack would be for an attacker to start claiming the home
address, causing the HA to stop proxying, and the attacker then gets the
traffic for the victim.

            jak