Subject: Re: [mobile-ip] Using Mobile IPv6 over PPP links

From: [email-masked]
Date: Tue, 15 Jul 2003 16:18:43 +0800

> >
> > Is there any work ongoing to support mobile ipv6 over PPP links ? I am
> > trying
> > to do this but am having problems during movement. When I move from 
the
> > HN to FN (disconnect the MN's serial cable from one network and 
reconnect
> > to another network), the device vanishes and I lose the home address. 
So
> > when I reconnect it to the FN, I get a new device and new foreign 
address,
> > but
> > since I don't have the home address any longer, movement fails.
> >
> > I don't know if any discussions have taken place about supporting 
mobility
> > over PPP. Please let me know if anyone has any insight into this, or 
if
> > there is
> > any work related to this (in IETF or elsewhere).

>dont assign the home address to the ppp0 interface.
>assigning the home address to a virtual interface 
>would be a good idea.

> Vijay

If so, how to proceed when the node go back its HN?

Bob

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 15 Jul 2003 10:53:40 -0700

Bob and Suvidh	

> If so, how to proceed when the node go back its HN?

thats simple. even though you assign the home address
to a virtual interface, you always assume that ppp0 
is the interface which actually connects to you to
the visited link or home link. you compare prefix
information in any router advert received on ppp0
with the home prefix.

assigning the home address to a virtual interface is
also very useful when you multiple egress interfaces 
(for eg a WLAN and a GPRS interface). you can use the 
same home address irrespective of whichever interface 
you use to connect to the network.

Vijay

---

From: montavont <[email-masked]>
Date: Thu, 17 Jul 2003 10:13:44 +0200

Hi,

>you use to connect to the network.

Yes, but it allows to use only one interface at a time. If you want to
simultaneoulsy use both interfaces, you need further mechanisms that are
not clearly defined in the base spec of MIPv6.

Nicolas