Subject: RE: [mobile-ip] Revised agenda for: MIP4 - Mobility for IPv4 BOF

From: <[email-masked]>
Date: Fri, 11 Jul 2003 16:29:43 -0500

Hi Kuntal,

Since we have a timeslot to discuss the charter of the proposed
WG, you can raise this as a work item for the WG to consider.

However IMO (no chair hat here), I think there is no reason
to extend Mobile IP signaling to obtain configuration parms
from the home network. There has also been some discussion 
or even drafts I think about using DHCP (tunnelling back
to home) for obtaining configuration data. I really see no
reason to extend Mobile IPv4 messages to carry DNS config
data from the home. I am not sure what you meant by the
session manager in your note, but lets discuss this at the
MIP4 meeting.

-Basavaraj

> 
> 
> I Request to add the following in the "Work expected to be 
> done by the MIP4 WG..." list:
> 
> 7. MIPv4 messages to exchange configuration options. The MN 
> may request some configuration options such as session manager address, DNS 
> server address etc. via MIPv4 messages.
> 
> We submitted a draft on this long time ago. There was some 
> limited discussion on 
> the MIP list. The current version (-02) is at:
> 
> http://www.ietf.org/internet-drafts/draft-bharatia-mobileip-ge
> n-mipv4-ext-02.txt
> 
> -Kuntal
> 
>

---

From: Kuntal Chowdhury <[email-masked]>
Date: Fri, 11 Jul 2003 17:23:41 -0500

Hello Basavraj,

I won't be there in Vienna, but Jayshree will be there to discuss this issue.

The draft proposal has facility to get these config info either from visited 
network or from the home network. Therefore tunneling may not be always 
required. DHCP option will require mandatory tunneling though if the MN wants 
these values from the home network.

There may be several ways to send these config parameters to the MN, and 
piggybacking the info exchange with MIPv4 messages is one option. This way the 
MN gets all the config parameters with the MIPv4 RRP without having to run 
another protocol like DHCP afterwards. This will reduce session setup time for 
SIP sessions. There are other advantages of doing it with MIPv4 as stated in the 
draft.

Regards,
Kuntal