Subject: RE: [mobile-ip] Revised agenda for: MIP4 - Mobility for IPv4 BOF

From: "Jayshree Bharatia" <[email-masked]>
Date: Thu, 17 Jul 2003 06:09:47 -0500

Basavaraj,

If reality is always conformant to the expectation, I agree that we won't
have any issues. 

I have personally requested alternatives of the solution(s) of these
problems mentioned earlier on this thread but didn't have any luck. Anyway,
if you are referring to DHCP as well understood mechanism, you might have
seen issues posted earlier by Kent and others on using DHCP.   

Regards,
Jayshree

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, July 17, 2003 4:27 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> Bharatia, Jayshree [RICH1:2H13:EXCH]; [email-masked]; 
> [email-masked]
> Subject: RE: [mobile-ip] Revised agenda for: MIP4 - Mobility 
> for IPv4 BOF
> 
> 
> 
> Kent,
> 
> How much of customization of the Mobile IPv4 specs should be 
> continued to be made simply because reality is non-conformant 
> to the specs? So will adding this additional extension to the 
> MIPv4 specs be the end of the line for such needs... I tend 
> to think that this encourages more such extensions to be made 
> in the future simply because there unwillingness to implement 
> well understood and standardized mechanisms... I think we are 
> doing things in the wrong order here. We see 
> implementations that are taking the wrong approach or a 
> shortcut to accomplishing something.... And then we come to 
> the IETF and 
> say this is reality and hence needs to be standardized... I 
> just dont buy this argument...
> 
> If you really think that there is no possibility of using 
> well understood mechanisms for configuration, then I would 
> propose that vendor specific extensions (MIPv4 RFC) be used 
> for this purpose rather than standardizing some new 
> extensions to the Reg_REQ and Reg_RESP messages.
> 
> -Basavaraj
> 
> 
> > -----Original Message-----
> > From: ext Kent Leung [mailto:[email-masked]]
> > Sent: 16 July, 2003 11:48 PM
> > To: Alper Yegin
> > Cc: Kuntal Chowdhury; Erik Nordmark; Patil Basavaraj (NET/Dallas); 
> > [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; 
> > [email-masked]; Lila Madour (LMC); Avi Lior; 
> > [email-masked]; Mike Borella
> > Subject: Re: [mobile-ip] Revised agenda for: MIP4 - 
> Mobility for IPv4 
> > BOF
> > 
> > 
> > Hi Alper.
> > 
> > At 08:52 AM 7/16/2003 -0700, Alper Yegin wrote:
> > 
> > > >        - MN doesn't have DHCP capability (PPP/IPCP only)
> > > >        - Home domain may not use DHCP for address allocation 
> > > > (alternatives such as AAA
> > > >          or local pool)
> > >
> > >These constraints must be a particular architecture's
> > constraints, not
> > >general IETF protocol suite constraint. I think this is the
> > core source of
> > >difference in opinions.
> > 
> > 
> > I would agree with you from the purist perspective.  Though
> > I'm not sure
> > if the world is that ideal.  Else we would probably be 
> running ATM, or
> > IPv6, or OSI.  :)  And using meters instead of yards.  I'm 
> > getting off the
> > issue..  but I think we still have to handle what we have 
> > been dealt.  See
> > possible alternative to solving the problem below.
> > 
> > 
> > 
> > > >
> > > > #1 - MNs that support PPP/IPCP only, use RFC 1877.  But
> > this does not
> > > > achieve the
> > > > objective of getting the DNS server info from the home
> > domain since
> > > > PPP/IPCP terminates
> > > > on the NAS/FA.
> > >
> > >I don't fully know which architecture we are solving this
> > for, but if there
> > >is authentication and AAA involved:
> > >- PPP authentication (or MIPv4 auth), in conjunction with
> > Radius/DIAMETER,
> > >could bring in the DNS parameter to NAS. If NAS implements
> > DHCP Relay or
> > >Agent, it  can deliver this parameter to the host.
> > 
> > 
> > As you probably already know, there is no PPP authentication
> > for Mobile IP
> > service in 3GPP2.  And the reality is that not all operators 
> > want to use DHCP.
> > 
> > 
> > > >
> > > > #2 - Not a technical issue, but changing how operators
> > deploy their
> > > > networks may be
> > > > futile.
> > > >
> > > > So, back to attempting to resolve the requirement.  Is
> > there an alternative
> > > > solution to
> > > > getting the DNS server info to the MNs that can satisfy
> > the hurdles?  I
> > > > don't see any
> > > > in the opposition.  Though I believe we need a solution here.
> > > >
> > > > Kent
> > 
> > 
> > If you are saying that this is not a generic Mobile IP issue but
> > 3GPP2-centric.  And
> > that it's better to update IS-835 to add 3GPP2 VSA for these 
> > functions, I'm 
> > not sure
> > if I would completely disagree.  However, GPRS would have the 
> > same problem when
> > PPP is not used.  3GPP may also encounter this issue, 
> > depending on how that
> > L2 authentication is specified.
> > 
> > Kent
> > 
> > 
>

---

From: Pete McCann <[email-masked]>
Date: Thu, 17 Jul 2003 14:08:38 -0500

IMHO, we should be leaving device configuration to the dhc folks.
Mobile IP does the minimum possible configuration to get connectivity
to a home network.  We really need to think about the modularity of
the standards process and the internet protocol suite and keep that in
mind when we are considering which nail to hit with our hammer.

-Pete

Jayshree Bharatia writes:
 > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
 > <HTML>
 > <HEAD>
 > <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
 > <META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2656.31">
 > <TITLE>RE: [mobile-ip] Revised agenda for: MIP4 - Mobility for IPv4  BOF</TITLE>
 > </HEAD>
 > <BODY>
 > 
 > <P><FONT SIZE=2>Basavaraj,</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>If reality is always conformant to the expectation, I agree that we won't have any issues. </FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>I have personally requested alternatives of the solution(s) of these problems mentioned earlier on this thread but didn't have any luck. Anyway, if you are referring to DHCP as well understood mechanism, you might have seen issues posted earlier by Kent and others on using DHCP.&nbsp;&nbsp; </FONT></P>
 > 
 > <P><FONT SIZE=2>Regards,</FONT>
 > <BR><FONT SIZE=2>Jayshree</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>&gt; -----Original Message-----</FONT>
 > <BR><FONT SIZE=2>&gt; From: [email-masked] [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>] </FONT>
 > <BR><FONT SIZE=2>&gt; Sent: Thursday, July 17, 2003 4:27 AM</FONT>
 > <BR><FONT SIZE=2>&gt; To: [email-masked]; [email-masked]</FONT>
 > <BR><FONT SIZE=2>&gt; Cc: [email-masked]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; [email-masked]; [email-masked]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; [email-masked]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; [email-masked]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; Bharatia, Jayshree [RICH1:2H13:EXCH]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; [email-masked]</FONT>
 > <BR><FONT SIZE=2>&gt; Subject: RE: [mobile-ip] Revised agenda for: MIP4 - Mobility </FONT>
 > <BR><FONT SIZE=2>&gt; for IPv4 BOF</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; Kent,</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; How much of customization of the Mobile IPv4 specs should be </FONT>
 > <BR><FONT SIZE=2>&gt; continued to be made simply because reality is non-conformant </FONT>
 > <BR><FONT SIZE=2>&gt; to the specs? So will adding this additional extension to the </FONT>
 > <BR><FONT SIZE=2>&gt; MIPv4 specs be the end of the line for such needs... I tend </FONT>
 > <BR><FONT SIZE=2>&gt; to think that this encourages more such extensions to be made </FONT>
 > <BR><FONT SIZE=2>&gt; in the future simply because there unwillingness to implement </FONT>
 > <BR><FONT SIZE=2>&gt; well understood and standardized mechanisms... I think we are </FONT>
 > <BR><FONT SIZE=2>&gt; doing things in the wrong order here. We see </FONT>
 > <BR><FONT SIZE=2>&gt; implementations that are taking the wrong approach or a </FONT>
 > <BR><FONT SIZE=2>&gt; shortcut to accomplishing something.... And then we come to </FONT>
 > <BR><FONT SIZE=2>&gt; the IETF and </FONT>
 > <BR><FONT SIZE=2>&gt; say this is reality and hence needs to be standardized... I </FONT>
 > <BR><FONT SIZE=2>&gt; just dont buy this argument...</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; If you really think that there is no possibility of using </FONT>
 > <BR><FONT SIZE=2>&gt; well understood mechanisms for configuration, then I would </FONT>
 > <BR><FONT SIZE=2>&gt; propose that vendor specific extensions (MIPv4 RFC) be used </FONT>
 > <BR><FONT SIZE=2>&gt; for this purpose rather than standardizing some new </FONT>
 > <BR><FONT SIZE=2>&gt; extensions to the Reg_REQ and Reg_RESP messages.</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; -Basavaraj</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; -----Original Message-----</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; From: ext Kent Leung [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Sent: 16 July, 2003 11:48 PM</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; To: Alper Yegin</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Cc: Kuntal Chowdhury; Erik Nordmark; Patil Basavaraj (NET/Dallas); </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; [email-masked]; [email-masked]; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; [email-masked]; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; [email-masked]; Lila Madour (LMC); Avi Lior; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; [email-masked]; Mike Borella</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Subject: Re: [mobile-ip] Revised agenda for: MIP4 - </FONT>
 > <BR><FONT SIZE=2>&gt; Mobility for IPv4 </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; BOF</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Hi Alper.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; At 08:52 AM 7/16/2003 -0700, Alper Yegin wrote:</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - MN doesn't have DHCP capability (PPP/IPCP only)</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; - Home domain may not use DHCP for address allocation </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; (alternatives such as AAA</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; or local pool)</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;These constraints must be a particular architecture's</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; constraints, not</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;general IETF protocol suite constraint. I think this is the</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; core source of</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;difference in opinions.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; I would agree with you from the purist perspective.&nbsp; Though</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; I'm not sure</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; if the world is that ideal.&nbsp; Else we would probably be </FONT>
 > <BR><FONT SIZE=2>&gt; running ATM, or</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; IPv6, or OSI.&nbsp; :)&nbsp; And using meters instead of yards.&nbsp; I'm </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; getting off the</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; issue..&nbsp; but I think we still have to handle what we have </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; been dealt.&nbsp; See</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; possible alternative to solving the problem below.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; #1 - MNs that support PPP/IPCP only, use RFC 1877.&nbsp; But</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; this does not</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; achieve the</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; objective of getting the DNS server info from the home</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; domain since</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; PPP/IPCP terminates</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; on the NAS/FA.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;I don't fully know which architecture we are solving this</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; for, but if there</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;is authentication and AAA involved:</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;- PPP authentication (or MIPv4 auth), in conjunction with</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Radius/DIAMETER,</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;could bring in the DNS parameter to NAS. If NAS implements</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; DHCP Relay or</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt;Agent, it&nbsp; can deliver this parameter to the host.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; As you probably already know, there is no PPP authentication</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; for Mobile IP</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; service in 3GPP2.&nbsp; And the reality is that not all operators </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; want to use DHCP.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; #2 - Not a technical issue, but changing how operators</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; deploy their</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; networks may be</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; futile.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; So, back to attempting to resolve the requirement.&nbsp; Is</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; there an alternative</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; solution to</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; getting the DNS server info to the MNs that can satisfy</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; the hurdles?&nbsp; I</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; don't see any</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; in the opposition.&nbsp; Though I believe we need a solution here.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt;</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; &gt; Kent</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; If you are saying that this is not a generic Mobile IP issue but</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; 3GPP2-centric.&nbsp; And</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; that it's better to update IS-835 to add 3GPP2 VSA for these </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; functions, I'm </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; not sure</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; if I would completely disagree.&nbsp; However, GPRS would have the </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; same problem when</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; PPP is not used.&nbsp; 3GPP may also encounter this issue, </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; depending on how that</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; L2 authentication is specified.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Kent</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > </P>
 > 
 > </BODY>
 > </HTML>