Subject: RE: [mobile-ip] Multiple CoA registration

From: Soliman Hesham <[email-masked]>
Date: Fri, 4 Jul 2003 04:40:54 -0400

> 
 > The use of MIP becomes expensive operations in some situation.

=> Could you elaborate on this ?

 > > => No we don't assume any static config. In fact there is no
 > > assumption at all about how policies are set.
 > 
 > OK. but I need static configuration support

=> Hmmm. I'm not sure why you couldn't use static
configuration. I said it is not assumed, that
doesn't mean it's precluded. Static, dynamic ...etc
is possible.

> I will check this draft.  
> Can I register multiple CoAs to CN by draft-elmalki-?

=> It's a BU extension so you can send it to anyone
that receives the BU. But of course it's unlikely
that people will use it for CNs (that's why the 
draft assumes HA/MAP). However, it is certainly 
possible if the MN is located in 2 CoAs at the same
time. 

Hesham

---

From: Ryuji Wakikawa<[email-masked]>
Date: Fri, 04 Jul 2003 18:45:40 +0900

At Fri, 4 Jul 2003 04:40:54 -0400 ,
> => Could you elaborate on this ?

If MN has 10 policies for a destination, the size of BU becomes large
due to additional 10 options. If an interface has narrow bandwidth,
the bigger BU causes overhead. no?

> possible if the MN is located in 2 CoAs at the same

There is benefit to register multiple CoAs to CNs.
If MN registers multiple CoAs to CN with MN's policy, MN
can use multiple CoAs effectively at the same time.

If MN registers multiple CoAs only to HA, MN should not do RO.
If MN has different types of interfaces which belong to different
domain, MN should notify these CoAs to HA and CNs instead of MAP.

regards,
ryuji