Subject: Re: [nemo] WG: [mobile-ip] new I-D on HA filtering

From: Thierry Ernst <[email-masked]>
Date: Thu, 24 Jul 2003 16:43:39 +0900

Soliman Hesham <[email-masked]> wrote:

>  > > 
>  > > Perhaps, we should initiate a discussion in mobile-ip or 
>  > nemo WG to discuss
>  > > 
>  > > about this topic.
>  > > 
>  > I Agree with you, we have now several drafts and it will be 
>  > interesting
>  > to converge towards an unique solution to solve this issue.
>  > 
>  > Perhaps, Nemo is the ideal WG to discuss about this topic.
> 
> => Definitely not the right WG for this. The right WG
> is MIP6 or if MIPSHOP had a more flexible name/charter
> it could go there as well. There is nothing NEMO specific
> for this problem.

Sorry, I tend to disagree. Ideally, the solution should work for both
Mobile IPv6 and NEMO Basic Support. So, if design team there is, we
should have people from both working groups, making sure it work for
both protocol. This said, whether the report is actually done, during
the IETF meeting, in the NEMO WG or another WG may not be important.

Thierry

---

From: Soliman Hesham <[email-masked]>
Date: Fri, 25 Jul 2003 03:36:41 -0400

> > I personally think there is nothing we should deal with at IETF.
 > > 
 > > Static Configuration:
 > > MN always wants to receives VoIP packets from 802.11b, MN 
 > can ask HA to
 > > configures this filter statically. 

=> How does the HA know if the packet contains VoIP?
The only concrete way of doing this today is to parse
the entire packet and check for RTP/UDP ...etc.
Needless to say that this is not possible if the packet
is encrypted. So I don't think that this is a general
solution.

 > > example: MN and HA shared meaning of IFID.  HA knows IFID1 
 > is assigned
 > > to GPRS and IFID2 is for 802.11b. so administrator of HA just
 > > configure VoIP and IFID2 as a filter.

=> Assuming that the HA knows which packet is VoIP and 
assuming that IFID1 does not chnge to mean WLAN or fixed LAN.

 > > 
 > > Policy Daemon (filter daemon):
 > > Policy daemon is run on HA and MN/MR. MN's daemon exchanges
 > > information of filters which associate IFID and flow type with HA's
 > > daemon. 

=> So this daemon knows MIP right? It knows the HA, home 
address(es) and Care-of addresses somehow. Why do we 
need a new daemon when we can already use MIP? 

Hesham