Subject: RE: [mobile-ip] Multiple CoA registration

From: Soliman Hesham <[email-masked]>
Date: Fri, 4 Jul 2003 03:55:47 -0400

> yes, It is similar, because I used to work on the same idea of you.
 > You can check my former research. The topic of my master 
 > thesis was same
 > of your draft. My thesis is written in Japanese:-<,  if you are
 > interested in, I could send copy of my "English" paper.
 > 
 > But the multiplecoa draft only targets on multiple CoAs 
 > registration. 
 > In my draft, I want to separate policy management and binding 
 > management (i.e. multiple CoAs registration).
 > I don't think MIP is only way to notify policy, but MIP is 
 > the only way
 > to manage the binding:-)
 > 
 > If there are plenty of policies. managing policy sometime 
 > cause a lot of BU.
 > If MN has a lot of policies, each BU also becomes really large... 

=> This seems the same in both drafts. We don't tell people
how to set their policies but how to use MIP in manage
the bindings.

 > 
 > Our proposed ID in our draft can be used to distinguish the 
 > bindings and
 > can be used as an ID of policy DB (i.e. something like SPI 
 > of IPsec), too.
 > 
 > If user has a static policy, it is simple. Just set up the policy
 > statically with the appropriate ID number of binding.
 > MN and HA can manage policy by _anyway_. maybe applications, maybe
 > static configuration, maybe your draft.

=> No we don't assume any static config. In fact there is no
assumption at all about how policies are set.

 > 
 > I can not understand clearly how to manage multiple CoAs 
 > bounded to same
 > HoA in your draft. 
 > How does MN register multiple CoAs if there are no rules to 
 > direct flows? 
 > (for example, just registering multiple CoAs for backup purpose)

=> This is not the aim of the flow movement draft. If you
want to achieve this please see:
http://www.ietf.org/internet-drafts/draft-elmalki-mobileip-bicasting-v6-03.t
xt

You can also combine the two mechanisms (as stated 
in draft-elmalki..) to achieve bicasting of some
flows and not all.

Hesham

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 04 Jul 2003 17:17:38 +0900

> how to set their policies but how to use MIP in manage

The use of MIP becomes expensive operations in some situation.

> assumption at all about how policies are set.

OK. but I need static configuration support

> in draft-elmalki..) to achieve bicasting of some

I will check this draft.  
Can I register multiple CoAs to CN by draft-elmalki-?

regards,
ryuji

---

From: Thomas Noel <[email-masked]>
Date: Fri, 04 Jul 2003 13:20:33 +0200

Hesham, Ryuji ,

It seems to me that MIPv6 specifications does not propose any solution
to solve multiple interfaces issues on a mobile node.

There are now several drafts to describe some new solutions  :

- Multiple CoAs registration - draft-ryuji ..
- Flow movement in Mobile IPv6 - draft-soliman....
- MIPv6 for Multiple Interfaces - draft-montavont...
....

It would be interesting to discuss at the next IETF how to propose a
new solution to solve all of these issues.

regards

Thomas