Subject: Re: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0 0.txt

From: Francis Dupont <[email-masked]>
Date: Wed, 30 Jul 2003 15:20:21 +0200

From: "Francis Dupont" >
   
   => as a cross-version tunnel will never be "optimized" (i.e., MN-CN direct
   > communication is not possible), IMHO mobile-ip solutions are clearly
   > overkilling in this kind of environments: a smart "road warrior" IPsec
   > VPN will be enough. Today two parts are missing:
   >  - cross-version IPsec tunnels are not commonly available (note for
   >    IPsec implementors: they are specified in RFC 2401, why do you not
   >    support them?)

   Are you recommending that all mobile phone operators should create IP VPN's
   for all phones on their network and to maintain them for visitors and
   roamers on other networks?
   
=> you already have a "VPN" between the MN and the HA in MIPv6, so
I feel free to recommend this (:-).

   This sounds like a lot of IP VPNs to create and maintain across multiple
   networks for people who roam, and unnecessary for those that don't.

=> I don't understand the "multiple networks" argument. The "VPN" is just
an IPsec SA pair (MIPv6 uses two pairs) between a mobile and a fix point
(the mobile-ip Home Agent).

   We are not talking dial-up users or even data users, jut straight
   3G, GPRS, or WAP users.
   
=> we are talking about IP users.

Regards

[email-masked]

---

From: Tsirtsis George <[email-masked]>
Date: Wed, 30 Jul 2003 09:54:26 -0400

Francis,

Not all is solved with VPN tunnels even if you manage to renegotiate the VPN
tunnel automatically when the mobile moves...BTW, I think this is a worthy
goal too and there are products already that support that kind of idea
combining MIPv4 and IPSEC.

There are other people, however, that would like to use Mobile IP (v4 or v6)
for local mobility management in a wireless operator kind of
environment....in which case it would be preferable not to have to use two
mobility management protocols.

You not being interested in that approach does not make this a non-issue
:--)

George

-----Original Message-----
From: Francis Dupont [mailto:[email-masked]] 
Sent: Wednesday, July 30, 2003 2:20 PM
To: EricLKlein
Cc: [email-masked]; [email-masked]
Subject: Re: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0
0.txt 

 In your previous mail you wrote:

   From: "Francis Dupont" >
   
   => as a cross-version tunnel will never be "optimized" (i.e., MN-CN
direct
   >    IPsec implementors: they are specified in RFC 2401, why do you not

   Are you recommending that all mobile phone operators should create IP
VPN's
   for all phones on their network and to maintain them for visitors and
   roamers on other networks?
   
=> you already have a "VPN" between the MN and the HA in MIPv6, so I feel
free to recommend this (:-).

=> I don't understand the "multiple networks" argument. The "VPN" is just an
IPsec SA pair (MIPv6 uses two pairs) between a mobile and a fix point (the
mobile-ip Home Agent).

Regards

---

From: Soliman Hesham <[email-masked]>
Date: Thu, 31 Jul 2003 00:18:46 -0400

Hi Wolfgang, 

We didn't address solutions yet but it's a good time to
talk about it.

 > As MIPv6 will use IPsec in tunnel mode between MN and HA,

=> Only for RO messages between the MN and CN (HOTI and HOT)

 I 
 > assume a MIPv6 MN in a v4 only foreign network will set up a 
 > "v6 over v6 over v4" bi-directional tunnel to its HA (with 
 > the first v6 being the outer header of the IPsec packet 
 > based on the CoA, and the second v6 being the inner header 
 > based on the HoA), not just a v6 over v4 one.

=> This setup would be applicable to HOTI/HOT messages
only, unless the MN decides to protect all traffic through
the HA, which is not a MIP issue. But for HOTI/HOT this would
be required according to MIPv6. 

Hesham

 > Wolfgang
 > > From: Alain Durand [mailto:[email-masked]] 
 > > Sent: Wednesday, July 30, 2003 12:23 AM
 > > To: Tsirtsis George
 > > Cc: Mobile-Ip ([email-masked]); 
 > > [email-masked]; Soliman
 > > Hesham; 'Thomas Narten'
 > > Subject: [mobile-ip] Re: FW: I-D 
 > > ACTION:draft-tsirtsis-dsmip-problem-00.txt
 > > 
 > > 
 > > Hi George,
 > > 
 > > Thank you for writing this draft, this is an interesting 
 > > perspective. There is one point you do not mention: what if 
 > > the IPv6 node is using directly or indirectly IPv6 in IPv4 
 > > tunnels for its IPv6 connectivity? For example, it may derive 
 > > a 6to4 prefix from its home address and then uses MIPv4.... 
 > > There are extra complexities here that I'm not sure I fully 
 > > understand. Is it a problem space that you intend to cover?
 > > 
 > > 	- Alain.
 > > 
 > > On Tuesday, July 29, 2003, at 12:17  PM, Tsirtsis George wrote:
 > > 
 > > > Hi all,
 > > >
 > > > During the Mobile IP WG meeting in Austria, Hesham and 
 > > myself brought 
 > > > up the issue of mobility management for dual stack nodes.
 > > >
 > > > Thomas N. requested that we put together a problem 
 > > statement so that 
 > > > we can discuss the issue; the draft below was published 
 > > today - it is 
 > > > short and I
 > > > hope to the point - so do read it :)
 > > >
 > > > I have copied v6ops since I think this is a v4 - v6 
 > > migration issue as 
 > > > well as Mobile IPv4 and Mobile IPv6 issue.
 > > >
 > > > Let us know what you think.
 > > >
 > > > George
 > > >
 > > >
 > > >
 > > > From: [email-masked] [mailto:[email-masked]]
 > > > Sent: Tuesday, July 29, 2003 5:15 PM
 > > > Subject: I-D ACTION:draft-tsirtsis-dsmip-problem-00.txt
 > > >
 > > >
 > > > A New Internet-Draft is available from the on-line 
 > Internet-Drafts
 > > > directories.
 > > >
 > > >
 > > > 	Title		: Mobility management for Dual stack 
 > > mobile nodes  A
 > > >
 > > >                           Problem Statement
 > > > 	Author(s)	: G. Tsirtsis, H. Soliman
 > > > 	Filename	: draft-tsirtsis-dsmip-problem-00.txt
 > > > 	Pages		: 4
 > > > 	Date		: 2003-7-29
 > > > 	
 > > > This draft discusses the issues associated with mobility 
 > management
 > > > for dual stack mobile nodes. Currently, two mobility management 
 > > > protocols are defined for IPv4 and IPv6. Deploying both 
 > in a dual 
 > > > stack mobile node introduces a number of inefficiencies. 
 > Deployment 
 > > > and operational issues motivate the use of a single mobility 
 > > > management protocol. This draft discusses such motivations. 
 > > The draft 
 > > > also hints on how current MIPv4 and MIPv6 could be 
 > extended so that 
 > > > they can support mobility management for a dual stack node.
 > > >
 > > > A URL for this Internet-Draft is:
 > > > 
 > > 
http://www.ietf.org/internet-drafts/draft-tsirtsis-dsmip-problem-00.tx
> > t
> >
> > To remove yourself from the IETF Announcement list, send a 
> message to
> > ietf-announce-request with the word unsubscribe in the body of the 
> > message.
> >
> > Internet-Drafts are also available by anonymous FTP. Login with the 
> > username "anonymous" and a password of your e-mail address. After 
> > logging in, type
> > "cd internet-drafts" and then
> > 	"get draft-tsirtsis-dsmip-problem-00.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-tsirtsis-dsmip-problem-00.txt".
> > 	
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 		
> > 		
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the 
> > Internet-Draft.
> >
> >
> > Date: Tue Jul 29, 2003  9:40:01  AM US/Pacific
> > To:
> > Subject:
> >
> >
> >
> > <ATT19898.txt>
> >
>

---

From: Tsirtsis George <[email-masked]>
Date: Thu, 31 Jul 2003 04:19:28 -0400

Alain,

I am not sure where Mipv6/Ipv6/Mipv4/IPv4 comes from in your e-mail and I am
not even sure what it means. MIPv4 and MIPv6 are signaling protocols....and
do not introduce overhead in the data path.

We can always complicate things but why not deal with the simple and by far
most important issue.

Today Mobile IP signals HoA to CoA bindings of the same version resulting in
either IPv4 over IPv4 encapsulation or IPv6 over IPv6 encapsulation.

All I am suggesting is that Mobile IP should be able to signal HoA to CoA
bindings of different versions so that IPv4 over IPv6 encapsulation or IPv4
over IPv6 encapsulation is also possible.

George

-----Original Message-----
From: Alain Durand [mailto:[email-masked]] 
Sent: Wednesday, July 30, 2003 6:19 PM
To: Tsirtsis George
Cc: Mobile-Ip ([email-masked]); [email-masked]; Soliman
Hesham; 'Thomas Narten'

On Wednesday, July 30, 2003, at 01:48  AM, Tsirtsis George wrote:

> Now, when the mobile is  not at home but in some other network, there
> is an
> issue about what kind of v4/v6 support there is in the foreign 
> network. The
> nice thing about Mobile IP is that it is based on tunnels and thus it
> provides natural way of tunneling over networks that are not 
> compatible with
> the mobile ...if only Mobile IP could configure v4 over v6 and v6 over 
> v4
> tunnels (as opposed to just v4 over v4 and v6 over v6 tunnels). A dual 
> stack
> mobile in a v4 only foreign network would then be able to create a 
> v4&v6
> over v4 (forward and reverse) tunnel with its HA and thus maintain all 
> its
> connectivity.

Call me skeptic, but I am a little concern with the potential effect of 
double or
even worse  triple tunneling: Mipv6/Ipv6/Mipv4/IPv4
and I'm sure we could build scenarios even more frightening with various
combination of encapsulation. I'm not worried about MTU, but about RTT and
debugging.

	- Alain.

---

From: Tsirtsis George <[email-masked]>
Date: Thu, 31 Jul 2003 16:20:40 -0400

I think you might be expecting too much :-) ...but we will try.

George

-----Original Message-----
From: Fred Templin [mailto:[email-masked]] 
Sent: Thursday, July 31, 2003 9:18 PM
To: Tsirtsis George
Cc: Mobile-Ip ([email-masked]); [email-masked]
Subject: Re: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0
0.txt

Tsirtsis George wrote:

>GT> Or alternatively use MIPv4 and register you IPv6HoA to the IPv4CoA
>binding to the HA without having to get an IPv6 address using ngtrans 
>tools.
>
I will be interested to see your proposals when they appear; especially if
they also account for the case of the IPv4CoA being from a private
addressing space behind a NAT.

Fred
[email-masked]