Subject: RE: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0 0.txt

From: Soliman Hesham <[email-masked]>
Date: Tue, 5 Aug 2003 11:02:18 -0400

> > We can always complicate things but why not deal with the 
 > simple and by far
 > > most important issue.
 > > 
 > > Today Mobile IP signals HoA to CoA bindings of the same 
 > version resulting in
 > > either IPv4 over IPv4 encapsulation or IPv6 over IPv6 
 > encapsulation.
 > > 
 > > All I am suggesting is that Mobile IP should be able to 
 > signal HoA to CoA
 > > bindings of different versions so that IPv4 over IPv6 
 > encapsulation or IPv4
 > > over IPv6 encapsulation is also possible.
 > 
 > And what benefit, exactly, would the change in encapsulation 
 > have?  

=> Did you see the problems in the draft? I'll sumarise:
- half the signalling in the local and home domain
- One mobility management protocol is used.
- IPv6 Connections survive moving from a dual stack network
to a V4 only network.

   The 
 > Home Agents and the nodes would still have to support both 
 > versions, you 
 > would just end up with two Mobile IP protocols which (to 
 > some extent) 
 > supported both IPv4 and IPv6.

=> Only one MIP version is needed. Of course a dual stack
is needed in the HA and MNs but _not_ dual MIP versions.

 > It seems like HIP fits the bill quite nicely, and would be 
 > architecturally 
 > better approach than trying to glue MIPv4 and MIPv6 together somehow.

=> This is not a research project though. MIP is  
deployed as we speak. 

Hesham

---

From: Pekka Savola <[email-masked]>
Date: Wed, 6 Aug 2003 12:16:37 +0300 (EEST)

> => Did you see the problems in the draft? I'll sumarise:

I looked at them quickly, but was not convinced.

> - half the signalling in the local and home domain

Assuming the signalling is identical enough that they could be bundled 
together, and only one protocol could be used.  I don't believe this is 
the case..

> - One mobility management protocol is used.

These mobility management protocols are not interchangeable.  They have 
significant differences.  I do not think it is appropriate to think that 
we could accomplish the functions of one with the other.  If so, it would 
certainly require some (even a great deal of) glue to hold it together, 
and the end result might be even worse than the other alternatives.

> - IPv6 Connections survive moving from a dual stack network

Already happens if you enable e.g. 6to4 to gain IPv6 connectivity.  If you 
had IPv6 connectivity in the past, but move somewhere where there is none, 
I think surviving the connections is not your biggest worry.

> is needed in the HA and MNs but _not_ dual MIP versions.

Which means the one MIP version would have to include all the features of 
the other MIP version because otherwise it would not work?  I.e., in 
practice dual MIP versions but just glued together in one?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings