Subject: [mobile-ip] neighbor Discovery for Mobile IPv6

From: Audsin <[email-masked]>
Date: Fri, 08 Aug 2003 18:05:46 +0100

Respected Sir / madam

I wish to know whether the Neighbor discovery procedure (neighbor 
solicitation, neighbor advertisement, router advertisement ) know that 
mobile IPv6 is enabled in a particular host as per the MIPv6 draft 24.

Does the neighbor discovery procedure detect that MIPv6 is running in a 
particular system as per the MIPv6 draft 24 ( does the Neighbor discovery 
procedure aware of the MIPv6 if it is enabled in a particular host )

Best regards
Dev

---

From: Greg Daley <[email-masked]>
Date: Mon, 11 Aug 2003 13:50:44 +1000

Dear Dev,

It's typically best not to cross-post to two lists.

> mobile IPv6 is enabled in a particular host as per the MIPv6 draft 24.

Neighbour discovery is used to detect movement in
Mobile IPv6.

At the time that recent drafts of MIPv6 were being written,
there has been some work to make movement detection using this
mechanism more prompt and robust.

This work has in part led to formation of a BoF called
Detecting Network Attachment, which hopes to find solutions
to these issues.

> particular system as per the MIPv6 draft 24 ( does the Neighbor 
> discovery procedure aware of the MIPv6 if it is enabled in a particular 
> host )

It's not particularly clear what you mean here.
If you're talking about knowledge within one host,
then I'd say the ND subsystem doesn't explicitly have to know
about MIPv6, although Mobile IPv6 will need to inspect
ND packets, and may force sending of them.

For ND systems on other hosts, they won't know if any other
host is undertaking Mobile IPv6.

Greg