Subject: [mobile-ip] [About Multiple Home Address]

From: "Jinwoo Jung" <[email-masked]>
Date: Fri, 29 Aug 2003 09:59:20 +0900

Dear all,

I have some question for MIPv6 registeiron.

If a mobile node have multiple interface, then I think it can generate multiple native IPv6 address in home network.

In this case, if the mobile node make different connection by using diverse home address located in home network,

how can it register its home address with Home Agent ?

I think two possible methods. 

first, register its multiple home address by using multiple home address option with HA (one registeraion)

second, register mutthe hoem address by the seperated BU  with HA (multiple registration).

Is there any popular or standard method ?

Thanks in advance.

========================================================
Ph. D candidate , Electronics @ Information Engineering
Korea Univeristy, [email-masked]
016-708-0575, +82-2-3290-3989

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Aug 2003 13:30:16 +0300

Jinwoo Jung wrote:
> If a mobile node have multiple interface, then I think it can generate 
> multiple native IPv6 address in home network.

The number of interfaces and home addresses isn't necessarily
related. If your home address is based on the MAC address,
then there's a relation, but otherwise you could have multiple
home adresses even if you have just one interface.

> In this case, if the mobile node make different connection by using 
> diverse home address located in home network,
>  

The current specification (as approved) allows a single home address to
be registered at one time. We previously had a feature to allow
multiple home addresses with the same IID but different prefix be
registered in one message, but it got removed. But this would not
have worked for you anyway, as I think you were after really
separate addresses.

So at this time the standard approach is to send separate BUs.

--Jari