Subject: Re: [mobile-ip] I-D ACTION:draft-hoon-mobileip-undad-00.txt

From: Erik Nordmark <[email-masked]>
Date: Thu, 23 Oct 2003 11:18:13 +0200 (CEST)

> The original RFC 2462 DAD is very strong and reliable.
> Just packet losses cause it to be unreliable. But, the all protocols
> are affected by the packet losses.

FWIW it isn't only packet loss that makes it unreliable.
The other case is link partitions.

If the L2 link is partitioned (e.g. down Ethernet switch) when DAD
is performed and the partition later heals then you can end up
with undetected duplicate addresses.

  Erik

---

From: "Ed Remmell" <[email-masked]>
Date: Thu, 23 Oct 2003 11:57:29 -0700

> Firstly, what L2 trigger can help the deregistration?
> So the NCE management seems to be complicated and be a scheme 
> depending on the L2 technology.
> I think that many people maybe feel uneasy about the 
> combination IPv6 core protocol and L2 module.

Yup. I'm very uncomfortable with using a L2 trigger for this purpose.
When the MN moves to a new link, you cannot assume it is capable of
being able to signal to its old access router on the old link (that it
moved from) to have the old AR delete the NCE.

Thanks.
- Ed

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003