Subject: [mobile-ip] ICMP Router Discovery

From: "Yohannes" <[email-masked]>
Date: Thu, 16 Oct 2003 11:37:28 -0400

Hi all,

        I am trying to test ICMP Router Discovery protocol that I have written.  Is there a way to test if the implementation of the protocol is functioning?  If you can give me a hint on the scenario I need to set up before I can test it.  

Thanks

Yohannes

---

From: Greg Daley <[email-masked]>
Date: Fri, 17 Oct 2003 09:24:52 +1000

G'day Johannes,

Yohannes wrote:
> Hi all,
>  
>         I am trying to test ICMP Router Discovery protocol that I have 
> written.  Is there a way to test if the implementation of the 
> protocol is functioning?  If you can give me a hint on the scenario I 
> need to set up before I can test it. 

You'll need a host and a router for basic router
discovery.

If you're interested in movement detection/detecting
network attachment, you'll need a couple of network
segments with routers on them to switch between.

Also, you may want to test multiple routers on one
subnet with a common set of prefixes, or multiple
routers on a subnet where the prefixes overlap,
but aren't common, or multiple routers with
disjoint prefixes on one link-instance.

I'm not sure which device is your DUT, (I'm
guessing the MN) but I'd guess that there
are conformance test tools (TAHI? UNH?) which
cover this stuff.

Greg Daley

---

From: "Yohannes" <[email-masked]>
Date: Fri, 17 Oct 2003 10:46:18 -0400

Hi Greg,

    Thanks for your help.  My DUT is the MN.  Do you know which Routers
support Mobile-ip Protocols?

Yohannes

---

From: Greg Daley <[email-masked]>
Date: Mon, 20 Oct 2003 09:49:53 +1000

Hi Yohannes,

We're using Linux boxes with (slightly
modified) RADVD.

Greg