Subject: [mobile-ip] Comment on MIPv6 I-D

From: Frank Quick <[email-masked]>
Date: Fri, 03 Oct 2003 08:59:30 -0700

In section 10.3.1:

"To begin processing the Binding Update, the home agent MUST perform the 
following sequence of tests:

...

   o  A Home Address destination option MUST be present in the message.

..."

11.7.1 says essentially the same thing on page 131:

"   o  The packet MUST contain a Home Address destination option, giving
       the mobile node's home address for the binding."

This seems to moot some of the text in 11.7.1, page 132:

"The mobile node MUST use its home address - either in the Home Address 
destination option or in   the Source Address field of the IPv6 header - in 
Binding Updates sent to the home agent."

This sentence implies that the node has the option of EITHER/OR whereas the 
preceding text would say the node MUST include the Home Address destination 
option, and (presumably) MAY also use the home address as the Source 
Address.  I'd suggest that this sentence be deleted, or amended to reflect 
the fact that the home address as Source Address is allowed but the 
destination option is mandatory.

---

From: Soohong Daniel Park <[email-masked]>
Date: Sat, 04 Oct 2003 11:54:14 +0900

One more

editorial: P 71

o The node MUST be able validate a Home Address option using an
   existing Binding Cache entry, as described in Section 9.3.1.

s/be able/be able to...:-)

Soohong Daniel Park @SAMSUNG.COM

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Frank Quick
> Sent: Saturday, October 04, 2003 1:00 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Mip6] Comment on MIPv6 I-D
> 
> 
> In section 10.3.1:
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6
>