Subject: [Mobopts] "Edge Handovers"

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Tue, 10 Feb 2004 11:49:41 +1100

G'day Mobopts-folk ...

	We've been playing with ways to manage handovers on the
edge network, is this the kind of thing which is on charter for
this group?  Would people be interested in discussing further
at Seoul?

	I wasn't sure of the official procedure for submitting
documents to IRTF, so I just put it up as an individual submission,
<draft-moore-mobopts-edge-handovers-00.txt>.  If it's not there
yet, try under <http://bluesky.zoic.org/sharkey/>.

Abstract: 

| Edge Handovers (EH) is an interoperable enhancement to Mobile IPv6 to
| reduce handover latency for movement within an edge network, and to
| reduce handover signalling outside the edge network.
| 
| EH does this by tunnelling traffic within the edge network.
| Multiple handovers per Home Agent are also allowed, and EH also
| considers the situation where a MN anticipates that it is about to move
| but does not know where it is about to move to.

enjoy,
	Nick
-- 
Nick Moore, Resarch Fellow        | <[email-masked]>
Monash University CTIE	          | <http://www.ctie.monash.edu.au/ipv6/>
Australian Telecommunications CRC | <http://www.telecommunications.crc.org.au/>

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: William Arbaugh <[email-masked]>
Date: Tue, 10 Feb 2004 08:45:22 -0500

I think this is something that would be interesting to hear about. Do 
you have simulation or implementation results?

While it is nice to hear ideas, we'd really prefer to see them backed 
up with results.

On Feb 9, 2004, at 7:49 PM, Nick 'Sharkey' Moore wrote:

> Australian Telecommunications CRC | 
> <http://www.telecommunications.crc.org.au/>
>

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Wed, 11 Feb 2004 16:59:37 +1100

> you have simulation or implementation results?

G'day William,

	We'll be extending our implementation of HMIPv6 for Linux
to support the HMIP-like version of EH and doing some testing.
We're also working on simulation of various protocols and 
suggested modifications with OMNeT++.
	
> While it is nice to hear ideas, we'd really prefer to see them backed 

	Agreed, thought I'd 'release early' and let other IRTF
folks know what we're working on ... in terms of results, you
might be interested in our testing results for non-predictive
handovers which we mention in:

	<http://bluesky.zoic.org/sharkey/no_predict.pdf>

-----Nick

---

From: "Christian Vogt" <[email-masked]>
Date: Wed, 11 Feb 2004 09:18:29 +0100

Hi Nick,

I like Edge Handovers because of the flexibility with which MNs can choose their communications anchor point (which in this case is their BAR).

Still, apart from the buffering service that a MN may request from its BAR, Edge Handovers appear to be equivalent to the following HMIPv6 setting:

(1) Use HMIPv6
(2) Put MAP functionality into each AR 
    (i.e., each MAP domain is a single subnet)
(3) Allow each MAP to forward packets to LCoAs from other MAP's domains
    (see section 8 of draft-ietf-mipshop-hmipv6-00.txt)

I might be missing something. Just let me know.

Best regards,

- Chris

|
| Christian Vogt
| Institute of Telematics, University of Karlsruhe (TH)
| www.tm.uka.de/~chvogt/
|

----- Original Message ----- 
From: "Christian Vogt" <[email-masked]>
To: "Christian Vogt" <[email-masked]>
Sent: Wednesday, February 11, 2004 9:15 AM

> | but does not know where it is about to move to.

¡º)¶ÉšŠX§‚X¬´Ê¢›lŠ»_¢¸!¶Úlÿü0ÃXžµú+ƒùšŠYšŸùb²Ø§~æ¡º)¶

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Wed, 11 Feb 2004 20:26:18 +1100

On 2004-02-11, Christian Vogt wrote:
> Hi Nick,
> 
> I like Edge Handovers because of the flexibility with which
> MNs can choose their communications anchor point (which in
> this case is their BAR).

Thanks.

> Still, apart from the buffering service that a MN may request
> from its BAR, Edge Handovers appear to be equivalent to the
> following HMIPv6 setting:

Yep.  Pretty much.  The possibility of placing MAPs at the edge
is even explicitly mentioned in HMIPv6 section 10.2:

| Network operators may choose a flat architecture in some cases where 
| a Mobile IPv6 handover may be considered a rare event. In these 
| scenarios operators may choose to include the MAP function in ARs 
| only.

but note that HMIPv6 has considered it only where 'handover may be
considered a rare event'.

EH extends the HMIP MAP-to-MAP handover behaviour to allow
the MN to defer its formation of a new RCoA indefinitely[1].
This means it can:

	* allow multiple handovers per BU-to-the-HA.  

	* defer the configuration of the new RCoA (and any 
	DAD or security signalling which may need to
	be done) to after the time critical phase
	of the handover.

... thus making it suitable where handover is not a rare event.

EH-00 uses a lot of HMIP components to avoid reinventing the wheel,
thus simplifying implementation and testing, and avoiding 
incompatibility problems.  Some of the techniques (especially
the buffering) could be easily fed back into HMIP.  For a view
of EH without HMIP , see the 'Alternative Version' (section 7) ... 
	
Thanks for your feedback!

cheers,
-----Nick

[1] Well, until the bound RCoA binding expires or the MN runs out
of EH coverage, anyway.  See the heuristics (section 5) and assume
N = several :-).

---

From: "Christian Vogt" <[email-masked]>
Date: Wed, 11 Feb 2004 13:59:58 +0100

Hi Nick! Hi MobOpts folks!

> EH-00 uses a lot of HMIP components to avoid reinventing the
> wheel. [...] Some of the techniques (especially the
> buffering) could be easily fed back into HMIP.[...]

The buffering feature is probably a security concern of Edge Handovers which is *not* covered by HMIPv6: A malicious MN may illegitimately occupy buffer space at an Access Router. (There is a similar buffering mechanism in FMIPv6, and it is a security issue there as well.) However, since Edge Handovers - as well as HMIPv6 - are likely to be employed in domains with a single administration, you may assume some kind of a security association between the domain and the MNs.

We recently submitted a new Internet-Draft, draft-vogt-mip6-early-binding-updates-00.txt, to the mip6 Working Group of the IETF. The I-D proposes Early Binding Updates for Mobile IPv6, an optional extension to Mobile IPv6's Route Optimization mode (see abstract below). While Edge Handovers are a local optimization, Early Binding Updates are a global one. The two approaches may well complement one another.

   Abstract:
   The long latency associated with Mobile IPv6's home-address and
   care-of-address tests can significantly impact delay-sensitive
   applications. We propose a modified binding-update procedure that
   evades the latency of both address tests. The modified binding update
   runs in half, or less, of the time that a standard binding update
   takes. Moreover, the modified binding update is nearly equivalent to
   the standard procedure with respect to security, and it increases the
   resources required at the correspondent node only marginally. The
   modification is realized as an optional, and fully
   backward-compatible, extension to Mobile IPv6.

   C. Vogt, R. Bless, M. Doll, T. Kuefner: "Early Binding Updates for Mobile IPv6",
   http://www.ietf.org/internet-drafts/draft-vogt-mip6-early-binding-updates-00.txt

There has been some discussion about Early Binding Updates on the mip6 mailing list. As Early Binding Updates is a handover optimization, the proposal also fits into the MobOpts charter. I would definitely appreciate feedback from the MobOpts group.

Best regards,

- Christian

|
| Christian Vogt
| Institute of Telematics, University of Karlsruhe (TH)
| www.tm.uni-karlsruhe.de/~chvogt/
|

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Thu, 12 Feb 2004 08:05:02 +1100

On 2004-02-11, Christian Vogt wrote:
> The buffering feature is probably a security concern of Edge
> Handovers which is *not* covered by HMIPv6: A malicious MN may
> illegitimately occupy buffer space at an Access Router.

Good point.  I'll add it to 'Security Concerns'.  I don't think
it's a biggie though, because the AR can choose to just start
discarding packets.

> However, since Edge Handovers - as well as HMIPv6 - are likely
> to be employed in domains with a single administration, you may
> assume some kind of a security association between the domain
> and the MNs.

I don't think this is true: I think a likely scenario for both
is a 'Campus Area Network' or larger, where you really can't trust
the customers, beyond what you can learn in AAA.  I think there's
an assumed trust between EH-ARs -- the NAR has to (perhaps
briefly) carry traffic to/from the BAR despite having no
association with the MN (yet).  That should presumably be in
'Security Concerns' too.

> We recently submitted a new Internet-Draft,
> draft-vogt-mip6-early-binding-updates-00.txt,

I had a flick through it, will read it properly later.  It seems
like we're working on similar things anyway :-)!

> There has been some discussion about Early Binding Updates on
> the mip6 mailing list. As Early Binding Updates is a handover
> optimization, the proposal also fits into the MobOpts charter.

Which reminds me:  what _is_ the right place these days?

-----Nick

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 12 Feb 2004 10:03:25 -0800

Folks,

> Which reminds me:  what _is_ the right place these days?

For Mobopts, we would like proposals that are experimental works
which could shed light on interesting problems. The result of the
discussion should lead to standardization in IETF and possibly IEEE.
In other words, treat Mobopts as an opprtunity to discuss your new
findings and figure out what needs to be standardized. It is crucial to
substantiate your findings before we can arrive at _why_ something
needs to be standardized.

-Rajeev

---

From: William Arbaugh <[email-masked]>
Date: Thu, 12 Feb 2004 16:04:53 -0500

Let me add to what Rajeev said by saying it also helps (but not 
required) if you can point to people or a group of people that need the 
technology.

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Fri, 13 Feb 2004 12:54:33 +1100

> | reduce handover signalling outside the edge network.

Greg Daley points out that I first heard of the Buffering idea
used in section 4.2 from Richard Nelson, who used to work with
us but is now at Waikato Uni.  He's since developed the idea in
a slightly different direction but I should have acknowledged
his contribution anyway: it'll be in -01.

(PS:  G'day Richard!  Draft is <draft-moore-mobopts-edge-handovers-00.txt>
by me, JinHyeock Choi of Samsung and Brett Pentland, by the way ...
let me know how you'd like to be acknowledged.)

-----Nick