Subject: [Mobopts] consecutive FMIP-handovers

From: ogawa <[email-masked]>
Date: Mon, 23 Feb 2004 16:08:39 +0900

Hi Mobopts folks,

Concerning with circumstances where handover happens 
consecutively, to reduce the number of messages (BU/ BA) 
between MNs and HA is one of the major issues.

Variable solutions would be exist, but I think there might be 
simpler one based on plain FMIPv6.

Main point of this idea is simply separating a router 
terminating FBU from a router terminating RtSolPr during 
consecutive FMIP-handovers.
Most of all messages and processing are same as plain FMIPv6.

An example of sequence is shown in fig. A below.

       MN         A-R         PAP         NAR
       |           |           |           |
       |        RtSolPr        |           |
       |---------------------->|           |
       |           |           |           |
       |        PrRtAdv        |           |
       |<----------------------|           |
       |           |           |           |
       |   FBU     |           HI          |
       |---------->|---------------------->|
       |           |           |           |
       |   FBACK   |          HACK         |
       |<----------|<----------------------|
       |           |           |           |
       |           |   FNA     |           |
       |---------------------------------->|
       |           |           |           |
       |           |   NAACK   |           |
       |<----------------------------------|

                       fig. A

A MN uses a particular router as an anchor-router (A-R) 
during consecutive handovers.

The A-R may be an access router that the MN attached first 
time or may be other router between the access router and 
the MN's HA. 
As a handover is initiated, the MN sends RtSolPr to PAR and 
get NAR's IP address, and it sends FBU to the A-R instead of 
PAR. (In some case, the A-R and the PAR are same)
The A-R acts as a PAR of plain FMIPv6 and sends HI to the 
NAR and get HACK from the NAR, and starts sending IP in IP 
packet to NCoA.
The MN dose not send BU to its HA until it changes its A-R. 

One problem of this method is how the MN gets the IP address 
of first A-R. This is common to plain FMIP and HMIP, and the 
results of them might be applied.

Second problem of this method is how the MN gets the next 
A-R. I suppose one solution is adding new option to PrRtAdv 
informing the MN the IP address of next A-R.

I would appreciate it if I hear your comment on this idea.

Best regards,
  -Takeshi

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: "Christian Vogt" <[email-masked]>
Date: Mon, 23 Feb 2004 14:40:32 +0100

SGkgT2dhd2E6DQoNCkRpZCB5b3UgdGFrZSBhIGxvb2sgYXQgSE1JUHY2PyANCg0KSWYgSSBhbSBub3QgbWlzdGFrZW4sIHRoZW4geW91ciBhcHByb2FjaCBpcyB2ZXJ5IHNpbWlsYXIgdG8gaG93IHRoZSBITUlQdjYgZm9sa3MgdHJ5IHRvIGNvbWJpbmUgSE1JUHY2IHdpdGggRk1JUHY2LiAoU2VlIGFwcGVuZGl4IEEgb2YgWzFdLikgSW4gb3RoZXIgd29yZHMsIHRoZSBNQVAgdXNlZCBpbiBITUlQdjYgaXMgZXF1aXZhbGVudCB0byB5b3VyIHByb3Bvc2VkIGFuY2hvciByb3V0ZXIuIExldCBtZSBrbm93IGlmIEkgYW0gbWlzc2luZyBzb21ldGhpbmcuDQoNCk5vdGUgdGhhdCBhIE1BUCBtYXkgYWxzbyBzZXJ2ZSBhcyBhbiBhY2Nlc3Mgcm91dGVyLiAoU2VjdGlvbiAyLCBwYXJhZ3JhcGggMywgaW4gWzFdLikNCg0KPiBTZWNvbmQgcHJvYmxlbSBvZiB0aGlzIG1ldGhvZCBpcyBob3cgdGhlIE1OIGdldHMgdGhlIG5leHQNCj4gQS1SLiBJIHN1cHBvc2Ugb25lIHNvbHV0aW9uIGlzIGFkZGluZyBuZXcgb3B0aW9uIHRvIFByUnRBZHYNCj4gaW5mb3JtaW5nIHRoZSBNTiB0aGUgSVAgYWRkcmVzcyBvZiBuZXh0IEEtUi4NCg0KSE1JUHY2IHVzZXMgYW4gb3B0aW9uIHRvIHRoZSBSb3V0ZXIgQWR2ZXJ0aXNlbWVudHMsIGNhbGxlZCBhIE1BUCBvcHRpb24sIGZvciB0aGlzIHB1cnBvc2UuDQoNCkJlc3QgcmVnYXJkcywNCg0KDQotIENocmlzdGlhbg0KDQoNClsxXSBodHRwOi8vd3d3LmlldGYub3JnL2ludGVybmV0LWRyYWZ0cy9kcmFmdC1pZXRmLW1pcHNob3AtaG1pcHY2LTAxLnR4dA0KDQoNCnwNCnwgQ2hyaXN0aWFuIFZvZ3QNCnwgSW5zdGl0dXRlIG9mIFRlbGVtYXRpY3MsIFVuaXZlcnNpdHkgb2YgS2FybHNydWhlIChUSCkNCnwgd3d3LnRtLnVrYS5kZS9+Y2h2b2d0Lw0KfA0KDQoNCg0Kb2dhd2Egd3JvdGU6DQo+IEhpIE1vYm9wdHMgZm9sa3MsDQo+IA0KPiBDb25jZXJuaW5nIHdpdGggY2lyY3Vtc3RhbmNlcyB3aGVyZSBoYW5kb3ZlciBoYXBwZW5zDQo+IGNvbnNlY3V0aXZlbHksIHRvIHJlZHVjZSB0aGUgbnVtYmVyIG9mIG1lc3NhZ2VzIChCVS8gQkEpDQo+IGJldHdlZW4gTU5zIGFuZCBIQSBpcyBvbmUgb2YgdGhlIG1ham9yIGlzc3Vlcy4NCj4gDQo+IFZhcmlhYmxlIHNvbHV0aW9ucyB3b3VsZCBiZSBleGlzdCwgYnV0IEkgdGhpbmsgdGhlcmUgbWlnaHQgYmUNCj4gc2ltcGxlciBvbmUgYmFzZWQgb24gcGxhaW4gRk1JUHY2Lg0KPiANCj4gDQo+IE1haW4gcG9pbnQgb2YgdGhpcyBpZGVhIGlzIHNpbXBseSBzZXBhcmF0aW5nIGEgcm91dGVyDQo+IHRlcm1pbmF0aW5nIEZCVSBmcm9tIGEgcm91dGVyIHRlcm1pbmF0aW5nIFJ0U29sUHIgZHVyaW5nDQo+IGNvbnNlY3V0aXZlIEZNSVAtaGFuZG92ZXJzLg0KPiBNb3N0IG9mIGFsbCBtZXNzYWdlcyBhbmQgcHJvY2Vzc2luZyBhcmUgc2FtZSBhcyBwbGFpbiBGTUlQdjYuDQo+IA0KPiBBbiBleGFtcGxlIG9mIHNlcXVlbmNlIGlzIHNob3duIGluIGZpZy4gQSBiZWxvdy4NCj4gDQo+IA0KPiAgICAgICAgTU4gICAgICAgICBBLVIgICAgICAgICBQQVAgICAgICAgICBOQVINCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgIFJ0U29sUHIgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwtLS0tLS0tLS0tLS0tLS0tLS0tLS0tPnwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgIFByUnRBZHYgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHw8LS0tLS0tLS0tLS0tLS0tLS0tLS0tLXwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICBGQlUgICAgIHwgICAgICAgICAgIEhJICAgICAgICAgIHwNCj4gICAgICAgIHwtLS0tLS0tLS0tPnwtLS0tLS0tLS0tLS0tLS0tLS0tLS0tPnwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICBGQkFDSyAgIHwgICAgICAgICAgSEFDSyAgICAgICAgIHwNCj4gICAgICAgIHw8LS0tLS0tLS0tLXw8LS0tLS0tLS0tLS0tLS0tLS0tLS0tLXwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICBGTkEgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwtLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tPnwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHwgICAgICAgICAgIHwgICBOQUFDSyAgIHwgICAgICAgICAgIHwNCj4gICAgICAgIHw8LS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLXwNCj4gDQo+IA0KPiAgICAgICAgICAgICAgICAgICAgICAgIGZpZy4gQQ0KPiANCj4gDQo+IA0KPiANCj4gQSBNTiB1c2VzIGEgcGFydGljdWxhciByb3V0ZXIgYXMgYW4gYW5jaG9yLXJvdXRlciAoQS1SKQ0KPiBkdXJpbmcgY29uc2VjdXRpdmUgaGFuZG92ZXJzLg0KPiANCj4gVGhlIEEtUiBtYXkgYmUgYW4gYWNjZXNzIHJvdXRlciB0aGF0IHRoZSBNTiBhdHRhY2hlZCBmaXJzdA0KPiB0aW1lIG9yIG1heSBiZSBvdGhlciByb3V0ZXIgYmV0d2VlbiB0aGUgYWNjZXNzIHJvdXRlciBhbmQNCj4gdGhlIE1OJ3MgSEEuDQo+IEFzIGEgaGFuZG92ZXIgaXMgaW5pdGlhdGVkLCB0aGUgTU4gc2VuZHMgUnRTb2xQciB0byBQQVIgYW5kDQo+IGdldCBOQVIncyBJUCBhZGRyZXNzLCBhbmQgaXQgc2VuZHMgRkJVIHRvIHRoZSBBLVIgaW5zdGVhZCBvZg0KPiBQQVIuIChJbiBzb21lIGNhc2UsIHRoZSBBLVIgYW5kIHRoZSBQQVIgYXJlIHNhbWUpDQo+IFRoZSBBLVIgYWN0cyBhcyBhIFBBUiBvZiBwbGFpbiBGTUlQdjYgYW5kIHNlbmRzIEhJIHRvIHRoZQ0KPiBOQVIgYW5kIGdldCBIQUNLIGZyb20gdGhlIE5BUiwgYW5kIHN0YXJ0cyBzZW5kaW5nIElQIGluIElQDQo+IHBhY2tldCB0byBOQ29BLg0KPiBUaGUgTU4gZG9zZSBub3Qgc2VuZCBCVSB0byBpdHMgSEEgdW50aWwgaXQgY2hhbmdlcyBpdHMgQS1SLg0KPiANCj4gT25lIHByb2JsZW0gb2YgdGhpcyBtZXRob2QgaXMgaG93IHRoZSBNTiBnZXRzIHRoZSBJUCBhZGRyZXNzDQo+IG9mIGZpcnN0IEEtUi4gVGhpcyBpcyBjb21tb24gdG8gcGxhaW4gRk1JUCBhbmQgSE1JUCwgYW5kIHRoZQ0KPiByZXN1bHRzIG9mIHRoZW0gbWlnaHQgYmUgYXBwbGllZC4NCj4gDQo+IFNlY29uZCBwcm9ibGVtIG9mIHRoaXMgbWV0aG9kIGlzIGhvdyB0aGUgTU4gZ2V0cyB0aGUgbmV4dA0KPiBBLVIuIEkgc3VwcG9zZSBvbmUgc29sdXRpb24gaXMgYWRkaW5nIG5ldyBvcHRpb24gdG8gUHJSdEFkdg0KPiBpbmZvcm1pbmcgdGhlIE1OIHRoZSBJUCBhZGRyZXNzIG9mIG5leHQgQS1SLg0KPiANCj4gDQo+IEkgd291bGQgYXBwcmVjaWF0ZSBpdCBpZiBJIGhlYXIgeW91ciBjb21tZW50IG9uIHRoaXMgaWRlYS4NCj4gDQo+IA0KPiBCZXN0IHJlZ2FyZHMsDQo+ICAgLVRha2VzaGkNCg==_______________________________________________Mobopts mailing [email-masked]://www1.ietf.org/mailman/listinfo/mobopts

---

From: ogawa <[email-masked]>
Date: Tue, 24 Feb 2004 18:37:03 +0900

Hi Christian, Mobopts folks,

Thank you for your comment.
I had missed the appendix (FMIP and HMIPv6), I'm sorry.

The appendix A in [1] shows two scenarios. (Appendix A, 
paragraph 5)
The first one involves placing MAPs in place of the ARs,
and second one involves placing MAPs in place of the 
aggregation routers.

In the first scenario, the round trip time of FBU/FBACK is 
longer than the time in the second scenario, but if the 
aggregation router is placed near the ARs, the round trip 
time of FBU/FBACK might not make serious problem.

And, the number of messages (BU/BA) between MNs and HA will 
be reduced in both scenario.

I suppose the first scenario is adequate if the aggregation 
router is placed near the ARs, and it would be easy to 
implement MAPs (placed only in place of the ARs) and MNs in 
first scenario based on FMIP function.

I suppose H-FMIP and edge-handover have similar target.

How about to compare these protocols?
Did anybody already? 
I'm sorry if I missed it again.

Best regards,
 - Takeshi

"Christian Vogt" <[email-masked]> wrote:

> Hi Ogawa:
> 
> Did you take a look at HMIPv6? 
> 
> If I am not mistaken, then your approach is very similar to how the HMIPv6 folks try to combine HMIPv6 with FMIPv6. (See appendix A of [1].) In other words, the MAP used in HMIPv6 is equivalent to your proposed anchor router. Let me know if I am missing something.
> 
> Note that a MAP may also serve as an access router. (Section 2, paragraph 3, in [1].)
> 
> HMIPv6 uses an option to the Router Advertisements, called a MAP option, for this purpose.
> 
> Best regards,
> 
> 
> - Christian
> 
> 
> [1] http://www.ietf.org/internet-drafts/draft-ietf-mipshop-hmipv6-01.txt
> 
> 
> |
> | Christian Vogt
> | Institute of Telematics, University of Karlsruhe (TH)
> | www.tm.uka.de/~chvogt/
> |
> 
> 
> 
> ogawa wrote:
> > Hi Mobopts folks,
> >

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Thu, 26 Feb 2004 22:10:39 +1100

On 2004-02-23, Christian Vogt wrote:
> If I am not mistaken, then your approach is very similar to
> how the HMIPv6 folks try to combine HMIPv6 with FMIPv6.
> (See appendix A of [1].)

... and not far different from draft-moore-mobopts-edge-handovers-00's
"Alternative Version", either.  That being said, EH is awfully close
to HMIP and FMIP anyway ...

Still, it can't be a totally silly idea if we are all working on it!

-----Nick