Subject: Re: PHP and architecture draft

From: Vasu Vuppala <[email-masked]>
Date: Sat, 29 Jan 2000 23:05:47 -0500

Markus,

check   http://cell.onecall.net/mhonarc/mpls/1999-Jun/msg00008.html
and follow the thread.

- vasu

--- Markus Jork <[email-masked]> wrote:
> I just noticed that the architecture draft
(draft-ietf-mpls-arch-06.txt)
> seems to be somewhat out of sync with reality.
> The section on penultimate hop popping says:
>
> "Initial label distribution protocol negotiations MUST allow each LSR
to
> determine whether its neighboring LSRS are capable of popping the
label
> stack. A LSR MUST NOT request a label distribution peer to pop the
label
> stack unless it is capable of doing so."
>
> Looking at the current label distribution protocols (RSVP and LDP),
none of
> them seems to provide the allegedly mandatory feature to figure out
whether
> a peer is capable of doing PHP.
>
> So what should we do about this issue:
> a) agree that I have misread the I-Ds and just ignore my message,
> b) change the "MUST" in the architecure document to a "SHOULD"
> c) or just ignore this section of the architecture document?
> Fixing the signalling protocols to provide the feature seems to be too

> bothersome.
> Markus

---

From: [email-masked]
Date: Tue, 1 Feb 2000 12:11:49 +0800

Hi Markus,

There is indeed a discrepancy between the requirements stated in the
architecture draft and what actually is available from LDP/RSVP.
In fact this issue has been discussed at length in the mailing list, around
June 1999.
Basically, it is generally felt that the negotiation is not necessary and
the implicit null label can be used in the label mapping msg to
"implicitly" signal to the peer to pop the label stack.

Rgds
Kheng Kok

---------------------------------------------
Mar Kheng Kok
IBM Emerging Technology Centre
Tel: 320-1086 (Direct)
Fax:  224-5260
Internet: [email-masked]

Markus Jork <[email-masked]> on 02/01/2000 01:36:34 AM

To:   [email-masked]
cc:    (bcc: Kheng Kok Mar/Singapore/IBM)
Subject:  PHP and architecture draft

I just noticed that the architecture draft (draft-ietf-mpls-arch-06.txt)
seems to be somewhat out of sync with reality.
The section on penultimate hop popping says:

"Initial label distribution protocol negotiations MUST allow each LSR to
determine whether its neighboring LSRS are capable of popping the label
stack. A LSR MUST NOT request a label distribution peer to pop the label
stack unless it is capable of doing so."

Looking at the current label distribution protocols (RSVP and LDP), none of
them seems to provide the allegedly mandatory feature to figure out whether
a peer is capable of doing PHP.

Markus