Subject: Re: Draft of revised charter

From: "Cheng-Yin Lee" <[email-masked]>
Date: Sun, 23 Jan 2000 22:16:12 -0500

George Swallow wrote:
> > You would be in a position to know, but I was under the
> > impression that RSVP-Tunnels pretty much covers the bases
> > for RSVP-MPLS once you realize that the messages do not
> > have to carry an explicit route object.  I thought this
> > point had been made once or twice already.
> 
> This is pretty much the case for unicast traffic.  Most of the
> technical guts of the RSVP draft was moved to the tunnels draft since
> the former was hung up on some multicast issues.
May i know what are these multicast issues?

thanks,
cyl

---

From: Eric Gray <[email-masked]>
Date: Mon, 24 Jan 2000 02:20:32 -0500

> May i know what are these multicast issues?

Multicast issues in MPLS are manifold (and they
just keep multiplying).

Looping is a major problem in multicast in general,
but it is much worse if using a technology which is
not suited to TTL manipulation.

Some hardware wants to use specific VCI numbers for
each output interface when replicating data.  How to
reconcile this with Downstream Allocation is a small
problem.

There have been multiple proposals and one of the
people who had been pursuing multicast issues in the
past has joined a startup and may not have the time
to pursue it further.

And that's just the economical, political and one of
the technical issues.  Anyone who wants to, please 
feel free to chime in with additional technical, and
other issues...

--
Eric Gray

---

From: "Cheng-Yin Lee" <[email-masked]>
Date: Tue, 25 Jan 2000 16:03:08 -0500

> not suited to TTL manipulation.

Agree, but there are feasible ways to overcome this. I can point you to some
work on this if you're interested.

> reconcile this with Downstream Allocation is a small

Doesn't sound like a lot of problems then :-) ?

thanks,
cyl