Subject: difference between propage and send

From: [email-masked]
Date: Sat, 29 Jan 2000 09:15:49 +0800

Hi,

In the "ldp-state-machine", there appear two word :propagate and send.
Can I think  it as the following?
Propagate a message is: already having a message, and send it.
Send a message is: construct a new message, and send it.

State:          ESTABLISHED
Event:          Internal Downstream Withdraw
New State:      Depends on the action routine.
Actions:
If it uses independent mode, set its state to `IDLE' and create a
internal `LDP Request' and send to its own state machine.
Else     Disconnect the upstream label from the downstream label.
Propagate the LDP-WITHDRAW upstream and go to state     `RELEASE_AWAITED'.
Send the event `Internal Destroy' to the Next_Hop_Trigger_Block's   state
machine if the LSR was in the middle of switching over to the   better next
hop.

State:          ESTABLISHED
Event:          Internal Downstream NAK New
State:      Depends on the action routine.
Actions:
If it uses independent mode, set its state to `IDLE' and create a
internal `LDP Request' and send to its own state machine.
Else     Disconnect the upstream label from the downstream label     Send
an LDP-WITHDRAW upstream and go to state `RELEASE_AWAITED'.   Send the
event `Internal Destroy' to the Next_Hop_Trigger_Block's   state machine if
the LSR was in the middle of switching over to the   better next hop.

Any marks is apperatiated.
Thanks!
Lijianping.

---

From: Eric Gray <[email-masked]>
Date: Sun, 30 Jan 2000 12:55:29 -0500

Lijianping,

	Yes, this is the meaning of "propagate".  A key
distinction in LDP is the existence of TLVs in the LDP
message to be propagated - some of these may need to be
"blind forwarded" (meaning irrespective of whether or not
they are understood) in the message being propagated.