Subject: MTU for tag/MPLS packets

From: "Aijaz Pathan" <[email-masked]>
Date: Fri, 21 Jan 2000 10:05:11 -0800

Hi All,

I was wondering if anyone had info/pointers to how a Tag/MPLS edge node should handle change in the MTU size 
because of addition of 4 bytes of tag header for Ethernet interfaces. For example, if the incoming Ethernet packet is already of MTU length, addition of the 4 bytes will cause it to be dropped when sent out another Ethernet interface.

In the book "Switching in IP networks" ( By Davie, Doolan, and Rekhter ), section 5.3 says:
"Tag switching uses the IP Path MTU Dsicovery procedures to ensure that even after the shim layer is added to the packet, the resulting packet size doesn't exceed the maximum packet size that could be transmitted without fragmentation."

What exactly are these "IP Path MTU Discovery procedures"? Is there any other way of avoiding fragmentation?

Thanks in advance.

***************************************************************** 
                                   Aijaz Pathan                                            
                                   Motorola IPO                                           
                     8303 N. Mopac Expway, St. A-400                 
                                Austin, TX 78759                                       
                               
                                 Ph:512.583.2313                                       
                                Fax:512.583.2350                                      
                              Pager:888.442.5946                                 
******************************************************************

---

From: Vasanthi Thirumalai <[email-masked]>
Date: Fri, 21 Jan 2000 11:18:13 -0500

Aijaz,
	You can find details of how MPLS handles the MTU issue by looking into section
3 of the label encaps draft. You can find this doc at:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-label-encaps-07.txt

IP Path MTU discovery is the procedure by which a host discovers the smallest
MTU size of all the links along the path. If a router finds that a packet is too
big to transmit, but it cannot fragment it because the 'don't fragment bit' is
set, it sends an alerting message to the source of the packet. This feature is
what is used in Path MTU discovery. You can find more details about it in RFC
1191.

-Vasanthi 

> Aijaz Pathan wrote:
> because of addition of 4 bytes of tag header for Ethernet interfaces. For
> example, if the incoming Ethernet packet is already of MTU length, addition of
> the 4 bytes will cause it to be dropped when sent out another Ethernet
> interface.
> 
> "Tag switching uses the IP Path MTU Dsicovery procedures to ensure that even
> after the shim layer is added to the packet, the resulting packet size doesn't
> exceed the maximum packet size that could be transmitted without
> fragmentation."
> 
>                                    Aijaz
> Pathan
>                                    Motorola
> IPO
>                                 Austin, TX
> 78759

-- 
------------------------------------------------
Vasanthi Thirumalai         Phone: 732-949-3787
Lucent Technologies         Room : 2J-643
101 Crawfords Corner
Holmdel, NJ-07733
------------------------------------------------