Subject: RE: Explicit route operations in RSVP

From: "Agranoff, Saul" <[email-masked]>
Date: Fri, 14 Jan 2000 15:13:30 -0500

> When setting up an LSP within another LSP.
> 
> Here is an example where this sub-object could be useful.
> Consider the following topology:
> 
>    A---B----C----D----E-----F
> 
> Assume that A sends a Path message with ERO = (B, E, F).  When this
> message arrives at B, B wants to route it along C and D. One way to do
> this is just to expand the ERO to (B, C, D, E, F). For this you don't
> need the label termination sub-object.
> 
> An alternative is for B to expand this ERO to (B, C, D, lto, E, F)
> (where "lto" is the label termination sub-object). When D gets a label
> L1 from E (this label will be carried in the Resv message 
> from E to D),
> D would use it as the outgoing label for the LSP.  D then 
> allocates its
> own label, L2, for that LSP.  In the Label Object that D 
> sends to C (in
> the Resv message) D will put not just L2, but <Implicit-Null, 
> L2>.  When
> C receives this Resv message, C allocates its own label, L3, and sends
> <L3, L2> in the Label Object to B. B at this point allocates its own
> label, L4, and sends *just* L4 in the Label Object to A (as it was
> B who inserted lto in the first place).
> 
> When A sends a packet over the LSP, A puts L4 on the packet. B
> replaces A4 with L2 and pushes L3 onto the stack. C pops the
> stack and sends the packet with just L2 to D. D replaces L2 with
> L1....
> 
> I don't think that the current text reflects what I described above...
> 
> Yakov.
> 

Thanks Yakov,  

I was wondering about this issue myself.  It almost makes sense now.

But since there is an alternative, why would an LSR ('B' in 
your example) choose to force an extra layer in the label stack?  

It doesn't seem to buy anything unless the LSP being used for 
tunnelling can be shared among multiple upper-layer LSPs.  

We still need some
better guidelines in the draft if this option is to be understood.

Saul Agranoff
Harris & Jeffries, Inc.

---

From: "Abes, Andi" <[email-masked]>
Date: Sat, 15 Jan 2000 13:07:49 -0500

See below..

> -----Original Message-----
> From: Agranoff, Saul [mailto:[email-masked]]
> Sent: Friday, January 14, 2000 3:14 PM
> To: MPLS mailing list
> Subject: RE: Explicit route operations in RSVP 
> 
> 

My understanding is that:
In order for LSP's signaled by RSVP to be shared,
they have to be in the same session. The session is defined
by the egress point and the tunnel id (assume no exteneded ID).
So, the "tunnel" B-C needs to be assigned a Tunnel ID, that can 
some how be learned by other potential users.
There are no provisions for "advertising" this tunnel ID, hence
it can not be share. 

I definitaly stand by Saul's statement, that if the LSP tunnel
can not be share, it's useless.

Andi.