Subject: LDP MIB Protocol Session Tables

From: Robert Schmitt <[email-masked]>
Date: Wed, 19 Jan 2000 14:07:17 -0500 (EST)

Joan..

In reference to recent correspondence about the
mplsLdpSessionPeerAddressEntry OBJECT-TYPE

whose DESCRIPTION is 
              "An entry in this table represents information on
              session's for a single next hop address which was
              advertised in an Address Message from the LDP peer.
              The information contained in a row is read-only."

If the premise is accepted that this is an appropriate DESCRIPTION,
along with the newly specified INDEX, then the DESCRIPTIONS for the
synonomous ATM and Frame Relay Tables would appear to be not correct.
These DESCRIPTIONS are as follows, for both  ATM and Frame Relay:

             "An entry in this table represents information on a
             single session between an LDP Entity and LDP Peer.
             The information contained in a row is read-only."

To be consistent, these should read

  An entry in this table represents information on a 
  single Label Range that is associated with a session.

I would like to be sure that the premise is correct, which is not
the case as we speak.

Thank you

+----------------------------------+------------------------------+
            |           |          |         Robert Schmitt
            |           |          |       [email-masked] (w)
           |||         |||         |         Chelmsford, MA
          |||||       |||||        |          978-244-3076
      ..:|||||||:...:|||||||:..    |         [email-masked] (h)  
      C i s c o  S y s t e m s     |          603-673-7571
+----------------------------------+------------------------------+

================================================================
     --
     -- MPLS LDP ATM Session Information
     --

     mplsLdpAtmSessionTable OBJECT-TYPE
         SYNTAX      SEQUENCE OF MplsLdpAtmSessionEntry
         MAX-ACCESS  not-accessible
         STATUS      current
         DESCRIPTION
             "A table of Sessions between the LDP Entities and
             LDP Peers using ATM as the underlying media.
             Each row represents a single session.

             NOTE:  this table cannot use the 'AUGMENTS'
             clause because there is not necessarily a one-to-one
             mapping between this table and the mplsLdpSessionTable."
         ::= { mplsLdpSessionObjects 2 }

     mplsLdpAtmSessionEntry OBJECT-TYPE
         SYNTAX      MplsLdpAtmSessionEntry
         MAX-ACCESS  not-accessible
         STATUS      current
         DESCRIPTION
             "An entry in this table represents information on a
             single session between an LDP Entity and LDP Peer.
             The information contained in a row is read-only."
         INDEX       { mplsLdpEntityLdpId,
                       mplsLdpEntityIndex,
                       mplsLdpPeerLdpId,
                       mplsLdpPeerIndex,
                       mplsLdpSessionIndex,
                       mplsLdpSessionAtmLabelRangeLowerBoundVpi,
                       mplsLdpSessionAtmLabelRangeLowerBoundVci

                     }
         ::= { mplsLdpAtmSessionTable 1 }

     MplsLdpAtmSessionEntry ::= SEQUENCE {
         mplsLdpSessionAtmLabelRangeLowerBoundVpi     AtmVpIdentifier,
         mplsLdpSessionAtmLabelRangeLowerBoundVci     AtmVcIdentifier,
         mplsLdpSessionAtmLabelRangeUpperBoundVpi     AtmVpIdentifier,
         mplsLdpSessionAtmLabelRangeUpperBoundVci     AtmVcIdentifier
     }
================================================================

     --
     -- MPLS LDP Frame Relay Session Information
     --

     mplsLdpFrameRelaySessionTable OBJECT-TYPE
         SYNTAX      SEQUENCE OF MplsLdpFrameRelaySessionEntry
         MAX-ACCESS  not-accessible
         STATUS      current
         DESCRIPTION
             "A table of Sessions between the LDP Entities and
             LDP Peers using Frame Relay as the underlying media.
             Each row represents a single session.

             NOTE:  this table cannot use the 'AUGMENTS'
             clause because there is not necessarily a one-to-one
             mapping between this table and the mplsLdpSessionTable."
         ::= { mplsLdpSessionObjects 3 }

     mplsLdpFrameRelaySessionEntry OBJECT-TYPE
         SYNTAX      MplsLdpFrameRelaySessionEntry
         MAX-ACCESS  not-accessible
         STATUS      current
         DESCRIPTION
             "An entry in this table represents information on a
             single session between an LDP Entity and LDP Peer.
             The information contained in a row is read-only."
         INDEX       { mplsLdpEntityLdpId,
                       mplsLdpEntityIndex,
                       mplsLdpPeerLdpId,
                       mplsLdpPeerIndex,
                       mplsLdpSessionIndex,
                       mplsLdpFrSessionMinDlci
                     }
         ::= { mplsLdpFrameRelaySessionTable 1 }

     MplsLdpFrameRelaySessionEntry ::= SEQUENCE {
         mplsLdpFrSessionMinDlci    Integer32,
         mplsLdpFrSessionMaxDlci    Integer32,
         mplsLdpFrSessionLen        INTEGER
     }
================================================================
> mplsLdpSessionPeerAddressEntry OBJECT-TYPE
>          SYNTAX      MplsLdpSessionPeerAddressEntry
>          MAX-ACCESS  not-accessible
>          STATUS      current
>          DESCRIPTION
>              "An entry in this table represents information on
>              session's for a single next hop address which was
>              advertised in an Address Message from the LDP peer.
>              The information contained in a row is read-only."
>          INDEX       { mplsLdpEntityLdpId,
>                        mplsLdpEntityIndex,
>                        mplsLdpPeerLdpId,
>                        mplsLdpSessionPeerNextHopAddressType,
>                        mplsLdpSessionPeerNextHopAddress
>                      }
>          ::= { mplsLdpSessionPeerAddressTable 1 }
> 
>      MplsLdpSessionPeerAddressEntry ::= SEQUENCE {
>          mplsLdpSessionPeerNextHopAddressType     AddressFamilyNumbers,
>          mplsLdpSessionPeerNextHopAddress         MplsLdpGenAddr
>      }

     mplsLdpSessionPeerAddressEntry OBJECT-TYPE
         SYNTAX      MplsLdpSessionPeerAddressEntry
         MAX-ACCESS  not-accessible
         STATUS      current
         DESCRIPTION
             "An entry in this table represents information on
             session's for a single next hop address which was
             advertised in an Address Message from the LDP peer.
             The information contained in a row is read-only."
         INDEX       { mplsLdpEntityLdpId,
                       mplsLdpEntityIndex,
                       mplsLdpPeerLdpId,
                       mplsLdpPeerIndex,
                       mplsLdpSessionIndex
                     }
         ::= { mplsLdpSessionPeerAddressTable 1 }

     MplsLdpSessionPeerAddressEntry ::= SEQUENCE {
         mplsLdpSessionPeerNextHopAddressType     AddressFamilyNumbers,
         mplsLdpSessionPeerNextHopAddress         MplsLdpGenAddr
     }
Piers,

I do think you are correct and
those NextHop objects should be included in the index.
And yes, we have removed the SessionIndex 
from the MIB, so your table appears to be correct.

   Thanks, Joan

> -----Original Message-----
> From: Piers Finlayson [mailto:[email-masked]]
> Sent: Monday, January 17, 2000 10:24 AM
> To: 'Joan Cucchiara'
> Cc: [email-masked]'
> Subject: RE: LDP MIB update?
> 
> 
> Joan,
> 
> I think there may be a problem with the 
> mplsLdpSessionPeerAddressTable in
> the LDP MIB.
> 
> The mplsLdpSessionPeerAddressTable extends the 
> mplsLdpSessionTable in the
> same way as the mplsLdpFrameRelaySessionTable and the
> mplsLdpAtmSessionTable.  They all use the same indexes as the
> mplsLdpSessionTable, but the Protocol Session Table indexes 
> are extended to
> include
> 
> mplsLdpSessionAtmLabelRangeLowerBoundVpi and
> mplsLdpSessionAtmLabelRangeLowerBoundVpi in the ATM case
> 
> mplsLdpFrSessionMinDlci in the Frame Relay case.
> 
> These additional indexes allow multiple rows to exist in the Protocol
> Session Tables for a single entry in the mplsLdpSessionTable.  this is
> important because there may be several label ranges for a 
> single session.
> 
> I think there may also be multiple peer next hop addresses 
> per session.
> This means that the two fields

> mplsLdpSessionPeerNextHopAddressType
> mplsLdpSessionPeerNextHopAddress
> 
> should be added to the index so that rows in this table can also be
> accessed.
> 
> 
> If you make this change, the ASN.1 for 
> mplsLdpSessionPeerAddressEntry will
> become
> 
> ...
> 
> mplsLdpSessionPeerAddressEntry OBJECT-TYPE
>          SYNTAX      MplsLdpSessionPeerAddressEntry
>          MAX-ACCESS  not-accessible
>          STATUS      current
>          DESCRIPTION
>              "An entry in this table represents information on
>              session's for a single next hop address which was
>              advertised in an Address Message from the LDP peer.
>              The information contained in a row is read-only."
>          INDEX       { mplsLdpEntityLdpId,
>                        mplsLdpEntityIndex,
>                        mplsLdpPeerLdpId,
>                        mplsLdpPeerIndex,
>                        mplsLdpSessionIndex
>                        mplsLdpSessionPeerNextHopAddressType
>                        mplsLdpSessionPeerNextHopAddress
>                      }
>          ::= { mplsLdpSessionPeerAddressTable 1 }
> 
>      MplsLdpSessionPeerAddressEntry ::= SEQUENCE {
>          mplsLdpSessionPeerNextHopAddressType     
> AddressFamilyNumbers,
>          mplsLdpSessionPeerNextHopAddress         MplsLdpGenAddr
>      }
> 
> The individual fields also have to become "not-accessible"
> 
> ...
> 
> However, in your email of 3 December 1999 you describe new 
> indexing for the
> mplsLdpSessionTable.  I assume, therefore that
> mplsLdpSessionPeerAddressEntry becomes
> 
> ...
> 
> mplsLdpSessionPeerAddressEntry OBJECT-TYPE
>          SYNTAX      MplsLdpSessionPeerAddressEntry
>          MAX-ACCESS  not-accessible
>          STATUS      current
>          DESCRIPTION
>              "An entry in this table represents information on
>              session's for a single next hop address which was
>              advertised in an Address Message from the LDP peer.
>              The information contained in a row is read-only."
>          INDEX       { mplsLdpEntityLdpId,
>                        mplsLdpEntityIndex,
>                        mplsLdpPeerLdpId,
>                        mplsLdpSessionPeerNextHopAddressType,
>                        mplsLdpSessionPeerNextHopAddress
>                      }
>          ::= { mplsLdpSessionPeerAddressTable 1 }
> 
>      MplsLdpSessionPeerAddressEntry ::= SEQUENCE {
>          mplsLdpSessionPeerNextHopAddressType     
> AddressFamilyNumbers,
>          mplsLdpSessionPeerNextHopAddress         MplsLdpGenAddr
>      }
> 
> ...
> 
> 
> Is this correct?
> 
> Thanks,
> Piers
> 
> ---------------------------------------------------------
> Piers Finlayson
> 
> ATM, MPLS and Telecoms Group
> Data Connection Ltd.
> 
> Tel:   +44 20 8366 1177     Fax: +44 20 8363 4478
> Email: [email-masked]     Web: http://www.datcon.co.uk
> ---------------------------------------------------------
>

---

From: Joan Cucchiara <[email-masked]>
Date: Wed, 19 Jan 2000 15:08:26 -0500

Hi Robert,

Yes, I agree the description needs to be reworded,
as this MIB table, mplsLdpAtmSessionTable, represents
one OR MORE label range intersections of the  
ATM Session Parameters between the entity and peer
for a session.

As you point out the indexing will remain
as it is.  (This is also the reason that this
table cannot use "AUGMENTS".)

Similar problem with the description for the
FR Session Table.  

I don't believe these problems are related to
the mplsLdpSessionPeerAddressTable issue which 
will require additional indices and also a better
description. 

   Thanks, 
     -Joan

> From: Robert Schmitt [mailto:[email-masked]]
> Sent: Wednesday, January 19, 2000 2:07 PM
> To: Joan Cucchiara
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: LDP MIB Protocol Session Tables
> 
> 
> 
> 
> Joan..
>