Subject: Re: source code for mpls?

From: m lu <[email-masked]>
Date: Tue, 11 Jan 2000 11:57:36 -0800 (PST)

Thanks. i am very gratefull for this.

one more question: does anyone build this on freebsd,
or solaris?

TIA

-mll

--- David Wilder <[email-masked]> wrote:
> Hi,
> 
> Try looking at:		www.nortelnetworks.com/mpls
> This will give you a look at Nortel's CR-LDP source
> code
> 
> Dave 
> 
>
****************************************************************
> 
> Hi:
> 
> I just join the group and try to learn mpls. Is
> there
> any source code availabe on the net, like gated?
> 
> TIA
> 
> -mll
> 
__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Tue, 11 Jan 2000 15:52:58 -0500

Just to be clear, the code on:
 
www.nortelnetworks.com/mpls

  Is for the LDP and CR-LDP pdu encoding and decoding
only.

  There are LINUX implementations of LDP/CR-LDP that
use these PDUs that are available elsewhere.

  Cheers,

  Peter Ashwood-Smith

---

From: Bora Akyol <[email-masked]>
Date: 11 Jan 2000 13:00:36 -0800

I am glad that you clarified this. Since the PDU decoding and encoding 
is really one of the easier components of developing an MPLS stack.

Bora Akyol
Pluris