Subject: I-D ACTION:draft-ietf-mpls-ldp-mib-05.txt

From: [email-masked]
Date: Tue, 07 Mar 2000 06:30:01 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

	Title		: Definitions of Managed Objects for the Multiprotocol 
                          Label Switching, Label Distribution Protocol (LDP)
	Author(s)	: J. Cucchiara,  H. Sjostrand, J. Luciani	
        Filename	: draft-ietf-mpls-ldp-mib-05.txt
	Pages		: 74
	Date		: 06-Mar-00
	
This memo defines a portion of the Management Information Base (MIB)
for use with network management protocols in the Internet community.
In particular, it describes managed objects for the Multiprotocol
Label Switching, Label Distribution Protocol (LDP).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-ldp-mib-05.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-mpls-ldp-mib-05.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-mpls-ldp-mib-05.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Piers Finlayson <[email-masked]>
Date: Sat, 11 Mar 2000 12:10:59 -0000

Joan,

I have reviewed your latest draft of the LDP MIB and have a few comments for
you.

-  Section 3.6.1 describes the LDP notifications and should be expanded to
cover both the mplsLdpSessionUp and Down and the mplsLdpLibUp and Down
notifications.  It may also be worth referencing the
mplsLdpSessionUpDownTrapEnable, mplsLdpLibLspUpDownTrapEnable,
mplsLdpEntityFailedInitSessionTrapEnable and
mplsLdpEntityPVLimitMismatchTrapEnable objects within this section,
indicating that these objects control whether the notifications are sent.

-  With regards to the following objects:

     mplsLdpEntityHopCountLoopDetection OBJECT-TYPE
         SYNTAX     INTEGER {
                               disabled(0),
                               enabled(1)
                            }
         MAX-ACCESS read-create
         STATUS     current
         DESCRIPTION
             "An indication of whether loop detection based
             on hop count is disabled or enabled for this
             Entity.  If this object has the value of
             'disabled(0)', then loop detection using
             hop counts is disabled.

             Otherwise, if this object has a value of 'enabled(1)',
             then loop detection based on hop counts is enabled.
             Also, the value of the object,
             'mplsLdpLsrLoopDetectionCapable', must have the value
             of either: 'hopCount(3)' or 'hopCountAndPathVector(5)'."
         ::= { mplsLdpEntityEntry 15 }

     mplsLdpEntityHopCount  OBJECT-TYPE
         SYNTAX      Unsigned32 (0..255)
         MAX-ACCESS  read-create
         STATUS      current
         DESCRIPTION
             "If the value of 'mplsLdpEntityHopCountLoopDetection'
             for this entry is 'enabled(1)', then this object
             represents the initial Hop Count for this Entity.

             If the value of 'mplsLdpEntityHopCountLoopDetection'
             is 'disabled(0)', then the value of this object is
             undefined."
         ::= { mplsLdpEntityEntry 16 }

   I think that the second object (mplsLdpEntityHopCount) should actually be
the configured maximum allowable value of the Hop Count.  In the LDP
specification, section 3.4.4 it states that "The first LSR in the
LSP(ingress for a Label Request message, egress for a Label Mapping message)
should set the hop count value to 1.".  Therefore this should not be
configurable.

   Each LSR then increments this value, and the spec states "If an LSR
receives a message containing a Hop Count TLV, it must check the hop count
value to determine whether the hop count has exceeded the maximum allowable
value.".  This is the value that should be configured in the LDP MIB.  The
range from this object should be (1..255).

   Given this change, it is also possible to merge the two Hop Count objects
together as follows.

      mplsLdpEntityHopCounterLimit OBJECT-TYPE 
          SYNTAX       Integer32 (0..255)
          MAX-ACCESS   read-create 
          STATUS       current 
          DESCRIPTION 
              "If the value of this object is 0 (zero),
              then Loop Detection using Hop Counters is
              disabled.
              If the value of this object is greater than
              0 (zero) then Loop Detection using Hop
              Counters is enabled, and this object
              specifies this Entity's maximum allowable
              value for the Hop Count.
              Also, the value of the object
              mplsLdpLsrLoopDetectionCapable must be set
              to either 'hopCount(3)' or
              'hopCountAndPathVector(5)' if this object
              has a value greater than 0 (zero)."
          ::= { mplsLdpEntityEntry 15 } 

-  Typo in section 3.5.2 "...  Then and only then is it save to ..." should
be changed to "... Then and only then is it safe to ...".

-  Typo in the mplsLdpSessionUp notification description.  "... changes from
any state accept ..." should be "... changes from any state except ...".

Cheers,
Piers

---------------------------------------------------------
Piers Finlayson

ATM, MPLS and Telecoms Group
Data Connection Ltd.

Tel:   +44 20 8366 1177     Fax: +44 20 8363 4478
Email: [email-masked]     Web: http://www.datcon.co.uk
---------------------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, March 07, 2000 11:30 AM
To: IETF-Announce
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-mpls-ldp-mib-05.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Multiprotocol Label Switching Working Group
of the IETF.

	Title		: Definitions of Managed Objects for the
Multiprotocol 
                          Label Switching, Label Distribution Protocol (LDP)
	Author(s)	: J. Cucchiara,  H. Sjostrand, J. Luciani	
        Filename	: draft-ietf-mpls-ldp-mib-05.txt
	Pages		: 74
	Date		: 06-Mar-00

Send a message to:
	[email-masked].
In the body type:

---

From: Joan Cucchiara <[email-masked]>
Date: Mon, 13 Mar 2000 11:39:24 -0500

Hi Piers,

> From: Piers Finlayson [mailto:[email-masked]]
> Sent: Saturday, March 11, 2000 7:11 AM
> To: [email-masked]
> Cc: [email-masked]; Adrian Farrel
> Subject: RE: I-D ACTION:draft-ietf-mpls-ldp-mib-05.txt
> 
> 
> Joan,
> 

I agree. 

>           ::= { mplsLdpEntityEntry 15 } 

I agree here also.

> any state accept ..." should be "... changes from any state 

Got it!

Thanks for your comments.

-Joan