Subject: RE: Optical IP activities

From: CATANZARITI Sergio FTR&D/TI <[email-masked]>
Date: Wed, 15 Mar 2000 10:17:38 -0800

I was aware of that. Indeed, that makes me more confused and worried.
The ITU-T (SG15?) seems to have concerns on working on a peer model for an
IP over Optics networking architecture, leaning towards an overlay scenario.
In other words, there are some concerns about making the OCh layer topology
information revealed to the IP service client layer. 
On the contrary, the IETF seems to go in the other direction (although a
recent IETF draft, I believe from Nortel and Lucent, endorses the same ITU-T
concerns).

From the MPLS revised charter:

4.  Simplify integration of routers with optical cross-connect based 
technologies 

a) making optical cross connects behave as peers to routers (thus 
reducing the number of routing peers that a router has to maintain), 

b) by making information about physical topology available to 
Network Layer routing procedures, and 

c) by employing common addressing, routing, and management 
procedures. 

I guess that it is too early to debate model issues, in order to avoid IP
over ATM model debate-like activities.
Personally, I would first work on Optical IP networking architecture and
control plane requirements definition, then choosing the right protocol
machinery (MPLS, X/Y/Z protocol), and ultimately facing the multi-dimension
model problem (topology complexity, service layer configuration, OA&M
procedures, PMO status quo, commercial considerations, etc.)

Sergio

> --------------------------------------------------------------------
> Sergio Catanzariti
> Senior Project Manager, Technology Integration
> France Telecom R&D 
> 1000 Marina Boulevard Suite 300 
> Brisbane CA 94005
> Tel. 650-875-1526
> Fax. 650-875-1505
> email:[email-masked] 
> --------------------------------------------------------------------
> 
> 
> -----Original Message-----
> From:	Chip Sharp [SMTP:[email-masked]]
> Sent:	Wednesday, March 15, 2000 9:45 AM
> To:	CATANZARITI Sergio FTR&D/TI;
> [email-masked]'
> Cc:	[email-masked]'
> Subject:	Re: Optical IP activities 
> 
> FYI,
> It looks like the ITU (SG 13, SG15 and possibly SG11) may be getting into 
> this area as well.  At the SG13 meeting in Kyoto, there was some
> discussion 
> of this topic.  They are definitely working on next-gen optical networking
> 
> issues.
> 
> Chip
> 
> At 05:23 PM 3/14/00 -0800, CATANZARITI Sergio FTR&D/TI wrote:
> 
> >Today I was reading the MPLS revised charter sent by Vijay and I have 
> >found optical IP related activities, like that:
> >
> >6.  Specify extensions to the protocols and procedures used for
> >signaling explicit routes and to effect fast recovery of LSPs
> >for use in Optical Cross Connects.
> >
> >Now, reading from the IP over Optical BoF description, I find:
> >
> >- Modifying existing IP and MPLS routing and connection signaling
> >   protocols
> >
> >I know that it is still pretty much immature to talk about results of the
> 
> >upcoming IP over Optical BoF, but how will an eventual WG coming out from
> 
> >this BoF reconcile with the MPLS WG activity in the Optical IP arena?
> >
> >By working on a generic control plane architecture and requirements 
> >definition, and leaving out to the MPLS WG specific work on the generic 
> >mechanisms and procedure for an MPLS implementation of an Optical IP 
> >control plane? Is this a possible intra-IETF activity scenario? Which
> others?
> >
> >Looking for a brief and rough hint.
> >
> >Thanks,
> >Sergio
> >-------------------------------------------------------------------- 
> >Sergio Catanzariti  Senior Project Manager, Technology Integration
> France 
> >Telecom R&D  1000 Marina Boulevard Suite 300  Brisbane CA 94005  Tel. 
> >650-875-1526  Fax. 
> >650-875-1505  email:[email-masked] 
> >--------------------------------------------------------------------
> 
> Support NetAid!  http://www.netaid.org
> --------------------------------------------------
> Chip Sharp                 Consulting Engineering
> Cisco Systems              Telco Bio-region
> Reality - Love it or Leave it.			
> --------------------------------------------------
>

---

From: "John Strand" <[email-masked]>
Date: Thu, 16 Mar 2000 10:19:33 -0500

I'd like to reinforce these concerns. It seems to me that defining the scope of this work to cover only peer-to-peer models
of router/OXC interactions would drastically limit its value in the short-to-medium term at least. Similarly with disclosure
of physical topology information. Recent OIF contributions from many of the principal players suggest that further study 
of these issues before limiting work to a single model  is needed, as does draft-rstb-optical-signaling-framework-00.txt.

John
John Strand
AT&T
Lightwave Networks Research Dept.
100 Schulz Drive, Room 4-212
Red Bank, N.J. 07701-7033
(732)345-3255
[email-masked] 

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of CATANZARITI Sergio FTR&D/TI
    Sent: Wednesday, March 15, 2000 1:18 PM
    To: 'Chip Sharp'
    Cc: [email-masked]'; [email-masked]'
    Subject: RE: Optical IP activities 

    I was aware of that. Indeed, that makes me more confused and worried. 
    The ITU-T (SG15?) seems to have concerns on working on a peer model for an IP over Optics networking architecture, leaning towards an overlay scenario. In other words, there are some concerns about making the OCh layer topology information revealed to the IP service client layer. 

    On the contrary, the IETF seems to go in the other direction (although a recent IETF draft, I believe from Nortel and Lucent, endorses the same ITU-T concerns).

    I guess that it is too early to debate model issues, in order to avoid IP over ATM model debate-like activities. 
    Personally, I would first work on Optical IP networking architecture and control plane requirements definition, then choosing the right protocol machinery (MPLS, X/Y/Z protocol), and ultimately facing the multi-dimension model problem (topology complexity, service layer configuration, OA&M procedures, PMO status quo, commercial considerations, etc.)

    Sergio 

        
        -----Original Message----- 
        From:   Chip Sharp [SMTP:[email-masked]] 
        Sent:   Wednesday, March 15, 2000 9:45 AM 
        To:     CATANZARITI Sergio FTR&D/TI; [email-masked]' 
        Cc:     [email-masked]' 
        Subject:        Re: Optical IP activities 

        FYI, 
        It looks like the ITU (SG 13, SG15 and possibly SG11) may be getting into 
        this area as well.  At the SG13 meeting in Kyoto, there was some discussion 
        of this topic.  They are definitely working on next-gen optical networking 
        issues. 

        Chip 

        At 05:23 PM 3/14/00 -0800, CATANZARITI Sergio FTR&D/TI wrote: 

        >control plane? Is this a possible intra-IETF activity scenario? Which others? 
        > 
        >Sergio Catanzariti  Senior Project Manager, Technology Integration  France

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 16 Mar 2000 07:45:28 -0800

John,

> I'd like to reinforce these concerns. It seems to me that defining the
> scope of this work to cover only peer-to-peer models of router/OXC
> interactions would drastically limit its value in the short-to-medium
> term at least. Similarly with disclosure of physical topology
> information. Recent OIF contributions from many of the principal
> players suggest that further study of these issues before limiting work
> to a single model  is needed, as does draft
> draft-rstb-optical-signaling-framework-00.txt.

I would assume that the same control plane based on MPLS TE could be
used to support both the peer and the overlay model (as well as a mixture
of both).  With this in mind I would suggest that the MPLS WG should
focus on defining the extension to the current MPLS TE protocols (ISIS,
OSPF, RSVP, CR-LDP) to handle Optical LSRs and SDH-LSRs.

Yakov.

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 16 Mar 2000 14:04:18 -0500

> OSPF, RSVP, CR-LDP) to handle Optical LSRs and SDH-LSRs.

[Disclaimer: I'm guessing at other people's objections so apply a
large grain of salt unless confirmed.]

I'm guessing that some of the objections to using MPLS as a means to
control the optical crossconnects come from the prolems of attenuation
and signal degradation (dispersion, etc) that are cummulative.
Determining whether an LSP path is feasible may not be a simple as
checking the bandwidth constraints on the legs of the path if there
are no OEO conversions at the hops.

If that is what John was getting at, then John may be trying to tell
us that it is premature to try to come up with means to quantify the
restrictions imposed by attenuation and signal degradation such that
the ingress can reliably predict LSP path feasibility.

btw- Some vendors may also not be looking forward to sharing these
characteristics (attenuation, dispersion, etc) openly as would be
necessary if advertising them through a vendor independent control
protocol, even if we knew how to express them and knew how to
accumulate the effects.

If this is the objection, its worth noting that the objection may not
apply if OEO is done everywhere (but it may cost more to do that).

Someone (John in particular, Chip, Sergio also) please correct me if
I'm wrong about my assumption.  If so, I appologize for incorrectly
reading between the lines of your message(s).  If I'm not wrong, then
perhaps this clarifies the objections.

Curtis

---

From: "John Strand" <[email-masked]>
Date: Thu, 16 Mar 2000 14:39:16 -0500

Yakov,
I agree that an MPLS TE-based control plane ought to be able to support
both models, and hope that the charter will be reworded accordingly.
Likewise I'd hope that the clause about making physical topology 
information available to Network Layer working procedures will be
reworded to indicate that this is an option to be supported.

I'd also like to suggest that BGP be kept in-scope explicitly.  I think that 
dealing with multi-domain issues will considerably increase the
applicability of the new control plane. Section 3.1 of
draft-rstb-optical-signaling-framework-00.txt gives one important
driver for this; another will arise as optical networking pushes
out to involve CLEC's and other access providers and also extends
internationally.

John 

John Strand
AT&T
Lightwave Networks Research Dept.
100 Schulz Drive, Room 4-212
Red Bank, N.J. 07701-7033
(732)345-3255
[email-masked] 
*************************************************************************

---

From: Bala Rajagopalan <[email-masked]>
Date: Thu, 16 Mar 2000 15:03:45 -0500

Hello:

> reworded to indicate that this is an option to be supported.

I agree with this completely. In general, I find the MPLambdaS push is
on IP transport over optical networks, but not necessarily addressing
 optical networking control needs (specifically, optical internetworking). It
would be nice to consider the requirements from the optical side,
and then look at solutions.

Regards,
--

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]

---

From: "John Strand" <[email-masked]>
Date: Thu, 16 Mar 2000 15:26:24 -0500

Curtis,
There definitely are technical issues that will need to be dealt with
before MPLS TE can be applied to transparent (all-optical) optical networks, as you
point out. However I'm assuming that we'll be able to work through
these, particularly if transparent and opaque technologies are kept in
separate routing domains.  So I definitely support moving ahead on an
MPLS-inspired control plane for the OL.  I also see a definite role
for the peer model, particularly when used as part of a "Virtual Optical
Network" (the OL equivalent of a VPN). However my Email was triggered
by a concern that overlay models and non-disclosure of physical topology
information was going to be ruled out-of-scope by the proposed charter,
which I think would drastically reduce interest in any proposals from
this group.

John

John Strand
AT&T

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 2:04 PM
To: Yakov Rekhter
Cc: [email-masked]; 'CATANZARITI Sergio FTR&D/TI'; 'Chip Sharp';
[email-masked]

Curtis

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 16 Mar 2000 12:35:44 -0800

John,

> reworded to indicate that this is an option to be supported.

Agreed.

And to address this I would suggest we'll add the following to the
WG charter:

   Use of MPLS control plane with OXCs should allow two basic
   architectural options:

    - One option is to use different instances of the control plane
      in the OTN (OXC) and IP (LSR) domains. In this situation, each
      instance of the control plane will operate independent of the
      other. 

    - Another option is to use a single instance of the control
      plane that subsumes and spans LSRs and OXCs.

> out to involve CLEC's and other access providers and also extends

May I suggest that we'll move "one step at a time". That is, we first
settle on how to use MPLS Traffic Engineering to control OXCs (and/or
SONET cross connects) within a single routing domain.  The next step
would be to extend this across domain's boundaries - that is where BGP
may come into play.  In the context of the MPLS WG charter that means
that we could always extend it at some future point to include
multi-domain operations.

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 16 Mar 2000 12:40:43 -0800

John,

> which I think would drastically reduce interest in any proposals from

Just to clarify, "non-disclosure of physical topology information"
could occur in the peer model as well. One example of such
"non-disclosure" is the "forwarding adjacency" construct
(see draft-kompella-mpls-optical-00.txt). Another example is
when you have multiple OSPF/ISIS areas (where an LSR sees only
topology within its own area).

Yakov.

---

From: Bala Rajagopalan <[email-masked]>
Date: Thu, 16 Mar 2000 17:19:36 -0500

Hello:

The following draft was submitted to internet-drafts last week, but
I haven't seen an announcement yet. It is, however, available at

http://www.ietf.org/internet-drafts/draft-ip-optical-framework-00.txt

Regards,

Bala

-----------------------------------------------------------------------

                IP over Optical Networks - A Framework
    J. Luciani, B. Rajagopalan, D. Awduche, B. Cain, and B. Jamoussi

                   draft-ip-optical-framework-00.txt

Abstract

   The Internet transport infrastructure is moving towards a model of
   high-speed routers interconnected by optical core networks. A
   consensus is emerging in the industry on utilizing IP-centric
   protocols for the optical control plane [9, 10], as well as for
   dynamic bandwidth provisioning for IP services. Also, there has
   recently been significant activity in defining models for IP
   transport over optical networks, specifically, the routing and
   signaling aspects [2,6,7]. This draft attempts to define a framework
   for IP over Optical networks, considering both the IP control plane
   for optical networks as well as IP transport over optical networks
   (together referred to as "IP over optical networks"). Within this
   framework, we develop a common set of terms and concepts which allows
   to discuss these IP over optical technologies in a consistent fashion.
   Additionally, this draft surveys some architectural frameworks that
   might be useful and appropriate for the deployment of IP over hybrid
   optical networks that contain IP routers, WDM multiplexers, and
   optical cross-connects (OXCs). This document is complementary to the
   framework of Multiprotocol Lambda Switching proposed in [2].
--

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]

---

From: "John Strand" <[email-masked]>
Date: Thu, 16 Mar 2000 17:47:05 -0500

Yakov,
Your reworking of the old (a) is fine as long as the peer-to-peer "Virtual
Optical Network" option isn't ruled out of scope. I hope that the physical topology
point ((b)) will also be made more inclusive in the same spirit.

With regard to BGP: In terms of defining specific solutions "one step at a time"
makes sense. I think things will go more smoothly in the long term,
however, if this work proceeds in a framework that more explicitly captures
Optical Layer reality than has been the case so far. To echo what Bala said:
"It would be nice to consider the requirements from the optical side,
and then look at solutions."  Multi-domain is one example of this: The single
domain routing problem seems much more complex if both opaque and transparent
(all-optical) islands are intermixed than it will be if a provisional decision
is made to keep them in separate domains.  (This is an assertion that needs more
discussion, of course.) Sec. 6.5 in draft-chaudhuri-ip-olxc-control-00
is a first stab at scoping this problem, where the islands are implicitly 
assumed to not be intermixed.

So I guess the bottom line is that it's up to us OL people to try to suggest
an appropriate framework and requirements set within which the single domain
problem can be worked intelligently, as a first step to the needed solution.

John

John Strand
AT&T

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 3:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Optical IP activities 

John,

Agreed.

Yakov.

---

From: Bala Rajagopalan <[email-masked]>
Date: Thu, 16 Mar 2000 18:38:03 -0500

>       plane that subsumes and spans LSRs and OXCs.

Given the specific requirements in optical networks (leading to possibly a
different
flavor of signaling procedures), I'm not sure what the "single instance" model
means.

Regards,
--

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]