Subject: Re: problems compiling LSR MIB v2 - NOT!

From: Hans Sjöstrand <[email-masked]>
Date: Thu, 16 Mar 2000 17:02:25 +0100

I provided the compile information for your information. You could 
of course treat that information in two ways. Either you throw it
back and blame something else (in this case my compile environment), 
or you consider it and update the mib. 

My opinion (and my compilers) are that the LSR MIB got errors
-  Counter32 are different from counter64! The whole purpuse
   of mplsInSegmentHCOctets is to be counter64. An easy change.  
-  All object needs to be part of a GROUP. The objects I listed 
   aren't. I guess you should put them in the appropriate groups. 

For some reason a } disapered in my file, which rendered a third 
error. Thats entirely on me. 

My proposal is that you update according to the remarks, and maybe 
use a more stringent mode on MOSY then I guess 
the mib would pass a lot more compilers than previously. 

/// Hasse

Cheenu Srinivasan wrote:
> 
> I just pulled down the latest version of the LSR MIB from
> http://www.ietf.org/internet-drafts/draft-ietf-mpls-lsr-mib-02.txt
> and compiled that (not my local copy), generated code etc. It
> went through without a hitch; output trace is attached below.
> 
> Of course, we went through this process _before_ we posted the
> MIB, and made sure all was kosher.
> 
> Perhaps there's a problem with your compiler/environment.
> 
> Cheenu
> 
> % premosy draft-ietf-mpls-lsr-mib-02.txt MPLS-LSR-MIB.my
> % mosy MPLS-LSR-MIB.my
> mosy 7.1 #1 (starship) of Sat Dec 13 18:23:09 EST 1997
> MPLS-LSR-MIB modules: mplsLsrMIB
> 
> MPLS-LSR-MIB conventions: MplsLSPID MplsLsrIANAAddrFamily MplsLabel
> Ipv6Address
>              MplsBitRate MplsBurstSize MplsBufferSize
> 
> MPLS-LSR-MIB identifiers: mplsLsrObjects mplsLsrNotifications
>              mplsLsrConformance
> 
> MPLS-LSR-MIB objects: mplsInterfaceConfTable mplsInterfaceConfEntry
> 
> MPLS-LSR-MIB types: MplsInterfaceConfEntry
> 
> MPLS-LSR-MIB objects: mplsInterfaceConfIndex mplsInterfaceLabelMinIn
>              mplsInterfaceLabelMaxIn mplsInterfaceLabelMinOut
>              mplsInterfaceLabelMaxOut mplsInterfaceTotalBandwidth
>              mplsInterfaceAvailableBandwidth mplsInterfaceTotalBuffer
>              mplsInterfaceAvailableBuffer mplsInterfaceIsGlobalLabelSpace
>              mplsInterfaceIsLocalLabelSpace mplsInterfaceAdminStatus
>              mplsInterfaceOperStatus mplsInterfacePerfTable
>              mplsInterfacePerfEntry
> 
> MPLS-LSR-MIB types: MplsInterfacePerfEntry
> 
> MPLS-LSR-MIB objects: mplsInterfaceInLabelsUsed mplsInterfaceInPackets
>              mplsInterfaceInDiscards mplsInterfaceFailedLabelLookup
>              mplsInterfaceOutLabelsUsed mplsInterfaceOutPackets
>              mplsInterfaceOutDiscards mplsInterfaceOutFragments
>              mplsInSegmentTable mplsInSegmentEntry
> 
> MPLS-LSR-MIB types: MplsInSegmentEntry
> 
> MPLS-LSR-MIB objects: mplsInSegmentIfIndex mplsInSegmentLabel
> mplsInSegmentNPop
>              mplsInSegmentAddrFamily mplsInSegmentXCIndex
>              mplsInSegmentTSpecIndex mplsInSegmentOwner
>              mplsInSegmentAdminStatus mplsInSegmentOperStatus
>              mplsInSegmentRowStatus mplsInSegmentPerfTable
>              mplsInSegmentPerfEntry
> 
> MPLS-LSR-MIB types: MplsInSegmentPerfEntry
> 
> MPLS-LSR-MIB objects: mplsInSegmentOctets mplsInSegmentPackets
>              mplsInSegmentErrors mplsInSegmentDiscards mplsInSegmentHCOctets
>              mplsOutSegmentIndexNext mplsOutSegmentTable mplsOutSegmentEntry
> 
> MPLS-LSR-MIB types: MplsOutSegmentEntry
> 
> MPLS-LSR-MIB objects: mplsOutSegmentIndex mplsOutSegmentIfIndex
>              mplsOutSegmentPushTopLabel mplsOutSegmentTopLabel
>              mplsOutSegmentNextHopIpAddrType mplsOutSegmentNextHopIpv4Addr
>              mplsOutSegmentNextHopIpv6Addr mplsOutSegmentXCIndex
>              mplsOutSegmentTSpecIndex mplsOutSegmentOwner
>              mplsOutSegmentAdminStatus mplsOutSegmentOperStatus
>              mplsOutSegmentRowStatus mplsOutSegmentPerfTable
>              mplsOutSegmentPerfEntry
> 
> MPLS-LSR-MIB types: MplsOutSegmentPerfEntry
> 
> MPLS-LSR-MIB objects: mplsOutSegmentOctets mplsOutSegmentPackets
>              mplsOutSegmentErrors mplsOutSegmentDiscards
> mplsOutSegmentHCOctets
>              mplsXCIndexNext mplsXCTable mplsXCEntry
> 
> MPLS-LSR-MIB types: MplsXCEntry
> 
> MPLS-LSR-MIB objects: mplsXCIndex mplsXCLspId mplsXCLabelStackIndex
> mplsXCCOS
>              mplsXCIsPersistent mplsXCOwner mplsXCAdminStatus
> mplsXCOperStatus
>              mplsXCRowStatus mplsMaxLabelStackDepth mplsLabelStackIndexNext
>              mplsLabelStackTable mplsLabelStackEntry
> 
> MPLS-LSR-MIB types: MplsLabelStackEntry
> 
> MPLS-LSR-MIB objects: mplsLabelStackIndex mplsLabelStackLabelIndex
>              mplsLabelStackLabel mplsLabelStackRowStatus mplsTSpecIndexNext
>              mplsTSpecTable mplsTSpecEntry
> 
> MPLS-LSR-MIB types: MplsTSpecEntry
> 
> MPLS-LSR-MIB objects: mplsTSpecIndex mplsTSpecMaxRate mplsTSpecMeanRate
>              mplsTSpecMaxBurstSize mplsTSpecRowStatus
> mplsInterfaceTrapEnable
>              mplsInSegmentTrapEnable mplsOutSegmentTrapEnable
> mplsXCTrapEnable
> 
> MPLS-LSR-MIB traps: mplsInterfaceUp mplsInterfaceDown mplsInSegmentUp
>              mplsInSegmentDown mplsOutSegmentUp mplsOutSegmentDown mplsXCUp
>              mplsXCDown
> 
> MPLS-LSR-MIB identifiers: mplsLsrGroups mplsLsrCompliances
> 
> MPLS-LSR-MIB compliances: mplsLsrModuleCompliance
> 
> MPLS-LSR-MIB groups: mplsInterfaceGroup mplsInSegmentGroup
> mplsOutSegmentGroup
>              mplsXCGroup mplsPerfGroup mplsHCInSegmentPerfGroup
>              mplsHCOutSegmentPerfGroup mplsTSpecGroup
> mplsXCIsPersistentGroup
>              mplsXCIsNotPersistentGroup mplsLsrNotificationGroup
> %
> 
> > -----Original Message-----
> > From: Hans Sjöstrand [mailto:[email-masked]]
> > Sent: Wednesday, March 15, 2000 2:19 PM
> > To: Thomas D. Nadeau
> > Cc: [email-masked]; Cheenu Srinivasan; [email-masked]
> > Subject: Re: LSR MIB WG Last Call
> >
> >
> > "Thomas D. Nadeau" wrote:
> > >
> > >         Hi Hans,
> > >
> > > > I would like to know why you have "issued a last call?
> > >
> > >         I did not issue a last call, as I cannot, nor
> > > was it my intention to do so. The intent of my first
> > > message to George and Vijay was to ask for a WG Last Call
> > > on the MIB. My second message was referring to this
> > > request, not declare a last call. I apologize for the
> > > confusion.
> >
> > Thanks Tom for the clarification on your last call. You
> > certanly fooled me and a lot of others I think.
> >
> > >
> > > > It almost ridiculous to say
> > > > something like that when it doesn't even compile!
> >
> > The main point wasn't that it didn't compile, but after
> > finding several errors in it I draw the conclusion that it
> > didn't go near a compiler. Maybe I was premature in
> > my conclusion. For me it was just another
> > indicator that there is some more work on this before it's
> > mature.
> >
> > >
> > >         We compiled the current version with SMIC prior
> > > to releasing it. What are you compiling it with?
> > > Please provide me with your compilation errors
> > > so that I can look into this ASAP.
> >
> > FYI, but as I said, those are editorials.
> >
> > MPLS-LSR-MIB.mib: 774: Error: syntax error before: mplsInSegmentOctets
> > {error,compilation_failed}
> >
> > -- Then I fixed that to get further
> > MPLS-LSR-MIB.mib: 813: Error: Types for mplsInSegmentHCOctets differs
> > from the SEQUENCE definition.
> > {error,compilation_failed}
> >
> > -- Then I fixed that to get further
> > MPLS-LSR-MIB.mib: Error: 'mplsTSpecIndexNext' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsLabelStackRowStatus' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsLabelStackLabel' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsLabelStackIndex' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsLabelStackIndexNext' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsMaxLabelStackDepth' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsXCOwner' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsXCCOS' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsXCLspId' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsOutSegmentErrors' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInSegmentErrors' missing in OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceOutFragments' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceFailedLabelLookup' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceAvailableBuffer' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceTotalBuffer' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceAvailableBandwidth' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsInterfaceTotalBandwidth' missing in
> > OBJECT-GROUP
> > MPLS-LSR-MIB.mib: Error: 'mplsOutSegmentDown' missing in
> > NOTIFICATION-GROUP
> > {error,compilation_failed}
> >
> > -- then I gave up
> >
> > >
> > > > The only thing you create is confusion, hopefully that
> > > > isn't the goal of the exercise. But what was your purpuse?
> > >
> > >         Of course not. My purpose was to ask for a last call
> > > and nothing else.
> > >
> > >         --Tom
> > >
> > > > /// Hasse
> > > >
> > > > "Thomas D. Nadeau" wrote:
> > > > >
> > > > >
> > > > >         Please do give comments if there are any.
> > > > > The WG Last Call should not preclude that. The
> > > > > reason why we decided to go WGLC at this point
> > > > > was that even during the last round of reviewed
> > > > > comments (most were from you in fact), the comments
> > > > > were relatively minor. We feel that the MIB is pretty
> > > > > solid and mature at this point.
> > > > >
> > > > >         --Tom
> > > > >
> > > > > > Your latest version is dated 6th March.
> > > > > > It is now 14th.
> > > > > >
> > > > > > I think it reasonable to give us all a little time to
> > read your
> > > > work
> > > > > > after
> > > > > > all of the effort you have put into it.
> > > > > >
> > > > > > Adrian
> > > > > > --
> > > > > > Adrian Farrel  mailto:[email-masked]
> > > > > > ATM, MPLS and Telecoms Development Group
> > > > > > Data Connection Ltd., Chester, UK
> > > > > > http://www.datcon.co.uk/
> > > > > > Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422
> > > > > >
> > > > > >
> > > > > > >-----Original Message-----
> > > > > > >From: Thomas D. Nadeau [mailto:[email-masked]]
> > > > > > >Sent: Tuesday, March 14, 2000 10:49 PM
> > > > > > >To: [email-masked]; [email-masked]; Vijay Srinivasan
> > > > > > >Cc: Cheenu Srinivasan; [email-masked]
> > > > > > >Subject: LSR MIB WG Last Call
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >       Since we have not received any additional comments
> > > > > > >on the current version of the LSR MIB, we would like
> > > > > > >to raise the document to WG Last Call.
> > > > > > >
> > > > > > >       --Tom
> > > > > > >
> > > > > > >
> > > > > >
> > > >
> >

---

From: Cheenu Srinivasan <[email-masked]>
Date: Thu, 16 Mar 2000 10:13:12 -0500

Cheenu