Subject: RE: LSR MIB WG Last Call

From: Arun Viswanathan <[email-masked]>
Date: Wed, 15 Mar 2000 12:55:02 -0800

Tim,
    Thanks for the comments.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Tim
> Mancour
> Tom,
> 
> I think it is a little premature for a last call on this MIB.
> I only had a chance to print-out the -02 version yesterday 
> and have the following comments:
> 
> 	1. There is no mention in the MIB regarding the 
> 	LSP type/style (e.g. E-LSP or L-LSP). Perhaps 
>       an object should be added to the cross-connect table?

Why do you think we need this? The owner object was added to
basically be able to track this.

> 
> 	2. I'm confused about the COS object in the XC table.
> 	Section 4 references the COS information in the [LblStk] 
> 	I-D but there is no mention of COS in this I-D. From the 
> 	mplsXCCOS description, I assume that this value should be 
> 	used to overwrite the EXP bits. If this is true then there 
> 	needs to be a way to disable overwriting the EXP bits. 

The intent was to use any non-zero information in this object
to indicate the action to overwrite as well. I guess having
a separate object is better (can overwrite with zero).

> 
> 	3. Why is the syntax of all of the get next index objects
> 	(e.g. mplsXCIndexNext) read-only? Shouldn't the TestAndIncr
> 	textual convention be followed?

Will check on this.

> 
> 	4. There are a number of typos regarding indexes. For example,
> 	mplsInSegmentXCIndex has a syntax of "Integer32 (1..2147483647)"
> 	but the description states that 0 is a valid value. It may be 
> 	advisable to create textual conventions to avoid these problems;
> 	something like MplsIndex and MplsIndexOrZero.

Okay.

> 
> 	5. There are also problems with bandwidth units and 
> descriptions.
> 	As I understand it, all bandwidths should be in kilobits per 
> 	second. In some places, the UNIT is "bits per second". In other 
> 	places the description contains "kilobits per second 
> (Kbps/sec)" 
> 	which should be either "kilobits per second (Kbps)" or 
> "kilobits 
> 	per second (Kb/sec)".

Will change the text to be consistent with the MplsBitRate definition.

> 
> 	6. Section 6.2 mentions a mplsInterfaceResTable but no table
> 	exists.

Vestige from some internal revisions. Will remove it.

> 
> 	7. The syntax for the mplsInSegmentNPop is 
> Integer32(1..2147483647).
> 	It should be Integer32(0..2147483647) or even INTEGER(0..255); 
> 	since popping 255 labels is still a very large range.

Agreed.

-arun
> 
> Best regards.
> TimM
> 	
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Thomas D.
> Nadeau
> Sent: Tuesday, March 14, 2000 5:49 PM
> To: [email-masked]; [email-masked]; Vijay Srinivasan
> Cc: Cheenu Srinivasan; [email-masked]
> Subject: LSR MIB WG Last Call
> 
> 
> 
> 	Since we have not received any additional comments
> on the current version of the LSR MIB, we would like
> to raise the document to WG Last Call.
> 
> 	--Tom
> 
> 
> 
>

---

From: "Tim Mancour" <[email-masked]>
Date: Wed, 15 Mar 2000 17:46:14 -0500

Arun,

I don't see anyway to manually configure an E-LSP or L-LSP
using the LSR MIB. Without knowing the LSP style, the incoming 
EXP bits cannot be properly interpreted and therefore cannot be
processed.  

On a related note, a better name for the mplsXCCOS object might be
mplsXCEXP. This would allow it to be used for both L-LSP and E-LSPs.
I don't think two separate objects are necessary. Just an enumeration
of values from 0 .. 7 and an ignore(255 ?).

Thanks.
TimM 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Arun
Viswanathan
Sent: Wednesday, March 15, 2000 3:55 PM
To: 'Tim Mancour'; 'Thomas D. Nadeau'; [email-masked]';
[email-masked]'; 'Vijay Srinivasan'
Cc: 'Cheenu Srinivasan'; [email-masked]'
Subject: RE: LSR MIB WG Last Call

Tim,
    Thanks for the comments.

Will check on this.

Okay.

Agreed.

-arun