Subject: RE: LDP MIB last call

From: Cheenu Srinivasan <[email-masked]>
Date: Tue, 14 Mar 2000 12:19:06 -0500

I have the same objections to the current LDP MIB as Tom. The LIB
and the FEC tables are not specific to LDP and do not belong here.
The first one is part of the LSR MIB already and the second one
should be in a seperate packet classifier MIB. They should be removed
before the LDP MIB goes to last call. 

I have seen several messages on this topic but no response from the
authors thus far.

Thanks,
Cheenu Srinivasan

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Friday, March 10, 2000 7:18 AM
To: Vijay Srinivasan; [email-masked]
Cc: [email-masked]'; Cheenu Srinivasan; Arun Viswanathan (E-mail);
Thomas D. Nadeau (E-mail); [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: Re: LDP MIB last call

        I still have two major objections to the current
state of the LDP MIB. There are two tables: the LIB
and the FEC tables, which I and the authors of the
TE/LSR MIBs would like removed. Rob Schmitt also
requested that these tables be removed prior to
version -05 of the MIB. These tables are at least in
part, redundant to that which is present in the LSR 
MIB. I have posted several messages to the mailing list 
requesting discussion on this issue, and both times 
I have not received any responses from the authors, nor
have they replied to the mailing list.  I will ask again for
this discussion to commence.

        --Tom

We would like to commence the last call for: 

Definitions of Managed Objects for the Multiprotocol Label Switching, Label
Distribution Protocol (LDP) 
draft-ietf-mpls-ldp-mib-05.txt 

Last call will end on Friday, March 17.  Please send your comments to the
list. 

Regards, 
- Vijay

---

From: [email-masked] (David Wilder)
Date: Tue, 14 Mar 2000 13:32:43 -0500 (EST)

Cheenu,

Isn't it a little premature to remove those tables from the LDP MIB when there
has not been an acceptable alternative?  I'd rather a little redundancy than
the to use the new proposed MIB which hasn't had the scrutiny that the LDP
MIB has had.

Dave

[Charset iso-8859-1 unsupported, filtering to ASCII...]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 14 Mar 2000 17:37:49 -0500

Hi Dave,

>Isn't it a little premature to remove those tables from the
>LDP MIB when there has not been an acceptable alternative?

         I actually think that now is the time to make sure
that these issues are addressed since the LDP MIB has gone
into WG Last Call.

>I'd rather a little redundancy than the to use the new proposed
>MIB which hasn't had the scrutiny that the LDP MIB has had.

         That may be true in terms of the new MPLS Packet
Classifier MIB which deals most closely with the LDP
FEC table. However, as Arun pointed out, the LIB Table
contained in the LDP MIB is redundant with the LSR MIB.
The LSR MIB has been out for quite a while now, and has been
under as much scrutiny as the LDP MIB.

         --Tom