Subject: RE: LSR MIB WG Last Call

From: Adrian Farrel <[email-masked]>
Date: Wed, 15 Mar 2000 05:00:38 -0000

Tom,

Your latest version is dated 6th March.
It is now 14th.

I think it reasonable to give us all a little time to read your work after
all of the effort you have put into it.

Adrian
--
Adrian Farrel  mailto:[email-masked]
ATM, MPLS and Telecoms Development Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

>-----Original Message-----
>From: Thomas D. Nadeau [mailto:[email-masked]]
>Sent: Tuesday, March 14, 2000 10:49 PM
>To: [email-masked]; [email-masked]; Vijay Srinivasan
>Cc: Cheenu Srinivasan; [email-masked]
>Subject: LSR MIB WG Last Call
>
>
>
>	Since we have not received any additional comments
>on the current version of the LSR MIB, we would like
>to raise the document to WG Last Call.
>
>	--Tom
>
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 15 Mar 2000 08:09:46 -0500

Please do give comments if there are any.
The WG Last Call should not preclude that. The
reason why we decided to go WGLC at this point
was that even during the last round of reviewed
comments (most were from you in fact), the comments
were relatively minor. We feel that the MIB is pretty
solid and mature at this point.

         --Tom

---

From: Hans Sjöstrand <[email-masked]>
Date: Wed, 15 Mar 2000 18:37:53 +0100

Tom,

I would like to know why you have "issued a last call?

You should ( and probably are) very familiar with WG last calls
procedures. And those defenetly don't say that somebody whoever can
issue a last call because he feels something. 

Also, I would assume that you are very aware that a mib that formally
have been out in two days and have had a second revision within two
weeks are not a "solid and mature" one. It almost ridiculous to say
something like that when it doesn't even compile! 

The only thing you create is confusion, hopefully that isn't the goal of
the exercise. But what was your purpuse?

/// Hasse

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 15 Mar 2000 13:33:02 -0500

Hi Hans,

>I would like to know why you have "issued a last call?

         I did not issue a last call, as I cannot, nor
was it my intention to do so. The intent of my first
message to George and Vijay was to ask for a WG Last Call
on the MIB. My second message was referring to this
request, not declare a last call. I apologize for the
confusion.

>It almost ridiculous to say

         We compiled the current version with SMIC prior
to releasing it. What are you compiling it with?
Please provide me with your compilation errors
so that I can look into this ASAP.

>The only thing you create is confusion, hopefully that
>isn't the goal of the exercise. But what was your purpuse?

         Of course not. My purpose was to ask for a last call
and nothing else.

         --Tom

---

From: Hans Sjöstrand <[email-masked]>
Date: Wed, 15 Mar 2000 20:18:52 +0100

> request, not declare a last call. I apologize for the

Thanks Tom for the clarification on your last call. You 
certanly fooled me and a lot of others I think.  

> > something like that when it doesn't even compile!

The main point wasn't that it didn't compile, but after 
finding several errors in it I draw the conclusion that it 
didn't go near a compiler. Maybe I was premature in 
my conclusion. For me it was just another 
indicator that there is some more work on this before it's 
mature. 

> so that I can look into this ASAP.

FYI, but as I said, those are editorials.  

MPLS-LSR-MIB.mib: 774: Error: syntax error before: mplsInSegmentOctets
{error,compilation_failed}

-- Then I fixed that to get further
MPLS-LSR-MIB.mib: 813: Error: Types for mplsInSegmentHCOctets differs
from the SEQUENCE definition. 
{error,compilation_failed}

-- Then I fixed that to get further
MPLS-LSR-MIB.mib: Error: 'mplsTSpecIndexNext' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsLabelStackRowStatus' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsLabelStackLabel' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsLabelStackIndex' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsLabelStackIndexNext' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsMaxLabelStackDepth' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsXCOwner' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsXCCOS' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsXCLspId' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsOutSegmentErrors' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInSegmentErrors' missing in OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceOutFragments' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceFailedLabelLookup' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceAvailableBuffer' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceTotalBuffer' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceAvailableBandwidth' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsInterfaceTotalBandwidth' missing in
OBJECT-GROUP
MPLS-LSR-MIB.mib: Error: 'mplsOutSegmentDown' missing in
NOTIFICATION-GROUP
{error,compilation_failed}

-- then I gave up

> > > > I think it reasonable to give us all a little time to read your
> > work
> > > > after