Subject: RE: Optical IP activities

From: John Drake <[email-masked]>
Date: Thu, 16 Mar 2000 13:46:17 -0800

John,

I was at the meeting and I think that my statement stands.  Their first
priority is a UNI interface, and their definition of NNI is network to
network.

Thanks,

John

-----Original Message-----
From: John Strand [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 11:56 AM
To: 'John Drake'
Cc: [email-masked]
Subject: RE: Optical IP activities 

John,
Thanks for the Awduche reference which also supports expanding the MPLS
charter to cover
both overlay and peer models.

Your statement about the OIF isn't completely up to date.  At their most
recent meeting
they started a signalling WG to produce specifications for service
discovery, lightpath
attributes, transporting signaling information, and NNI. They identified
this work
as being "..closely related to work at IETF ... Technical documents will be
exchanged
as appropriate."

John

John Strand
AT&T
Lightwave Networks Research Dept.
100 Schulz Drive, Room 4-212
Red Bank, N.J. 07701-7033
(732)345-3255
[email-masked] 
-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 11:16 AM
To: 'Yakov Rekhter'; [email-masked]
Cc: 'CATANZARITI Sergio FTR&D/TI'; 'Chip Sharp'; [email-masked]
Subject: RE: Optical IP activities 

The Awduche draft, which provided the impetus for the MPL(ambda)S work,
specificaly states that both the overlay model, as well as the peer model,
will be supported.  

Further, neither the ODSI nor the OIF are currently working to define the
control plane for a network of OXCs (or PXCs), so it doesn't seem as though
there are overlapping activities.

John

---

From: "John Strand" <[email-masked]>
Date: Mon, 20 Mar 2000 14:23:51 -0500

I checked with several people who actually attended the OIF meeting and
they confirmed John Drake's statement of OIF priorities.
John

John Strand
AT&T

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 4:46 PM
To: [email-masked]'; John Drake
Cc: [email-masked]
Subject: RE: Optical IP activities 

John,

Thanks,

John

-----Original Message-----
From: John Strand [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 11:56 AM
To: 'John Drake'
Cc: [email-masked]
Subject: RE: Optical IP activities 

John,

John

John Strand
AT&T
-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Thursday, March 16, 2000 11:16 AM
To: 'Yakov Rekhter'; [email-masked]
Cc: 'CATANZARITI Sergio FTR&D/TI'; 'Chip Sharp'; [email-masked]
Subject: RE: Optical IP activities 

John

---

From: Zheng Wang <[email-masked]>
Date: Mon, 20 Mar 2000 15:49:41 -0500

I dont know if someone has raised this question or not. 
The label value 3 is reserved for Implicit NULL Label.
The draft says:

           iv. A value of 3 represents the "Implicit NULL Label".
                 This is a label that an LSR may assign and distribute,
                 but which never actually appears in the encapsulation.
                 When an LSR would otherwise replace the label at the
                 top of the stack with a new label, but the new label is
                 "Implicit NULL", the LSR will pop the stack instead of
                 doing the replacement.  Although this value may never
                 appear in the encapsulation, it needs to be specified
                 in the Label Distribution Protocol, so a value is
                 reserved.

My question is which label is used to determine the next hop in this
case, the imcoming label or the new top label after the popping of the
stack?

Thanks in advance
Cheers
Zheng