Subject: bug in draft-ietf-rsvp-lsp-tunel-04 ?

From: Sridhar Komandur <[email-masked]>
Date: Fri, 31 Mar 2000 09:59:32 -0500 (EST)

Hi,

Section 3.2 (page 14) currently  has 
<FF flow descriptor> ::= [ <FLOWSPEC> ] <FILTER_SPEC> <LABEL>
                               [ <RECORD_ROUTE> ]

i.e  FLOWSPEC is optional, while this is illegal in classical rsvp (rfc2205). 
Shouldn't flowspec be mandatory ?

thanks,

- Andy Malis, Jack Shaio, Sridhar Komandur

---

From: Rohit Chhapolia <[email-masked]>
Date: Fri, 31 Mar 2000 12:23:34 -0500

Yes, it is mandatory as was discussed on the mailing list some time
back. Please see the attached mail (from last discussion) for more details.

Rohit

-- 
Rohit Chhapolia
Globespan, Inc.
mailto:[email-masked]
http://www.globespan.net

Subject: Re: RSVP: Usage of FlowSpec
Date: Thu, 16 Dec 1999 10:40:23 -0500
From: Lou Berger <[email-masked]>
To: Rohit Chhapolia <[email-masked]>
CC: Lou Berger <[email-masked]>, MPLS WG <[email-masked]>, [email-masked]

At 10:05 AM 12/16/99 -0500, Rohit Chhapolia wrote:
>Lou,
>
> > >- In the rsvp-tunnel-04 draft (section 3.2), FlowSpec is defined
> > >to be optional when the reservation style is FF but it is mandatory
> > >for SE. Is this intentional? If yes, why so?
> >
> > I think the text is ambiguous.  There should be at least 1 FlowSpec for
FF,
> > see the format in rfc2205.  It's clear there, but obviously doesn't
include
> > labels.  It would be good for the text to be clear on this.
>
>The SenderTSpec is optional in the PATH message to allow creating LSP which
>does not have any QoS associated with it.

Rohit,

This is a bug in the document.  Sender description should read:

       <sender descriptor> ::=  <SENDER_TEMPLATE>  <SENDER_TSPEC>
                                [ <ADSPEC> ]
                                [ <RECORD_ROUTE> ]

i.e., sender_tspec is always required.  If you don't want QoS, a
Class-of-Service SENDER_TSPEC object with a CoS value of 0 should be used.

Thanks for pointing this out.

>  In this case, the RESV message
>generated from egress node need not have any FlowSpec in it. If one must
>be provided, what should be the contents of this object?

Class-of-Service FLOWSPEC object.

> > >- In the native RSVP,
> >
> > what does that mean?
>
>Just a colloquial for rfc2205.
>
> > >  let's assume that the style is SE and there are
>                                     ^^
>                                     FF
> > >multiple FilterSpecs in the RESV message. In this case, if FlowSpec is
not
> > >present before second FilterSpec, it should be assumed that it is same
as
> > >the FlowSpec for first FilterSpec. Since, (if) FlowSpec is optional
> for mpls-rsvp,
> > >this rule can cause a problem. The absence of FlowSpec can also be
> interpreted
> > >as no FlowSpec is desired for this FilterSpec. There is some ambiguity
> here.
> >
> > in the question too.  There's always 1 FlowSpec for SE.
>
>Sorry, no issues for SE here. Please read this question with SE replaced
>by FF.

With the above, I think this should no be clear.

Thanks,
Lou

>Rohit
>--
>Rohit Chhapolia
>Ficon Technology, Inc.
>mailto:[email-masked]
>http://www.ficon-tech.com