Subject: RE: draft-ietf-mpls-lsr-mib-02.txt nits

From: "Atkinson, Stephen" <[email-masked]>
Date: Tue, 21 Mar 2000 10:15:40 -0500

Hi Tom,

Just one comment below on the LSPID.

Regards,
steve atkinson

>-----Original Message-----
>From: Thomas D. Nadeau [mailto:[email-masked]]
>Sent: Monday, March 20, 2000 4:12 PM
>To: Adrian Farrel; [email-masked]
>Cc: [email-masked]; [email-masked]
>Subject: RE: draft-ietf-mpls-lsr-mib-02.txt nits
>
>
>
>        Hi Adrian,
>
>        My comments are in blue.
>
>
>>> 1. LSPID
>>>   
>>>   In previous mail exchanges I asked why the LSPID Textual
>>>   Convention needed to allow 63 bytes.  You answered that
>>>   this was to allow space for IPv6 addresses.
>>>
>[snip]
>
>The LSPID is not the label.
>I  don't  think the framework mentions LSPID at all.  This is
>something in the protocols where 2 bytes is the currently defined
>maximum.  
>I don't suppose this is a big issue - just pushing you to try to 
>understand why 63 bytes.
>
>        Agreed. We will make it 4 bytes.

The LSPID needs to be 6 bytes to handle CR-LDP using IPV4.
Refer to section 4.5 "LSPID TLV" of draft-ietf_mpls-cr-ldp-03.txt.
I believe the same is true for TE-RSVP.

[snip]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 21 Mar 2000 10:59:51 -0500

Hi Stephen,

>I believe the same is true for TE-RSVP.

         Okay. We will make this change, and probably make it
8 bytes just to be safe. I knew that the original, larger value
for the octet string albeit big, would have sufficed for
all cases. ;)

         BTW, Joan, should you make this change in the LDP
MIB as well to be consistent? You currently have LSP ID
defined as:

mplsLdpLibLspId  OBJECT-TYPE
          SYNTAX       Unsigned32 (1..4294967295)

         --Tom