Subject: LDP Session Initialization & MPLS Hardware

From: "Jorge Patrão" <[email-masked]>
Date: Thu, 27 Apr 2000 10:56:00 -0700

Hi everybody!

    Do you know where can I find information on MPLS hardware vendors, models and it's features?

    I alse have a doubt regarding LDP Session Initialization as described in draft-ietf-mpls-ldp-06, section 2.5.3, pages 15/16.
 
    2 LSRs are initiating an LDP session, LSR2 is active.
 
                    LSR1---------------------------------------LSR2

    LSR2 establishes the TCP connection and sends an initialization message to LSR1.
    LSR1 processes the message and finds the proposed session parameters to be acceptable. It sends an Initialization message proposing it's own session parameters and a KeepAlive message to signal acceptance of LSR2's parameters.
    Next, LSR2 processes LSR1's init message - here's where the doubts begin.
 
    First, lets suppose the parameters LSR1 wishes to use are unacceptable to LSR2. What happens?
        According to the LDP spec, LSR2 closes the connection [Page 16, 2.b)] - remember that LSR1 agreed on LSR2's parameters.
 
    Second, suppose that the parameters LSR1 wishes to use are acceptable to LSR2.
        LSR2 replies with a KeepAlive message - and I presume that the parameters used are proposed by LSR1.

    Am I missing anything?

    Thanks for your help,

                Jorge

---

From: "James R. Leu" <[email-masked]>
Date: Thu, 27 Apr 2000 13:15:04 -0500

Comments within:

>     LSR1 processes the message and finds the proposed session parameters to be acceptable. It sends an Initialization message proposing it's own session parameters and a KeepAlive message to signal…

Both sides send init messages with the parameter they want.  In other words
LSR2 already knows what it will send in it's init message before it recieves
the init message from LSR1.  After they exchange init message, it is up to
each LSR to arrive at the same subset of parameters.  If each LSR follows the
spec then this is not a problem.  They signal to each other that this subset
of parameters is acceptable by exchanging keepalives.  If either side
find the subset unacceptable, they send a notification and close the TCP
session.

Does this make sense?

Jim

-- 
James R. Leu