Subject: RE: TE Extension of IGP

From: "Don Fedyk" <[email-masked]>
Date: Fri, 21 Apr 2000 12:58:33 -0400

Indra

Don: 

I don't see your reasoning below. Could you please 
explain why you would still prefer to do the path selection 
for the protection LSP online when the working LSP is 
calculated offline.   

I am assuming the state of the network is not in synch with the offline
tool. 

Of course one can make this a gray area as well by saying that the offline

tool could listen to IGP and generate paths but our experience is that TE

info changes faster than IGP reachability and hence we have proposed 

feedback that supports the online calculation tageted at the source node.  

Maybe we're looking at different problems. 
My understanding of the problem is that you would like to 
compute n working LSPs on a network using an offline tool, 
and each working LSP is to be protected by another protection 
LSP using a common option; e.g., 1:1 or 1+1 (it may be 
expanded to include shared protection). 
The question is that would it be better for the protection 
LSPs to be computed offline or online?  

If you do it that way, offline may be reasonable. The question is:  Is that
the majority

of your LSPs or just a selected few ?  A selected few is O.K. but for the
rest 

online scales better and is more manageable.  What I was talking about was 

restoration of LSPs that may take a little longer but is much less
expensive.

Don 

indra 

Don Fedyk wrote: 

Indra 

I disagree, even if you compute your LSPs offline the protection is 
most useful on network. You can't possibly calculate all the failure 
possibilities offline. The only exception is dedicated protection 
circuity which is more expensive. 

Don 

> -----Original Message----- 
> From: Indra.Widjaja [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, April 21, 2000 9:51 AM 
> To: Bora Akyol 
> Cc: HANSEN CHAN; [email-masked] 
> Subject: Re: TE Extension of IGP 
> 
> 
> Bora Akyol wrote: 
> 
> > On the contrary, 
> > 
> > The IGP extensions are needed because most protection LSP 
> calculation 
> > happens on box and most vendors support automatic routing of LSPs. 
> 
> Actually, if you compute your working LSP offline, you would generally 
> prefer 
> to also compute the corresponding protection LSP offline, except for 
> local repair. 
> 
> indra 
> 
> > 
> > 
> > Bora Akyol 
> > 
> > At 01:59 PM 4/20/00 -0400, you wrote: 
> > >I am trying to understanding the use of TE extension of 
> IGP in a MPLS 
> > >network. From my understanding, you need TE extension when 
> you're doing 
> > >on-node path computation. However, since LSPs in today's 
> MPLS network 
> > >are usually computed off-node (in software tool), why 
> would the use of 
> > >TE extension be critical? 
> > > 
> > >Appreciate if someone can shed some light on this question. 
> > > 
> > >Thanks, 
> > >Hansen 
> > > 
> 
> 
>

---

From: "Indra.Widjaja" <[email-masked]>
Date: Fri, 21 Apr 2000 16:38:03 -0400

Don:

>      If you do it that way, offline may be reasonable. The
>      question is:  Is that the majority
>
>      of your LSPs or just a selected few ?  A selected few is
>      O.K. but for the rest
>
The number of LSPs computed offline depends on the network environment.
In particular,
if the traffic demand for a given node pair is predictable for a
relatively long duration,
then there is a role for computing such an LSP offline. On the other
hand, if the traffic
demand cannot be predicted, then one has to resort to an online system
only.
It is generally not worth doing offline computation if only a few LSPs
are
computed offline since the major advantage of an offline system  is
better network
efficiency. This is because a few LSPs computed offline would mostly not
result in
a significant overall improvement. Of course, there are specific cases
which this
may not be true.

>      restoration of LSPs that may take a little longer but is
>      much less expensive.
>
So you're refering to protection LSPs that are established "on-demand"
after
failure notification is received, in which case an online system is the
only option.

indra