Subject: encoding 2 labels in vpi/vci fieds

From: "Abes, Andi" <[email-masked]>
Date: Fri, 7 Apr 2000 10:31:37 -0400

Hi,

In the back of my mind I have this recolection of reading about this 
possible encoding - 
the VPI  encodes the top level label and the VCI the next higher label.

I think it was in atm-mpls-00, but I don't have that version anymore.
In the current atm-mpls-02 this encoding not mentioned.

Is this a valid way to encode labels over ATM ?

Thanx.

---

From: Shahram Davari <[email-masked]>
Date: Fri, 7 Apr 2000 07:48:05 -0700

Abes,

Check section 3.25.2. of : 

http://www.ietf.org/internet-drafts/draft-ietf-mpls-arch-06.txt

-Shahram

>-----Original Message-----
>From: Abes, Andi [mailto:[email-masked]]
>Sent: Friday, April 07, 2000 10:32 AM
>To: MPLS mailing list
>Subject: encoding 2 labels in vpi/vci fieds
>
>
>Hi,
>

---

From: Paul Brittain <[email-masked]>
Date: Fri, 7 Apr 2000 16:06:23 +0100

Andi,

I think there was a discussion in an earlier draft on ATM VP-switching
(draft-feldman-mpls-atmvp??) that likened use of VP switching to the use of
a VCI lower label within a VPI top label.  However the MPLS Architecture
doesn't treat VP switching like this any more - it just considers it to be a
means of achieving label merge.

I think the only currently documented way to carry a label stack in ATM is
to put the top-most label in the cell header and carry the lower labels in
shim headers on the packet.

Hope this helps,

Paul. 

-----Original Message-----
From: Abes, Andi [mailto:[email-masked]]
Sent: 07 April 2000 15:32
To: MPLS mailing list
Subject: encoding 2 labels in vpi/vci fieds

Hi,

Thanx.