Subject: Higher labels and RSVP

From: "Abes, Andi" <[email-masked]>
Date: Thu, 6 Apr 2000 11:33:23 -0400

Hi, 

I'm trying to resolve a question that looked simple at first:

Is it correct to say that higher level labels can only be drawn from the 
per-platform label space ?

At first it seemed natural, and then I even found in my archives discussions
before the BGP draft was issued that reinforced my conviction:

since packets labeld with BGP labels can arrive at an LSR over different 
interfaces, and the route my vary depending on IGP activity,
at packet reception time - the LSR can not tell by what interface the
labeled
packet should have arrived at.

This is all fine, and sound fine for BGP assigned labels. But...
When labels are assigned using RSVP the whole label stack 
is assigned at once - such that it depends on the semantics  -
is the label stack valid only as a whole ? 
Can the LSR that received the label binding (with 2+ labels)
use the higher levels stacked on other top labels ?

If the former is the case - then per-interface label space can be used.
if the latter, then only per-platform space can be used.

To make things interesting, in draft-swallow-rsvp-bypass-label-00 it
is explicitly assumed that the higher labels can be used with different
top labels (one for the original tunnel and a different one for the bypass
tunnel).

Ok,
so what say you ?

Andi.

---

From: "Abes, Andi" <[email-masked]>
Date: Fri, 7 Apr 2000 13:04:44 -0400

Hi again,

thanx to Shahram Davari for giving me the reference -

The MPLS arch allows (section 3.25.2 - bullet 2. SVP Encoding)
to encode 2 labels in the VPI/VCI fields, and states
that this might not always be usable.

So, when allocating a higher label (not a top one),
it could concievably by used in an SVP encoding - 
like in the case of 2 directly connected LSR using 
LCATM interfaces.

In this case, the second label has to be from a per-interface
label pool.

Is this encoding still supported ?
Any of this make sense ?

Can a statement that says that higher level label
are always from the per-platform label space still 
be made ?

Andi.

> -----Original Message-----
> From: Abes, Andi [mailto:[email-masked]]
> Sent: Thursday, April 06, 2000 11:33 AM
> To: MPLS mailing list
> Subject: Higher labels and RSVP
> 
> 
> Hi, 
>