Subject: cr-ldp

From: "ashish" <[email-masked]>
Date: Thu, 13 Apr 2000 12:17:25 +0530

Hi Everybody,
I have few queries regarding CR-LDP draft : draft-ietf-mpls-crldp-03.txt .
1. In traffic parameter TLV, there are 3 fields: 
  a. PBS : Peak Burst Size 
  b. CBS : Committed Burst Size 
  c. EBS : Excess Burst Size    
 Whats the relation between these . 

2. In Resource Class TLV, its said there are 32 administrative groups or colors of Resources. 
Is there any document or draft explaining these Resource Classes.
I have checked 
a)cr-ldp draft and 
b)RFC -2702 - requirements for Traffic Enggineering over MPLS.
But there is not much detail regarding Resource Classes and how Resources are classified into 32 Resource Classes.
Are these Resource Classes Implementation Dependent or there are some standards for these.
Please Clarify
Cheers
ashish

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Mon, 17 Apr 2000 10:44:42 -0400

>  Whats the relation between these .

   Bilel can answer these better than I but he's been off sick. 
I'll ask him to post something when he gets a chance.

> Are these Resource Classes Implementation Dependent or there are some standards for these.

   The resource classes are intended to be a generic set of properties that can be compared against a
generic set of constraints. The idea is that you do not need to know (on a global basis) what these 
individual bits mean. Within an administrative domain, the network operator will decide what 
each bit means and assign them accordingly. 

   For example: 

       Let's say you want to assign bit #4 to mean "protected link". You would then go round
your network and when provisioning links which have some kind of physical protection, you would
set bit $4 in the Resource Class vector. This would then cause this bit to be propogated around.

       Now, when you want to establish a CR-LSP which only traverses "protected links" you simply
remove all links which do not have bit#4 set, in addition to those that do not have the required
bandwidth, and then run Dijkstra over the remaining topology.

       If one of your neighbouring systems uses a different bit to mean "protected" then either
you have to map one to the other, or, simply not honor his request.

    Aside:

        We did actually propose having common meanings for 1/2 the bit vector so that it would
be less likely that we would have boundary inconsistencies later but we were beaten into
submission ;)

    Cheers,

    Peter Ashwood-Smith

---

From: "Subodh Mathur" <[email-masked]>
Date: Fri, 21 Apr 2000 10:22:24 -0400

Hi,
How will setting up of a CR LSP with Preemption TLV will deal with an
existing CR LSP which has been setup without using optional Preemption TLV?.
Assuming there is a contention of resources between them. The draft on
CR-LDP does not make it clear or I might have missed it.
Thanks,
Subodh Mathur
Digital Technology Inc.,
Bedford, MA 01730

---

From: Anup Anil Cheruvathoor <[email-masked]>
Date: Mon, 24 Apr 2000 10:40:45 +0530

Hi,

> CR-LDP does not make it clear or I might have missed it.

U can assume default setup and hold priority values for those CR-LSP which are
setup without the preemption TLVas an local decision. The values are 4 for
default.

This matter can be locally decided as to what is the default priority to be
given. Even if the pre-emption is not present, based on the other parameters
like FEC, bandwidth etc, LSR policies can  decide the  default setup and
hold-priority for the CR-LSP.

--

Name : Anup Anil Chervathoor
E-mail : mailto:[email-masked]
Web : www.ficon-tech.com