Subject: RE: TE Extension of IGP

From: "Don Fedyk" <[email-masked]>
Date: Fri, 21 Apr 2000 09:07:36 -0500

Indra

I disagree, even if you compute your LSPs offline the protection is
most useful on network. You can't possibly calculate all the failure 
possibilities offline. The only exception is dedicated protection 
circuity which is more expensive.

Don

> -----Original Message-----
> From: Indra.Widjaja [mailto:[email-masked]]
> Sent: Friday, April 21, 2000 9:51 AM
> To: Bora Akyol
> Cc: HANSEN CHAN; [email-masked]
> Subject: Re: TE Extension of IGP
> 
> 
> Bora Akyol wrote:
> 
> > On the contrary,
> >
> > The IGP extensions are needed because most protection LSP 
> calculation
> > happens on box and most vendors support automatic routing of LSPs.
> 
> Actually, if you compute your working LSP offline, you would generally
> prefer
> to also compute the corresponding protection LSP offline, except for
> local repair.
> 
> indra
> 
> >
> >
> > Bora Akyol
> >
> > At 01:59 PM 4/20/00 -0400, you wrote:
> > >I am trying to understanding the use of TE extension of 
> IGP in a MPLS
> > >network. From my understanding, you need TE extension when 
> you're doing
> > >on-node path computation. However, since LSPs in today's 
> MPLS network
> > >are usually computed off-node (in software tool), why 
> would the use of
> > >TE extension be critical?
> > >
> > >Appreciate if someone can shed some light on this question.
> > >
> > >Thanks,
> > >Hansen
> > >
> 
> 
>

---

From: "Indra.Widjaja" <[email-masked]>
Date: Fri, 21 Apr 2000 10:38:13 -0400

Don:

I don't see your reasoning below. Could you please
explain why you would still prefer to do the path selection
for the protection LSP online when the working LSP is
calculated offline.
Maybe we're looking at different problems.
My understanding of the problem is that you would like to
compute n working LSPs on a network using an offline tool,
and each working LSP is to be protected by another protection
LSP using a common option; e.g., 1:1 or 1+1 (it may be
expanded to include shared protection).
The question is that would it be better for the protection
LSPs to be computed offline or online?

indra