Subject: RE: Any more comments on draft-ietf-mpls-te-feed-00.txt?

From: "Don Fedyk" <[email-masked]>
Date: Thu, 6 Apr 2000 12:56:32 -0500

Dear Atsushi Iwata, 

The feedback draft is aimed at numbered links only. The cycle is 
a path is selected from a topology database that is populated by 
an IGP. Both IGPs use the same format so it does not matter which 
IGP. The path becomes the ER MPLS LSP.

Next the ER LSP is established and our Draft uses CR-LDP to accomplish 
this. If a link that is not able to support the path is encountered, 
the bandwidth profile (independent of the IGP for the number link) is
added to the failure notification. This information is generated for 
every link along the traversed section of the path.

This information can then be added to the topology database improving its
accuracy for all subsequent path requests.  

A crankback as you describe cannot update the database since it may 
not have an accurate bandwidth profile. This could happen if you 
encountered a node that did not support the feedback. So crankback
could be the degenerate case of feedback. 

ER paths can support un-numbered links in some cases. When the path is 
loose routed, for example, but this is not the constraint based case 
we were covering in the draft.

Don

> -----Original Message-----
> From: Atsushi Iwata [mailto:[email-masked]]
> Sent: Wednesday, April 05, 2000 8:30 PM
> To: Ashwood-Smith, Peter [CAR:CS57:EXCH]
> Cc: MPLS mailing list; Norihito Fujita
> Subject: Re: Any more comments on draft-ietf-mpls-te-feed-00.txt?
> 
> 
> Hi, Peter,
> 
> I have one comment.
> 
> At 10:17 00/04/05 -0400, Peter Ashwood-Smith wrote:
> >RE: draft-ietf-mpls-te-feed-00
> >
> >   Still looking for feedback on the feedback draft ... pun
> >intended.
> >
> >   I will be asking the WG chairs for a last call on this in the
> >next few days unless somebody has some issues with it.
> 
> As I explained our draft, 
> draft-fujita-mpls-crldp-crankback-00.txt, in the 
> last IETF, there are several possibilities of indicating of 
> links or nodes. 
> If you use unnumbered point-to-point links between routers, 
> you cannot 
> specify IPv4 address of interfaces for IPV4 specificed link 
> feedback TLV 
> and IPV6 specified link feedback TLV. In that case, you have to use a 
> routing protocol (OSPF etc) dependent TLV to indicate links or nodes.
> 
> Our draft specifies protocol independent TLV (using ER-HOPS 
> information) 
> and routing protocol dependent TLV (OSPF, ISIS-specific 
> information). I 
> guess that our draft could be an one of possible solution to 
> indicate such 
> links or nodes.
> 
> What do you think ?
> 
> Best regards,
> ----------------------------------------------------------------
> Atsushi Iwata
> Assistant Manager
> Network Architecture TG, Networking Research Laboratory
> C&C Media Research Laboratories
> NEC Corporation
> 4-1-1 Miyazaki Miyamae-ku, Kawasaki, Japan 216-8555
> TEL: +81-44-856-2123 (Direct), Fax: +81-44-856-2230 (Direct)
> NEC-internal TEL: 8-272-3281, NEC-internal FAX: 8-272-3299
> E-mail: [email-masked]
> 
> ** New organization has started since Apr.1, 2000. ***
> 
>

---

From: Atsushi Iwata <[email-masked]>
Date: Fri, 07 Apr 2000 10:54:30 +0900

Dear Don Fedyk,

Thank you for your reponse.

I understand the target of your draft.
Could you add any sections which clarify the current limitation of your 
draft, such as not supporting unnumbered links, or something like that ?

Regards,

At 12:56 00/04/06 -0500, Don Fedyk wrote:

> > From: Atsushi Iwata 
> [<mailto:[email-masked]>mailto:[email-masked]]

----------------------------------------------------------------
Atsushi Iwata
Assistant Manager
Network Architecture TG, Networking Research Laboratory
C&C Media Research Laboratories, NEC Corporation
4-1-1 Miyazaki Miyamae-ku, Kawasaki, Japan 216-8555
TEL: +81-44-856-2123 (Direct), Fax: +81-44-856-2230 (Direct)
NEC-internal TEL: 8-272-3281, NEC-internal FAX: 8-272-3299
Internet E-mail:     [email-masked]
NEC-internal E-mail: [email-masked]

---

From: "Don Fedyk" <[email-masked]>
Date: Fri, 7 Apr 2000 09:55:00 -0500

Dear Atsushi Iwata

Usually, we do not specify limitations that are required attributes of
the design. Numbered links are a required part of the current TE design.

Don

> Sent: Thursday, April 06, 2000 9:55 PM
> To: Fedyk, Don [BL60:2001:EXCH]
> Cc: Ashwood-Smith, Peter [CAR:CS57:EXCH]; MPLS mailing list; Norihito
> Fujita
> Subject: RE: Any more comments on draft-ietf-mpls-te-feed-00.txt?
> 
> 
> Dear Don Fedyk,
>