Subject: LDP Abort message notification

From: manikantan <[email-masked]>
Date: Fri, 5 May 2000 18:18:28 +0530

Hello

Can some one clarify my doubts?

When a downstream LSR (LDP Peer) receives an LDP Abort
message from its upstream LSR (LDP Peer) it is expected to
respond with a notification message with status indicating
"Label Request Aborted - 0x00000015".

My doubts are 
1) What should be message id value in the Status TLV
that is to be sent in the notification message?

  a) Should the message id value be the message id
      value of the Label request message received from the
      upstream peer earlier (for which the abort is sent now)?
  b) or Should the message id value be the message id
      value of the Label Abort message received from the
      upstream peer?
      
2) If the message id is to be the value of the one that is
    received in the label Abort message, then how do 
    we indicate the message id of the earlier received
    Label Request message. ( this is required to locate
    the LSP control block). 

    Should the message id of the earlier received Label
    Request message be sent in the Optional parameter -
    Extended  Status?

Thanks in advance
with best regards
mani

---

From: Bob Thomas <[email-masked]>
Date: Fri, 05 May 2000 09:24:23 -0400

Mani,

>       value of the Label Abort message received from the

It should be b), the message id of the received Label Abort message.

>     Label Request message. ( this is required to locate

From Section 3.5.9.1. Label Abort Request Message Procedures of
draft-ietf-mpls-ldp-0x.txt:

   When an LSR receives a Label Abort Request message, if it has not
   previously responded to the Label Request being aborted with a Label
   Mapping message or some other Notification message, it must
   acknowledge the abort by responding with a Label Request Aborted
   Notification message.  The Notification must include a Label Request
   Message ID TLV that carries the message ID of the aborted Label
   Request message.

Bob