Subject: Re: MPLS and IS-IS

From: Jessica Yu <[email-masked]>
Date: Thu, 18 May 2000 07:08:05 -0700 (PDT)

Every couple of years (as recent as last year), IS-IS
vs OSPF debate pops up. Same history reiterated, same
comparison made and not much differences among the two
discovered. 

Every time a new features to be added to IGP such as
TE, parallel efforts have to be made to add it to both
protocols.

Every time someone building a new network, they have
to spent time agonizing about what to use: OSPF or
IS-IS.

Every router vendor has to split already thin software
development resource to develop and/or maintain both
IGP protocols. As a result, instead of having a fully
cooked IGP, they may have two half-cooked ones.

......

Lots lots energy, resource and brain power can be
saved.

So the question is -

Is there any value to continue supporting 2 different
IGP protocols which essentially serve the same purpose
(especially the need for supporting CLNS does not
exist) and there is no obvious advantages associated
with one over the other ?

To continue serve the installed base is probably the
only reason to keep both? Anything else?

By the way, it's fortunate that BGP and IDRP did not
take the same path. Now we only have one inter-domain
protocol to implement and support.

                                --jessica

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Rene Tio <[email-masked]>
Date: Thu, 18 May 2000 11:15:08 -0700

On Thu, May 18, 2000 at 07:08:05AM -0700, Jessica Yu wrote:
[...]

> with one over the other ?
[...]

Anyone who thinks that any single protocol can (a) be fully cooked or (b)
take care of the entire world's needs really needs to re-think.  Gee, why
not just build a sedan, forget about SUVs, vans, or sports cars.

Nothing wrong with a friendly OSPF / IS-IS debate.  Vive la difference.

R.