Subject: simple question about label encapsulation

From: "Yoav Levy" <[email-masked]>
Date: Thu, 4 May 2000 18:09:53 +0200

In the MPLS Label Stack Encoding Internet Draft the we have this  paragraph
 
      4. Label Value

         This 20-bit field carries the actual value of the Label.

         When a labeled packet is received, the label value at the top
         of the stack is looked up.  As a result of a successful lookup
         one learns:

            (a) the next hop to which the packet is to be forwarded;

            (b) the operation to be performed on the label stack before
                forwarding; this operation may be to replace the top
                label stack entry with another, or to pop an entry off
                the label stack, or to replace the top label stack entry
                and then to push one or more additional entries on the
                label stack.

My problem is this sentence about the label at the top of the stack - “As a
result of a successful lookup one learns (a) the next hop” 

In case of penultimate LSR that do not supports pop operation the egress LSR
should do lookup according to underlying label / IP header.

---

From: Rajiv Papneja <[email-masked]>
Date: Thu, 4 May 2000 16:39:52 -0400 (EDT)

Hi 

Please see the insert :

> should do lookup according to underlying label / IP header. 

Comments : if the Penultimate LSR do not support poping then 
in this scenario, the egress LSR has to do two label lookups
or one label lookup and network address lookup. For further reading please
refer to the Section 3.16. "Penultimate Hop Popping"
(http://www.ietf.org/internet-drafts/draft-ietf-mpls-arch-06.txt) Comments

Take Care 

Rajiv

********************************
Rajiv Papneja (GRA)
Advanced Internet Laboratory
George Mason University,
G10, Johnson Center,
Fairfax, VA 22030-4444
Tel: 703.993.4700
email: [email-masked]
********************************

---

From: "Yoav Levy" <[email-masked]>
Date: Sun, 7 May 2000 08:35:07 +0200

Hi,

I will try to clarify my question:

Is there a contradiction between MPLS Label Stack Encoding Internet Draft
section 4 (a) and Multiprotocol Label Switching Architecture Internet Draft
section 3.16 ?

 * In the first one we have - "...the label value at the top of the stack is
looked up.  As a result of a successful lookup one learns: (a) the next hop
to which the packet is to be forwarded ..."
 * In the second one we have - "... this would require the egress to do TWO
lookups, either two label lookups ..."

Thanks,
Yoav

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]]  On Behalf Of Rajiv
Papneja
Sent:	Thursday, May 04, 2000 10:40 PM
To:	Yoav Levy
Cc:	[email-masked]
Subject:	Re: simple question about label encapsulation

Hi

Please see the insert :

On Thu, 4 May 2000, Yoav Levy wrote:

> My problem is this sentence about the label at the top of the stack - "As
a
> result of a successful lookup one learns (a) the next hop"
>

Take Care

Rajiv

---

From: Eric Gray <[email-masked]>
Date: Sun, 07 May 2000 10:43:13 -0700

Yoav,

    Perhaps the wording in the encapsulation document
could have been a little clearer, but is it really worth it?

    The meaning is made clearer in the architecture draft
where it explicitly states that the "next hop" may be the
local LSR (see the note after bullet "f" on page 15).  If
a second lookup is required, then the logical operation
is to show the next hop as "self" and pop the top label.
When the packet is logically "forwarded" to "self", the
second label (if present) or the higher layer (IP) header
is then used to make a forwarding decision.  Hence,
both documents are consistent - even if the consistency
is not crystal clear at first.

    It is not, of course, necessary to implement this logical
operation explicitly. In this respect, implementations will
fall into 3 categories:

o    those that do not support "pop and look again" - this
is one very good reason to support penultimate hop pop,

o    those that support the logical operation exactly and

o    those that support the logical operation using some
proprietary shortcut.

Although I use the word "proprietary", at least one such
shortcut is really obvious and is very likely in common
use.

--
Eric Gray