Subject: RE: MPLS and IS-IS

From: "Gabor Korossy (ETH)" <[email-masked]>
Date: Wed, 17 May 2000 10:54:14 +0200

Hi,

to answer your question finally:
both protocols have TE extensions defined and those extensions have 
the same fields. 
So, from MPLS TE point of view they are equally good.

btw.: the IS-IS extensions for Traffic Engineering," Internet Draft, 
draft-ietf-isis-traffic-01.txt, May 1999 is expired. 
Anyone updating it? Where could it be found?

regards - Gabor

At 08:22 05/16/2000 -0400, HANSEN CHAN wrote:
>Hi all,
>
>I have been hearing IS-IS is a better protocol to be used than OSPF in a MPLS
>network for TE application. Is that a fair statement? What are the technical
>reasons?

---

From: Danny McPherson <[email-masked]>
Date: Wed, 17 May 2000 12:01:12 -0600

> An overly complex design will almost certainly result in more difficult
> implementation.  More difficult implementations generally give rise to
> more bugs.  I believe there is a strong correlation between protocol
> design quality and implementation quality and simply dismissing that
> relationship seems rather ivory towerish.

I'm not simply dismissing it, I'm dismissing the presumption 
that "ISIS scales better than OSPF, simply because a single
implementation appears as such".  Obviously, if something is
more difficult to implement it's more bug-prone.  However, that
doesn't mean that it's a broken by design or will scale poorly.

-danny

---

From: Danny McPherson <[email-masked]>
Date: Wed, 17 May 2000 12:16:03 -0600

> IS-IS is defined to work with CLNP not for IP originally. Until today a lot
> of SONET and telecommunication equipment vendors still use IS-IS to route
> CLNP packets through the SONET Data communication channel(DCC) to carry
> management information and there is a great pressure to change this to OSPF
> and IP. I also know that UUNET runs IS-IS on their network. I never heard
> any other networks run IS-IS. Seems I am wrong. My questions are.

Note also that besides what Curtis/Dave mentioned wrt the state of
a particular vendors implementation having an impact on which IGP
legacy providers deployed, the capability of IS-IS to support both 
CLNP and IP should be considered.  After all, a lot of the legacy 
ISP networks wanted to pickup NSF contracts at the time, contracts
based on solicitations that required support of both IP and CLNP.
Their desire to avoid a "ships in the night" approach, coupled with 
seemingly more stable IS-IS suuport, lead to an obvious outcome.

> 1. You guys are talking about using IS-IS in a IP networks not in CLNP
> networks. The IS-IS has been modified according to RFC 1195 (Use of OSI
> IS-IS for Routing in TCP/IP and Dual Environments) or some other standard.
> Is this correct? 

Yes.

> 2.  Besides UUNET, which ISPs run IS-IS protocol? Can you name a few? or
> what percentage of networks run IS-IS instead of OSPF?

Of the 7 largest US ISP networks (in my mind), 5 run IS-IS. 

-danny

---

From: Danny McPherson <[email-masked]>
Date: Wed, 17 May 2000 13:46:44 -0600

Dave is actually discussing this at the upcoming NANOG.  I really
can't think of anyone more qualified.

-danny

> Irrespective of who's running what, I'd be interested in hearing someone
> compare the technical aspects of the *protocols* (although of course the
> quality of the available implementation is a factor in any operational
> choice) - I used to be able to do this, but it's been years since I looked at
> the two of them in detail.
> 
> 	Noel

---

From: "Gabor Korossy (ETH)" <[email-masked]>
Date: Thu, 18 May 2000 10:20:20 +0200

Hi,

if I may repeat,
could anyone help me please, find the draft
"IS-IS extensions for Traffic Engineering," 
draft-ietf-isis-traffic-01.txt

If so many ISPs run IS-IS with MPLS TE extensions shouldn't 
it become an IETF standard?
Maybe one of the MPLS, TE and IS-IS working groups doesn´t 
feel ashamed to adopt this child?

regards - Gabor

>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Wednesday, May 17, 2000 8:48 PM
>> To: [email-masked]
>> Subject: FW: MPLS and IS-IS
>> 
>> 
>> 
>> David - 
>> 
>> Most large ISPs in the US use ISIS:
>> 
>> UUnet, C&W, Sprintlink, Qwest, Verio, Digex, Frontier, Broadwing.
>> 
>> It also seems like more and more european ISPs are starting 
>> to use ISIS:
>> EUnet, Ebone, Hermes, TeleDanMark, Renater (FT), Telia, Tele2, etc.
>> 
>> Chris
>> 
>> -----Original Message-----
>> From: David Wang [mailto:[email-masked]]
>> Sent: Wednesday, May 17, 2000 12:36 PM
>> To: 'HANSEN CHAN'; [email-masked]
>> Subject: RE: MPLS and IS-IS
>> 
>> 
>> Hi all,
>> 
>> Thanks
>> David
>> -----Original Message-----
>> From: HANSEN CHAN [mailto:[email-masked]]
>> Sent: Tuesday, May 16, 2000 7:22 AM
>> To: [email-masked]
>> Subject: MPLS and IS-IS
>> 
>> 
>> Hi all,
>> 
>> I have been hearing IS-IS is a better protocol to be used 
>> than OSPF in a
>> MPLS
>> Appreciate if someone can shed some light on this subject.
>> 
>> Thanks,
>> Hansen
>> 
>>

---

From: "Proch, Daniel" <[email-masked]>
Date: Thu, 18 May 2000 16:17:08 -0400

Gabor,

http://202.38.127.18/res/www.ietf.org/internet-drafts/draft-ietf-isis-traffi
c-01.txt

If that link is broke, I will send it to you.

========================
Daniel Proch
Marconi Communications
========================

-----Original Message-----
From: Gabor Korossy (ETH) [mailto:[email-masked]]
Sent: Thursday, May 18, 2000 4:20 AM
To: [email-masked]; [email-masked]'; [email-masked]'
Subject: [Isis-wg] RE: MPLS and IS-IS

Hi,

if I may repeat,

regards - Gabor

>> Appreciate if someone can shed some light on this subject.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Danny McPherson <[email-masked]>
Date: Fri, 19 May 2000 10:15:38 -0600

> I think that router vendors would allocate resources for ISIS and OSPF
> based on their customers' demand for ISIS and OSPF.  So, the answer to
> your question will be determined by customers, not by vendors.
> 
> It seems that so far we've been moving along option (b).

Indeed, it's all about market demand.  And considering there's 
a huge install base for both, well, I doubt either will be 
retired anytime soon.

Besides that, I could envision the "which one should be retired"
debate going on for years, and using more resources then simply
doing parallel development of both.

Lastly, having intially fostered much of the beginning of this 
thread, I'd suggest we now retire it (at least for another year 
or so), we've strayed quite a ways form the mailing lists 
charter.

-danny