Subject: Removal of oper/adminStatus for LSR MIB in/out segments

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 10 May 2000 13:55:14 -0400

Hi,

	We would like to ask if there is any
objection to the removal of the admin/operStatus
objects on the in/outSegment objects in the
LSR MIB. Some folks had asked to have them removed, and
we had intended to do this in the last WG Last Call
version, but did not make the changes then. We would
like to ask if anyone would object to their being
removed in the second last call version.

	--Tom, Cheenu, Arun

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 11 May 2000 11:18:56 +0100

I support this proposal.
Adrian
--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

>-----Original Message-----
>From: Thomas D. Nadeau [mailto:[email-masked]]
>Sent: Wednesday, May 10, 2000 6:55 PM
>To: [email-masked]; cheenu Srinivasan; [email-masked]
>Subject: Removal of oper/adminStatus for LSR MIB in/out segments
>
>
>
>	Hi,
>

---

From: "Mancour, Tim" <[email-masked]>
Date: Thu, 11 May 2000 08:39:06 -0400

Hi,

I fully support removing the adminStatus, and associated notifications and
notification controls for both the in-segment and out-segment. 

In the following cases, however, the segment's operStatus will not simply
reflect the operStatus of the underlying interface:
	1. The segment's rowStatus is set to notInService.
	2. The underlying interface for an out-segment is missing.
	3. An in-segment whose label is out-of-range.

I'm aware that the above won't occur for LSP's that are created via
signalling, but all three are possible (according to my interpretation of
the current MIB) for manually configured LSPs. Therefore, I vote that the
operStatus objects remain - although it might be wise to more clearly define
their return values.

TimM

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Wednesday, May 10, 2000 1:55 PM
To: [email-masked]; cheenu Srinivasan; [email-masked]
Subject: Removal of oper/adminStatus for LSR MIB in/out segments

	Hi,

	--Tom, Cheenu, Arun

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 11 May 2000 17:37:18 -0400

Hi Tim,

>         2. The underlying interface for an out-segment is missing.

         An inSegmentEntry in the active state simply represents an
installed label. It has nothing to do with the underlying interface
per se. What you are asking for is done by the XC's operStatus.

>         3. An in-segment whose label is out-of-range.

         The agent should reject such a SET request (the label
should never be installed).

         --Tom