Subject: Re: MPLS and IS-IS

From: Jessica Yu <[email-masked]>
Date: Fri, 19 May 2000 04:22:44 -0700 (PDT)

Just use your example. Compare to sedan, SUV has
higher clearance, more leg room and advantage when
collision happens. SUVs also consume more gas, pollute
more, etc. Does IS-IS and OSPF have such clear
differences in terms of function and performance? All
the discussion happens year after year pretty much
concluded that the two has little differences (except
quality of implementation difference). So supporting
both does not gain more but consumes more resources. 

In terms of the benefit of having one protocol vs two
very similar ones or whether one is enough. Just think
about the case of BGP. There used to be BGP and IDRP.
The two have very similar function and mechanism. IDRP
supports dual mode (sounds familiar?) Just having BGP
works just as well as having both and maybe better
given vendors do not need to spread thin development
resource to take care of both.

There is nothing wrong to discuss the difference. But
when the content just repeats time after time, it
makes you wonder if we have better things to do.

                             --Jessica
--- Rene Tio <[email-masked]> wrote:
> On Thu, May 18, 2000 at 07:08:05AM -0700, Jessica Yu
> wrote:
> [...]
> > Every router vendor has to split already thin
> software
> > development resource to develop and/or maintain
> both
> > IGP protocols. As a result, instead of having a
> fully
> > cooked IGP, they may have two half-cooked ones.
> 
> > ......
> > 
> > Lots lots energy, resource and brain power can be
> > saved.
> > 
> > So the question is -
> > 
> > Is there any value to continue supporting 2
> different
> > IGP protocols which essentially serve the same
> purpose
> > (especially the need for supporting CLNS does not
> > exist) and there is no obvious advantages
> associated
> > with one over the other ?
> [...]
> 
> Anyone who thinks that any single protocol can (a)
> be fully cooked or (b)
> take care of the entire world's needs really needs
> to re-think.  Gee, why
> not just build a sedan, forget about SUVs, vans, or
> sports cars.
> 
> Nothing wrong with a friendly OSPF / IS-IS debate. 
> Vive la difference.
> 
> R.
> 

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 19 May 2000 05:47:36 -0700

Jessica,

> resource to take care of both.

Just to add, as BGP evolved it included some of the
functionality of IDRP (e.g., multiprotocol extensions,
BGP Refresh).

Yakov.

---

From: Randy Bush <[email-masked]>
Date: Fri, 19 May 2000 15:35:35 -0700

i'll be my normal tactless self.  the problem is that one has to support
ospf because the vast majority of customers use it.  is-is is only used
by a few networks, just the largest ones.  so expect support for both.

randy