Subject: Question:draft-ietf-mpls-atm-03.txt

From: Levi Daphna <[email-masked]>
Date: Wed, 17 May 2000 11:23:45 +0300

Hi

I have a question concerning the MPLS-ATM draft.
In paragraph 7.2 we deal with the scenario of ATM-LSRs which are connected
via an ATM VP cloud. (to my understanding this is an overlay model )
7.2. Connections via an ATM VP 
Sometimes it can be useful to treat two LSRs as adjacent (in some LSP)
across an LC-ATM interface, even though the connection between them is made
through an ATM "cloud" via an ATM Virtual Path. In this case, the VPI field
is not available to MPLS, and the label MUST be encoded entirely within the
VCI field. 
In this case, the default VCI value of the non-MPLS connection between the
LSRs is 32. Other values can be configured, as long as both parties are
aware of the configured value. The VPI is set to whatever is required to
make use of the Virtual Path. 

My question is: How do we set the VPI value, is it through a management
system or is there some signaling between the ATM-LSR and the VP switch.

Thanks in advance,
Daphna

---

From: Hans Sjöstrand <[email-masked]>
Date: Wed, 17 May 2000 13:06:48 +0200

Via management system, e.g in the LDP case you use 
the following object in the LDP MIB

     mplsLdpEntityDefaultControlVpi OBJECT-TYPE
         SYNTAX      AtmVpIdentifier
         MAX-ACCESS  read-create
         STATUS      current
         DESCRIPTION
             "The default VPI value for the non-MPLS connection.  The
             default value of this is 0 (zero) but other values may
             be configured.  This object allows a different value
             to be configured."
         REFERENCE
            "draft-ietf-mpls-atm-02.txt, Section 7.1"
         DEFVAL
             { 0 }
         ::= { mplsLdpEntityAtmParmsEntry 6 }

Regards
/// Hasse