Subject: RE: LSR MIB last call comments

From: manikantan <[email-masked]>
Date: Tue, 9 May 2000 09:03:26 +0530

Hello

I have a doubt.

This is regarding the Type value that is to be assigned to the
ifType in the ifTable (RFC 2233)

The following reference is from draft-ietf-mpls-te-mib-03.txt

mplsTunnelEntry OBJECT-TYPE
   SYNTAX        MplsTunnelEntry
   MAX-ACCESS    not-accessible
   STATUS        current
   DESCRIPTION
       "An entry in this table represents an MPLS
        tunnel.  An entry can be created by a network
        administrator or by an SNMP agent as instructed
        by an MPLS signaling protocol. Whenever a new
        entry is created with mplsTunnelIsIf set to
        true(1), then a corresponding entry is created
        in ifTable as well (see RFC 2233). The ifType of
        this entry is mplsTunnel(150)."
   REFERENCE
       "1. RFC 2233 - The Interfaces Group MIB using
        SMIv2, McCloghrie, K., and F. Kastenholtz, Nov.
        1997
        2. RFC 1700 - Assigned Numbers, Reynolds, J. and
        J. Postel, Oct. 1994"
   INDEX         { mplsTunnelIndex, mplsTunnelInstance }
      ::= { mplsTunnelTable 1 }

From this I understand if the IfType is mplsTunnel, the number to
be assigned is 150.

The following reference is from draft-ietf-mpls-lsr-mib-04.txt   

   When using MPLS interfaces, the interface stack table might appear
   as follows:
   
   +----------------------------------------+
   | MPLS-interface ifType = mpls(166)      +
   +----------------------------------------+
   | Underlying Layer...                    +
   +----------------------------------------+
   
   In the above diagram, "Underlying Layer..." refers to the ifIndex
   of any interface type, which has been defined for MPLS
   interworking.  Examples include ATM, Frame Relay, Ethernet, etc.

   ....
   
   ifType        The value that is allocated for MPLS is 166.

From this I understand if the IfType is mpls, the number to
be assigned is 166.

My doubt is the interface type being "mpls" and "mplsTunnel" different?
if so can this be explained.

If these are same then the values in the two MIBs are to be synced.

thanks in advance
with best regards
mani

---

From: Tony Van Kerckhove <[email-masked]>
Date: Tue, 09 May 2000 12:28:33 +0200

Hello, Manikantan,

The way I understood it, is:

- the ifType 166 is associated with an MPLS layer (something that can
transmit/receive MPLS-encapsulated
  packets and can be associated with a label distribution protocol)
- the ifType 150 is associated with a single LSP

Hence, an mpls interface (166) can be the underlying layer for multiple
mplsTunnels (150).

Regards,

Tony Van Kerckhove
Alcatel

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 09 May 2000 14:26:06 -0400

Hi,

         There are actually two different ifTypes, one an
LSP and one for a tunnel interface, both of which have
different and distinct ifType numbers (166, 150). We will
add some descriptive text in the next version of the TE MIB
to illustrate more clearly the fact that a tunnel may or may
not be an interface.

         --Tom