Subject: RE: can egress know the ingress of a packet?

From: Kireeti Kompella <[email-masked]>
Date: Tue, 30 May 2000 09:44:00 -0700 (PDT)

Perhaps we've gone off on an tangent here.  The question
as I understood it is "when a *data* packet arrives at
the egress, can we know which ingress and which LSP it
travelled on?" -- and the answer is, not without some
extracurricular work.

Tan, can you clarify your question?

[I posted a reply to this earlier, but that seems to fallen
into a blackhole.]

Kireeti.

> 	In CR-LDP, the LSP-ID TLV consists of an IP
> address of the ingress LSR and a locally unique
> identifier.  Because it can be any address of the
> ingress LSR, it does not have to be an address the
> egress LSR will recognize (although it should be a
> "legal" address - i.e. not private or unregistered).
> 
> 	Therefore, I'm not sure how useful it is to 
> try to recapture information on the ingress LSR 
> using the LSP-ID TLV.
> 
> --
> Eric Gray
> 
> 
> > -----Original Message-----
> > From: Shahram Davari [mailto:[email-masked]]
> > Sent: Tuesday, May 30, 2000 7:27 AM
> > To: [email-masked]'; Tan Su Wei
> > Cc: [email-masked]
> > Subject: RE: can egress know the ingress of a packet?
> > 
> > 
> > Hi,
> > 
> > I think in CR-LDP you may use LSP-ID TLV, which will give you 
> > the tunnel
> > ingress and the LSP ID. And in RSVP-TE you may use the Sender Template
> > Object, which will give you the same information. RRO may 
> > also be used in
> > RSVP-TE, however you only will get the ingress LSR 
> > information that you
> > need, but not which LSP it is coming from.
> > 
> > Regards,
> > -Shahram
> > 
> > >-----Original Message-----
> > >From: [email-masked] [mailto:[email-masked]]
> > >Sent: Tuesday, May 30, 2000 10:01 AM
> > >To: Tan Su Wei
> > >Cc: [email-masked]
> > >Subject: Re: can egress know the ingress of a packet?
> > >
> > >
> > >Can we use the Record route Object for this?
> > >
> > >Dave
> > >
> > >> Dear all,
> > >> 
> > >>     I'd a doubt on :
> > >>         In a mpls network domain, for a particular 
> > >ingress-egress pair
> > >> with multiple LSPs in between them, is it possible when a 
> > >packet reach
> > >> the engress node, the engress node will know the following:
> > >>         i. ) the ingress node
> > >>         ii.) the lsp it travel
> > >> 
> > >>         Thanks for any reply.
> > >> 
> > >> Regards
> > >> Tan Su Wei

---

From: "Tan Su Wei" <[email-masked]>
Date: Tue, 30 May 2000 09:32:38 +0700

Dear All,
    Thanks for answering my question.
    > Tan, can you clarify your question?

and my question is exactly as above. I'm sorry if there is any
misunderstanding.
For the posted answer from Mr. Eric Gray

    It is possible to know the LSP traversed, only if
    the LSP is "identified".  This is possible with either
    CR-LDP (using LSP-ID) or RSVP-TE (using SESSION).

Lets if the LSP is "identified" using either lspid or session object (during
the LSP setup time, right?) , to know the lsp and ingress the *data* packet
from, is that mean we need adding a field in the data packet on this
information? (Maybe ip header option field?).
Since information get from the incoming label and interface might be
incorrect when there is LSP merge.
Is my interpretation correct?

    Thank you for your reply.

Regards
Tan Su Wei