Subject: LSP Merge issue(Using RSVP)

From: Neetu Gupta <[email-masked]>
Date: Tue, 23 May 2000 16:46:04 +0530

Hello,
    This topic has been discussed before. But, My query is bit different

from the one previously discussed:

Suppose we have the following setup:

    A
        \
          \
           C===D===E
          /
         /
      B

Suppose that A sends Path message specifying tunnel endpoint address E.
Thus LSP 1  is created from A to E.
Now Suppose another Path Message from B and destined for E comes.

Suppose , it is configured that LSP merging at C is possible
- Both Path messages have "Merge permitted" flag in Session
  Attributes set
- Both Path Messages requesting for same Class of Service

When the Path Message from B reaches E, E finds that there is already an

LSP for the session, and since it knows that C can merge the LSPs, it'll

assign a new label with the resources set for this LSP equal to LUB of
both the flowspecs(if style is Shared Explicit) or sum of both the
flowspecs(if style is FixedFilter) and delete the label of LSP1
- E sends Resv Message to D with Flow Descriptor containing merged
flowspec and two Filterspec objects (one for A and one for B) and same
label to both .

- D assigns a new incoming label and remove the old label of LSP1 and
modify the flowspec with the one coming in the Resv Message and sends
the Resv Message to C.  This Resv also specifies identical label values
for A and B, and flowdescriptor identical to the one coming in the Resv
Message from E.
- Since, C is the merge point.  It assigns a new incoming label for B.
Thus at C, there will be two incoming labels , one for A and one for B.
  It then sends Resv to B.

Is this correct? Can we Merge the LSPs as specified above?
Please clarify
-neetu

---

From: Rohit Chhapolia <[email-masked]>
Date: Tue, 23 May 2000 10:20:01 -0400

Please see the comments below.

> flowspec and two Filterspec objects (one for A and one for B) and same

E can not send same label for both filterspecs.
For E to send same label for both Filterspecs, it should know that C
is capable of merging LSPs. Firstly, E does not know which node does the
merging. Secondly, it does not know whether that node is merge capable.

-- 
Rohit Chhapolia
Globespan, Inc.
mailto:[email-masked]
http://www.globespan.net

---

From: Neetu Gupta <[email-masked]>
Date: Wed, 24 May 2000 09:47:54 +0530

Please c the comments

>>>> We have a centralized Policy Server that maintains the information that
whether the LSR is capable of merging the LSPs or not. This information is
available to all the nodes in the MPLS Domain, so E already knows that what
all nodes support VC Merging, Now if the Path Message contains RECORD_ROUTE
Object that contains the address of C also, then E can send a single label.

---

From: Rohit Chhapolia <[email-masked]>
Date: Wed, 24 May 2000 09:23:33 -0400

I think the approach you have mentioned should work. However,
what's the problem you are trying to solve here? Multiple
LSPs for same session is useful for make-before-break scenarios.
Here the first LSP will be released soon after second LSP is setup
and so the extra label used between C to E is only for short
duration. I don't think it is useful to have centralized policy
servers for this purpose. Furthermore, this approach requires
that you must have RRO and this RRO needs to be parsed and compared
at the egress point to determine the merge point.

One point:
There is no need for E to allocate new label. It can send old
label itself with modified FlowSpec.

Rohit

Neetu Gupta wrote:
> >>>> We have a centralized Policy Server that maintains the information that whether the LSR is capable of merging the LSPs or not. This information is
> available to all the nodes in the MPLS Domain, so E already knows that what all nodes support VC Merging, Now if the Path Message contains RECORD_ROUTE Object
> that contains the address of C also, then E can send a single label.
> 
> >
> >

---

From: Neetu Gupta <[email-masked]>
Date: Thu, 25 May 2000 08:53:51 +0530

We want to provide VC Merge Support in the MPLS Domain.
For differentiated Signalling, we creating LSPs between all the Edge Routers. so to reduce the number of labels, we want to provide VCMerge Support.

Also c my comments below:

> label itself with modified FlowSpec.

This can be done.