Subject: RE: LDP Abort message notification

From: manikantan <[email-masked]>
Date: Fri, 5 May 2000 18:58:56 +0530

Bob,

Thanks for the reply. I have a doubt still mentioned below.

#
#> Can some one clarify my doubts?
#> 
#> When a downstream LSR (LDP Peer) receives an LDP Abort
#> message from its upstream LSR (LDP Peer) it is expected to
#> respond with a notification message with status indicating
#> "Label Request Aborted - 0x00000015".
#> 
#> My doubts are 
#> 1) What should be message id value in the Status TLV
#> that is to be sent in the notification message?
#> 
#>   a) Should the message id value be the message id
#>       value of the Label request message received from the
#>       upstream peer earlier (for which the abort is sent now)?
#>   b) or Should the message id value be the message id
#>       value of the Label Abort message received from the
#>       upstream peer?
#
#It should be b), the message id of the received Label Abort message.
#
#
#> 2) If the message id is to be the value of the one that is
#>     received in the label Abort message, then how do 
#>     we indicate the message id of the earlier received
#>     Label Request message. ( this is required to locate
#>     the LSP control block). 
#
#
#>From Section 3.5.9.1. Label Abort Request Message Procedures of
#draft-ietf-mpls-ldp-0x.txt:
#
#   When an LSR receives a Label Abort Request message, if it has not
#   previously responded to the Label Request being aborted with a Label
#   Mapping message or some other Notification message, it must
#   acknowledge the abort by responding with a Label Request Aborted
#   Notification message.  The Notification must include a Label Request
#   Message ID TLV that carries the message ID of the aborted Label
#   Request message.
#
#
#Bob 

But when we say that the Notification must include
a Label Request Message ID TLV, the normal format of the
Notification message allows for the status TLV and three optional parameters
the extended status, the returned message and returned PDU types.

so, how do we fit the Request Message ID TLV here?

Do I make the assumption/understand as

1) The message id in the Status TLV of the Notification message
is equal to the one received in the Label Abort message.
2) The 2 byte message type in the status TLV set to Label Abort
    message
3) (Looking at the Abort message type), The info after the status TLV
in the notification message be filled with Label Request Message ID TLV?
OR Send in an optional parameter TLV with Returned Message type,
Return the Label Abort message itself back.

thanks in advance
with best regards
mani

---

From: Bob Thomas <[email-masked]>
Date: Fri, 05 May 2000 09:58:14 -0400

Mani,

> so, how do we fit the Request Message ID TLV here?

Please note the following from 3.5.1. Notification Message:

     Optional Parameters
       ...

  ***  Other Optional Parameters, specific to the particular event being
  ***  signaled by the Notification Messages may appear.  These are
  ***  described elsewhere.

One such place is Section 3.5.9.1. Label Abort Request Message Procedures.

> is equal to the one received in the Label Abort message.

Yes.

> 2) The 2 byte message type in the status TLV set to Label Abort

Yes.

> 3) (Looking at the Abort message type),

???

>                                       The info after the status TLV

Yes.

Bob