Subject: Re: MPLS and IS-IS

From: Jessica Yu <[email-masked]>
Date: Fri, 19 May 2000 08:30:08 -0700 (PDT)

Yakov:

That's something I wanted to point out in my previous
message but forgot in the process. Thanks for
mentioning it and if I can add, the concept of
confederation is another feature that BGP incorporated
from IDRP.

Back to the basic question:

If we have two protocols (X and Y) which essentially
serve the same purpose and are very similar, shall we,
given resource is limited, 

     a)evolve one of them and incorporate all the good
       features of the other and just support one, or 

     b)keep doing parallel work (which does not led to
       significant difference between the two) on
both?

                       --Jessica

--- Yakov Rekhter <[email-masked]> wrote:
> Jessica,
> 
> > Just use your example. Compare to sedan, SUV has
> > higher clearance, more leg room and advantage when
> > collision happens. SUVs also consume more gas,
> pollute
> > more, etc. Does IS-IS and OSPF have such clear
> > differences in terms of function and performance?
> All
> > the discussion happens year after year pretty much
> > concluded that the two has little differences
> (except
> > quality of implementation difference). So
> supporting
> > both does not gain more but consumes more
> resources. 
> > 
> > In terms of the benefit of having one protocol vs
> two
> > very similar ones or whether one is enough. Just
> think
> > about the case of BGP. There used to be BGP and
> IDRP.
> > The two have very similar function and mechanism.
> IDRP
> > supports dual mode (sounds familiar?) Just having
> BGP
> > works just as well as having both and maybe better
> > given vendors do not need to spread thin
> development
> > resource to take care of both.
> 
> Just to add, as BGP evolved it included some of the
> functionality of IDRP (e.g., multiprotocol
> extensions,
> BGP Refresh).
> 
> Yakov.

=====

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 19 May 2000 09:02:20 -0700

Jessica,

>        significant difference between the two) on both ?

I think that router vendors would allocate resources for ISIS and OSPF
based on their customers' demand for ISIS and OSPF.  So, the answer to
your question will be determined by customers, not by vendors.

It seems that so far we've been moving along option (b).

Yakov.

---

From: "Brijesh Kumar" <[email-masked]>
Date: Fri, 19 May 2000 12:20:56 -0400

> both.
Jessica,

Routing is not alone where multiple standards exist for essentially
the same purpose. Even though many subtle differences exist between OSPF
and IS-IS as pointed out by previous mails in this thread, supporting
an extra routing protocol is a far simpler problem compared to the problems
in some other technology domains. Just compare this to the problem of
manufacturers and/or  operators of cellular systems who need to put
resources
in developing infrastructure components (BTS, BSCs and Switches etc.) for
TDMA,
GSM and CDMA which all achieve the "similar purpose" (with only marginal
differences in channel utilization and/or quality of voice).

The parallel evolution is not such a bad thing as at some point the natural
factors will decide whether IS-IS or OSPF survives, or they both get
replaced
by a single unified specification.

Cheers,

--brijesh
Ennovate Networks Inc.