Subject: MPLS Interworking

From: "Santosh Gupta" <[email-masked]>
Date: Mon, 10 Apr 2000 10:00:01 +0530

Hi
    I have a question on Interworking between non MPLS and MPLS domain. The scenario is as depicted below 

 Non MPLS            MPLS domain
                   |
             A    |    B
                   |

Suppose router B is in the MPLS domain and A is the router in nonMPLS domain. The data is to be sent from A to B and we wish to have the data coming on ATM switch. Now A being in non MPLS router is having Ethernet interface on 1 side and ATM interface on the interface to B. For all data coming on A at ethernet interface, it is passed on to B thru the ATM interface. Now the problem is how to inform A as to which label (VPI/VCI) should be to send data to B ? 
There are 2 options to this:
1. Run some Label Distribution Protocol on A also so that they can exchange Labels and the data goes as it goes normally with some mapping for CoS parameters in the     two domains.
2. Statically configure labels (PVC) between A and B thru SLA. In this there would be "n" PVCs set between A and B where "n" is the no. of Class of Services     supported by the MPLS domain. When data comes to A (say on ethernet i/f) it is mapped to one of the PVCs depending on the CoS byte. And the data goes to B. The data would come upto the layer 3 in B and then FEC to Label mapping would be done for the data to go thru the MPLS domain.

Taking case 2 : Is it possible for such a scenario to work if I dont want to run any MPLS protocol on A ? If yes then who ( which protocol ) does this FEC to Label mapping on A before pasing on the data to B.
Is there any way out so that I could have SVCs between A and B and still not run any MPLS protocol on A.

santosh

---

From: Rohit Chhapolia <[email-masked]>
Date: Wed, 10 May 2000 09:42:38 -0400

Hi Santosh,

Please see the comments below.

Santosh Gupta wrote:
> Suppose router B is in the MPLS domain and A is the router in nonMPLS domain. The data is to be sent from A to B and we wish to have the data coming on ATM
> switch. Now A being in non MPLS router is having Ethernet interface on 1 side and ATM interface on the interface to B. For all data coming on A at ethernet
> interface, it is passed on to B thru the ATM interface. Now the problem is how to inform A as to which label (VPI/VCI) should be to send data to B ?
> 2. Statically configure labels (PVC) between A and B thru SLA. In this there would be "n" PVCs set between A and B where "n" is the no. of Class of Services
>     supported by the MPLS domain. When data comes to A (say on ethernet i/f) it is mapped to one of the PVCs depending on the CoS byte. And the data goes to

By CoS byte, do you mean DSCP in the IP header?

> B. The data would come upto the layer 3 in B and then FEC to Label mapping would be done for the data to go thru the MPLS domain.

In the diff-serv model, you may need to consider the incoming CoS
also to decide the outgoing label. If the outgoing interface is ATM,
it supports only L-LSPs and there should be different L-LSPs for
different CoS.

> 
> Taking case 2 : Is it possible for such a scenario to work if I dont want to run any MPLS protocol on A ? If yes then who ( which protocol ) does this FEC to
> Label mapping on A before pasing on the data to B.

As I understand, there is no such mapping on A for this case.

> Is there any way out so that I could have SVCs between A and B and still not run any MPLS protocol on A.

Rohit

-- 
Rohit Chhapolia
Globespan, Inc.
mailto:[email-masked]
http://www.globespan.net

---

From: Jeremy Lawrence <[email-masked]>
Date: Thu, 11 May 2000 11:07:42 +1000

Santosh,

At 10:00 04/10/2000 +0530, Santosh Gupta wrote:
>Suppose router B is in the MPLS domain and A is the router in nonMPLS domain. 

That's not possible. An MPLS domain must end at a router, called
an edge Label Switch Router (LSR). An edge LSR has both MPLS and
ordinary IP interfaces.

>The data is to be sent from A to B and we wish to have the data coming on ATM switch. Now A being in non MPLS router is having Ethernet interface on 1 side and ATM interface on the interface to B. For all data coming on A at ethernet interface, it is passed on to B thru the ATM interface. Now the problem is how to inform A as to which label (VPI/VCI) should be to send data to B ? 

This makes router A into an edge LSR, and part of the MPLS domain.

>2. Statically configure labels (PVC) 

A PVC is not really a label. A PVC carrying RFC 1483 (or the sucessor
RFC, whatever it is) IP-over-ATM is not an MPLS link at all, just
another IP link. In this case, B becomes the edge LSR, and A is not
running MPLS at all.

>between A and B thru SLA. In this there would be "n" PVCs set between A and B where "n" is the no. of Class of Services     supported by the MPLS domain. 

At least one vendor supports use of multiple, bundled, PVCs to support
multiple IP classes of service. However this is somewhat different
to MPLS+Diffserv using multiple label VCs (LVCs) for different classes.

>When data comes to A (say on ethernet i/f) it is mapped to one of the PVCs depending on the CoS byte. And the data goes to B. The data would come upto the layer 3 in B and then FEC to Label mapping would be done for the data to go thru the MPLS domain.
>  
>Taking case 2 : Is it possible for such a scenario to work if I dont want to run any MPLS protocol on A ? 

Yes.

>If yes then who ( which protocol ) does this FEC to Label mapping on A before pasing on the data to B.

Ordinary IP forwarding forwards packets on the PVC link to B. The PVC
link is just another IP link.

>Is there any way out so that I could have SVCs between A and B and still not run any MPLS protocol on A.

If you really wanted to, you could run NHRP & SVCs between A and B,
but it is not clear that this adds anything except complexity. It's
probably easier to have PVCs between A & B.

Hope this helps,

Jeremy Lawrence

---

From: "Santosh Gupta" <[email-masked]>
Date: Tue, 11 Apr 2000 17:24:41 +0530

Hello Lawrence
    Please see the comments embedded.

> an edge Label Switch Router (LSR). An edge LSR has both MPLS and
OK fine, no MPLS protocol should run on A as it is outside MPLS domain.
>
> >The data is to be sent from A to B and we wish to have the data coming on
ATM switch. Now A being in non MPLS router is having Ethernet interface on 1
side and ATM interface on the interface to B. For all data coming on A at
ethernet interface, it is passed on to B thru the ATM interface. Now the
problem is how to inform A as to which label (VPI/VCI) should be to send
data to B ?
> >1. Run some Label Distribution Protocol on A also so that they can
exchange Labels and the data goes as it goes normally with some mapping for
CoS parameters in the     two domains.
> >between A and B thru SLA. In this there would be "n" PVCs set between A
and B where "n" is the no. of Class of Services     supported by the MPLS
domain.
> to MPLS+Diffserv using multiple label VCs (LVCs) for different classes.

I am also proposing the same thing. I am supporting "n" class of service for
which there are "n" PVCs opened. that way it is possible to police on the
amount of data sent by the customer for different class of service at the
edge LSR.

>
> >When data comes to A (say on ethernet i/f) it is mapped to one of the
PVCs depending on the CoS byte. And the data goes to B. The data would come
upto the layer 3 in B and then FEC to Label mapping would be done for the
data to go thru the MPLS domain.