Subject: RE: LDP request

From: Eric Gray <[email-masked]>
Date: Wed, 3 May 2000 09:19:04 -0700

Sreeni,

	In the future, please remember to identify the
source of your quote. :-)

	I found this text in "A Framework for MPLS", by
Ross Callon, George Swallow, N. Feldman, C Srinivasan, 
P. Doolan, and A. Fredette - dated 09/22/1999.

	This document merely discusses MPLS possibilities.
To see what was actually proposed, read the architecture
draft at

http://www.ietf.org/internet-drafts/draft-ietf-mpls-arch-06.txt

To see what has actually been defined, see specific drafts
available at

	http://www.ietf.org/ids.by.wg/mpls.html

--
Eric Gray

> -----Original Message-----
> From: ksreeni [mailto:[email-masked]]
> Sent: Wednesday, May 03, 2000 4:36 AM
> To: mpls
> Subject: LDP request
> 
> 
> Hi,
> 
> >     3.4.2 Request Driven Label Assignment
> 
> >   In this scheme labels are assigned in response to normal
> >   processing of request based control traffic. Examples of such
> >   control protocols are RSVP. As an LSR processes RSVP messages it
> >   can, as it makes or changes entries in its forwarding tables,
> >   assign labels to those entries.
> 
> >   Among the properties of this scheme are:
> 
> >  - The computational load of assignment and distribution and
> >    the bandwidth consumed by label distribution are bounded by
> >    the amount of control traffic in the system.
> 
> >  - Labels are in the general case preassigned. If a route
> >    exists then a label has been assigned to it (and
> >    distributed). Traffic may be label swapped immediately it
> >    arrives, there is no label setup latency at forwarding time.
> 
> >  - Requires LSRs to be able to process control traffic load
> >    only.
> 
> >  - Depending upon the number of flows supported, this approach
> >    may require a larger number of labels to be assigned
> >    compared with topology driven assignment.
> 
>         In the above the 4th paragraph says, labels are 
> preassigned  and distributed. How labels are preassigned 
> and distributed even before the data packet has come to 
> LER. If the labels are preassigned and distributed , when
> LDP request message is used.
> 
>     Can somebody answer my query by taking an unlabeled L3 packet as
> input to LER.
> 
> thanks,
> Sreeni.
> 
>

---

From: Joe Kelly <[email-masked]>
Date: Wed, 3 May 2000 12:16:08 -0400 (EDT)

Get it back man!  Smash some heads!  :-)

> 	http://www.ietf.org/ids.by.wg/mpls.html

Joseph Kelly					212-324-1543
Manager of Network Architecture			[email-masked]
OnSite Access

---

From: "HANSEN CHAN" <[email-masked]>
Date: Wed, 03 May 2000 12:23:24 -0400

Can someone give me an update of the status of the MPLS documents? My last
understanding is the following are in IESG and would become a RFC anytime
soon:

RSVP Tunnels
LDP
CR-LDP
MPLS Architecture
MPLS Framework
Label Stack Encoding
ATM Encaps

Is there an RFC number assigned to those draft now?

Thanks,
Hansen