Subject: RE: can egress know the ingress of a packet?

From: Shahram Davari <[email-masked]>
Date: Tue, 30 May 2000 07:26:38 -0700

Hi,

I think in CR-LDP you may use LSP-ID TLV, which will give you the tunnel
ingress and the LSP ID. And in RSVP-TE you may use the Sender Template
Object, which will give you the same information. RRO may also be used in
RSVP-TE, however you only will get the ingress LSR information that you
need, but not which LSP it is coming from.

Regards,
-Shahram

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Tuesday, May 30, 2000 10:01 AM
>To: Tan Su Wei
>Cc: [email-masked]
>Subject: Re: can egress know the ingress of a packet?
>
>
>Can we use the Record route Object for this?
>
>Dave
>
>> Dear all,
>> 
>>     I'd a doubt on :
>>         In a mpls network domain, for a particular 
>ingress-egress pair
>> with multiple LSPs in between them, is it possible when a 
>packet reach
>> the engress node, the engress node will know the following:
>>         i. ) the ingress node
>>         ii.) the lsp it travel
>> 
>>         Thanks for any reply.
>> 
>> Regards
>> Tan Su Wei
>> 
>> 
>> 
>

---

From: Eric Gray <[email-masked]>
Date: Tue, 30 May 2000 09:01:50 -0700

Jana,

	This is not always (or perhaps even generally)
true.

	Information about ingresses for any LSP is lost 
at each merge point in the LSP.  Given the importance
of merging for MPLS scalability, it is probably not a 
good idea to count on an ability to recover information 
about ingress LSRs from label and incoming interface.

--
Eric Gray

> From: Pathangi N Janardhanan [mailto:[email-masked]]
> Sent: Monday, May 29, 2000 8:18 PM
> To: Tan Su Wei; [email-masked]
> >         In a mpls network domain, for a particular ingress-egress
> pair
> > with multiple LSPs in between them, is it possible when a packet
> reach
>   Either the label on the incoming packet or the combination of label
> and interface of the
> incoming packet can be used to identify the ingress/LSP of the
> incoming packet.
> 
> Thanks
> Jana
> 
>

---

From: Eric Gray <[email-masked]>
Date: Tue, 30 May 2000 09:06:37 -0700

Sharam,

	In CR-LDP, the LSP-ID TLV consists of an IP
address of the ingress LSR and a locally unique
identifier.  Because it can be any address of the
ingress LSR, it does not have to be an address the
egress LSR will recognize (although it should be a
"legal" address - i.e. not private or unregistered).

	Therefore, I'm not sure how useful it is to 
try to recapture information on the ingress LSR 
using the LSP-ID TLV.

--
Eric Gray

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Tuesday, May 30, 2000 7:27 AM
> To: [email-masked]'; Tan Su Wei
> Cc: [email-masked]
> Subject: RE: can egress know the ingress of a packet?
> 
> 
> Hi,
>

---

From: Eric Gray <[email-masked]>
Date: Tue, 30 May 2000 09:27:50 -0700

Tan Su Wei,

	It is possible to know the LSP traversed, only if
the LSP is "identified".  This is possible with either
CR-LDP (using LSP-ID) or RSVP-TE (using SESSION).

--
Eric Gray

> From: Tan Su Wei [mailto:[email-masked]]
> Sent: Monday, May 29, 2000 7:40 PM
> To: [email-masked]
> Subject: can egress know the ingress of a packet?
> 
> 
> Dear all,
> 
>     I'd a doubt on :
>         In a mpls network domain, for a particular ingress-egress pair
> with multiple LSPs in between them, is it possible when a packet reach

---

From: Eric Gray <[email-masked]>
Date: Tue, 30 May 2000 19:00:27 -0700

Tan,

	No information is added to the IP header to
aid in determining what LSP it is to be propagated
on except for the MPLS label (which is prepended as
part of the MPLS stack and is not part of the IP
header).  When the last useful label is removed from 
a data packet (either by popping it or by using an
explicit NULL label), there is no longer any way to 
positively identify the LSP that it was forwarded on.

	I had the impression - because of the way that
you asked your question - that you were trying to 
find out how LSP information might be inferred from
the label on a packet.  Again, (and as Kireeti already
pointed out) it cannot be easily inferred from the IP
packet once all useful label information is gone.  I
doubt that it can be determined absolutely at that 
point through much less than magic.

--
Eric Gray

> Sent: Monday, May 29, 2000 7:33 PM
> To: Kireeti Kompella; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]
> Dear All,
>     Thanks for answering my question.
> As Kireeti wrote:
>     > Perhaps we've gone off on an tangent here.  The question
>     > as I understood it is "when a *data* packet arrives at
>     > the egress, can we know which ingress and which LSP it
>     > travelled on?" -- and the answer is, not without some
>     > extracurricular work.
>     >
>     > Tan, can you clarify your question?
> 
> and my question is exactly as above. I'm sorry if there is any
> misunderstanding.
> For the posted answer from Mr. Eric Gray
> 
> Lets if the LSP is "identified" using either lspid or session 
> object (during
> the LSP setup time, right?) , to know the lsp and ingress the 
> *data* packet
> from, is that mean we need adding a field in the data packet on this
> information? (Maybe ip header option field?).
> Since information get from the incoming label and interface might be
> incorrect when there is LSP merge.
> Is my interpretation correct?
> 
>     Thank you for your reply.
> 
> Regards
> Tan Su Wei
> 
>