Subject: Control Channel

From: "Santosh Gupta" <[email-masked]>
Date: Sun, 16 Apr 2000 15:06:55 +0530

Hi
    I have the following question regarding Control Channel for ATM switches running MPLS and ATM switches which dont run MPLS protocols. Suppose the scenario is the following:

non MPLS             |        MPLS
                            |        
    edge router        |        LER1
                            |

data is coming from a non MPLS domain into MPLS domain and there is an ATM switch at the edge router in non MPLS domain. For interworking between domains "n" PVCs have been statically configured between edge router and LER1 through SLA  where "n" is the no. of class of services supported. Data belonging to different class of service comes onto the specified PVC. 

Now my question is do we need to have a seperate "Control Channel" between edge router in non MPLS domain and LER1  in MPLS domain. If yes, then how does the driver on edge router make out that this packet is "control data" and needs to be sent onto a particular "control channel". 

One solution which can work temporarily could be that the driver looks onto the "Protocol ID" in IP header of the packet and then distinguishes between control packets and data packets. But this means driver can identify only those protocols for which it knows the "protocol ID". Any suggestions.

Thanx in advance.

santosh

---

From: Pathangi N Janardhanan <[email-masked]>
Date: Tue, 16 May 2000 16:22:22 +0530

Hi Santhosh,

>     I have the following question regarding Control Channel for ATM
> switches running MPLS and ATM switches which dont run MPLS protocols.
> Suppose the scenario is the following:
> 
> non MPLS             |        MPLS
>                             |
>     edge router        |        LER1
>                             |
> 
> data is coming from a non MPLS domain into MPLS domain and there is an
> ATM switch at the edge router in non MPLS domain. For interworking
> between domains "n" PVCs have been statically configured between edge
> router and LER1 through SLA  where "n" is the no. of class of services
> supported. Data belonging to different class of service comes onto the
> specified PVC.
> 
> Now my question is do we need to have a seperate "Control Channel"
> between edge router in non MPLS domain and LER1  in MPLS domain. If
> yes, then how does the driver on edge router make out that this packet
> is "control data" and needs to be sent onto a particular "control
> channel".

  What is the need for having a separate control channel? 

   The non MPLS router talks IP to the MPLS LER using the PVCs 
and the MPLS LER would then send the packets on an LSP to the 
MPLS domain and convert from MPLS to IP on the other side. 

Thanks
Jana

---

From: Jeremy Lawrence <[email-masked]>
Date: Wed, 17 May 2000 11:30:35 +1000

>MPLS domain and convert from MPLS to IP on the other side. 

That's correct. Note that the "MPLS domain" must start in the
middle of a edge LSR (LER), not in the middle of a link.
So:
- The edge LSR is in both the MPLS domain and the non-MPLS
   domain, as it deals with both unlabelled IP packets and
   MPLS packets. An implication is that an edge LSR must
   be a router, or a similar device with capability to do
   non-trivial amounts of manipulation of packet headers.
- Some links (the PVCs described above) carry unlabelled IP
   traffic without using MPLS control. Note that MPLS control
   is _not_ necessary to have parallel PVCs carry different
   classes of traffic.
- The other links carry labelled traffic with MPLS control.
- No links carry unlabelled IP traffic with MPLS control.

Regards,

Jeremy Lawrence