Subject: RE: Re: MPLS - ATM interworking?

From: CATANZARITI Sergio FTR&D/TI <[email-masked]>
Date: Wed, 31 May 2000 12:18:59 -0700

Sorry, in my previous e-mail I meant draft-ietf-mpls-diff-ext-04.txt
does not say anything about ECN ..., 
	the problem is that I have not received any
draft-ietf-mpls-ecn-00.txt.

	Sergio

> --------------------------------------------------------------------
> Sergio Catanzariti
> Senior Project Manager, Technology Integration
> France Telecom R&D 
> 1000 Marina Boulevard Suite 300 
> Brisbane CA 94005
> Tel. 650-875-1526
> Fax. 650-875-1505
> email:[email-masked] 
> --------------------------------------------------------------------
> 
> 
> -----Original Message-----
> From:	CATANZARITI Sergio FTR&D/TI
> [SMTP:[email-masked]]
> Sent:	Wednesday, May 31, 2000 12:13 PM
> To:	'Shahram Davari'
> Cc:	[email-masked]; 'Andrzej Czerczak'; [email-masked]
> Subject:	RE: Re: MPLS - ATM interworking?
> 
> Shahram, 
> 
> 	the draft-ietf-mpls-ecn-00.txt does not say anything about ECN usage
> and applications, but only about ECN support and definition in an MPLS
> network, the things are quite different. So, I have the same question:
> where I can find Ramakrishnan et al., "A Proposal to Incorporate ECN in
> MPLS", draft-ietf-mpls-ecn-00.txt?
> 
> 	Also, I do believe that the ECN in an MPLS network works on resource
> types (LSPs) quite different than native IP flows. So, the source address
> is not that useful here, albeit in an ECN schema in pure IP networks.
> 
> 	ECN in an MPLS network is supposed to signal congestion in an
> edge-to-edge fashion (different from end-to-end) where the LERs could
> cooperate on that.
> 
> 	Absolutely, I want to associate LSPs with congestion dynamics to
> eventually slow them down. How can I do that? That's the question.
> 
> Sergio 
> 
> 	--------------------------------------------------------------------
> 
> Sergio Catanzariti 
> Senior Project Manager, Technology Integration 
> France Telecom R&D 
> 1000 Marina Boulevard Suite 300 
> Brisbane CA 94005 
> Tel. 650-875-1526 
> Fax. 650-875-1505 
> email:[email-masked] 
> -------------------------------------------------------------------- 
> 
> 
> 	-----Original Message----- 
> From:   Shahram Davari [SMTP:[email-masked]] 
> Sent:   Wednesday, May 31, 2000 11:34 AM 
> To:     'Andrzej Czerczak'; [email-masked] 
> Cc:     [email-masked] 
> Subject:        RE: Re: MPLS - ATM interworking? 
> 
> 	Andrzej, 
> 
> 	1)ECN usage is defined in draft-ietf-mpls-ecn-00.txt, which is
> attached to 
> this email. 
> 
> 	2)Congestion Notification is and end-to-end signal which is meant to
> be used 
> by TCP. You don't need to know the ingress LSR or even the LSP from which 
> the congested packet is received. The receiver may send the congestion 
> notification to the sender using source IP address, either through another
> 
> LSP or even through normal IP hop-by-hop routing. 
> 
> 	Regards, 
> -Shahram 
> 
> 
> 
> 
> 	>-----Original Message----- 
> >From: Andrzej Czerczak [ <mailto:Andrzej_Czerczak/[email-masked]>] 
> >Sent: Wednesday, May 31, 2000 1:46 PM 
> >To: [email-masked] 
> >Cc: [email-masked] 
> >Subject: Re:Re: MPLS - ATM interworking? 
> > 
> > 
> > 
> >Robert, 
> >First of all thanks for your comments. 
> > 
> >>Have you read draft MPLS Support of Differentiated Services 
> >>draft-ietf-mpls-diff-ext-04.txt where we are proposing to use the ECN 
> >>(explicit congestion notification) on a per LSP basis using 
> >the EXP bits 
> >>in the shim header ? Currently this is the most attractive 
> >option, but I 
> >> am not aware of any implementation support this today. 
> > 
> > 
> > 
> >a) Document draft-ietf-mpls-diff-ext-04.txt does not not 
> >define the usage 
> >of ECN. 
> > 
> >b) Taking into account label merging capabilites of LSRs, how 
> >can determine 
> >to which ingress LSP to to send Congestion Notification? 
> > 
> >c) Where can I find: 
> > 
> >Ramakrishnan et al., "A Proposal to Incorporate ECN in 
> >   MPLS", draft-ietf-mpls-ecn-00.txt? 
> 
> 	> 
> > 
> > 
> >What I'd like to say is, that at least during first phases of 
> >implementations (before entire infrastructure will become IP) 
> >interworking 
> >of MPLS core and ATM edge will be important, but I could not find a 
> >proposal of how to do interworking between them. 
> > 
> > 
> > 
> >Andrzej 
> > 
> > 
> > 
> > 
> > 
> > 
>  << File: draft-mpls-ecn-00.txt >> 
>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 31 May 2000 13:26:37 -0700

Just simple yahoo query would do:

http://www.ics.forth.gr/ICS/acti/netgroup/documents/mpls/draft-ietf-mpls-ecn-00.txt

R.

> CATANZARITI Sergio FTR&D/TI wrote:
> 
>      the problem is that I have not received any draft-ietf-mpls-ecn-00.txt.
> 
>      Sergio
> 
>              the draft-ietf-mpls-ecn-00.txt does not say anything about ECN
>      usage and applications, but only about ECN support and definition in an
>      MPLS network, the things are quite different. So, I have the same
>      question: where I can find Ramakrishnan et al., "A Proposal to
>      Incorporate ECN in MPLS", draft-ietf-mpls-ecn-00.txt?
> 
>              Also, I do believe that the ECN in an MPLS network works on
>      resource types (LSPs) quite different than native IP flows. So, the
>      source address is not that useful here, albeit in an ECN schema in pure
>      IP networks.
> 
>              2)Congestion Notification is and end-to-end signal which is
>      meant to be used