Subject: MPLS Traffic Engineering MIB - draft-ietf-mpls-te-mib-03.txt

From: manikantan <[email-masked]>
Date: Sat, 13 May 2000 18:06:52 +0530

Hello

I have a doubt and some comments in the MPLS Traffic Engineering MIB.
draft-ietf-mpls-te-mib-03.txt

Can some one clarify me.

thanks in advance.

I am sorry if the comments mentioned in this mail had already
been indicated.

Doubt: mplsTunnelOperStatus: When will this field get a value "up"?

My understanding is that after the Tunnel is created using the 
mplsTunnelRowStatus object and the Admin Status is set to up,
the LSP establishments will be initiated. i.e., either RSVP Path 
message will be sent down or CRLSP label request message will
be sent to the next hop.

My question is will the mplsTunnelOperStatus be marked/set 
to "up" after the successful reception of the Resv message or
Lbl Mapping message?

Comments:
1) In the Tunnel setup example provided in page 12 reproduced
below for reference:

   In mplsTunnelHopTable:
   {
     mplsTunnelHopIndex              = 1,
     mplsTunnelHopAddrType           = 1,
     mplsTunnelHopIpv4Addr           = 123.123.125.1,
     mplsTunnelHopIpv4PrefixLen      = 9,
     mplsTunnelHopStrictOrLoose      = loose (2),
     mplsTunnelHopRowStatus          = createAndGo (4)
   }
   
   The following denotes the end of the network, or the
   last hop in our example. We have used the fictitious
   LSR identified by "123.123.126.1" as our end router.
   
   In mplsTunnelHopTable:
   {
     mplsTunnelHopIndex              = 2,
     mplsTunnelHopAddrType           = 1,
     mplsTunnelHopIpv4Addr           = 123.123.126.1,
     mplsTunnelHopIpv4PrefixLen      = 9,
     mplsTunnelHopStrictOrLoose      = loose (2),
     mplsTunnelHopOwner              = snmp (1),
     mplsTunnelHopRowStatus          = createAndGo (4)
   }
My questions are
  a) The mplsTunnelHopIpv4Prefix Len has been set to 9 in 
  both cases. The resultant network will be 123.0.0.0 in 
  both cases and there results no difference in the ER Hop.
  Am I correct or missing something.

  b) The example includes mplsTunnelHopOwner, This does not
  exist in this draft. Does this needs to be removed?

2) In the Description of the mplsTunnelSessionAttributes object
   in Page 28, the first para starts with "fastReroute". 
   should this be "ingressMayReroute"?

3) A minor typo in the first line of page 29. "det4ected"
   should be made "detected"

thanks in advance
with best regards
mani
 
/*-------------------------------------------------------------------*/
S.Manikantan
Future Software Private Limited
480-481, Anna salai, Nandanam,
Chennai, Tamil Nadu, 600 035,
India.
Phone	: +91-44-4330550
Fax	: +91-44-4344157.
Email	: [email-masked]
http://www.futsoft.com
/*--------------------------------------------------------------------*/

---

From: Adrian Farrel <[email-masked]>
Date: Mon, 15 May 2000 11:33:58 +0100

Hi Mani,

I'm sure Tom will want to jump in, but here are a couple of answers to be
going on with.

>to "up" after the successful reception of the Resv message or

This would appear to be the intention.  It is generally the purpose of
operStatus to indicate the operational status of the resource described by
the MIB row.  In this case, signaling would be complete and all of the
cross-connects would be programmed before operStatus showed 'up'.

>  Am I correct or missing something.

Yes.  The example is not helpful.  In use, the second hop would be stripped
from the explicit route when the Path/Label_Request reached an LSR
satisfying the first hop.

>  exist in this draft. Does this needs to be removed?

Unclear what the authors were trying to do here. This function should
probably be provided totally by mplsTunnelOwner, although there is scope for
distinguishing configured hops from those determined through routing in a
pinned ER.

>   should this be "ingressMayReroute"?

Yes. See my email of 20th March.

>   should be made "detected"

ditto.

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422