Subject: DU mode:Label Advt.

From: Prem Shankar Sharma <[email-masked]>
Date: Mon, 15 May 2000 19:14:47 -0700

Hi,

    It seems there is some difference in the opinion
    about the broadcast the labels to the neighbours
    in the DU mode. (Please have a look at the following
    mails).

    Please clarify!!!

Regards.
Prem

<1st Mail>
Question about interfacing Routing and LDP in MPLS systems?
From: Eric Gray <[email-masked]> 
Date: Fri, 10 Dec 1999 07:57:10 -0500 
CC: Zhong Hu <[email-masked]>, [email-masked] 
References: <[email-masked]> 
X-Accept-Language: en 

...
	In the DU mode, it's quite a bit simpler.  Any
time such an implementation derives a new route table
entry, it sends a Label Mapping to all but the next hop
for that route entry.
...

<2nd Mail>
Sending mapping for REC-NEW-FEC
From: Bob Thomas <[email-masked]> 
Date: Thu, 27 Jan 2000 06:31:53 -0500 
cc: [email-masked] 
In-reply-to: Your message of "Thu, 27 Jan 2000 09:33:10 +0530."
<[email-masked]> 
X-Authentication-Warning: rhthomas-sun2.cisco.com: rhthomas owned process
doing -bs 

Sree,
...
> In the Recognise New FEC in the Label Distribution Procedures in  
> ldp-06.txt (Appendix A.1.6), according to FEC.1, for downstream 
> unsolicited independent control, for each peer we are supposed to 
> send a label mapping. No distinction is made for the next hop. Are 
> we supposed to send it to the next hop also ?

Yes.

Bob

---

From: manikantan <[email-masked]>
Date: Tue, 16 May 2000 09:18:20 +0530

Hello Prem

I agree with Bob's Yes, and my understanding is as follows.

I am Referring to the section 2.6.2.2 from LDP draft 06.txt - "Liberal Label Retention Mode"
as basis for my explanation.

Generally DU mode of advertisement goes along with the
Liberal Label Retention mode.

Now if an LSR Ru detects a network N and advertises a label L for 
that FEC F (N and prefix), to all its peers including its next hop Rd, it is fine.
Rd will store the label ( since liberal mode supported) but will not
use it.

If after some time Ru happens to the next hop of for the Network N
w.r.to Rd, then Rd can make use of the label L advertised earlier.

In case of Ru not having advertised the Label L to Rd, then when
the next hop changes, Rd has to make an explicit label request.

Hence advertising label to all peers including the next hop in 
DU mode (Liberal Label retention) is helpful.

thanks in advance
with best regards
mani
 
/*-------------------------------------------------------------------*/
S.Manikantan
Future Software Private Limited
480-481, Anna salai, Nandanam,
Chennai, Tamil Nadu, 600 035,
India.
Phone	: +91-44-4330550
Fax	: +91-44-4344157.
Email	: [email-masked]
http://www.futsoft.com
/*--------------------------------------------------------------------*/

-----Original Message-----
From:	Prem Shankar Sharma [SMTP:[email-masked]]
Sent:	Tuesday, May 16, 2000 7:45 AM
To:	[email-masked]'
Cc:	Prem Shankar Sharma
Subject:	DU mode:Label Advt.

Hi,

    Please clarify!!!

Regards.
Prem

<1st Mail>

...

<2nd Mail>

Sree,
...

Yes.

Bob