Subject: Re:

From: "Steven Wright" <[email-masked]>
Date: Tue, 9 May 2000 07:54:51 -0400

Hi Tom,
Firstly, thankyou for pulling this together.
I had been scrambling through the other published MPLS mibs trying to find
where the FEC controls were.
My main interest is in the policies related to MPLS and eventually an MPLS
PIB, but such a PIB obviously depends on the underlying capabilities of MIBs
such as this.

A couple of questions though...

1. You mention in the motivation section (4) that there are other
classification processes ( diffserv comes to mind ). Are there existing MIBs
(e.g. Diffserv) that this document should be compared against? or is this
intended to be a common document for a variety of technologies ?

2. The packet header tuple used for classification here seems to be missing
a few items that might be useful e.g classifications based on:
-packet size ( for some QoS applications )
-ToS Bits / DSCP ( for MPLS /Diffserv interoperation )

3. There are some other bases for classification that are not based on the
packet header, but on other information that may be available in the
router - e.g. the source interface, MTU size, traffic
marking/measurement/policing metrics etc.

4. I'd like some more background on the options available under
mplsMplsPacketClassifierActionMask. I'm not sure of the difference between
redirect(2) and redirectLsp (3). If you use the settos(4) option, don't you
need some other parameter to identify which tos codepoint to use ? I'm also
not sure where this list of actions came from - Is it intended to be
complete, or just a starting point ?.

regards
Steven Wright
-----Original Message-----
From: Thomas D. Nadeau [<mailto:[email-masked]>]
Sent: Thursday, May 04, 2000 10:41 AM
To: Steven Wright
Subject: Re: status of MPLS packet classifier mib

Hi Steve,

The MIB was not presented due to a packed
schedule. The MIB was actually never submitted
as a draft because it was submitted late. We
will be republishing it soon. You can find it
at ftp-eng.cisco.com/tnadeau in the meantime.
Please send me your comments.

--Tom

What is the status of the MPLS packet classifier MIB -
draft-nadeau-mpls-packet-classifier-mib-00.txt ?
was this presented in Adelaide ?
Is there now a WG document version ( draft-ietf-....)

regards

Steven Wright, Ph.D.
Network Architecture
Science and Technology
BellSouth Telecommunications
phone (404) 332-2194
fax (404) 529-8025

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 11 May 2000 18:29:06 -0400

Hi,

>marking/measurement/policing metrics etc.

         We intended this MIB to specifically address the
FTN functionality for MPLS. There does exist a DiffServ Packet
Classifier MIB, which does not however, address the FTN
requirements for MPLS.  In particular, the DiffServ MIB does
not allow for the forwarding of packets onto LSPs or Tunnels.
We do however, welcome comments and suggestions on our draft.

>redirect(2) and redirectLsp (3).

         First, it is clear that the BITS defined need more clarification
in their DESCRIPTION clause.

    SYNTAX          BITS {
                   drop(0),
                   pass(1),
                   redirect(2),
                   redirectLsp(3),
                   settos(4),
                   assignTSpec(5)
                 }

         Second, the intent for redirect was to allow forwarding
onto a regular interface. The redirectLsp(3) was intended to
allow for the forwarding of packets onto LSPs. We intend to
delete drop(0), settos(4), assignTSpec(5) and redirect(2). We
also indent to add redirectTunnel to allow for the fowarding
of packets onto MPLS Tunnels.

         Also, we would like to point out that the current
version was a re-posting of an earlier failed posting
before the Adelaide, SA meeting. We will be reissuing this
draft shortly to align it more closely with our goals of
being very specific to MPLS FTNs as well as to include
comments from the WG.

         --Tom