Subject: RE: Lambda Switching

From: Rajesh Kumar <[email-masked]>
Date: Wed, 24 May 2000 10:24:47 -0700

There are some internet drafts focussing on optical networking and use of 
mpls in these networks. These will be useful places to begin your search. I 
found some drafts at
http://ftp.sunsite.utk.edu/ftp/pub/internet-drafts/

The ones I've seen are:
draft-fan-mpls-lambda-signaling-00.txt
draft-ip-optical-framework-00.txt
draft-awduche-mpls-te-optical-01.txt
draft-kompella-mpls-optical-00.txt
draft-basak-mpls-oxc-issues-01.txt

Rajesh

-----Original Message-----
From:	Stewart Pu [SMTP:[email-masked]]
Sent:	Wednesday, May 24, 2000 3:05 AM
To:	[email-masked]
Subject:	Lambda Switching

Hi, all,

I have a question about MPLS. Is it possible for MPLS using lambda as the
label? I mean, if DWDM technology can provide enough available lambda, can
MPLS use lambda as the label? If yes, can we say ' We can achieve optical
switching or optical routing.'? But I ever heard that it is impossible to
achieve optical routing, is it right?

Stewart
 << File: ATT00004.htm >>

---

From: "Holmes, David A." <[email-masked]>
Date: Thu, 25 May 2000 11:08:53 -0700

See the article "Advances in Photonic Packet Switching: An Overview" (S.
Yao, B. Mukherjee, S. Dixit) in the February 2000 issue of IEEE
Communications Magazine, for an overview of some approaches to optical
buffering techniques.

David

-----Original Message-----
From: Yang Cao [mailto:[email-masked]]
Sent: Thursday, May 25, 2000 10:53 AM
To: Hull, Kenneth A.
Cc: 'Dmitri Krioukov'; Krishna Bala; Yakov Rekhter; Stewart Pu;
[email-masked]
Subject: Re: Lambda Switching

I think that's only because a smarter and really practical solution
has not come up yet.

Yang

"Hull, Kenneth A." wrote:
> 
> I believe that true optical buffering without O-E-O conversion would have
to
> accomplished via an optical delay line (ie. a pre-determined length of
> fiber).
> 
> Ken
>         From:   Dmitri Krioukov [SMTP:[email-masked]]
>         Sent:   Wednesday, May 24, 2000 9:15 PM
>         To:     Krishna Bala; Yakov Rekhter; Stewart Pu
>         Cc:     [email-masked]
>         Subject:        RE: Lambda Switching
> 
>         i have a question on optical buffering --
>         what are the available technologies here
>         or links/references to them? (to be more
>         precise: are they just pools of fiber
>         or specially designed mirror boxes, etc.)
> 
>         thanks,
>         --
>         dima.
> 
>         > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Krishna
>         > Bala
>         > Sent: Wednesday, May 24, 2000 5:50 PM
>         > To: Yakov Rekhter; Stewart Pu
>         > Cc: [email-masked]
>         > Subject: RE: Lambda Switching
>         >
>         >
>         > Stewart,
>         > If you define Optical Switching as the ability to switch large
> pipes in a
>         > circuit switched fashion .... yes, this is the core competence
of
> optics.
>         >
>         > If you define Optical Routing as the ability to switch
individual
> packets
>         > in a packet switched manner .... no, this is not the strength of
>         > optics. The
>         > biggest barrier to entry for optics here is the inability of
> optics to
>         > perform
>         > buffering. Large spools of fiber are used as "delay lines" to
> emulate
>         > buffering.
>         >
>         >
>         > Krishna Bala
>         > Tellium
>         >
>         > > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Yakov
>         > > Rekhter
>         > > Sent: Wednesday, May 24, 2000 1:06 PM
>         > > To: Stewart Pu
>         > > Cc: [email-masked]
>         > > Subject: Re: Lambda Switching
>         > >
>         > >
>         > > Stewart,
>         > >
>         > > > label? I mean, if DWDM technology can provide enough
available
>         > > lambda, can
>         > > > MPLS use lambda as the label?
>         > >
>         > > Yes. See draft-awduche-mpls-te-optical-01.txt.
>         > >
>         > > > If yes, can we say ' We can achieve optical switching or
>         > > optical routing.'?
>         > >
>         > > It depends on how you define "optical switching or optical
> routing".
>         > >
>         > > > But I ever heard that it is impossible to achieve optical
> routing,
>         > > > is it right?
>         > >
>         > > I guess folks who told you so may reconsider their opinion :-)
>         > >
>         > > Yakov.
>         > >
>         > >

---

From: "Hull, Kenneth A." <[email-masked]>
Date: Thu, 25 May 2000 14:21:30 -0400

This reference is great for all the ways delay lines are being used.

	A question for Yang @ Lucent.:  Is the MEMs technology based on
slotted network design?

	See the article "Advances in Photonic Packet Switching: An Overview"
(S.
	Yao, B. Mukherjee, S. Dixit) in the February 2000 issue of IEEE
	Communications Magazine, for an overview of some approaches to
optical
	buffering techniques.

	David

	-----Original Message-----
	From: Yang Cao [mailto:[email-masked]]
	Sent: Thursday, May 25, 2000 10:53 AM
	To: Hull, Kenneth A.
	Cc: 'Dmitri Krioukov'; Krishna Bala; Yakov Rekhter; Stewart Pu;
	[email-masked]
	Subject: Re: Lambda Switching

	Yang

	to
	of
	individual
	>         > > > I have a question about MPLS. Is it possible for
MPLS using
	>         > > lambda as the
	available