Subject: RE: TEWG framework updates / MPLS-TE drafts

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 9 May 2000 09:48:01 -0400

> -----Original Message-----
> From: Daniel Awduche [mailto:[email-masked]]
> 
> Regarding draft-li-mpls-igp-te-00.txt, this work was presented 
> at the MPLS WG meeting in March, 1999 (44th IETF, Minneapolis, MN).

[ ... ]

> Essentially, draft-li-mpls-igp-te-00.txt ("IGP Requirements for
> Traffic Engineering with MPLS") describes the 'functional
> requirements' for a conventional IGP to support Traffic
> Engineering. Two complementary drafts detail the protocol extensions
> needed to address these functional requirements. These are (1)
> D. Katz, D. Yeung, "Traffic Engineering Extensions to OSPF"
> and (2) H. Smit and T. Li, "IS-IS extensions for Traffic
> Engineering."
> 
> Implementations based on these specifications are currently shipping
> are being deployed, even though the supporting documents are still in
> draft form.
> 
> Back to the question, draft-li-mpls-igp-te-00.txt has expired 
> and the -01- version does not exist, but we can certainly update 
> and re-issue it if there's sufficient WG interest.

I'm not sure how this would be handled. If implementations are shipping now,
does the IETF view these implementations to be (or soon to be) an Internet
standard, or are they viewed as proprietary solutions? If the former, then
wouldn't the drafts naturally proceed on a standards track?

Is this situation similar to the PIM-SM version 1 vs version 2 sort of
thing, where version 2 is the standard and version 1 is largely proprietary?

Thanks.

Bert
[email-masked]

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 09 May 2000 09:35:12 -0700

> [email-masked]

John can comment on the OSPF side but for ISIS the intention is to make things
informational (Henk is in process of submitting new version of the ISIS TE extensions
and it's supposed to go into last call then).

That's in the spirit of OSPF being the IGP-PS but ISIS needing maintainance
for the selective group (however growing ;-) of large ISPs deploying ISIS. Informational
is good enough for the small group of people building the implementations
to make things interoperable.  In this sense it's not proprietary but the discussion
whether it's informational, experimental or any standard track from ISIS WG point
of view would be just hair-splitting.

    -- tony

---

From: Daniel Awduche <[email-masked]>
Date: Tue, 9 May 2000 12:06:08 -0400

Bert,

Thanks for the comments. 

The referenced documents are Internet drafts. They are not standards
at all. The process for developing and adopting Internet
standards is described in RFC-2026 (Bradner, "The Internet
Standards Process -- Revision 3"). Do you see a need to depart from
that methodology?

The following paragraph from RFC-2026 is, however, pertinent:

 "In general, an Internet Standard is a specification that is stable
  and well-understood, is technically competent, has multiple,
  independent, and interoperable implementations with substantial
  operational experience, enjoys significant public support, and is
  recognizably useful in some or all parts of the Internet."

Thus, specifications that enjoy interoperable implementations from
multiple sources and have demonstrated utility in operational contexts
(e.g., the referenced documents) should clearly stand a better chance
of progressing through the standards process than those that do not
exhibit such attributes.  One of the issues then would be to determine
the appropriate categories for such specifications (ie, informational,
experimental, BCP, standards track, etc)

Cheers,
/Dan