Subject: Last Call for LDP

From: George Swallow <[email-masked]>
Date: Wed, 07 Jun 2000 14:24:48 -0400

This message signals the begining of a last call on LDP.  This last
call is limited to the changes made in draft -07 to address the issues
raised in the previous last call.

The last call ends at 12 pm GMT Wednesday 6/14.

...George

======================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824

---

From: "Cucchiara, Joan" <[email-masked]>
Date: Thu, 8 Jun 2000 15:29:27 -0400

Bob,

My understanding is that the Frame Relay Forum has
dropped support for 17-bit DLCIs.  The LDP MIB and
LSR MIB (drafts) are not supporting 17-bit FrameRelay
labels.

I would like to request that references to 17-bit DLCI
Frame Relay labels be removed from the LDP Specification.
Admittedly, this was not an issue during the prior last
call because the 17-bit FR DLCIs were still being supported
by the FRF during that time.  

This change would more closely align the LDP spec with the 
LDP MIB and LSR MIB.

   Thank you, Joan

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Wednesday, June 07, 2000 2:25 PM
> To: [email-masked]
> Subject: Last Call for LDP
> 
>

---

From: Rob Schmitt <[email-masked]>
Date: Thu, 08 Jun 2000 15:55:47 -0700

LDP MIB authors:

Last time I saw a rev, it was '05' and the MODULE-ID
was set at 'experiment XXX'.  Is a valid experiment
number contemplated to be acquired from the
appropriate authority?
Thanks
/rs

> > The last call ends at 12 pm GMT Wednesday 6/14.

+-----------------------------------------------------------------+
       Robert Schmitt            CISCO SYSTEMS
       [email-masked]
       Chelmsford, MA              978-244-3076
+----------------------------------------------------------------+

---

From: "Cucchiara, Joan" <[email-masked]>
Date: Thu, 8 Jun 2000 17:43:54 -0400

> From: Rob Schmitt [mailto:[email-masked]]
> Sent: Thursday, June 08, 2000 6:56 PM
> To: Cucchiara, Joan
> Cc: [email-masked]
> Subject: RE: Last Call for LDP
> 
> 
> LDP MIB authors:
> 

Speaking for the LDP MIB co-authors, we have not 
requested any number under the experiemental branch.

   -Joan

---

From: [email-masked]
Date: Fri, 9 Jun 00 12:40:07 EDT

Hi,

> Any reason why LDP can't use SCTP ( sigtran ) instead of TCP ?

One reason is that the TCP MD-5 usage called for in LDP is a
well-established peer trust mechanism and there's not been any
deployment of SCTP security yet.

> And it would be far more light weight if it used SCTP.

SCTP isn't lighter weight than TCP, but has different services
to meet different requirements.

Allison (TSV Co-AD)

---

From: [email-masked]
Date: Fri, 9 Jun 00 14:01:54 EDT

Arun,

> IPsec SA between peers should solve security requirement,
> which is not mandatory in any case. 

I'm not up enough on the spec to comment on how to use IPsec
and not fully cognizant of the protocol status, but it seems
from the risk factors described in the LDP Security Considerations
that it would be important to require security.  My two cents...

> As for "horses, for courses" requirements, it would seem
> to me that SCTP is meant for packet oriented signalling
> protocols, which is what LDP is.

If a requirements analysis shows that SCTP matches LDP's needs
well, which it might, that's very valid.  I was pushing back
on your suggestion that SCTP would be a good choice because
it's "light weight".  

Allison

---

From: [email-masked]
Date: Fri, 9 Jun 00 14:12:28 EDT

By the way, I agree too with Dave Katz's points.  

There were compelling requirements in SIGTRAN because of 
estabished telephony signalling parameters that TCP 
could not meet.

We're encouraging WGs to consider the use of SCTP 
especially when muxing or multiple hosting are important, but
with careful evaluation of the costs and benefits.

Allison

---

From: Chip Sharp <[email-masked]>
Date: Fri, 09 Jun 2000 16:32:25 -0400

It might be interesting some time in the future to investigate it, but 
right now I don't know of a compelling reason to do it.

FWIW, SCTP (the spec) will support the same port numbers as TCP for 
LDP.  You can theoretically run SCTP over IPSEC for security although you'd 
have to think carefully about the multihoming issues and it hasn't been 
beaten on.  There is a reliable, unordered mode of operation and it does 
support multiple independent data streams in a single session.

SCTP is just now going through its first bakeoff.  Give it a year and see 
how it works out.  There is no need to rush it.

Of course, if you come up with a huge advantage for using SCTP let me know.
:-)

Chip
SCTP co-editor

At 12:02 PM 6/9/00 -0400, Punj, Arun wrote:
>It doesnot seem to utilize byte stream feature of TCP anyway,
>And would be far more light weight if it used SCTP.
>
>-TL
>
>
>
>

-------------------------------------------------------------------
Chip Sharp                 CTO Consulting Engineering
Cisco Systems
Reality - Love it or Change it.	
http://www.netaid.org		
-------------------------------------------------------------------