Subject: AW: Applications running on RSVP Aware Host End

From: [email-masked]
Date: Wed, 7 Jun 2000 11:22:50 +0200

Dear Gupta:

A scenario:
The customer get a subscrition for a service, say Olympic Gold data service,
with a SP.
At the time of authentication via the AAA-Server. The SP might be in the
position to assign the DSCP according to the subscrition contract to the
user. The DSCP of the IP header of the customer's data will be set
accordingly.

At the point of interconnection (PoI) - where the PE will translate the
DDSCP into CoS - the corresponding VPN, say VPN-Gold of this SP, will be
used for forwarding the user data according to the SLS (Service Level Spec)
and TCS (Traffic Conditioning Spec) contracted with the NP.

Is this feasible?

Regards,
Paul

-----Ursprüngliche Nachricht-----
Von: Neetu Gupta [mailto:[email-masked]]
Gesendet am: Mittwoch, 7. Juni 2000 10:52
An: mpls
Betreff: Re: Applications running on RSVP Aware Host End

Eric,
    Does that mean the Customer will not set TOS byte in the data packet?

Then when the data packets are coming at the ingress point of the MPLS
Domain, how will it be known, to which Diff Serv LSP, the packet has to be
sent, since DSCP value is not set in the header.

Then, who will set the DSCP value?

Eric Gray wrote:

> Neetu,
>
>         Considering the primary application du jour
> for MPLS is traffic engineering, only network
> elements would determine the treatment of host
> packets in the network.  This could - for example
> - be the result of a service level agreement or
> a network domain local decision.
>
>         In general, it would be nice if the network
> operators could rely on hosts to properly set bits
> in the IP header according to how the packets will
> be treated in competition with other packets in a
> network.  But this is unlikely since "cheaters"
> prosper only too well.
>
> --
> Eric Gray

---

From: Eric Gray <[email-masked]>
Date: Wed, 7 Jun 2000 10:40:45 -0700

Neetu,

	The mapping from DS byte to PHB is domain
specific.  A service provider may work out an SLA
with a specific customer to map DS byte values in
packets received from that customer to a service
level to be provided for those packets.  Service
providers may - in turn - use DS byte values to
support those services, which means that the SP
will define a mapping from DS byte value received
to DS byte value used within the SP domain.  If
the SP does not tunnel the IP packets in providing
a service using this approach, the SP will likely
need to perform a reverse mapping for packets as
they leave the SP domain.

	Note that SP customers frequently include 
at least one other SP.  Therefore, this sort of
mapping is very likely to be needed.  But even if 
this sort of SLA is worked out with an enterprise
customer, the chances are very good that the value
that is plugged into the DS byte for packets that
are sent to the SP will be assigned under direct
control of the network services provider within 
the enterprise.  It is possible that a specific
enterprise may do this by allowing end stations
to pick their own DS byte values, depending on
how important each individual thinks their own
work is.  But then again, maybe not. :-)

--
Eric Gray

> -----Original Message-----
> From: Neetu Gupta [mailto:[email-masked]]
> Sent: Wednesday, June 07, 2000 1:52 AM
> To: mpls
> Subject: Re: Applications running on RSVP Aware Host End
> 
> 
> Eric,