Subject: About LDP PDU

From: [email-masked]
Date: Mon, 5 Jun 2000 16:17:42 +0800

I have a question about LDP that bother me :

Does an LDP PDU is tranfered in one TCP packet or
it may be separated to two or more TCP packet.
How can I guarantee to transfer a LDP PDU in one TCP
packet?

Thanks in advance,
lijianping.

---

From: "Chris LaVallee" <[email-masked]>
Date: Mon, 5 Jun 2000 10:03:26 -0700

lijianping,

The max PDU length is 4096, therefore it's possible to use multiple TCP
packets (over ethernet), if a message gets really big ( > 1500)

The Init message does allow you to inform your peer the max PDU you want to
receive. Although I don't think this guarantees that there will be only one
LDP PDU per TCP packet. TCP data is a stream and PDUs don't have to begin
and end at the boundary of the TCP packet.

Fortunately, I think it's unlikely that a PDU will ever get really big.

Chris

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Monday, June 05, 2000 1:18 AM
> To: [email-masked]
> Subject: About LDP PDU
>
>
>
>
>