Subject: RE: Information about optical routing in MPLS net.

From: CATANZARITI Sergio FTR&D/TI <[email-masked]>
Date: Thu, 15 Jun 2000 11:39:15 -0700

> It would simply use the IP network as the out-of-band control
plane.

Fully agree on the advantages. But, this is still an open problem rather
than an acceptable and stable solution, at least in today carriers
operational models.

Sergio

> --------------------------------------------------------------------
> Sergio Catanzariti
> Senior Project Manager, Technology Integration
> France Telecom R&D 
> 1000 Marina Boulevard Suite 300 
> Brisbane CA 94005
> Tel. 650-875-1526
> Fax. 650-875-1505
> email:[email-masked] 
> --------------------------------------------------------------------
> 
> 
> -----Original Message-----
> From:	Tony Li [SMTP:[email-masked]]
> Sent:	Thursday, June 15, 2000 11:29 AM
> To:	[email-masked]
> Cc:	[email-masked]; [email-masked]; [email-masked]
> Subject:	RE: Information about optical routing in MPLS net.
> 
> 
>  | I would support the view that having the router control the optical
> domain
>  | is not good.  This comes down to a simple desire to see an optical
> layer
>  | which is open to ALL clients - not just IP.  Of course it is possible
> to
>  | allow the router to control the optical layer ... however, this idea
>  | overlooks the fact that an operator may wish to carry many other
> clients
>  | across an optical network.
> 
> 
> The optical plane clearly needs a control plane that provides a (lambda)
> routing and signaling infrastructure.  This infrastructure is
> fundamentally
> similar to the routing and signaling technology that we're already using
> for MPLS.  Now, we can choose to re-invent this technology, or we can
> leverage the technology that we have already have developed and have
> started to deploy.
> 
> Note that this argument is completely independent of the nature of the
> optical client.  Nothing here precludes non-IP usage of the optical core.
> It would simply use the IP network as the out-of-band control plane.
> 
> Regards,
> Tony
> 
> 
>

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Thu, 15 Jun 2000 15:13:05 -0400

> Fully agree on the advantages. But, this is still an open problem rather than an acceptable and stable solution, at
> least in today carriers operational models.
> 
> Sergio

    What you are seeing is a recognition by many folks that a PATH regardless of
what we call the labels can be controlled by MPLS (if the MPLS protocols are 
suitibly generalized). What actually goes over these paths can be anything. After
all, that is the "MP" part of "MPLS".

    Constraint based, distributed source routing with an OSPF/IS-IS style 
topology database are the preferred solution to path oriented routing problems
and have been used for a number of years now in ATM and proprietary systems
so it is only natural to extend them to Optical networks.

    Cheers,

    Peter Ashwood-Smith