Subject: FW: Hierarchical Tunnel Establishment in RSVP-TE

From: Shahram Davari <[email-masked]>
Date: Mon, 12 Jun 2000 14:14:49 -0700

Chatur,

I don't think so. Since in case of label= 1, the draft says:

"A value of 1 represents the "Router Alert Label".  This label value is
legal anywhere in the label stack except at the bottom."

So in case of Label=2,4 they could have written: "nowhere except at the
bottom". 

-Shahram

>-----Original Message-----
>From: Chatur sharp [mailto:[email-masked]]
>Sent: Monday, June 12, 2000 5:08 PM
>To: Shahram Davari
>Subject: RE: Hierarchical Tunnel Establishment in RSVP-TE 
>
>
>On the face of it what you say seems to be correct.
>
>Could it be that draft should be interpreted as:
>
>"As that there should be no more labels below a NULL
>label. However, labels could be applied on top
>of a NULL label. "
>
>
>
>
>--- Shahram Davari <[email-masked]>
>wrote:
>> Toni,
>> 
>> The Encaps-draft says that the IPV4/6 Explicit Null
>> Labels are only legal if
>> they are the sole label stack entry. However, in
>> your example the RSVP
>> messages will have two labels, the outer label and
>> the IPV4/6 Explicit Null
>> Label. Isn't this a violation of the Encaps-draft
>> requirement?
>> 
>> Regards,
>> -Shahram
>> 
>> >-----Original Message-----
>> >From: Tony Li [mailto:[email-masked]]
>> >Sent: Monday, June 12, 2000 1:22 PM
>> >To: [email-masked]
>> >Cc: Tony Li; Bora Akyol; [email-masked]'
>> >Subject: Re: Hierarchical Tunnel Establishment in
>> RSVP-TE 
>> >
>> >
>> >
>> >Curtis,
>> >
>> > | If the outer tunnel is constrained (by
>> configuration) to accept only
>> > | inner tunnels with one L3PID, then that L3PID
>> can be placed on the
>> > | outer tunnel.  If there are optimization
>> possible for a particular
>> > | L3PID (IP src/dst hash to split loading along
>> the way comes to mind
>> > | for IPv4) then putting the inner L3PID on the
>> outer tunnel has
>> > | advantages.
>> >
>> >
>> >I agree that this is also possible for
>> implementations that 
>> >want to parse
>> >up the label stack.
>> >
>> >
>> > | No where have I seen a requirement to put a null
>> label on traffic
>> > | destined to the egress LSR.
>> >
>> >
>> >The requirement exists if you take the more general
>> approach 
>> >of specifying
>> >an outer L3PID of MPLS and then wish to tunnel
>> (otherwise 
>> >unlabeled) RSVP.
>> >Under the approach that you've proposed, this would
>> not be necessary.
>> >
>> >Tony
>> >
>> 
>
>
>=====
>I am willing to learn,  if you care to teach.
>I am willing to teach, if you care to learn.
>
>__________________________________________________
>Do You Yahoo!?
>Yahoo! Photos -- now, 100 FREE prints!
>http://photos.yahoo.com
>

---

From: Rajiv Papneja <[email-masked]>
Date: Tue, 13 Jun 2000 09:35:00 -0400 (EDT)

Hi Sharam,

  Hi Sharam,

   According to the draft on label encapsulation, for the label
values (0 or 2) this is true that the values would be legal if
and only if they are the sole label stack entries, indicating that the
label stack must be popped and forwarding should be based on the IPv4 or
IPv6 header. However, does this draft mention that when the label
value is 4, it should be "nowhere except at the bottom of the stack?" If
you refer to the draft-ietf-mpls-label-encaps-07.txt, section 4 part v, it
states that values 4-15 are reserved but it does not mention about the
positioning of these values, top or the bottom of the stack. Please
correct me if I have misunderstood or missed something here.

 Regards       

 Rajiv