Subject: RE: Applications running on RSVP Aware Host End

From: Eric Gray <[email-masked]>
Date: Tue, 6 Jun 2000 08:55:39 -0700

Neetu,

	Considering the primary application du jour
for MPLS is traffic engineering, only network 
elements would determine the treatment of host
packets in the network.  This could - for example
- be the result of a service level agreement or
a network domain local decision.

	In general, it would be nice if the network 
operators could rely on hosts to properly set bits
in the IP header according to how the packets will
be treated in competition with other packets in a
network.  But this is unlikely since "cheaters"
prosper only too well.

--
Eric Gray

> -----Original Message-----
> From: Neetu Gupta [mailto:[email-masked]]
> Sent: Monday, June 05, 2000 11:47 PM
> To: [email-masked]
> Subject: Applications running on RSVP Aware Host End
> 
> 
> Hello,
>     I've a doubt. Please clarify it.
> 
>     We are implementing both Integrated Signaling and Diff Serv LSPs
> using RSVP in the MPLS Domain.
> 
>     Now, my question is: Do the Applications running on the 
> Host machine
> have to be RSVP Aware only or not? Can we run a general 
> Application? If
> we can, then how will the Type of Service byte in the IP Header be set
> specifying the Class of Service with which the data packets of the
> Application will be sent.
> 
> -neetu
>

---

From: Neetu Gupta <[email-masked]>
Date: Wed, 07 Jun 2000 14:21:52 +0530

Eric,
    Does that mean the Customer will not set TOS byte in the data packet?

Then when the data packets are coming at the ingress point of the MPLS
Domain, how will it be known, to which Diff Serv LSP, the packet has to be
sent, since DSCP value is not set in the header.

Then, who will set the DSCP value?