Subject: RE: Ingress LER in LDP

From: Eric Gray <[email-masked]>
Date: Tue, 6 Jun 2000 10:03:12 -0700

Chris,

	The "standard" approach - as far as I know -
is to use PPP for POS.  The ethertypes defined in
[ENCAPS] are for transmission of MPLS labeled data
over "LAN media".  It is arguable that some type of
HDLC framing of IP packets makes SONET a "LAN media"
but that may be a stretch - particularly if a pro-
prietary approach is used.  PPP protocol numbers 
0x0281 (unicast) and 0x0283 (multicast) are defined 
for PPP encapsulation of MPLS labeled packets.

	I am not familiar with whether or not the 
Cisco proprietary approach you describe (I will
take your word for it that it exists) is available
without licensing fees.  If it exists, is deployed
as the only Cisco supported POS approach and is not
available for licensing, then I think we can look 
forward to government regulation of the new Internet 
monopoly in the very near future. :-)

--
Eric Gray

> -----Original Message-----
> From: Chris LaVallee [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 9:35 AM
> To: Eric Gray; [email-masked]; David Wang
> Cc: [email-masked]
> Subject: RE: Ingress LER in LDP
> 
> 
> I was already aware of the MPLSCP in the draft, so what I 
> really meant to
> ask was this:
> 
> 1) Cisco-HDLC uses ethertypes, right ? Therefore MPLS will treat
> POS/Cisco-HDLC as Ethernet.
> 
> 2) Is there really a benefit to PPP-MPLSCP ?
> Meaning, you could just use Cisco-HDLC or PPP-BCP. MPLSCP 
> doesn't negotiate
> anything.
> 
> I guess you do save a few bytes with PPP-MPLS data and if 
> you're only MPLS
> switching PPP to PPP, nothing has to be add/deleted or modified in the
> packet.
> 
> 
> Chris
> 
> 
> 
> 
> > -----Original Message-----
> > From: Eric Gray [mailto:[email-masked]]
> > Sent: Tuesday, June 06, 2000 8:44 AM
> > To: 'Chris LaVallee'; [email-masked]; David Wang
> > Cc: [email-masked]
> > Subject: RE: Ingress LER in LDP
> >
> >
> > Chris,
> >
> > 	Please read the draft:
> >
> >
> > 
> http://www.ietf.org/internet-drafts/draft-ietf-mpls-label-enca
> ps-07.txt
> >
> > I'm not sure where you got the quote below (I seem to
> > be getting mail messages from the MPLS mailing list
> > in some sort of random ordering), but it is incorrect
> > - the numbers given are not ether types...
> >
> > --
> > Eric Gray
> >
> > > -----Original Message-----
> > > From: Chris LaVallee [mailto:[email-masked]]
> > > Sent: Friday, June 02, 2000 4:29 PM
> > > To: [email-masked]; David Wang
> > > Cc: [email-masked]
> > > Subject: RE: Ingress LER in LDP
> > >
> > >
> > > > -POS the ether type will be 0x8847 or 0x8848 (as oppsed to
> > > 0x0800 for IP)
> > >
> > > This might be off topic, but...
> > >
> > > How do you get an ethertype over POS ?
> > > I'm guessing it's Cisco-HDLC (which I know nothing about)
> > >
> > > PPP over POS has 2 other possibilities to carry MPLS
> > > - Add a new CP (control proto) for MPLS
> > > - Have BCP (PPP Bridging) carry MPLS
> > >
> > > Anyone have a preference / opinion on what people should use ?
> > >
> > > Chris
> > >
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]On Behalf
> > > Of James R.
> > > > Leu
> > > > Sent: Friday, June 02, 2000 11:43 AM
> > > > To: David Wang
> > > > Cc: [email-masked]
> > > > Subject: Re: Ingress LER in LDP
> > > >
> > > >
> > > > On Fri, Jun 02, 2000 at 01:20:33PM -0500, David Wang wrote:
> > > > > One related question: How a LSR distinguishes a labeled
> > > packet from an
> > > > > unlabeled packet?
> > > >
> > > > Depends on the medium:
> > > > -ATM the VCC will contain a protcol type (AAL5Null 
> requires this)
> > > > -POS the ether type will be 0x8847 or 0x8848 (as oppsed to
> > > 0x0800 for IP)
> > > > -PPP has some PIDs assigned for MPLS as well (as does IP)
> > > >
> > > > Hope this helps.
> > > >
> > > > Jim
> > > >
> > > > >
> > > > > -----Original Message-----
> > > > > From: Eric Rosen [mailto:[email-masked]]
> > > > > Sent: Thursday, June 01, 2000 9:28 AM
> > > > > To: Santosh Gupta
> > > > > Cc: [email-masked]
> > > > > Subject: Re: Ingress LER in LDP
> > > > >
> > > > >
> > > > > Santosh> Can someone tell me how to decide if a router is
> > > > supposed to act as
> > > > > Santosh> an Ingress LER for some particular FEC in 
> MPLS domain ?
> > > > >
> > > > > People keep asking  this question, and I'm never quite sure
> > > > just what it is
> > > > > they are asking, because there isn't much of a mystery here.
> > > > >
> > > > > If a router received an unlabeled  packet which belongs to a
> > > > particular FEC,
> > > > > and the next hop for that packet supports MPLS, and the router
> > > > is configured
> > > > > such that it is allowed to do allow label imposition for
> > > > packets in that FEC
> > > > > with that next hop, then the router should impose the label
> > > > assigned to that
> > > > > FEC by that next hop.
> > > > >
> > > > > Does that answer your question?
> > > >
> > > > --
> > > > James R. Leu
> > > >
> > >
> >
>

---

From: Pankaj K Jha <[email-masked]>
Date: Wed, 07 Jun 2000 04:03:07 -0700

- In POS, the protocol used is PPP indeed, and entire provisioned (a VT,
STS-1, etc.) bandwidth of a SONET frame is terminated at a node. This means
that all packets containing PPP (POS) packets within the provisioned area of
SONET SPE are terminated at the node. This is similar to standard PPP where
all packets are point-to-point and the receiver receives all packets that
come on the point-to-point WAN link. Using MPLS on POS has same meaning and
usefulness as that on PPP.

- One of the uses of MPLS in POS is to enable mesh networking easily without
having to use LAN-like protocol for SONET (in LAN-like protocol, each SONET
node must be assigned a MAC address and an entire suite of Ethernet and
higher layer protocols must be used).

A note on LAN-like protocols:
So far, all LAN-like protocols for SONET/SDH are proprietary; some are at
standards committees for further discussions. At higher speeds, some do not
use HDLC since byte-stuffing and de-stuffing at OC-192-type speeds for each
byte is very difficult and because long packets are susceptible to malicious
scrambling. Those that do not use HDLC use a length/length-CRC construct for
packet framing (SDL protocol framing is an example). Almost all of these
LAN-like protocols contain extra bytes in the header to do a TTL discard on
the packet. Recall that in Ethernet packets do not 'come back' to sender. In
SONET, to ensure that a packet does not go around the ring ad nauseum each
node decrements TTL count as a packet passes by it, and discards a packet
(takes it off the ring) when TTL expires.

If MPLS is used with POS, nodes can use MPLS to interconnect and make mesh
network of nodes rather than use a LAN-like addressing for every packet. In
case of optical networks since packets/frames must pass through every node
(packets enter Rx port, and are analyzed after de-scrambling, etc. and then
sent out on Tx port)  there is no need for an Ethernet-like addressing.
Nodes can negotiate and establish MPLS labels and then use that to send
packets to different nodes. Advantage of using MPLS for POS will be that the
host system does not have to look at all of its received POS packets, look
at the layer3 info in payload and do full route lookup work for each packet
to determine where the packet should go. An MPLS lookup logic at line cards
will be able to do packet forwarding and re-routing.

-Pankaj