Subject: COPS - Unsolicited Decision Message

From: "Santosh Gupta" <[email-masked]>
Date: Thu, 29 Jun 2000 19:45:21 +0530

Hello
    I am working on COPS ( rfc 2748 ) and have the following doubt.

All Request Messages going from PEP to PDP have a unique Handle. PEP is supposed to ensure this uniqueness for the TCP connection with the PDP. For all solicited Decisions from PDP to PEP  Handle of the corresponding Request Message is sent. 
My question is: What is the Handle for Unsolicited Decision Message from PEP to PDP ?

From the RFC what I make out is that PDP doesnt keep any track of Handle. It simply performs comparison to find the context of incoming message. So how does it decide which Handle to use? 

Santosh Gupta

---

From: "Francis Reichmeyer (IPHighway MA)" <[email-masked]>
Date: Thu, 29 Jun 2000 11:02:01 -0400

In the outsourcing model, Unsolicited Decision is used to make
changes/updats to a previous (Solicited) decision. In that case
the same Handle used in the previous decison is used in the 
Unsolicited decision.
The Unsolicited Decision is primarily used in the provisioning
management model. The PEP supplies a Handle in its initial
Request to the PDP and that Handle is used in the Decision
messages. See the cops-pr draft (draft-ietf-rap-pr-02.txt) for more
details.
Thanks,
-Fran

-----Original Message-----
From: Santosh Gupta
To: [email-masked]
Sent: 06/29/2000 10:15 AM
Subject: COPS - Unsolicited Decision Message

Hello
 
All Request Messages going from PEP to PDP have a unique Handle. PEP is
supposed to ensure this uniqueness for the TCP connection with the PDP.
For all solicited Decisions from PDP to PEP  Handle of the corresponding
Request Message is sent. 
My question is: What is the Handle for Unsolicited Decision Message from
PEP to PDP ?
 
From the RFC what I make out is that PDP doesnt keep any track of
Handle. It simply performs comparison to find the context of incoming
message. So how does it decide which Handle to use? 
 
Santosh Gupta