Subject: RE: Ingress LER in LDP

From: Shahram Davari <[email-masked]>
Date: Mon, 5 Jun 2000 08:22:32 -0700

Chris,

There is already a Control Protocol defined for MPLS, which is called
MPLSCP. Look at section 4 in:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-label-encaps-07.txt

So I don't see any point in using BCP for MPLS. Besides BCP is mostly
focused on LAN encapsulations.

MPLS Ethertypes are encapsulated in PPP packets in the PPP protocol field.

Regards,
-Shahram 

>-----Original Message-----
>From: Chris LaVallee [mailto:[email-masked]]
>Sent: Friday, June 02, 2000 7:29 PM
>To: [email-masked]; David Wang
>Cc: [email-masked]
>Subject: RE: Ingress LER in LDP
>
>
>> -POS the ether type will be 0x8847 or 0x8848 (as oppsed to 
>0x0800 for IP)
>
>This might be off topic, but...
>
>How do you get an ethertype over POS ? 
>I'm guessing it's Cisco-HDLC (which I know nothing about)
>
>PPP over POS has 2 other possibilities to carry MPLS
>- Add a new CP (control proto) for MPLS
>- Have BCP (PPP Bridging) carry MPLS
>
>Anyone have a preference / opinion on what people should use ?
>
>Chris
>
>
>
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]On Behalf 
>Of James R.
>> Leu
>> Sent: Friday, June 02, 2000 11:43 AM
>> To: David Wang
>> Cc: [email-masked]
>> Subject: Re: Ingress LER in LDP
>> 
>> 
>> On Fri, Jun 02, 2000 at 01:20:33PM -0500, David Wang wrote:
>> > One related question: How a LSR distinguishes a labeled 
>packet from an
>> > unlabeled packet? 
>> 
>> Depends on the medium:
>> -ATM the VCC will contain a protcol type (AAL5Null requires this)
>> -POS the ether type will be 0x8847 or 0x8848 (as oppsed to 
>0x0800 for IP)
>> -PPP has some PIDs assigned for MPLS as well (as does IP)
>> 
>> Hope this helps.
>> 
>> Jim
>> 
>> > 
>> > -----Original Message-----
>> > From: Eric Rosen [mailto:[email-masked]]
>> > Sent: Thursday, June 01, 2000 9:28 AM
>> > To: Santosh Gupta
>> > Cc: [email-masked]
>> > Subject: Re: Ingress LER in LDP 
>> > 
>> > 
>> > Santosh> Can someone tell me how to decide if a router is 
>> supposed to act as
>> > Santosh> an Ingress LER for some particular FEC in MPLS domain ?
>> > 
>> > People keep asking  this question, and I'm never quite sure  
>> just what it is
>> > they are asking, because there isn't much of a mystery here.
>> > 
>> > If a router received an unlabeled  packet which belongs to a 
>> particular FEC,
>> > and the next hop for that packet supports MPLS, and the router 
>> is configured
>> > such that it is allowed to do allow label imposition for 
>> packets in that FEC
>> > with that next hop, then the router should impose the label 
>> assigned to that
>> > FEC by that next hop.
>> > 
>> > Does that answer your question? 
>> 
>> -- 
>> James R. Leu
>> 
>

---

From: Tony Li <[email-masked]>
Date: Tue, 6 Jun 2000 11:47:28 -0700 (PDT)

| 	The "standard" approach - as far as I know -
 | is to use PPP for POS.  The ethertypes defined in
 | [ENCAPS] are for transmission of MPLS labeled data
 | over "LAN media".  It is arguable that some type of
 | HDLC framing of IP packets makes SONET a "LAN media"
 | but that may be a stretch - particularly if a pro-
 | prietary approach is used.  PPP protocol numbers 
 | 0x0281 (unicast) and 0x0283 (multicast) are defined 
 | for PPP encapsulation of MPLS labeled packets.
 | 
 | 	I am not familiar with whether or not the 
 | Cisco proprietary approach you describe (I will
 | take your word for it that it exists) is available
 | without licensing fees.  If it exists, is deployed
 | as the only Cisco supported POS approach and is not
 | available for licensing, then I think we can look 
 | forward to government regulation of the new Internet 
 | monopoly in the very near future. :-)

The Cisco serial link protocol (commonly known as Cisco HDLC) is not widely
known outside of the operational community but has been publically
published by Cisco and is implemented in certain BSD Unix variants as well
as certain other router implementations.

It does use Ethertypes for demuxing protocols, however, this should not be
misconstrued into thinking that the serial link is modeled as a LAN.

I believe that Cisco also supports PPP on POS.

Regards,
Tony

---

From: "Yongjun Im" <[email-masked]>
Date: Wed, 7 Jun 2000 13:41:16 +0900

According to "draft-ietf-label-encaps-07.txt", 

When transporting labeled packets over PPP,
PPP protocol fields are as follows:
   Unicast : 0x0281
   Multicast : 0x0283

When transporting labeled packets over LAN media,
ethertype fields are as follows:
   Unicast : 0x8847
   Mulicast : 0x8848

Do you mean that POS uses Ethernet or 802.3 LLC/SNAP encapsulation?

Yongjun Im

----- Original Message ----- 
From: "James R. Leu" <[email-masked]>
To: "David Wang" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, June 03, 2000 3:43 AM
Subject: Re: Ingress LER in LDP

On Fri, Jun 02, 2000 at 01:20:33PM -0500, David Wang wrote:
> One related question: How a LSR distinguishes a labeled packet from an
> unlabeled packet? 

Depends on the medium:
-ATM the VCC will contain a protcol type (AAL5Null requires this)
-POS the ether type will be 0x8847 or 0x8848 (as oppsed to 0x0800 for IP)
-PPP has some PIDs assigned for MPLS as well (as does IP)

Hope this helps.

Jim

> Santosh> Can someone tell me how to decide if a router is supposed to act as
> People keep asking  this question, and I'm never quite sure  just what it is
> If a router received an unlabeled  packet which belongs to a particular FEC,
> and the next hop for that packet supports MPLS, and the router is configured
> such that it is allowed to do allow label imposition for packets in that FEC
> with that next hop, then the router should impose the label assigned to that
> FEC by that next hop.
> 

-- 
James R. Leu