Subject: RE: OAM functionality (Was: RE: can egress know the ingress of a packet?)

From: Shahram Davari <[email-masked]>
Date: Mon, 5 Jun 2000 07:48:04 -0700

Florian,

When I mentioned ATM, I didn't mean that we adopt and simply copy all the
ATM OAM for MPLS. What I meant was, since MPLS has lot of similarity to ATM,
probably we could leverage our knowledge of ATM OAM and design a set of OAM
functions which are tailored to MPLS. 

Regards,
-Shahram

>-----Original Message-----
>From: Florian-Daniel Otel [mailto:[email-masked]]
>Sent: Monday, June 05, 2000 10:41 AM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]; [email-masked];
>[email-masked]; [email-masked]; [email-masked]
>Subject: OAM functionality (Was: RE: can egress know the ingress of a
>packet?)
>
>
>
>Sharam,
>
>> Hi Neil,
>
>> I also think we need some sort of OAM function at MPLS 
>layer. And as you
>> said, to be able to process OAM cells, they must be 
>recognized by LSRs. But
>> it might be hard to change the definition of TTL field at 
>this point in
>> time. So I have a different proposal. Why don't we 
>assign/reserve some Label
>> values to be used only by OAM packets. This is very 
>analogous to ATM, in
>> which, some VPI/VCIs are reserved for OAM cells (e.g. VPI=0 
>and VCI =0-15).
>> For example we could assign Label = 0 for the Keepalive 
>messages that you
>> described.
>
>> I am interested in writing such an I-D, and in fact my 
>company is expert in
>> ATM OAM, so we could leverage that knowledge for the MPLS OAM.
>
>As Neil already pointed out, there are several people intrested in O&M 
>functionality in MPLS, and for several reasons (you can also check the
>discussion between Neil and Vishal on TEwg mailing list on 17 Apr &
>ff. I also had some off-list questions about it). 
>
>But the impression i got (and please, someone correct me if I'm wrong) 
>is that, as the Theimer OAM requirements draft clearly states:
>
>"[..]we do not intend to simply adopt the OAM functions and procedures
>previously defined  for other technologies (in particular ATM), as
>this would probably lead to very complex and expensive 
>implementations[..]"
>
>
>
>Putting it bluntly, the way i read this is that "we simply don't want
>to turn MPLS into ATM-2 by adding all possible types of OAM functions".
>
>
>So, my take is (and, by all means, please correct me if i'm wrong)
>that in addition to the (rather vague IMHO) Theimer draft there you
>have all other proposals for recovery, protection, restoration and
>loop prevention but no other general O&M spec than the above
>draft. Why is that and how to solve (if ever need be) the OAM
>needs...well, that's it's beyond my knowledge (and the reason I'm 
>asking about it here).
>
>
>My $0.02 worth.
>
>With kind regards,
>
>Florian.
>

---

From: "David Allan" <[email-masked]>
Date: Tue, 6 Jun 2000 10:34:15 -0400

Neil:

I, for one, would like to see the minimum set you refer to before we start
discuss fiddling with things.

Dave

> -----Original Message-----
	<snip>

> I really ought to get something drafted so that other people can more
> constructively criticise it......there may indeed be better ways to
> provide
> the functionality we would like to see.   I will try and do something over
> the next few weeks or so and circulate to those who have expressed an
> interest so far. 
> 
> Regards, Neil
> 
>