Subject: RE: OAM labels (was: can egress know the ingress of a packet?)

From: Shahram Davari <[email-masked]>
Date: Thu, 8 Jun 2000 10:55:11 -0700

Hi Indra,

>-----Original Message-----
>From: Indra.Widjaja [mailto:[email-masked]]
>Sent: Wednesday, June 07, 2000 4:28 PM
>To: Shahram Davari
>Cc: 'Theimer Thomas'; 'Ross Callon'; [email-masked]
>Subject: Re: OAM labels (was: can egress know the ingress of a packet?)
>
>
>Shahram:
>Thanks for your clarification.
>I was slow and didn't read the message from Thomas.
>As he said in his later message, the LSP can be identified in the
>body of the OAM packet if needed (which is still to be defined),
>so the problem can be solved, right?

Not exactly. What if there are hierarchical tunnels and the egress of one
tunnel is the intermediate node of another tunnel. Then you can't identify
the LSP by looking at the body of the OAM packet, because the OAM packet
belongs to many LSPs (i.e., hierarchical LSPs). Right?

-Shahram

>indra
>
>
>Shahram Davari wrote:
>
>> Indra,
>>
>> There is no problem in sending the packet to OAM processor. 
>The problem is
>> when the packet is received by OAM processor, because the 
>forwarding label
>> is not present any more, how can the OAM processor determine 
>which LSP this
>> OAM packet belonged to. Because the processing of the OAM 
>packet will depend
>> on identifying the LSP.
>>
>> -Shahram
>>
>> >-----Original Message-----
>> >From: Indra.Widjaja [mailto:[email-masked]]
>> >Sent: Wednesday, June 07, 2000 1:41 PM
>> >To: Shahram Davari
>> >Cc: 'Theimer Thomas'; 'Ross Callon'; [email-masked]
>> >Subject: Re: OAM labels (was: can egress know the ingress 
>of a packet?)
>> >
>> >
>> >Shahram:
>> >I still don't understand what the problem really is.
>> >The penultimate LSR forwards the packet to the egress LSR
>> >based on the user data label that was just popped out.
>> >When the packet with the OAM label arrives at the egress
>> >LSR, the egress LSR should be able to direct the OAM
>> >packet to the proper OAM handler.
>> >Does this work?
>> >indra
>> >
>> >
>> >Shahram Davari wrote:
>> >
>> >> Theimer,
>> >>
>> >> I think what Ross meant was that using PHP, when OAM label
>> >is below the
>> >> forwarding label, the egress node can't determine the LSP
>> >that the OAM
>> >> packet belongs to.
>> >>
>> >> Regards,
>> >> -Shahram
>> >>
>> >> >-----Original Message-----
>> >> >From: Theimer Thomas [mailto:[email-masked]]
>> >> >Sent: Wednesday, June 07, 2000 5:10 AM
>> >> >To: 'Ross Callon'
>> >> >Cc: [email-masked]
>> >> >Subject: RE: OAM labels (was: can egress know the ingress
>> >of a packet?)
>> >> >
>> >> >
>> >> >> -----Original Message-----
>> >> >> From:        Ross Callon [SMTP:[email-masked]]
>> >> >> To:  Theimer Thomas; 'Shahram Davari'; 'Peter Willis'
>> >> >>
>> >> >> If the outer label identifies the LSP, and the inner label is a
>> >> >> special OAM value, then I think that there is a problem with
>> >> >> penultimate hop label popping.
>> >> >       [Theimer Thomas]  Good point. We missed that. 
>However, if the
>> >> >penultimate hop removes the top label, the egress node will
>> >receive the
>> >> >packet with an OAM label on top. That would still trigger OAM
>> >> >processing in
>> >> >the egress node, so I don't necessarily see a problem here,
>> >except that
>> >> >perhaps the egress node needs to be an LSR. If not, then in
>> >my view the
>> >> >penultimate hop is really the logical endpoint of the LSP,
>> >and should
>> >> >process the OAM label if present. However, I must admit I
>> >don't clearly
>> >> >understand how penultimate hop popping is really applied in a
>> >> >network. I
>> >> >also could not find any explicit support in LDP, CR-LDP and
>> >> >TE-RSVP. Without
>> >> >such support, is anyone actually using that mechanism in 
>practice ?
>> >> >
>> >> >       Thomas
>> >> >
>> >> >
>> >
>

---

From: "Indra.Widjaja" <[email-masked]>
Date: Thu, 08 Jun 2000 17:51:20 -0400

> belongs to many LSPs (i.e., hierarchical LSPs). Right?

I'm not sure if I follow you completely; however, I see that there could
be a problem if the OAM sink has to know the LSP that the OAM packet
came from.
So the question is what type of identification that is sufficient for an OAM
sink
to know. Is it sufficient to provide the LSR ID of the OAM source,
probably plus another ID unique within that OAM source to take care
of possible multiple LSPs?
Do you know of an example of a particular OAM operation that requires the
OAM sink to know the LSP?
indra