Subject: RE: MPLS Diffserv Extensions related questions/comments

From: "tom worster" <[email-masked]>
Date: Tue, 6 Jun 2000 08:51:52 -0400

From: [email-masked] [mailto:[email-masked]]On Behalf Of CATANZARITI
Sergio FTR&D/TI
>
> I agree that it would be actually very helpful. I
> would like to build topology-driven LSPs and use
> EXP-PHBs stuff for differentiating CoS-like traffic.

i certainly see the utility of being able to control
the exp -> phb mapping. i just don't see (yet) that
every phb needs a unique mapping.

> I do not understand the "hardware cost friendly"
> problem.

the cost i'm referring to is that a system needs to
provide memory to store an exp -> phb mapping for
every lsp. in a fast implementation that may come
at a noticeable marginal hw memory cost.

> The real issue here is to have a flexible
> LSPs management/control plane (I do not understand
> where the signalling problem is in all this) that
> would allow me to do it in a simple, and semantically
> congruous manner.

yes. say you could establish several exp -> phb
mappings in your lsrs and each is given an index
unique within the domain. you could signal the
index per lsp. would not that give you the
flexibility you are looking for? how many such
mappings would you need?

> It should not be that hard, at least at the
> provisioning level, and I guess I saw it already but
> I do not recall now which vendor was it :-).

it's certainly doable. but it comes at a cost in
some designs. in designs in which the memory for
each lsp is reallocated, providing support for
random signalled mappings comes at a cost.

c u
tom

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 06 Jun 2000 10:07:37 -0400

In message <[email-masked]>, "tom wors
> at a noticeable marginal hw memory cost.

If the network provider is reasonably sane, then you will probalby
need to map a medium to large number of LSPs into a small number of
EXP to PHB mappings.

OTOH .. at least a few people built full mesh IGPs on ATM overlays so
assumptions of ISP sanity don't hold up universally.  :-(

Curtis

---

From: "tom worster" <[email-masked]>
Date: Tue, 6 Jun 2000 11:04:45 -0400

From: Curtis Villamizar [mailto:[email-masked]]
> 
> In message 
> <[email-masked]>, "tom wors
> ter" writes:
> > 

that's what i imagined too. which is why i question the
design of a protocol that provides unnecessary resolution
with a non-trivial cost attached to that resolution.

> assumptions of ISP sanity don't hold up universally.  :-(

if the requirement for a different exp -> phb mapping for 
each of a medium to large number of lsps is considered
unreasonable then that should be taken into consideration
in the diff-ext protocol design.

i thought about a separation of ds semantics from mpls
signalling using an "exp -> phb mapping index" which would
be signalled in the new tlv instead of the mapping itself.
a set of mappings would be configured and referred to in 
the by the index in the signalling messages.

the technical benefits i see are reduced signalling 
bandwidth and processing and a reduced per lsp memory
budget.

but there are other advantages. the diff-ext draft could
be radically simplified since the distinction of e-lsp
and l-lsp disappears -- they are just different classes
of mappings. conceivable, the mappings could go into
experimental rfcs and a range of indexes could be reserved
for standardisation. such a separation of mpls signalling
and (perhaps more controversial) ds-related semantics could 
be expeditious.

c u
tom

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 06 Jun 2000 13:58:54 -0400

In message <[email-masked]>, "tom wors
> in the diff-ext protocol design.

The BGP protocol specification doesn't need to limit the number of BGP
routes that need to be supported.  The OSPF protocol specification
doesn't need to limit the number of OSPF adjacencies or ASE routes and
most people know you can kill an OSPF implementation by feeding it a
grossly excessive number of ASE routes.

None of these protocols scale infinitely.  Yet they are all useful.

There is no need for diffserv or MPLS diffserv to specify similar
limits.  You need to find out what your customers are trying to build
in terms of number of routes, etc and build something that meets their
needs.  The IETF can't tell you that and it shouldn't try to.

Curtis