Subject: RE: MPLS and IS-IS

From: Navaneeth K <[email-masked]>
Date: Fri, 16 Jun 2000 12:15:20 +0530

Hi....
Any of you got any links to the papers mentioned below?
Any pointers in this regard, most welcome..

Regards
Navaneeth.

At 4:08 PM -0400 5/17/00, J. Noel Chiappa wrote:
>PS: Somwhere, covered by many layers of dust, I have at least two such
>documents, one by Radia and one by me, dating from around the period of the
>FSU IETF (whenever that was - probably '84 or so).

Noel,

Probably not '84, as the first IETF meeting took place in January 1986.

Radia's paper was published in IEEE Network (September 1991) - "A 
Comparison between Two Routing Protocols: OSPF and IS-IS."

The definitive comparison of OSPF and IS-IS, of course, is the 1991 
Interop debate between Radia and Milo Medin, which also featured Ross 
Callon and Dave Clark debating the merits, respectively, of 
"integrated" and "ships in the night" routing for the Internet.

Radia and Milo published their debate arguments in the October 1991 
number (5:10) of Ole Jacobsen's ConneXions - "The Great IGP Debate, 
Part I: IS-IS and Integrated Routing" by Radia, and "The Great IGP 
Debate, Part II: The Open Shortest Path First (OSPF) Routing 
Protocol" by Milo. I'm sure these are on the web somewhere.

- Lyman

---

From: Neal Castagnoli <[email-masked]>
Date: Mon, 19 Jun 2000 16:26:47 -0700

> From: 	David Wang [mailto:[email-masked]] 
> 
> Hi All,
> 
> I need to learn some basics of IS-IS. I checked amazon.com, 
> cl.com (San Jose Computer literature book store), 
> bookpool.com and several other technology bookstores. To my 
> great surprise I couldn't find any book about IS-IS. I 
> couldn't find any tutorial or white paper about the IS-IS 
> protocol on the Internet either. All I can read is the 10 
> years old RFC 1142 and RFC 1195.

You can download the protocol specification for IS - IS (ISO/IEC 10589) from
ANSI (www.ansi.org) for a fee.  This is the base upon which RFC 1195 is
built.  You also might want to check out the ietf is-is working group.

> 1.	When IS-IS protocol is used to route IP packet only, 
> what kind of lay 3 protocol the IS-IS routers use to 
> communicate link state information (the link state 
> advertisements) and other protocol related information, IP or 
> CLNP? What is the encapsulation format of these packets. What 
> the standard specify and what people actually implement?  

IS - IS runs directly on top of the data-link using the CLNP protocol ID
(SAP in Ethernet 802 terms).  IS - IS packets are not encapsulated in CLNP.
You don't need to forward or process CLNP packets. To be compliant with RFC
1195, you run the IS portion of ES - IS (ISO 9542) over WAN links.

There is also a draft standard describing the encapsulation of IS - IS in
IP, draft-ietf-isis-wg-over-ip-02.txt.

> 2.	Can someone recommend me a book, a white paper or some 
> tutorials so I may get started quicker.

There is some discussion of IS - IS in Radia Perlman's book
"Interconnections, Second Edition," ISBN 0-201-63448-1.

> Thanks for your help.
> David

  --Neal Castagnoli
    allegro networks

> 
> -----Original Message-----
> From:	HANSEN CHAN [mailto:[email-masked]]
> Sent:	Tuesday, May 16, 2000 7:22 AM
> To:	[email-masked]
> Subject:	MPLS and IS-IS
> 
> 
> Hi all,
> 
> I have been hearing IS-IS is a better protocol to be used 
> than OSPF in a MPLS network for TE application. Is that a 
> fair statement? What are the technical reasons?
> Appreciate if someone can shed some light on this subject.
> Thanks,
> Hansen
>