Subject: Re: Last Call on MPLS-Diff-Serv

From: Eric Gray <[email-masked]>
Date: Mon, 26 Jun 2000 09:57:07 -0700

George,

One last call comment on MPLS Diff Serv (editorial 
comments via separate posting).

Explicit Congestion Notification
================================

	This section cannot remain as is if the document is
to be allowed to complete last call.

	The reference [MPLS-ECN] is no longer available (the
'00' version was replaced by a '01' version which has since
expired).  Perhaps a better reference would be:

"ECN Interactions with IP Tunnels", S. Floyd, K. Ramakrishnan
(http://www.ietf.org/internet-drafts/draft-floyd-ecn-tunnels-00.txt)

Because there is no referent for MPLS-ECN, the text in section
11 ("Explicit Congestion Notification") is not workable - since,
in the absence of work in progress on MPLS-ECN, the following 
things remain unclear (with no obvious relief in sight):

o	How many bits are needed for ECN ([ECN] uses 2 bits,
	the current text claims that a single bit is used - 
	but there is no referent from which to validate this);
o	What the position of any ECN bit(s) would be within the
	EXP field; 
o	To what packets ECN bits would be applied;
o	What the implications with respect to DiffServ treatment
	are for ECN marked MPLS encapsulated packets.  

This is by no means intended to be an exhaustive listing of the
remaining issues with interactions between DiffServ and MPLS-ECN.

Perhaps what is really needed is the ability to configure both
a set of EXP to PHB mappings and a EXP field mask to be used 
to extract the EXP bits that apply to this mapping.  For example,
if the bit arrangement is like this:

      E P P
      C H H
      T B B
        1 2

. . . X Y Y . . .

then the mask would be '0 1 1' and values 'Y Y' would be used to
determine the EXP to PHB mapping that applies to this packet.

In addition, it might be a good idea to configure - or define
signaling for - the behavior that applies to the masked out
bit(s).  Presumably, the default would be "forward unchanged".

This section - as is - should be discarded (or possibly replaced
with a more generalized approach - such as suggested above).

--
Eric Gray

George Swallow wrote:
> 
> This message marks the beginning of a last call on
> draft-ietf-mpls-diff-ext-05.txt, MPLS Support of Differentiated
> Services.
> 
> The last call ends June 26, 2000 at mid-night GMT.
> 
> ...

---

From: Bora Akyol <[email-masked]>
Date: Mon, 26 Jun 2000 11:31:52 -0700

I think one can only overload those 3 bits so much. As we keep on
overloading these bits, we create more and more state in every LSR on
the way which is something not desirable.

I do agree that the ECN section should be removed completely from this
document.

Bora