Subject: RE: MPLS Performance analysis.....

From: Rajesh Kumar <[email-masked]>
Date: Wed, 7 Jun 2000 12:54:49 -0700

"It is a well known fact at this point we can make IP lookups as fast we 
can do MPLS lookups"

"can" is right. But the complexity of implementing a longest-prefix-match 
in hardware (or using a cam) is definitely more than a table index lookup 
(like mpls allows). And more expensive too.

If your car could get you there as quickly, do you need to build a 
spaceship!!!!

-----Original Message-----
From:	Bora Akyol [SMTP:[email-masked]]
Sent:	Wednesday, June 07, 2000 11:57 AM
To:	'Yakov Rekhter'
Cc:	[email-masked]
Subject:	RE: MPLS Performance analysis.....

Yakov,

It is a well known fact at this point we can make IP lookups as fast we can
do MPLS lookups.

So the lookup speed advantage of MPLS does not exist anymore which I 
believe
was the point that was being raised.

Bora (just catching up with my old mail)

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Monday, May 29, 2000 4:14 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: MPLS Performance analysis.....
>
>
> Sean,
>
> > Several people write:
> >
> > > [lots of commentary about how wonderful MPLS is at making
> forwarding fast]
> >
> > You are analysing the performance of MPLS using the wrong metric.
> > I think MPLS performs exactly as intended.
> > Ipsilon basically died, and not even Nokia could revive it.
> > UUNET found a new layer-2 religion, essentially killing
> backbone ATM.
> > Many companies are distracted from actually learning how to
> do IP routing.
>
> Of course, for some folks the *one and only* way to move data is by
> looking at the IP header, and executing the longest match algorithm on
> the destination address in that header (aka "destination based
> routing"). Anything else (e.g., MPLS), *regardless* of its pragmatic
> value, is viewed as "religion", "distraction", etc...
>
> Yakov.
>

---

From: Debanjan Saha <[email-masked]>
Date: Wed, 07 Jun 2000 16:21:02 -0500

> (like mpls allows). And more expensive too.

Can you quantify it -- both the cost and the complexity when you
use ternary CAMs for LPM?

-- 
Debanjan Saha                         Phone: 732-923-4264
Senior Network Architect              Fax:   732-923-9804
Tellium Optical Systems               http://www.tellium.com

---

From: Mark Stewart <[email-masked]>
Date: Wed, 07 Jun 2000 18:30:12 -0400

> If your car could get you there as quickly, do you need to build a

I believe we are flogging a dead horse with this debate.

If you ask a spaceship manufacturer the answer is "of course you do",
and if you ask a car manufacturer the answer is "of course not".

c u

Mark Stewart