Subject: RE: OAM labels (was: can egress know the ingress of a packet?)

From: Shahram Davari <[email-masked]>
Date: Wed, 7 Jun 2000 06:47:36 -0700

Theimer,

I think what Ross meant was that using PHP, when OAM label is below the
forwarding label, the egress node can't determine the LSP that the OAM
packet belongs to.

Regards,
-Shahram

>-----Original Message-----
>From: Theimer Thomas [mailto:[email-masked]]
>Sent: Wednesday, June 07, 2000 5:10 AM
>To: 'Ross Callon'
>Cc: [email-masked]
>Subject: RE: OAM labels (was: can egress know the ingress of a packet?)
>
>
>> -----Original Message-----
>> From:	Ross Callon [SMTP:[email-masked]]
>> To:	Theimer Thomas; 'Shahram Davari'; 'Peter Willis'
>> 
>> If the outer label identifies the LSP, and the inner label is a
>> special OAM value, then I think that there is a problem with
>> penultimate hop label popping.
>	[Theimer Thomas]  Good point. We missed that. However, if the
>penultimate hop removes the top label, the egress node will receive the
>packet with an OAM label on top. That would still trigger OAM 
>processing in
>the egress node, so I don't necessarily see a problem here, except that
>perhaps the egress node needs to be an LSR. If not, then in my view the
>penultimate hop is really the logical endpoint of the LSP, and should
>process the OAM label if present. However, I must admit I don't clearly
>understand how penultimate hop popping is really applied in a 
>network. I
>also could not find any explicit support in LDP, CR-LDP and 
>TE-RSVP. Without
>such support, is anyone actually using that mechanism in practice ?
>
>	Thomas
>
>

---

From: "Darek Skalecki" <[email-masked]>
Date: Wed, 07 Jun 2000 10:09:37 -0400

Hi,

I was wondering if there ever was a proposal/discussion related to  carring
unreserved bandwidth per QoS/CoS in addition to priority (setup/holding).
It seems the current TE extensions to OSPF and ISIS for MPLS only allow
unreserved bandwidth to be specified for each of 8 priority levels. In
order to carry services like PNNI over MPLS it would be necesary to
advertise to PNNI bandwidth availability per QoS/CoS.

Thanks in advance,

Darek

---

From: "Indra.Widjaja" <[email-masked]>
Date: Wed, 07 Jun 2000 13:40:46 -0400

Shahram:
I still don't understand what the problem really is.
The penultimate LSR forwards the packet to the egress LSR
based on the user data label that was just popped out.
When the packet with the OAM label arrives at the egress
LSR, the egress LSR should be able to direct the OAM
packet to the proper OAM handler.
Does this work?
indra