Subject: New MPLS implementation for Linux

From: Keir Fraser <[email-masked]>
Date: Sat, 17 Jun 2000 16:07:49 +0100

This is just to announce that I have released a new implementation of
MPLS for Linux 2.3. Note that this is NOT related to the existing
implementation by Jim Leu at University of Wisconsin.

It can be found at: 
http://www.cl.cam.ac.uk/Research/SRG/netos/netx/code/mpls-current.tar.gz

Advantages of the new implementation
------------------------------------
 * The Linux traffic classification architecture can be used to
   implement differentiated forwarding for different LSPs. This is
   documented further in the distribution.

 * We use the existing Linux routing code to map packets to LSPs. This
   can allow greater flexibility in specifying FECs than just destination
   subnet. 

 * The switching code is implemented quite efficiently and hooks
   cleanly into the Linux networking architecture. This was a _big_
   weakness in early versions of the Wisconsin implementation, which
   prompted me to write my own version in the first place. (However,
   new versions appear to have been massively reworked: this may not
   be a problem any more).

 * The whole thing is written cleanly and could be extended quite
   easily (I think! :-)

Disadvantages
-------------
 * This isn't an LDP implementation. All we needed for our own work
   was the switching plane.

 * No label pushing/popping. 

 * Only support for IPv4 tunnelling at present (more could be added
   quite easily).

 * I only supply a patch for linux 2.3.99-pre5. However, porting to
   other recent versions of the kernel shouldn't be a big task.

Feel free to contact me if you have any questions or problems!

 -- Keir Fraser 
    (Systems Research Group, University of Cambridge)

---

From: "Dmitri Krioukov" <[email-masked]>
Date: Mon, 19 Jun 2000 19:20:30 -0400

have you tried to work with the zebra
group? they already have ldp in place.
i don't think they have hierarchical
tunnels.
--
dima.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Keir
> Fraser
> Sent: Saturday, June 17, 2000 11:08 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: New MPLS implementation for Linux
> 
>

---

From: "Hideo Ishii" <[email-masked]>
Date: Tue, 20 Jun 2000 14:35:33 +0900

Zebra doesn't have LDP function yet, as far as I know.
But zebra will be implemented LDP, I guess.:-)

--
Hideo Ishii
Global One Japan

---

From: "Dmitri Krioukov" <[email-masked]>
Date: Tue, 20 Jun 2000 13:14:46 -0400

i based my statement on phrase "we have the ldp that works"
in http://tania.be.linux.org/zebra/msg00835.html, but
now i know that they were looking at the wisconsin code
reuse and later on the decision was made to implement
ldp independently (which is not done yet).

thanks,
--
dima.

> From: Hideo Ishii [mailto:[email-masked]]
> Sent: Tuesday, June 20, 2000 1:36 AM
> To: Dmitri Krioukov
> Cc: [email-masked]
> Subject: RE: New MPLS implementation for Linux
>
>

---

From: "Hideo Ishii" <[email-masked]>
Date: Wed, 21 Jun 2000 13:57:28 +0900

I talked with zebra's developer about LDP implementation before.
but I am not sure about what's going on now.
Anyway, a start,our requirement for zebra is MPLS BGP-RR, in terms of zebra
will be able to handle the Huge Routing table with RD by many CE-PE routing 
instance.

Regards,
Hideo

---
Hideo Ishii
IP Engineering , GlobalOne Japan
---