Subject: RE: Hierarchical Tunnel Establishment in RSVP-TE

From: Shahram Davari <[email-masked]>
Date: Mon, 12 Jun 2000 13:22:16 -0700

Toni,

The Encaps-draft says that the IPV4/6 Explicit Null Labels are only legal if
they are the sole label stack entry. However, in your example the RSVP
messages will have two labels, the outer label and the IPV4/6 Explicit Null
Label. Isn't this a violation of the Encaps-draft requirement?

Regards,
-Shahram

>-----Original Message-----
>From: Tony Li [mailto:[email-masked]]
>Sent: Monday, June 12, 2000 1:22 PM
>To: [email-masked]
>Cc: Tony Li; Bora Akyol; [email-masked]'
>Subject: Re: Hierarchical Tunnel Establishment in RSVP-TE 
>
>
>
>Curtis,
>
> | If the outer tunnel is constrained (by configuration) to accept only
> | inner tunnels with one L3PID, then that L3PID can be placed on the
> | outer tunnel.  If there are optimization possible for a particular
> | L3PID (IP src/dst hash to split loading along the way comes to mind
> | for IPv4) then putting the inner L3PID on the outer tunnel has
> | advantages.
>
>
>I agree that this is also possible for implementations that 
>want to parse
>up the label stack.
>
>
> | No where have I seen a requirement to put a null label on traffic
> | destined to the egress LSR.
>
>
>The requirement exists if you take the more general approach 
>of specifying
>an outer L3PID of MPLS and then wish to tunnel (otherwise 
>unlabeled) RSVP.
>Under the approach that you've proposed, this would not be necessary.
>
>Tony
>

---

From: Eric Rosen <[email-masked]>
Date: Tue, 13 Jun 2000 13:24:08 -0400

Shahram> The Encaps-draft says that the IPV4/6 Explicit Null Labels are only
Shahram> legal if they are the sole label stack entry.

It does say that, but I think that is just a mistake.  This restriction will
be removed in the next draft.