Subject: RE: Ingress LER in LDP

From: Eric Gray <[email-masked]>
Date: Tue, 6 Jun 2000 08:43:38 -0700

Chris,

	Please read the draft:

    http://www.ietf.org/internet-drafts/draft-ietf-mpls-label-encaps-07.txt

I'm not sure where you got the quote below (I seem to
be getting mail messages from the MPLS mailing list 
in some sort of random ordering), but it is incorrect
- the numbers given are not ether types...

--
Eric Gray

> -----Original Message-----
> From: Chris LaVallee [mailto:[email-masked]]
> Sent: Friday, June 02, 2000 4:29 PM
> To: [email-masked]; David Wang
> Cc: [email-masked]
> Subject: RE: Ingress LER in LDP
> 
> 
> > -POS the ether type will be 0x8847 or 0x8848 (as oppsed to 
> 0x0800 for IP)
> 
> This might be off topic, but...
> 
> How do you get an ethertype over POS ? 
> I'm guessing it's Cisco-HDLC (which I know nothing about)
> 
> PPP over POS has 2 other possibilities to carry MPLS
> - Add a new CP (control proto) for MPLS
> - Have BCP (PPP Bridging) carry MPLS
> 
> Anyone have a preference / opinion on what people should use ?
> 
> Chris
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of James R.
> > Leu
> > Sent: Friday, June 02, 2000 11:43 AM
> > To: David Wang
> > Cc: [email-masked]
> > Subject: Re: Ingress LER in LDP
> > 
> > 
> > On Fri, Jun 02, 2000 at 01:20:33PM -0500, David Wang wrote:
> > > One related question: How a LSR distinguishes a labeled 
> packet from an
> > > unlabeled packet? 
> > 
> > Depends on the medium:
> > -ATM the VCC will contain a protcol type (AAL5Null requires this)
> > -POS the ether type will be 0x8847 or 0x8848 (as oppsed to 
> 0x0800 for IP)
> > -PPP has some PIDs assigned for MPLS as well (as does IP)
> > 
> > Hope this helps.
> > 
> > Jim
> > 
> > > 
> > > -----Original Message-----
> > > From: Eric Rosen [mailto:[email-masked]]
> > > Sent: Thursday, June 01, 2000 9:28 AM
> > > To: Santosh Gupta
> > > Cc: [email-masked]
> > > Subject: Re: Ingress LER in LDP 
> > > 
> > > 
> > > Santosh> Can someone tell me how to decide if a router is 
> > supposed to act as
> > > Santosh> an Ingress LER for some particular FEC in MPLS domain ?
> > > 
> > > People keep asking  this question, and I'm never quite sure  
> > just what it is
> > > they are asking, because there isn't much of a mystery here.
> > > 
> > > If a router received an unlabeled  packet which belongs to a 
> > particular FEC,
> > > and the next hop for that packet supports MPLS, and the router 
> > is configured
> > > such that it is allowed to do allow label imposition for 
> > packets in that FEC
> > > with that next hop, then the router should impose the label 
> > assigned to that
> > > FEC by that next hop.
> > > 
> > > Does that answer your question? 
> > 
> > -- 
> > James R. Leu
> > 
>

---

From: David Charlap <[email-masked]>
Date: Tue, 06 Jun 2000 12:05:06 -0400

Eric Gray wrote:
> I'm not sure where you got the quote below (I seem to be getting mail
> messages from the MPLS mailing list in some sort of random ordering),
> but it is incorrect - the numbers given are not ether types...

I just read it and it says the same thing Chris quoted.  Section 5:

    5. Transporting Labeled Packets over LAN Media

	Exactly one labeled packet is carried in each frame.

	The label stack entries immediately precede the network layer
	header, and follow any data link layer headers, including, e.g.,
	any 802.1Q headers that may exist.

	The ethertype value 8847 hex is used to indicate that a frame is
	carrying an MPLS unicast packet.

	The ethertype value 8848 hex is used to indicate that a frame is
	carrying an MPLS multicast packet.

	These ethertype values can be used with either the ethernet
	encapsulation or the 802.3 LLC/SNAP encapsulation to carry
	labeled packets.  The procedure for choosing which of these two
	encapsulations to use is beyond the scope of this document.

(I do note, however, that the draft doesn't specifically say anything
about POS.  It just says what I quoted above.)

-- David

---

From: "Chris LaVallee" <[email-masked]>
Date: Tue, 6 Jun 2000 09:35:11 -0700

I was already aware of the MPLSCP in the draft, so what I really meant to
ask was this:

1) Cisco-HDLC uses ethertypes, right ? Therefore MPLS will treat
POS/Cisco-HDLC as Ethernet.

2) Is there really a benefit to PPP-MPLSCP ?
Meaning, you could just use Cisco-HDLC or PPP-BCP. MPLSCP doesn't negotiate
anything.

I guess you do save a few bytes with PPP-MPLS data and if you're only MPLS
switching PPP to PPP, nothing has to be add/deleted or modified in the
packet.

Chris

> From: Eric Gray [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 8:44 AM
> To: 'Chris LaVallee'; [email-masked]; David Wang
> Cc: [email-masked]