Subject: RE: OAM labels (was: can egress know the ingress of a packet?)

From: Shahram Davari <[email-masked]>
Date: Mon, 5 Jun 2000 08:49:48 -0700

Peter,

But we can use two labels. The top label can be the reserved one, and the
second label can be the actual label, which is used for forwarding the OAM
packet. This is basically similar to the Router Alert Label = 1.

Regards,
-Shahram  

>-----Original Message-----
>From: Peter Willis [mailto:[email-masked]]
>Sent: Monday, June 05, 2000 11:37 AM
>To: [email-masked]
>Subject: RE: OAM labels (was: can egress know the ingress of a packet?)
>
>
>
>An LSR will be terminating many LSPs so will be terminating 
>many OAM flows. 
>How do you correctly diagnose LSPs with merged or corrupted 
>labels if they all 
>arrive on the same reserved label? The label the OAM flow 
>arrives on has to 
>match exactly the label used for the data (user plane) flow in 
>order to be able
>to detect faults caused by LSRs using broken label swapping tables.
>
>So we need a bit somewhere in the MPLS header to identify an 
>OAM payload but 
>we need to keep the same label as used for the user plane data.
>
>Peter.
>
>

---

From: Peter Willis <[email-masked]>
Date: Mon, 05 Jun 2000 17:27:01 +0100

Shahram,

 Wouldn't it be better to have the top label
as the one that is used for forwarding the OAM & user data and the second 
label the one that identifies an OAM flow within a particular LSP? This way 
the OAM
data gets treated exactly the same as the user data by the non-edge LSRs.
Obviously the problem with this approach is that the terminating LSR does not
know it has an OAM packet until it has popped the outer label; this may cause
implementation problems (Does it?).

If the OAM data is treated differently from the user data then any faults in
the user data plane may not be detected correctly. The trouble with the
Route Alert Label =1 type approach is that it is effectively out-of-band;
LSRs will treat this differently from user data which is not what we want.

Peter.

---

From: "Indra.Widjaja" <[email-masked]>
Date: Mon, 05 Jun 2000 13:50:56 -0400

Peter:
I agree that OAM packets should not be forced to always
take the out-of-band path as in router alert.
In some PM applications (e.g., end-to-end transfer delay),
one may want to have OAM packets to be treated the same
way as data packets end-to-end.
indra