Subject: RE: Additional Index for TE-MIB: mplsTunnelTable

From: Adrian Farrel <[email-masked]>
Date: Mon, 19 Jun 2000 16:48:02 +0100

Sorry Tom.
 
I'd rather like to hang on to the direction field.  It proves very useful
for bi-directional tunnels!
 
What is more, when Lambda Switching extends its tentacles into the TE MIB
this field will definitely need to be re-instated.
 
Did you have a particular reason why you consider it no longer appropriate
to consider bi-directional tunnels?
 
Cheers,
Adrian

--
Adrian Farrel  mailto:[email-masked] <mailto:[email-masked]> 
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/ <http://www.datcon.co.uk/> 
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Monday, June 19, 2000 1:59 PM
To: [email-masked]
Cc: arun Viswanathan; cheenu Srinivasan
Subject: Re: Additional Index for TE-MIB: mplsTunnelTable

        Hi,

        Responses are highlighted in blue.

It is not clear to me how to represent a bi-directional tunnel with the MIB.
Some of my confusion may come from the fact that I don't understand the
mplsTunnelDirection object. For example, what does it mean to have this
object
set to "bi-directional"? Does it mean that this row refers to a
bi-directional
tunnel? Does the TunnelDirection (in, out) have any significance at the
tunnel
midpoint? What role does the cookie (or the lack of one!) play in
bi-directional tunnels?

        We will remove this object since it is a vestage from the
time when we had bi-directional tunnels in mind (this will be
removed along with the cookie objects). This will instead be replaced
by an object which indicates whether the LSR is a tunnel src, dst, or
intermediate point.

        --Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 22 Jun 2000 14:20:46 -0400

Hi,

>to consider bi-directional tunnels?

         There is nothing in the standard documents which
defines what bidirectional tunnels are. The standard MIB cannot
model non-standard objects.

         --Tom

>
>Cheers,
>Adrian
>
>--
>Adrian Farrel  <mailto:[email-masked]>mailto:[email-masked]
><http://www.datcon.co.uk/>http://www.datcon.co.uk/