Subject: RE: Address Message in LDP

From: Eric Gray <[email-masked]>
Date: Tue, 6 Jun 2000 09:32:03 -0700

Santosh/Surekha(?)

	Which is it? :-)

	To add to what Bob has said, one of your base
assumptions is not necessarily correct.  Two LSR peers
may be connected by more than one link.  Additional 
interface addresses may be assigned to any interface
of a router.  Also, an LSR that shares more than one
link with a peer LSR will most likely use its router
ID as its LDP ID (address portion) in order to avoid
losing its LDP session as a result of removing the
interface (from which it got the IP address) from
service (i.e. - pulling out the interface card, or
executing a "shut" command).  In any of these cases,
it is some advantage to know additional addresses
that apply to peer LSRs.

--
Eric Gray

> -----Original Message-----
> From: Bob Thomas [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 7:08 AM
> To: Surekha Gupta
> Cc: [email-masked]
> Subject: Re: Address Message in LDP 
> 
> 
> Santosh,
> 
> > Hello Bob
> >     I have gone thru the section but still have a doubt. 
> Even in DownStream
> > unsolicited Mode of label distribution, according to the 
> draft each LSR
> > keeps a list of address prefix and their associated  (LDP 
> Identifier, label)
> > 
> > LDP Identifier = Interface IP Address : Label Space.
> 
> There is no guarantee/requirement that the first 4 octects of the
> LDP Id is the IP address of the "Interface".
> 
> 
> > Actually the Next hop address in the routing table will 
> exactly match the
> > "Interface IP Address" specified in the LDP Identifier. 
> This "Interface IP
> 
> I think you cannot guarantee that this is always true.
> 
> 
> > Address" is the one directly connected to the peer.
> > This is depicted below.
> > 
> >                                             C
> >                                       /
> >                                 A   -----  | B |
> >                                       \
> >                                             D
> > 
> > If B,C,D are directly connected to A then the "Interface IP 
> Address" that
> > will be specified in the Address Message will be the same 
> as the Interface
> > which A concludes from the HELLO message exchange. So what 
> is the need for a
> > seperate "Address Message" altogether ?
> 
> Please see comments above.
> 
> 
> Bob
> 
> 
> > One more thing, what is the use of specifying some other 
> "Interace IP
> > Address" to A by B (say the interface of B with C ) if that 
> is not the
> > directly connected interface to A?
> > 
> > 
> > > Santosh,
> > >
> > > >     In draft-ietf-mpls-ldp-06.txt, there is an Address 
> Message and =
> > > > Address Withdraw Message. I am not able to figure out 
> what purpose does
> > =
> > > > it serve. In the Hello packet that an LSR sends, it can 
> send the =
> > > > Interface IP Address optionally. If it doesnt send then 
> the receiving =
> > > > LSR can make out when it receives from the particular 
> socket. And what =
> > > > do we gain if an LSR advertizes IP Addresses of other 
> interfaces also ?
> > =
> > > > The connection between 2 LSRs is anyway thru some 
> particular interface =
> > > > and knowing the IP Address of other interfaces will be 
> of no use.
> > >
> > > See Section "LDP Identifiers and Next Hop Addresses".
> > >
> > > Bob
> > >
> > 
> > 
> 
>

---

From: "Santosh Gupta" <[email-masked]>
Date: Wed, 7 Jun 2000 09:42:24 +0530

Hi Eric
    Sorry for the goofup in name. It's actually Santosh. :)
Please c comments inline.

santosh
> may be connected by more than one link.  Additional

fine

> ID as its LDP ID (address portion) in order to avoid

I cant make out what do you mean by router ID. If a router has "n" cards
then it will have "n" IP Addresses corresponding to each card. Where is this
concept of router ID? Or is it the Internal representation (some no.
assigned ) at an LSR for the peer that you are refering to ?

---

From: David Charlap <[email-masked]>
Date: Wed, 07 Jun 2000 09:19:38 -0400

Santosh Gupta wrote:
>> 
>> interface addresses may be assigned to any interface of a router.
>> Also, an LSR that shares more than one link with a peer LSR will most
>> likely use its router ID as its LDP ID (address portion) in order to
>> avoid
> 
> I cant make out what do you mean by router ID. If a router has "n"
> cards then it will have "n" IP Addresses corresponding to each card.
> Where is this concept of router ID? Or is it the Internal
> representation (some no. assigned ) at an LSR for the peer that you
> are refering to ?

Not necessarily.  There is a concept of an "unnumbered link", where a
port does not have its own address.

With many routing protocols, unnumbered links may be used for routing,
as long as there's a way to uniquely identify each router.  this is the
"router ID".  The router ID may be administratively assigned or it may
be dynamically assigned (eg. by choosing one address from those in use
by local ports that have IP addresses).

From the standpoint of a routing/forwarding table, a next-hop address of
a router ID address means "any port on that switch, I don't care
which.".

-- David