Subject: RE: Ingress LER in LDP

From: David Wang <[email-masked]>
Date: Fri, 2 Jun 2000 13:20:33 -0500

One related question: How a LSR distinguishes a labeled packet from an
unlabeled packet? 

-----Original Message-----
From: Eric Rosen [mailto:[email-masked]]
Sent: Thursday, June 01, 2000 9:28 AM
To: Santosh Gupta
Cc: [email-masked]
Subject: Re: Ingress LER in LDP 

Santosh> Can someone tell me how to decide if a router is supposed to act as
Santosh> an Ingress LER for some particular FEC in MPLS domain ?

People keep asking  this question, and I'm never quite sure  just what it is
they are asking, because there isn't much of a mystery here.

If a router received an unlabeled  packet which belongs to a particular FEC,
and the next hop for that packet supports MPLS, and the router is configured
such that it is allowed to do allow label imposition for packets in that FEC
with that next hop, then the router should impose the label assigned to that
FEC by that next hop.

Does that answer your question?

---

From: "James R. Leu" <[email-masked]>
Date: Fri, 2 Jun 2000 13:43:11 -0500

> One related question: How a LSR distinguishes a labeled packet from an

Depends on the medium:
-ATM the VCC will contain a protcol type (AAL5Null requires this)
-POS the ether type will be 0x8847 or 0x8848 (as oppsed to 0x0800 for IP)
-PPP has some PIDs assigned for MPLS as well (as does IP)

Hope this helps.

Jim

-- 
James R. Leu

---

From: "Chris LaVallee" <[email-masked]>
Date: Fri, 2 Jun 2000 16:29:09 -0700

> -POS the ether type will be 0x8847 or 0x8848 (as oppsed to 0x0800 for IP)

This might be off topic, but...

How do you get an ethertype over POS ? 
I'm guessing it's Cisco-HDLC (which I know nothing about)

PPP over POS has 2 other possibilities to carry MPLS
- Add a new CP (control proto) for MPLS
- Have BCP (PPP Bridging) carry MPLS

Anyone have a preference / opinion on what people should use ?

Chris

> From: [email-masked] [mailto:[email-masked]]On Behalf Of James R.
> Leu
> Sent: Friday, June 02, 2000 11:43 AM
> To: David Wang
> Cc: [email-masked]