Subject: non-RSVP router and LRO

From: [email-masked]
Date: Fri, 14 Jul 2000 11:37:42 -0400

I have a question for the non-RSVP router and LRO from draft-mpls-rsvp-lsp-tunnel-06.txt.

it says "RSVP is designed to cope gracefully with non-RSVP routers anywhere
   between senders and receivers. However, obviously, non-RSVP routers
   cannot convey labels via RSVP. This means that if a router has a
   neighbor that is known to not be RSVP capable, the router MUST NOT
   advertise the LABEL_REQUEST object when sending messages that pass
   through the non-RSVP routers.  The router SHOULD send a PathErr back
   to the sender, with the error code "Routing problem" and the error
   value "MPLS being negotiated, but a non-RSVP capable router stands in
   the path." 

In my understanding, the upstream node should know the nhop is a non-rsvp router. Then it will stop sending the Path message with LRO and send back the sender a PathErr message.

If it is correct, how the upstream node knows the nhop is non-RSVP?

If it is not correct, then the router should know the existing of non-rsvp after receiving the phop's path message if one of phops is non-rsvp. Then the router will send back the PathErr message to the sender. Can the non-RSVP router pass the LRO and Path message?

Another question is where I can find the list of error code(not value) like "Routing Problem", etc.

Thanks

Regards,
Ted

----------
Get your own FREE, personal Netscape Webmail account today at http://home.netscape.com/webmail/

---

From: Arthi Ayyangar <[email-masked]>
Date: Fri, 14 Jul 2000 13:37:04 -0400 (EDT)

A non-RSVP router will simply propagate RSVP messages w.o processing them.
(ref. RFC 2205)
So when a downstream RSVP-capable router receives a Path msg. from this
router containing LRO, it detects the presence of a non-RSVP router
upstream (from TTL values) and sends a PathErr message upstream. When this
reaches the RSVP-capable upstream router, it knows that it's next-hop is a
non-RSVP router. So, henceforth it sends PathErr back to the sender if it
receives a Path msg. with LRO directed towards that next-hop.

-arthi