Subject: RE: IP header compression (was "process")

From: Eric Gray <[email-masked]>
Date: Thu, 20 Jul 2000 10:05:55 -0700

Lou,

	I did, as you well know - since you were
copied. :-)

	You are the one who is making statements 
on the list that are inconsistent with public
information.  I am simply trying to correct your
assertion - to the same audience, of course.

--
Eric Gray

> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]]
> Sent: Thursday, July 20, 2000 9:48 AM
> To: Eric Gray
> Cc: 'Lou Berger'; [email-masked]; George Swallow (E-mail); 'Vijay
> Srinivasan'; MPLS Mailing List (E-mail)
> Subject: RE: IP header compression (was "process") 
> 
> 
> Eric,
>          Your message&issue seem to be procedural.  WG 
> procedure is an 
> issue for the chairs, not me.  I suggest you take the issue 
> up with them.
> 
> Lou
> 
> At 09:36 AM 7/20/00 -0700, Eric Gray wrote:
> >Lou,
> >
> >         I'm not going to let this one slip by.
> >
> >         The minutes say that "we" (those who were
> >able to make it to Adelaide) reached a consensus
> >that MPLS header compression is an appropriate
> >work item for the working group.  Quoting:
> >
> >"Vijay wanted to gauge the reaction of the MPLS
> >  WG on the header compression work, i.e., whether
> >  it is an appropriate work item for the group.
> >  The upshot was that there was consensus to
> >  perform work in that area."
> >
> >This is not the same thing as asking if there is
> >consensus to adopt your draft as a working group
> >draft (and getting it).
> >
> >         If you thought the consensus was rather more
> >than that, you should have said something when the
> >minutes came out. :-)  Much better to have done it
> >that way than by trying to assert otherwise now.
> >
> >--
> >Eric Gray
> >
> > > -----Original Message-----
> > > From: Lou Berger [mailto:[email-masked]]
> > > Sent: Thursday, July 20, 2000 8:18 AM
> > > To: [email-masked]
> > > Cc: Robert M Matheson; Lou Berger; Adrian Farrel; Eric 
> Gray; George
> > > Swallow (E-mail); 'Vijay Srinivasan'; MPLS Mailing List (E-mail)
> > > Subject: Re: IP header compression (was "process")
> > >
> > >
> > > At 10:59 AM 7/20/00 -0400, Eric Rosen wrote:
> > > >Robert> Isn't this  equivalent to saying that such  header
> > > compression would
> > > >Robert> be useful if  the use of MPLS extended into  the
> > > access network? Has
> > > >Robert> this happened  yet? Does anyone  have a view  as to
> > > whether  it will
> > > >Robert> happen?
> > > >
> > > >These days,  the edge  rarely consists of  the 9.6  kbps
> > > lines that  were so
> > > >common when IP header compression was first used.  I wonder
> > > how common it is
> > > >even  to use  IP  header compression  these  days.  I  would
> > >  still like  to
> > > >understand better the application which uses low speed links
> > > and MPLS.
> > > >
> > > >Lou> I  guess this  means we  need  to repeat  some of  the
> > > discussion  that
> > > >Lou> happened in Adelaide in Pittsburgh.
> > > >
> > > >Or on the mailing list.
> > >
> > > Fine with me, particularly since we've already reach a level
> > > of "consensus"
> > > at the last WG meeting.
> > >
> > > Lou
> > >
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 20 Jul 2000 13:12:03 -0400

>         I did, as you well know - since you were

Eric,
         Your message was directed to me (on both subject line and in body) 
and to Eric R. on subject line.  Not the chairs.  The chairs were on cc'ed.

>assertion - to the same audience, of course.

Actually, I think my statements *are* consistent with the minutes.  The 
minutes make a statement that can reasonably be interpreted to mean that 
the 3 drafts covered in the meeting were to be adopted as WG documents.  To 
me that fact that this wasn't spelled out was a matter of style, i.e. how 
much detail to include in the minutes.

Lou

---

From: Grenville Armitage <[email-masked]>
Date: Thu, 20 Jul 2000 10:51:53 -0700

#define PROCEDURAL_TANGENT

Lou Berger wrote:
	[..]
> Actually, I think my statements *are* consistent with the minutes.

It is actually more consistent to assert that if the minutes
meant *your* specific drafts were being adopted as work items,
the minutes would say so. They dont. They should have if it were
the case.

>  The
> the 3 drafts covered in the meeting were to be adopted as WG documents.

I was at the meeting, and the minutes *appear* to confirm
my hazy recollection that compression was declared interesting, but
no real decision was made to elevate anyone's documents to the
status of work item just yet. (Note I'm not making any personal
observations on whether I believe the group made the right choice...)

> To

Hmmm... if minutes are going to be stylistically re-interpreted months
down the track, instead of being corrected for precision following the
meeting, we might as well not have minutes at all.

(Chairs cc'd to indicate this is their thread too)

cheers,
gja
________________________________________________________________________
Grenville Armitage                    http://members.home.net/garmitage/
Bell Labs Research Silicon Valley

---

From: "Brijesh Kumar" <[email-masked]>
Date: Thu, 20 Jul 2000 13:54:30 -0400

Hi,

I think this discussion is going in the wrong direction.

IP header compression has definitely proved very useful, and is still
used in most wireless data devices. For instance CDPD devices use IP
header compression, and so do many other wireless (cellular) data
systems. The case for using mpls header compression is not that
straight forward due to this being a router to router mechanism,
though I do know instances where routers were placed on wireless
links. In a particular network in China, I used a VSAT 64 kbps common
channel to route IP traffic from about 60 cities. Each site had an IP
router, a few base stations and a switch. We  didn't use any dynamic
routing, and we only used static routing/bridging to simplify things,
and reduce routing protocol overhead. I am not sure if there are any
other situations which require a router to be placed on a slow
wireless link.

There are two issues: 1) understand technical mechanisms to do MPLS
header compression and 2) to justify the need of any one ever using
it. I think one can discuss the mechanisms (1) but the final decision
to proceed should only be taken after a case can be built for its real
use. If you put (2 i.e., utility) ahead of (1 i.e., mechanisms), I
think many other IDs in the IETF Internet Draft directory will also
fail to meet this criteria. I personally think we can briefly discuss
mechanisms for the time being, and freeze things after that unless the
authors of the draft can make a convincing case for its usage. Let us
have no-confrontation mid-path solution.

Cheers,

--brijesh
Ennovate Networks Inc.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Lou
> Berger
> Sent: Thursday, July 20, 2000 1:12 PM
> To: Eric Gray
> Cc: 'Lou Berger'; Eric Gray; George Swallow (E-mail); 'Vijay