Subject: Re: Policy Information Model for MPLS Traffic Engineering

From: Ritu Chadha <[email-masked]>
Date: Mon, 17 Jul 2000 15:19:42 -0400 (EDT)

Tom,

>Date: Mon, 17 Jul 2000 14:21:49 -0400
>To: Ritu Chadha <[email-masked]>, [email-masked],
>[email-masked]
>From: "Thomas D. Nadeau" <[email-masked]>
>Subject: Re: Policy Information Model for MPLS Traffic Engineering
>Cc: [email-masked]
>
>	Hi,
>
>	A few questions about your draft.
>
>	1) How does this draft differ from say the use
>		of COPS and the definition of a PIB
>		instead of using the object model?

The information model in our draft would be used to describe policies
that a PDP would implement, in accordance with the policy framework. 
The PDP could implement the policies via COPS and appropriate PIBs.
Appropriate PIBS could very well be defined based on some of the 
information presented in our model. 

>
>	2) It is not clear to me whether or not it is your
>		intent to make this object model useful
>		for both MPLS network management or just
>		only for off-line TE. It seems from reading
>		your document that your intent is to do
>		both.
>

That's correct; the intent is to be able to do both.

>	--Tom

Ritu

=============================================================================
Ritu Chadha
Senior Scientist
Telcordia Technologies 				(973) 829-4869 (voice)
MCC 1J-218R                                     (973) 829-5889 (fax)
445 South Street                                [email-masked]
Morristown NJ 07960.
=============================================================================

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 17 Jul 2000 16:23:13 -0400

Hi Ritu,

>information presented in our model.

         I disagree. This is what the PIB should be used for.
The object model you define could very well be done by
a proprietary vendor. I don't see the need or advantage
to do so in a standard way. What advantages do you see of
defining such an object model versus using say, a PIB
and COPS to define and implement policy for MPLS?

>That's correct; the intent is to be able to do both.

         In terms of device management, is it then your
assertion that the MIBs will need to be re-aligned to fit
in with your object model in order to do device-level
management? As I see it, I don't see how the MIBs as they
are defined today, fit in with your object model. If anything,
I think that the object model should be changed to reflect
that which is defined in the MIBs.

         --Tom

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 18 Jul 2000 10:08:27 +0200

Tom,

A propriatary vendor can still define its own information model, whether
it succeeds on the marcket is an other story. But that argument paly
agains many many IETF standards.

Marcus

-- 

Dr. Marcus Brunner
C&C Research Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.tik.ee.ethz.ch/~brunner

New address starting 9/1/2000
Postal Mail:
Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 905110
Fax:   +49 (0)6221/ 9051155

Address valid until 8/31/2000
Postal Mail:
Hardenbergplatz 2
D-10623 Berlin
Germany

Phone:  +49 (0)30/ 25 42 30 17
Fax:    +49 (0)30/ 25 42 30 99