Subject: Re: MPLS TE MIB - Doubts

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 06 Jul 2000 15:14:57 -0400

Hi Paul,

>     Hi Tom. I apologize. I did not mean to imply that these comments would be
>incorporated into the MIB. I was just trying to shed some light on some 
>commonly
>used terms. I choose the term "LSP tunnel" over "tunnel" based on the text in
>draft-ietf-mpls-rsvp-lsp-tunnel-05.txt.

         I think that there is still some confusion here. By "tunnel" I mean
MPLS Traffic Engineered Tunnel, nothing more, nothing less. It was
not our intent to create a generic tunnel MIB; rather, just to model
MPLS Tunnels.

>     I must say I am surprised by your 'tunnel statement' below. I thought 
> that the
>TE MIB was based on RSVP and CR-LDP (explicitly routed) LSPs. I did not 
>think of it
>as a general tunnel MIB. Don't get me wrong, I don't mean to imply that 
>this is a
>bad thing. I did not realize the scope was this broad.

         A TE Tunnel first contains the desired parameters that a
user wishes to have signaled via the MPLS signaling protocol to form an
LSP which can support said parameters. If those parameters are successfully
signaled by the MPLS signaling protocol, a corresponding LSP(s) will
have been signaled (and will appear in the LSR MIB). It is
this LSP(s) which are then pointed at by the TE Tunnel to
indicate that they are being used by the TE Tunnel.

>I guess the first comment I
>have is that the text at the front of the MIB needs to reflect this.

         Agreed. The text at the front of the MIB should be updated if
it does not state that. Can you point out where we contradict the
statements I made?

         --Tom

>             Paul
>
>"Thomas D. Nadeau" wrote:
><snip>
>
> >
> >
> > > > 3. LSP vs Tunnel vs LSP Tunnel - Yep, this stumps me also.
> > >
> > >First let's get rid of one of the terms. I think that a "tunnel" and 
> an "LSP
> > >tunnel" in the context of the TE MIB are the same things. So throw out
> > >"tunnel". It is too general.
> >
> >          No LSP Tunnel. The use of "tunnel" in the TE MIB
> > refers to the specific parameters used to describe a
> > traffic engineered tunnel which may or may not result in
> > the formation of an LSP.
> >
> >          --Tom
>
>--
>Paul Langille                e-mail: [email-masked]
>Crescent Networks            phone: (978) 244-9002 x244
>201 Riverneck Road           fax: (978) 244-9211
>Chelmsford, MA 01824

---

From: Paul Langille <[email-masked]>
Date: Thu, 06 Jul 2000 17:27:27 -0400

Hi Tom. Good, now I understand. It would probably be good to have some text at
the front of the draft that explains this and references the terms used in the RSVP
Tunnel draft and the CR-LDP draft.

    I will try to throw together some text. (I will be out of the office next week
so there will be a delay!)

                Paul