Subject: Re: Reg. MPLS-RSVP LSP Tunnels...

From: Jahaapanah Alampanah <[email-masked]>
Date: 25 Jul 00 07:48:52 PDT

Hi Jie,

If I understand Nallur's problem statement
correctly, its got to do with aggregation
of RSVP micro flows into LSP Tunnels 
setup by MPLS-RSVP.

I guess, Routers A and B are RSVP(2205 only)
aware and S and R are the end-hosts of a
microflow. Hence there's no chance of
receiving LROs in PATH messages generated
from S.

Aggregation of millions of RSVP
micro-flows has been mooted in the 
Applicability Statement draft for RSVP LSP 
Tunnels. However, I too am not sure of an
answer to this problem. Stating it in 
different words, the problem statement goes
like this:

An RSVP-LSP-Tunnel has already been established
between LER1 and LER2. Now a micro-flow RSVP
PATH message from S arrives at LER1. We want
this micro-flow to take the LSP. So if we just
tunnel this PATH message into the LSP, and 
make it reach end-host R, the problem is
how do we transport the RESV message from R
back to S through the same LSP since this
is uni-directional?

I hope Nallur agrees with this re-statement!

All comments are welcome.

-Jah

-----Original Message-----
From: Jie Zou <[email-masked]>
To: Pramoda Nallur <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked]
<[email-masked]>; Kishore Rao <kishore>;
[email-masked] <[email-masked]>
Date: Tuesday, July 25, 2000 6:49 PM
Subject: Re: Reg. MPLS-RSVP LSP Tunnels...

>
>I hope the following can answer a part of questions.
>
>According the darft, if A or B is a non-RSVP router, it can't convey
>labels via RSVP path. And it's neighber who knows it's non-RSVP 
>router should send a PathErr back to the sender.
>
>If A or B is an RSVP router but doesn't recognize the LRO, it should
>send a PathErr toward the sender.
>
>If A or B is an RSVP router and recognize the LRO but not C_TYPE also
>sends a PathErr toward the sender.
>
>Else the Path msg should pass A and B toward the receiver and 
>vice verse the Resv msg should pass the B and A toward the sender.
>
>
>Regards,
>
>-----------------------------------------------------
>Jie Zou (603)862-4212(Office)
>MPLS Consortium 
>IOL, UNH (603)868-2983(Home)
>-----------------------------------------------------
>
>On Tue, 25 Jul 2000, Pramoda Nallur wrote:
>
>> Hi,
>> 
>> I have a query on setting up RSVP MPLS LSPs in an ATM network.
>> [ Topology Driven LSP Setup Scenario ]
>> 
>> Suppose the network configuration is as follows :
>> 
>>     S--A--LER1---LSR---LER2--B--R
>> 
>> where,
>>     S                   --> Sender(RSVP aware)
>>     R                   --> Receiver(RSVP aware)
>>     A, B                --> Legacy IP Routers
>>     LER1, LER2 and LSR  --> MPLS-RSVP ATM switches.
>> 
>> An LSP setup is initiated from LER1 with FEC=(S,R).
>> 
>> The RSVP-TE PATH msg (with Sender=S, Session = Sess_R) creates an
>> RSVP Session, Sess_R at LER1, LSR and LER2. The Egress LER2 responds with
a
>> 
>> RSVP-TE RESV msg reserving resources and sets up an LSP via LSR to LER1.
>> 
>> After the LSP is setup, the RSVP-TE PATH msgs from LER1 and RSVP-TE RESV
>> msgs
>> from LER2 periodically refresh the RSVP reservation state on all nodes
>> along the LSP.
>> 
>> Suppose, Sender S sends an RSVP PATH msg to R (with Session = Sess_R).
>> 
>>  1. Will this PATH msg take the unlabelled path OR will it get switched
>> onto the LSP at LER1 ?
>> 
>>  2. Also, how are the resulting RESV msgs from R propagated back to S ?
>> 
>>  3. If these PATH and RESV msgs take the unlabelled path, will this result
>> in
>>     resource allocation again along all nodes traversed by the LSP ?
>> 
>> 
>> The "RSVP-TE: Extensions to RSVP for LSP Tunnels"
>> (draft-ietf-mpls-rsvp-lsp-tunnel-06.txt)
>> does not mention how the above should be handled.
>> 
>> Any comments on this ?
>> 
>> - Pramoda Nallur
>> 
>
>
>

____________________________________________________________________
Get your own FREE, personal Netscape WebMail account today at http://webmail.netscape.com.

---

From: Pramoda Nallur <[email-masked]>
Date: Tue, 25 Jul 2000 21:42:21 +0530

Jah,

> back to S through the same LSP since this

You are right in your understanding. But, the question is, should the micro-flow PATH message
be tunelled into the LSP at all ?

- Pramoda.