Subject: RE: draft-kompella-mpls-te-mib-00.txt

From: Adrian Farrel <[email-masked]>
Date: Mon, 24 Jul 2000 17:27:49 +0100

Hi Kireeti,

I must say that the arrival of your draft for a TE MIB worries me
conflicting as it does with the work that the WG has been pursuing for the
last couple of years.

Could you comment on what function your draft offers over and above the WG
draft?  

Are you proposing this
- in place of the WG efforts
- in parallel to the WG efforts so that we end up with a choice of MIBs
- as a way of getting your functional additions incorporated into the WG
MIBs?

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

>-----Original Message-----
>From: Kireeti Kompella [mailto:[email-masked]]
>Sent: Monday, July 17, 2000 8:36 PM
>To: [email-masked]; [email-masked]
>Cc: [email-masked]; [email-masked]; [email-masked];
>[email-masked]
>Subject: Re: draft-kompella-mpls-te-mib-00.txt
>
>
>Hi Tom,
>
>> 	I am writing to you today to ask you
>> about draft-kompella-mpls-te-mib-00.txt. Are
>> you aware that there has been an MPLS Traffic
>> Engineering MIB working group document for
>> roughly 2 years now? After giving your
>> document a quick read, it appears to
>> cover most of what is contained in the LSR
>> and TE MIBs. At this point The MPLS LSR MIB
>> has cleared WG Last Call and the TE MIB is
>> getting very close.
>
>I am aware of the TE/LSR MIBs.  I tracked them for a while.
>The MIB I submitted was *implemented* in Nov 1998, updated in
>May 1999 to add traps, and has otherwise changed very little.
>It is being used in several production networks.  I have had
>several favorable comments (and of course some requests for
>changes), and some have asked me to propose it as an ID.
>
>>	What are your intentions for this
>> new document?
>
>I have submitted it to the Traffic Engineering WG.
>
>Kireeti.
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 24 Jul 2000 21:09:00 -0400

Randy,

>as far as i can tell, simplicity while retaining the useful function.  and i
>am a big simplicity fan.

         I am personally a fan of not reinventing the wheel. As far
as I can tell, this new draft really just duplicates at best, a
subset of the efforts that the MPLS WG has been making on its
own TE/LSR drafts for the past 2 years. In fact, the MPLS
WG has recently come to a consensus to close the MPLS-LSR-MIB
draft and bring it to the IESG.

         The MPLS-TE-MIB is still under development in the MPLS
WG and we welcome input on its continued progress.

         --Tom

---

From: Randy Bush <[email-masked]>
Date: Mon, 24 Jul 2000 17:26:13 -0700

and perhaps, as this is a te mib, the tewg, which is in o&M should be the
forum to bash it?

randy