Subject: RE: <FF flow descriptor list> in rsvp-lsp-tunnel-06 draft

From: "Arvind, K" <[email-masked]>
Date: Wed, 12 Jul 2000 11:35:10 -0400

Markus:

I had assumed that the <FLOWSPEC> object is mandatory in each flow
descriptor, which is not quite what RFC2205 says. According to RFC 2205, "A
Flowspec object can be omitted if it is identical to the most recent such
object that appeared in the list; the first FF flow descriptor must contain
a FLOWSPEC". The syntax rules that you have adapted from 2205 does seem to
capture the above rules. Thanks.

  Regards,
  Arvind.

> -----Original Message-----
> From:	Markus Jork [SMTP:[email-masked]]
> Sent:	Wednesday, July 12, 2000 11:28 AM
> To:	Arvind, K
> Cc:	[email-masked]
> Subject:	Re: <FF flow descriptor list> in rsvp-lsp-tunnel-06 draft 
> 
> Arvind,
> 
> > Wouldn't the following be the proper BNF?:
> >
> > <FF flow descriptor list> ::= <FF flow descriptor> |
> >                               <FF flow descriptor list> <FF flow
> descriptor>
> >
> > <FF flow descriptor> ::= <FLOWSPEC> <FILTER_SPEC> <LABEL>
> [<RECORD_ROUTE>]
> >
> > This makes the <FLOWSPEC> mandatory in each flow descriptor, but doesn;t
> > allow the <FLOWSPEC> object to
> > be repeated.
> 
> your suggestion also doesn't capture the syntax rules correctly.
> This should do the trick (RFC 2205 does it the same way):
> 
> <FF flow descriptor list> ::= <FLOWSPEC> <FILTER_SPEC>
>                               <LABEL> [<RECORD_ROUTE>] |
>                               <FF flow descriptor list> <FF flow
> descriptor>
> 
> <FF flow descriptor> ::= [<FLOWSPEC>] <FILTER_SPEC> <LABEL>
> [<RECORD_ROUTE>]
> 
> Markus
> 
>

---

From: "Arvind, K" <[email-masked]>
Date: Wed, 12 Jul 2000 12:01:40 -0400

George:

  I think the BNF as proposed in the draft is likely to cause confusion
about what was intended by the authors. The rules that Markus adapted from
RFC2205 will make the intent unambiguously clear. I think the correction
proposed by Markus should be used in the draft.

  Regards,
  Arvind

> From:	George Swallow [SMTP:[email-masked]]
> Sent:	Wednesday, July 12, 2000 11:50 AM
> To:	Arvind, K
> Cc:	[email-masked]; [email-masked]
> Arvind -
> As you seem to have noticed, the change was made to point out that
> while the FLOWSPEC isn't required in every flow descriptor, it is
> required in the first one.  This is also true of RFC2205.  I don't
> think we should be changing that just to make the BNF easy.  If folks
> believe that coders *really* are likely to put in multiple flowspecs
> based on this I can add a note.  But I personally think it's overkill.
> 
> ...George
> 
> ps. glad to see you're giving it a close read.  I'm about to post a
> marked up copy to make it easier.
> 
> 
> ==================================================================
> George Swallow       Cisco Systems                   (978) 244-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824