Subject: mplsTunnelResourceTable in TE MIB

From: Namita Sinha <[email-masked]>
Date: Wed, 12 Jul 2000 15:41:05 -0400 (EDT)

Could someone clarify the semantics of the
mplsTunnelResourceIn{MaxRate,MeanRate,MaxBurstSize}
vs. the semantics of the
mplsTunnelResourceOut{MaxRate,MeanRate,MaxBurstSize}
in the mplsTunnelResourceTable?

Thanks
Namita Sinha

-----------------------------------------------
FREE! The World's Best Email Address @email.com
Reserve your name now at http://www.email.com

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 12 Jul 2000 16:04:02 -0400

Namita,

>in the mplsTunnelResourceTable?

         The description in the MIB indicates that
they contain resources required for the tunnel.
If two tunnels point at the same resources, this
indicates sharing (though does not require it).
The reason why there are in/out parameters is
because some folks apparently felt that it was
necessary or useful to specify these
parameters/resources for both data sent and
received on the tunnel.

6.2.  mplsTunnelResourceTable

    mplsTunnelResourceTable is used to indicate the resources
    required for a tunnel. Multiple tunnels may share the
    same resource by pointing to the same entry in this
    table. Tunnel that do not share resource must point to
    separate entries in this table.

         --Tom

---

From: David Charlap <[email-masked]>
Date: Wed, 12 Jul 2000 16:34:47 -0400

"Thomas D. Nadeau" wrote:
> The description in the MIB indicates that they contain resources
> required for the tunnel.  If two tunnels point at the same resources,
> this indicates sharing (though does not require it).  The reason why
> there are in/out parameters is because some folks apparently felt that
> it was necessary or useful to specify these parameters/resources for
> both data sent and received on the tunnel.

It seems to me that this is also a placeholder for some future revision,
where multicasting is supported.

In a multicast environment, incoming resource requests must be merged
with each other in order to determine the correct resources to request
of the previous hop router.  When this is happening the inbound
resources may not match the outbound resources

-- David