Subject: <FF flow descriptor list> in rsvp-lsp-tunnel-06 draft

From: "Arvind, K" <[email-masked]>
Date: Wed, 12 Jul 2000 11:04:52 -0400

According to the latest version of the draft:

<FF flow descriptor list> ::= <FLOWSPEC> <FF flow descriptor> |
                                         <FF flow descriptor list> <FF flow
descriptor>
<FF flow descriptor> ::= [<FLOWSPEC>] <FILTER_SPEC> <LABEL> [<RECORD_ROUTE>]

This allows a flow descriptor list of the form:
    <FLOWSPEC><FLOWSPEC><FILTER_SPEC><LABEL>[<RECORD_ROUTE>]
to be valid, i.e. the <FLOWSPEC> object can appear twice.

Wouldn't the following be the proper BNF?:

<FF flow descriptor list> ::= <FF flow descriptor> |
                                         <FF flow descriptor list> <FF flow
descriptor>
<FF flow descriptor> ::= <FLOWSPEC> <FILTER_SPEC> <LABEL> [<RECORD_ROUTE>]

This makes the <FLOWSPEC> mandatory in each flow descriptor, but doesn;t
allow the <FLOWSPEC> object to
be repeated.

Regards,
Arvind.

K. Arvind, Ph.D.
Founding Engineer
TENOR Networks, Inc.
100, Nagog Park, Acton, MA 01720
W: 978-264-4900 x124
F: 978-264-0671
E: mailto:[email-masked]
U: http://www.tenornetworks.com

> -----Original Message-----
> From:	Markus Jork [SMTP:[email-masked]]
> Sent:	Wednesday, July 12, 2000 10:52 AM
> To:	[email-masked]
> Subject:	TIME_VALUES in new RSVP-TE draft
> 
> in draft-ietf-mpls-rsvp-lsp-tunnel-06.txt:
> The TIME_VALUES object in the Path and Resv message
> has now been made optional. Why is that?
> It's not optional in RFC 2205 for a good reason: it is
> needed to compute the timeout value for the path/reservation
> state.
> 
> Markus
> 
>

---

From: Markus Jork <[email-masked]>
Date: Wed, 12 Jul 2000 11:27:40 -0400

Arvind,

>                               <FF flow descriptor list> <FF flow descriptor>
>

your suggestion also doesn't capture the syntax rules correctly.
This should do the trick (RFC 2205 does it the same way):

<FF flow descriptor list> ::= <FLOWSPEC> <FILTER_SPEC>
                              <LABEL> [<RECORD_ROUTE>] |
                              <FF flow descriptor list> <FF flow descriptor>

Markus

---

From: George Swallow <[email-masked]>
Date: Wed, 12 Jul 2000 11:50:12 -0400

Arvind -

As you seem to have noticed, the change was made to point out that
while the FLOWSPEC isn't required in every flow descriptor, it is
required in the first one.  This is also true of RFC2205.  I don't
think we should be changing that just to make the BNF easy.  If folks
believe that coders *really* are likely to put in multiple flowspecs
based on this I can add a note.  But I personally think it's overkill.

...George

ps. glad to see you're giving it a close read.  I'm about to post a
marked up copy to make it easier.

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824

---

From: George Swallow <[email-masked]>
Date: Wed, 12 Jul 2000 12:34:05 -0400

> <FF flow descriptor> ::= [<FLOWSPEC>] <FILTER_SPEC> <LABEL> [<RECORD_ROUTE>]

This I can go with.

...George