Subject: Re: your mail

From: Chatur sharp <[email-masked]>
Date: Wed, 19 Jul 2000 06:51:50 -0700 (PDT)

Hi folks,

I have a very simple querry.

Consider the scenerio given below

          L1       L2
    LSR1 ---- LSR2----LSR3

The LSR1 and LSR3 are the ingress and egress
respectively for an LSP for FEC F. 

Now when LSR1 gets an unlabelled packet, such that 
it maps to FEC F then it will label the packet with
a label L1 and forward it LSR2 who will in turn
forward it to LSR3 with label L2. (LSR2 will swap L1
with L2)

Now should will LSR3 do an LPM to determine the
interface through which it must forward the packet ?

Can it be avoided by choosing appropriate label L2 ?

In general, is it always necassary to do LPM at
the egress LSR. ( Assuming no PHP ) ? Put differently
at the end of a LSP, what is generally done - LPM,
or a direct forwarding based on the incoming label.

Is there any other forum where I can ask this 
question.

thanks
C.

=====
I am willing to learn,  if you care to teach.
I am willing to teach, if you care to learn.

__________________________________________________
Do You Yahoo!?
Get Yahoo! Mail – Free email you can access from anywhere!
http://mail.yahoo.com/

---

From: "James R. Leu" <[email-masked]>
Date: Wed, 19 Jul 2000 10:09:29 -0400

Comment below:

> Is there any other forum where I can ask this 

Being that LSR3 allocated the label L2 it can attach whatever
meaning it wants to L2.  It all depends on the qualities of the FEC F,
the granularity of the label allocation scheme, and how these are tied
together in the forwarding plan.

Jim
-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]

---

From: "G.B.Naidu" <[email-masked]>
Date: Thu, 20 Jul 2000 11:00:35 +0530 (IST)

Hey,

What is this LPM Chatur is referring to?

--gb

-- 
Never trust an operating system you don't have sources for. ;-)

---

From: "James R. Leu" <[email-masked]>
Date: Thu, 20 Jul 2000 08:20:15 -0400

> What is this LPM Chatur is referring to?

Longest Prefix Match.

-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]