Subject: Some questions on VCID procedures.

From: Anup Anil Cheruvathoor <[email-masked]>
Date: Wed, 12 Jul 2000 18:11:40 +0530

Hello,
    I Have the following questions vis-a-vis the VCID
procedures as defined in draft-ietf-mpls-vcid-atm-04:

a)  In case of VCID procedure how is the session Negotiation

procedure handled. The draft does not talk about this at
all. The confusion arises as the ATM optional parameters
have to be sent to pass information like Merge capabilty, VC

directionality etc. But label ranges are not required to be
sent as they do not have end to end significance. So what
should be done as part of session negotiation w.r.t to the
initialization message?

b) In case of VPID procedures, we can have a cases when
multiple VP tunnels might be involved. But the VCI values
have end to end significance. So they must be negotiated.
But it is possible that different VPs might have different
VCI ranges, how is this information conveyed during the
Session Negotiation procedures as defined by the LDP draft.

c) The VCID draft does not explicitly say that VCID should
be sent in label request message. In all cases except one
VCID Request ID would suffice, other than the outband in
which GIT is used. In this case as
there is no VCID Request ID, as UNI does not have it, VCID
TLV is mandatory. So can we assume that VCID TLV would be
passed in this case. So should VCID TLV be sent in all the
label requests using VCID procedures.

d) No where in the draft is it explicitly told that in the
label request , the VCID message ID  is passed as an TLV. Is

the VCID TLV passed as an optional VCID message TLV as
defined in u'r draft and not as the message ID in the label
request Message?

e) In case of VPID, when does the VPID procedures start as
such? after the session gets operational. This would mean
till the procedures are not over at both the ends, the LSPs
can't be set up. Am I correct?

f) In case of VPID procedures, does the VPID proposal Ack
arrive in the LDP VC or the VP for which the procedure is
being done.

Thanks in advance for the reply.
Regardx,

-Cheru
--

Name : Anup Anil Chervathoor
E-mail : mailto:[email-masked]
Web : www.globespan.net

---

From: Ken Nagami <[email-masked]>
Date: Fri, 14 Jul 2000 19:11:39 +0900

Hi Anup,

> Session Negotiation procedures as defined by the LDP draft.

In the current VCID draft, VCI range need to configure manually in VPID
procedure. So currently, the VCID draft does not define about the
Session Negotiation procedures.

> label requests using VCID procedures.

VCID TLV is not sent in label request message.
This VCID TLV is sent only in label mapping message.

> defined in u'r draft and not as the message ID in the label

A label request message includes VCID Message ID TLV defined in the
VCID draft. Described in sec 3.1.1:

   7. After receiving the proposer ACK message, the node A sends an LDP
      REQUEST message to the node B. It contains the message ID used for
      VCID PROPOSE.  When the node B receives the LDP REQUEST message,

> can't be set up. Am I correct?

VPID procedures start before first LSP is established.  After the LDP
session gets operational is OK for starting VPID procedures. But I
don't understand why you mentions the LSPs can't be set up as your
sentence.

> arrive in the LDP VC or the VP for which the procedure is

VPID ACK message is sent in the LDP VC.
This is written in first paragraph in sec 5.1.

   A label value in the label stack entry [ENCAPS] for the
   VCID PROPOSE inband message and the VPID PROPOSE message are 4.
   Other messages are sent as TCP packets. This is the same as LDP.

Regards,

Ken Nagami