Subject: mpls on ethernet

From: [email-masked]
Date: Tue, 25 Jul 2000 22:58:04 +0900

Hi,

I am new to the mpls and have the following doubts.
If any of  u , have implemented this pls help me.

For implementing mpls on ethernet :

which part of ethernet frame can be used as LABEL.

and which part of PPP frame can be used as LABEL, in case implementing mpls on PPP.

How exactly I need to procede.
Any references /suggestions pls.....

regards
seenu

---

From: "James R. Leu" <[email-masked]>
Date: Tue, 25 Jul 2000 12:38:56 -0400

> If any of  u , have implemented this pls help me.

ftp://ftp.ietf.org/internet-drafts/draft-ietf-mpls-label-encaps-07.txt

> which part of ethernet frame can be used as LABEL.

It's not in the frame.  Read the above and it will explain.

> Any references /suggestions pls.....

If your looking for example implementation of MPLS forwarding take a look
at:

FreeBSD:
http://www.antd.nist.gov/itg/nistswitch/

Linux:
http://nero.doit.wisc.edu/mpls-linux/
http://www.cl.cam.ac.uk/Research/SRG/netos/netx/code/

Jim
-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]