Subject: Two last calls

From: George Swallow <[email-masked]>
Date: Wed, 19 Jul 2000 12:08:26 -0400

This message begins a last calls on:

  draft-ietf-mpls-diff-ext-06.txt and
  draft-ietf-mpls-rsvp-lsp-tunnel-06.txt

The last calls will end on July 26 midnight GMT.  Comment are limited
to the deltas between these and their respective prior drafts.  

With regard to the RSVP-TE draft, the recent comments to the list are
accepted as last call comments and need not be repeated.

...George

======================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824

---

From: Bora Akyol <[email-masked]>
Date: Wed, 19 Jul 2000 09:38:52 -0700

It would have been very nice to see a diff of the diffserv extensions
draft as well.

Thanks

Bora

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 19 Jul 2000 18:57:19 +0200

Hello,

At 12:08 19/07/2000 -0400, George Swallow wrote:
>  draft-ietf-mpls-diff-ext-06.txt 

Thanks to everyone who reviewed and commented as part of the first last call, to help us improve this document.
To facilitate this last call, here are the details on the resolution of the first last call comments (i.e. on -05.txt): 

Tunnelling Models
=================
o Some concerns were expressed about the stability of the Pipe and Uniform models defined in the Diff-Serv WG:
The document defining those two models has since completed Working Group LAst CAll (<draft-ietf-diffserv-tunnels-02.txt>) and is under Area Director Review on its way to the IESG for publication as an Informational RFC. So we feel this is stable material.

o There was a discussion on whether both models were necessary for MPLS operations:
We concluded from the discussion that :
	- 1) the Pipe model is necessary for operations in intra-domain operations (e.g. MPLS VPN) and is "simpler" to implement in MPLS (on the pop side)
	- 2) the Uniform model seems mainly useful for inter-domain operations (which is a lower priority target for our current specification) and for "emulating" operations of a non-MPLS IP network. Also it involves more complex MPLS operations.
Based on this we changed the levels of requirement for support of these models: the Pipe model is changed to Mandatory, while the Uniform model is changed to Optional.

o one comment that the Uniform Model was not fully specified:
I understand this was cleared in the discussion between Shahram and Eric (Shahram, Eric?)

o some minor word-smithing in the description of the models to align to proper Diff-Serv terminology (in line with latest adjustment of the Diff-Serv over Tunnel draft).

Additional Error Codes
======================
o one possible error situation was not covered by existing Error Codes:
one error code and associated Error Handling description was added in both RSVP and LDP. This was resolved in thread "New Error Codes".

Multiple pops with PHP
======================
o comment that section 2.6 discussed multiple POPs with PHP which is not a realistic situation.
text refering to multiple POPs with PHP has been removed.

Outgoing PHB Determination in Router Model
=========================================
o comment that text incorrectly referred to the "outgoing PHB Determination" as optional while in reality it is only the Traffic Conditioning stage of the Outgoing PHB Determination which is optional:
text corrected accordingly.

ECN
===
o as agreed, ECN section was removed. A short statement on compatibility of the Diff-Serv solution with future ECN support was added to the introduction.

Default for Preconfigured EXP<-->PHB mapping
============================================
As suggested, a default for Preconfigured EXP<-->PHB mapping was added.

signaling of Diff-Serv tunnelling mode
======================================
o one request to signal Diff-Serv tunnelling model on a per-LSP basis:
This had been discussed before on the alias and conclusion was that it was not yet clear that signalling of the tunnelling model was required. Text has been updated to clarify that signaling to set tunneling model on a per-LSP basis is out of the scope of this first version but could be added later if required.

signaling of per-PSC bandwidth with E-LSPs
==========================================
o one request to signal per-PSC bandwidth with E-LSPs:
This had been discussed before in the WG. This additional option would allow bandwidth reservation on a per PSC basis using E-LSPs. However , bandwidth reservation on a per-PSC basis can already be achieved with the existing option set through the use of L-LSPs. The poll to the WG had concluded that it was not worth supporting this additional option in the first version. So no change was made in the draft.

LDP Status Codes
================
o Comment that some proposed LDP Status Codes were overlapping with some recently allocated code values in the LDP spec:
LDP Status Codes where changed to a separate range in line with allocation rules defined in LDP spec.

Other changes
=============
	- section on ATM specifics and FR specifics: text changed to explain that it is the CLP/DE mapping defined earlier which ensures that the AF requirements for operations with two drop precedence levels are met. 
	- sections on PPP and LAN combined into a single one. Simpler wording used.
	- removed text which was identical for E-LSPs and L-LSPs in sections 3 and 4 by cross-referencing. 
	- descriptions of Uniform and Pipe models was shortened by removing redundant text
	- changed wording to more clearly state the relationship between the tunnel models used at different levels of LSP hierarchy  
	- in RSVP section. Use "reservation" only in context of bandwidth reservation. Otherwise use "label request". 
	- in RSVP section, "RSVP Router" was replaced by "LSR"
	- in RSVP section, removed the value of 26 tentatively proposed for the "Diff-SErv Error" error code since it is pending IANA allocation.
	- clarification in ascii art for pictures illustrating tunnel models
	- removed redundant text in description of E-LSPs/L-LSPs between section 1 and sections 3 and 4
	- removed a few additional redundancies
	- added text to introduce the concept of "MPLS Protection" (instead of using the "Fast Restoration")
	- added terminology section
	- added IANA section (and corresponding references)
	- added Copyright statement
	- minor wording improvements
	- typos

Francois

---

From: Lou Berger <[email-masked]>
Date: Fri, 21 Jul 2000 08:39:19 -0400

George,
         I still believe the draft doesn't cover the cases where there are 
non-DS and DS LSRs in the same network.  I raised this issue in February, 
see list archive for 2/8 - 2/10, and briefly at the last WG session.  My 
understanding from the authors was that they just didn't belive this case 
was valid and therefore didn't need to be addressed in the draft.  Given 
that draft-lefaucheur-diff-te-reqts-00.txt raises the same issue (in 
section 3), I think the diff-ext draft should be fixed to allow for non-DS 
and DS LSRs in the same network.

Lou

PS As mentioned back on 2/8, I believe one trivial solution is to require 
the use of the DiffServ Object/TLV for all E-LSPs, where use of 
preconfigured EXP<-->PHB mappings is indicated by either (pick one) no map 
parameters or a single map parameter set to all zeros.  Another solution is 
to use the one proposed in draft-lefaucheur-diff-te-ext-00.txt, although it 
does use a new object that could just be merged with the DiffServ Object.