Subject: RE: Policy Information Model for MPLS Traffic Engineering

From: "Francis Reichmeyer (IPHighway MA)" <[email-masked]>
Date: Mon, 17 Jul 2000 17:33:43 -0400

Hi,

I haven't had the chance to read the draft being discussed here
yet (still looking for a pointer to it, can anyone help with
that? :^). That said, there is something similar going on with
Diff Serv/QoS. The Policy Framework WG has specified a QoS
Information Model while the RAP WG is working on a Diff Serv/QoS
PIB. Along with the QoS Information Model, there is also a
LDAP schema, but this is separate from the PIB (as it should be).
So, there is some precedent for this "information architecture."
Again, I haven't seen the MPLS TE Information Model draft to 
verify it's at the same (abstraction) level as the QoS Info
Model, and there is no MPLS/TE PIB (yet ;^), so I can't say
the same relationship applies, but it could.

Thanks,
-Fran

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Monday, July 17, 2000 4:23 PM
> To: Ritu Chadha; [email-masked]; 
> [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Policy Information Model for MPLS Traffic Engineering
> 
> 
> 
>          Hi Ritu,
> 
>          My comments are inline:
> 
> > >       A few questions about your draft.
> > >
> > >       1) How does this draft differ from say the use
> > >               of COPS and the definition of a PIB
> > >               instead of using the object model?
> >
> >The information model in our draft would be used to describe policies
> >that a PDP would implement, in accordance with the policy framework.
> >The PDP could implement the policies via COPS and appropriate PIBs.
> >Appropriate PIBS could very well be defined based on some of the
> >information presented in our model.
> 
>          I disagree. This is what the PIB should be used for.
> The object model you define could very well be done by
> a proprietary vendor. I don't see the need or advantage
> to do so in a standard way. What advantages do you see of
> defining such an object model versus using say, a PIB
> and COPS to define and implement policy for MPLS?
> 
> > >       2) It is not clear to me whether or not it is your
> > >               intent to make this object model useful
> > >               for both MPLS network management or just
> > >               only for off-line TE. It seems from reading
> > >               your document that your intent is to do
> > >               both.
> > >
> >
> >That's correct; the intent is to be able to do both.
> 
>          In terms of device management, is it then your
> assertion that the MIBs will need to be re-aligned to fit
> in with your object model in order to do device-level
> management? As I see it, I don't see how the MIBs as they
> are defined today, fit in with your object model. If anything,
> I think that the object model should be changed to reflect
> that which is defined in the MIBs.
> 
>          --Tom
> 
> 
>

---

From: "Francis Reichmeyer (IPHighway MA)" <[email-masked]>
Date: Tue, 18 Jul 2000 11:15:55 -0400

Tom,

>         I thought that the purpose of the MPLS WG was to define
>protocols (and MIBs to manage them) not policy, but I may be
>mistaken here. ;)

From the Adelaide meeting minutes (regarding the presentation
made on 'Requirements for Policy Enabled MPLS'):
"... Moreover, George Swallow stated that policy and MPLS are 
two things that have very much in common and much to do with each 
other, so it is worth working on." 

I'm not sure that means policy is actually part of the purpose of the
WG ;^) but it's worth considering.

On a related note, we've submitted a draft on COPS usage for MPLS/TE
that should be showing up on the repository any day now (submitted
on Friday). It should come out as draft-franr-mpls-cops-00.txt.
Looking forward to discussing it, PIBs and maybe even
information models, in Pittsburgh.

Thanks,
-Fran

---

From: Ritu Chadha <[email-masked]>
Date: Wed, 19 Jul 2000 09:31:43 -0400 (EDT)

Unfortunately, the draft agenda released yesterday shows that
the NIM BOF clashes with the MPLS meeting on Wed morning...

Ritu

>X-Sender: [email-masked]
>Date: Tue, 18 Jul 2000 13:31:42 -0400
>To: George Swallow <[email-masked]>, Ritu Chadha 
<[email-masked]>
>From: "Thomas D. Nadeau" <[email-masked]>
>Cc: [email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked], Walter Weiss 
<[email-masked]>
>Mime-Version: 1.0
>
>
>         Hi,
>
>         I just want to add my 2 cents here. First, I
>agree as I have all along, that this stuff does not belong
>in the MPLS WG. Second, there is a BOF in Pittsburgh which
>is designed specifically to coordinate the specification
>of object models (for policy or otherwise). The BOF
>is called Network Information Modeling (NIM). You
>can join the discussion list by sending email to
>[email-masked]  I believe that Walter Weiss
>is coordinating the BOF.
>
>         --Tom
>
>> > George Swallow stated that policy and MPLS are two things
>> > that have a lot in common and therefore was worth working on.
>>
>>There's a problem with sound bites.  I also said that I didn't think
>>the work belonged in MPLS.
>>
>> > The consensus in the WG seemed to be that contributions in
>> > this area should be brought to the MPLS WG.
>>
>>I didn't agree with this consensus because the request was too general
>>and thus overlaps with other work groups.  Though our revised charter
>>is still being worked out with the IESG, there will be no general
>>policy item in it.  If specific items are needed in RSVP, LDP and
>>CR-LDP to glue things together, these are appropriate.
>>
>>Given that the MPLS agenda is tight, I would like both
>>
>>   draft-chadha-policy-mpls-te-00.txt
>>   draft-isoyama-policy-mpls-info-model-00.txt
>>
>>present only in the policy wg.
>>
>>...George
>>
>>
>>==================================================================
>>George Swallow       Cisco Systems                   (978) 244-8143
>>                      250 Apollo Drive
>>                      Chelmsford, Ma 01824
>

=============================================================================
Ritu Chadha
Senior Scientist
Telcordia Technologies 				(973) 829-4869 (voice)
MCC 1J-218R                                     (973) 829-5889 (fax)
445 South Street                                [email-masked]
Morristown NJ 07960.
=============================================================================