Subject: Forwarding Adjacency Setup Question

From: Chris Metz <[email-masked]>
Date: Tue, 22 Aug 2000 12:11:23 -0700

Hello-
I had a question forwarding adjacencies. 
http://search.ietf.org/internet-drafts/draft-ietf-mpls-lsp-hierarchy-00.txt 
states that

>In general, creation/termination of a forwarding adjacency and its
>    FA-LSP could be driven either by mechanisms outside of MPLS (e.g.,
>    via configuration control on the LSR at the head-end of the
>    adjacency), or by mechanisms within MPLS (e.g., as a result of the
>    LSR at the head-end of the adjacency receiving LSP setup requests
>    originated by some other LSRs).

I am confused by the latter statement and the implied sequence of events. 
It seems to be saying that

"some other LSRs" (let's say A in the example below) would signal 
RSVP/CRLDP messages (towards H) that pass thru a "head-end" LSR (C) who in 
turn would establish a FA-LSP to F.

A--B--C(head-end)====D====E====F--G--H

How does the A know to send an RSVP/CRLDP message thru C if the FA-LSP 
(C===F) does not already exist? Shouldn't the FA-LSP appear first as a link 
in A's topology database which would imply it has already been setup?

Thanks ...

Chris Metz
Lead IP Architect
Solutions Integration
Service Provider Line of Business
Cisco Systems
email: [email-masked]
offic phone: 408-525-3275
home office: 914-241-0423
pager: 800-365-4578
Internal URL: http://wwwin-people.cisco.com/chmetz/chmetz.htm

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 22 Aug 2000 10:04:43 -0700 (PDT)

> turn would establish a FA-LSP to F.

So far, so good.  Note that the path the A computes is ABCDEFGH.

> A--B--C(head-end)====D====E====F--G--H

See section 4.3.2. (LSP regions) that explains how C determines
that an FA is needed to F.

> in A's topology database which would imply it has already been setup?

Well, as mentioned above, the path that A computed is ABCDEFGH; but
C intercepts this, and creates an FA to F (C is the head end of this
FA-LSP), then strips the FA from the original ERO, and sends the path
message for the A->H LSP directly to F.

C also advertises the CF FA-LSP so that others can see it and use it.

Kireeti.

---

From: Eric Gray <[email-masked]>
Date: Tue, 22 Aug 2000 13:21:15 -0700

Kireeti,

	Alternatively, A may have computed a path that 
is AB(X)GH where (X) is an AS, or an address prefix, 
including routers C, D, E and F.  When C received the 
ERO containing (X) - which it is a part of - it could 
be configured to set up an FA-LSP through the AS.  
Correct?

> -----Original Message-----
> From: Kireeti Kompella [mailto:[email-masked]]
> Sent: Tuesday, August 22, 2000 10:05 AM
> To: [email-masked]; [email-masked]
> Subject: Re: Forwarding Adjacency Setup Question
> 
>