Subject: LDP - Path Vector TLV

From: "Santosh Gupta" <[email-masked]>
Date: Mon, 7 Aug 2000 16:30:10 +0530

Hello
    I have some doubts regarding Path Vector TLV in LDP. Could someone help me.
  1.. Why do we need to have Path Vector TLV in Label Map Message? If we follow Downstream On demand Ordered Control Mode of Label Distribution then what could be the need for Path Vector TLV in Label Map Message. The same path was followed in Request Message. 
  2.. The only use that I can think of Path Vector TLV in Label Map Message is when Egress LER didnt receive any Path Vector TLV/ Hop Count TLV so it sends back Label Map message so as to make sure that no loop is formed. 
  3.. There are 2 ways in which an LSR could know it's HopCount. Either it receives a Label Request Message which carries it's previous Hop's "HopCount" or if it is 0 then the Label Map message ( which comes from DownStream peer ) will contain the "HopCount" once this LSP is formed till the Egress point. So is the LSR supposed to maintain 2 "HopCount" values for different directions? 
  4.. How can each LSR know the no. of Hops in the LSP? Is it to be made from no. of entries in PathVector TLV when in Label Map message or their is some other means?
thanx in advance.

santosh

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 11 Aug 2000 15:21:21 -0400

Santosh,

From: "Santosh Gupta" <[email-masked]>
Subject: LDP - Path Vector TLV
Date: Mon, 7 Aug 2000 16:30:10 +0530

>   1.. Why do we need to have Path Vector TLV in Label Map Message? If we follow Downstream On demand Ordered Control Mode of Label Distribution then what could be the need for Path Vector TLV in La…

It is diffucult to explain all things briefly, but Path Vector TLV in
Label Mapping Message is needed for detecting loop without propagating
Label Request messages downstream beyond label merging node.

>   2.. The only use that I can think of Path Vector TLV in Label Map Message is when Egress LER didnt receive any Path Vector TLV/ Hop Count TLV so it sends back Label Map message so as to make sure…

No.  Propagating a Label Mapping Path Vector is independent from
whether the egress node received Label Request Path Vector.  In
addition, an egress node needs not include a Label Mapping Path
Vector.

>   3.. There are 2 ways in which an LSR could know it's HopCount. Either it receives a Label Request Message which carries it's previous Hop's "HopCount" or if it is 0 then the Label Map message ( w…

A node should maintain 2 hop count values for different directions.
Label Request Hop Count is used for detecting Label Request Message
looping especially for non-label-merging LSP.  Label Mapping Hop Count
is used for both detecting LSP loop and calculating TTL contained in
shim headers.

>   4.. How can each LSR know the no. of Hops in the LSP? Is it to be made from no. of entries in PathVector TLV when in Label Map message or their is some other means?

It depends on the case.  For example, if some nodes on the LSP are
configured to perform loop detection and others are not, Label Mapping
Path Vector does not provide exact information on the number of hops
in the LSP.  

Yoshihiro Ohba