Subject: Fwd: RSVP-LSP-TUNNEL

From: Lou Berger <[email-masked]>
Date: Mon, 07 Aug 2000 18:24:39 -0400

FYI -

>Reply-To: <[email-masked]>
>From: "IANA" <[email-masked]>
>To: <[email-masked]>, <[email-masked]>
>Cc: <[email-masked]>
>Subject: RSVP-LSP-TUNNEL
>Date: Mon, 7 Aug 2000 15:02:32 -0700
>X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0)
>Importance: Normal
>
>George and Lou,
>
>We have updated the RSVP-parameters file.  We apologize for long
>delay in completing this.  This is to confirm that we have assigned
>all the values requested to the RSVP protocol parameters file.  Please
>check the following file for these assignments:
>
><http://www.isi.edu/in-notes/iana/assignments/rsvp-parameters>
>
>Thank you,
>
>Michelle Schipper
>IANA
>
>Requested Assignments below (**changes)
>----------------------------------------------------------------------------
>Object and C-Type Assignments:
>
>LABEL Object  (this is already assigned, but should change from Davie
>                to the RFC number which gets assigned.)
>    LABEL class = 16
>
>Label Request Object
>    LABEL_REQUEST Class = 19
>    Label Request without Label Range            C_Type = 1
>    Label Request with ATM Label Range           C_Type = 2
>    Label Request with Frame Relay Label Range   C_Type = 3
>
>Explicit Route Object
>     EXPLICIT_ROUTE Class = 20
>     Type 1 Explicit Route                       C_Type = 1
>
>   Subobjects of the Type 1 EXPLICIT_ROUTE object
>     0   Reserved
>     1   IPv4 prefix
>     2   IPv6 prefix
>    32   Autonomous system number
>
>Record Route Object
>     ROUTE_RECORD Class = 21
>     Type 1 Record Route                          C_Type = 1
>
>   Subobjects of the Type 1 RECORD_ROUTE object
>     0   Reserved
>     1   IPv4 address
>     2   IPv6 address
>
>Session Object
>    LSP_TUNNEL_IPv4   C-Type = 7
>    LSP_TUNNEL_IPv6   C-Type = 8
>
>Sender Template Object
>    LSP_TUNNEL_IPv4   C-Type = 7
>    LSP_TUNNEL_IPv6   C-Type = 8
>
>Filter Specification Object
>    LSP_TUNNEL_IPv4   C-Type = 7
>    LSP_TUNNEL_IPv6   C-Type = 8
>
>SESSION_ATTRIBUTE object
>    Session Attribute Class = 207
>    LSP_TUNNEL       C-Type = 7
>
>Sender Tspec Object
>     Class-of-Service  C-Type = 3
>
>Flowspec Object
>     Class-of-Service  C-Type = 3
>
>HELLO Object
>     HELLO Class =  22
>     HELLO REQUEST   C_Type = 1
>     HELLO ACK       C_Type = 2
>
>*Message Assignment
>*Hello Message
>    Msg Type 14  **Assigned Value 20
>
>Error Code Assignments
>
>"Routing Problem" error code = 24
>"Notify" error code = 25
>
>The following defines error values for the Routing Problem Error Code:
>       Value Error:
>       1     Bad EXPLICIT_ROUTE object
>       2     Bad strict node
>       3     Bad loose node
>       4     Bad initial subobject
>       5     No route available toward destination
>       6     RRO syntax error detected
>       7     RRO indicated routing loops
>       8     MPLS being negotiated, but a non-RSVP-capable router
>             stands in the path
>       9     MPLS label allocation failure
>       10    Unsupported L3PID
>
>For the Notify Error Code, the 16 bits of the Error Value field are:
>       ss00 cccc cccc cccc
>The high order bits are as defined under Error Code 1. RFC2205
>When ss = 00, the following subcode is defined:
>        1    RRO too large for MTU
>        2    RRO notification

---

From: Gu Yuan <[email-masked]>
Date: Wed, 09 Aug 2000 09:52:52 +0800

> >Requested Assignments below (**changes)

Is there any DIFFSERV (draft-ietf-mpls-diff_ext) object definition?

Regards!
Yuan Gu

---

From: Gu Yuan <[email-masked]>
Date: Wed, 09 Aug 2000 09:52:52 +0800

Regards!
Yuan Gu

---

From: Markus Jork <[email-masked]>
Date: Wed, 09 Aug 2000 10:32:54 -0400

Lou,

But draft-ietf-mpls-rsvp-lsp-tunnel-06 redefines error value 6:

>       6     Unacceptable label value

How will this be resolved?

Markus

---

From: Lou Berger <[email-masked]>
Date: Wed, 09 Aug 2000 10:43:57 -0400

Good catch.  I'll ask IANA to fix the description.

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 09 Aug 2000 11:04:38 -0400

It's been fixed.

See: http://www.isi.edu/in-notes/iana/assignments/rsvp-parameters

Thanks again for catching this.

Lou