Subject: label encapsulation for LAN media

From: [email-masked]
Date: Mon, 7 Aug 2000 17:57:27 +0900

Hi,

I have the following doubts on mpls-ethernet.

Draft-ietf-mpls-label-encaps-07.txt  says that the Label Stack (label encapsulation on LAN media) must appear AFTER the data link layer headers, but BEFORE any network layer headers.

But the draft-srinivasan-mpls-lans-label-00.txt says that: (ARIS too)

	The main drawback of using the above approach for label-encapsulation is that accessing the labels requires that the frames be processed by software, reducing the benefit offered by label switching. Alternatively, hardware technology specific to label switching may be developed. However, standardized devices incorporating this technology do not exist today and cannot be built until the MPLS standard becomes stable. 

	And this draft has proposed the use of destination MAC address field for label encapsulation.

Now, my doubts are:

· If one follows the first case (label-encaps-07.txt), how the label swapping will be done (s/w or h/w)
· Is there any ethernet standard (h/w) that supports the above type of switching (label-encaps-07.txt).
· Which is the standard draft that is being followed.
· If any of u have implemented the above, pls help me.

Thanks in advance

regards
seenu

---

From: Bora Akyol <[email-masked]>
Date: Mon, 07 Aug 2000 12:44:57 -0700

[email-masked] wrote:

> ? If one follows the first case (label-encaps-07.txt), how the label swapping will be done (s/w or h/w)
> ? Is there any ethernet standard (h/w) that supports the above type of switching (label-encaps-07.txt).
> ? Which is the standard draft that is being followed.
> ? If any of u have implemented the above, pls help me.
>
> Thanks in advance
>
> regards
> seenu

I haven't read this draft, but I see no reason why having the shime header between IP and Ethernet headers would cause packets to be processed in SW.

Bora

---

From: Jeremy Lawrence <[email-masked]>
Date: Tue, 08 Aug 2000 13:48:10 +1000

One more comment:

>[email-masked] wrote:
[...]
>> ? Which is the standard draft that is being followed.

draft-ietf-mpls-label-encaps-07.txt has been approved as a Proposed
Standard RFC, but can't yet be published as one as it's waiting for
the LDP draft. See http://www.rfc-editor.org/queue.html

draft-srinivasan-mpls-lans-label-00.txt is long expired, and there
were significant doubts expressed at the time about interoperability
with existing LAN switches.