Subject: questions on mpls-ldp-09

From: Yuan Gu <[email-masked]>
Date: Thu, 24 Aug 2000 11:42:37 +0800

Dear All:

I have some questions on  mpls-ldp-09.txt:

1.How many LSPs can be setup in same session?  If session fails for some
reason, do all LSPs in this session have to be released?

2. In section 3.5.2.1 Hello Message Procedures
Configuration Sequence Number:
What kind of session parameter can be changed by passive LSR without
noticed by active LSR? If receiving LSR detects a change in the
configuration in the sending LSR by detecting the change of
Configuration Sequence Number, beside clearing the session setup backoff
delay, what else the receiving LSR does? If receiving LSR playing the
passive role and detect the change, what does it do?

Thanks alot.
Yuan Gu

---

From: Nick Weeds <[email-masked]>
Date: Fri, 25 Aug 2000 15:47:44 +0100

Edward,

The draft you mention has been superceded.  The latest draft is
draft-brittain-mpls-ldp-ft-00.txt.  (This latest draft combines the earlier
farrel and matthews drafts).

	Nick.

> Nick Weeds
> Software Developer
> Network Convergence Group
> Data Connection Ltd
> Tel:	+44 1244 313440		Fax:	+44 1244 312422
> Email:	[email-masked]		Web:
http://www.datcon.co.uk

> -----Original Message-----
> From: Edward Brookhouse [mailto:[email-masked]]
> Sent: 24 August 2000 21:35
> To: Eric Gray; 'Yuan Gu'; [email-masked]
> Subject: RE: questions on mpls-ldp-09
> 
> 
> 
> Is the draft-farrel-mpls-ldp-ft-00.txt the latest version of 
> the draft ??
> 
> Thanks 
> 
> Edward
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Eric Gray
> Sent: Thursday, August 24, 2000 9:49 AM
> To: 'Yuan Gu'; [email-masked]
> Subject: RE: questions on mpls-ldp-09
> 
> 
> Yuan,
> 
> 	Please see embedded comments below.
> 
> > -----Original Message-----
> > From: Yuan Gu [mailto:[email-masked]]
> > Sent: Wednesday, August 23, 2000 8:43 PM
> > To: [email-masked]
> > Subject: questions on mpls-ldp-09
> > 
> > 
> > Dear All:
> > 
> > 1.How many LSPs can be setup in same session?  
> 
> As many as the two LSRs can maintain state for.
> There is no artificially imposed limit.
> 
> > If session fails for some reason, do all LSPs in 
> > this session have to be released?
> 
> Currently, yes.  See the draft on Fault Tolerant 
> LDP - which was accepted as a working group draft
> at the last IETF meeting - for how LSP state may
> be preserved across LDP sessions.
>  
> The intent of the configuration sequence number is
> to allow the active peer to be able to find out that
> the passive peer has been re-configured.  
> 
> Why do we want to allow this?  
> 
> Because we can assume that a likely reason why two 
> peers are unable to establish a session is that they 
> have been configured with session parameters that are 
> incompatible.  In this event, each repeated attempt
> will fail and - with exponential back-off - each
> new attempt will be delayed by an interval that is
> twice what it was in the immediate prior attempt.
> Obviously, this delay can grow to be quite large.
> The inclusion of a changed configuration sequence 
> number in a Hello message from the passive peer 
> signals the active peer that it might ignore the
> current retry delay and try again immediately.
> 
> Since the passive peer does not control when an
> attempt will be made (it does not initiate LDP
> session establishment), it does not matter if it
> detects a change in the configuration sequence
> number.  If the active peer has been re-configured,
> it can initiate LDP session establishment on its
> own (without sending a configuration sequence
> number to its passive peer or peers).
> 
> > 
> > Thanks alot.
> > Yuan Gu
> > 
> > 
>