Subject: RE: Questions on Solving Congestion in MPLS

From: Shahram Davari <[email-masked]>
Date: Thu, 17 Aug 2000 13:22:06 -0700

Robert,

>-----Original Message-----
>From: Robert Sterol [mailto:[email-masked]]
>Sent: Thursday, August 17, 2000 3:40 PM
>To: [email-masked]
>Subject: Questions on Solving Congestion in MPLS
>
>
>
>
>Hi,
>
>I have some questions on a couple of relate things.
>The main question is: In case of TE, and there is congestion 
>in the network, how
>will traffic be send over a new LSP to prevent any discarding 
>of packets/frames?
>
>I did some searching and came up with the following:
>1) In case of TE, you will not run into congestion problems

It depends on the network policy and the extent of TE implementation. If the
network policy is to drop packets when all the routes are congested, and if
TE is implemented in all edge routers, then you won't probably see any
persistant congestion. Otherwise you may see.

>2) Congestion is really associated to QoS, and can be solved 
>by e.g. Explicit
>Congestion Notification (ECN) which currently is experimental 
>and not deployed.
>It is also included in the IP header, so really a layer 3 service.

ECN can help reduce congestion in case of well-behaved sources. But network
operators can't rely entirely on user behaviors, so they need to implement
other methods such as RED, TE , etc too.

>3) Fast Rerouting, in the case of link failures and router 
>failures will use a
>new route, by attaching a new label to all packets with a 
>label that would go
>over the link or to the router that failed, and pushing the 
>packets belonging to
>other LSPs on the label stack.

The tunneling method that you described is one of the rerouting methods.
There are other moethods too.

>
>My first question is if these observations are correct, and my 
>second question
>is: In the case of fast rerouting, how is decided to use that 
>new label and go
>over another route? Is this dynamically decided by the routing 
>protocol, and
>when, or is this a manual operation by an admin that sets a 
>default route with a
>label, in case other routes go down?

There are basically 2 methods:

1) offline (pre-computation) -> can be manual or automatic
2) on-line (instant computation)-> is automatic

Regards,
-Shahram

>
>I hope the questions have the proper granularity and are 
>clear. If not, please
>let me know...
>Thanks very much in advance.
>
>Kind Regards,
>Robert
>
>

---

From: "raghu arni" <[email-masked]>
Date: Thu, 17 Aug 2000 16:39:12 -0400

Talking about offline and online...Are there any offline tools that are
being used in the market today? I heard of wandl..Are there any others..??

Thx,
A

---

From: Rob Rice <[email-masked]>
Date: Thu, 17 Aug 2000 17:11:49 -0400

Raghu,

Make Systems is developing an offline MPLS TE tool scheduled to ship in
October. I can send you details if you are interested.

Rob Rice
Product Manager, Network Engineering Tools
Make Systems, Inc.
919-461-2445 x226
www.makesys.com