Subject: RE: resource preemption

From: Sundara Murugan <[email-masked]>
Date: Fri, 4 Aug 2000 11:32:36 -0700

John ,

The resv message doesn't contain session attribute object and hence you
don't know the setup and holding priorities of the LSP. These are available
in the path message and hence Call admission should be done during path
message.

When there is not enough resources available to support the LSP, you can
find out how much is allocated to lower priority LSPs and based on that you
can generate the AdSepc. These lower priority must be preempted only when
you get the resv message.

-sundara  

-----Original Message-----
From: John Sparr [mailto:[email-masked]]
Sent: Friday, August 04, 2000 11:18 AM
To: Navin
Cc: [email-masked]
Subject: RE: resource preemption

Hi Navin,

It should be that Resv message triggers this compare.
But why the draft says "When a path message is
considered for admission"?(section 4.8.3) It seems
when a node received a Path message it checks if the
bandwidth is avialable. I think the bandwidth request
should be in Resv message. is that right?

Regards,
John

--- Navin <[email-masked]> wrote:
> Hi There,
> 
> First of all, you carry out admission control check
> while
> processing the RESV message NOT PATH message.
> 
> Secondly, admission control check will be done at
> all the nodes
> EXCEPT the receiver node as there you really don't
> reserve
> anything.
> 
> Hope this helps,
> 
> Cheers,
> Navin
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of John
> Sparr
> Sent: Friday, August 04, 2000 9:30 AM
> To: [email-masked]
> Subject: resource preemption
> 
> 
> Hi,
> 
> Quick question on resource preemption from RSVP-TE.
> 
> In section 4.8.3, it says when a new Path message is
> considered for admission, the bandwidth requested is
> compared with the bandwidth at the priority
> specified
> in the Setup Priority.
> 
> My question is who will do this compare,
> intermidiate
> nodes or receiver?
> 
> 
> Thanks in advance
> John
> 
> __________________________________________________
> Do You Yahoo!?
> Kick off your party with Yahoo! Invites.
> http://invites.yahoo.com/

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

---

From: "Navin" <[email-masked]>
Date: Fri, 4 Aug 2000 11:53:53 -0500

Hi Folks,

>in the path message and hence Call admission should be done during path

In any case, Once your LSP is 'setuped', the setup priority doesn't have any
meaning.
And the only priority which will be used is the holding priority.

A quick question. If you are implementing RFC2212 i.e GS, how would you
accomodate
R, if R > r. Considering that you would have already accepted the session
while
processing the Path message.

Anyway, Read RFC2209 and get the first hand info on RSVP message processing.

Have a nice weekend.

Over & out.

Navin