Subject: RE: Use of the term "end-to-end"

From: "David Allan" <[email-masked]>
Date: Fri, 4 Aug 2000 08:45:48 -0500

Agreed

> -----Original Message-----
> From:	Scott Brim [SMTP:[email-masked]]
> Sent:	Thursday, August 03, 2000 11:37 AM
> To:	David R. Oran
> Cc:	mpls; IESG; IAB
> Subject:	Re: Use of the term "end-to-end"
> 
> LER-to-LER
> 
	<snip>

---

From: "Loa Andersson" <[email-masked]>
Date: Mon, 07 Aug 2000 02:53:34 +0200

This is fine with me, but the last time (back in the childhood of MPLS)
I tried to propose the term LER as part of the MPLS vocabulary it was 
not considered necessary. SO either we add it or use something else.

/Loa

-- 

Loa Andersson
Director Routing Architecture Lab, EMEA
St Eriksgatan 115A, PO Box 6701
113 85 Stockholm, Sweden
phone: +46 8 50 88 36 34,   mobile + 46 70 522 78 34
e-mail: [email-masked]

---

From: Eric Gray <[email-masked]>
Date: Sun, 06 Aug 2000 20:57:02 -0700

Loa,

    I distinctly remember your proposing the term and
its more-or-less being rejected.  Never-the-less, it has
come to be accepted as a real term.  Many slides and
charts now contain some subset of this picture:

  LER -- LSR -- ... -- LSR -- LER

While it is still debatable that a box which is exclusively
either an LER or an LSR will be a long-term survivor
in the market place, it is useful to think of LSR verses
LER functionality.

---

From: "Loa Andersson" <[email-masked]>
Date: Mon, 07 Aug 2000 17:36:04 +0200

Eric,

well yes! And it was precisely the argument - no boxes will do only
LER functionality in the long run, so they will all be LSRs anyway.
So what I proposed was "a functional group" called LER and another
called LSR for network modeling purposes. But it was felt that that
level of abstraction wasn't needed, but it seems that it is.

So any of the architecture people care to put it in?

/Loa

-- 

Loa Andersson

---

From: Eric Rosen <[email-masked]>
Date: Mon, 07 Aug 2000 12:51:26 -0400

I have to say  that I don't see what the problem is.  Or rather, I don't see
that  there   is  a   problem  which  requires   any  modification   of  the
specifications. 

I don't think that "end-to-end" is used  in any of the MPLS documents, and I
believe  that  those documents  contain  terminology  which  is adequate  to
precisely state any necessary concepts.

In discussing MPLS, the term  "end-to-end" is sometimes used colloquially in
contexts  where it is  clear to  most that  it doesn't  mean "host-to-host".
Dave might be  right to deplore this usage.   However, increasing the number
of precisely  defined terms and acronyms  will not do anything  to stamp out
such colloquialisms.

---

From: Scott Brim <[email-masked]>
Date: Mon, 07 Aug 2000 18:00:14 -0400

>of precisely  defined terms and acronyms  will not do anything  to stamp out

But (1) we can do the right thing and not use "end-to-end" in a way that 
further erodes its meaning. and (2) if it's a confusing term then we 
shouldn't use it anyway.  I like LER because it's a clearly defined 
functionality, within the context of MPLS, regardless of whether the box 
that is an LER is doing other things as well.

...Scott

---

From: Grenville Armitage <[email-masked]>
Date: Mon, 07 Aug 2000 16:15:33 -0700

LER-to-LER makes sense because it contains the notion
of "edge" (the 'E' in LER) as opposed to "end".  Which makes
me think the better phrase is just "edge to edge" since it really
isn't a new term per se, generalizes neatly to similar concepts
in Diffserv, and captures the non-end2end nature of what we're talking
about without constraining the mental model to start/end on an
MPLS-specific functional element.

cheers,
gja

Scott Brim wrote:
	[..]