Subject: RE: consensus to make draft-kompella-mpls-te-mib-00.txt a TEWG it em?

From: Adrian Farrel <[email-masked]>
Date: Mon, 21 Aug 2000 10:42:13 +0100

My $0.02 on this...

>> So, with that said - I'd like to see what the consensus of 
>> the list is.
>> 
>> Should Kireeti's draft
>> a) be accepted as a TE WG item at this time?
>> b) not be accepted as a TE WG item at this time?

I believe that this should NOT move forward as a tewg item at this time.

I suggest that it could be the role of the tewg to
- produce a TE MIB that is independent of MPLS
- produce a set of requirements on the MPLS TE MIB and
  request (insist?) that the mplswg incorporate them

I suggest that it is the role of the mplswg to
- produce a fully functional MIB (set of MIBs) that
  can be used to configure, manage and observe an MPLS
  TE network
- take input from implementers, operators and those
  with particular TE experience 

Having had considerable experience with the mplswg MIBs
I feel that there _is_ considerable overlap between the
MIBs and that much of what Kireeti shows in his MIB can
be found in the mplswg MIB.  On the other hand, there are
other functions that are "new" in Kireeti's MIB that would
be of value in the mplswg MIBs, and my view is that the
authors of the mplswg MIBs must incorporate them.

I cannot understand why it would not be a valuable use of
the conformance statement and conformance units to produce
a single combined MIB where the function of Kireeti's MIB
can be achieved by legally supporting just a subset of the
objects in the mplswg MIBs.

Would the authors (on both sides) like to comment on whether 
this is feasible, or indeed whether they have already started
discussions on this topic?

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 21 Aug 2000 08:39:46 -0400

Adrian,

>discussions on this topic?

         This is totally feasible, and in our (MPLS-TE-MIB co-authors)
view is the best choice. It accommodates both camps of people without
ignoring either. This is the option that we have advocated
since Kireeti presented his MIB in Pittsburgh.

         --Tom