Subject: RE: MPLS label authentication

From: Nageswara Soma <[email-masked]>
Date: Thu, 10 Aug 2000 18:55:36 -0700

LDP uses reliable TCP for label exchange.

> -----Original Message-----
> From: Man Trinh [mailto:[email-masked]]
> Sent: Thursday, August 10, 2000 6:47 PM
> To: [email-masked]
> Subject: MPLS label authentication
> 
> 
> Hi,
> 
> I am kind of new to the MPLS protocol.  If I ask a
> question that is already discussed, please point me
> to the thread in the archive.
> 
> My question is how do I know that the label that I
> am getting is the correct label.  What if it is 
> corrupted when I receive it?
> 
> Thanks,
> -Man
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Kick off your party with Yahoo! Invites.
> http://invites.yahoo.com/
>

---

From: naidu <[email-masked]>
Date: Fri, 11 Aug 2000 12:44:14 +0530

Hi,

> LDP uses reliable TCP for label exchange.

I think the question is about Label in data path.
IP header checksum calculation won't consider MPLS Label.
So label can be corrupted and have to rely on Data Link CRC.

Regards
Naidu
HCL Networking Products Division