Subject: RE: resource preemption

From: John Sparr <[email-masked]>
Date: Fri, 4 Aug 2000 11:18:09 -0700 (PDT)

Hi Navin,

It should be that Resv message triggers this compare.
But why the draft says "When a path message is
considered for admission"?(section 4.8.3) It seems
when a node received a Path message it checks if the
bandwidth is avialable. I think the bandwidth request
should be in Resv message. is that right?

Regards,
John

--- Navin <[email-masked]> wrote:
> Hi There,
> 
> First of all, you carry out admission control check
> while
> processing the RESV message NOT PATH message.
> 
> Secondly, admission control check will be done at
> all the nodes
> EXCEPT the receiver node as there you really don't
> reserve
> anything.
> 
> Hope this helps,
> 
> Cheers,
> Navin
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of John
> Sparr
> Sent: Friday, August 04, 2000 9:30 AM
> To: [email-masked]
> Subject: resource preemption
> 
> 
> Hi,
> 
> Quick question on resource preemption from RSVP-TE.
> 
> In section 4.8.3, it says when a new Path message is
> considered for admission, the bandwidth requested is
> compared with the bandwidth at the priority
> specified
> in the Setup Priority.
> 
> My question is who will do this compare,
> intermidiate
> nodes or receiver?
> 
> 
> Thanks in advance
> John
> 
> __________________________________________________
> Do You Yahoo!?
> Kick off your party with Yahoo! Invites.
> http://invites.yahoo.com/

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

---

From: David Charlap <[email-masked]>
Date: Fri, 04 Aug 2000 18:58:08 -0400

John Sparr wrote:
> 
> It should be that Resv message triggers this compare.  But why the
> draft says "When a path message is considered for admission"? (section
> 4.8.3) It seems when a node received a Path message it checks if the
> bandwidth is avialable. I think the bandwidth request should be in
> Resv message. is that right?

The actual resources must be reserved and locked down while processing
the Resv message.

Some hardware and/or software implementation may find it useful or
necessary to reserve (or confirm the availability of) resources during
Path processing.

It is also, however, reasonable for a switch to just record the contents
of a Path message and do all admission control processing when the Resv
message is processed.

-- David