Subject: RE: generalized MPLS signaling question

From: Eric Gray <[email-masked]>
Date: Wed, 16 Aug 2000 09:57:13 -0700

Kireeti,

	Hi.

	I'm afraid that this doesn't help, too much,
in understanding how this might be done.  For one
thing, if the interface ID sub-object type you've
defined in the unnumbered draft (I am assuming you
refer to draft-kompella-mpls-unnum-00) is intended
to be used to identify LSPs, then it should maybe
have been defined as a larger than 16-bit field.
Since LSPs may be extended to large numbers of 
LSRs either directly or indirectly connected, the
number of interface IDs needed may be arbitrarily 
large.

	For another, there's an issue with how an LSR
might interpret an IPv4 prefix in an ERO when there
are multiple routes to that prefix - including one
or more that traverse an LSP.  In fact, there is 
nothing to prevent having more than one LSP at any
LSR that extends toward an IPv4 prefix, is there?   
And, although it may make sense to use an LSP that 
directly connects the current LSR to a remote next 
hop associated with the IPv4 prefix specified in an 
ERO, if you cannot explicitly identify the LSP, the 
local routing engine may decide to use another route.  
This would appear to defeat the purpose of using the 
ERO.

	So, I guess the question comes down to "is there
a reason why a user might want to force the path to
follow a particular LSP even when routing would prefer
a different path?"  I think the answer is yes, using
Alan's specific example as a case in point, so the
next question is - "how do we force this behavior?"

	In CR-LDP, there is an explicit LSPID Hop type.
Perhaps there should be a "Session" sub-object for 
RSVP-TE?

	Thanks!

> -----Original Message-----
> From: Kireeti Kompella [mailto:[email-masked]]
> Sent: Wednesday, August 16, 2000 9:16 AM
> To: [email-masked]; [email-masked]
> Subject: Re: generalized MPLS signaling question
> 
> 
> > how do LSR-A and LSR-B coordinate
> > the timeslot allocation so that LSR-A sends the data in the
> > timeslot on the correct Lambda?
> 
> Using the ERO.  Each lambda (actually, lambda-switched path) is
> uniquely identified, either by an IP address or by an "interface"
> index as defined in the unnumbered draft.
> 
> Kireeti.
>

---

From: "James R. Leu" <[email-masked]>
Date: Wed, 16 Aug 2000 13:28:38 -0400

I agree with Eric.

Not only would this provide a means to clearly indicate that the resulting
LSP should utilize (tunnel through) and existing LSP.  It would also align
RSVP-TE, CR-LDP, and the TE-MIB with respect to EROs.

Jim
-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]