Subject: RE: negotiations in CR-LDP

From: "Ajay Malik" <[email-masked]>
Date: Wed, 23 Aug 2000 14:38:57 -0400

Can a lower limit for negotiations for any parameter be specified in the
setup message ?

-----Original Message-----
From: Vasanthi Thirumalai [mailto:[email-masked]]
Sent: Wednesday, August 23, 2000 2:14 PM
To: Malik, Ajay [SKY:1H62:EXCH]
Cc: [email-masked]
Subject: Re: negotiations in CR-LDP

Hi, 
    In the example that you have given, LSR2 would modify the PDR(it may
substitute it with a smaller value) and send the Label request to LSR3. 

In general an LSR that cannot satisfy a negotiable traffic parameter
request, replaces it with a smaller  value and propagates the Label request.
Label Mapping carries the final negotiated value. The LSRs along the path,
then adjust the resources they  reserved for the path, based on the values
conveyed in  the Label Mapping message. 

-Vasanthi 

Ajay Malik wrote: 
Hi, 

  I have a question regarding negotiations in CR-LDP: 
     LER--LSR1--LSR2---LSR3--LER 

  if the LSR2 finds that sufficient resources are not available and the
parameter 
  values are negotiable what does it exactly does ? 
    * does it modify the setup and sends it to LSR3 irrespective of anything
? 
    * does it first negotiate with LSR1 ? how ? (take example of PDR in
Delay 
      sensitive service) 

Ajay

---

From: Prem Shankar Sharma <[email-masked]>
Date: Wed, 23 Aug 2000 14:54:52 -0700

Well, the negotiation flag associated with each parameter dictates what all
parameters could be negotiated or not. 
 
The drafts don't mention anything about the lower limits except that PDR
can not be less than CDR .
 
The exact rules for deciding on downgrading the requirements of the LSP or
to initiate pre-emption of other LSPs could depend on network policies.
 
Prem

-----Original Message-----
From: Vasanthi Thirumalai [mailto:[email-masked]]
Sent: Wednesday, August 23, 2000 2:14 PM
To: Malik, Ajay [SKY:1H62:EXCH]
Cc: [email-masked]
Subject: Re: negotiations in CR-LDP

Hi, 

-Vasanthi 

Ajay Malik wrote: 
Hi, 

Ajay