Subject: MPLS label authentication

From: Man Trinh <[email-masked]>
Date: Thu, 10 Aug 2000 18:47:18 -0700 (PDT)

Hi,

I am kind of new to the MPLS protocol.  If I ask a
question that is already discussed, please point me
to the thread in the archive.

My question is how do I know that the label that I
am getting is the correct label.  What if it is 
corrupted when I receive it?

Thanks,
-Man

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

---

From: Man Trinh <[email-masked]>
Date: Thu, 10 Aug 2000 20:25:12 -0700 (PDT)

Hi,

I am talking about the label I am getting when I
do label exchange.  I am talking about the shim
label in the data packet.  For example, the IP
Header has the checksum for protection against
corrupted header.  Is there anything I can do to
protect against a corrupted MPLS label.

-Man

--- Nageswara Soma <[email-masked]> wrote:
> LDP uses reliable TCP for label exchange.
> 
> > -----Original Message-----
> > From: Man Trinh [mailto:[email-masked]]
> > Sent: Thursday, August 10, 2000 6:47 PM
> > To: [email-masked]
> > Subject: MPLS label authentication
> > 
> > 
> > Hi,
> >

---

From: Eric Gray <[email-masked]>
Date: Thu, 10 Aug 2000 20:36:22 -0700

Man,

	The MPLS Shim header is part of the L2 frame's data.

> Sent: Thursday, August 10, 2000 8:25 PM
> To: Nageswara Soma
> Cc: [email-masked]
> Subject: RE: MPLS label authentication
> 
> 
> Hi,
>

---

From: Nageswara Soma <[email-masked]>
Date: Fri, 11 Aug 2000 11:35:09 -0700

Hi Man,
Sorry for misinterpreting your question.
Eric Gray got the exact answer.

> Cc: [email-masked]