Subject: mplsInterfaceConfTable in LSR MIB

From: "Sudhanshu Jain" <[email-masked]>
Date: Thu, 17 Aug 2000 11:21:37 -0700

Hi All,

I have some doubt on draft-ietf-mpls-lsr.mib.

Here "mplsInterfaceConfTable" has all the object IDs as read only. Is there any specific reason to make these parameters as read only?
 
Is there any other mib which may allow some of these params like "mplsInterfaceLabelMinOut",
"mplsInterfaceLabelMaxOut", to configure?

Any comments??

-Sudhanshu Jain

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 17 Aug 2000 14:16:34 -0400

Hi Sudhanshu,

>Here "mplsInterfaceConfTable" has all the object IDs as read only. Is 
>there any specific reason to make these parameters as read only?

         Yes, the reason is that RFC2233 interfaces should be created
by the system. The MPLS parameters are viewed as being attached
or augmenting those.

>"mplsInterfaceLabelMaxOut", to configure?

         IETF-LDP-MIB

         --Tom

---

From: "Sudhanshu Jain" <[email-masked]>
Date: Thu, 17 Aug 2000 11:54:52 -0700

----- Original Message ----- 
  From: Thomas D. Nadeau 
  To: Sudhanshu Jain ; [email-masked] 
  Cc: cheenu Srinivasan ; [email-masked] 
  Sent: Thursday, August 17, 2000 11:16 AM
  Subject: Re: mplsInterfaceConfTable in LSR MIB

          Hi Sudhanshu,

Yes I under this part, as this is the reason we don;t have admin and oper status here.
    Is there any other mib which may allow some of these params like "mplsInterfaceLabelMinOut",
    "mplsInterfaceLabelMaxOut", to configure?

          IETF-LDP-MIB

But as far as these augmented parameters are concerned, I think they are specific to interface and are based on peer LSRs characteristics. And that interface may be running LDP or not. 

Does this mean, IETF-LDP-MIB need to be supported by all the LSR irrespective of protocols supported on that LSR? IMHO, these type of parameters should be configurable via LSR mib, instaed of LDP MIB.

-Sudhanshu

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 17 Aug 2000 14:55:35 -0400

>But as far as these augmented parameters are concerned, I think they are 
>specific to interface and are based
>on peer LSRs characteristics. And that interface may be running LDP or not.
>
>Does this mean, IETF-LDP-MIB need to be supported by all the LSR 
>irrespective of protocols supported on that LSR?

         Only if you want to configure those LDP parameters.

>IMHO, these type of parameters should be configurable via LSR mib, instaed 
>of LDP MIB.

         The consensus was that the LSR MIB reflect the label
ranges which were configured by the other various distribution
protocols.

         --Tom

---

From: "Sudhanshu Jain" <[email-masked]>
Date: Thu, 17 Aug 2000 14:45:35 -0700

Hi Tom,

Thanks for the responses. 

I understand due to backward compatibility ( with ATM or FR mibs) we might have avoided these prams to be configured at a common place like LSR MIB, and we added in LDP MIB.

Now in case of RSVP interface, is there any mib which talks about these kind of parameters. 

Don't you think these params are independent of the distribution protocol and should be based on encapsulation protocol ( ATM, FR, SHIM header ......)

Regards,
-Sudhanshu
  ----- Original Message ----- 
  From: Thomas D. Nadeau 
  To: Sudhanshu Jain ; [email-masked] 
  Cc: cheenu Srinivasan ; [email-masked] 
  Sent: Thursday, August 17, 2000 11:55 AM
  Subject: Re: mplsInterfaceConfTable in LSR MIB

    But as far as these augmented parameters are concerned, I think they are specific to interface and are based 
    on peer LSRs characteristics. And that interface may be running LDP or not. 
     
    Does this mean, IETF-LDP-MIB need to be supported by all the LSR irrespective of protocols supported on that LSR?

    IMHO, these type of parameters should be configurable via LSR mib, instaed of LDP MIB.

          --Tom