Subject: LSP setup time and delay

From: Vishal M <[email-masked]>
Date: Fri, 18 Aug 2000 01:14:55 -0700 (PDT)

Hello,

Suppose an IP packet is to sent over a MPLS network.
As I understand the protocol, different components at
the ingres LSR (also called LER) interact in the 
following way:

1. MPLS Signaling Plane (CR-LDP/RSVP) queries the
Routing Plane (IGP Extensions) to get the Explicit 
Path to reach the destination (assuming nothing
in the tables initially).

2. Signaling Plane uses RSVP or CR-LDP to reserve
resources along the explicit path. Label mapping
is performed at the intermediatory LSRs.

3. After the path is set up i.e. LSP is established 
from the source to the destination, the incoming 
packet is forwarded and the rest of the packets follow
the same path.

Questions:

Q1. In the process mentioned above (and if it is the
right sequence), there might be a noticable delay 
between the time the packet arrived at LER and
the time when the LSP is established and actual
traffic starts flowing.

This could lead to two problems:
a. Delay at the LER. If we are dealing with mission 
critical applications, is this delay acceptable ?
b. Memory crunch at the LER (considering OC-192 i/f).

We could have pre-configured tunnels or LSPs to 
circumvent this problem. Are tunnels the way to go to
resolve this ? Is there any other solution (assuming 
this is really a problem !) ?

Q2. I'm not very sure of the Step #3. Is the first 
packet routed ?
I mean, does the first packet go along with the
Resource Resv request OR does it have to wait till the

entire path is established ?

I apologize if this is a very basic question, but
I have trouble understanding this.

Thanks,
Vishal.

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: "James R. Leu" <[email-masked]>
Date: Fri, 18 Aug 2000 10:07:16 -0400

> Hello,

LSP setup is not data driven.  The signalling protocols should have setup the
LSP long before the arrival of data.

-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]

---

From: "tom worster" <[email-masked]>
Date: Fri, 18 Aug 2000 11:32:27 -0400

From: James R. Leu
> LSP long before the arrival of data.

i hadn't noticed that mpls specified this. i though it was
up to the application (e.g. te) to decide when to set up an 
lsp.

c u
tom