Subject: "Two roads diverged in a yellow wood"

From: Danny McPherson <[email-masked]>
Date: Sat, 19 Aug 2000 22:41:18 -0600

Thomas, 
Perhaps some of these operators you've spoken with and
keep referring to should "chime in"?  Do they have email?
Can they speak for themselves?  I've reviewed all the
posts to the thread and not seen a single one of "your
operators" voice their own opinions.  

For that matter, a glean of the archives doesn't indicate
their existence either.  

I think the reality here is that folks who are deploying
MPLS/TE and need to manage their networks today are happy
with a MIB similar to that of Kireeti's, simply because 
it's sufficient for what they're doing.  The folks that 
have been working some 2 years "MPLS-TE-MIB" have just 
been blind-sided by the simplicity and [arguable] 
usability of such a trivial, non-academically-geared MIB,
while they've been off in their corner developing this 
perfectly structured, academically sound, looks-good-on-
paper MIB.

It would seem this is occurring all to often in the IETF 
today, that's unfortunate.

As for what we do now, good question.  While I completely 
agree with Randy/Vijay's comments, I also understand there's
significant value in a single MIB.  Perhaps the right way
to go is to merge the MIBs, with some wording surrounding
the use of Kireeti's MIB as a base, and the "MPLS-TE-MIB"
as the "full MIB".  While I'm guessing this goes against 
all the "MPLS-TE-MIB" folks stand for,  and do realize it's
not quite that simple, I'm also guessing it's the only 
agreement that I foresee will result in a single MIB.

[side note:  as for the repetitive "that's only because
you use Juniper's in your network", get over it -- especially
you]

-danny

> world that only uses Juniper boxes in their network. I am
> trying to speak for those operators who I have spoken with, who
> are in the majority. These folks have networks which are not comprised
> of a single vendor's devices. This group manages networks comprised of
> boxes from many vendors and would specifically like to use a single MIB
> to do this. It is an operational nightmare to have to figure out which
> vendors boxes (and perhaps which versions of those boxes) use which
> standard MIB. In these cases your Juniper-specific solution just will
> not work for the reasons which I and others have outlined about 10 times
> today. I hope that people are seeing this situation for what it really
> is.

---

From: "Xipeng Xiao" <[email-masked]>
Date: Sun, 20 Aug 2000 11:32:09 -0700

> agreement that I foresee will result in a single MIB.

I agree with Danny here.

Xipeng