Subject: RE: What's in or out?

From: "Ash, Gerald R (Jerry), ALCOO" <[email-masked]>
Date: Thu, 30 Nov 2000 12:41:23 -0500

> Not in charter
> ==============
> LSP Modification Using CR-LDP (25333 bytes)

Is in Charter under Goal 1 at
http://www.ietf.org/html.charters/mpls-charter.html

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 30 Nov 2000 13:06:54 -0500

You noted that the MPLS-LSR/TE/LDP/FTN-MIBs are
no longer in the charter's scope. After reading the
revised charter, I seem to agree with you (though
not with the charter). This seems bad to me since
they were defined (and accepted by the wg) to manage
specific MPLS components. Where are things like this
going to be moved? I think that it would be a terrible
shame to loose this work, especially since there are
numerous implementations of these drafts out there
now.

         --Tom

>Not in charter
>==============
>A Framework for MPLS (sounds like this should have been an Informational RFC
>by now)
>The Assignment of the Information Field and Protocol Identifier in the
>Q.2941 Generic Identifier and Q.2957 User-to-user Signaling for the Internet
>Protocol (51283 bytes)
>VCID Notification over ATM link for LDP (37102 bytes)
>Definitions of Managed Objects for the Multiprotocol Label Switching, Label
>Distribution Protocol (LDP) (175663 bytes)
>MPLS Traffic Engineering Management Information Base Using SMIv2 (110714
>bytes)
>Framework for IP Multicast in MPLS (61038 bytes)
>ICMP Extensions for MultiProtocol Label Switching (17870 bytes)
>IMPROVING TOPOLOGY DATA BASE ACCURACY WITH LSP FEEDBACK (29565 bytes)
>LSP Hierarchy with MPLS TE (23524 bytes)
>MPLS/IP Header Compression (30916 bytes)
>MPLS/IP Header Compression over PPP (17770 bytes)
>Link Management Protocol (LMP) (89750 bytes)
>Framework for MPLS-based Recovery (84785 bytes)
>Multiprotocol Label Switching (MPLS) FEC-To-NHLFE (FTN) Management
>Information Base Using SMIv2 (43776 bytes)
>Fault Tolerance for LDP and CR-LDP (63133 bytes)
>MPLS LDP Query Message Description (37892 bytes)
>Signalling Unnumbered Links in CR-LDP (12534 bytes)
>Signalling Unnumbered Links in RSVP-TE (14605 bytes)
>Requirements for support of Diff-Serv-aware MPLS Traffic Engineering (33232
>bytes)
>Extensions to RSVP-TE and CR-LDP for support of Diff-Serv-aware MPLS Traffic
>Engineering (26349 bytes)
>LDP Extensions for Optical User Network Interface (O-UNI) Signaling (47991
>bytes)
>
>In charter
>==========
>Bullet 1
>-------
>Multiprotocol Label Switching Architecture (145511 bytes)
>Carrying Label Information in BGP-4 (14682 bytes)
>LDP Specification (271735 bytes)
>LDP State Machine (106866 bytes)
>RSVP-TE: Extensions to RSVP for LSP Tunnels (130237 bytes)
>Constraint-Based LSP Setup using LDP (87356 bytes)
>MPLS Support of Differentiated Services (130818 bytes)
>MPLS Loop Prevention Mechanism (94671 bytes)
>MPLS Label Switch Router Management Information Base Using SMIv2 (104632
>bytes)
>LDP Applicability (12396 bytes)
>MPLS Label Stack Encoding (47028 bytes)
>
>Bullet 2
>--------
>
>Bullet 3
>--------
>Use of Label Switching on Frame Relay Networks Specification (52911 bytes)
>MPLS using LDP and ATM VC Switching (46275 bytes)
>Generalized MPLS - Signaling Functional Description (94621 bytes)
>Generalized MPLS Signaling - CR-LDP Extensions (29232 bytes)
>Generalized MPLS Signaling - RSVP-TE Extensions (43771 bytes)
>
>Miscellaneous
>------------
>Applicability Statement for CR-LDP (13805 bytes)
>Applicability Statement for Extensions to RSVP for LSP-Tunnels (16573 bytes)
>
>- Vach

---

From: Vach Kompella <[email-masked]>
Date: Thu, 30 Nov 2000 11:49:25 -0800

I guess my motivation for sending that somewhat rough
classification was to see if there was enough
good content (or at least problem identification) in
the remaining drafts, so whether *this* MPLS WG shuts
down or not, the work goes on in a new MPLS-2 WG that
has a new charter addressing those issues.

George's email is more definitive, but if you filter out
what is in or out based on that, I don't believe there is
enough to make up a WG charter yet.  Maybe that should
be an agenda item in the non-existent agenda.

-Vach

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Thursday, November 30, 2000 10:07 AM
To: Vach Kompella; [email-masked]'
Subject: Re: What's in or out?

         --Tom