Subject: RE: Creating .txt with IETF Format

From: [email-masked]
Date: Fri, 17 Nov 2000 09:36:24 -0000

I find it kind of weird that the vast majority (read as 'overwhelming
consensus and far from rough running code') use Word/ppt and yet we are
forced to use this outdated mode for producing IDs.  This is just dogma to
me and I don't buy any of the arguments I have heard to retain this mode.
If IETF claim to act on a consenus basis then why not lets have a vote on
this?

neil

> -----Original Message-----
> From:	Pankaj K Jha [SMTP:[email-masked]]
> Sent:	Thursday, November 16, 2000 6:42 PM
> To:	C. Chen
> Cc:	mpls
> Subject:	Re: Creating .txt with IETF Format
> 
> Dear Cheng:
> 
> <I'm CC'ing to reflector, just in case someone else has similar problems>
> 
> Once you have made your .doc file, steps to making an IETF draft are
> simple:
> 
> - Go  to Printers, and select Add Printer
> - In the list of manufacturers for printers, look for Generic. Select
> Generic/Text
> 
> - This printer should appear in your printer list
> - When printing your .doc file, select this printer. This printer prints
> to a
> file. When asked for a file name, give a file name in your directory.
> Let's call
> it "note".
> 
> You'll see that all pages are getting printed as if they are going to a
> real
> printer.
> You should see a file name called "note.prn" in your directory.
> 
> I'm sure you have the program "crlf.exe" downloaded from IETF website. If
> you do
> not have it, get it from the website.
> 
> Then run the following line in DOS prompt:
> 
> "crlf note.prn note.txt"
> 
> The file "note.txt" is your IETF draft. Rename it to your flavor, and you
> are
> ready to submit.
> 
> The template is quite finicky about font sizes, paragraph settings, etc.
> Any
> deviations and you'll end up with a bizarre output. You need to pay
> attention to
> your fonts and spacing for header 1/2/3, etc. as well.
> 
> Should you need a sample word file, I can send you mine. It took me a
> while to
> figure it out, but  it works great now. You can cut and paste your
> document into
> this document to finish your work quickly.
> 
> Note that as long as you do not change font size, you can make your
> headers bold
> and of different colors, without any side effects. If you must use
> bullets, make
> sure the List Bullet has same font properties as your RFC Text.
> 
> Hope it helps.
> 
> -Pankaj
> 
> "C. Chen" wrote:
> 
> > Mr. Jha,
> >
> > Thank you very much for your kindness offer. Several people gave me some
> tips
> > but none of them works yet. Please adise me how you do it.
> >
> > Thank you very muvh in advance,
> >
> > Best Regards,
> >
> > Cheng C. Chen
> >
> > Pankaj K Jha wrote:
> >
> > > Did someone already reply to your question? If not, please let me know
> and I
> > > can write it for you.
> > > -Pankaj
> > >
> > > "C. Chen" wrote:
> > >
> > > > Does anyone know how to generate the .txt file from Microsoft workd
> file
> > > > while keep
> > > > the proper IETF draft format? I down load the word template from
> IETF
> > > > web site and
> > > > created a .doc file. However, when I tried tosave the file with .txt
> > > > extension. the
> > > > resulting .txt file is not in the write format.  Please advise me me
> how
> > > > to do it
> > > > right. Thank you very much in advance,
> > > >
> > > > Best Regards,
> > > >
> > > > Cheng C. Chen
> > > >
> > > > Bilel Jamoussi wrote:
> > > >
> > > > >    Part 1.1Type: Plain Text (text/plain)

---

From: Eric Gray <[email-masked]>
Date: Fri, 17 Nov 2000 06:53:34 -0500

Neil,

    Speaking as one who occasionally uses MS-Word, I
think you are very hard on them when you say that it is
"far from rough running code".  It does work a lot of the
time, you know.

--
Eric Gray

---

From: Rob Blais <[email-masked]>
Date: Fri, 17 Nov 2000 07:36:43 -0500 (EST)

Would it not be hypocritical of the IETF to both create and promote
open specifications (RFCs) while at the same time advocating or at least
accepting a proprietary document format such as MS-Word?  As one who 
has wasted far too much time on the blue screen of death and finally
made the switch back to Unix, I would very much be opposed to any
attempts to change the current open and portable document distribution
practices.  The IETF has reached almost Zen-like perfection in management
of documents.  I wish all standards organizations were this good!  It is
the epitomy of the KISS principle in action.  

If it ain't broke, don't fix it.  It sure doesn't look broken to me. 
I vote in favor of keeping the status quo. 

/rob

---------------------------------------------------------------------
Rob Blais                  [email-masked]          "The Internet?
MPLS Consortium Manager    Phone: 603-862-4569       Is that thing
ATM Operations Manager     Fax:   603-862-4181       still around?"
UNH InterOperability Lab   http://www.iol.unh.edu/   -Homer Simpson

---

From: theo <[email-masked]>
Date: Fri, 17 Nov 2000 14:54:33 +0100

Hi all,

Why don't you propose to microsoft to include a new add-on such as an
"ietf-converter" ?

theo