Subject: draft-ietf-mpls-diff-ext-07.txt

From: Francis Arts <[email-masked]>
Date: Thu, 30 Nov 2000 08:38:58 +0100

Hello,

The draft-ietf-mpls-diff-ext-07.txt defines 2 types of LSPs - E-LSPs and
L-LSPs. For the DIFF SERV object defined in this draft, also 2 variants
are defined -1 for E-LSPs and 1 for L-LSPs.

I have the following question: Why have L-LSPs been defined (instead of
defining just 1 type - E-LSPs)? According to my understanding all the
capabilities of an L-LSP can be obtained by using an E-LSP with the
proper PHB set.

Example: Assume that we want to establish an L-LSP for AF1 traffic. We
could achieve the same effect (an MPLS tunnel for Af1 traffic) by using
an E-LSP with 3 exp <--> PHB mappings:
** exp_af11 <--> AF11
** exp_af12 <--> AF12
** exp_af13 <--> AF13

Thanks for your answer.

Kind regards,

    Francis.

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Thu, 30 Nov 2000 10:25:06 +0200

Francis,
	Regarding your example:

	To the best of my understanding AF11, AF12 and AF13 are three DSCPs
belonging to the same PHB (AF1),
	expressing 3 different levels of drop precedence. So you have actually
given an excellnet example of
	an L-LSP (with the scheduling behavior inferred from the label and drop
precedence - from the EXP bits).

	A real example of an E-LSP would be an LSP carrying, say AF-1 and AF-2.
Such a sharing carries with
	it some difficult questions, i.e.how to split the aggregate bandwidth
allocated to an E-LSP between two (or more) PHBs
	with individual bandwidth reservations etc.

______________________________________________
With best regards,
Sasha Vainshtein
mailto: [email-masked]
phone: +972-3-7659993 (office)
fax:      +972-3-6487779 (office)

>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>Francis Arts
>>Sent: Thursday, November 30, 2000 9:39 AM
>>To: [email-masked]
>>Subject: draft-ietf-mpls-diff-ext-07.txt
>>
>>
>>
>>Hello,
>>