Subject: RE: draft-yu-mpls-rsvp-oif-uni-00

From: Fong Liaw <[email-masked]>
Date: Thu, 30 Nov 2000 11:15:15 -0800

Hi, Diego

The official name for ligthpath ID is now "Connection_ID".
We are still discussing (among authors) how this
object should be used and therefore where it should
show up in the messages.  Right now, we don't have
a clear definition of these from the requirement
but this will hopefully be resolved between the
carrier group in OIF and the signaling group authors soon.

Right now our proposal is the following:

"The Connection_ID object will be an optional
object in all RSVP messages. However, once a 
Connection_ID is assigned by the network, 
a user node MUST carry the object in every 
subsequent RSVP message it generates."
 
This phrase gives network the freedom of generating
or not generating a Connection_ID, and if they do 
generate one, a user node will play it back to 
the network.  A connection is still identified by
RSVP Session object, at the UNI. 

-Fong

>  -----Original Message-----
>  From: Diego Caviglia [mailto:[email-masked]]
>  Sent: Thursday, November 30, 2000 5:54 AM
>  To: [email-masked]
>  Subject: draft-yu-mpls-rsvp-oif-uni-00
>  
>  
>  
>  
>  Fong,
>                 I've seen that w.r.t. the OIF version of this 
>  draft a Lightpath
>  ID object is introduced but in the message definition I 
>  can't find it.
>  
>  If it is not a mistake, could someone explain in wich 
>  message Lightpath ID must
>  be inserted?
>  
>  Regards Diego.
>  
>

---

From: Guangzhi Li <[email-masked]>
Date: Thu, 30 Nov 2000 14:58:56 -0500

Fong:

From signaling point of view, let's clarify something first:
(1) who generate the "Connection_ID" ? The first-hop-router in the
network, right.
(2) Suppose that I am a user node and I want to setup a lightpath. I
send out a lightpath request throught UNI. Then the first-hop-router
will try to establish the lightpath.
(3) When will I get the connection_ID from the network?
(4) You said that a user node MUST carry the object in every subsequent
RSVP messages it generates. You mean "refresh messages, teardown
messages, or update messages" ?
(5) If my understanding is correct, why should a user node bother
"Connection_ID"?
(Connection_ID = AS number+source address+local_id). Any ID simpler will
work between UNI.

Please give me more explanation. Thanks,

-- Guangzhi