Subject: Re: Doubts in draft-ietf-mpls-te-mib-04.txt

From: "Faisal S. Naik" <[email-masked]>
Date: Fri, 3 Nov 2000 01:15:26 +0500

Hello Thomas,

I feel Richard is right in saying that how will the management software tell
the operator in case of a failed LSP creation.??? Why do u feel that sending
a trap for this type of information will adversely affect the performance of
a particular network.
Any comments.
Bye

-----Original Message-----
From: Thomas D. Nadeau <[email-masked]>
To: Morgan, Richard <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: Thursday, November 02, 2000 10:57 PM
Subject: RE: Doubts in draft-ietf-mpls-te-mib-04.txt

>
>         Hi Richard,
>
>>I note that there is not a trap to signal that an LSP has been configured,
>>only that it has come up or has gone down. Say I have a piece of
management
>>software that moniters LSPs on a device would I be notified should someone
>>attempt to create an LSP but it failed, ie it never changed state from
down
>>and hence it never sent a notification trap?
>
>         No, according to my understanding (and implementation)
>of the current traps in the MPLS-TE-MIB, no trap would
>be issued for mis-configuration of a tunnel. I am however,
>open to the possibility of adding such a trap if there
>is enough support for it. I would like to hear from others
>as to what their opinion is. In particular, I would like
>to hear from operators, since such traps can adversely
>impact or improve their networks.
>
>         --Tom
>
>
>
>
>>Thanks
>>
>>Rich
>>
>>
>> > Hello Thomas
>> >
>> > I have the following  doubts and can you please clarify.
>> >
>> > 1) The Objects of the traps mplsTunnelUp, mplsTunnelDown, and
>> > mplsTunnelRerouted have been
>> > specified as
>> >  mplsTunnelIndex,
>> >  mplsTunnelInstance,
>> >  mplsTunnelAdminStatus and
>> >  mplsTunnelOperStatus.
>> >
>> > Since we use  mplsTunnelIndex, mplsTunnelInstance and
>> > mplsTunnelIngressLSRId
>> > (triplet) to uniquely identify a Tunnel, the
>> > mplsTunnelIngressLSRId value
>> > too will be required as an object during the Trap generation.
>> > Should this
>> > value too be passed when a trap is generated?
>> >
>> > 2) The Description for "mplsTunnelTrapEnable" deals with the
>> > generation of
>> > mplsTunnelUp and mplsTunnelDown. Should the
>> > mplsTunnelRerouted be added too?
>> > or mplsTunnelRerouted trap needs to generated irrespective of the
>> > "mplsTunnelTrapEnable" value?
>> >
>> > thanks in advance
>> > with best regards
>> > Mani
>> >
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Nov 2000 15:27:29 -0500

>a trap for this type of information will adversely affect the performance of

         It is not that I feel either way. I want to hear
how operators feel. It is their networks which will be
affected by the increased load of additional inform
traffic.  BTW, one option is to have the NMS which just
tried to create the tunnel go back and check its
operStatus after a second or two. If the operStatus is
still down, then the tunnel was not signalled correctly.

         --Tom