Subject: Re: Traffic engineering and RSVP

From: "jchen" <[email-masked]>
Date: Mon, 27 Nov 2000 11:23:23 -0800 (PST)

Mike Badil wrote:
> 
> Hi
> 
> I confused  when I read traffic engineering with MPLS.
> 
> My question is:
> 
> MPLS is combination of layer 2 swithing and layer 3 routing. Traffic eng. is
> part of layer 3. In MPLS route(LSP) is established in advance according to
> the constraints. in other word, instead of choosing shortest path, it choose
> the path which satisfy its requirments, and to make link utulization better.
> In order to have done this with MPLS there are some works which say that
> OSPF,IS-IS can be modified by adding constraint to it.
> 
> That is clear so far,
> 
> I wondering that whether we can have those traffic engineering conditions be
> satisfied by other tech.
> 
> For example; RSVP-Intserv set up route in advance also. If we use extended
> OSPF,IS-IS etc.algorithm with Intserv-RSVP as we use in MPLS,
> we can choose the path which satisfy our constraints instead of choosing
> Shortest path. Link load balancing can be done as in MPLS. So most of
> traffic engineering requirements will be satisfied.(let don't consider
> scalibility problem with RSVP now). Or it can work any other technology
> which use RSVP.
>

The problem is in applying filter at every node to make sure your IP
packet
is following the selected path. Hence data path becomes slow.

- sudheer
 
> What am I missing here?
> 
> _________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.
> 
> Share information about yourself, create your own public profile at
> http://profiles.msn.com.

---

From: "jchen" <[email-masked]>
Date: Mon, 27 Nov 2000 11:23:25 -0800 (PST)

Good that there are routers who does the 5 tuple lookup 
for 1 million connections at line rate of OC-48 :-)
But do we need them in the core?

- sudheer

Bora Akyol wrote:
> 
> I would not jump on this so fast, there is at least one router out there that can
> do line rate 5-tuple lookups for many, many rules.
> 
> Just because **you** don't know how to do it, doesn't mean it can't be done.
> 
> Bora
> 
> Sudheer Dharanikota wrote:
> 
> > Yes sir.. you are missing many things.
> >
> > TE is mainly used for core. In core nobody in right mind
> > will do 5 tuple lookup on the the Ip packet :-)
> >
> > - sudheer
> >
> > Rajeev Manur wrote:
> > >
> > > see below...
> > >
> > > -----Original Message-----
> > > From: Sudheer Dharanikota [mailto:[email-masked]]
> > > Sent: Thursday, October 19, 2000 7:21 AM
> > > To: Mike Badil
> > > Cc: [email-masked]
> > > Subject: Re: Traffic engineering and RSVP
> > >
> > > Mike Badil wrote:
> > > >
> > > > Hi
> > > >
> > > RAJEEV> I thought almost all the boxes today perform complete packet
> > > processing at line-rate with or without the application of packet filters. I
> > > don't see the relevence of the above statment. Am i missing anything..
> > >
> > > - sudheer
> > >
> > > > What am I missing here?
> > > >

---

From: "jchen" <[email-masked]>
Date: Mon, 27 Nov 2000 11:23:27 -0800 (PST)

Rajeev:

See below.

Rajeev Manur wrote:
> see below
> Sent: Thursday, October 19, 2000 11:45 AM
> To: Rajeev Manur
> Cc: Mike Badil; [email-masked]
> RAJEEV> I never said anybody would or would not do 5 tuple lkup in the core.
> All i am saying is that your statement "Hence data path becomes slow" does
> not make any sense, because as far as i know today's packet processors can
> handle this without affecting the line-rate performance..

Yes.. most of the router vendors have to do 5 tuple lookup for
some reason or the other. But the following should be the
considerations.

From data plane point-of-view:

 1. How many look ups do you want to do?
 2. Does other routers in the same domain (or AS) do the same for 
    the traffic (at line rate)?
 3. What are the line rates we are talking about?

From control plane point-of-view:

 1. Does make sense to have the state kept for all these intserv conns?
 2. Do we (being ISPs) have to care about the individual connections
    from the other ISPs?

- sudheer

> with regards,
> Rajeev.
> > > MPLS is combination of layer 2 swithing and layer 3 routing. Traffic
> eng.
> > is
> > > I wondering that whether we can have those traffic engineering
> conditions
> > be
> > > satisfied by other tech.
> > >