Subject: RE: ce range in l2 mpls vpns

From: "Metz, E.T." <[email-masked]>
Date: Thu, 23 Nov 2000 11:43:56 +0100

hello juha,

it is the pe that is configured with the parameters you mention, not the ce.

using these, the pe automatically establishes lsp's to other pe's,
effictively carrying the ce-to-ce circuits across the mpls backbone. i think
ce configuration could still be as you described below (or something similar
to that).

cheers,
	eduard

> -----Original Message-----
> From: Juha Heinanen [mailto:[email-masked]]
> Sent: donderdag 23 november 2000 11:31
> To: [email-masked]
> Subject: ce range in l2 mpls vpns
> 
> 
> this may have been discussed already, but why does
> draft-kompella-mpls-l2vpn-01.txt require that the ce is 
> configured with
> the ce id, the ce's range and all labels in that range?  why can't the
> ce dynamically add a new neighbor when it learns about a new label via
> lmi, ilmi, or a corresponding mpls protocol?
> 
> i'm asking this because the proposed practice would be a step 
> backwards
> from how people have been running atm or fr vpns for years using cisco
> cpe routers, where the only thing i need to configure is the
> (sub)interface and an ip address.
> 
> here is a frame relay example:
> 
> interface Serial <number>
>   ip address <address> <mask>
>   encapsulation frame-relay IETF 
>   ip ospf network point-to-multipoint 
> 
> and here is an atm example:
> 
> vc-class atm broadcast 
>   broadcast 
> 
> interface ATM <number>
>   atm pvc 2 0 16 ilmi 
>   atm ilmi-pvc-discovery subinterface 
> 
> interface ATM <number>/<number> multipoint 
>   ip address  address mask 
>   ip ospf network point-to-multipoint 
>   class-int broadcast 
> 
> dlcis or atm vcs of the other sites are learned dynamically via lmi or
> ilmi.  as you see in above, the cpe doesn't even need to be configured
> with its own ce id.
> 
> -- juha
>

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 23 Nov 2000 12:48:05 +0200 (EET)

> it is the pe that is configured with the parameters you mention, not

that is not what the i-d says:

4.2.1. CE Configuration

   Each CE that belongs to a VPN is given a "CE ID".  CE IDs must be
   unique in the context of a VPN.  We assume that the CE ID for CE-k is
   k.  Each CE is also configured with a maximum number of CEs that it
   can connect to; this is the CE's "range".

   Each CE is configured to communicate with its corresponding PE with
   the set of DLCIs given above; for example, CE0 is configured with
   DLCIs 100 through 109.  OSPF is configured to run over each DLCI. 

-- juha