Subject: RE: Label space of a label advertised through MPLS-BGP

From: Shahram Davari <[email-masked]>
Date: Mon, 27 Nov 2000 12:26:19 -0800

Hi James,

 One of the reasons that per-interface label spaces 
> were introduced is
> so that ATM and FR interfaces would only allocated label 
> values for LSPs that
> it was going to use.  Thus allowing them to stretch there 
> limited number of
> VCs or DLCIs farther.  By doing as you suggest your "wasting" 
> label values.
>

ATM and FR don't need per-platform label space, because there is no hierarchy in ATM/FR.
 
> When allocating an N level label (where N is > 1) it should 
> be allocated from
> the same label space as all of the N-1 labels that may 
> possible tunnel this
> label.  When N = 1, the value should be allocated from the label space
> associated with the set of possible interfaces that will receive this
> label. 
> This assumes that any service allocating N level labels MUST 
> know the set of
> LSPs in which it's label values will have meaning.  When N = 
> 1 the service
> MUST know what set of interfaces its label values will have meaning.
> 

All levels of hierarchy use the same label space. There is no notion of a separate label space per hiererchy level.

Regards,
-Shahram

---

From: "James R. Leu" <[email-masked]>
Date: Mon, 27 Nov 2000 15:04:10 -0600

Hello Shahram,

> ATM and FR don't need per-platform label space, because there is no hierarchy in ATM/FR.

Which draft makes this assertion?  I consider hierarchy to include the case
where the top label is ATM/FR and the rest of the label stack is composed of
generic labels under the require "NULL" label.

> All levels of hierarchy use the same label space. There is no notion of a separate label space per hierarchy level.

Exactly.  All of the values in the label stack must be in the same ILM.
The values in the ILM are pulled from the same label space.

The problem arises when considering multiple interfaces and how to populate
those ILMs with all of the values needed to terminate possible multiple
levels of "tunnel" LSPs _and_ the service related labels.

Jim
-- 
James R. Leu