Subject: draft-ietf-mpls-generalized-signaling-00 questions

From: "Lipovetsky, Sergey" <[email-masked]>
Date: Wed, 22 Nov 2000 18:33:04 +0200

Hi All,

The draft-ietf-mpls-generalized-signaling-00 defines the following LSP
Encoding Types in the Generalized Label Request:

                   Value       Type
                   -----       ----
                     1         Packet
                     2         Ethernet
                     3         ANSI PDH
                     4         ETSI PDH
                     5         SDH
                     6         SONET
                     7         Digital Wrapper
                     8         Lambda (photonic)
                     9         Fiber

The draft-kompella-ospf-gmpls-extensions-00.txt defines the following
related sub-TLVs of the TE Link TLV:

Link descriptor sub-TLV with Link Encoding Type
      Value        Link Encoding Type
          1        Standard SONET
          2        Arbitrary SONET
          3        Standard SDH
          4        Arbitrary SDH
          5        Clear
          6        GigE
          7        10GigE

and Link Mux Capability sub-TLV (draft-ietf-mpls-lsp-hierarchy-01.txt)

       Value         Link Mux Capabilities
           1         Packet-Switch Capable-1 (PSC-1)
           2         Packet-Switch Capable-2 (PSC-2)
           3         Packet-Switch Capable-3 (PSC-3)
           4         Packet-Switch Capable-4 (PSC-4)
          51         Layer-2 Switch Capable  (L2SC)
         100         Time-Division-Multiplex Capable (TDM)
         150         Lambda-Switch Capable   (LSC)
         200         Fiber-Switch Capable    (FSC)

Is there any way to check that an LSP with a given LSP Encoding Types can be
carried over a link with given link encoding type and link mux capability? I
can't see a direct mapping.

Is there other link parameters relevant to this checking?

Other questions relate to the to the CR-LDP TLV encoding.
0x0901 - Generalized Label Request
         draft-ietf-mpls-diff-ext-07.txt uses this value for Diff-Serv
         Which one is correct?
0x0902 - Generalized Label Request with SONET/SDH label range and
         Generalized Label
         Which one is correct?
0x0904 - Label Set and
         Suggested Label
         Which one is correct?

Will 0x0903 be used for the Waveband Label?

How can a downstream LSR know that a waveband allocation is requested?

Thank you in advance,
Sergey
=====================================
Sergey Lipovetsky          +972-9-7663288 (ext.207)
Virata Corporation, Haharoshet 2, Kfar-Saba, Israel

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Thu, 23 Nov 2000 11:25:18 -0500

>          draft-ietf-mpls-diff-ext-07.txt uses this value for Diff-Serv

  Take the diff-ext as correct. I screwed up and collided with it.
Sorry. 

> 0x0902 - Generalized Label Request with SONET/SDH label range and

  I will pick a new range and reassign these in the next day or so.
Stand by...

> How can a downstream LSR know that a waveband allocation is requested?

  By context. There is almost no difference between lambda and lambda 
band as far as tandem LSRs are concerned. 

> Sergey

  Cheers,

  Peter Ashwood-Smith

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Thu, 23 Nov 2000 11:25:18 -0500

Cheers,

  Peter Ashwood-Smith

---

From: Yangguang Xu <[email-masked]>
Date: Mon, 27 Nov 2000 11:12:02 -0500

> band as far as tandem LSRs are concerned.

This may be true in the signaling "implementation" point of view and only in
case of some pure OXCs (no OEO). Depending on different technologies, even pure
OXC may need to differentiate lambda and lambda band. They have different
optical domain requirements.

In the functional point of view, they are quite different. In OTN, Lambda is in
OCh layer, lambda band is in OMS layer. Waveband LSPs and lambda LSPs are
created at different time and for different reasons. Waveband paths might be set
up as tunnels (or FA) for OCh connections.

Yangguang