Subject: RE: Doubts in draft-ietf-mpls-te-mib-04.txt

From: "Morgan, Richard" <[email-masked]>
Date: Thu, 2 Nov 2000 17:41:53 -0000

I note that there is not a trap to signal that an LSP has been configured,
only that it has come up or has gone down. Say I have a piece of management
software that moniters LSPs on a device would I be notified should someone
attempt to create an LSP but it failed, ie it never changed state from down
and hence it never sent a notification trap? 

Thanks

Rich

> Hello Thomas
> 
> I have the following  doubts and can you please clarify.
> 
> 1) The Objects of the traps mplsTunnelUp, mplsTunnelDown, and
> mplsTunnelRerouted have been
> specified as
>  mplsTunnelIndex,
>  mplsTunnelInstance,
>  mplsTunnelAdminStatus and
>  mplsTunnelOperStatus.
> 
> Since we use  mplsTunnelIndex, mplsTunnelInstance and 
> mplsTunnelIngressLSRId
> (triplet) to uniquely identify a Tunnel, the 
> mplsTunnelIngressLSRId value
> too will be required as an object during the Trap generation. 
> Should this
> value too be passed when a trap is generated?
> 
> 2) The Description for "mplsTunnelTrapEnable" deals with the 
> generation of
> mplsTunnelUp and mplsTunnelDown. Should the 
> mplsTunnelRerouted be added too?
> or mplsTunnelRerouted trap needs to generated irrespective of the
> "mplsTunnelTrapEnable" value?
> 
> thanks in advance
> with best regards
> Mani
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Nov 2000 12:52:21 -0500

Hi Richard,

>and hence it never sent a notification trap?

         No, according to my understanding (and implementation)
of the current traps in the MPLS-TE-MIB, no trap would
be issued for mis-configuration of a tunnel. I am however,
open to the possibility of adding such a trap if there
is enough support for it. I would like to hear from others
as to what their opinion is. In particular, I would like
to hear from operators, since such traps can adversely
impact or improve their networks.

         --Tom

---

From: "Morgan, Richard" <[email-masked]>
Date: Thu, 2 Nov 2000 18:46:39 -0000

Thanks for the speedy reply.

On further thought it also occurs to me that a management system would also
be interested in a LSP resizing its bandwidth reservation.

Rich

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Nov 2000 14:08:40 -0500

Hi,

>be interested in a LSP resizing its bandwidth reservation.

         We have added bandwidth resizing as part of
the mplsTunnelRerouted trap in version -05, which
will be out shortly.

         --Tom

---

From: "Morgan, Richard" <[email-masked]>
Date: Wed, 8 Nov 2000 13:40:35 -0000

Excellent sounds like a good idea to me.

Rich

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 7:09 PM
> To: Morgan, Richard
> Cc: [email-masked]
> Subject: RE: Doubts in draft-ietf-mpls-te-mib-04.txt
> 
> 
> 
>          Hi,
>