Subject: RE: draft-ietf-mpls-te-feed-01

From: "Kullberg, Alan" <[email-masked]>
Date: Thu, 9 Nov 2000 11:04:02 -0500

Hi Darek,

Will the draft be updated to specify that U and F MUST be set to 1
and that the feedback TLVs MUST be dropped when exiting an area
or an AS?

Thanks,

Alan Kullberg

-----Original Message-----
From: Darek Skalecki [mailto:[email-masked]]
Sent: Thursday, November 09, 2000 8:55 AM
To: Bui, Khanh
Cc: [email-masked]
Subject: Re: draft-ietf-mpls-te-feed-01

"Bui, Khanh" wrote: 
Hi, 
I have a couple of questions on this draft. 
1. How should the U and F bits be set in the feedback TLV? 
   Should they both be set to 1 so that the message containing 
   this TLV will go through any node that doesn't support 
   feedback TLV, and eventually will get to the source node?
The idea is that nodes which do not support Feedback TLVs simply pass these
TLVs transparently. This obviously can create discontinuity in the
information that is fed back, i.e. information about some links along the
path can be omitted. 
  
2. How should the feedback TLV be handled if the message 
   containing this TLV travels from one autonomous system or 
   from one IGP area to another?  Should the TLV be filtered 
   out at the edge node before entering the other AS or other 
   IGP area?
Yes, all the Feedback TLVs present on a message should be dropped when the
message exits AS or IGP area through an edge node. 
  
Thanks in advance, 
Khanh
-- 
Darek Skalecki
Nortel 
(613) 765-2252

---

From: "Darek Skalecki" <[email-masked]>
Date: Fri, 10 Nov 2000 07:00:16 -0500

> and that the feedback TLVs MUST be dropped when exiting an area

Yes the next version of the draft will make these points clear.

Darek

--
Darek Skalecki
Nortel
(613) 765-2252