Subject: re: LSR MIB, OutSegment Index

From: "Friedeborn, William" <[email-masked]>
Date: Fri, 17 Nov 2000 14:22:45 -0500

I've been working with the LSR and TE MIBs for a while and have run into
some implementation problems with the OutSegment objects. In a monolithic
environment it is pretty straight forward to implement the OutSegment table.
However, in a distributed environment, this is quite challenging.

What is the reasoning behind using an IndexNext object to get the OutSegment
Index? The InSegment table is indexed by IfIndex and Label, which makes it
very easy to distribute. I can look at the ifIndex and know what line card
has the InSegment object. On the other hand the OutSegment table only has
the abtract OutSegmentIndex. I would have to go to each line card to find
out which one has that index, or maintain lists of indexes to ifIndexes on
each line card.

It just seems like an added indirection that creates more complexity. Am I
missing something here?

Thanks,
Bill

---

From: "Cucchiara, Joan" <[email-masked]>
Date: Sun, 19 Nov 2000 18:07:20 -0500

Bill,

This issue was raised during the last call
of the LSR MIB by yours truly.  

I agree with you that the OutSegment Table should 
ifIndex and OutLabel as indices.   Also, this would
mean that the XC Table would change to include these
as indices also. 

Was this change to the OutSegment and XC Tables 
overlooked?  

   Thanks, Joan

> -----Original Message-----
> From: Friedeborn, William [mailto:[email-masked]]
> Sent: Friday, November 17, 2000 2:23 PM
> To: [email-masked]'
> Subject: re: LSR MIB, OutSegment Index
> 
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Sun, 19 Nov 2000 22:13:09 -0500

Hi,

         To be honest, my implementation is on
a monolithic subagent model. I have been
able to successfully implement the MIB as it
is currently defined. I have heard that others
have been able to implement it as well.

         I am interested to hear what
implementation others are experiencing using
the current indexing.

         --Tom

---

From: "Friedeborn, William" <[email-masked]>
Date: Mon, 20 Nov 2000 10:11:07 -0500

What I ended up doing was dividing the index range between the line cards
and assigned indexes appropriately. I thought a little bit more on this and
maybe it's not so bad (other than it limits the number of outsegments).

thanks for the response!
Bill F.

-----Original Message-----
From: Cucchiara, Joan [mailto:[email-masked]]
Sent: Sunday, November 19, 2000 6:07 PM
To: 'Friedeborn, William'; [email-masked]'
Subject: RE: LSR MIB, OutSegment Index

Bill,

   Thanks, Joan