Subject: RE: E-LSP or L-LSP

From: [email-masked]
Date: Wed, 22 Nov 2000 09:29:07 -0600

Hi

E-LSP is used when DSCP DiffServ field is mapped to the EXP field in the
MPLS header.
L-LSP is used when DSCP DiffServ field is mapped to the EXP+LABEL fields
in the MPLS header.

Thanks.
------------------------------------------------------------------------
- 
Wesam Alanqar 
Member of Technical Staff 
Technology Concepts, Innovations and Evaluation (TCIE) 
Technology Planning & Integration- Sprint TP&I 
9300 Metcalf Avenue 
Overland Park, KS 66212-1463 
Phone: 913-534-5623 
Fax: 913-534-3485 
------------------------------------------------------------------------
- 

> -----Original Message-----
> From: mastropietro [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 4:05 AM
> To: mpls
> Cc: mastropietro
> Subject: E-LSP or L-LSP
> 
> 
> Hi All,
> I am a novel researcher on MPLS and TE for Co.Ri.Tel ( Rome, Italy)...
> Is there anyone that can help me to understand when E-LSPs or L-LSPs
> actually should be used?
> Thanks in advance
> 
> Simeone Mastropietro
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Tue, 28 Nov 2000 08:50:58 -0800

Daniel,

> 1.) How does the "admission control for each supported BA" work?
>     How does the ingress LSR split up the aggregated BW request into
>     a BW request for each BA? What is the rational to do admission
>     control for the BAs only at the edge?

Since we know the BW of the established E-LSP, every time that we admit a requested BA in to this LSP, we can subtract its BW from the E-LSP BW, and we can admit till we exhaust our E-LSP BW. 

>     I don't find this very similar to the Aggregate RSVP 
> admission control.
>     There, the requirement of each flow is known before the 
> flows are aggregated.
>     This is not the case for E-LSPs.

Let's assume before establishing the E-LSP you have a few request for a number of BAs. You could add their BW request and find the total BW and establish an E-LSP for that BW (this is the same as aggregate RSVP). Now if a new request comes in, you could either reject is, or modify the E-LSP BW or establish a new LSP. 

> 
> 2.) If admission control for E-LSPs is only based on the 
> aggregate bandwidth,
>     it becomes difficult to do a reliable admission control 
> for L-LSPs. For L-LSP
>     admission control, the LSRs need to know the unreserved 
> bandwidth per OA.
>     How is it possible to do book-keeping for unreserved 
> bandwidth, if E-LSPs
>     are admitted on the aggregate?

Very good question. I didn't claim that E-LSP with aggregate BW signaling is perfect. If one needs good BW control he can always use L-LSP. However, one solution might be to use different PHBs (or different PHB instances) for the E-LSPs and L-LSPs. 

> 
> Maybe a solution is to extend the signaling and include optionally the
> BW requirements per OA for E-LSPs.
>

This option has been discussed by the MPLS WG as there was no consensus on it.

Regards,
-Shahram
 
> Regards,
> -Daniel