Subject: Re: Hierarchies

From: Jeremy Lawrence <[email-masked]>
Date: Mon, 11 Dec 2000 12:07:04 +1100

At 20:57 12/09/2000 +0530, Abhijit wrote:

>Hello all,
>
>Can anyone point me to a scenario where there will be 4-5 levels of
>hierarchies in an MPLS domain? I am not able to grasp that particular
>scenario... 

Sure.

Assume a provider A is doing rfc2547(bis) VPNs, using two labels,
and MPLS TE, using an additional label. Three labels so far.

A may allow a VPN, X, to transport MPLS packets rather than IP
packets. Assume that the "customer" using X is another
provider, B, who is using X as the backbone for their MPLS
network. B may, in turn, be offering an MPLS VPN service,
using two MPLS labels. 

That's nominally five labels. However, the "top" label of B's label
stack will be at the same level as the third-top of A's
(that label is what B uses to tell A "transport this packet
to this specific site in my VPN"). So, A will transport MPLS
packets with four labels. (I didn't realize this until I
saw it in a presentation two weeks ago. :)

B may in turn be offering MPLS rather than IP transport to
a provider C, and so on. So, the number of labels carried
by A, and the number of levels of administration, may be
arbitrary.

Regards,

Jeremy Lawrence

---

From: Grenville Armitage <[email-masked]>
Date: Sun, 10 Dec 2000 20:45:44 -0800

> >hierarchies in an MPLS domain? I am not able to grasp that particular
	[..]
> So, A will transport MPLS

Although this might be the answer Abhijit is looking
for, I'm not comfortable with calling this "four labels"
being carried by domain A. Your formulation requires domain A
to only know (and ever need to interpret) three levels of
labels - anything else deeper inside the MPLS frame at the
third label level is simply opaque payload to the LSRs in
domain A. IMHO, naturally ;)

cheers,
gja

---

From: Vincent Hamrick <[email-masked]>
Date: Wed, 13 Dec 2000 14:09:41 -0500

What presentation did you see this in?  Is it available on the web?  I have 
been struggling with implementation of the carrier's carrier concept in 
2547bis, and I would love to see it on paper (so to speak).

Thanks,
Vincent Hamrick

---

From: Jeremy Lawrence <[email-masked]>
Date: Fri, 15 Dec 2000 12:30:12 +1100

Vincent,

The presentation doesn't seem to be publicly available, but
a colleague recommended the carrier's carrier coverage
in these books:
_MPLS: Technology and Applications_, Bruce S. Davie, Yakov Rekhter
_MPLS and VPN Architectures_, Jim Guichard, Ivan Pepelnjak

Regards,

Jeremy Lawrence