Subject: Re: Lack of outgoing label was Re: (Reply) RE: (Reply)

From: Martin Picard <[email-masked]>
Date: Wed, 06 Dec 2000 12:09:01 -0500

Keith,

Wether or not the LSR are capable of popping the stack should
be determined at session initialization according to mpls-arch.
But, this is assumed to be the case when peer LSRs are not
ATM or F/R LSRs (lsp-spec section 6).

Now, when an LSRs knows that its peer is capable of popping the
stack, it should distribute an Implicit Null label for its ultimate
destination prefixes  (mpls-arch section 4.1.5).

Then, the upstream LSR has no choice but to do penultimate hop
pop since it's been requested with Implicit Null. (mpls-arch section 3.16)

Although designed to be optional and flexible eventually, it looks
like for now, with LSRs not ATM or F/R, the penultimate hop pop
behavior is optionnal but "ASSUMED" for now.

mp

>
>
>
> According to section 3.16 of MPLS arch,
>
> "An LSR which is capable of popping the label stack at all MUST do
>  penultimate hop popping when so requested by its downstream label
>  distribution peer."
>
> So I assume that when you say PHP is optional and not mandatory,
> you mean the downstream LSR can optionally choose whether or not
> to request PHP.
>
> However, it appears that the upstream LSR is required to support
> PHP (if it is capable of popping the label stack at all).
>
> Do you agree?
>
> Keith
>
>
>
> > RE: Lack of outgoing label was Re: (Reply)
> > RE: (Reply)Yes, you are right Eyad.
> > Penultimate Hop Pop is an optional behavior.
> > mp
> >
> >   ----- Message d'origine -----
> >   De : Eyad Saheb
> >
>
>

----------------------------------------------------------------------------
----

À : 'Martin Picard'
>   Envoyé : 6 décembre, 2000 10:14
>   Objet : RE: Lack of outgoing label was Re: (Reply) RE: (Reply)
>
>
>   Last I looked, PHP was not a mandatory req in the MPLS arch.
>
>   Eyad

---

From: Serge Maskalik <[email-masked]>
Date: Tue, 12 Dec 2000 15:51:18 -0800

IMO, the network operator should have a choice whether the 
  explicit or implicit null values are signalled. One may want
  to do ultimate hop popping instead of PHP to preserve the 
  contents of the EXP field at the egress LSR. This is also 
  applicable to single hop LSPs, in case of which, traffic
  would not be encapsulated if implicit null value is signalled.
  Most implementations today do not support such control knob.

	- Serge 

-- 
 ---------------------
|Serge Maskalik       |
|Sr. Network Architect|
|iVMG, Inc.           |
|408.468.0480 office  |
|408.507.7374 mobile  |
 ---------------------

---

From: Martin Picard <[email-masked]>
Date: Tue, 12 Dec 2000 19:15:58 -0500

Serge,

   I can see why one would want to carry the semantic of the
   EXP field all the way to the egress LER but it doesn't mean
   that it has to be carried via the EXP bits of the MPLS header.
   In fact, at some point or another, these bits will be mapped to
   the IP-ToS bits (precedence), so this could very well be done
   on the penultimate hop.

   Although it sounds nice to have a control knob for this, the
   question would be "Is there a definite need for this ?"
   "Why would you want to disable optimization ?"

mp