Subject: RE: [IP-Optical] GMPLS - Hierarchies

From: Heiles Juergen <[email-masked]>
Date: Wed, 6 Dec 2000 17:53:05 +0100

John,

I agree that at the endpoints of a trail (in ITU terms), where the signal that is connected through the network is terminated, the same processing for the payload is needed (either multiplexing or any other kind of adaptation). However this is not part of the LSP and of the LSR functionality. Consider a Optical Channel/lambda LSP. According to the document - as I read it -  the LSP is should be terminated on a LSR with Lambda switch capable (LSC) interfaces (e.g. an optical switch), hwoever the paylaod of the Optical Channel is a SDH or IP signal which require TDM or packet processing.
For sure you want to connect your signal between endpoints with the same client processing, but this is only of interest for the selection of the correct endpoints, but not for the LSP set-up itself. The LSP set up should only care about the signal itself and not about its payload. FAX and telphones use the same infrastrucutre for the setup of the connection, you have to be shure to connect the same endpoints by using up to correct number or you have a automatic selection of the correct payload processing using signaling. This signaling should only apply to theendpoints and not to intermediate  nodes.

Furthermore a LSP -at least for circuit switching - doesn't have to start and end at the trail termination where you extract your payload. A LSP could be used only for a sub part of the overall connection, e.g. a DS1 signal starts in a user domain with tradional TMN path setup or even manual connections, the DS1 comes to a operator which uses GMPLS for path -setup (in this case a permanent connection set-up by himself as the user doesn't support the UNI). The LSP starts in the middleof the overall DS1 connection and no access to the paylaod of the DS1 is requried at that point.

	Regards

	Juergen

> -----Original Message-----
> From:	John Drake [SMTP:[email-masked]]
> Sent:	Wednesday, December 06, 2000 5:14 PM
> To:	'Heiles Juergen'; [email-masked]
> Cc:	[email-masked]
> Subject:	RE: [IP-Optical] GMPLS - Hierarchies
> 
> Jergen,
> 
> An LSP has an two endpoints.  At the ingress endpoint, a node is
> multiplexing stuff into a given LSP.  At the egress endpoint, a node is
> demultiplexing stuff from that LSP.  If the ingress and egress endpoints
> aren't multiplexing and demultiplexing stuff consistently, how is stuff able
> to successfully transit the LSP?
> 
> Thanks,
> 
> John 
> 
> -----Original Message-----
> From: Heiles Juergen [mailto:[email-masked]]
> Sent: Wednesday, December 06, 2000 4:34 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [IP-Optical] GMPLS - Hierarchies
> 
> 
> draft-ietf-mpls-generalized-signaling-01 mentions in the introduction a
> hierachy with fiber switching at the top followed by lambda, time-slot and
> packet switching and clearly distinguish between these levels. I don't agree
> with this view that a LSP starts and ends on the same LSR type and onyl
> nesting of LSPs of different LSR types is possible.
> Take for example an optical cross-connect that switches fiber between its
> ports (=> fiber switch capable). The single or multiple lambdas on this
> fiber might be directly after the cross-connect or later combined with other
> signals from other fibers in a WDM system => (lambda switch capable) or a
> TDM technique is used to combine several of these signals to a higher
> bandwidth signal (e.g. going from 2.5 to 10 Gbit/s) (=> time switch
> capable). So a LSP that starts at LSC device ends up at a TSC device and
> might have a LSC device in between. Even an interchange of LSPs between
> packet and circuit switch capable devices is possible, take for a example
> circuit emulation via ATM. With circuit emulation you can also have a LSP
> that starts on a TSC device nested into a LSP that starts on a PSC device.
> A LSP represents a connection through the network/sub-network for a certain> 
> signal. This is independent of the switching technologies along the route
> and at the end as long as the specific signal is supported. At both ends
> access to the specific signal has to be provided, but it doesn't matter if
> e.g. a 1.5 Mbit/s signal is transported on a time-slot of a TDM system, on a
> single wavelength of a WDM system (not economic), over a CDMA radio system
> or with circuit emulation over an ATM network.
> The Hierarchy is defined by different signals nested into each other
> (client/server relationship), but not by the switching types.
> 
> Regards
> 
> Juergen Heiles
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> IP-Optical mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/ip-optical

---

From: Maarten Vissers <[email-masked]>
Date: Thu, 07 Dec 2000 10:49:51 +0100

All:

It might be the moment to introduce some more terminology to
differentiate between the two cases. In the ATM/FR interconnection the
terms "network interworking" and "service interworking" are being used.
Refer e.g. to FRF.5 and FRF.8 (see
http://www.frforum.com/5000/5000index.html).

This has then be used as basis for an extension of ITU-T Rec. G.805:
- network interworking has been present in G.805 from day one as
  the default "client/server relation", in which the complete client
  signal (i.e. actual traffic plus trail overhead) is transparently
  transported within the payload of the server signal
- service interworking has been added (section 5.5/G.805 (03/00) in  
  the form of a generic definition of "layer network interworking".
  The importance here is that not only the traffic is forwarded, but 
  also the associated trail overhead/OAM information. 
  
--------------------
5.5/G.805 (03/00) Layer network interworking

The objective of layer network interworking is to provide an end-to-end
trail between different types of layer network trail terminations. This
requires interworking of characteristic information as different layer
networks have per definition different characteristic information. In
general the adapted information of different layer networks for the same
client layer network is also different, although this is not necessarily
the case. Layer networking may therefor require the interworking of
adapted information.

The trail overhead of a layer network can be defined in terms of
semantics and syntax. Provided that the same semantics exist in two
layer networks, the trail overhead can be interworked by passing on the
semantics from one layer network to the other in the appropriate syntax,
as defined by the characteristic information. In other words layer
network interworking shall be transparent for the semantics of the trail
overhead. If both layer networks have a different set of semantics, the
layer network interworking is restricted to the common set of semantics.
The layer network interworking function has to terminate (insert,
supervise) the semantics that are not interworked.
 
Figure 19/G.805 - Layer network interworking

Layer network interworking is accomplished through an interworking
processing function as depicted in Figure 19. The interworking
processing function supports an interworking link connection between two
layer network connections. The interworking link connection is special
in the sense that it is asymmetric, delimited by different types of
ports. Also special because it is in general only transparent for a
specified set of client layers. An interworking link is a topological
component that represents a bridge between two layer networks. The
interworking link creates a "super layer network", defined by the
complete set of access groups that can be interworked for a specified
set of client layer networks.

Layer network interworking function uni-directional: A transport
processing function which converts characteristic information of one
layer network to the characteristic information of another layer
network. The integrity of end-to-end performance and maintenance
information is maintained. The function may be limited to a set of
client layer networks.

Layer network interworking function bi-directional: A transport
processing function that consist of a pair of co-located uni-directional
service interworking functions, one for the interworking form layer
network X to Y and the other for the interworking from layer network Y
to X.
----------------------

Regards,

Maarten