Subject: RE: Reservation style

From: Prabakar T S <[email-masked]>
Date: Sat, 16 Dec 2000 15:35:16 +0530

Hello John,

In case of RSVP-TE, when the tunnel egress node receives the Path message
with SESSION_ATTRIBUTE object, the objects "Flags" field indicating "SE Style desired" 
flag bit set, then it SHOULD use the SE Style when responding with a Resv message.
Else, if the egress receives the Path message without Session Attribute 
object or Session Attribute Object with SE Style desired flag bit reset
then the egress should respond with  FF Style. 

In case of RSVP, it is based on the Receiver end Real Time Applications, 
where it is possible to change the existing reservation from FF to SE based on the
situation dynamically.

Refer: draft-ieft-mpls-rsvp-lsp-tunnel-07.txt, pg:47.

Thanks and regards,
-----------------------------------------------------------
Prabakaran TS.
Senior Software Engineer, 
Future Software Ltd,
480-481 Mount Road,
Nandanam,
Chennai - 600 035, INDIA.
Ph : 91-44-4330550 - Extn : 363.
E-Mail : [email-masked]
               [email-masked]
-----------------------------------------------------------

-----Original Message-----
From:	John Sparr [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 2:22 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Reservation style

Hello,

I have a question about reservation style in RSVP:

How does the receiver decide the reservation style?
Since the sender has no effect for the style.

Thanks,

John

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: [email-masked]
Date: Sat, 16 Dec 2000 22:44:26 +0900

Hi Prabhakar,

In the draft "draft-ieft-mpls-rsvp-lsp-tunnel-07.txt, pg:47",  they mentioned 
only about the case where, "SE Style desired"  flag bit in 
SESSION_ATTRIBUTE is set. In that case, it should use the SE style. 
That's fine. But they didn't mention anything about another case i.e., the 
case where the egress receives the Path message without Session 
Attribute object or Session Attribute Object with SE Style desired flag 
bit reset. Can we assume that the egress should respond with  FF Style, 
in this case? Can you please give me some clarification on this?

Thanks in advance,
Reddy.

------Original Message----
Hello John,

Thanks and regards,

-----Original Message-----
From:	John Sparr [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 2:22 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Reservation style

Hello,

Thanks,

John

---

From: Arumugam R <[email-masked]>
Date: Mon, 18 Dec 2000 10:09:39 +0530

Hi Venki,
The answer is yes. we have to associate FF style for the reservation.to be done in case of receiving a
Path message without a Session Attribute Object or receiving the Session Attribute Object with SE Style desired flag bit reset.
Also the tunnels which are established in this type of scenario cannot be rerouted because of the FF style.
Regards
Aru
--------------------------------------------------------------------------------
Arumugam R
Senior Software Engineer,
Future Software Ltd.
Chennai - 35
Fone-4330550 Ext-363
--------------------------------------------------------------------------------
.

-----Original Message-----
From:	[email-masked] [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 7:14 PM
To:	[email-masked]
Subject:	Re: RE: Reservation style

Hi Prabhakar,

Thanks in advance,
Reddy.

------Original Message----
Hello John,

Thanks and regards,

-----Original Message-----
From:	John Sparr [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 2:22 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Reservation style

Hello,

Thanks,

John

---

From: [email-masked]
Date: Mon, 18 Dec 2000 21:56:10 +0900

Hi Aru,

Thank u very much for answering my question. But i am not completely satisfied
with your answer. What i am thinking is, it should act just like RSVP, in absence 
of Session Attribute Object or receiving the Session Attribute Object with SE 
Style desired flag bit reset, i.e., it should select the reservation style based 
on the Receiver end Real Time Applications. 

Because, in the case of selection of a reservation style at egress router, it should
behave in the same way in both RSVP and RSVP-TE. Only thing is, they have 
provided one extra facility in RSVP-TE, i.e., rerouting. To support this one, the
ingress node should be in a position to force the egress router to select SE style
for that LSP. That'swhy, they added that flag( SE style desired ) in SESSION_
ATTRIBUTE object. So without that flag or without that object, it should behave 
just like RSVP. 

Here i am giving my idea on this one. Please correct me if i am wrong.

Thanks in advance,
Reddy.

------Original Message-----
Hi Venki,

-----Original Message-----
From:	[email-masked] [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 7:14 PM
To:	[email-masked]
Subject:	Re: RE: Reservation style

Hi Prabhakar,

Thanks in advance,
Reddy.

------Original Message----
Hello John,

Thanks and regards,

-----Original Message-----
From:	John Sparr [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 2:22 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Reservation style

Hello,

Thanks,

John

---

From: Arumugam R <[email-masked]>
Date: Mon, 18 Dec 2000 19:27:18 +0530

Hi Venki,
one to one comparison with RSVP cannot be done for RSVP-TE. 
In RSVP multiple sessions can be possible whereas in case of RSVP-TE,
session will be a unique one which is identified by the triplet TunnelIndex, 
TunnelInstance, TunnelIngressLSRId as per TE-MIB (te-mib-04.txt).
Since the session (Tunnel) cannot be shared with multiple senders, it is left to the
 implementation to respond with a SE style or FF style. 
Since a Session (Tunnel) cannot be shared at all most of the time, most of the 
implementations will respond with FF style reservation according to my opinion.   
Regards
Aru
--------------------------------------------------------------------------------
Arumugam R
Senior Software Engineer,
Future Software Ltd.
Chennai - 35
Fone-4330550 Ext-363
--------------------------------------------------------------------------------

-----Original Message-----
From:	[email-masked] [SMTP:[email-masked]]
Sent:	Monday, December 18, 2000 6:26 PM
To:	[email-masked]
Subject:	Re:RE: RE: Reservation style

Hi Aru,

Thanks in advance,
Reddy.

------Original Message-----
Hi Venki,

-----Original Message-----
From:	[email-masked] [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 7:14 PM
To:	[email-masked]
Subject:	Re: RE: Reservation style

Hi Prabhakar,

Thanks in advance,
Reddy.

------Original Message----
Hello John,

Thanks and regards,

-----Original Message-----
From:	John Sparr [SMTP:[email-masked]]
Sent:	Saturday, December 16, 2000 2:22 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	Reservation style

Hello,

Thanks,

John