Subject: (Reply) RE: (Reply)

From: [email-masked]
Date: Wed, 6 Dec 2000 18:36:20 +0900

Hi manik,

I would like to clarify my previous mail.

If a packet comes and if it contains Invalid Incoming Label (there is no Label Entry with the "In Label" in the label switching matrix)
then it should be dropped.

If a packet comes and  it has valid Incoming Label Entry, but no Out going label....This is the egress case...So, need to apply conventional routing
on the packet.

Regards,
Seenu
Samsung India Software Operations
Level 7, Prestige Meridian - II
M.G.Road, Bangalore, India.

Tel: +91-80-558 1281 ext: 268

=============================

Hi manik,

You need to drop the packet.

For more infromation pls go thorugh  the section
"3.18. Invalid Incoming Labels" in  "draft-ietf-mpls-arch-07.txt"

Regards,
Seenu
Samsung India Software Operations
Level 7, Prestige Meridian - II
M.G.Road, Bangalore, India.

Tel: +91-80-558 1281 ext: 268

=============================

Hi all,

I am working on MPLS protocol implementation.

I have a doubt on MPLS forwarding process. If I received the labeled packet
which does not have the entry Label Information Table (I mean does not have
the outgoing label entry).. What I have to DO?

1. Do I have to drop the packet
2. Do I have to strip of the Shim header and go for conventional IP routing.

Thanks in advance,
Manikandan.V

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Martin Picard <[email-masked]>
Date: Wed, 06 Dec 2000 06:47:27 -0500

Seenu, Manik,

  "the only safe procedure is to discard the packet" -
draft-ietf-mpls-arch-07 section 3.22

martin

> If a packet comes and if it contains Invalid Incoming Label (there is no
Label Entry with the "In Label" in the label switching matrix)
> If a packet comes and  it has valid Incoming Label Entry, but no Out going
label....This is the egress case...So, need to apply conventional routing