Subject: Question on Draft of RSVP-TE

From: Gaitonde Anandprasanna <[email-masked]>
Date: Wed, 6 Dec 2000 15:21:03 +0530 (IST)

I have read this draft. But i found it to be discussing only Objects and
message processing for Path and REsv mesage.

Does the format and the Processing of the PathERR or Resv ERR , Path Tear
or Resv tear messages change from base protocol RSVP

Please give me some info on this.

Thanx in advance

pras

                     _____________________________                  
                   _ |ANANDPRASANNA GAITONDE     | _ 
                  / )|COMP. SCIENCE & AUTOMATION |( \
                 / / |D-7,IISc HOSTEL            | \ \
                / /  |INDIAN INSTITUTE OF SCIENCE|  \ \
              _( (_  |BANGALORE-560012.          |  _) )_
              (((\ \>|_/->___________________<-_|</ /)))
              (\ _/ /LAB Ph.(080)3092906  \ _/ ////)
               \       /HOSTEL Ph.-            \       /  
                \    _/     (080)3092452        _    /     
                /   /-----------------------------\   \                  
               /  Email Id-                            \ 
              /      [email-masked]         \
	     ---------------------------------------------
            -----------------------------------------------

--------------------------------------------------------------------------------
		
*************************************************************************  
| | | | __ ___   _____     __ _    _ __ (_) ___ ___     __| | __ _ _   _
| |_| |/ _` \ \ / / _ \   / _` |  | '_ \| |/ __/ _ \   / _` |/ _` | | | |
|  _  | (_| |\ V /  __/  | (_| |  | | | | | (_|  __/  | (_| | (_| | |_| |
|_| |_|__,_| _/ ___|   __,_|  |_| |_|_|______|   __,_|__,_|__, |
*************************************************************************

---

From: David Charlap <[email-masked]>
Date: Wed, 06 Dec 2000 11:25:17 -0500

Gaitonde Anandprasanna wrote:
> 
> I have read this draft. But i found it to be discussing only Objects
> and message processing for Path and REsv mesage.
> 
> Does the format and the Processing of the PathERR or Resv ERR , Path
> Tear or Resv tear messages change from base protocol RSVP

Processing of these is the same as RFC 2205, except as modified by the
TE-draft.

These changes (to the best of my knowledge) are:

- PathErr:
	- may be generated by Resv admission control errors as well as
	  Path errors.  The name is now a misnomer - any time an error
	  message should be sent to the ingress node, it's done via a
	  PathErr.

	- New error codes (Routing Error and Notify)

	- RRO objects may be included.  The BNF for PathTear in RFC 2205
	  specifies "Sender Descriptor", which was redefined in the TE
	  draft.

- ResvErr:
	- Won't be generated by admission control error.  PathErr is
	  used instead.

	- RRO and Label objects may be included.  The BNF for ResvErr
	  specifies "Flow Descriptor" which was redefned in the TE
	  draft.

- PathTear:
	- When an ERO was used for establishing a Path, that same ERO
	  must be used when tearing it down.

	- RRO objects may be included.  See above.

- ResvTear:
	- RRO and Label objects may be included.  See above.

-- David