Subject: RE: looser ER and RSVP-TE

From: "Sanford, Bill" <[email-masked]>
Date: Thu, 7 Dec 2000 08:45:40 -0500

Wouldn't that be the same as an Explicit Route Object with "strict" nodes?

In the second and third paragraph of 4.3.3.1. (Strict and Loose Subobjects)

   The path between a strict node and its preceding node MUST include
   only network nodes from the strict node and its preceding abstract
   node.

   The path between a loose node and its preceding node MAY include
   other network nodes that are not part of the strict node or its
   preceding abstract node.

> -----Original Message-----
> From: Kainia Cloutier [mailto:[email-masked]]
> Sent: Thursday, December 07, 2000 11:32 AM
> To: [email-masked]
> Subject: looser ER and RSVP-TE
> 
> 
> My dear colleagues,
> 
> section 2.4 of the CR-LDP draft specifies the Route pinning TLV: loose
> ERs are pinned down, upon establishment, to ensure they will 
> not deviate
> from their route in the event a better route becomes available.
> 
> I was always certain that RSVP-TE had addressed this. 
> However, a recent
> search in the RSVP-TE draft, showed me that route pinning is 
> omitted. I
> am extremely concerned about this. I have recently sent some 
> e-mails to
> my closest MPLS colleagues in other companies, and yes, it seems that
> this issue is left to be vendor specific.
> 
> Could the authors of the RSVP-TE draft comment about this?
> 
> Best Regards,
> Kainia Cloutier,
> Alcatel.
> 
> 
> 
> 
> 
> 
> 
>

---

From: "Sanford, Bill" <[email-masked]>
Date: Tue, 12 Dec 2000 18:04:11 -0500

Hi Madhukar,
You are right about the pinning.  But when you (or anyone) talks about an
ERO being the almost the same as route pinning, you must qualify an Explicit
Route Object with "strict" nodes.  If the ERO has "loose" nodes within the
LSP and an IGP advertised a better path, the ERO could be altered. 

If you look at an LSP that is pinned with more than one connection between 2
of the same nodes, I believe it can't deviate from its path right down to
the interface.  In that same case using ERO with strict nodes, I believe it
can change interfaces, it just cant deviate from the node IP address.

Bill 

> From: madhukar khare [mailto:[email-masked]]
> Sent: Tuesday, December 12, 2000 5:31 PM
> To: Kainia Cloutier; George Swallow
> Cc: [email-masked]; [email-masked]
> Subject: Re: looser ER and RSVP-TE 
> 
> 
> In route pinning, the path should not change if a better one 
> is available.
> This also then assumes that
> the source would not change the ERO if an IGP advertised a 
> better path-
> ----- Original Message -----
> From: "George Swallow" <[email-masked]>
> To: "Kainia Cloutier" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, December 07, 2000 10:46 AM
> Subject: Re: looser ER and RSVP-TE
> 
> 
> > Kainia -
> >
> > This is one of the places where soft state works to your advantage.
> > In RSVP you can pin a route by.
> >
> > 1.  Sending a Path message with a loose source route and an RRO.
> >
> > 2.  Use the RRO to create a fully defined ERO.
> >
> > 3.  Refreseh the Path with that ERO.
> >
> > ...George
> >
> > ==================================================================
> > George Swallow       Cisco Systems                   (978) 244-8143
> >                      250 Apollo Drive
> >                      Chelmsford, Ma 01824
>