Subject: Re: New MPLS Charter?

From: "Andre N. Fredette" <[email-masked]>
Date: Fri, 01 Dec 2000 17:33:29 -0500

I've seen a couple of opinions posted on how things might get sorted out.

Are any of you working to sort out what goes where, and what this means for 
the upcoming meeting?

Thanks,
Andre

At 09:41 AM 11/30/2000 -0500, George Swallow wrote:
>Rob -
>
>It would have been nice if someone had pointed it out to me.
>
>This goes further toward shutting down MPLS than anything we discussed
>in the past.
>
>If it is to be taken literally then *none* of the drafts into this
>meeting belong in MPLS.
>
>Please let us know how to proceed.
>
>...George
>
>cc: [email-masked]
>
>==================================================================
>George Swallow       Cisco Systems                   (978) 244-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Fri, 01 Dec 2000 22:32:51 -0500

I can see how a literal interpretation of item 3) could cause problems.
Being pragmatic let me suggest that we insert an indication that both implicit
and explicit labels are part of the charter.

  I believe the literal interpretation that George is referring to is
"explicit labels" and indeed if we are limited to explicit labels GMPLS
is homeless. I am sure that is not the intention of the wording because
it clearly talks about implicit label switching like wavlength and space
so simply adding the words "implicit and explicit" should solve the problem.

  Cheers,

  Peter Ashwood-Smith

---

From: Eric Gray <[email-masked]>
Date: Sun, 03 Dec 2000 08:29:05 -0500

Peter,

    The problem with including "implicit" labels in
the MPLS working group charter is that doing so
may defeat the intent of getting the charter down to
a manageable size.  GMPLS may be generic in its
intent, but I think we all know that the focus remains
on MPL(ambda)S.  If the idea is to break up the
charter into manageable chunks, MPL(ambda)S
might be better off in the IPO working group.  This
is especially true, if MPL(ambda)S includes TDM
time-slot assignment "label", optical waveband and
optical fiber switching: if these are included, the delta
between MPL(ambda)S and GMPLS is very small.

    As far as GMPLS is concerned, IMHO, we
need to make a philosophical distinction as to
whether GMPLS is intended to be a generalized
use of MPLS signaling or an attempt generalize
MPLS signaling.  The distinction is a subtle one,
but I think it's at the root of whether or not we
(as individuals) feel GMPLS belongs in the MPLS
working group.  If it is intended to be a generalized
use of MPLS signaling, then it should probably
find a home elsewhere.  If it is intended that MPLS
signaling itself should be generalized, then it should
be done in the MPLS working group.

    Again, IMHO, we should not try to generalize
the set of protocols that apply to anything using
MPLS - that seems like a rat-hole and contributes
to a general atmosphere of FUD.

--
Eric Gray

---

From: Yakov Rekhter <[email-masked]>
Date: Sun, 03 Dec 2000 14:47:24 -0800

Eric,

> be done in the MPLS working group.

Would you consider draft-ashwood-generalized-mpls-signaling-01.txt
as a generalized use of MPLS signalling, or as an attempt to
generalize MPLS signalling ?

Yakov.

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Sun, 03 Dec 2000 20:13:36 -0500

Yakov Rekhter wrote:
> > on MPL(ambda)S. 

  I do not believe the focus is on Lambda switching. Most
devices today are doing either spacial switching with
mirrors or bubbles or some other physical device, or 
TDM switching with SONET. The Lambda stuff is done with
a DWDM infront of a space switch, at least to the best 
of my knowledge. As a result there is a great deal of
interest in TDM and Spacial switching right now.

> > If the idea is to break up the

  If we need more time to discuss the various things going
on in MPLS then let's have another WG meeting. Its kind of
frustrating doing almost the same thing several times in
different groups. I recall the traffic engineering stuff
being duplicated and would hate to see us do the same
things with GMPLS. 

> > be done in the MPLS working group.

  Call me naive, but I have always felt that a path, no
matter what the characteristics of the switches that create
that path, is controllable by a single signaling and routing
protocol and that only minor differences are required to deal
with the differences in switching technology. As such I 
see GMPLS as an attempt to generalize MPLS signaling, not
something that you piggy back on existing MPLS signaling.

  Anyway, my simplistic view of things looks like this:

  - a place to discuss signaling for all layer 1&2 switches. (G)MPLS-WG
  - a place to discuss routing OSPF & ISIS-WG
  - a place to discuss traffic engineering TE-WG
  - a place to discuss applications of (G)MPLS
  - a place to discuss peculiarities of different layer 1&2 technologies, IPO+other standards bodies
 
  Cheers,

  Peter

---

From: Eric Gray <[email-masked]>
Date: Mon, 04 Dec 2000 08:19:49 -0500

Yakov,

    Hi.

    I invite your attention to the abstract of the draft
to which you refer, in which a cast of thousands say:

   "This document describes extensions to MPLS signaling required to
   support Generalized MPLS.  Generalized MPLS extends MPLS to encompass

   time-division (e.g. SONET ADMs), wavelength (optical lambdas) and
   spatial switching (e.g. incoming port or fiber to outgoing port or
   fiber). ..."

This sounds to me like it's attempting to describe how MPLS
signaling might be extended to support a more general usage.
As a result, the intentions of the authors are ambiguous and
unclear.  I cannot tell whether it is the intention of the authors
that these extensions are to become part of MPLS (generalizing
MPLS) or to be used as a super-set of MPLS signaling that
would be applicable only to signaling applications not already
described in current MPLS signaling.

    It is my hope that it is this latter case as otherwise, we are
still in the pre-standard mode where vendors implement MPLS
at their own risk  I'd really like to see closure on what we have
already accomplished.

--
Eric Gray

Yakov Rekhter wrote (in part):

> > ...

---

From: Eric Gray <[email-masked]>
Date: Mon, 04 Dec 2000 08:27:54 -0500

Peter,

    We're bandying words here.  In the abstract of your
draft, you give specific examples of the other things you
would like to see covered by GMPLS signaling.  If you
read through my original message, you will see that I
said that MPL(ambda)S may be extended in the scope
of its meaning to include other types of optical switching
- including TDM time-slot and spatial switching applied
to optics.  The key here is the word "optical".  If you
look carefully at the abstract of your draft, there is very
little targeted there that is not optical.

    As for the argument that we should do the work all in
one place, I do not disagree.  I just do not think it should
be in the MPLS working group as previously constituted.
Our work there is done, and I think it is time we let the
world know that.  Then we can all move on, like so many
of us did from LANE and MPOA and other completed
specifications.

--
Eric Gray

---

From: "tom worster" <[email-masked]>
Date: Mon, 4 Dec 2000 08:54:53 -0500

From: [email-masked] [mailto:[email-masked]]On Behalf Of 
Andre N. Fredette
> Are any of you working to sort out what goes where, and what 

i understand the current status to be that, given the 
new context of a) mpls re-chartering b) the new sub-ip 
pseudo-area c) the instantiation of certain new wgs, a 
great many many work items (i.e. i-ds) must be 
relocated. i understand that the ads are responsible 
for determining where each i-d now belongs and we now 
have to wait for their decision.

c u
tom

---

From: "tom worster" <[email-masked]>
Date: Mon, 4 Dec 2000 10:07:44 -0500

eric, peter,

in response to both of you: isn't coma supposed to be 
the new home for what gmpls is trying to do? when i 
read the description of coma (in the new sub-ip context) 
i understood it imply as much.

(i'm assuming here that the gmpls draft involves, using 
eric's terminology, generalisation of mpls signalling
and not a generalised use.)

c u
tom

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Eric Gray
> Sent: Sunday, December 03, 2000 8:29 AM
> To: Peter Ashwood-Smith
> Cc: [email-masked]
> Subject: Re: New MPLS Charter?
> 
> 
> Peter,
>