Subject: RE: MPLS and fragmentation..

From: Shahram Davari <[email-masked]>
Date: Tue, 5 Dec 2000 05:06:27 -0800

Hi,

It is possible to do fragmentation in MPLS layer. Please check section 3 of:

http://www.ietf.org/internet-drafts/draft-ietf-mpls-label-encaps-08.txt

   "If the LSR chooses not to discard a labeled IPv4 datagram which is
   too big, or if the DF bit is set in that datagram, then it MUST
   execute the following algorithm:

      1. Strip off the label stack entries to obtain the IP datagram.

      2. Let N be the number of bytes in the label stack (i.e, 4 times
         the number of label stack entries).

      3. If the IP datagram does NOT have the "Don't Fragment" bit set
         in its IP header:

            a. convert it into fragments, each of which MUST be at least
               N bytes less than the Effective Maximum Frame Payload
               Size.

            b. Prepend each fragment with the same label header that
               would have been on the original datagram had
               fragmentation not been necessary.

            c. Forward the fragments "

Yours,
-Shahram

> -----Original Message-----
> From: Ben Black [mailto:[email-masked]]
> Sent: Monday, December 04, 2000 3:07 PM
> To: Wilder, David
> Cc: 'Faisal S. Naik'; mpls uunet; [email-masked]
> Subject: Re: MPLS and fragmentation..
> 
> 
> it is not possible to exceed the MTU (hence the name).  the MTU
> for a path will be less than the MTU of the media carrying the path.
> exactly how much less depends on how many labels are stacked, how
> the encapsulation for a given media is implemented, etc.  however,
> once an LSP is established, its MTU *should* be known (barring
> oddities when the LSP MTU changes during a failure or other
> re-routing event).
> 
> so, faisal is correct: all fragmentation should occur outside the MPLS
> domain.  
> 
> 
> ben
> 
> On Mon, Dec 04, 2000 at 03:02:20PM -0500, Wilder, David wrote:
> > This is true; IP fragmentation is done by IP before 
> entering the MPLS
> > domain.  However,  there are case where adding the 4 byte 
> label is going to
> > cause the packet to now exceed the max mtu size.  Then  one 
> must look at how
> > to handle that situation i.e. fragment, discard or do nothing.
> > 
> > Dave
> > 
> > -----Original Message-----
> > From: Faisal S. Naik [mailto:[email-masked]]
> > Sent: Monday, December 04, 2000 2:08 PM
> > To: mpls uunet
> > Cc: [email-masked]
> > Subject: Re: MPLS and fragmentation..
> > 
> > 
> > hello soumen,
> > Isnt this Ip fragmentation a part of the router before the 
> packet enters the
> > MPLS domain. Within the domain, there is only the label 
> swapping mechanism
> > that is working, with nothing to mention about the 
> fragmentation part.
> > Esp in cases of IPv6 fragmentation is not at all allowed, 
> for exceptional
> > cases, extended headers of IPv6 are used.
> > Am i right Nisar saheb :)
> > Regards,
> > Faisal Naik
> > >
> > >
> > >
> > 
>

---

From: David Charlap <[email-masked]>
Date: Tue, 05 Dec 2000 10:51:35 -0500

Shahram Davari wrote:
> 
> It is possible to do fragmentation in MPLS layer. ...

Yes, but it is a bad idea if your LSPs are not using best-effort levels
of QoS.

Fragmentation causes a packet to be forwarded via a router's slow-path. 
It also increases the amount of data in the stream.  Both of which can
cause otherwise-compliant data to violate the signalled QoS contract.

The only way to avoid this is to have the ingress router do all
fragmentation (and possibly subsequent traffic shaping) before injecting
the packets into the LSP.

-- David

---

From: "Andre N. Fredette" <[email-masked]>
Date: Tue, 05 Dec 2000 12:33:23 -0500

>Fragmentation causes a packet to be forwarded via a router's slow-path.

This is not always the case.

---

From: "Andre N. Fredette" <[email-masked]>
Date: Tue, 05 Dec 2000 12:41:03 -0500

Fragmentation in the MPLS layer presumes you know that the packets are IP 
packets.  This is probably the case, but not guaranteed.

Andre

---

From: Steve Kohalmi <[email-masked]>
Date: Tue, 5 Dec 2000 15:05:22 -0500

>Fragmentation causes a packet to be forwarded via a router's slow-path.

That used to be true.  But many new routers with ASIC and network
processor assistance can do fragmentation at line speed.