Subject: MPLS World exhibition

From: "Peter Lewis" <[email-masked]>
Date: Wed, 20 Dec 2000 12:50:40 +0100

The MPLS World exhibition : 14 of the 30 booths have been allocated. 7 are reserved. 
Don't miss the international meeting (conference and exhibition):
http://www.upperside.fr/congress/exhi.htm

---

From: Randy Bush <[email-masked]>
Date: Wed, 20 Dec 2000 10:48:44 -0800

> The MPLS World exhibition : 14 of the 30 booths have been allocated.

do all come with toilet paper?