Subject: GMPLS - Hierarchies

From: Heiles Juergen <[email-masked]>
Date: Wed, 6 Dec 2000 13:34:09 +0100

draft-ietf-mpls-generalized-signaling-01 mentions in the introduction a hierachy with fiber switching at the top followed by lambda, time-slot and packet switching and clearly distinguish between these levels. I don't agree with this view that a LSP starts and ends on the same LSR type and onyl nesting of LSPs of different LSR types is possible.
Take for example an optical cross-connect that switches fiber between its ports (=> fiber switch capable). The single or multiple lambdas on this fiber might be directly after the cross-connect or later combined with other signals from other fibers in a WDM system => (lambda switch capable) or a TDM technique is used to combine several of these signals to a higher bandwidth signal (e.g. going from 2.5 to 10 Gbit/s) (=> time switch capable). So a LSP that starts at LSC device ends up at a TSC device and might have a LSC device in between. Even an interchange of LSPs between packet and circuit switch capable devices is possible, take for a example circuit emulation via ATM. With circuit emulation you can also have a LSP that starts on a TSC device nested into a LSP that starts on a PSC device.
A LSP represents a connection through the network/sub-network for a certain signal. This is independent of the switching technologies along the route and at the end as long as the specific signal is supported. At both ends access to the specific signal has to be provided, but it doesn't matter if e.g. a 1.5 Mbit/s signal is transported on a time-slot of a TDM system, on a single wavelength of a WDM system (not economic), over a CDMA radio system or with circuit emulation over an ATM network.
The Hierarchy is defined by different signals nested into each other (client/server relationship), but not by the switching types.

Regards

Juergen Heiles

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Wed, 06 Dec 2000 09:58:36 -0500

Correct,

  One could take a signal and instead of using hierarchy, simply map it from one type to another of LSP.
There is nothing in the generalized draft that precludes such translations. Actually if you go back a year
and look at a draft that was presented we had something called a composite label that could change from
type to type as it propogated. This work was subsumed by the generalized draft. While it is generally
recognized that LSPs form a natural hierarchy, it is perfectly feasable to map from one type to another
where the bandwidths are a close match, given that the hardware is capable of doing it. Such hardware
is a hybrid LSR (we produce ATM/PPP examples of them today), which may change the label type as the 
requests/path messages flow.

  This is most likely to occur with TDM and OXC equipement at the OC-192 and OC-48 rates where there is a
close mapping between the OXC lambda and the TDM signal bandwidth. It won't work sell so well at lower rates
because you waste too much bandwidth and are forced into a heirarchy whether you want one or not.

  Cheers,

  Peter Ashwood-Smith

---

From: Yangguang Xu <[email-masked]>
Date: Wed, 06 Dec 2000 10:53:57 -0500

Juergen,

Agree in concept,

LSPs don't have to starts and ends on the same LSR type. A not ugly example is,
in circuit switched transport network, a T1 equivalent LSP can go through a TDM
mux and then a SONET box capable of low order switch. 

The key issue is not about "LSR type". It's the characteristic of the LSP. They
have to be consistent for "a" LSP. However, when a LSP goes through different
technology domains, it's possible, clear and convenient (for many cases) to
break them into sections, set up them independently and concatenate them. These
sections are actually peers. 

The client/server relation exist for LSPs of different granularities. Typically,
low granularity LSP can use high granularity LSP as tunnel (in your example, the
2.5G pipe can tunnel through a previously established 10G pipe). LSPs of
different granularity are set up at different time and triggered by different
reasons.

Thanks,

Yangguang

---

From: "Udo Neustadter" <[email-masked]>
Date: Wed, 6 Dec 2000 12:03:21 -0500

May understanding is that the hierarchy build is a logical one, and no real
labels are added to the flow. The flow is identified by the specific TDM
channels. I just can not see where the waste of bandwidth is coming from.

Udo

>...
>...

---

From: Chrysostomos Tziouvaras <[email-masked]>
Date: Fri, 22 Dec 2000 10:05:55 +0200 (EET)

Mr Ashwood-Smith,
in your answer, cited below, you claim that a signal can be mapped from
one type of LSP to another type of LSP. I am using this in order to make
packet LSPs that traverse the optical network. 
But, is the mapping of LSPs a local decision for the ingress router of the
optical network? If it is, can he change this mapping dynamically without
notifying the initiator of the packet LSP?

Thanks in advance

Tziouvaras Chrysostomos
ICS-FORTH Researcher 

On Wed, 6 Dec 2000, Peter Ashwood-Smith wrote:

> _______________________________________________
> IP-Optical mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/ip-optical
>