Subject: RE: E-LSP or L-LSP

From: Jim Boyle <[email-masked]>
Date: Mon, 4 Dec 2000 08:38:42 -0700 (MST)

On Wed, 22 Nov 2000 [email-masked] wrote:

> Hi
> 
> E-LSP is used when DSCP DiffServ field is mapped to the EXP field in the
> MPLS header.
> L-LSP is used when DSCP DiffServ field is mapped to the EXP+LABEL fields
> in the MPLS header.

actually, I don't think L-LSPs look at EXP, just the label.

My answer to this question is: consult your vendor.

Most high end routers I know of can do a good level of queue processing
based on the COS bits (aka the EXP bits), thus for many, this works now.

Some high end router vendors can infer the queuing to do based on the
label, but I'm not sure about the availability of that.  At least one
router vendor (avici) should be working to make this available, as L-LSPs
have curtis as a major advocate :)

best of luck.

Jim

 > > Thanks.
> ------------------------------------------------------------------------
> - 
> Wesam Alanqar 
> Member of Technical Staff 
> Technology Concepts, Innovations and Evaluation (TCIE) 
> Technology Planning & Integration- Sprint TP&I 
> 9300 Metcalf Avenue 
> Overland Park, KS 66212-1463 
> Phone: 913-534-5623 
> Fax: 913-534-3485 
> ------------------------------------------------------------------------
> - 
> 
> 
> 
> > -----Original Message-----
> > From: mastropietro [mailto:[email-masked]]
> > Sent: Wednesday, November 22, 2000 4:05 AM
> > To: mpls
> > Cc: mastropietro
> > Subject: E-LSP or L-LSP
> > 
> > 
> > Hi All,
> > I am a novel researcher on MPLS and TE for Co.Ri.Tel ( Rome, Italy)...
> > Is there anyone that can help me to understand when E-LSPs or L-LSPs
> > actually should be used?
> > Thanks in advance
> > 
> > Simeone Mastropietro
> > 
> > 
> 
>

---

From: Jay Wang <[email-masked]>
Date: Mon, 4 Dec 2000 11:03:13 -0800

> From: Jim Boyle [mailto:[email-masked]]
> Sent: Monday, December 04, 2000 7:39 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: E-LSP or L-LSP
> 
> 

In L-LSP, the label along can be used to infer the corresponding 
PSC.  However, the EXP bits may be used to keep drop precedence when
the Shim header is used. Otherwise, the drop precedence may need to
be inferred from the native L2 header.

- Jay