Subject: Hello Messages in RSVP-TE

From: Gaitonde Anandprasanna <[email-masked]>
Date: Sun, 17 Dec 2000 14:03:59 +0530 (IST)

I have some doubts about the Hello Message extension of RSVP-TE
Draft of RSVP-TE 07.txt

One basic doubt is this :

 If no Instance values are received, via either REQUEST or ACK
   objects, from a neighbor within a configured number of
   hello_intervals, then a node MUST presume that it cannot communicate
   with the neighbor.  The default for this number is 3.5.   

From this paragraph i feel that if my nighbour does not support Hello
messages then obviosly he will just discrad  them and i wont get any
response to my Hello request messages. the i mght consider the
communication to be lost. Though this is not the case .
 I am confused about this??

And as per the above argument even the part of the draft(shown below)is
not well understood by me.

 The Hello extension is specifically designed so that one side can use
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   the mechanism while the other side does not.  Neighbor failure
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   detection may be initiated at any time.  This includes when neighbors
   first learn about each other, or just when neighbors are sharing Resv
   or Path state.

Please let me know.

Second difficulty:

Please refer Section 5.3:

 The receiver of a HELLO REQUEST object SHOULD also verify that the
   neighbor is reflecting back the receiver's Instance value.  This is
   done by comparing the received Dst_Instance field with the
   Src_Instance field value most recently transmitted to that neighbor.
   If the neighbor continues to advertise a wrong non-zero value after a
   configured number of intervals, then the node MUST treat the neighbor
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   as if communication has been lost. 

And one more paragraph for ACK meesages

 The receiver of a HELLO ACK object MUST also verify that the neighbor
   is reflecting back the receiver's Instance value.  If the neighbor
   advertises a wrong value in the Dst_Instance field, then a node MUST
   treat the neighbor as if communication has been lost. 

In this paragraph there is no menion of whether we should wait for some
number of hello intervals before considering the communication to be
lost.??
I think we should consider the number of hello intervals here also right??

Thanx in advance

Pras

---

From: Arumugam R <[email-masked]>
Date: Mon, 18 Dec 2000 20:04:15 +0530

Hi,
If I am right, when the machine reboots itself, all the information associated with the session
                                                                               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
will be lost. This includes neighbor information too. If the neighbor itself is not available 
when the machine reboots, it has to rebuild the neighbor information by someother 
way i.e. either by receiving a RSVP-TE message or as per implementation dependant means.

so building the neighbor information & generating a Hello message within 17.5 millisec 
is too practical unless otherwise the neighbor information is available readily outside.
 
Regarding the amount of traffic generated due to hello message already a nice explanation as 
well as calculation was given by David Charlap in the mailing list.

Herewith what I would like to conclude is that since rebooting & sending a Hello message itself is 
very difficult to achieve within 17.5 millisec, the receiver of the HELLO REQUEST has no 
need to wait for the configured number of intervals in case of wrong value advertised, instead 
the receipt of first time wrong value itself  can be considered as link failure.
This will be in sink with the receiver of HELLO ACK message (next paragraph), which could be the 
answer to your earlier question.

Reg
Arumugam
 
-----Original Message-----
From:	Gaitonde Anandprasanna [SMTP:[email-masked]]
Sent:	Monday, December 18, 2000 4:15 PM
To:	Arumugam R
Cc:	[email-masked]
Subject:	RE: Hello Messages in RSVP-TE

Please see some queries which i have below...

> 
> Also where this type of scenario can happen, the neighbor being fine but the 
values 
> alone being changed due to noises in the Link, then the checksum mechanism 
with the
> RSVP will take care.
> Secondly if the neighbor is rebooted is it possible to bring up the node as 
well as 
> sending a Hello message within 17.5 milliseconds, because once the neighbor 
> reboots itself the neighbor info associated with it also will be washed out.
 Learning 
> a neighbor from smoother means & sending a Hello message within 17.5 ms, 
I think 
> it is too practical.

Thanx for the reply. Well i think in the last part of the mail u are
asking
a question . Am in right??
and as per my understanding the question is . If a machine reboots and
comes up  well before 17.5 ms, then what will happen is that though the
node
have lost the whole RSVP-TE soft state , it still will be sending hello
messages to the adjacent nodes. and then the adjacent nodes will not come
to know that the machine has rebooted through hello messages. (Well it can
 know that if after rebooting the hello message instance value changes.
Does this happen  ??)

Also i did not know get what u mean by u 'r last  line 
"Learning
> a neighbor from smoother means & sending a Hello message within 17.5 ms,
I think
> it is too practical.
"

Some how i feel that the default value of 5 ms which is given for the
Hello messages, will cause much traffic on the network and the other
mesages of RSVP-TE and also the data traffic  might get affected . Is it
not the case that the hello interval i too less????

Please explain . 

Thanx in advance

Pras

> 
> Thanx in advance
> 
> 
> Pras
> 
> Regards
> Aru
> --------------------------------------------------------------------------------
> Arumugam R
> Senior Software Engineer,
> Future Software Ltd.
> Chennai - 35
> Fone-4330550 Ext-363
> --------------------------------------------------------------------------------
>  
> 

                     _____________________________                  
                   _ |ANANDPRASANNA GAITONDE     | _ 
                  / )|COMP. SCIENCE & AUTOMATION |( \
                 / / |D-7,IISc HOSTEL            | \ \
                / /  |INDIAN INSTITUTE OF SCIENCE|  \ \
              _( (_  |BANGALORE-560012.          |  _) )_
              (((\ \>|_/->___________________<-_|</ /)))
              (\ _/ /LAB Ph.(080)3092906  \ _/ ////)
               \       /HOSTEL Ph.-            \       /  
                \    _/     (080)3092452        _    /     
                /   /-----------------------------\   \                  
               /  Email Id-                            \ 
              /      [email-masked]         \
	     ---------------------------------------------
            -----------------------------------------------

--------------------------------------------------------------------------------
		
*************************************************************************  
| | | | __ ___   _____     __ _    _ __ (_) ___ ___     __| | __ _ _   _
| |_| |/ _` \ \ / / _ \   / _` |  | '_ \| |/ __/ _ \   / _` |/ _` | | | |
|  _  | (_| |\ V /  __/  | (_| |  | | | | | (_|  __/  | (_| | (_| | |_| |
|_| |_|__,_| _/ ___|   __,_|  |_| |_|_|______|   __,_|__,_|__, |
*************************************************************************