Subject: in topology-driven how is ospf work?

From: "yojiny" <[email-masked]>
Date: Mon, 4 Dec 2000 16:58:07 +0900

I have a question.
I wnat to know difference fo funtction fo ospf in topology-driven and traffic-driven?
and what informaton is carred by routing protocol in two different method?

thanks in advance.

yang yojin.
I

---

From: "Gabor Korossy (ETH)" <[email-masked]>
Date: Mon, 4 Dec 2000 10:00:15 +0100

Yojiny,
if you want other people to consider your question worth answering,
please, respect the readers by browsing your letter once more before
sending it,
so that we don't have to guess what do you "wnat to know".
/Gabor

-----Original Message-----
From: [email-masked] <mailto:[email-masked]>  [mailto:owner-
[email-masked]]On Behalf Of yojiny
Sent: Monday, December 04, 2000 8:58 AM
To: [email-masked] <mailto:[email-masked]> 
Subject: in topology-driven how is ospf work?

I have a question.
I wnat to know difference fo funtction fo ospf in topology-driven and
traffic-driven?
and what informaton is carred by routing protocol in two different method?
 
thanks in advance.
 
yang yojin.
I

---

From: "Yang Yo-Jin" <[email-masked]>
Date: Thu, 7 Dec 2000 11:22:33 +0900

RE: in topology-driven how is ospf work?Hi Eyad Saheb
i mean by "possible path" a pair of source and destination, or engress and egress that was linked 
by shortest path .

and what i want to know is in topology-driven, whether allocation of Label was done by routing prothocol or by another signaling protocol like LDP?

i will appreciate your thought on this question.
regards/yojiny

  ----- Original Message ----- 
  From: Eyad Saheb 
  To: 'Yang Yo-Jin' 
  Sent: Thursday, December 07, 2000 12:25 AM
  Subject: RE: in topology-driven how is ospf work?

  see in-line comments.. 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Yang Yo-Jin 
  Sent: Wednesday, December 06, 2000 2:17 AM 
  To: Gabor Korossy (ETH) 
  Cc: [email-masked] 
  Subject: Re: in topology-driven how is ospf work? 

  >Hi Gabor, 
  > 
  >as i knew, in topology-driven LSR have Label that was allocate all path, 
  >                in traffic-driven LSR allocate Label to required path or loaded path 
  >                more than some point determined by administrator. 
  >                and in MPLS, one of most important thing is to reduce label. 
  > 
  >but after seeing your mail, 
  >as i understand, today all MPLS router allocate Label to all possible path. 
  >in that case, LSR have big overhead to manage to Label that was not referred. 

  How can this happen ?  If LSR allocate label to ALL POSSIBLE paths, then any other 
  ones are IMPOSSIBLE, correct ?  In fact, I don't believe that topology-driven LSRs can 
  perform traffic-driven label allocation since that wasn't the intended configuration. 
     
  >am i right? 
  > 
  >I appreciate your thought on this matter. 
  >regards / yojiny

---

From: "Gabor Korossy (ETH)" <[email-masked]>
Date: Fri, 8 Dec 2000 10:09:37 +0100

Hi,
Labels are distributed by the Label Distribution Protocol, let it be a separate protocol or 
piggibacking on existing protocols.
I don't know of any implementation using OSPF for piggibacking.
I suggest you to study the MPLS architecture draft:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-arch-07.txt <http://www.ietf.org/internet-drafts/draft-ietf-mpls-arch-07.txt> 
 
/Gabor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Yang Yo-Jin
Sent: Thursday, December 07, 2000 3:23 AM
To: Eyad Saheb
Cc: [email-masked]
Subject: Re: in topology-driven how is ospf work?

Hi Eyad Saheb

----- Original Message ----- 
From: Eyad  <mailto:[email-masked]> Saheb 
To: 'Yang Yo-Jin' <mailto:[email-masked]>  
Sent: Thursday, December 07, 2000 12:25 AM
Subject: RE: in topology-driven how is ospf work?

see in-line comments..