Subject: RE: New MPLS charter

From: Shahram Davari <[email-masked]>
Date: Fri, 1 Dec 2000 06:32:05 -0800

Hummel,
 
> Shahram,
> Well why was label switching invented in the first place?
> Obviously, longest prefix match is slower than looking up the 
> next interface and the next label based on an incoming label.

Although at the beginning of MPLS development it was believed that longest prefix match is slow and label switching will improve it, but future developments showed otherwise. In fact very good algorithms became available that could do a maximum of 3 lookups to do the longest prefix match. So the benefits of MPLS with regard to fast lookup diminished.

> 	I mentioned several protocols where to setup labels for 
> the control plane: Particularly BGP4 and LDP(unsolicited 
> downstream mode).

But you still need IP to transport BGP, LDP, ..., don't you?

Yours,
-Shahram

---

From: George Swallow <[email-masked]>
Date: Fri, 01 Dec 2000 10:17:55 -0500

Shahram -

Small correction

> Although at the beginning of MPLS development it was believed 

by some people who weren't paying close attention to advances in
datastructures and ASIC designs that could take advantage of them

> that
> longest prefix match is slow and label switching will improve it, but
> future developments showed otherwise. In fact very good algorithms
> became available that could do a maximum of 3 lookups to do the
> longest prefix match. So the benefits of MPLS with regard to fast
> lookup diminished.

...George

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824