Subject: Question of path attributes for MP-REACH-NLRIs

From: Janardan Ramesh <[email-masked]>
Date: Thu, 21 Dec 2000 10:46:16 -0800

When an MPLS BGP speaker receives an update from
a peer, what are the path attributes relevant to the MP-REACH-NLRIs.

Am I right in assuming that AS-Path, MEDISC, NEXTHOP (since it
is contained within MP-REACH-NLRI), ATOMIC, AGGREGATOR
are not relevant.

Local preference might not be relevant since a prefix from two peers
come in with different RDs anyway.

That leaves ORIGIN, Community, Route-Relector-Originator-ID and
RR-Cluster-ID. 

Is it OK just to store the relevant attributes?

Thanks in advance

Regards
Ramesh

---

From: Yakov Rekhter <[email-masked]>
Date: Sat, 23 Dec 2000 15:35:35 -0800

Ramesh,

>is contained within MP-REACH-NLRI), ATOMIC, AGGREGATOR

What makes your think that AS-Path, MED, ATOMIC, and AGGREGATOR"
"are not relevant" ?

NEXTHOP is not relevant.

Yakov.

---

From: "Brijesh Kumar" <[email-masked]>
Date: Thu, 28 Dec 2000 17:31:08 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Yakov
> Rekhter
> Sent: Saturday, December 23, 2000 6:36 PM
> To: Janardan Ramesh
> Cc: [email-masked]'
> Subject: Re: Question of path attributes for MP-REACH-NLRIs
>
> Ramesh,
>
> >

I think the description of the NEXT_HOP issue in multi-protocol
extension RFC isn't very clear.  True that NEXT_HOP path attribute is
not relevant. But the NEXT_HOP (well known, mandatory attribute) has
to be there in the PDU for it to be a valid UPDATE message.

--brijesh
Ennovate Networks Inc.,