Subject: RE: MPLS for UDLR

From: Eyad Saheb <[email-masked]>
Date: Mon, 4 Dec 2000 10:12:56 -0500

Have you considered CR/LDP ?  Ofcourse, there's the TCP overhead (is TCP
affected by UDL?), but I don't believe CR/LDP has the bi-directional link
limitation that RSVP  does.  However, CR/LDP doesn't have the refreshs; the
overhead is only incurred on LSP setup & neighor discovery.

For further study, I guess.

Eyad

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Robert
Schellhase
Sent: Thursday, November 30, 2000 9:58 AM
To: [email-masked]; Nhat Thanh Hoang; eduard metz
Cc: [email-masked]
Subject: RE: MPLS for UDLR

Thanks for the RSVP insights. They improve my overall understanding of
what's happening.

UDLR is supposed to fix the problem of receiving on one interface while
sending on another, by combining the two physical paths into a single
logical interface. So it sounds like we are saying that since MPLS uses RSVP
to build its tunnels, but RSVP needs bi-directional interfaces to get its
job done, and therein lies the problem.

Am I reading this correctly? Does anyone else have thoughts, or a possible
workaround idea?

Best regards,
Robert

-----Original Message-----
From: Alexander Marhold [mailto:[email-masked]]
Sent: Thursday, November 30, 2000 2:07 AM
To: Nhat Thanh Hoang; [email-masked]; eduard metz;
[email-masked]
Subject: RE: MPLS for UDLR

> As I know RSVP for traffic engineering that uses in MPLS context is
> unidirectional, which means you need to configure at least two
> constraint-based LSPs (ingress--->egress and ingress<---egress),
> if you want
> a bidirectional path.
>
>> LSP is unidirectional, but RSVP is not,
>>

Sorry for not being clear enough:
Of course you are right  the tunnel which is set up by RSVP is
unidirectional (this is what we tell RSVP when starting the RESV message).

What I wanted to express is:
That the messages itself, RSVP is sending forward (RESV) and backwards
(PATH) to set up the path are assumed to go over the same links in forward
and reverse direction. In the UDLR case those links forward and reverse are
different.

And I think that exactly that is the problem in the UDLR case.

with best regards
Alexander

---

From: Markus Jork <[email-masked]>
Date: Mon, 04 Dec 2000 10:40:42 -0500

Just to clear up some confusion in this e-mail exchange.
RSVP does not have a problem with unidirectional links.
A Path message can be sent out on one interface and the
corresponding Resv message can come back in through any
other interface.
So when there is a unidirectional link from A to B, the only
requirement is that B somehow has to be able to send back a Resv
message to A (through some other interface or possibly via multiple
other intermediate nodes). There is no need for a bi-directional link.

Markus

> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
> <META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2652.35">
> <TITLE>RE: MPLS for UDLR</TITLE>
> </HEAD>
> <BODY>
> 
> <P><FONT SIZE=2>Have you considered CR/LDP ?&nbsp; Ofcourse, there's the TCP overhead (is TCP affected by UDL?), but I don't believe CR/LDP has the bi-directional link limitation that RSVP&nbsp; does.&nbsp; However, CR/LDP doesn't have the refreshs; the overhead is only incurred on LSP setup &amp; neighor discovery.</FONT></P>
> 
> <P><FONT SIZE=2>For further study, I guess.</FONT>
> </P>
> 
> <P><FONT SIZE=2>Eyad</FONT>
> </P>
> 
> <P><FONT SIZE=2>-----Original Message-----</FONT>
> <BR><FONT SIZE=2>From: [email-masked] [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]On Behalf Of Robert</FONT>
> <BR><FONT SIZE=2>Schellhase</FONT>
> <BR><FONT SIZE=2>Sent: Thursday, November 30, 2000 9:58 AM</FONT>
> <BR><FONT SIZE=2>To: [email-masked]; Nhat Thanh Hoang; eduard metz</FONT>
> <BR><FONT SIZE=2>Cc: [email-masked]</FONT>
> <BR><FONT SIZE=2>Subject: RE: MPLS for UDLR</FONT>
> </P>
> <BR>
> 
> <P><FONT SIZE=2>Thanks for the RSVP insights. They improve my overall understanding of</FONT>
> <BR><FONT SIZE=2>what's happening.</FONT>
> </P>
> 
> <P><FONT SIZE=2>UDLR is supposed to fix the problem of receiving on one interface while</FONT>
> <BR><FONT SIZE=2>sending on another, by combining the two physical paths into a single</FONT>
> <BR><FONT SIZE=2>logical interface. So it sounds like we are saying that since MPLS uses RSVP</FONT>
> <BR><FONT SIZE=2>to build its tunnels, but RSVP needs bi-directional interfaces to get its</FONT>
> <BR><FONT SIZE=2>job done, and therein lies the problem.</FONT>
> </P>
> 
> <P><FONT SIZE=2>Am I reading this correctly? Does anyone else have thoughts, or a possible</FONT>
> <BR><FONT SIZE=2>workaround idea?</FONT>
> </P>
> 
> <P><FONT SIZE=2>Best regards,</FONT>
> <BR><FONT SIZE=2>Robert</FONT>
> </P>
> 
> <P><FONT SIZE=2>-----Original Message-----</FONT>
> <BR><FONT SIZE=2>From: Alexander Marhold [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
> <BR><FONT SIZE=2>Sent: Thursday, November 30, 2000 2:07 AM</FONT>
> <BR><FONT SIZE=2>To: Nhat Thanh Hoang; [email-masked]; eduard metz;</FONT>
> <BR><FONT SIZE=2>[email-masked]</FONT>
> <BR><FONT SIZE=2>Subject: RE: MPLS for UDLR</FONT>
> </P>
> <BR>
> 
> <P><FONT SIZE=2>&gt; As I know RSVP for traffic engineering that uses in MPLS context is</FONT>
> <BR><FONT SIZE=2>&gt; unidirectional, which means you need to configure at least two</FONT>
> <BR><FONT SIZE=2>&gt; constraint-based LSPs (ingress---&gt;egress and ingress&lt;---egress),</FONT>
> <BR><FONT SIZE=2>&gt; if you want</FONT>
> <BR><FONT SIZE=2>&gt; a bidirectional path.</FONT>
> <BR><FONT SIZE=2>&gt;</FONT>
> <BR><FONT SIZE=2>&gt;&gt; LSP is unidirectional, but RSVP is not,</FONT>
> <BR><FONT SIZE=2>&gt;&gt;</FONT>
> </P>
> 
> <P><FONT SIZE=2>Sorry for not being clear enough:</FONT>
> <BR><FONT SIZE=2>Of course you are right&nbsp; the tunnel which is set up by RSVP is</FONT>
> <BR><FONT SIZE=2>unidirectional (this is what we tell RSVP when starting the RESV message).</FONT>
> </P>
> 
> <P><FONT SIZE=2>What I wanted to express is:</FONT>
> <BR><FONT SIZE=2>That the messages itself, RSVP is sending forward (RESV) and backwards</FONT>
> <BR><FONT SIZE=2>(PATH) to set up the path are assumed to go over the same links in forward</FONT>
> <BR><FONT SIZE=2>and reverse direction. In the UDLR case those links forward and reverse are</FONT>
> <BR><FONT SIZE=2>different.</FONT>
> </P>
> 
> <P><FONT SIZE=2>And I think that exactly that is the problem in the UDLR case.</FONT>
> </P>
> 
> <P><FONT SIZE=2>with best regards</FONT>
> <BR><FONT SIZE=2>Alexander</FONT>
> </P>
> 
> </BODY>
> </HTML>
>

---

From: "Robert Schellhase" <[email-masked]>
Date: Mon, 4 Dec 2000 11:19:56 -0500

Markus,

Thanks for clearing this up.
Has anyone at Avici thought of using MPLS for UDLR?

Robert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Markus
Jork
Sent: Monday, December 04, 2000 10:41 AM
To: Eyad Saheb
Cc: 'Robert Schellhase'; [email-masked]'; 'Nhat Thanh
Hoang'; 'eduard metz'; [email-masked]'
Subject: Re: MPLS for UDLR

Markus

> <P><FONT SIZE=2>Have you considered CR/LDP ?&nbsp; Ofcourse, there's the
TCP overhead (is TCP affected by UDL?), but I don't believe CR/LDP has the
bi-directional link limitation that RSVP&nbsp; does.&nbsp; However, CR/LDP
doesn't have the refreshs; the overhead is only incurred on LSP setup &amp;
neighor discovery.</FONT></P>
> <BR><FONT SIZE=2>From: [email-masked] [<A
HREF="mailto:[email-masked]">mailto:[email-masked]</A>]On Behalf Of
Robert</FONT>
> <BR><FONT SIZE=2>From: Alexander Marhold [<A
HREF="mailto:[email-masked]">mailto:[email-masked]
</A>]</FONT>

---

From: Yangguang Xu <[email-masked]>
Date: Mon, 04 Dec 2000 12:03:07 -0500

Markus,

I am confused. LSPs are uni-directional, it doesn't mean data links are
uni-directional. My understanding is that data links are always bi-directional.
In another word, logical physical interfaces to forwarding engine are
bi-directional. OSPF only treats bi-directional links as working links. Even
RSVP doesn't explicitly assume the bi-directional data link. It seems to me
that's the default

Can you give me an example of uni-directional data link in packet network?

Yangguang

---

From: Markus Jork <[email-masked]>
Date: Mon, 04 Dec 2000 12:41:36 -0500

Yangguang,

I didn't say that uni-directional links are currently in use
in packet networks. I'm not familiar with the UDLR work at all but
obviously it is an attempt to make use of uni-directional links.
So my point was that RSVP's design permits its use over uni-directional
links if someone wants to do that.

Markus