Subject: RE: What's in or out?

From: Steve Yao <[email-masked]>
Date: Fri, 8 Dec 2000 16:50:11 -0600

George,

Do you know the reason that IESG rejected the ICMP Extensions to MPLS?

Thanks,
- Steve

> > ICMP Extensions for MultiProtocol Label Switching (17870 bytes)
> 
> Rejected by the IESG
> 

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]]
> Sent: Thursday, November 30, 2000 12:16 PM
> To: Vach Kompella
> Cc: [email-masked]'; [email-masked]
> Subject: Re: What's in or out? 
> 
> 
> > A Framework for MPLS (sounds like this should have been an 
> Informational RFC
> > by now)
> 
> This is pretty much overcome by events and probably should die.
> 
> > The Assignment of the Information Field and Protocol 
> Identifier in the
> > Q.2941 Generic Identifier and Q.2957 User-to-user Signaling 
> for the Internet
> > Protocol (51283 bytes)
> 
> This is already on the RFC editor's queue
> 
> > VCID Notification over ATM link for LDP (37102 bytes)
> 
> This is already on the RFC editor's queue
> 
> > Definitions of Managed Objects for the Multiprotocol Label 
> Switching, Label
> > Distribution Protocol (LDP) (175663 bytes)
> 
> This went to IESG last call just before Thanksgiving
> 
> > MPLS Traffic Engineering Management Information Base Using 
> SMIv2 (110714
> > bytes)
> > Framework for IP Multicast in MPLS (61038 bytes)
> 
> > ICMP Extensions for MultiProtocol Label Switching (17870 bytes)
> 
> Rejected by the IESG
> 
> > LSP Modification Using CR-LDP (25333 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > IMPROVING TOPOLOGY DATA BASE ACCURACY WITH LSP FEEDBACK 
> (29565 bytes)
> > LSP Hierarchy with MPLS TE (23524 bytes)
> > MPLS/IP Header Compression (30916 bytes)
> > MPLS/IP Header Compression over PPP (17770 bytes)
> > Link Management Protocol (LMP) (89750 bytes)
> > Framework for MPLS-based Recovery (84785 bytes)
> > Multiprotocol Label Switching (MPLS) FEC-To-NHLFE (FTN) Management
> > Information Base Using SMIv2 (43776 bytes)
> > Fault Tolerance for LDP and CR-LDP (63133 bytes)
> > MPLS LDP Query Message Description (37892 bytes)
> > Signalling Unnumbered Links in CR-LDP (12534 bytes)
> > Signalling Unnumbered Links in RSVP-TE (14605 bytes)
> > Requirements for support of Diff-Serv-aware MPLS Traffic 
> Engineering (33232
> > bytes)
> > Extensions to RSVP-TE and CR-LDP for support of 
> Diff-Serv-aware MPLS Traffic
> > Engineering (26349 bytes)
> > LDP Extensions for Optical User Network Interface (O-UNI) 
> Signaling (47991
> > bytes)
> > 
> > In charter
> > ==========
> > Bullet 1
> > -------
> > Multiprotocol Label Switching Architecture (145511 bytes)
> 
> This is already on the RFC editor's queue
> 
> > Carrying Label Information in BGP-4 (14682 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > LDP Specification (271735 bytes)
> 
> This is already on the RFC editor's queue
> 
> > LDP State Machine (106866 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > RSVP-TE: Extensions to RSVP for LSP Tunnels (130237 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > Constraint-Based LSP Setup using LDP (87356 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > MPLS Support of Differentiated Services (130818 bytes)
> 
> went to difserv last call just before Thanksgiving
> 
> > MPLS Loop Prevention Mechanism (94671 bytes)
> 
> Experimental - will be published
> 
> > MPLS Label Switch Router Management Information Base Using 
> SMIv2 (104632
> > bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > LDP Applicability (12396 bytes)
> 
> This is already on the RFC editor's queue
> 
> > MPLS Label Stack Encoding (47028 bytes)
> 
> This is already on the RFC editor's queue
> 
> > 
> > Bullet 2
> > --------
> > 
> > Bullet 3
> > --------
> > Use of Label Switching on Frame Relay Networks 
> Specification (52911 bytes)
> 
> This is already on the RFC editor's queue
> 
> > MPLS using LDP and ATM VC Switching (46275 bytes)
> 
> This is already on the RFC editor's queue
> 
> > Generalized MPLS - Signaling Functional Description (94621 bytes)
> > Generalized MPLS Signaling - CR-LDP Extensions (29232 bytes)
> > Generalized MPLS Signaling - RSVP-TE Extensions (43771 bytes)
> 
> I wish.  I believe the above three are bound to go into COMA.
>  
> > Miscellaneous
> > ------------
> > Applicability Statement for CR-LDP (13805 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> > Applicability Statement for Extensions to RSVP for 
> LSP-Tunnels (16573 bytes)
> 
> went to IESG last call just before Thanksgiving
> 
> ...George
> 
> ==================================================================
> George Swallow       Cisco Systems                   (978) 244-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 08 Dec 2000 21:54:36 -0800

> Do you know the reason that IESG rejected the ICMP Extensions to MPLS?

this is from my recollection without checking, so beware.

essentially the same reasons as last time, the *unanimous* iesg conclusion
was that it
  o broke existing protocol
  o had security/privacy issues (exposed payload)

again, i could be misremembering.  so await confirmation from another
source before going to press.

also note that a design team (bonica, meyer, kompella [0]) is working on a
generic approach to a general restatement of the same problem.  i believe
they'll be dropping a trial draft as soon as the draft window opens again.

randy

[0] - sorry to fink guys