Subject: [mpls] draft-bashandy-mpls-ldp-bgp-frr-00 motivation

From: "Ilya Varlashkin" <[email-masked]>
Date: Tue, 27 Mar 2012 10:08:12 +0200

Ahmed, Kamran,

as first expressed at the mic during MPLS session, I'd like to ask you for a
clarification of the motivation behind the draft. You say that this draft
will provide faster switch-over/fail-over time compare to anything already
existing today. Do you have some numbers for comparison?

/iLya

---

From: <[email-masked]>
Date: Tue, 27 Mar 2012 10:20:52 +0200

Ilya,

The best current available mechanism is BGP PIC Edge that relay on IGP convergence to detect that remote PE is no longer reachable : PIC Edge result mainly depends on how fast your IGP is converging (sub sec or more).

Ahmed solution is an FRR solution so doesn't rely on convergence. As soon as a P router detects that the link to the protected PE fails, it will switch (using pre-programmed backup NHLFE), so there you are in FRR numbers ... 50msec - 100msec depending of implementation ...

Clearly the solution is today complex, and I hope it could be a bit simplified :)

Regards,

Stephane

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Ilya Varlashkin
Envoyé : mardi 27 mars 2012 10:08
À : IETF MPLS
Objet : [mpls] draft-bashandy-mpls-ldp-bgp-frr-00 motivation

Ahmed, Kamran,

as first expressed at the mic during MPLS session, I'd like to ask you for a clarification of the motivation behind the draft. You say that this draft will provide faster switch-over/fail-over time compare to anything already existing today. Do you have some numbers for comparison?

/iLya

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 27 Mar 2012 04:43:44 -0400

Hi,

The switchover AFTER the failure has been detected in both cases is:
Prefix independent - ie no RIB->FIB interactions
Sub 100ms for reasonable number of primary/backup pairs

So the real issue here is reliable and fast failure notification!

As for this draft - if the repairing P router is not directly connected to the primary PE it is subject to the same limitations and would initiate switchover on either multihop BFD down or IGP convergence.
Even though it is presumably closer to the failure than ingress PE and could react faster IMHO the complexity introduced is rather significant compared to the gain.

Regards,
Jeff

---

From: <[email-masked]>
Date: Tue, 27 Mar 2012 10:55:24 +0200

I totally agree with your point as if the P router is not directly connected to the protected PE, the solution doesn't bring any improvement compared to PIC Edge.
The solution as a value for a repairing P connnected to the PE and so detecting the failure immediately.
If the repairing P is remote to the failure, we are no more in a FRR case ... And I think this should be prevented ...

-----Message d'origine-----
De : Jeff Tantsura [mailto:[email-masked]] 
Envoyé : mardi 27 mars 2012 10:44
À : LITKOWSKI Stephane DTF/DERX
Cc : Ilya Varlashkin; IETF MPLS
Objet : Re: [mpls] ahRE: draft-bashandy-mpls-ldp-bgp-frr-00 motivation

Hi,

The switchover AFTER the failure has been detected in both cases is:
Prefix independent - ie no RIB->FIB interactions Sub 100ms for reasonable number of primary/backup pairs

Regards,
Jeff

On Mar 27, 2012, at 10:21 AM, "[email-masked]" <[email-masked]> wrote:

> De : [email-masked] [mailto:[email-masked]] De la part 
> de Ilya Varlashkin Envoyé : mardi 27 mars 2012 10:08 À : IETF MPLS 
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: "Ilya Varlashkin" <[email-masked]>
Date: Tue, 27 Mar 2012 10:55:25 +0200

> -----Original Message-----
> The best current available mechanism is BGP PIC Edge that relay on IGP
> convergence to detect that remote PE is no longer reachable : PIC Edge
result
> mainly depends on how fast your IGP is converging (sub sec or more).
>

I've been recently measuring convergence on not very fast RP and found that
even for 10 000 nodes it's less than 900ms. Clearly 10K nodes is unlikely to
be seen in many networks if in any at all. And for real-world sized nets
convergence is like few tens of ms - not really to worry about.
 
> Ahmed solution is an FRR solution so doesn't rely on convergence. As soon
as
> a P router detects that the link to the protected PE fails, it will switch
(using
> pre-programmed backup NHLFE), so there you are in FRR numbers ... 50msec
> - 100msec depending of implementation ...
> 

If _P_ node needs to do fail-over to backup PE depending on VPN (L3VPN, PWE,
L2VPN etc) then _P_ node needs to have VPN-level knowledge, and that
contradicts with original idea of P nodes (they shouldn't care what's
inside, only how to get to the edge independent of "payload").

> Clearly the solution is today complex, and I hope it could be a bit
simplified :)

Because of previous statement I see proposed solution as complication rather
than simplification, and because of above mentioned IGP convergence times
the gain seems to be too little when balanced against complexity.
 
/iLya

---

From: <[email-masked]>
Date: Tue, 27 Mar 2012 11:04:55 +0200

As said to you offline, I would be interrested with discussing about your testing, achieving tns of msec with convergence is something I don't really see in a real world (otherwise why should we implement TE FRR or LFA ??).

Regarding the paradigm of giving VPN info on P, yes I agree with your point, that is something to care about.
Globally the solution proposed, gives a per CE view at P router (not really per VPN) and I have some scaling concerns about it.

Today I'm not pushing this kind of solution as clearly it has some issues and brings concerns , I'm just interrested looking at it and see what could be the improvement that we could provide to some premium customers.
The improvement exists, but it must be clearly measured against scaling concern, interop with current FRR mechanism ...

As we are more discussing about the solution, rather than the LDP evolutions, I propose to move the discussion to IDR mailing list ...

-----Message d'origine-----
De : Ilya Varlashkin [mailto:[email-masked]] 
Envoyé : mardi 27 mars 2012 10:55
À : LITKOWSKI Stephane DTF/DERX; 'IETF MPLS'
Objet : RE: ahRE: [mpls] draft-bashandy-mpls-ldp-bgp-frr-00 motivation

result
> mainly depends on how fast your IGP is converging (sub sec or more).

I've been recently measuring convergence on not very fast RP and found that even for 10 000 nodes it's less than 900ms. Clearly 10K nodes is unlikely to be seen in many networks if in any at all. And for real-world sized nets convergence is like few tens of ms - not really to worry about.
 
as
(using
> - 100msec depending of implementation ...

If _P_ node needs to do fail-over to backup PE depending on VPN (L3VPN, PWE, L2VPN etc) then _P_ node needs to have VPN-level knowledge, and that contradicts with original idea of P nodes (they shouldn't care what's inside, only how to get to the edge independent of "payload").

> Clearly the solution is today complex, and I hope it could be a bit
simplified :)

Because of previous statement I see proposed solution as complication rather than simplification, and because of above mentioned IGP convergence times the gain seems to be too little when balanced against complexity.
 
/iLya

---

From: Ahmed Bashandy <[email-masked]>
Date: Tue, 27 Mar 2012 11:32:29 +0200

see comment inline about P routers having VPN level knowldege

Thanks

Ahmed

> inside, only how to get to the edge independent of "payload").
The solution defined in draft-bashandy-bgp-edge-node-frr ensures that
the core routers do NOT have VPN level knowledge. We are also working on
a solution that would actually bring down the information stored in the
core router to a very small number, much smaller than what is proposed
in version 02 of the draft.
So lookout for version 03

---

From: Ahmed Bashandy <[email-masked]>
Date: Wed, 28 Mar 2012 12:17:13 +0200

The basic idea behind any (IP)FRR mechanism is to have the repairing
node per-calculate the repair path and be directly connected to the
failure point. This allows the repairing node can make quick and small
local modification to the FIB so that traffic gets re-routed over the
per-calculated repair path within a guaranteed recovery period

This draft, just like all (IP)FRR drafts (including those that protect
multicast traffic), addresses the case of the repairing node being
adjacent  to failing network element. Detecting a remote failure is
really beyond the scope

Thanks

Ahmed