Subject: [mpls] draft-ietf-mpls-ldp-ipv6-06

From: <[email-masked]>
Date: Tue, 27 Mar 2012 10:34:48 +0200

Rajiv,
 
Regarding the discussion about separation of sessions between transport layers.
I don't have a strong position on this, I would say that like for BGP, it could be fine to let each operator choose what they want and so both possibilities implemented. 
If I compare to BGP , sometimes we are using multi AFI/SAFI on a common transport, sometimes we are separating (especially towards customer or at inter AS).
The main concern I have with using one session per transport layer, is about ok, we have two LDP session, one will transport Ipv4 FEC, one will transport IPv6 FEC. But how will we control other FEC ? On which session PW FEC will be propagated ? same for other FEC types ... In case of multiple sessions, it s important that operators may have control on FEC types transported on each session.
 
Regards,

Stephane Litkowski
FT/OF/DTF/DEX/DERX/EE IP/TAC ENTREPRISE

Operational Engineering & Support IPTAC for RAEI network
tél. +33 2 23 28 49 83
[email-masked]

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Kamran Raza <[email-masked]>
Date: Tue, 27 Mar 2012 04:56:21 -0400

IMO, the ³default² choice for a host session for different types of [ LDP
application ] FECs be as follows:

1. MP (P2MP/MP2MP) FECs: Root Address¹s AFI determines the host LDP session.
2. PW (Pwid, G. PWid, PW P2MP) FECs: Remote PE ³target² address¹s AFI
determines the host LDP session.
3. Multi-Topo (MT IP/MT IPv6) FECs: MT is just an extension to LDP FEC  so
MT IP FEC takes IPv4 session, MT IPv6 takes IPv6 session

In addition to above defaults, a  configuration option could/should be
provided per-app [and/or per-fec-type] to allow a user to change the default
AFI for host session.
 
My 2 cents.

On 12-03-27 4:34 AM, "[email-masked]"
<[email-masked]> wrote:

> I don't have a strong position on this, I would say that like for BGP, it
> could be fine to let each operator choose what they want and so both
> possibilities implemented.
> If I compare to BGP , sometimes we are using multi AFI/SAFI on a common
> transport, sometimes we are separating (especially towards customer or at
> inter AS).
> The main concern I have with using one session per transport layer, is about
> ok, we have two LDP session, one will transport Ipv4 FEC, one will transport
> IPv6 FEC. But how will we control other FEC ? On which session PW FEC will be
> propagated ? same for other FEC types ... In case of multiple sessions, it s
> important that operators may have control on FEC types transported on each
> session.
>  
> Regards,
>  
> 
> 
> Stephane Litkowski
> ______________________________________________________________________________
> ___________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> As emails may be altered, France Telecom - Orange is not liable for messages
> that have been modified, changed or falsified.
> Thank you.
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

-- 
Syed Kamran Raza
Technical Leader, SPRSG IOS-XR Routing (MPLS)
Cisco Systems, Inc.,
Kanata, ON, K2K 3E8, Canada
Ph: +1 (613) 254-4520
http://www.cisco.com

---

From: <[email-masked]>
Date: Tue, 27 Mar 2012 11:06:15 +0200

Thanks for the clarification.

________________________________

	De : Kamran Raza [mailto:[email-masked]] 
	Envoyé : mardi 27 mars 2012 10:56
	À : LITKOWSKI Stephane DTF/DERX; [email-masked]
	Cc : IETF MPLS
	Objet : Re: [mpls] draft-ietf-mpls-ldp-ipv6-06

	IMO, the "default" choice for a host session for different types of [ LDP application ] FECs be as follows:
	
	1. MP (P2MP/MP2MP) FECs: Root Address's AFI determines the host LDP session.
	2. PW (Pwid, G. PWid, PW P2MP) FECs: Remote PE "target" address's AFI determines the host LDP session.
	3. Multi-Topo (MT IP/MT IPv6) FECs: MT is just an extension to LDP FEC  so MT IP FEC takes IPv4 session, MT IPv6 takes IPv6 session
	
	In addition to above defaults, a  configuration option could/should be provided per-app [and/or per-fec-type] to allow a user to change the default AFI for host session.
	 
	My 2 cents.
	
	On 12-03-27 4:34 AM, "[email-masked]" <[email-masked]> wrote:

		Rajiv,

		Regards,

		Stephane Litkowski

		

		

________________________________