Subject: [mpls] Comments to draft-pan-shared-mesh-protection-04

From: Gregory Mirsky <[email-masked]>
Date: Tue, 20 Mar 2012 17:40:01 -0400

Dear Authors, et al.,
Please find my comments to the latest version below:
*       Section 3 "All paths are assumed to be bi-directional."
Do you make distinction between:
*       co-routed and associated bi-directional LSP
*       Coordinated and independent protection mode for associated bi-directional LSP
*       Section 5.2 "If a sender is not getting the reply within a time interval." How this time interval defined, determined. Does it have to be the same for both head- and tail-end of protecting path?
*       Section 6.1 "If the headend node is not receiving the acknowledgement within a time internal ..." Is this the same time interval referenced in Section 5.2? Is there a default value for it? Perhaps it might be named for ease of reference.

Thank you for your kind consideration.

        Regards,
                Greg

---

From: Ping Pan <[email-masked]>
Date: Thu, 22 Mar 2012 23:08:26 +0000

Hi, Gregory,

Thanks for the questions. Sorry about the delay.

See in-line

Regards,

Ping

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Tuesday, March 20, 2012 2:40 PM
To: Ping Pan; Rajan Rao; Biao Lu; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Comments to draft-pan-shared-mesh-protection-04

Dear Authors, et al.,
We are considering co-routed and associated bi-directional LSP's at this point. The key reason is that this enables us to initiate the protection switching-over operation on one headend node to take care of the entire bi-directional circuits. We need to check the design and see if the existing design can support coordinated LSP's.

*         Section 5.2 "If a sender is not getting the reply within a time interval." How this time interval defined, determined. Does it have to be the same for both head- and tail-end of protecting path?
We think that the time-out timer is a local implementation issue.
Our design is the following: upon the detection of a network failure, the headend node will trigger activation messages that traverse through the entire data path (a.k.a. LSP) to perform switch-over function on each hop. The processing overhead on each hop should be very small - in the neighborhood of BFD packet handling. As such, within one round-trip, the activation messages should enable the completion of the entire protection switching operation.
Of course, the messages are transmitted as LSP packets, and could be dropped in data networks. In this case, the headend should detect the activation failure, and switch to another protection path. To protect user traffic, the time-our interval should be small.
Similar to the implementation of BFD, the implementation for Shared Mesh Protection could be in software or with hardware-assistance. The processing complexity at each node should be similar too. Today, one can get a commercial chip to support BFD processing at near wire speed, and generate one message each 3.3 msec. We would think that, the protection message round trip delay should be well within 50msec time range. In fact, given the network topology, the activation interval should be fixed, if it is implemented with hardware-assistance.
The short answer is, the time-out should be nx50msec.
*         Section 6.1 "If the headend node is not receiving the acknowledgement within a time internal ..." Is this the same time interval referenced in Section 5.2? Is there a default value for it? Perhaps it might be named for ease of reference.
Yes. Thanks. Will make the changes.
Regards,

Ping

        Regards,
                Greg