Subject: [mpls] Fwd: Last Call: <draft-ietf-bmwg-protection-meth-09.txt> (Methodology for benchmarking MPLS protection mechanisms) to Informational RFC

From: Al Morton <[email-masked]>
Date: Wed, 07 Mar 2012 10:05:29 -0500

On this Last Call, bmwg requests any final comments.

Al
bmwg chair

>Date: Tue, 06 Mar 2012 09:21:41 -0800
>Cc: [email-masked]
>X-BeenThere: [email-masked]
>
>The IESG has received a request from the Benchmarking Methodology WG
>(bmwg) to consider the following document:
>- 'Methodology for benchmarking MPLS protection mechanisms'
>   <draft-ietf-bmwg-protection-meth-09.txt> as an Informational RFC
>
>The IESG plans to make a decision in the next few weeks, and solicits
>final comments on this action. Please send substantive comments to the
>[email-masked] mailing lists by 2012-03-20. Exceptionally, comments may be
>sent to [email-masked] instead. In either case, please retain the
>beginning of the Subject line to allow automated sorting.
>
>Abstract
>
>
>    This draft describes the methodology for benchmarking MPLS Protection
>    mechanisms for link and node protection as defined in [MPLS-FRR-EXT].
>    This document provides test methodologies and testbed setup for
>    measuring failover times while considering all dependencies that
>    might impact faster recovery of real-time applications bound to MPLS
>    based traffic engineered tunnels.  The benchmarking terms used in
>    this document are defined in [TERM-ID].
>
>
>
>
>The file can be obtained via
>http://datatracker.ietf.org/doc/draft-ietf-bmwg-protection-meth/
>
>IESG discussion can be tracked via
>http://datatracker.ietf.org/doc/draft-ietf-bmwg-protection-meth/ballot/
>
>
>No IPR declarations have been submitted directly on this I-D.
>
>
>_______________________________________________
>IETF-Announce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 12 Mar 2012 15:36:14 -0400

Dear All,
Please consider my comments for the LC:
*       I'm concerned with the very title of the document, Methodology for benchmarking MPLS protection mechanisms, even though only MPLS-TE FRR being considered while LSP end-to-end and segment protection implicitly being kept out of the scope.
*       I've found several textual inaccuracies related to both MPLS and BFD to make me wonder if the document was liasioned to MPLS WG.
*       List of acronyms is missing - PLR, OIR, LOS, AIS, etc.
*       Introduction. I think that for "planned link or node failure" MBB is more efficient and useful than FRR. But MBB is not being mentioned in the document.
*       Introduction. "A correlated failure is the simultaneous occurrence of two or more failures." Personally, as correlated events I consider events with cause-effect relationship.
*       Introduction. Path restoration after FRR discussion does not appear logical, in the scope of benchmarking document.
*       Document Scope. "Protection from Bi-directional Forwarding Detection (BFD) is outside the scope of this document." I frankly couldn't decode this sentense.
*        Document Scope. Several references to Path Restoration as Re-optimization - doubt that it belongs in the document at all.
*        Sections 6.1.1 through 6.2.4 - what is relevance of listing numbers of labels in the stack?
*       Peerformance of control plane should be outside of the scope of benchmarking as it is end-to-end metrics, not explicitly of DUT.

Regards,
        Greg