Subject: Re: [mpls] Note on draft-cheung-mpls-tp-mesh-protection-05

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Fri, 16 Mar 2012 11:31:30 +0900

Greg,

You are right.

Indeed, there exists a case that just a node cannot be viewed as being shared.

Thanks for the sofisticated consideration.

Jeong-dong and Taesik

-----Original Message-----
From: "Gregory Mirsky" <[email-masked]>
From Date: 2012-03-15 AM 10:01:26
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc:
Subject: Note on draft-cheung-mpls-tp-mesh-protection-05

Dear Authors, et al.,

I have a single note to the draft-cheung-mpls-tp-mesh-protection-05:

Section 2.2 "The shared protection resource may be a node, …" I think that a node by itself can not be viewed as shared resource. Only if BW of a link, physical or logical, is being shared, only then terminating nodes can be viewed as shared resource.

Regards,

Greg

---

From: Ping Pan <[email-masked]>
Date: Thu, 22 Mar 2012 16:36:54 -0700

Hi, Jeong-dong and Taesik,

After reading your draft, I am a bit confused. Could you please explain the
operation in this network using your scheme?

           ----- B ------- C ----
          /                      \
         /                        \
        A                          D
         \                        /
          \                      /
           ==== E === F === G ===
          /                      \
         /                        \
        H                          K
         \                        /
          \                      /
           ----- I ------- J ----

Link E-F and F-G are shared links to protect failure from headend nodes A,
H, D, K and other nodes in the network.

In case of failure that has been detected by A, how does A sends the
notification to E, F and G. In your draft, you have mentioned to transmit
messages real fast three times to reach to the desired nodes. But do you
imply there is a control LSP for each node E, F and G?

I think this is the key difference between your proposal and ours (
http://www.ietf.org/id/draft-pan-shared-mesh-protection-04.txt). We always
initiate activation messages from headends over the entire protecting
LSP's. Given its simplicity, we can always get the switch-over completed
within a short interval.

In your proposal, there seems to be a few underlying assumptions:

1. By re-transmitting critical protection messages three times in packet
networks, you assume they would be delivered reliably. Don't think this is
how the packet networks work.

2. There is always a special LSP to deliver control messages between the
headend to the protection nodes, even if the protection nodes are transit
LSR's. In one network, we see the network diameter being 16 hops, with a
few hundred edge nodes. In this type of meshy network, don't think you can
setup thousands of LSP's between headend nodes to the transit nodes just
for the protection messages.

Please confirm if my understand is wrong.

Regards,

Ping

On Thu, Mar 15, 2012 at 7:31 PM, Ryoo, Jeong-dong <[email-masked]> wrote:

> *From:* "Gregory Mirsky" <[email-masked]>
> *From Date:* 2012-03-15 AM 10:01:26
> *To:* "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Cc:*
> *Subject:* Note on draft-cheung-mpls-tp-mesh-protection-05
>
>  Dear Authors, et al.,
>    - Section 2.2 "The shared protection resource may be a node, …" I
>    think that a node by itself can not be viewed as shared resource. Only if
>    BW of a link, physical or logical, is being shared, only then terminating
>    nodes can be viewed as shared resource.
>
>
>         Regards,
>                 Greg
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Yaacov Weingarten <[email-masked]>
Date: Fri, 23 Mar 2012 06:59:18 +0200

Ping, hi

In your scenario -
1. We consider E-F-G as a segment rather than as a collection of links.
This is one of the advantages of MPLS - that we do not need to consider
each link separately but rather "talk" to the signalled LSP or segment.
2. Therefore, A & H need only to communicate with E, K & D need only
communicate with G and E needs to communicate with G.  F being an
intermediate node on a pre-reserved segment is transparent to this
communication and the allocation of the resources are immediate as
supported by the MPLS framework.
3. As to whether this is true for all packet switched networks - it may not
be completely true for Ethernet but this is one of the justifications for
defining MPLS, by my understanding, i.e. not to have to address each link
along a path!

Hope this clarifies a little,
yaacov
On Mar 23, 2012 1:37 AM, "Ping Pan" <[email-masked]> wrote:

> After reading your draft, I am a bit confused. Could you please explain
> the operation in this network using your scheme?
>
>            ----- B ------- C ----
>           /                      \
>          /                        \
>         A                          D
>          \                        /
>           \                      /
>            ==== E === F === G ===
>           /                      \
>          /                        \
>         H                          K
>          \                        /
>           \                      /
>            ----- I ------- J ----
>
>
> http://www.ietf.org/id/draft-pan-shared-mesh-protection-04.txt). We
> always initiate activation messages from headends over the entire
> protecting LSP's. Given its simplicity, we can always get the switch-over
> completed within a short interval.
>

---

From: Ping Pan <[email-masked]>
Date: Thu, 22 Mar 2012 22:19:51 -0700

> supported by the MPLS framework.

But, here is one of the original problems that we are confused about: how
does A & H "talk" to E, and K&D "talk" to G? In the context of TP network,
the messages are not routed. But unless there exists a special LSP or
channel established ahead of time, the nodes cannot communicate, no?

> defining MPLS, by my understanding, i.e. not to have to address each link

Not sure I understand this fully. But regardless of MPLS or Ethernet
networks, the nodes need to talk to each other. In the draft, it seems that
it is to establish a special LSP between the headends and all other
intermediate nodes that may participate in the protection. For large
networks, that could be a lot of control-only LSP's. In fact, that's an
entire new control-plane by itself. Not sure if this is manageable.

Regards,

Ping

>> Link E-F and F-G are shared links to protect failure from headend nodes
>> A, H, D, K and other nodes in the network.
>>
>> On Thu, Mar 15, 2012 at 7:31 PM, Ryoo, Jeong-dong <[email-masked]>wrote:
>>
>>>  Greg,
>>>
>>> You are right.
>>>
>>> [email-masked]" <[email-masked]>, "[email-masked]"
>>> <[email-masked]>, "[email-masked]" <[email-masked]>
>>> *Cc:*