Subject: Re: [mpls] Comments on draft-ezy-mpls-1ton-protection-01

From: Yaacov Weingarten <[email-masked]>
Date: Thu, 29 Mar 2012 10:52:57 +0200

Greg, hi

Unfortunately, I am not sure that I fully understand all of your comments,
but I will try to address them as well as possible inline.

BR,
yaacov

On Mar 29, 2012 9:35 AM, "Gregory Mirsky" <[email-masked]>
wrote:
>
> Dear Authors, et al.,
> Please kindly consider my comments to the document:
> Section 1.2, second bullet. Is LER-A expecting to receive W1 from P after
is sends PSC message to LER-Z?

yw> Yes, LER-A is prepared to acept W1 traffic from the protection path,
but will not transport the traffic until it is sure that LER-Z can process
it.

> Section 1.2, third bullet. I think that part of the last sentence doesn't
correctly reflect LER-A to LER-Z flow of W1: "… LER-Z receives the W1 data
traffic from P …". I believe that LER-Z would not be receiving W1 until, as
described in bullet #4, LER-A processes PSC reply from LER-Z. Perhaps the
following can replace the text in question: "… LER-Z doesn't receive W1
data traffic …" If the intention of the phrase in question is to indicate
that LER-Z is prepared to receive W1 from P, then wording might be
something like "… LER-Z is ready to receive the W1 data traffic from P if
and when LER-A sends them …"

yw> yes, your interpretation is correct and we will clarify the text.

> Section 1.2 is not consistent with Section 3.3.1.2

yw> thank you for pointing this out - we will align the two descriptions.

> Section 1.4 I think that in case of FIFO priority policy PSC must be used
to guarantee deterministic switchover to protected path by analyzing MEP_ID
and introduction of tie breaking rule(s), not to leave it to an operator.

yw> not sure that you are really saying anything different from what the
text states. In the final analysis - the MEP_ID is assigned by the operator
in the same way that an explicit priority would be assigned.  The purpose
of this section is merely to clarify that the assignment of priority and
the consistency check of the priority definitions are out of scope of this
document!

> Section 3.3.1.1 - uni-directional non-locking 1:n scenario - simultaneous
detection in opposite directions.

yw> Not sure what the comment is - are you suggesting another scenario to
be explained?

> Section 3.3.3.3, Figure 8. Not clear when and if LER-A and LER-Z remove
W2 from P

yw> There is a basic assumption here that the LER will not transport
traffic from two working paths on the protection path simultaneously.
Therefore, when the text states that an LER "bridges W1 into P" the
implication is that the W2 traffic is no longer being tranported on P.

> Section 4.3.2, as mentioned in note above, protection at LER-A and LER-Z
might be triggered by almost simulteneous failures of two working paths,
e.g. W1 and W2 respectively, of the same priority. Thus FIFO should be used
but since LER-A would protect W1 while LER-Z - W2 a tiebreaker should be
used to avoid situation where both working paths would be partially locked
out and protection would not be useful.

yw>  Not sure what the comment here is - I agree that there is a need for a
tiebreaker, but I am not sure where you found text that precludes this.

>
> Some generalization question: "Can, and if "yes", is it worth it, 1:n be
viewed as special case of Shared Mesh Protection?" Personally, I think that
1:n can be viewed as special case of SMP but optimization of operation for
1:n makes it not worth of applying generic SMP solution.

yw> My personal opinion is that 1:n has a major difference from SMP due to
the fact that the endpoints of the working paths and the protection path
are identical.  Therefore there is no need for the additional coordination
between the endpoints that is necessary in SMP.  There is also no need to
coordinate "shared segments" in 1:n protection - since the sharing here is
of the entire protection path.
>
> Thank you for your kind consideration.
>
>         Regards,
>                 Greg
>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 29 Mar 2012 05:16:31 -0400

Hi Yaakov,
apologies for perhaps too much implicit commenting on my part. I've snipped parts that we agree on and added couple comments tagged GIM>>.

    Regards,
        Greg

________________________________
[...]
 > Section 1.4 I think that in case of FIFO priority policy PSC must be used to guarantee deterministic switchover to protected path by analyzing MEP_ID and introduction of tie breaking rule(s), not to leave it to an operator.

yw> not sure that you are really saying anything different from what the text states. In the final analysis - the MEP_ID is assigned by the operator in the same way that an explicit priority would be assigned.  The purpose of this section is merely to clarify that the assignment of priority and the consistency check of the priority definitions are out of scope of this document!

GIM>> I've mentioned MEP-ID as potential source for tiebreaking but since MEP-ID is not signalled by 1:n message, that's mute point. As suggested below, document need to specify tiebraking procedure for bi-directional protection switchover of two working paths of equal priority.

> Section 3.3.1.1 - uni-directional non-locking 1:n scenario - simultaneous detection in opposite directions.

yw> Not sure what the comment is - are you suggesting another scenario to be explained?

GIM>> It was original intention but now I realize that all working paths and protecting path are expected to be uni-directional, e.g. from LER-A to LER-Z and thus LER-A would do the local arbitration.

> Section 3.3.3.3, Figure 8. Not clear when and if LER-A and LER-Z remove W2 from P

yw> There is a basic assumption here that the LER will not transport traffic from two working paths on the protection path simultaneously.  Therefore, when the text states that an LER "bridges W1 into P" the implication is that the W2 traffic is no longer being tranported on P.

GIM>> Perhaps it can be made as explicit note in the document.

> Section 4.3.2, as mentioned in note above, protection at LER-A and LER-Z might be triggered by almost simulteneous failures of two working paths, e.g. W1 and W2 respectively, of the same priority. Thus FIFO should be used but since LER-A would protect W1 while LER-Z - W2 a tiebreaker should be used to avoid situation where both working paths would be partially locked out and protection would not be useful.

yw>  Not sure what the comment here is - I agree that there is a need for a tiebreaker, but I am not sure where you found text that precludes this.

GIM>> I think that the document need to define such tiebreaking rule(s) not merely allow them to be proprietary implemented.

>
> Some generalization question: "Can, and if "yes", is it worth it, 1:n be viewed as special case of Shared Mesh Protection?" Personally, I think that 1:n can be viewed as special case of SMP but optimization of operation for 1:n makes it not worth of applying generic SMP solution.

yw> My personal opinion is that 1:n has a major difference from SMP due to the fact that the endpoints of the working paths and the protection path are identical.  Therefore there is no need for the additional coordination between the endpoints that is necessary in SMP.  There is also no need to coordinate "shared segments" in 1:n protection - since the sharing here is of the entire protection path.

GIM>> I think we do agree on this one too.