Subject: [mpls] I-D Action: draft-ietf-mpls-tp-itu-t-identifiers-03.txt

From: [email-masked]
Date: Tue, 06 Mar 2012 01:51:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

	Title           : MPLS-TP Identifiers Following ITU-T Conventions
	Author(s)       : Rolf Winter
                          Eric Gray
                          Huub van Helvoort
                          Malcolm Betts
	Filename        : draft-ietf-mpls-tp-itu-t-identifiers-03.txt
	Pages           : 12
	Date            : 2012-03-06

   This document specifies an extension to the identifiers to be used in
   the Transport Profile of Multiprotocol Label Switching (MPLS-TP).
   Identifiers that follow IP/MPLS conventions have already been
   defined.  This memo augments that set of identifiers for MPLS-TP
   management and OAM functions to include identifier information in a
   format typically used by the ITU-T.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-mpls-tp-itu-t-identifiers-03.txt

---

From: Rolf Winter <[email-masked]>
Date: Tue, 6 Mar 2012 09:57:52 +0000

MPLS WG,

this new version has expanded a lot based on comments received from the list. While the amount of text has increased significantly, the actual content has changed little. Most IDs defined in the document are equal to the ones defined in RFC 6370 with the exception when global uniqueness is required (the Global_ID is exchanged with the ICC_Operator_ID, an ID which is based on the ICC rather than on the AS number). In addition the maintenance IDs differ. Feedback highly appreciated. 

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:i-d-announce-
> [email-masked]] On Behalf Of [email-masked]
> Sent: Dienstag, 6. März 2012 10:51
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-mpls-tp-itu-t-identifiers-03.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Multiprotocol Label
> Switching Working Group of the IETF.
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "t.petch" <[email-masked]>
Date: Wed, 7 Mar 2012 15:09:32 +0100

----- Original Message -----
From: "Rolf Winter" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, March 06, 2012 10:57 AM

MPLS WG,

this new version has expanded a lot based on comments received from the list.
While the amount of text has increased significantly, the actual content has
changed little. Most IDs defined in the document are equal to the ones defined
in RFC 6370 with the exception when global uniqueness is required (the Global_ID
is exchanged with the ICC_Operator_ID, an ID which is based on the ICC rather
than on the AS number). In addition the maintenance IDs differ. Feedback highly
appreciated.

<tp>
The elephant in the room is the lack of a Content Transfer Encoding that allows
the ICC_Operator_Id to fit into the space allocated in the protocols for an AS
number.  Arguably, that is not part of this specification, but if not here,
where?

Tom Petch

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3
6BL | Registered in England 2832014

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Rolf Winter <[email-masked]>
Date: Wed, 7 Mar 2012 19:55:48 +0000

Hi,

Like here http://tools.ietf.org/html/draft-cui-mpls-tp-on-demand-cv-id-00 e.g. Or other places where it is actually used. Just like it was done for the IP-based IDs (e.g. RFC 6426). 

Best,

Rolf

> From: t.petch [mailto:[email-masked]]
> Sent: Mittwoch, 7. März 2012 15:10
> To: Rolf Winter; [email-masked]
> Subject: Re: [mpls] I-D Action: draft-ietf-mpls-tp-itu-t-identifiers-
> 03.txt
> 
> While the amount of text has increased significantly, the actual
> content has changed little. Most IDs defined in the document are equal
> to the ones defined in RFC 6370 with the exception when global
> uniqueness is required (the Global_ID is exchanged with the
> ICC_Operator_ID, an ID which is based on the ICC rather than on the AS
> number). In addition the maintenance IDs differ. Feedback highly
> appreciated.
> 
> <tp>
> The elephant in the room is the lack of a Content Transfer Encoding
> that allows the ICC_Operator_Id to fit into the space allocated in the
> protocols for an AS number.  Arguably, that is not part of this
> specification, but if not here, where?
> 
> Tom Petch
> 
> Best,
> 
> Rolf
> 
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
>