Subject: [mpls] comments on draft-chen-mpls-p2mp-egress-protection

From: Yimin Shen <[email-masked]>
Date: Wed, 4 Apr 2012 13:11:38 -0400

Huaimo, 

As I commented during your presentation, the current draft only supports 1:1 protection. IOW, in order to protect X primary PEs, you would need X dedicated backup PEs. Therefore, from the perspective of cost efficiency, the draft may need to consider 1:N protection and "dual-role" PE (i.e. a primary PE also serves as a backup PE for another primary PE).

OTOH, even with the current 1:1 protection, I see a more fundamental issue with the following type of topology, where two primary PEs (i.e. their paths) share the same penultimate hop router, and the paths to their backup PEs share the same downstream link from the penultimate hop router. 

Please see an example below. Assume a CE is dual-homed to PE-prim-1 and PE-back-1, and another CE is dual-homed to PE-prim-2 and PE-back-2 (not shown in the picture). If PE-prim-1 fails, P1 will turn on traffic towards P2, hoping the traffic to reach PE-back-1. However, not only PE-back-1 will receive the traffic, but also PE-back-2 as well. This is because the path P1 -> P2 -> PE-back-2 shares the  link P1-P2 with the path P1 -> P2 ->PE-back-1. Hence, the CE connected to PE-prim-2 and PE-back-2 will receive duplicate traffic from both PEs at the same time. I think the draft needs to address this kind problem.

PE-in ---------- P1 ---------- PE-prim-1
                 | \---------- PE-prim-2
                 |
                 |
                 P2 ---------- PE-back-1
                   \---------- PE-back-2

Thanks,

-Yimin Shen
 Juniper Networks

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 9 Apr 2012 01:19:06 +0000

Hi Yimin,

    See my answers inline below.

Best Regards,
Huaimo
-----Original Message-----
From: Yimin Shen [mailto:[email-masked]]
Sent: Wednesday, April 04, 2012 1:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: comments on draft-chen-mpls-p2mp-egress-protection

Huaimo,

As I commented during your presentation, the current draft only supports 1:1 protection. IOW, in order to protect X primary PEs, you would need X dedicated backup PEs. Therefore, from the perspective of cost efficiency, the draft may need to consider 1:N protection and "dual-role" PE (i.e. a primary PE also serves as a backup PE for another primary PE).
[[Chen,Huaimo]] One to one protection and one to many protection (or bypass protection) are in our mind when we started our drafts. It may be better to have one thing at a time.

OTOH, even with the current 1:1 protection, I see a more fundamental issue with the following type of topology, where two primary PEs (i.e. their paths) share the same penultimate hop router, and the paths to their backup PEs share the same downstream link from the penultimate hop router.
[[Chen,Huaimo]] Your assumption seems not true. Thus your conclusion is not valid. We may have two primary PEs sharing the same penultimate hop node. However, when we compute backup paths to their backup PEs, we will avoid the situation that the paths to their backup PEs share the same downstream link from the penultimate hop node.

Thanks,

-Yimin Shen
 Juniper Networks

---

From: Yimin Shen <[email-masked]>
Date: Wed, 11 Apr 2012 17:54:15 -0400

Huaimo,

I think 1:N protection is eventually needed due to its efficiency, flexibility and scalability. It also covers 1:1 protection as a special case. However, your current 1:1 solution doesn't seem to be extendable to support 1:N. So my concern is if there is a solution for 1:N in the future, it would be a different approach than this draft. Why would we need this 1:1 specific draft now?

The draft needs to discuss the detail about how to detect and avoid the situation in backup path computation. IMO, you would hit the same situation if two backup paths share a link in common, regardless of whether they share a same PLR or not.

Thanks,

-Yimin

From: Huaimo Chen [mailto:[email-masked]] 
Sent: Sunday, April 08, 2012 9:19 PM
To: Yimin Shen; [email-masked]
Cc: [email-masked]
Subject: RE: comments on draft-chen-mpls-p2mp-egress-protection 

Hi Yimin,

Best Regards,
Huaimo
-----Original Message-----
From: Yimin Shen [mailto:[email-masked]] 
Sent: Wednesday, April 04, 2012 1:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: comments on draft-chen-mpls-p2mp-egress-protection 
 
Huaimo, 

 

Thanks,
 
-Yimin Shen
Juniper Networks