Subject: [mpls] entropy label draft: reserved label for ELI

From: Kireeti Kompella <[email-masked]>
Date: Thu, 12 Apr 2012 12:47:44 -0700

Hi All,

Following up on the presentation at IETF 83, I promised to "take this to the list".

The two questions are:
1) should we make the ELI a "well-known" reserved label?
2) should we associate the EL with tunnel labels or with application labels?

This email is to poll the list about (1).

Making the ELI a reserved label has the following benefits:
a) Transit LSRs can hash on labels up to the ELI and one more (the EL), rather than processing all labels in the label stack.

b) Similar to (a), transit LSRs could use a Reserved ELI Label as a means of bailing out early from grabbing "deeper" fields (e.g., IP headers within Ethernet within ...) for hashing.

c) Transit LSRs, (particularly ones doing LDP/RSVP tunneling), can avoid adding another entropy-label for the RSVP tunnel *if* the transit LSR finds a reserved ELI already in the stack.  Call this a 'short circuit' rule.

d) The short circuit rule can also be used for Carrier of Carrier VPNs and other situations with label hierarchy.

e) A reserved ELI obviates the need for upstream ELI allocation for mLDP and P2MP RSVP-TE.

(Thanks to Shane for providing some of the above.)

The main drawback is the scarcity of reserved labels, which hopefully is addressed by the pixie label draft.

So, the question is: should we make the ELI a reserved label?  (If no, a short reason would be helpful.)

Kireeti.

---

From: John E Drake <[email-masked]>
Date: Thu, 12 Apr 2012 13:32:34 -0700

Yes.  This is an IQ test and we want to pass it.

Sent from my iPhone

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Kireeti Kompella
> Sent: Thursday, April 12, 2012 12:48 PM
> To: [email-masked]
> Subject: [mpls] entropy label draft: reserved label for ELI
> 
> Hi All,
> 
> a) Transit LSRs can hash on labels up to the ELI and one more (the EL),
> rather than processing all labels in the label stack.
> 
> b) Similar to (a), transit LSRs could use a Reserved ELI Label as a
> means of bailing out early from grabbing "deeper" fields (e.g., IP
> headers within Ethernet within ...) for hashing.
> 
> c) Transit LSRs, (particularly ones doing LDP/RSVP tunneling), can
> avoid adding another entropy-label for the RSVP tunnel *if* the transit
> LSR finds a reserved ELI already in the stack.  Call this a 'short
> circuit' rule.
> 
> d) The short circuit rule can also be used for Carrier of Carrier VPNs
> and other situations with label hierarchy.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 12 Apr 2012 17:14:32 -0400

Hi Kireeti,

For all the reasons mentioned below (and hence consequences for the FW performance ) I think we should be making ELI a "well-known" reserved label.

Regards,
Jeff
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, April 12, 2012 12:48 PM
To: [email-masked]
Subject: [mpls] entropy label draft: reserved label for ELI

Hi All,

The two questions are:

Kireeti.

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 12 Apr 2012 18:01:36 -0700

Hi Kireeti,

What is the relationship between this EL and the fat Label (RFC6391)? Can they both coexist? How many Entropy Labels can exist in a stack? How many ELI can exist in a stack?

Thanks
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, April 12, 2012 12:48 PM
To: [email-masked]
Subject: [mpls] entropy label draft: reserved label for ELI

Hi All,

The two questions are:

Kireeti.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 13 Apr 2012 09:26:53 -0400

My Opinion on your poll -

1) Yes - Make ELI a reserved label
2) EL with application label would be my preference (some of your (a) to (e) points below 
   seems to favor that option, in my view) and would address runaway stack depth increase concerns.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, April 12, 2012 3:48 PM
To: [email-masked]
Subject: [mpls] entropy label draft: reserved label for ELI

Hi All,

The two questions are:

Kireeti.

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Apr 2012 08:52:45 -0700

Himanshu,

>   seems to favor that option, in my view) and would address runaway stack depth increase concerns.

Thanks for your replies.

The points a-e were for a reserved ELI, not for (2), for which you should see my other mail.

I fully understand your comment about "runaway stack depth", and am very sorry that it's a problem for you.  Of course, not doing entropy labels at all is always an option, and that saves yet another label.

Kireeti

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Apr 2012 12:16:46 -0700

Hi Shahram,

On Apr 12, 2012, at 18:01 , Shahram Davari wrote:

> Hi Kireeti,
> 
> What is the relationship between this EL and the fat Label (RFC6391)?

Same thing.

> Can they both coexist? How many Entropy Labels can exist in a stack? How many ELI can exist in a stack?

Yes, they can coexist.  In theoretical cases, there can be many entropy labels; each one, except the fat PW entropy label, must be preceded by an ELI.

Practically speaking, there would be just one entropy label, either below the PW label (for fat PWs), or below the tunnel label (for all other apps, assuming that's what we agree on).  The main case for multiple entropy labels is inter-provider hierarchical situations.

HTH,
Kireeti.

---

From: "Shahram Davari" <[email-masked]>
Date: Fri, 13 Apr 2012 19:23:41 +0000

Thanks Kireeti,

One more question. Why do LSRs need to do Hashing just up to the ELI+1? Can't they hash the whole label stack? If they can then, why is there a need for ELI?

Thx
Shahram

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]] 
Sent: Friday, April 13, 2012 12:17 PM
To: Shahram Davari
Cc: Kireeti Kompella; [email-masked]
Subject: Re: entropy label draft: reserved label for ELI

Hi Shahram,

Same thing.

HTH,
Kireeti.

---

From: Alia Atlas <[email-masked]>
Date: Fri, 13 Apr 2012 16:16:00 -0400

I support making the ELI a well-known reserved label.   There is a
benefit in intermediate LSRs being able to recognize the ELI and use
the entropy label underneath for hashing.

Alia

---

From: John E Drake <[email-masked]>
Date: Fri, 13 Apr 2012 13:15:39 -0700

Shahram,

A transit LSR can use the whole label stack if it wishes.  The ELI needs to be there for the egress LSR, so it knows that an EL is included in the label stack and can toss it (along with the ELI).

Thanks,

John 

Sent from my iPhone

> Shahram Davari
> Sent: Friday, April 13, 2012 12:24 PM
> To: Kireeti Kompella
> Cc: [email-masked]
> Subject: Re: [mpls] entropy label draft: reserved label for ELI
> 
> Thanks Kireeti,
> 
> One more question. Why do LSRs need to do Hashing just up to the ELI+1?
> Can't they hash the whole label stack? If they can then, why is there a
> need for ELI?
> 
> Thx
> Shahram
> 
> Yes, they can coexist.  In theoretical cases, there can be many entropy
> labels; each one, except the fat PW entropy label, must be preceded by
> an ELI.
> 
> Practically speaking, there would be just one entropy label, either
> below the PW label (for fat PWs), or below the tunnel label (for all
> other apps, assuming that's what we agree on).  The main case for
> multiple entropy labels is inter-provider hierarchical situations.
> 
> HTH,
> Kireeti.
> 
> > Thanks
> > Shahram
> >
> > a) Transit LSRs can hash on labels up to the ELI and one more (the
> EL), rather than processing all labels in the label stack.
> >
> > d) The short circuit rule can also be used for Carrier of Carrier
> VPNs and other situations with label hierarchy.
> >

---

From: Shane Amante <[email-masked]>
Date: Fri, 13 Apr 2012 14:59:51 -0600

> 1) should we make the ELI a "well-known" reserved label?

Yes, please.  I think that this should vastly simplify label processing by both transit and egress LSR/LER's and in the cases of upstream assigned labels (p2mp LSP's), to mention but a few of the positive benefits.

-shane

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 13 Apr 2012 18:41:52 -0400

I completely agree with Shane.

Cheers,
Andy