Subject: [mpls] Scalability with regards to draft-chen-mpls-mldp-deployment-via-p2p-tunnels-00

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 2 Apr 2012 09:34:17 +0200

Dear Emily & Quintin,

The solution in this draft requires a mLDP router upstream of the non-mLDP router to do the packet forwarding and replication. The receiver interest is signaled to the upstream router via tLDP sessions. The upstream router will end up with the number of tLDP session to all the of the receivers downstream of the non-mLDP router, and will have to replicate the multicast packets over P2P LSPs to them.je

This has exactly the same tLDP scale considerations as discussed in the context of draft-wijnands-mpls-mldp-node-protection-00, yet for mLDP node protection it seems to be a concern for you?

Thx,

Ice.

BTW, we already have had a fair bit of discussion on the list Oct 2011 regarding the other concerns for this draft.

---

From: "Chenying (Emily)" <[email-masked]>
Date: Mon, 2 Apr 2012 20:43:58 +0000

Dear Ice,

Thanks for your comments. IMO, the mldp-via-p2p-tunnel and mldp-node-protection mechanisms are under different situations. The following is my 2 cents, please see whether this make sense to you. Thanks.

The scalability issue would exist only when N node has a large number of downstream routers. In mLDP deployment scenario, if users want to upgrade the network into a mLDP capable one, such 'heavy-duty' N node should be the first priority for upgrade, because it really need packet duplication functionality. Once the N node is upgraded, then t-ldp is not needed, and there is no scalability issue at all. But in mldp-node-protection scenario, such 'heavy-duty' N node should be the first priority for node protection, because it is really important for the multicast tree. Then the t-ldp sessions are always needed, and the scalability issue will always exist. This is why I think the mldp-via-p2p-tunnel and mldp-node-protection mechanisms are under different situations.

Best regards,
Emily Chen 

-----Original Message-----
From: IJsbrand Wijnands [mailto:[email-masked]] 
Sent: Monday, April 02, 2012 12:34 AM
To: Chenying (Emily); Quintin zhao
Cc: [email-masked]
Subject: Scalability with regards to draft-chen-mpls-mldp-deployment-via-p2p-tunnels-00

Dear Emily & Quintin,

Thx,

Ice.

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 3 Apr 2012 10:25:38 +0200

Hi Emily,

> The scalability issue would exist only when N node has a large number of downstream routers. In mLDP deployment scenario, if users want to upgrade the network into a mLDP capable one, such 'heavy-duty' N node should be the first priority for upgrade, because it really need packet duplication functionality. Once the N node is upgraded, then t-ldp is not needed, and there is no scalability

If a router can be upgraded to full mLDP functionality, that always has the preference. I don't see when you would upgrade it with this lite-mLDP if the router can support full mLDP. Unless you are talking about a hardware upgrade/replace of the router.

> issue at all. But in mldp-node-protection scenario, such 'heavy-duty' N node should be the first priority for node protection, because it is really important for the multicast tree. Then the t-ldp

In these cases I would also not apply P2P based node protection to such heavy-duty router. I would rather rely on HA capability of it. As discussed during the meeting, there are scalability limitations with P2P replication. 

> sessions are always needed, and the scalability issue will always exist. This is why I think the mldp-via-p2p-tunnel and mldp-node-protection mechanisms are under different situations.

This is the part we disagree on, the scalability limitation of the solution is not tLDP, its the excessive replication over P2P LSPs and the increase of bandwidth. Suppose the node N has 100 tLDP sessions (which is really low), the upstream router potentially has to pump out 100 times the multicast traffic compared to 1x if node N support mLDP.

So in my opinion both solutions have the same considerations, you can only apply them if the P2P replication is not excissive.

Thanks,

Ice.

---

From: "Chenying (Emily)" <[email-masked]>
Date: Tue, 3 Apr 2012 17:40:11 +0000

Please see [Emily] inline, thanks.

Best regards,
Emily Chen 

-----Original Message-----
From: IJsbrand Wijnands [mailto:[email-masked]] 
Sent: Tuesday, April 03, 2012 1:26 AM
To: Chenying (Emily)
Cc: [email-masked]
Subject: Re: Scalability with regards to draft-chen-mpls-mldp-deployment-via-p2p-tunnels-00

Hi Emily,

[Emily] Yes, I was talking about a hardware upgrade or replacement. If user has an upgrade list in hand, it is reasonable to put such 'heavy-duty' node at the first priority for fully upgrade. Then there is no t-ldp issue over it. In other words, the mldp-via-p2p mechanism is likely to be used on those less-important nodes, which might temporally not get the chance of upgrading hardware. 

[Emily] Not sure what kind of 'HA capability' you are talking about? Anyway, I totally agree with you that p2p-based node protection is not a good idea for such 'heavy-duty' node.

[Emily] I think we are on the same page. Indeed, p2p duplication is a bigger issue than maintaining the t-ldp sessions. But it might be not a good idea to ignore the risk/burden of maintaining the huge number of t-ldp sessions when there is other issue.

[Emily] If both solutions are deployed on the same 'heavy-duty' node, they indeed have the same scalability issues on both t-ldp sessions and p2p replications. But what I am trying to say is that, in real deployment, such 'heavy-duty' node has less chance to deploy mldp-via-p2p-tunnel because it should be fully upgrade, but it has more possibility to deploy mldp-node-protection because it is really important for the multicast tree.

Thanks,

Ice.

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 3 Apr 2012 20:05:02 +0200

Emily,

> [Emily] Not sure what kind of 'HA capability' you are talking about? Anyway, I totally agree with you that p2p-based node protection is not a good idea for such 'heavy-duty' node.

HA means High Availability, it protects the router from a control plane failure by having dual RP's in hot standby mode. It allows the router to  do Non Stop Forwarding (NSF) and recover from control plane failure while continuing to forward. This improves the reliability and uptime of the router making it less necessary to apply node protection. This is typically a feature that high end routers have.

Thx,

Ice.

---

From: "Chenying (Emily)" <[email-masked]>
Date: Tue, 3 Apr 2012 18:31:22 +0000

Oh, I thought you were saying other protection mechanisms such as p2mp based protection. :-)

I totally agree that GR or NSR can help a lot when control plane fails. But what if there is a power-off accident, or the protected node just crashes? That's the situations for which we are working hard to develop an ideal protection mechanism.

Best regards,
Emily Chen 

-----Original Message-----
From: IJsbrand Wijnands [mailto:[email-masked]] 
Sent: Tuesday, April 03, 2012 11:05 AM
To: Chenying (Emily)
Cc: [email-masked]
Subject: Re: [mpls] Scalability with regards to draft-chen-mpls-mldp-deployment-via-p2p-tunnels-00

Emily,

Thx,

Ice.