Subject: [mpls] FW: MPLS entropy : clarification on the need for ELI

From: "Rajeev Manur" <[email-masked]>
Date: Fri, 13 Apr 2012 21:03:57 +0000

Hi All,

I am trying to get more clarity on the justification for using an ELI. Thanks to Kireeti for his feedback. I have one more question added inline below. Adding the discussion to the list so that others can also chime in.

Thanks !
--Rajeev

------------------------------------------------------------------

Hi Kireeti,

>I am trying to understand the justification for using a ELI instead of using TL label context to indicate the presence >of EL label,

If you mean, everyone advertise two LDP labels, one for EL, one without, that was a non-starter ... that doubles state in the core, and worse when you factor in LFA.

[Rajeev] Why do we need 2 LSPs. An LSP either has EL or it does'nt? If we have an LSP with EL, then all LSRs that push naked IP into the LSP would have to add entropy label. Is your intent to keep the transit LSRs isolated from having to compute/add EL?

Thanks !
--Rajeev

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]] 
Sent: Friday, April 13, 2012 8:17 AM
To: Rajeev Manur
Cc: [email-masked]
Subject: Re: MPLS entropy : clarification

Hi Rajeev,

On Apr 12, 2012, at 19:22, "Rajeev Manur" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Shane/Kireeti,

I am trying to understand the justification for using a ELI instead of using TL label context to indicate the presence of EL label,

If you mean, everyone advertise two LDP labels, one for EL, one without, that was a non-starter ... that doubles state in the core, and worse when you factor in LFA.

If you mean something else, you'll have to explain.

similar to what we do for PW FAT.

This I don't understand.

I tracked down this old conv on the WG mailing list with your response.

-----------------------------------------------------------------------------------------------------------------------------------------------
On Jul 27, 2010, at 07:24 , Stewart Bryant wrote:
> John
>
> Why do you prefer to use an ELI as opposed to using a new set of FECs with the property that they are followed by an EL?

The ELI is a catch-all, in case there is any potential confusion that the EL may be interpreted as an app label.  Most app labels (PWs (via T-LDP or BGP), VPN labels, etc.) can easily be followed by an EL, as Shane's slides showed.  No need for new FECs.

The sticky case is "naked" IP over LDP tunnels.  Do you have a suggestion that doesn't need an ELI in that case?

Thanks,
Kireeti.
-----------------------------------------------------------------------------------------------------------------------------------------------

Agreed, LSPs can carry naked IP or MPLS traffic. One issue I see with LDP tunnels is that IP traffic can be pushed into a LDP lsp from any hop along the LSP. To make this work for EL without ELI we would have to store the EL signaling state at all hops along the LDP lsp. Is that the issue? If we did have the state, then when any hop pushes IP into a LDP Lsp, it would also know if it needs to add a EL label and this issue would go away, right? I would really appreciate any pointers.

Actually, either way, the control plane carries the EL-capability state, but that's just an additional bit.  With separate FECs, there's data plane state as well, and that's a lot worse.

HTH,
Kireeti

Thanks !
--Rajeev

> Stewart

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Apr 2012 14:55:14 -0700

Hi Rajeev,

On Apr 13, 2012, at 14:04, "Rajeev Manur" <[email-masked]> wrote:

> [Rajeev] Why do we need 2 LSPs. An LSP either has EL or it does'nt?

Not true today. 

> If we have an LSP with EL, then all LSRs that push naked IP into the LSP would have to add entropy label.

And if a particular ingress is not capable of inserting an EL?

Kireeti

---

From: John E Drake <[email-masked]>
Date: Fri, 13 Apr 2012 15:06:50 -0700

Snipped...

Sent from my iPhone
> And if a particular ingress is not capable of inserting an EL?

[JD]  Then it should be disciplined? 

> 
> Kireeti
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: "Rajeev Manur" <[email-masked]>
Date: Fri, 13 Apr 2012 23:01:52 +0000

Hi Kireeti,

Please see inline...

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]] 
Sent: Friday, April 13, 2012 2:55 PM
To: Rajeev Manur
Cc: [email-masked]; [email-masked]
Subject: Re: MPLS entropy : clarification on the need for ELI

Hi Rajeev,

Not true today.

<<Rajeev>> Not sure what you mean. Do you mean existing implementations of EL for such LSPs?

<<Rajeev>> Ok, if the LSR is not capable of inserting an EL, then there is a problem. We either have to use 'ELI' as proposed in this draft and make the packet self identifying, Or use separate TL labels for EL-aware and non-EL-aware Lsps. Later, obviously has its own issues.
  Q1 : Is this only reason for adding ELI?
  Q2 : If yes, have we looked at other possible ways of working around the problem. For example if such LSRs are capable of inserting at least 2 labels, then we should be able to program such boxes to add second dummy label (EL="fixed value").

Kireeti

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 13 Apr 2012 17:21:33 -0700

> Q2 : If yes, have we looked at other possible ways of working around the problem. For example if such LSRs are capable of inserting at least 2 labels, then we should be able to program such boxes t…

The problem is only partly "can it?". Even if it could, it doesn't at present. So, if you upgrade one LER to do ELs, no one else can talk to it until they too are upgraded. All-or-nothing upgrade policies are not the best way to make friends with network operators :-)

Kireeti

---

From: "Rajeev Manur" <[email-masked]>
Date: Sat, 14 Apr 2012 01:02:52 +0000

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]] 
Sent: Friday, April 13, 2012 5:22 PM
To: Rajeev Manur
Cc: [email-masked]; [email-masked]
Subject: Re: MPLS entropy : clarification on the need for ELI

[Rajeev] Agreed. Thanks for the clarification. It would be gr8 if we can capture this reasoning of "incremental deployment" as the key reason for using ELI label approach for LSPs.

Kireeti

---

From: Kireeti Kompella <[email-masked]>
Date: Sun, 15 Apr 2012 21:50:25 -0700

> [Rajeev] Agreed. Thanks for the clarification. It would be gr8 if we can capture this reasoning of "incremental deployment" as the key reason for using ELI label approach for LSPs.

It's not the key reason, but I'll capture it.

Kireeti