Subject: [mpls] wg last call and IPR poll on draft-ietf-mpls-ldp-ipv6-07

From: Loa Andersson <[email-masked]>
Date: Mon, 11 Jun 2012 08:20:35 +0200

Working Group,

this is to start a one week working group last call on
draft-ietf-mpls-ldp-ipv6-07.

Bckground - the draft was passed working group last call in August
last year, and it should from that perspective be OK to request
publication.

However;

- it is a bit too long ago
- after the wg last call a discussion, that did not really cause any
   changes to the draft, that generated great interest.
   The background was that for the 32-bit LSR-id an routeable IPv4
   address has often been used in IPv4 networks. Thre were interest of
   using an routeabel  IPv6 address for LSR-id in IPv6 networks.
   It was decided not to go down this path, since it would have huge
   impact on the LDP protocol itself and all the HW implementations.

This working group last call is limited to the changes between version
-06 and -07.

Also since this draft was through wg last call before we explicitly
started to poll for IPRs on our draft, we need to do that now.

Listed authors need to make an explicit statement to the working group
and working group chairs that all the IPRs they now of has been
disclosed or that they are not aware of any IPRs

Other working group members that har aware of IPRs should state so on
the working group mailing list.

This working group last call and IPR poll ends June 18th, 2012.

/Loa
for the mpls wg co-chairs

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 11 Jun 2012 02:27:14 -0400

Yes/support - stable and well written doc.

Regards,
Jeff

On Jun 10, 2012, at 23:20, "Loa Andersson" <[email-masked]> wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 11 Jun 2012 09:13:28 -0700

Hi Loa,

There are no IPR that I know of directly related to this work.

Thanks,
Vishwas

>> On Sun, Jun 10, 2012 at 11:20 PM, Loa Andersson <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>    Working Group,
>>
>>    Loa Andersson                         email:
>>    [email-masked] <mailto:[email-masked]>
>>    Sr Strategy and Standards Manager [email-masked] <mailto:[email-masked]>
>>
>>    <tel:%2B46%2010%20717%2052%2013>
>>    +46 767 72 92 13 <tel:%2B46%20767%2072%2092%2013>
>>    _________________________________________________
>>    mpls mailing list
>>    [email-masked] <mailto:[email-masked]>
>>    https://www.ietf.org/mailman/__listinfo/mpls
>>    <https://www.ietf.org/mailman/listinfo/mpls>
>>
>>
>>
> --
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 12 Jun 2012 09:11:16 +0900

I've looked at the changes from -06 to -07 and they look fine for publication.

BTW to the WG - it's really easy to review the changes by using this URL:

https://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-mpls-ldp-ipv6-07.txt

Cheers,
Andy

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 12 Jun 2012 05:11:12 +0000

Thank you, Loa. 

I am not aware of any IPR relevant to this I-D

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

---

From: "Aissaoui, Mustapha (Mustapha)" <[email-masked]>
Date: Tue, 12 Jun 2012 09:16:34 -0500

Hi Loa,
I raised a couple of major issues with this draft and proposed a solution to address them. I have discussed these at length with the authors on this mailing list but it does not seem we are making any progress to address it. 

I have summarized the issues below as well as a possible solution. Since thes issues cause backward compatibility with RFC 5036, I do not believe we can publish the draft in its current version.

Regards,
Mustapha.
=====================================================================================
Issues in draft-ietf-mpls-ldp-ipv6:

1. Current version of LDP IPv6 draft mandates maintaining a Hello adjacency for each of IPv4 and IPv6 over a dual-stack interface between two LSRs but will bootstrap a single LDP session (IPv4 or IPv6). RFC 5036 allows bootstrapping of an IPv6 session by an IPv6 Hello adjacency OR bootstrapping of an IPv4 LDP session by an IPv4 Hello Adjacency over the same IP interface. 
The proposal in this draft doubles number of Hello adjacencies and breaks backward compatibility with RFC 5036 for no gain. 

2. Current version of LDP IPv6 draft ties the FEC types resolved over a given interface to the type of adjacency. This violates RFC 5036 which allows any FEC type (unicast IPv4, unicast IPv6, mLDP p2mp FEC, PW FEC) over an interface regardless of the Hello adjacency is IPv4 or IPv6. A Hello adjacency over a link is an assertion that a link is associated with the LDP session with the peer, meaning FECs exchanged over the session can be programmed over those links, and nothing else. The control of which FEC type is resolved over which interface is controlled via LDP capability and/or LDP FEC policies.

3. There is no need to maintain two link Hello adjacencies over the same interface for resolving an IPv4 or an IPv6 FEC. We just published a draft to specify LDP adjacency capability negotiation. This is the correct way to control which FECs can be resolved to a link such that we can keep IPv6 and IPv4 FEC resolution compatible with RFC 5036 in the case of dual-stack interfaces:
http://www.ietf.org/id/draft-pdutta-mpls-ldp-adj-capability-00.txt

=====================================================================================

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Monday, June 11, 2012 2:21 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] wg last call and IPR poll on draft-ietf-mpls-ldp-ipv6-07

Working Group,

this is to start a one week working group last call on draft-ietf-mpls-ldp-ipv6-07.

Bckground - the draft was passed working group last call in August last year, and it should from that perspective be OK to request publication.

However;

Also since this draft was through wg last call before we explicitly started to poll for IPRs on our draft, we need to do that now.

Listed authors need to make an explicit statement to the working group and working group chairs that all the IPRs they now of has been disclosed or that they are not aware of any IPRs

Other working group members that har aware of IPRs should state so on the working group mailing list.

/Loa

-- 

                                              +46 767 72 92 13 _______________________________________________

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Sat, 16 Jun 2012 20:52:08 -0500

Loa,

I am not aware of any IPR on this.

Cheers,
Rajiv 

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Loa Andersson
draft-ietf-mpls-ldp-
> ipv6-07.
last year,
> and it should from that perspective be OK to request publication.
> 
> However;
> 
started to
> poll for IPRs on our draft, we need to do that now.
> 
and
> working group chairs that all the IPRs they now of has been disclosed
or that
> they are not aware of any IPRs
> 
the
> working group mailing list.
> 
[email-masked]

---

From: Loa Andersson <[email-masked]>
Date: Wed, 20 Jun 2012 18:28:39 +0200

Working Group,

this working last call has been closed.

We have had comments, could the authors plese work with the commenter
to resolve the comments and if necessary republish a new version of the
draft!

/Loa

--