Subject: [mpls] Comments to draft-vkst-mpls-tp-oam-id-mib-03

From: Muly Ilan <[email-masked]>
Date: Tue, 12 Jun 2012 13:36:12 +0000

Hi,

It seems that the case of associated bidirectional LSPs is not fully covered by the current draft.
According to the MPLS-TP OAM framework, in this case two independent unidirectional MEs should be defined to independently monitor each direction.

1.       It would be helpful if there was an indication in the mplsOamIdMeTable whether the ME is uni or bi directional.

2.       For associated bidirectional LSPs there are two separate entries in the mplsTunnelTable. Thus, the mplsOamIdMeServicePointer of each of the unidirectional MEs shall point to its relevant entry i.e. to the forward or the reverse tunnel entry. This is another reason to keep the pointer in the ME table and not in the MEG table. The description of mplsOamIdMeServicePointer should be expanded.

3.       A proactive OAM session would utilize both MEs (one ME for transmission of OAM packets and the other for reception). This can be indicated by having the same value of mplsOamIdMeProactiveOamSessIndex. Its worth noting it in the description of mplsOamIdMeProactiveOamSessIndex.

Regards,

Muly

---

From: Sam Aldrin <[email-masked]>
Date: Tue, 12 Jun 2012 20:38:57 -0700

Hi Muly,

Thanks for the email.
Please see inline for my comments.

-sam

> 1.       It would be helpful if there was an indication in the mplsOamIdMeTable whether the ME is uni or bi directional.
%sam - Sure thing. We should be able to add a new object to indicate that, in the next version.
> 2.       For associated bidirectional LSPs there are two separate entries in the mplsTunnelTable. Thus, the mplsOamIdMeServicePointer of each of the unidirectional MEs shall point to its relevant e…
%sam - We make/add appropriate changes to the description.
> 3.       A proactive OAM session would utilize both MEs (one ME for transmission of OAM packets and the other for reception). This can be indicated by having the same value of mplsOamIdMeProactiveO…
%sam - Will fix the description.
>  
> Regards,
>  
> Muly
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls